Audio Doesn't Work, Aspire One Netbook - URN 9.10

Asked by Sblood on 2009-12-09

Like the summary says, my audio doesn't work.
The device shows working properly, just nothing comes out. To save anyone from asking the obvious, it is not muted and the speakers work, also tried with headphones

I am running UNR 9.10 (am considering downgrading to 9.04 but I can't find a mirror to)

This is an Aspire One D-150

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu unr-meta Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2009-12-11
Last query:
2009-12-11
Last reply:
2009-12-10

Can you look on the bottom to give the model. This will be very useful. Thanks

This may benefit you also:
https://help.ubuntu.com/community/AspireOne

Readin helps uh, d'oh

D150 (1G, 160Gb HDD)

OOTB:

    * Ethernet 10/100
    * Camera
    * Keyboard and functional keys
    *

      WiFi (the switcher was not tested because it's broken on my netbook)
    * Bluetooth and BT button above the keyboard
    * Suspend/hibernate (but not on lid close, see below)
    * Sound and headphones out
    * Card reader

Known issue with know sound out of the box. Do you have the latst BIOS? You may need to compile ALSA based on this guide:

http://www.summet.com/blog/2009/07/18/acer-aspire-one-d150-ubuntu-9-04-jaunty-linux/

Sblood (sblood86) said : #3

will try that when I get home. Thanks alot. - though it seams you found it, I'll provide the complete model incase you have any more thoughts:

Aspire One D150-1358
this is the model without bluetooth, just one less thing to make work :-)

I'm going to try that fix when I have the chance, I do want to point out however;
the sound worked properly when running jaunty jackalope, I never did test the build in mic which is what that link is mainy referring.

Will post after I have tried that to let you all know if it worked

Thanks again

Can you give the output of:

sudo lshw -C network

Thanks

Sblood (sblood86) said : #5

sudo lshw -C network

  *-network
       description: Wireless interface
       product: AR5001 Wireless Network Adapter
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: wmaster0
       version: 01
       serial: 00:24:2b:52:99:04
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list logical ethernet physical wireless
       configuration: broadcast=yes driver=ath5k latency=0 multicast=yes wireless=IEEE 802.11bg
       resources: irq:16 memory:55100000-5510ffff
  *-network
       description: Ethernet interface
       product: Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Controller
       vendor: Attansic Technology Corp.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: b0
       serial: 00:23:5a:4b:e2:cc
       size: 100MB/s
       capacity: 100MB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=ATL1E driverversion=1.0.0.7-NAPI duplex=full firmware=L1e ip=72.177.107.222 latency=0 link=yes multicast=yes port=twisted pair speed=100MB/s
       resources: irq:28 memory:53000000-5303ffff ioport:1000(size=128)

right theres that, gonna check on that ALSA bit now, just got home

sudo apt-get install linux-backports-modules-wireless-karmic-generic linux-backports-modules-`uname -r`

Then reboot, should be ok.

Sblood (sblood86) said : #7

Thanks actionparsnip, that solved my question.