installing UNR on any computer

Asked by starfleet70 on 2009-05-03

Can UNR be installed on any computer or is it specific only to netbooks ? I would like to try dualbooting it on my wife's Dell Inpiron B120 laptop.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu unr-meta Edit question
Assignee:
No assignee Edit question
Solved by:
FD
Solved:
2009-05-03
Last query:
2009-05-03
Last reply:
2009-05-03
Tom (tom6) said : #1

Usually with linux it's best to try out a "LiveCd session" to see how it looks and feels. Simply put the Cd in the drive and reboot. With *buntu choose the option "Try Ubuntu without changes" and this should get you to a working desktop that we call a "LiveCd session". If you didn't get that menu option then this guide might help
https://help.ubuntu.com/community/BootFromCD

It's worth trying the web-browser and see if you can get some multi-media stuff running on this type of demo. Don't expect much from the multi-media. Installing stuff and any updates and settings get completely lost when you reboot the machine so don't spend long trying to tweak it all. Even documents and stuff are usually lost unless you take care to save stuff to hard-drive rather than just the "Documents" etc folders. LiveCd sessions of distros do run slower than a full proper install but they are still a good way to demo it and see what potential problems you might need to be ready to solve when you install it.

Hope this helps
Good luck and regards from
Tom :)

PS https://help.ubuntu.com/community/Installation#Installation%20without%20a%20CD
It's often called a "LiveCd session" even if it's from a Usb stick or something ;)

I have several live cd's but wanted to know if UNR will work on any computer before i go and order a cd. I haven't ordered one yet because i don't know if it will work.

thanks,
Scott

So is UNR only for netbooks?

Best FD (fdouw) said : #4

“Ubuntu Netbook Remix (UNR) is a ‘remix’ of the standard Ubuntu Desktop release to enable it to work better on devices with small screens, such as netbooks (sub-notebooks), although these packages will work on any 8.04 (Hardy) or 8.10 (Intrepid) installation.” – https://wiki.ubuntu.com/UNR

So it should work anywhere where Ubuntu works – but why use the Netbook Remix on a computer that is not actually a netbook?

By the way, you can download the UNR image, so trying it should not be expensive.

Tony Pursell (ajpursell) said : #5

UNR is only available as an image (.img) file to copy to a USB stick which is 1GB or bigger. This is because the image is too big to write to a CD. It is nearly 950MB. CDs are only 700MB. Perhaps it can be written to a DVD

Does anyone know how it can be written to a DVD?

Tony

Thanks Floris Douw, that solved my question.

Thanks to all of you, you've been a great help. :)

Scott

Tom (tom6) said : #8

@ Tony
Slowly

I didn't realise the filesize was so large! It would be well worth "doing the right thing" and setting it up properly on a usb stick but i assume there is a problem with downloading the image otherwise this question probably wouldn't have been asked. Not all of us are on unlimited broadband so downloading can be a problem in a lot of cases. I would order the UNR from ShipIt asap because it does take quite a while to arrive and during that time i would look up whether it will be useful for this machine. If it turns out that it isn't then it'd make a good present for someone else or might be useful later ;)

Good luck and regards from
Tom :)

Uwe Geuder (ubuntulp-ugeuder) said : #9

From the description UNR is specific for Intel Atom processors. (I don't know the details, I've just read it). Normally all PCs containing an Intel processor have the "Intel inside" sticker. If it says something else than Atom, I'd guess UNR is not an option. If it has no sticker, it probably not an Intel processor, so again UNR is probably not an option.

Tony Pursell (ajpursell) said : #10

I know it says you need an Atom processor, but it runs OK on my EEEPC 701 4G with a Celeron processor (which has a prominent "Intel inside" sticker).

I am going to try and find out how to create a bootable iso that I can write to a DVD. There was (probably still is) a distro called eeebuntu which came as an iso. In fact, I have it downloaded on this machine and wrote it to DVD for my son. He has an external DVD drive. So I want to try and create the DVD of UNR for him.

Tony

Uwe Geuder (ubuntulp-ugeuder) said : #11

> I know it says you need an Atom processor, but it runs OK on my EEEPC 701 4G with a Celeron processor

Interesting to know.

> I am going to try and find out how to create a bootable iso that I can write to a DVD.

Good. I've asked this in https://answers.launchpad.net/ubuntu/+question/69648 but have not received a clear answer, whether/how it can be done. Please post your solution once you have it. Thanks.

Creating a bootable ISO should not be that difficult if you extract
the files and then use isolinux to load the kernel and init. Assuming
syslinux is already in use, modifying the config file for syslinux
should be cake.

I will try it out once it finishes downloading and post results.

I was correct. Creating an ISO from the IMG is a very simple process.
I tested in VirtualBox (BTW, also tried to see if I could boot from
the .img in there without modification, but could not, I guess they
didn't lie it does need to be usb). I did not actually burn this to a
DVD because I am on a system with no optical drive, so YMMV. Maybe
there's an easier or more correct way to do it, but it worked. :)

First, I did it all on the desktop. You can do it anywhere you want.

- Download the UNR image.

- Create a directory to be your ISO root:

steve@ubuntu:~/Desktop$ mkdir unr

- Create a directory to mount the ubuntu image:

steve@ubuntu:~/Desktop$ mkdir realunr

- Mount the netbook image:

steve@ubuntu:~/Desktop$ sudo mount -o loop -t vfat
ubuntu-9.04-netbook-remix-i386.img realunr/

- Copy the files from realunr/ to unr/ (make sure the .disk directory
copies, it will apparently not load without it)

I did this through nautilus. Press Ctrl H to show hidden files and
copy them over too.

Now you need to rename a few things (that's right, only rename).

The syslinux folder needs to be isolinux, now isolinux/syslinux.cfg
needs to be isolinux/isolinux.cfg. Isolinux is already on there, which
makes me think there is or was a plan to release iso images
officially.

The final step is to build the ISO file:

steve@ubuntu:~/Desktop$ mkisofs -o ubuntu-9.04-netbook-remix-i386.iso
-r -J -l -V "Ubuntu-Netbook-Remix 9.04 i386" -b isolinux/isolinux.bin
-c isolinux/boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table
unr/

At this point the generated ISO image should be functional. Like I
said, I did not burn it and only used it in a Virtual Machine, but is
was enough for me to be a believer. Please let me know if for some
reason it doesn't work for you. For some reason one file got corrupted
(it's name was shortened). I'm not sure how to avoid this. It is a
German openoffice dictionary of some sort.

Screenshots: http://www.flickr.com/photos/stupendoussteve/tags/ubuntu/

Uwe Geuder (ubuntulp-ugeuder) said : #14

Thanks a lot Steven for your quick post. I don't have the netbook in question handy right now, but I hope I can test in a couple of days.

Tony Pursell (ajpursell) said : #15

That's fantastic! I was up to 2:00am last night and only got an iso that barely booted. Now I have an iso that I can burn to DVD and sent to my son.

Thanks for all your help.

Tony

PS You deserve the tag 'stupendoussteve'

Tom (tom6) said : #16

Err, there's always "Ship It", it takes a few weeks but is a great service and the Cd's look quite nice. No holographic logos and stuff but rather just nice and presentable :)
http://www.ubuntu.com/getubuntu/download

Good luck and regards from
Tom :)

Tom (tom6) said : #17

Oooops, i meant
https://shipit.ubuntu.com/
lol

Tony Pursell (ajpursell) said : #18

AFAIK Ship it do not do UNR DVDs :(

They only do standard Desktop and Server CDs

Tony

Tom (tom6) said : #19

UNR is new to this release so we don't really know what they would be prepared to do. Previously releases have only had Desktop & Server Editions and so that's all that ShipIt have been able to provide. This time i think there are 4 different standard editions. Ubuntu means "humanity to others" and could possibly be swayed to provide the product in the way consumers want.

Interesting.

The integrity check fails when booting a USB stick from an img that passes the md5sum because /pool/main/p/ppp/ppp_2.4.5~git20081126t100229-0ubuntu2_i386.deb is named ppp_45~.d for some reason. Same thing happens with the iso.

To get your self made ISO to pass the integrity check, make sure you rename the file in your unr folder before you make an ISO out of it. Same fix works for the usb boot.

Tony Pursell (ajpursell) said : #21

Not a problem for me. Neither USB stick or the DVD I have just made has a problem. But I did download the image some days ago. Perhaps it has been 'updated'.

Tony

Mark Ellse (markellse) said : #22

Lucid alpha 2, "Check disc for defects" doesn't seem to work on either of my test machines, despite it seeming to work OK in both.

Mark Ellse (markellse) said : #23

Sorry: symptons of "Check disc for defects" not working in Lucid alpha 2: some CD activity, then everything goes quiet with "Ubuntu" logo on screen, but nothing happening.

Tom (tom6) said : #24

Hi Mark :)

Please re-post as a new question
https://answers.launchpad.net/ubuntu/+source/unr-meta/+addquestion
Different forums work in different ways but at Launchpad we seldom look through older questions to help solve the issues there, especially if the thread is already marked as solved. You can always copy&paste this link into this thread so that people can see what has been tried already
https://answers.launchpad.net/ubuntu/+source/unr-meta/+question/69754

Note that Lucid is still in alpha development, it has not even reached the beta testing stage yet so there will be a number of things that don't quite work. Reporting problems, as you have tried to do, helps development enormously and is much appreciated.

Good luck, thanks and regards from
Tom :)