Blank Ubuntu background on boot, with no login available.

Asked by Bill Morris on 2010-09-11

http://paste.ubuntu.com/492304/

Ubuntu background screen and cursor appear on startup, but no login, icons or anything else clickable shows up. Anyone know how to fix this? It may or may not be a video driver bug . . . Running ubuntu 10.04 Netbook remix on an HP Mini 110c, Installed fine and worked like a charm for about a month. The activities preceeding the malfunction were: 1.) I was configuring the required libraries for an installation of MapServer (libjpeg, libpng, GD, etc.), 2.) I opened GNU emacs to edit a script, and it locked the screen, 3.) After closing emacs, the screen was still blocked, and nothing was clickable, 4.) Not knowing any non-gui ways to force a shutdown, I hard-booted the netbook, 5.) On reboot, the BIOS loaded, the "Ubuntu Loading" progress bar came up, the marimba sounded and the Ubuntu bubbles background screen came up with a moveable cursor on it, 6.) No login was presented and no interface was available. This has happened through a half-dozen reboots. I've tried a few things via console login (https://wiki.ubuntu.com/X/Troubleshooting/BlankScreen#Workaround A: VESA Driver, http://ubuntuforums.org/showthread.php?t=121819), but the suggested prompts don't appear. I'm sure this is a basic problem, and I seem to be missing something fundamental (I'm new to Linux; many apologies). Any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu unr-meta Edit question
Assignee:
No assignee Edit question
Solved by:
Bill Morris
Solved:
2010-09-27
Last query:
2010-09-27
Last reply:
2010-09-19

If you press ALT+F2 do you get teh run dialogue?
If you log in as another user, is it ok?

Bill Morris (vtcraghead) said : #2

Alt+F2 doesn't yield anything, and I haven't configured any other users. But I'd still only be able to login in the console.

On another diagnostic note, trying to run firefox from the console produces "Error: no display specified"

Please press ctrl+alt+f2 and made login with your user and password then type:

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get --reinstall install ubuntu-desktop

sudo reboot

Bill Morris (vtcraghead) said : #4

The packages failed to download; I wonder if my network configuration is blown as well. Is there a way to force a network connection from the console?

Thank you for your help on this, in any case.

Bill Morris (vtcraghead) said : #5

Continuing the diagnostics, I reinstalled ubuntu from scratch and the netbook went back to functioning correctly. However, I then rebuilt the Mapserver associated libraries, and immediately after rebooted. The same problem (Blank bubble screen, no login) occurred again!

I believe this means that configuring, building and installing either the proj.4 (http://trac.osgeo.org/proj/) or the shapelib (http://shapelib.maptools.org/) libraries is screwing with GNOME. Is this something I should take up with the administrators of those libraries or is there an obvious reconfiguration I can perform?

i use every days mapserver with qgis and other... why you compile it... install from packages

Please first enable the universe repository:

Open System → Administration → Software sources → [ Tab Ubuntu software ]
enable "Community Maintained open source software (universe)"
Close and confirm the repository reload.

Here some repositories details: https://help.ubuntu.com/community/Repositories/Ubuntu

Then open a Terminal from the menu Applications → Accessories → Terminal and type:

sudo aptitude update
sudo apt-get dist-upgrade
sudo aptitude install cgi-mapserver mapserver-bin

give your user password when requested, you don't see nothing when you type it, then press enter.

Hope this helps

Sorry i'm not sure but for Ubuntu network remix the path to enable the universe repository is different from:
System → Administration → Software sources → [ Tab Ubuntu software ]
i cannot verify i don't use ubuntu network remix

Bill Morris (vtcraghead) said : #8

After several reinstalls of Ubuntu all is working again. I'll abandon the mapserver build completely and try installation from the packages you recommended. Thank you again for your help.