installation error failed

Asked by Robert Haver on 2010-06-06

I loaded 10.4 netbook on my gateway netbook...over the last couple of days I have been able to install new software...I've now been getting the following message:

**************************************************

Previous installation hasn't been completed

The installation could have failed because of an error in the corresponding software package or it was cancelled in an unfriendly way. You have to repair this before you can install or remove any further software.

***************************************************

I'm new to ubuntu and don't see a place that addresses this...please help...thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu unr-meta Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2010-06-06
Last query:
2010-06-06
Last reply:
2010-06-06

Can you give the output of:

sudo apt-get update; sudo apt-get upgrade; sudo apt-get -f install

Thanks

Robert Haver (robhaver) said : #2

This is the output...

rhaver@rhaver-laptop:~$
rhaver@rhaver-laptop:~$ sudo apt-get update; sudo apt-get upgrade; sudo apt-get -f install
[sudo] password for rhaver:
Sorry, try again.
[sudo] password for rhaver:
Get:1 http://dl.google.com stable Release.gpg [189B]
Ign http://dl.google.com/linux/deb/ stable/main Translation-en_US
Get:2 http://dl.google.com stable Release [2,544B]
Get:3 http://security.ubuntu.com lucid-security Release.gpg [189B]
Ign http://security.ubuntu.com/ubuntu/ lucid-security/main Translation-en_US
Hit http://archive.canonical.com lucid Release.gpg
Ign http://archive.canonical.com/ubuntu/ lucid/partner Translation-en_US
Hit http://us.archive.ubuntu.com lucid Release.gpg
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/main Translation-en_US
Get:4 http://dl.google.com stable/main Packages [1,052B]
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/restricted Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/universe Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-en_US
Get:5 http://us.archive.ubuntu.com lucid-updates Release.gpg [189B]
Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/universe Translation-en_US
Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-en_US
Hit http://archive.canonical.com lucid Release
Ign http://security.ubuntu.com/ubuntu/ lucid-security/restricted Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/universe Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-en_US
Get:6 http://security.ubuntu.com lucid-security Release [38.5kB]
Hit http://us.archive.ubuntu.com lucid Release
Get:7 http://us.archive.ubuntu.com lucid-updates Release [38.5kB]
Hit http://archive.canonical.com lucid/partner Packages
Get:8 http://security.ubuntu.com lucid-security/main Packages [23.6kB]
Hit http://us.archive.ubuntu.com lucid/main Packages
Hit http://us.archive.ubuntu.com lucid/restricted Packages
Hit http://us.archive.ubuntu.com lucid/main Sources
Hit http://us.archive.ubuntu.com lucid/restricted Sources
Hit http://us.archive.ubuntu.com lucid/universe Packages
Hit http://us.archive.ubuntu.com lucid/universe Sources
Hit http://us.archive.ubuntu.com lucid/multiverse Packages
Hit http://us.archive.ubuntu.com lucid/multiverse Sources
Get:9 http://us.archive.ubuntu.com lucid-updates/main Packages [180kB]
Get:10 http://security.ubuntu.com lucid-security/restricted Packages [14B]
Get:11 http://security.ubuntu.com lucid-security/main Sources [8,520B]
Get:12 http://security.ubuntu.com lucid-security/restricted Sources [14B]
Get:13 http://security.ubuntu.com lucid-security/universe Packages [5,236B]
Get:14 http://security.ubuntu.com lucid-security/universe Sources [1,297B]
Get:15 http://security.ubuntu.com lucid-security/multiverse Packages [14B]
Get:16 http://security.ubuntu.com lucid-security/multiverse Sources [14B]
Get:17 http://us.archive.ubuntu.com lucid-updates/restricted Packages [2,102B]
Get:18 http://us.archive.ubuntu.com lucid-updates/main Sources [70.8kB]
Get:19 http://us.archive.ubuntu.com lucid-updates/restricted Sources [737B]
Get:20 http://us.archive.ubuntu.com lucid-updates/universe Packages [35.4kB]
Get:21 http://us.archive.ubuntu.com lucid-updates/universe Sources [9,566B]
Get:22 http://us.archive.ubuntu.com lucid-updates/multiverse Packages [632B]
Get:23 http://us.archive.ubuntu.com lucid-updates/multiverse Sources [14B]
Fetched 419kB in 1s (260kB/s)
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
rhaver@rhaver-laptop:~$ ^C
rhaver@rhaver-laptop:~$ sudo dpkg --configure -a
dpkg: dependency problems prevent configuration of language-pack-en:
 language-pack-en depends on language-pack-en-base (>= 1:10.04+20100422); however:
  Package language-pack-en-base is not installed.
dpkg: error processing language-pack-en (--configure):
 dependency problems - leaving unconfigured
Processing triggers for software-center ...
Processing triggers for python-central ...
Errors were encountered while processing:
 language-pack-en
rhaver@rhaver-laptop:~$

Robert Haver (robhaver) said : #3

Just posted response

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
actionparsnip
Sent: Sunday, June 06, 2010 10:59 AM
To: <email address hidden>
Subject: Re: [Question #113661]: installation error failed

Your question #113661 on Ubuntu changed:
https://answers.launchpad.net/ubuntu/+question/113661

    Status: Open => Needs information

actionparsnip requested for more information:
Can you give the output of:

sudo apt-get update; sudo apt-get upgrade; sudo apt-get -f install

Thanks

--
To answer this request for more information, you can either reply to this
email or enter your reply at the following page:
https://answers.launchpad.net/ubuntu/+question/113661

You received this question notification because you are a direct subscriber
of the question.

Best Sam_ (and-sam) said : #4

> Package language-pack-en-base is not installed

sudo apt-get install language-pack-en-base

Robert Haver (robhaver) said : #5

Thanks Sam, that solved my question.

The gui is nice but essentially useless if things go awry. If you use terminal then you will see all the USEFUL output which dumb gui apps hide away from you.

If you get package issues again, use the same commands we gave and you can see what is going on as well as what is causing the issue then take appropriate steps. The command line way says exactly what is happening rather than "oops, something done broken durrr"

I stopped using software-centre/synaptic purely for this reason.

Glad you got the gold champ
=D

Sam_ (and-sam) said : #7

> The gui is nice but essentially useless if things go awry

+1
GUI probably means guide_user_invisible or something like that ;-)

Although I've to admit, never ran into issues with Synaptic, but never used Software Center.
Still, CLI usage is fun and taught me a lot about my system, I just love it.

Robert Haver (robhaver) said : #8

Thank you greatly...i did figure it out too...all is working fine...I think
when I did an update a few days ago, it got interupted and did not
complete...thanks again...Bob

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Sam
Sent: Sunday, June 06, 2010 12:33 PM
To: <email address hidden>
Subject: RE: [Question #113661]: installation error failed

Your question #113661 on Ubuntu changed:
https://answers.launchpad.net/ubuntu/+question/113661

    Status: Open => Answered

Sam proposed the following answer:
> Package language-pack-en-base is not installed

sudo apt-get install language-pack-en-base

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+question/113661/+confirm?answer_id=3

If you still need help, you can reply to this email or go to the following
page to enter your feedback:
https://answers.launchpad.net/ubuntu/+question/113661

You received this question notification because you are a direct subscriber
of the question.

Robert Haver (robhaver) said : #9

Action...thank you too...i'm new so it is a learning experience...you and
sam have started me...it is great to know that such great resources and
people such as yourself are out there to help...thanks again...Bob

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
actionparsnip
Sent: Sunday, June 06, 2010 2:29 PM
To: <email address hidden>
Subject: RE: [Question #113661]: installation error failed

Your question #113661 on Ubuntu changed:
https://answers.launchpad.net/ubuntu/+question/113661

actionparsnip posted a new comment:
The gui is nice but essentially useless if things go awry. If you use
terminal then you will see all the USEFUL output which dumb gui apps hide
away from you.

If you get package issues again, use the same commands we gave and you can
see what is going on as well as what is causing the issue then take
appropriate steps. The command line way says exactly what is happening
rather than "oops, something done broken durrr"

I stopped using software-centre/synaptic purely for this reason.

Glad you got the gold champ
=D

--
You received this question notification because you are a direct subscriber
of the question.