Ubuntu Netbook Edition 10.04 touchpad/mouse issues on ACER ASPIRE ONE

Asked by Mohammed Ali Osman on 2010-05-03

I just downloaded Ubuntu Netbook Remix/Edition 10.04 and burned it to my flash drive. I booted from the USB drive to try it out. I love the interface and how everything looks but I had 2 major issues that prevented me from using my computer:

1. Whenever I even TOUCH the touchpad, I see the cursor jumping around all over the screen and weird white boxes appearing and disappearing. Not to mention it keeps clicking on whatever it wants to click on. So I can't use my touchpad now.

2. I put in 2 different USD mice (?) and the cursor moves around normally, but both right click and left click do nothing.

Overall, I couldn't even interact with the interface properly. I barely managed to restart the computer since the touchpad accidentally opened the power options menu.

I have an ACER ASPIRE ONE 532H with an Intel Atom N450.

Any help would be greatly appreciated since Ubuntu is kinda growing on me now.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu unr-meta Edit question
Assignee:
No assignee Edit question
Last query:
2010-05-04
Last reply:
2010-06-01

Here is the workaround I found in a few short websearches:
http://ubuntuforums.org/showthread.php?p=9209315

Mohammed Ali Osman (mhmdali) said : #2

Well actionparsnip the problem isn't in the vertical scrolling or multi gestures, I just can't use my touchpad at all. Not to mention both right clicks and left clicks DO NOT work either on touch pad or an external mouse.

One more thing, I'm a complete Linux newbie. I don't even know where to add the codes that were stated on that link. ;(

They may fix other things so are worth a shot.

run:

gksudo gedit /etc/modprobe.d/psmouse.conf

add this line to the file:

options psmouse proto=imps

Save the new file and close gedit. You can also run this in terminal to make it work now:

sudo modprobe -r psmouse; sleep 5; sudo modprobe psmouse proto=imp

Should be ok.

Mohammed Ali Osman (mhmdali) said : #4

Thanks for the prompt replies actionparsnip. Looks like the Linux community is pretty cool. One more thing though, like I said I'm a total newb so here's where I'm stumped.....

1. Where do I run the code? Do I have to run it while ubuntu is running or do I run it first on windows?

2. Does this change in code get saved to my flash drive? Cause I'm running it off my flash drive. I want to make sure that all the bugs are sorted out before I install UNR on my netbook. I've sort of developed a phobia to changing OS as soon as I get a new notebook ever since my last notebook died.

Thanks again :D

It will change the flashdrive as far as I know but the installed system will need changing once installed.

You press ALT+F2 and paste (or type)

gksudo gedit /etc/modprobe.d/psmouse.conf

Then add the code above, you will need to run a terminal (Applications -> Accessories -> Terminal

To run:

sudo modprobe -r psmouse; sleep 5; sudo modprobe psmouse proto=imp

Mohammed Ali Osman (mhmdali) said : #6

Oww.... why is linux so hard..... I don't usually have a hard time with new tech stuff, although programming more than simple things is beyond me, but this is ridiculous....... sniff.......

Thanks Action I'll give it a shot. So what you're saying is that I need to do this while I'm on Ubuntu and not on Windows right? (Stupid question I know but the fact that I can't seem to interact with Ubuntu or even open my browser is rather annoying)

Its not hard at all, you just have some hardware which isn't supported with the default options so you have to change the system a little. Back in 1990 Linux was a lot harder but its a lot easier.

Windows is no part of this so forget windows all together.

You could use a USB mouse while you get sorted then remove it when the touchpad gets working.

Mohammed Ali Osman (mhmdali) said : #8

Well I did use a USB mouse. I could move the cursor around normally but I can't click on anything. :(

That's why I'm concerned....

Ok I'll try to give this a shot tonight when I'm done with my studies :D

I've heard compiz can ruin clicks sometimes. Try pressing ALT+F2
type: metacity --replace
Then press ENTER

Clicking should be ok now

Nymphilis (nymphilis) said : #10

I had this problem, that is until i booted ubuntu up with my usb mouse plugged in, it would left and right click and function properly, then i decided to see if my pad worked...and it did! just multitouch functions did not...which is no biggie to me, just happy everything is working right

so in conclusion
boot up ubuntu with your usb mouse attached(or usb adapter for wireless mouse) ubuntu will detect them, and set the right field for both your usb mouse and touch pad.

hope this works for the rest of you!

Can you help with this problem?

Provide an answer of your own, or ask Mohammed Ali Osman for more information if necessary.

To post a message you must log in.