Unable to install unity8 on ubuntu 16.04 LTS

Asked by Battant on 2016-04-22

Hello,

Here is my configuration.

Ubuntu 16.04 64 bit LTS
Problem :

When I try to install unity8, I get this result.

Here is my terminal output

sudo apt-get install unity8
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 unity8 : Depends: qtdeclarative5-gsettings1.0 but it is not going to be installed
          Depends: ubuntu-system-settings but it is not going to be installed
          Recommends: unity-scope-click but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Could you help me please.

Best regards

Battant

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu unity8 Edit question
Assignee:
No assignee Edit question
Last query:
2016-04-23
Last reply:
2016-04-23
Manfred Hampl (m-hampl) said : #1

What is the output of the following diagnostic commands:

uname -a
lsb_release -crid
apt-get --simulate install qtdeclarative5-gsettings1.0 ubuntu-system-settings unity-scope-click

Battant (mparchet) said : #2

Hello,

Here is my terminal output :

uname -a
Linux mparchet-W240EU-W250EUQ-W270EUQ 4.4.0-18-generic #34-Ubuntu SMP Wed Apr 6 14:01:02 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 16.04 LTS
Release: 16.04
Codename: xenial

 apt-get --simulate install qtdeclarative5-gsettings1.0 ubuntu-system-settings unity-scope-click
NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 qtdeclarative5-gsettings1.0 : Depends: libgsettings-qt1 (= 0.1+16.04.20160111-0ubuntu1) but 0.1+16.04.20160329-0ubuntu1 is to be installed
 ubuntu-system-settings : Depends: dbus-property-service but it is not going to be installed
                          Depends: indicator-network (>= 0.5.0+13.10.20130918)
                          Depends: qml-module-qtmultimedia or
                                   qml-module-qtmultimedia-gles but it is not going to be installed
                          Depends: urfkill
 unity-scope-click : Depends: ubuntu-sdk-libs but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Could you help me please ?

Thanks for your support

Best regards

Battant

Manfred Hampl (m-hampl) said : #3

What is the output of the commands

apt-cache policy qtdeclarative5-gsettings1.0 libgsettings-qt1
apt-get --simulate install ubuntu-system-settings dbus-property-service qml-module-qtmultimedia

Battant (mparchet) said : #4

Hello,

Here is my terminal output :

apt-cache policy qtdeclarative5-gsettings1.0 libgsettings-qt1
qtdeclarative5-gsettings1.0:
  Installed: (none)
  Candidate: 0.1+16.04.20160111-0ubuntu1
  Version table:
     0.1+16.04.20160111-0ubuntu1 500
        500 http://archive.ubuntu.csg.uzh.ch/ubuntu xenial/universe amd64 Packages
libgsettings-qt1:
  Installed: 0.1+16.04.20160329-0ubuntu1
  Candidate: 0.1+16.04.20160329-0ubuntu1
  Version table:
 *** 0.1+16.04.20160329-0ubuntu1 100
        100 /var/lib/dpkg/status
     0.1+16.04.20160111-0ubuntu1 500
        500 http://archive.ubuntu.csg.uzh.ch/ubuntu xenial/main amd64 Packages

 apt-get --simulate install ubuntu-system-settings dbus-property-service qml-module-qtmultimedia
NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 dbus-property-service : Depends: libhybris-utils but it is not going to be installed
 qml-module-qtmultimedia : Depends: libqt5multimedia5-plugins but it is not going to be installed
 ubuntu-system-settings : Depends: indicator-network (>= 0.5.0+13.10.20130918)
                          Depends: qtdeclarative5-gsettings1.0 (>= 0.1+14.10.20140801.1) but it is not going to be installed
                          Depends: urfkill
E: Unable to correct problems, you have held broken packages.

Could you help me please ?

Thanks for your support

Best regards

Battant

Manfred Hampl (m-hampl) said : #5

The version numbers of qtdeclarative5-gsettings1.0 and libgsettings-qt1 must be identical, because they come from the same source.

There seems to be a problem with the repository server that you use.

If you look at https://launchpad.net/ubuntu/+mirror/archive.ubuntu.csg.uzh.ch-archive you see that there are some questions about the status of that repository server ("last update unknown").
I recommend that you try switching to another repository server in your vicinity (e.g. ETH), or the country server for your country, or the central server.

Can you help with this problem?

Provide an answer of your own, or ask Battant for more information if necessary.

To post a message you must log in.