Build failure due to dependency issues

Asked by Niklas Wenzel on 2015-02-28

I branched off the most recent version (r1638) of the Unity8 source code on my system running Ubuntu 14.10 and tried to build it by running "./build.sh --setup" and "./build.sh". However, that didn't work flawlessly.
There are some dependency issues with the unity8-build-dep package.

The package has been created.
Attention, the package has been created in the current directory,
not in ".." as indicated by the message above!
Vormals nicht ausgewähltes Paket unity8-build-deps wird gewählt.
(Lese Datenbank ... 716910 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von unity8-build-deps_1.0_amd64.deb ...
Entpacken von unity8-build-deps (1.0) ...
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... Fertig
Die folgenden Pakete werden ENTFERNT:
  unity8-build-deps
0 aktualisiert, 0 neu installiert, 1 zu entfernen und 0 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Nach dieser Operation werden 28,7 kB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n]

That's German but it tells me that it is going to remove the package again.

When trying to install the package manually, I am told that a lot of dependencies are missing:

nikwen@nikwen:~/Programmieren/Ubuntu/unity8/trunk$ sudo dpkg -i builddir/unity8-build-deps_1.0_amd64.deb
Vormals nicht ausgewähltes Paket unity8-build-deps wird gewählt.
(Lese Datenbank ... 716910 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../unity8-build-deps_1.0_amd64.deb ...
Entpacken von unity8-build-deps (1.0) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von unity8-build-deps:
 unity8-build-deps hängt ab von dbus-test-runner; aber:
  Paket dbus-test-runner ist nicht installiert.
 unity8-build-deps hängt ab von doxyqml; aber:
  Paket doxyqml ist nicht installiert.
 unity8-build-deps hängt ab von libconnectivity-qt1-dev; aber:
  Paket libconnectivity-qt1-dev ist nicht installiert.
 unity8-build-deps hängt ab von libgsettings-qt-dev; aber:
  Paket libgsettings-qt-dev ist nicht installiert.
 unity8-build-deps hängt ab von libhardware-dev; aber:
  Paket libhardware-dev ist nicht installiert.
 unity8-build-deps hängt ab von libpay2-dev; aber:
  Paket libpay2-dev ist nicht installiert.
 unity8-build-deps hängt ab von libpulse-dev; aber:
  Paket libpulse-dev ist nicht installiert.
 unity8-build-deps hängt ab von libqmenumodel-dev (>= 0.2.9); aber:
  Paket libqmenumodel-dev ist nicht installiert.
 unity8-build-deps hängt ab von libsystemsettings-dev; aber:
  Paket libsystemsettings-dev ist nicht installiert.
 u
dpkg: Fehler beim Bearbeiten des Paketes unity8-build-deps (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 unity8-build-deps

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu unity8 Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2015-03-06
Last query:
2015-03-06
Last reply:
2015-03-06
Niklas Wenzel (nikwen) said : #1

It got better after running "sudo apt-get build-dep unity8 && sudo apt-get install libsystemsettings-dev libconnectivity-qt1-dev".

Now I've reduced it to this:

nikwen@nikwen:~/Programmieren/Ubuntu/unity8/trunk$ sudo dpkg -i builddir/unity8-build-deps_1.0_amd64.deb
Vormals nicht ausgewähltes Paket unity8-build-deps wird gewählt.
(Lese Datenbank ... 717357 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../unity8-build-deps_1.0_amd64.deb ...
Entpacken von unity8-build-deps (1.0) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von unity8-build-deps:
 unity8-build-deps hängt ab von libqmenumodel-dev (>= 0.2.9); aber:
  Version von libqmenumodel-dev auf dem System ist 0.2.8+14.10.20141013-0ubuntu1.
 unity8-build-deps hängt ab von libunity-api-dev (>= 7.96); aber:
  Version von libunity-api-dev:amd64 auf dem System ist 7.92+14.10.20141003.1-0ubuntu1.
 unity8-build-deps hängt ab von qtdeclarative5-ubuntu-settings-components (>= 0.5); aber:
  Version von qtdeclarative5-ubuntu-settings-components:amd64 auf dem System ist 0.4+14.10.20140926-0ubuntu1.

dpkg: Fehler beim Bearbeiten des Paketes unity8-build-deps (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 unity8-build-deps

Manfred Hampl (m-hampl) said : #2

What Ubuntu release are you running

uname -a
lsb_release -crid

Where did you get this unity8-build-deps_1.0_amd64.deb file from? It seems not to be standard Ubuntu and it seems that it has requirements which your Ubuntu system does not meet.

e.g. libqmenumodel-dev 2.9 is available only in the Ubuntu development release 15.04
https://launchpad.net/ubuntu/+source/qmenumodel

Niklas Wenzel (nikwen) said : #3

Thank you very much for your reply. :)

As I said, I'm running Ubuntu 14.10. (See the command output below.)

The deb file is the one which is created (and theoretically installed) by Unity8's build script.
Does that mean I cannot build Unity8 on Utopic?

============================

nikwen@nikwen:~$ uname -a
Linux nikwen 3.16.0-31-generic #41-Ubuntu SMP Tue Feb 10 15:24:04 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
nikwen@nikwen:~$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 14.10
Release: 14.10
Codename: utopic
nikwen@nikwen:~$

Best Manfred Hampl (m-hampl) said : #4

Sorry for overlooking the version number in your original posting and requesting information again that is already there.

It seems to me that you are trying a version of the source that cannot be built/installed on an utopic release.

Compare the dependency on libqmenumodel-dev between http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/utopic/unity8/utopic-proposed/view/head:/debian/control and http://bazaar.launchpad.net/~unity-team/unity8/trunk/view/head:/debian/control

Another one is http://bazaar.launchpad.net/~unity-team/unity8/trunk/revision/1410/debian/control where you see the change of dependencies on libunity-api-dev from >= 7.92 to >= 7.93

My conclusion: it seems that you cannot build/install the most recent version of unity8 on your utopic system. because there are dependencies on packages that are available on vivid only.

I do not have any idea what you now best can do.

Niklas Wenzel (nikwen) said : #5

Thanks Manfred Hampl, that solved my question.

Niklas Wenzel (nikwen) said : #6

> Sorry for overlooking the version number in your original posting and requesting information again that is already there.

No problem. Instead, thank you for your answer.

> It seems to me that you are trying a version of the source that cannot be built/installed on an utopic release.
>
> Compare the dependency on libqmenumodel-dev between http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/utopic/unity8/utopic-proposed/view/head:/debian/control and http://bazaar.launchpad.net/~unity-team/unity8/trunk/view/head:/debian/control
>
> Another one is http://bazaar.launchpad.net/~unity-team/unity8/trunk/revision/1410/debian/control where you see the change of dependencies on libunity-api-dev from >= 7.92 to >= 7.93
>
> My conclusion: it seems that you cannot build/install the most recent version of unity8 on your utopic system. because there are dependencies on packages that are available on vivid only.
>
> I do not have any idea what you now best can do.

Yes, that's what I found as well. I hoped there would be a possibility to do this on Utopic but it looks like I have to set up a Vivid VM on hack on the DE now.
Thanks again. :)