cant boot on to Cairo dock 18.04

Asked by Henry Folorunsho on 2018-07-18

Just finshed installing ubuntu 18.04, and installed Cairo dock. On login i choose cairo dock at the setting. once i put my password to login, it restart back to login screen. i can only login to ubuntu

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu unity Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2018-07-18
Last query:
2018-07-18
Last reply:
2018-07-18

What is the output of:

lsb_release -a; uname -a; apt-cache policy cairo-dock

Thanks

You may want to run:

sudo apt-get install xcompmgr

As well. Make sure you have what cairo-dock needs
https://www.lifewire.com/setting-up-using-cairo-dock-4054034

Henry Folorunsho (henryxav) said : #3

 lsb_release -a; uname -a; apt-cache policy cairo-dock
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04 LTS
Release: 18.04
Codename: bionic
Linux polaris 4.15.0-23-generic #25-Ubuntu SMP Wed May 23 18:02:16 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
cairo-dock:
  Installed: 3.4.1-1.2
  Candidate: 3.4.1-1.2
  Version table:
 *** 3.4.1-1.2 500
        500 http://mirror.ng/ubuntu-archive bionic/universe amd64 Packages
        100 /var/lib/dpkg/status

Does installing xcompmgr help any?

Henry Folorunsho (henryxav) said : #5

Sorry did not

Can you launch Cairo Dock manually once logged in by pressing ALT+F2 and running it?

Henry Folorunsho (henryxav) said : #7

Yes I can

Then add the command as a startup item and you'll win

Henry Folorunsho (henryxav) said : #9

Sorry I can't run it through the command line. I thought you meant running it from dash

It's the same difference. You can report a bug as the option in LightDM is not working

Henry Folorunsho (henryxav) said : #11

Solved I revert to 16.04. thank you for all the assistance