Disable IPv6 (bug ?)

Asked by ubuntu-tester on 2015-04-24

Hello everybody,

On Ubuntu 14.04, I have a wireless connection issue and I think it may cause by IPv6 which is not completely disabled.
I don't have this issue on Ubuntu 12.04 with the same configuration.
In my explication there is no cable connected on eth0.

On Ubuntu 14.04 :
===============

I add this options in /etc/systcl.conf :
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 0

IPv6 is enabled on lo interface because this is a prerequisite for X11 Forwarding on ssh server.

I reboot and I check this options :
$ sysctl net.ipv6.conf.default.disable_ipv6
net.ipv6.conf.default.disable_ipv6 = 1
$ sysctl net.ipv6.conf.all.disable_ipv6
net.ipv6.conf.all.disable_ipv6 = 1
$ sysctl net.ipv6.conf.lo.disable_ipv6
net.ipv6.conf.lo.disable_ipv6 = 0

I check for each physical interface :
$ sysctl net.ipv6.conf.eth0.disable_ipv6
net.ipv6.conf.eth0.disable_ipv6 = 1
$ sysctl net.ipv6.conf.wlan0.disable_ipv6
net.ipv6.conf.wlan0.disable_ipv6 = 1

I check with "ip" command :
$ ip -6 addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever

So, IPv6 is disabled for eth0 and wlan0 interfaces however I have this kernel log :
$ grep -i "IPv6.*link becomes ready" /var/log/syslog
Apr 24 08:21:37 my-computer kernel: [ 59.572471] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

I have an issue on a specific wireless network => all my computers using Ubuntu 14.04 with the above configuration are regularly disconnected.
To solve this issue, on NetworkManager, for this connection I have to :
- Force IPv4 : Enable IPv4 settings > Require IPv4 addressing for this connection to complete
- Disable IPv6 : Enable IPv6 settings > Method : Ignore

On Ubuntu 12.04 :
==============

I have exactly the same configuration but I don't have this kernel log "IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready" in syslog and my specific wireless connection works perfectly without having to force IPv4 and disable IPv6 on NetworkManager.

Question :
========

On Ubuntu 14.04, I have disabled IPv6 on wlan0 interface, but I have this kernel log "IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready". It may be the cause of my wireless connection issue.
If you disable IPv6 on your wlan0 (or eth0) interface, do you have this kernel log too ?
Do you think that is a bug ?

Information :
==========
networkmanager 0.9.8.8-0ubuntu7
linux-image-3.13.0-49-generic 3.13.0-49.81

Thanks for your help :)

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu unity Edit question
Assignee:
No assignee Edit question
Last query:
2015-04-24
Last reply:
2015-11-10

add the boot option:

ipv6.disable=1

Should help

ubuntu-tester (ubuntu-tester1) said : #2

Thanks for your answer actionparsnip, I will test this boot option, it may help me to understand :)
However I would like to known if this kernel log is normal or not, if not I prefer open a bug report instead of applying a workaround. Moreover, I don't want to disable IPv6 on lo interface.

Prahlad Yeri (prahladyeri) said : #3

What I've done is to disable ipv6 at the iptables (firewall) level, so in the rare case that an external device decides to communicate using an IPv6 address on my ubuntu machine, it won't be able to do so. Just set a default policy using ip6tables (note the change in name) to deny all traffic like this:

sudo ip6tables -P INPUT DROP
sudo ip6tables -P OUTPUT DROP
sudo ip6tables -P FORWARD DROP

Make sure to make these settings permanent by installing (or re-configuring) the iptables-persistent package (Or alternatively, by any other method you may be using to make the iptables settings permanent)

Can you help with this problem?

Provide an answer of your own, or ask ubuntu-tester for more information if necessary.

To post a message you must log in.