lock screen not working

Asked by Jorge on 2014-10-13

The lock screen on Ubuntu 14.04.1 LTS is not working for some reason, .it wants to lock...however the screen just bounces...would appreciate any insight here...thanks... I believe the package for the lockscreen is gnome-screensaver

I expected the screen to lock.
Instead the screen just bounces and doesn't lock. this happened after i updated to the new version of ubuntu.

here is a video of it not locking: http://youtu.be/RCCepVCQ0Zo

Here is the auth.log for when I tried to lock the screen

Oct 12 22:58:15 jorge-MS-7788 compiz: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory

Oct 12 22:58:15 jorge-MS-7788 compiz: PAM adding faulty module: pam_kwallet.so

Oct 12 22:58:15 jorge-MS-7788 compiz: pam_succeed_if(lightdm:auth): requirement "user ingroup nopasswdlogin" was met by user "jorge"

kind regards

thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu unity Edit question
Assignee:
No assignee Edit question
Solved by:
Jorge
Solved:
2014-10-14
Last query:
2014-10-14
Last reply:
2014-10-14
Jorge (jvidaurre7) said : #1

Plegase answer

Are there any bugs reported? If not, please report one.

Thanks

Jorge (jvidaurre7) said : #3

I just linked the bug related to this question just a moment ago.

Jorge (jvidaurre7) said : #4

It seems that somehow my user got added to the nopasswordlogin group. Removing my user from this group would solve the problem so I solved this by going into the terminal and typing in the command line: sudo gedit /etc/group and deleting my user name from the nopasswdlogin group in the text file and then saving the file again. Now I can lock the screen and the system requests a password on the ubuntu login screen. The screen wouldn't lock before because there was no password with which to lock the screen. The system didn't request a password because the user was in the nopasswordlogin group. Thanks.

Kind Regards