no unity sidebar after upgrading from 12.04 to 12.10

Asked by Bill Horne on 2014-04-22

errors were encountered while processing linux-image-3.5.0-48-generic_3.5.0-48.72_i386.deb
using Acer Travelmate 2301XC (circa 2004) with 1 GB RAM

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu unity Edit question
Assignee:
No assignee Edit question
Solved by:
Bill Horne
Solved:
2014-04-29
Last query:
2014-04-29
Last reply:
2014-04-27
Bill Horne (bhorne) said : #2

Update:
Today I was able to login to the Unity 12.10 desktop as a Guest. However, the system is very slow & login still won't recognize my own administrator password.

I copied & pasted the error I got when Ubuntu Software Center tried to repair broken packages here http://pastebin.com/1qJ63YXa

Seems I've been trying to install a kernel that does not support a non-PAE CPU. My old Acer notebook has an Intel Celeron M320 processor 1.3GHz with 1.5 GB RAM; Graphics Driver VESA: Intel(r)852GM/852GME/852GM/852GME Graphics; Experience Standard
Disk 133.6 GB; OS type 32-bit.

I think I probably need to reinstall 12.04...

Bill Horne (bhorne) said : #3

After a reboot I saw a message in Terminal asking if I wanted to upgrade to 13.10. I thought, why not see what happens - can't get much worse than it is now! A couple of hours later, though, I got the following:

A fatal error occurred. Please report this as a bug and include the files
/var/log/dist-upgrade/main.log and /var/log/dist-upgrade/apt.log in your report.
The upgrade has aborted. Your original sources.list was saved in /etc/apt/sources.list.distUpgrade.
SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)

Here is the apt.log http://pastebin.com/7n9nXsUW

and the main.log http://pastebin.com/v4RnTmNR

and my original sources.list that was saved in /etc/apt/sources.list.distUpgrade is at http://pastebin.com/i6FjjEAe

Manfred Hampl (m-hampl) said : #4

The main questions now are:
Can you boot your system?
What version is it?
What kernel can you boot?
What is the status of your package management system?

If you are able to boot, please provide the output of

uname -a
lsb_relase -a
cat /etc/apt/sources.list
sudo dpkg --audit

Bill Horne (bhorne) said : #5

Thanks for writing, Manfred ;-)

Yes, I can boot the system to a Ubuntu 12.10 login screen which still won't recognize my password. Yesterday I could login as Guest, and although there was no Unity desktop, menu bars or Dash, I could TTY Terminal which does recognize my username and password. Today I can't login as Guest.

Now I am rebooting with the Shift key to take me via GNU Grub version 2.00-19ubuntu2.1 to Ubuntu, with Linux 3.11.0-15-generic (recovery mode). Then I drop to root shell prompt. I have also managed to Ctrl-Alt-F2 to a TTY Terminal from the login window and run the commands you suggest.

Below are the results; let me know if I ought to place the longer word-wrapped logs into Pastebin.

uname -a
Linux Acer 3.11.0-15-generic #25ňúprecise1-Ubuntu SMP Thu Jan 30 17:42:40 UTC 2014 i686 i686
i686 GNU/Linux

lsb_relase -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 13.10
Release: 13.10
Codename: saucy

cat /etc/apt/sources.list
# deb cdrom:[Ubuntu 12.04.4 LTS _Precise Pangolin_ - Release i386 (20140204)]/ precise main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to # newer versions of the distribution.
deb http://ca.archive.ubuntu.com/ubuntu/ saucy main restricted
##
Major bug fix updates produced after the final release of the ## distribution.
deb
http://ca.archive.ubuntu.com/ubuntu/ saucy-updates main restricted ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu ## team. Also, please note that software in universe WILL NOT receive any ## review or updates from the Ubuntu security team.
deb

http://ca.archive.ubuntu.com/ubuntu/ saucy universe
deb http://ca.archive.ubuntu.com/ubuntu/

saucy-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu ## team, and may not be under a free licence. Please satisfy yourself as to ## your rights to use the software. Also, please note that software in ## multiverse WILL NOT receive any review or updates from the Ubuntu ## security team.
deb http://ca.archive.ubuntu.com/ubuntu/

saucy multiverse
deb http://ca.archive.ubuntu.com/ubuntu/ saucy-updates multiverse
## N.B.

software from this repository may not have been tested as ## extensively as that contained in the main release, although it includes ## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review ## or updates from the Ubuntu security team.
deb http://ca.archive.ubuntu.com/ubuntu/ saucy-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu saucy-
security main restricted
deb http://security.ubuntu.com/ubuntu saucy-security universe
deb

http://security.ubuntu.com/ubuntu saucy-security multiverse

## Uncomment the following two lines to add software from Canonical's ## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the ## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu quantal partner
# deb-src

http://archive.canonical.com/ubuntu quantal partner

## Uncomment the following two lines to add software from Ubuntu's ## 'extras' repository.
## This software is not part of Ubuntu, but is offered by third-party ## developers who want to ship their latest software.
# deb

http://extras.ubuntu.com/ubuntu precise main # deb-src http://extras.ubuntu.com/ubuntu precise

main

sudo dpkg --audit
The following packages have been unpacked but not yet configured.They must be configured using dpkg --configure or the configure menu option in dselect for them to work:
 gstreamer1.0-tools
Tools for use with GStreamer
 gcalctool gnome-calculator is a powerful graphical calculator for G gnome-calculator GNOME desktop calculator
 gstreamer1.0-alsa:i386

GStreamer plugin for ALSA gnome-bluetooth GNOME Bluetooth tools
 linux-image-generic

Generic Linux kernel image
 gstreamer1.0-plugins-base-apps GStreamer helper programs from the "base" set ubuntu-desktop The Ubuntu desktop system linux-image-extra-3.11.0-19-generic

Linux kernel extra modules for version 3.1
 linux-generic Complete Generic Linux kernel and headers

The following packages are only half configured, probably due to problems configuring them the first time. The configuration should be retried using dpkg --configure

<package> or the configure menu option in dselect:
 bluez Bluetooth tools and daemons

The following packages are missing the md5sums control file in the database, they need to be reinstalled:
 wine Microsoft Windows Compatibility Layer (meta-package)

-end-

Manfred Hampl (m-hampl) said : #6

Your system is on Ubuntu release 13.10 saucy, no more on 12.10.
The sources.list configuration file is correct for saucy (at least for all repositories that are enabled)
There are a few problems in the package management system.

There seems still to be the problem that your processor does not have PAE capabilities. As you do not have more that 1.5 GB memory, there should be no need for PAE, but I do not know whether the tricks for 'faking' the PAE flag will work well on your system with the newest kernels. See https://help.ubuntu.com/community/PAE for details.

Depending on how much time you have and how adventurous you are, I see as possible steps:
1. Dump 13.10 and go back to re-installing 12.04
or
2. Try getting the package management system back into a consistent state; this will most probably require manually installing fakepae, executing "sudo dpkg --configure -a", and some commands more.

Bill Horne (bhorne) said : #7

Thanks, Manfred. I had been reading the PAE help page and was trying out adding <forcepae> to the < ~quiet splash -- > as suggested while trying to install 14.04 or reinstall 12.04. Unfortunately, this hasn't worked. What seems strange in trying to reinstall 12.04 is that I had successfully installed it a few weeks ago without any problem. I'm using the exact same DVD that worked the first time.

My Acer has an Intel Celeron M320 processor which according to the PAE help page, shouldn't be an issue. So I will try some of the more involved steps in Option B on the PAE help page and report back...

Bill Horne (bhorne) said : #8

I was not able to install even a mini.iso version of 12.04, with or without the force-pae options. The system hung up in a purple window for hours with no activity. Reboots kept taking me back to a 12.10 desktop (even though 13.10 was underneath somewhere) where I could not log in.

In the end I decided to install Mint 13 (a friend gave me a disc) and that is mostly functional. There's a bit of an issue with the video driver, but I'll pursue that in a different forum and thread.

Thank-you again for your assistance.