Launcher woes, please help!

Asked by Glen on 2013-02-02

I am new to Ubuntu, having just installed it on my Samsung 10" netbook that had been running Windows 7. I'm getting familiar with the new setup and like it very much. One problem I am having, however, is with the launcher. (on left side of screen) Since I am currently using Docky, which has all the same info as the side launcher, I wanted to remove the launcher to increase the size of my limited screen space. I understand that it can be set up to enable it to come and go using the curser, but it does not seem to work 100% of the time. (sensitivity slider is not much help) So I'd like to keep the launcher hidden, and just use Docky. Trouble is, when I hide the launcher, I still cannot take over that last piece of screen real estate, no matter how hard I try. All of my windows stop at where the launcher used to be, and nothing I do can make use of that final inch of screen. I'm sure it's a simple fix, but my tired brain is struggling at the moment. Any and all help would be greatly appreciated!

Thanks,
Glen B.
Fogo Island, Newfoundland

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu unity Edit question
Assignee:
No assignee Edit question
Last query:
2013-02-03
Last reply:
2013-02-03

I suggest you install xfce4, log in to the xfce session then configure the xfce panel s as you desire and run compiz and docky

Glen (glen-d) said : #2

Sorry, but I have no idea what this means. What is "xfce4" and where do I find it? Same goes for compiz.

Adam Cajander (cajander1111) said : #3

xfce4 is a different desktop environment. If you want a less drastic change I suggest switching to gnome-classic, which will allow you to choose when you log in. Open a terminal (ctrl+alt+t) and type:

sudo apt-get install gnome-session-fallback

Once that is done, log-out, and click the button near where you log in, which will open a drop-down menu. Then choose, gnome-classic. The unity launcher will be gone, and you will instead have an applications menu. I can also use Docky, or any other dock you want. You will now be automatically logged into gnome classic, every time you log in. If you want to switch back, simply select the drop-down menu again upon log in, and click Ubuntu.

Glen (glen-d) said : #4

Adam, I did as you suggested, but when I logged back in using gnome-classic nothing had changed. (the unity launcher is still there) When I tried typing in "sudo apt-get install gnome-session-fallback" a second time, nothing happened. Any other ideas?
  thanks

Glen (glen-d) said : #5

OK, I got it to where I am able to use gnome-classic (with its application menu, rather than unity launcher) but the space where the launcher used to be is still blank. I am unable to place any windows over that blank strip on the left side where the launcher used to be. I know of no way to get anything to use the full screen width. Very frustrating.

Adam Cajander (cajander1111) said : #6

Hmm. That seems very odd. Try adjusting the screen resolution. In gnome-classic go to Applications>System Tools>System Settings>Displays. Try playing with the resolution to see if that helps. Let us know what happens.

Glen (glen-d) said : #7

Nope, didn't help. Not sure what this means, but when I try to use the curser to expand the windows into the "launcher zone", it becomes shaded, with a thin orange border, which stops precisely where the unity launcher would begin. Frustrating, because I was really loving Ubuntu until this issue arose.

Adam Cajander (cajander1111) said : #8

Don't stop loving Ubuntu. This sort of thing isn't a common occurance. Can you give some specs about your computer?
Enter this in terminal:

sudo lshw -c display

And post the results

Glen (glen-d) said : #9

I'm using a 2 year old Samsung NF-210 netbook with a dual core 1.5GHZ Intel ATOM Processor(N550), 2GB RAM, 1024X600 res, 250BG HHD. Here's the info you requested:

glen@glen-NF110-NF210-NF310:~$
glen@glen-NF110-NF210-NF310:~$ sudo lshw -c display
[sudo] password for glen:
  *-display:0
       description: VGA compatible controller
       product: Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 02
       width: 32 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:46 memory:f0300000-f037ffff ioport:18d0(size=8) memory:d0000000-dfffffff memory:f0000000-f00fffff
  *-display:1 UNCLAIMED
       description: Display controller
       product: Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 02
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:f0380000-f03fffff
glen@glen-NF110-NF210-NF310:~$

Adam Cajander (cajander1111) said : #10

See if their are any new video drivers available.
In terminal type:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get dist-upgrade

Reboot your computer. If something goes wrong and you need to revert back to the original drivers then use:

sudo apt-add-repository --remove ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get upgrade

I

Glen (glen-d) said : #11

Well, this made things go from bad to worse. When I entered your code and rebooted, it has caused me to lose my internet connection, no matter what I try to fix it. And to top it off, when I enter the second batch of code to revert back, it tells me "command not found".

So now I am in a real mess, and am writing this reply on another computer, as my netbook will not connect to the internet since this last experiment.

Hate to say it, but I am close to packing it in.

Adam Cajander (cajander1111) said : #12

Just completely reinstall Ubuntu. Use 12.04. If you don't have much to lose, this will most likely fix the problem. Something is definitely wrong with your system, so just do a complete reinstall.

Can you help with this problem?

Provide an answer of your own, or ask Glen for more information if necessary.

To post a message you must log in.