No icon top-left on 12.04 upgrade from 10.04

Asked by William Sherman

Finally upgraded from lucid to precise.

1. There is no Ubuntu icon top-left. the words reflecting active program change as expected, but I cannot access my programs
     like Ajunta, Gimp, Games, etc.
2. Cannot load "Files" from launcher bar, just sits there, but icon does animate when clicked..
3. Software Center does not load (wheel just keeps spinning). Hoping to reinstall python 2.7. Did notice numerous "unable to
      bind" errors during upgrade.
4. Tried to sudo apt-get install gnome-tweak-tool and I keep getting errors from not being able to bind with python 2.7.
      Too many errors process stopped. webpage said it could make icon visible.
5. "Software up to date" says everything current, and "settings" button doesn't work.
6. Need to use Unity 2d to see anything, and "alt" produces "hud service not connected" error.

Downloaded & burned disk everything worked fine "live", upgraded from 10.04 update manager directly lts to lts and I am now crippled. Sony VAIO dual core 2Ghz, 2Gb ram, dualboot vista, linux partion 35Gb 18Gb free prior to upgrade. Please help I am working with First Robotics and need my computer back.

Question information

English Edit question
Ubuntu unity Edit question
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Last query:
Last reply:
Revision history for this message
William Sherman (wsherman2) said :

I have tried numerous "apt-get -f" , the python minimal config options, and just about everything I could find on the web. now I have a european stopsign telling me of unmet dependancies: "broken count > 0", and system settings just flashes & closes. I guess that this is the newer update manager. nothing works in it, and I have nonstop interrmitent hd activity.

Revision history for this message
Best N1ck 7h0m4d4k15 (nicktux) said :

If an upgrade didn't go well , then is time to re-install.

Backup your important - personal data to an external media , and install Ubuntu 12.04 from scratch.. is a about 15-20 minutes.. procedure.


Revision history for this message
William Sherman (wsherman2) said :

For some strange reason the disk I burned from Ubuntu didn't work. Luckily I had Linux Format Journal's disk. Didn't know ubuntu would rebuild like that. Thank you very much!

Revision history for this message
William Sherman (wsherman2) said :

Thanks NikTh, that solved my question.