What to do if Reset Option is Deprecated ?

Asked by Navin Talati on 2012-11-02

When I apply a command " Unity --reset", the out put is shown as "The reset option is now depricated"
How to solve this?
Navin Talati / 2-11-2012

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu unity Edit question
Assignee:
No assignee Edit question
Solved by:
Navin Talati
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

What are you trying to solve exactly?

Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#2

http://www.webupd8.org/2011/04/how-to-reset-unity-launcher-icons-or.html

But please answer and wait to actionparsnip reply first.

Revision history for this message
Navin Talati (n-m-talati) said :
#3

Actually this is the issue arised during the Upgradation of Ubuntu 12.04 to 12.10 as mentioned in the full detail with the question as under:
---------------------------------------------------------------------------------------------------------------------------------------------------------
How to detect System Tray ? Ubuntu “gnome-desktop” package Questions Question #211868
----------------------------------------------------------------------------------------------------------------------------------------------------------
During the course of the active interaction in the matter on Launchpad, finall the stuff " "sudo apt-get dist-upgrade" worked very nicely and could upgrade most of the disturbed and new packages (about 329 or so ) as the problem was arised due to power inturruption while upgrading process. The full detail is available step by step at:
https://answers.launchpad.net/ubuntu/+source/gnome-desktop/+question/211868

At present the problem is that an ICON BAR from the top and LAUNCHER from Left-side of the DESKTOP is DISAPPEARED ! which was already there in Ununtu 12.04. Unity is not getting reset and not functioning the os in its natural tone. This is the issue which I want to solve.
Please guide and help.
Navin Talati /02-11-2012

Revision history for this message
N1ck 7h0m4d4k15 (nicktux) said :
#4

Maybe you have disabled the Unity Plugin from compizconfig-settings-manager ?

If you haven't this package installed , then open a terminal with CTRL+ALT+T keys combo and install it via

~$ sudo apt-get install compizconfig-settings-manager

Then give in terminal this command

~$ ccsm

and at the opened window , search and find "Unity Plugin" and see if is enabled. If not , then enable it by marking the box.
Logout and login , or reboot.

Also use the commands from answer #2 to try to reset Unity again.

Thanks

Revision history for this message
Navin Talati (n-m-talati) said :
#5

I run the above commands as per your suggestion. The output is as under:
-----------------------------------------------------------------------------------------------------------------------------------------------------------
navin@navin:~$ sudo apt-get install compizconfig-settings-manager
[sudo] password for navin:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  g++-4.6 icedtea-6-plugin libattica0.3 libauthority-shared-perl
  libavahi-client-dev libavahi-common-dev libbabl-0.0-0 libbloom-filter-perl
  libboost-filesystem1.46.1 libboost-python1.46.1 libboost-regex1.46.1
  libboost-signals1.46.1 libboost-system1.46.1 libboost-thread1.46.1
  libcelt0-0 libclass-load-perl libclass-singleton-perl libcrypt-gpg-perl
  libdatetime-format-w3cdtf-perl libdatetime-locale-perl libdatetime-perl
  libdatetime-timezone-perl libexif-dev libfile-slurp-perl libgegl-0.0-0
  libgeo-distance-perl libgeo-distance-xs-perl libgetopt-simple-perl
  libglew1.5 libgphoto2-2-dev libhttp-link-parser-perl libhttp-lrdd-perl
  libicon-famfamfam-silk-perl libieee1284-3-dev libjbig-dev libjpeg-dev
  libjpeg-turbo8-dev libjpeg8-dev libkdcraw20 libkexiv2-10 libkipi8
  liblzma-dev libmarblewidget13 libmath-round-perl
  libmodule-implementation-perl libnepomukdatamanagement4 libopenspc0
  libparams-validate-perl libparse-recdescent-perl libpng12-dev
  librdf-prefixes-perl librdf-query-client-perl librdf-query-perl
  librdf-rdfa-generator-perl librdf-trineshortcuts-perl librpmio2
  libservlet2.5-java libstdc++6-4.6-dev libtiff4-dev libtiffxx0c2 libtiffxx5
  libtry-tiny-perl libusb-dev libv4l-dev libx264-120 libxml-atom-owl-perl
  libxrd-parser-perl libyaml-libyaml-perl libyaml-perl
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  compizconfig-settings-manager
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,111 kB of archives.
After this operation, 4,570 kB of additional disk space will be used.
Get:1 http://in.archive.ubuntu.com/ubuntu/ quantal-updates/universe compizconfig-settings-manager all 1:0.9.8.4-0ubuntu3 [1,111 kB]
Fetched 1,111 kB in 5s (206 kB/s)
Selecting previously unselected package compizconfig-settings-manager.
(Reading database ... 407204 files and directories currently installed.)
Unpacking compizconfig-settings-manager (from .../compizconfig-settings-manager_1%3a0.9.8.4-0ubuntu3_all.deb) ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for man-db ...
Setting up compizconfig-settings-manager (1:0.9.8.4-0ubuntu3) ...
navin@navin:~$ ccsm
compizconfig - Info: Backend : gsettings
compizconfig - Info: Integration : true
compizconfig - Info: Profile : unity
Loading icons...
navin@navin:~$
----------------------------------------------------------------------------------------------------------------------------------------------------------
In this Unity Plugin was enabled. I re-enabled it (by just refreshing "Right Mark" ).
Logout - and again restarted the machine.
Then also applied commands as per ANS. #2
Restarted thesystem.
No change is observed.
It still shows "Reset Option is Depricated"
I assume something little is missing.
What this may be?
Navin Talati / 03-11-2012

Revision history for this message
N1ck 7h0m4d4k15 (nicktux) said :
#6

This reset option is deprecated in 12.10. This is not a mistake. This is normal in 12.10 . The unity --reset is deprecated.

You can reset all your settings and try to reset unity and gnome with bellow commands . Run them one at time in terminal.

First run this command to remove all unwanted packages and clean up your system

~$ sudo apt-get autoremove;sudo apt-get autoclean

Then run bellow commands

~$ sudo apt-get install dconf-tools
~$ dconf reset -f /org/compiz/
~$ unity --reset-icons
~$ setsid unity

Then reboot.

BE AWARE that your settings will be lost.

Thanks

Revision history for this message
Navin Talati (n-m-talati) said :
#7

This has reference to the following initial questions asked on the launchpad.net
(1).What to do if Reset Option is Deprecated ? Question #213078
And
(2).How to detect System Tray ? Question #211868
Problems arised while interruption and failure of power during the upgrading of Ubuntu 12.04 to 12.10 through Update Manager. Different actions were taken during the course of various suggestions and advises and guidance provided by the experts. All step-wise detail is well explained in full text under the above questions. Lots of changes were also caused due to the stuffs applied as per suggestions and many other experiments I carried out in order to solve the problem. The main focus was on getting reset original formate and look after upgradation. Googling was also carried out to resolve the matter. Finally it could be regained as under:
In a terminal I run “ccsm”.
Window opened.
Many of the options were UN-ticked. (i.e. Not Ticked)
Sequentially I went on ticking the options.
Warned interfering/conflicting options were selected in favor of avoiding the conflicting situations.
Accordingly made all ticked at the most default balanced status.
All of a sudden, the Laincher at the Left and Toolbar at the top of the desktop appeared.
Finally I applied the stuff “ sudo shutdown -r now
The machine shutdowned and restarted.
And I got the LOST APPEARANCE
At present the problem is SOLVED.
An ICON BAR at the top and LAUNCHER at Left-side of the DESKTOP is RE-APPEARED ! which was already there in Ununtu 12.04.
Of course, this may not be the pure result of the only above TWO commands but I am sure that everybody who suggested different solutions and made me applying different stuffs would have certainly made favorable changes leading last two stuffs in becoming determinants to achieve the goal.
ONCE AGAIN “MANY MANY THANKS” TO ALL OF YOU.
Navin Talati /04-11-2012