12.10 Upgrade now can't login

Asked by Paul Merrill on 2012-10-20

I've upgraded from 12.04 to 12.10 but I get the message: no system tray detected on this system. I cannot do anything except hit CRTL-ALT-DEL and logout. The upgrade seemed to work ok, no problems at all.

How does one fix this?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu unity Edit question
Assignee:
No assignee Edit question
Solved by:
Paul Merrill
Solved:
2012-10-20
Last query:
2012-10-20
Last reply:
2012-10-20
samuel (samuel-h) said : #1

Are you able to open a terminal w/ ctrl+alt+t

Christian (christianpolking) said : #2

I'm having the same problem. Logging in as a guest does not help - I get the same error.

I can open a terminal.

Paul Merrill (paul-a-merrill) said : #3

Ok

Paul Merrill (paul-a-merrill) said : #4

Ok, problem solved for me. I had the AMD accelerated drivers installed fglrx. In order to fix the problem, I did the following:
Boot into Ubuntu
<ctrl><alt><t> to get a terminal window
execute sudo apt-get remove fglrx
execute sudo reboot

Problem solved!

The remove fglrx actually removes the drivers fglrx AND fglrx-amdcccle (the control centre as well).

Hope this works for you.

Question now is, is there a new AMD driver package within 12.10

Mario Cornali (crnmra) said : #5

This solved the problem for me after a 4 days attempt with other solutions. Thanks