Since the last round of updates, windows no longer have the minimize/maximize/close buttons.

Asked by Jaime Cruz

Ever since the last batch of updates were installed to Ubuntu 12.04 LTS, my windows no longer have that bar at the top with the minimize/maximize/close buttons. Some (but not all) applications will have them when they run full screen, but none of them do when run normally.

Question information

English Edit question
Ubuntu unity Edit question
No assignee Edit question
Solved by:
Thomas Krüger
Last query:
Last reply:
Revision history for this message
Best Thomas Krüger (thkrueger) said :

If you run a window full screen, the upper border with the headline containing the button is hidden and the buttons are placed into the top panel. They will appear then you hover the mouse over the top (menu) panel.
If that does not happen, there might be something wrong with your profile settings. Open a Terminal window and run the command:

unity --reset

Log out and in again!

Revision history for this message
actionparsnip (andrew-woodhead666) said :

If you click the restore button in the top left, do the windows have the controls in the window decorator?

Revision history for this message
Jaime Cruz (jaime-cruz) said :

Thanks Thomas Krüger, that solved my question.

Revision history for this message
Howard W (nycboy57) said :

Do i need to make a new question similar problem except it did not work for me in terminal i did unity--reset both single and double minus bar and get command not found, so maybe i do not have unity??
how do i know?
also how can i get the minimize, maximize, close button I only get the x for close button and i do not see the restore in the upper left as mentioned or when hovering over full screen i do not get anything showing.
thanks in advance

Revision history for this message
Howard W (nycboy57) said :

it seems it is working when i changed to gnome classic, so solved it myself thanks for the sight