Applications disappear from Unity bar

Asked by Artem Khyzha

I encountered the following problem. Every Unity session after certain (yet unknown) events such applications as GIMP and Java applets (javaws) start not occurring into dock. Consequently, there is no way to access them from GUI if one minimizes them. Once happened in a single session, these apps do not appear in a dock until reboot.

I guess this may be a reproducible bug. Thus, I am asking whether someone experiences the same problem and if so, if he knows what exactly causes it so that bug could be properly reported.

P.S. Did I get it right that I should ask here before filling a bug via apport?

Question information

English Edit question
Ubuntu unity Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best Jeet (gour-jitendrasingh) said :

Report a bug ... with full detail H/W etc.

Revision history for this message
Artem Khyzha (metar-deactivatedaccount) said :

Thanks Jeet, that solved my question.

Revision history for this message
Paolo Milani (j-s-sebastian) said :

I am having the same problem today. I have no idea what may have triggered it, but so far it has happened to me with mysql workbench and keepassx. What both applications have in common, is that at startup they launch a small window that later gets closed (a splash screen for mysql workbench, an open dialog for keepassx). A moment after the first window gets closed, the icon disappears from the doc, and neither does the application appear in alt-tab.

Killing the applications and then logging out and back in seemed to fix the problem.

Revision history for this message
Artem Khyzha (metar-deactivatedaccount) said :

Paolo, I added two related bug reports to the question. It seems that a fix is almost ready. Meanwhile we can use Meta+W as a workaround to access such problematic windows.

Revision history for this message
pvanb (p-vanbreugel) said :

Hi, I am having the same problems, with amongst others keepassx and just now LibreOffice. The Meta+W is a good temporary solution,thanks!

The status is set to solved, but I am still experiencing the same problem, running Ubuntu 12.04 will all packages updated

Revision history for this message
Andrew L Joseph (ofus) said :

I've installed Ubuntu multiple times on two different computers, and I have this problem every time