Unity freeze after close and open lid ( nvidia video card )

Asked by varlogin on 2012-05-06

Hello. I have Acer 5920g laptop. Ubuntu 12.04. When I close the lid and then after a few second open it - Unity is freezes. Mouse and keyboard are working but nothing more. Only restarting X server is helping. Unity 2D working fine.

Video drivers - standard.
Hibernate - disabled.
When the lid is closed - do nothing.

$ sudo lshw -C display; lsb_release -a; uname -a
       description: VGA compatible controller
       product: G84 [GeForce 8600M GT]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:16 memory:f2000000-f2ffffff memory:d0000000-dfffffff memory:f0000000-f1ffffff ioport:2000(size=128)
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise
Linux yura-PC 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Question information

English Edit question
Ubuntu unity Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

Sounds like a suspend issue with your video driver. Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a


You are using the open source driver? Is it the same with the proprietary driver?

varlogin (varlogin) said : #3

It was open source driver. I installed proprietary Nvidia driver 295.40. Unity stoped freezes. Thanks for advice:)

But now I get another issue. I'm use dual monitor via hdmi and often plug and unplug second monitor (use as primary display). With open source driver, when I unplug second monitor, all windows move on first monitor well and laptop monitor became primary. With proprietary driver it's not happening. Laptop monitor not became primary, Ubuntu don't change X screen size and windows with panel stay in dead zone. And I need restart X-server. Can you help my with that? I'm use TwinView.

varlogin (varlogin) said : #4

Thanks anyway. Main topic question was solved