how to refresh the dash / head-up display

Asked by Aisano

I have a question about dash -- or is it the head-up display (HUD)? I never quite got what is the difference between the two but I mean the thing that opens when I click the Ubuntu symbol and that replaced the menu. In the process list it seems to show up under unity-2d-shell.

Since I have been on Ubuntu 12.04 I sometimes experience the problem that after log-in the dash contains no applications. Waiting a reasonable amount of time (say, five minutes) and reopening the dash many times does not help. So far the only solution I know is to log off and back on. (I do not need to reboot.)

Is there a way to force a refresh of the dash's contents without logging of? Such as sending it a signal or so? I can open a terminal by pushing Ctrl-Shift-T (not by Alt-F2, though).

Thank you in advance,
Reinhard (Aisano)

Question information

English Edit question
Ubuntu unity Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Sam_ (and-sam) said :


Dash is displayed by super-key.

HUD is displayed by alt-key.

Long-press super-key displays overlay shortcuts.

Processes can be viewed in system monitor, e.g. hud-service, unity-panel-service.

Monitoring activities is done by zeitgeist.

Since Dash works with locate try in a terminal:
sudo updatedb

Revision history for this message
Aisano (info-ais-sanmarino) said :

Thank you, Sam and sam. I now understand what is the dash and the HUD. And I will try updatedb the next time I experience the problem.

Revision history for this message
Aisano (info-ais-sanmarino) said :

The problem has not appeared for about a week, so I consider my question solved. The hints on terminology were, in any case, very useful.

Revision history for this message
Aisano (info-ais-sanmarino) said :

Thanks Sam_, that solved my question.

Revision history for this message
Aisano (info-ais-sanmarino) said :

Just for the records: Today the problem reappeared (no applications in the dash, only recent files and downloads. So I tried "sudo updatedb". It took about two minutes to complete but did not help.

(I wish I had my old menu back.)

Revision history for this message
Aisano (info-ais-sanmarino) said :

It's five days now that my dash does not show any applications, just "recent files" and "downloads". In the meantime I memorized the names of the applications I normally use, so I can start them from a terminal, and I put shortcuts on my desktop. Still this is just a workaround.

Has anybody got an idea what I can do to get my dash working again? Or, since I am not too fond of the dash anyhow, how I can get a decent way of navigating through Ubuntu applications?

Many thanks,

Revision history for this message
Sam_ (and-sam) said :

When you click on the application lens there're no applications displayed?

The 'home lens' displays recently, last used and others.
The 'application lens' displays all installed apps.

Revision history for this message
Aisano (info-ais-sanmarino) said :

Thanks for the image to avoid confusion about terminology. my home lens displays just two sections, which I (naively) translate as "recently used" and "download". The application lens is completely empty; clicking on "filter results" does not change anything, as there is nothing to filter. Until about a week ago the two lenses were mostly full of applications. The present problem was only sporadic; now it seems to be permanent.

I reboot every day, and I usually accept all proposed updates, though for many weeks update-manager would not show me the changes (suggesting me a TTT address instead).

Revision history for this message
Aisano (info-ais-sanmarino) said :

I just got an e-mail that Sam_ pointed me to bug 962265 but this hint does not appear here. I do not, however, think that bug 962265 is my problem as it affects only the home lens. I have used the home lens for several weeks until the problems appeared, and I think it is the empty application lens that is at the root of the problem. I understand the application lens is almost never supposed to be empty. Please correct me if I am wrong here.

Revision history for this message
Sam_ (and-sam) said :

Please close all open applications and open a terminal only: ctrl+alt+t
sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get -f install

Please post complete output here. Thanks.

Revision history for this message
Aisano (info-ais-sanmarino) said :

It is like witchcraft: I had the problem for five consecutive days but when I had posted it here it disappeared. Both my home lens and my application lens now display applications again. But I will post my apt-get output here all the same.

I had not updated for two days so I got a couple of lines under "update" / "upgrade". I forgot to switch LANG to English, so the output is a mixture of German and Esperanto.

As presently I cannot reproduce the problem I am setting this question to "solved" again. Many thanks.

$ sudo apt-get clean
$ sudo apt-get update
Ign precise InRelease
Ign precise InRelease
OK precise Release.gpg
OK precise Release.gpg
OK precise Release
OK precise/partner i386 Packages
Ign precise InRelease
Ign precise/partner TranslationIndex
Ign precise-security InRelease
Ign precise-updates InRelease
OK precise Release
OK precise/main Sources
OK precise/main i386 Packages
Ign precise/main TranslationIndex
Ign precise/partner Translation-eo
Ign precise/partner Translation-de_DE
Ign precise/partner Translation-de_AT
Ign precise/partner Translation-de_CH
Ign precise/partner Translation-en
Ign precise/main Translation-eo
Ign precise/main Translation-de_DE
Ign precise/main Translation-de_AT
Ign precise/main Translation-de_CH
Ign precise/main Translation-en
Ign precise-proposed InRelease
OK precise Release.gpg
OK precise-security Release.gpg
OK precise-updates Release.gpg
OK precise-proposed Release.gpg
OK precise Release
OK precise-security Release
OK precise-updates Release
OK precise-proposed Release
OK precise/main Sources
OK precise/universe Sources
OK precise/main i386 Packages
OK precise/universe i386 Packages
OK precise/main TranslationIndex
OK precise/universe TranslationIndex
OK precise-security/main Sources
OK precise-security/universe Sources
OK precise-security/main i386 Packages
OK precise-security/universe i386 Packages
Hole:1 precise-security/main TranslationIndex [73 B]
Hole:2 precise-security/universe TranslationIndex [73 B]
OK precise-updates/main Sources
OK precise-updates/universe Sources
OK precise-updates/main i386 Packages
OK precise-updates/universe i386 Packages
OK precise-updates/main TranslationIndex
OK precise-updates/universe TranslationIndex
OK precise-proposed/main Sources
OK precise-proposed/universe Sources
OK precise-proposed/main i386 Packages
OK precise-proposed/universe i386 Packages
Hole:3 precise-proposed/main TranslationIndex [3564 B]
Hole:4 precise-proposed/universe TranslationIndex [2850 B]
OK precise/main Translation-eo
OK precise/main Translation-en
OK precise/universe Translation-en
OK precise-security/main Translation-en
OK precise-security/universe Translation-en
OK precise-updates/main Translation-en
OK precise-updates/universe Translation-en
OK precise-proposed/main Translation-eo
OK precise-proposed/main Translation-en
OK precise-proposed/universe Translation-en
Es wurden 6560 B in 24 s geholt (265 B/s)
Paketlisten werden gelesen... Fertig

$ sudo apt-get upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
Die folgenden Pakete werden aktualisiert (Upgrade):
  gir1.2-panelapplet-4.0 gir1.2-pango-1.0 gnome-control-center gnome-control-center-data
  gnome-panel gnome-panel-data gnome-settings-daemon gnome-settings-daemon-dev
  libgnome-control-center1 libgtkhtml-4.0-0 libgtkhtml-4.0-common libgtkhtml-editor-4.0-0
  libpanel-applet-4-0 libpango1.0-0 libpango1.0-dev unity-lens-video
  unity-scope-video-remote xdiagnose xkb-data xserver-xorg-input-synaptics
20 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 7577 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 56,3 kB Plattenplatz freigegeben.
Möchten Sie fortfahren [J/n]? J
Hole:1 precise-proposed/main libpango1.0-dev i386 1.30.0-0ubuntu3.1 [473 kB]
Hole:2 precise-proposed/main gir1.2-pango-1.0 i386 1.30.0-0ubuntu3.1 [22,7 kB]
Hole:3 precise-proposed/main libpango1.0-0 i386 1.30.0-0ubuntu3.1 [361 kB]
Hole:4 precise-proposed/main xkb-data all 2.5-1ubuntu1.3 [474 kB]
Hole:5 precise-proposed/universe libpanel-applet-4-0 i386 1:3.4.1-0ubuntu1.1 [94,1 kB]
Hole:6 precise-proposed/universe gir1.2-panelapplet-4.0 i386 1:3.4.1-0ubuntu1.1 [5044 B]
Hole:7 precise-proposed/main gnome-control-center-data all 1:3.4.2-0ubuntu0.3 [1121 kB]
Hole:8 precise-proposed/universe gnome-panel i386 1:3.4.1-0ubuntu1.1 [485 kB]
Hole:9 precise-proposed/universe gnome-panel-data all 1:3.4.1-0ubuntu1.1 [2621 kB]
Hole:10 precise-proposed/main gnome-settings-daemon i386 3.4.2-0ubuntu0.3 [477 kB]
Hole:11 precise-proposed/main libgnome-control-center1 i386 1:3.4.2-0ubuntu0.3 [79,3 kB]
Hole:12 precise-proposed/main gnome-control-center i386 1:3.4.2-0ubuntu0.3 [660 kB]
Hole:13 precise-proposed/main libgtkhtml-editor-4.0-0 i386 4.2.2-1ubuntu1.2 [83,8 kB]
Hole:14 precise-proposed/main libgtkhtml-4.0-0 i386 4.2.2-1ubuntu1.2 [364 kB]
Hole:15 precise-proposed/main libgtkhtml-4.0-common all 4.2.2-1ubuntu1.2 [76,5 kB]
Hole:16 precise-proposed/main unity-lens-video all 0.3.5-0ubuntu1.2 [8280 B]
Hole:17 precise-proposed/main unity-scope-video-remote all 0.3.5-0ubuntu2.1 [7250 B]
Hole:18 precise-proposed/main xdiagnose all 2.5.2 [58,5 kB]
Hole:19 precise-proposed/main xserver-xorg-input-synaptics i386 1.6.2-1ubuntu1~precise1 [72,3 kB]
Hole:20 precise-proposed/main gnome-settings-daemon-dev i386 3.4.2-0ubuntu0.3 [33,2 kB]
Es wurden 7577 kB in 55 s geholt (136 kB/s)
(Legado de datumbazo ...793453 dosieroj kaj dosierujoj aktuale instalitaj.)
Ni prepariĝas por anstataŭi libpango1.0-dev 1.30.0-0ubuntu3 (uzante .../libpango1.0-dev_1.30.0-0ubuntu3.1_i386.deb) ...
Elpakado de anstataŭanto libpango1.0-dev ...
Ni prepariĝas por anstataŭi gir1.2-pango-1.0 1.30.0-0ubuntu3 (uzante .../gir1.2-pango-1.0_1.30.0-0ubuntu3.1_i386.deb) ...
Elpakado de anstataŭanto gir1.2-pango-1.0 ...
Ni prepariĝas por anstataŭi libpango1.0-0 1.30.0-0ubuntu3 (uzante .../libpango1.0-0_1.30.0-0ubuntu3.1_i386.deb) ...
Elpakado de anstataŭanto libpango1.0-0 ...
Ni prepariĝas por anstataŭi xkb-data 2.5-1ubuntu1.2 (uzante .../xkb-data_2.5-1ubuntu1.3_all.deb) ...
Elpakado de anstataŭanto xkb-data ...
Ni prepariĝas por anstataŭi libpanel-applet-4-0 1:3.4.1-0ubuntu1 (uzante .../libpanel-applet-4-0_1%3a3.4.1-0ubuntu1.1_i386.deb) ...
Elpakado de anstataŭanto libpanel-applet-4-0 ...
Ni prepariĝas por anstataŭi gir1.2-panelapplet-4.0 1:3.4.1-0ubuntu1 (uzante .../gir1.2-panelapplet-4.0_1%3a3.4.1-0ubuntu1.1_i386.deb) ...
Elpakado de anstataŭanto gir1.2-panelapplet-4.0 ...
Ni prepariĝas por anstataŭi gnome-control-center-data 1:3.4.2-0ubuntu0.2 (uzante .../gnome-control-center-data_1%3a3.4.2-0ubuntu0.3_all.deb) ...
Elpakado de anstataŭanto gnome-control-center-data ...
Ni prepariĝas por anstataŭi gnome-panel 1:3.4.1-0ubuntu1 (uzante .../gnome-panel_1%3a3.4.1-0ubuntu1.1_i386.deb) ...
Elpakado de anstataŭanto gnome-panel ...
Ni prepariĝas por anstataŭi gnome-panel-data 1:3.4.1-0ubuntu1 (uzante .../gnome-panel-data_1%3a3.4.1-0ubuntu1.1_all.deb) ...
Elpakado de anstataŭanto gnome-panel-data ...
Ni prepariĝas por anstataŭi gnome-settings-daemon 3.4.2-0ubuntu0.2 (uzante .../gnome-settings-daemon_3.4.2-0ubuntu0.3_i386.deb) ...
Elpakado de anstataŭanto gnome-settings-daemon ...
Ni prepariĝas por anstataŭi libgnome-control-center1 1:3.4.2-0ubuntu0.2 (uzante .../libgnome-control-center1_1%3a3.4.2-0ubuntu0.3_i386.deb) ...
Elpakado de anstataŭanto libgnome-control-center1 ...
Ni prepariĝas por anstataŭi gnome-control-center 1:3.4.2-0ubuntu0.2 (uzante .../gnome-control-center_1%3a3.4.2-0ubuntu0.3_i386.deb) ...
Elpakado de anstataŭanto gnome-control-center ...
Ni prepariĝas por anstataŭi libgtkhtml-editor-4.0-0 4.2.2-1ubuntu1.1 (uzante .../libgtkhtml-editor-4.0-0_4.2.2-1ubuntu1.2_i386.deb) ...
Elpakado de anstataŭanto libgtkhtml-editor-4.0-0 ...
Ni prepariĝas por anstataŭi libgtkhtml-4.0-0 4.2.2-1ubuntu1.1 (uzante .../libgtkhtml-4.0-0_4.2.2-1ubuntu1.2_i386.deb) ...
Elpakado de anstataŭanto libgtkhtml-4.0-0 ...
Ni prepariĝas por anstataŭi libgtkhtml-4.0-common 4.2.2-1ubuntu1.1 (uzante .../libgtkhtml-4.0-common_4.2.2-1ubuntu1.2_all.deb) ...
Elpakado de anstataŭanto libgtkhtml-4.0-common ...
Ni prepariĝas por anstataŭi unity-lens-video 0.3.5-0ubuntu1.1 (uzante .../unity-lens-video_0.3.5-0ubuntu1.2_all.deb) ...
Elpakado de anstataŭanto unity-lens-video ...
Ni prepariĝas por anstataŭi unity-scope-video-remote 0.3.5-0ubuntu2 (uzante .../unity-scope-video-remote_0.3.5-0ubuntu2.1_all.deb) ...
Elpakado de anstataŭanto unity-scope-video-remote ...
Ni prepariĝas por anstataŭi xdiagnose 2.5.1 (uzante .../xdiagnose_2.5.2_all.deb) ...
Elpakado de anstataŭanto xdiagnose ...
Ni prepariĝas por anstataŭi xserver-xorg-input-synaptics 1.6.0-0ubuntu1~precise1 (uzante .../xserver-xorg-input-synaptics_1.6.2-1ubuntu1~precise1_i386.deb) ...
Elpakado de anstataŭanto xserver-xorg-input-synaptics ...
Ni prepariĝas por anstataŭi gnome-settings-daemon-dev 3.4.2-0ubuntu0.2 (uzante .../gnome-settings-daemon-dev_3.4.2-0ubuntu0.3_i386.deb) ...
Elpakado de anstataŭanto gnome-settings-daemon-dev ...
Procezado de ekigiloj por man-db ...
Procezado de ekigiloj por hicolor-icon-theme ...
Procezado de ekigiloj por desktop-file-utils ...
Procezado de ekigiloj por bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Procezado de ekigiloj por gnome-menus ...
Procezado de ekigiloj por libglib2.0-0 ...
Procezado de ekigiloj por gconf2 ...
Procezado de ekigiloj por menu ...
Procezado de ekigiloj por ureadahead ...
ureadahead will be reprofiled on next reboot
Ni alĝustigas libpango1.0-0 (1.30.0-0ubuntu3.1) ...
Ni alĝustigas gir1.2-pango-1.0 (1.30.0-0ubuntu3.1) ...
Ni alĝustigas libpango1.0-dev (1.30.0-0ubuntu3.1) ...
Ni alĝustigas xkb-data (2.5-1ubuntu1.3) ...
Ni alĝustigas libpanel-applet-4-0 (1:3.4.1-0ubuntu1.1) ...
Ni alĝustigas gir1.2-panelapplet-4.0 (1:3.4.1-0ubuntu1.1) ...
Ni alĝustigas gnome-control-center-data (1:3.4.2-0ubuntu0.3) ...
Ni alĝustigas gnome-panel-data (1:3.4.1-0ubuntu1.1) ...
Ni alĝustigas gnome-panel (1:3.4.1-0ubuntu1.1) ...
Ni alĝustigas gnome-settings-daemon (3.4.2-0ubuntu0.3) ...
Ni alĝustigas libgnome-control-center1 (1:3.4.2-0ubuntu0.3) ...
Ni alĝustigas gnome-control-center (1:3.4.2-0ubuntu0.3) ...
Ni alĝustigas libgtkhtml-4.0-common (4.2.2-1ubuntu1.2) ...
Ni alĝustigas libgtkhtml-4.0-0 (4.2.2-1ubuntu1.2) ...
Ni alĝustigas libgtkhtml-editor-4.0-0 (4.2.2-1ubuntu1.2) ...
Ni alĝustigas unity-lens-video (0.3.5-0ubuntu1.2) ...
Ni alĝustigas unity-scope-video-remote (0.3.5-0ubuntu2.1) ...
Ni alĝustigas xdiagnose (2.5.2) ...
Ni alĝustigas xserver-xorg-input-synaptics (1.6.2-1ubuntu1~precise1) ...
Ni alĝustigas gnome-settings-daemon-dev (3.4.2-0ubuntu0.3) ...
Procezado de ekigiloj por libc-bin ...
ldconfig deferred processing now taking place
Procezado de ekigiloj por menu ...

$ sudo apt-get install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Statusinformationen werden eingelesen... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.