Ubuntu

Desktop not working in a recent install

Asked by Jon Erling Vembe on 2012-03-05

I recently installed Ubuntu on my computer, running a dual-boot configuration as described here:

http://lifehacker.com/5403100/dual+boot-windows-7-and-ubuntu-in-perfect-harmony

And the problem I am having is that when I boot Ubuntu everything works fine up to after the login screen, at which point the desktop appears with nothing in any of the menus and the mouse not responding when I click.

(It does, however, respond to movement.)

The install was done using a CD I burned myself, which worked perfectly fine for my laptop.

The computer I am having problems on has an AMD six-core processor, an AMD radeon graphics card, and an ASUS motherboard.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu unity Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-03-06
Last query:
2012-03-06
Last reply:
2012-03-06

If you log in to Unity2D, does the desktop show?

Jon Erling Vembe (iamlikhan) said : #2

Yes.

Ok use that to get fully updated and such. What video chip do you use?

Jon Erling Vembe (iamlikhan) said : #4

Before I say anything else, I'd like to just clarify that I am completely new to Linux usage, so I have no idea how to do that.

Anyway. The chipset on my motherboard is an AMD 890FX / SB850 one, other than that I have no idea, really. Sorry.

copy this command:

sudo apt-get update; sudo apt-get -y upgrade; sudo apt-get -y dist-upgrade; sudo reboot

Press CTRL+ALT+T and paste the command there, type your password and get updates. Once you get updated and rebooted try logging in. If not then use Unity2D again but use the additional drivers app to install your video drivers.

Unity (non 2D) needs 3D accelleration which you currently don't have due to drivers.

Jon Erling Vembe (iamlikhan) said : #6

Thanks actionparsnip, that solved my question.