Light doesn't follow the orange line on Workspace Switcher

Asked by Alex Solanos

I'm in 11.10 downloaded and fresh-installed today.
Hello, I'm asking this because I am not quite sure how to describe this bug or in which package it is...
Description: I access the Workspace Switcher via Super+S and then I click on one of the 4 desktops available from default. Double-clicking on one of the desktops will quit the Workspace Switcher and it'll set focus to the selected Desktop.

The thing is that (sometimes) when I just click to a desktop while Workspace Switcher is activated, the light follow the orange. To be more clear, here's a screenshot:
In this occasion I've selected the top left desktop (where the orange line is) but the light is still on the bottom left right while it should follow the orange line. Just to mention that this is not happening too rarely, I'd say 50% of the times I've tried it happens.

Thanks in advance for any help on how and where should I post this bug...

Question information

English Edit question
Ubuntu unity Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Alex Solanos (hakermania) said :

Some typos:
*the light DOES not follow the orange
*the bottom left CORNER

Revision history for this message
Best Danillo (danillo) said :

The lights are to indicate workspaces currently in use, i.e. in which you have at least one window open, while the orange line is used to indicate which workspace has the focus, following your single clicks. I'm not sure what's going on with the terminals in your picture, but yeah, the lights and the orange line are two different and unconnected things.

Let's say you open Firefox in workspace #2 and Nautilus in workspace #3 and then access the workspace switcher. You should see lights in the workspaces #2 and #3 only. The orange line will be in whatever workspace you were working and will move independently from the lights as you click on the workspaces.

Revision history for this message
Alex Solanos (hakermania) said :

Thanks Danillo, that solved my question.