Unity kills "classic" workspaces. How to regain them?

Asked by Harry Skelton

I wanted to resume my workplace changing via moving my mouse to the desktop area and moving my scroll-wheel. When I try to set it up it does not work, and my other Compiz features, when enabled, kills Unity and leaves me with no option to regain my old environment.


1. What can I do to to regain the ability to flip through workspaces via mouse scroll wheel on desktop?

2. A fix needs to be made so that Compiz disabling of Unity does not leave the user without a way to undo it. Perhaps a shell script needs to be added to restore Unity when Compiz modifications make it disappear.

P.S. please do not explain the workspace feature at the bottom of the Unity Dock. I know about it. But it does not do what I was working with in 11.04.

Question information

English Edit question
Ubuntu unity Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
steve taylor (stevemail) said :

Hi Harry, just been fixing that one myself.

So, you can use 'Compizconfig settings manager' which I think comes ready installed.
If you click your dash open and type ccs the manager should appear as an app.

Open the thing and under desktop settings you should find 'Expo'. It needs to be enabled.
Also Desktop wall but that's probably default.

That should be enough but if not load up 'Ubuntu Tweak' from Synaptic, if you don't already have it.
Open the program and locate Compiz Settings. Check 'enable workspace switching with mouse wheel'.
Also 'Workspace Edge Settings' needs looking at.

There are four corners around the Ubuntu Tweak Logo, with mine only the lower right menu is allocated as 'Show Workspaces'.

Hope this works for you

Can you help with this problem?

Provide an answer of your own, or ask Harry Skelton for more information if necessary.

To post a message you must log in.