Some essential Unity packages not installed after Natty upgrade

Asked by Federico Tello Gentile on 2011-04-12

Last Sunday (2011-04-10) I upgraded to Natty with the update-manager (using -d option). Everything went fine as there were no errors reported.
After I restarted my default desktop was Unity (in maverick I had it's default gnome), and it worked fine, but I discovered there were some packages not installed in my system that reduced the Unity functionality.

unity-place-applications
unity-place-files
indicator-appmenu

The time indicator was also missing.

The result was that my unity after the upgrade did not show the gtk applications menu in the top panel, I could not find files or applications from the launcher and Firefox 4.0 did not have the application menu displayed on the top panel either.

After I installed those missing packages everything looked like the natty Live CD unity.

Is this a dependency problem? Those packages are optional for Unity, but they should be required by the ubuntu-desktop package.

Should this question be turned into a bug?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu unity Edit question
Assignee:
No assignee Edit question
Solved by:
Federico Tello Gentile
Solved:
2011-04-15
Last query:
2011-04-15
Last reply:
2011-04-12

Log a bug

Natty is NOT ready and NOT stable so you will get issues like this

I rather file a bug before natty is ready since this would hurt lots of users upgrading from maverick unnecessarily.

Exactly, get a bug logged and it will be addressed hopefully before release:
https://help.ubuntu.com/community/ReportingBugs

The linked bug is fixed, therefore this question is solved.

If you can't fix stuff like this yourself or cannot search to find guides, I don't recommend you use pre-releases.