Garbled screen in natty narwhal

Asked by poonforce on 2011-02-23

When i tried to install natty from live CD, my monitor gave error "Out of Range".
Then i installed in in Nomodset mode, it got installed.
But after every boot my screen gets garbled and i m not able to read anything on the screen.
But when i boot in failsafe graphic mode, everything works fine, but ubuntu classic desktop comes instead of Unity.

I have desktop
Motherboard-Asus M2N MX SE Plus
Processor-AMD Athelon 4600+
Ram-2GB
Onboard Nvidia Card version-GeForce 6150 and nForce 430

Please Help.
Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu unity Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2011-02-24
Last query:
2011-02-24
Last reply:
2011-02-23

This question was reopened

Did you add the nomodeset boot option to grub so it gets applied to your kernels

Have you installed the proprietary nvidia driver too?

poonforce (poonforce) said : #2

no i have not installed proprietary nvidia driver.
bcoz if i install them then i m not able to run eve failsafe mode. and normal boot also hang up in between.

Try:

sudo apt-get --purge remove xserver-xorg-video-nouveau

Then reboot.

poonforce (poonforce) said : #4

Thanks actionparsnip, that solved my question.

poonforce (poonforce) said : #5

Thanks actionparsnip, that solved my question.

When i run your command it says this package is not installed so could not removed.

Then i installed this package and i got my screen back. Thanks

But it logs in Classic Ubuntu desktop by default instead of ubuntu unity.

Any thanks again.

poonforce (poonforce) said : #6

Now the garbled screen is gone, but every time i boot i choose ubuntu-desktop-edition but it logs me in ubuntu classic gnome desktop instead of unity desktop.
when i try to install ubuntu-desktop unity it says

Reading package lists... Done
Building dependency tree
Reading state information... Done
unity is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ubuntu-desktop : Depends: language-selector but it is not going to be installed
E: Broken packages

And if i try to install language-selector it says

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 language-selector : Depends: language-selector-common (= 0.13) but 0.16 is to be installed
E: Broken packages

please help.

poonforce (poonforce) said : #7

Thanks actionparsnip, that solved my question.