Desktop icons in Ubuntu Netbook

Asked by Valters Jansons on 2011-01-16

I am enjoying my Ubuntu Netbook 10.10 and I started wondering about the desktop icon (files and folders) invisibility. There is even a "Desktop" folder in the user files! I also downloaded and tried Ubuntu Desktop 10.10 and the icons were visible there.
After some checking, I found that root's (root is kind of a main admin account) desktop has icons. My first idea was to use a command (it was 'gksudo nautilus') that makes a desktop. Just this time the desktop is root. It worked, just the files were taken from root's files, not user's.
Later on, we found out that the configuration '/apps/nautilus/preferences/show_desktop' is true for root account, but false for other users. (Note: that configuration sets if the icons on desktop should be displayed) Now, you might think, just change the value and you are done! Well, not exactly. This configuration is not writable (read-only). I also found out that the key (configuration) can be reset by clicking "Unset key" in it's context (right-click) menu.
Current problem: The configuration is reset to false when user logs off or logs back in. I am not really sure, but it gets reset at some point. Now looking for a file that sets this value to false.

P.S. I could not have even made it this far without help from Samantha.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu unity Edit question
Assignee:
No assignee Edit question
Solved by:
Valters Jansons
Solved:
2011-01-20
Last query:
2011-01-20
Last reply:
2011-01-20

This question was reopened

Because you are using the netbook interface you won't see those files. If you log off and log into the desktop system you will see the files.

If you are in the desktop system and see no icons, press ALT+F2 and run:

nautilus

Do you see the files now?

mycae (mycae) said : #2

The desktop in the netbook version uses the "unity" desktop environment, which by design does not allow desktop icons.

You can choose your desktop session when you login, at the bottom of the screen ("Classic desktop", or "Unity" (I think)), after you type your name, and before you enter your password. If you have auto-login set, you need to disable this.

mycae (mycae) said : #3

The desktop in the netbook version uses the "unity" desktop environment, which by design does not allow desktop icons.

You can choose your desktop session when you login, at the bottom of the screen ("Classic desktop", or "Unity" (I think)), after you type your name, and before you enter your password. If you have auto-login set, you need to disable this.

Valters Jansons (sigv) said : #4

In Desktop version, I see the files without the command.
I am a netbook user and I would like to have desktop icons in Ubuntu Netbook 10.10, but well... does really matter that much.

Thanks for the fast answer.

Valters Jansons (sigv) said : #5

P.S. mycae, will try that. Be right back!

Valters Jansons (sigv) said : #6

So. The Desktop choice on log-in makes the whole OS become a kind of Desktop version.
I want the icons in Netbook interface. And if you have not tried Netbook interface, then the best change is the sidebar/dock with applications (open & pinned ones). That is just one of the changes.

As I said, it does not matter. This question is answered and the icons can NOT be enabled in Netbook version (maybe with some changes in OS code they can, but not otherwise).

Sam_ (and-sam) said : #7

Not familiar with Netbook, but the 'desktop version' of Unity has an option to add folder to desktop when there is a global menu.
http://en.wikipedia.org/wiki/File:Ubuntu_11.04_Alpha_Desktop.png

When no app is focused and you hoover over the global menu it shows
- ubuntu logo
- file
- edit
- view
- places
- help

Under file menu is a submenu which has an option to create folder (and files) on desktop.

Unity session calls: Ubuntu-Desktop-Edition
Gnome session calls: Ubuntu Classic Desktop

If you add the Desktop folder to nautilus in the left panel, it should appear in the places menu and be quicker to access.

Valters Jansons (sigv) said : #9

@Sam: The Netbook 10.10 has another interface. This interface has no desktop icons and the global menu (the upper bar menu) hidden...or maybe the last one is just a glitch for me?
I will look in Google, maybe I will find a way to enable the global menu.
P.S. There appears an application-specific menu there when an application/file/etc. is open.

So, is it maybe possible to add desktop icons in Netbook 10.10?

Valters Jansons (sigv) said : #10

Wow. I made desktop files in /root/desktop folder, even as a regular user.
Well, I am off to the school! Will (most likely) not answer for some time.

So, are the desktop icons possible for a regular user? Commands?

Why are you making files in the root profile?

Valters Jansons (sigv) said : #12

So, I enabled the desktop icons by creating a "root" desktop.
Command: sudo nautilus
It enables the desktop icons. Only problem is that the items are from /root/desktop. Usually users can NOT access that folder, but when using the "root nautilus" you can read and write (make) items.

So. The question is now, can a user have desktop icons in Netbook 10.10 in any other way?

Valters Jansons (sigv) said : #13

Oh well. No answer in some hours, so I am marking this question as solved/answered!

Conclusion: By default you can not have icons on desktop, but using "sudo nautilus" you can make a x-nautilus application/window open in background. With the x-nautilus active the icons and other things can be made in /root/desktop/, but I would not advise this, because then the desktop has root access (at least I think so).

Sam_ (and-sam) said : #14

> No answer in some hours

Well, there is support available which may resolve your needs in a rush. ;-)
http://www.canonical.com/consumer-services/support

> desktop has root access

Try chown and chmod to give permissions back to user.
https://help.ubuntu.com/community/FilePermissions

Sam_ (and-sam) said : #15

> The command for that is "sudo nautilus"

Please correct 'sudo nautilus', otherwise it may corrupt privileges.
https://help.ubuntu.com/community/RootSudo#Graphical%20sudo

Are there differences between those files on desktop pc vs. netbook?
~/.config/user-dirs.dirs
Origins are in /etc/xdg/user-dirs.defaults.

Valters Jansons (sigv) said : #16

Weren't online for some time, because of a little problem with internet connection here... and it was nothing Ubuntu related. :-)

Well, the answers were coming in with an hour interval so this time they were coming kinda slow. And I do not really need a very quick answer, just saying that the question is answered. By that I do not mean that I am not going to listen to comments and suggestions.

> Try chown and chmod to give permissions back to user.
I do not really understand what you mean with that. I read the link and will read it more, but could you maybe explain it (maybe a short version)?

> Please correct 'sudo nautilus', otherwise it may corrupt privileges.
I will change it and then test the result.

> Are there differences between those files on desktop pc vs. netbook?
I will check those files...

So, I will post back a little later!

Valters Jansons (sigv) said : #17

So, the 'gksudo nautilus' work perfectly! Use it instead.

Also, I could not find a difference in the directory files. They seem the same!

And about the chown and chmod (the ones for giving permissions back to user)... can you explain a little? Thanks!

I will mark this question as not answered. Current question: How to transfer/give permissions back to the user?

Valters Jansons (sigv) said : #18

A little fail by me... Marking the question as not answered now...

Current question: How to transfer/give permissions back to the user?

Sam_ (and-sam) said : #19

Forget my idea regarding user permissions, I've misread created folder as_root in user_desktop instead of root_desktop.

Try this.
Open gconf-editor and verify that
/apps/nautilus/preferences/show_desktop
is set to true.
In case right click and make it mandatory.

http://library.gnome.org/users/gconf-editor/2.32/gconf-editor.html

Valters Jansons (sigv) said : #20

So, I will check the file.
Marking as answered because that one bit was unnecessary.

Valters Jansons (sigv) said : #21

So, I have found the value and it is set false for users and true for "root".

It can not be changed manually, because the show_desktop key is not writeable.
http://img20.imageshack.us/img20/3677/screenshotconfiguration.png

I will check a little more and I am off to school...
I will leave with a question: How to change a key that is not writeable?

Sam_ (and-sam) said : #22

Try:
gksudo gconf-editor

Valters Jansons (sigv) said : #23

Good idea, but in my last post I said that it is true for root (sudo & gksudo) and false for other users. Those configurations are set per user.
Maybe they can be changed in some file in file system or at any other file?
I now know the problem, but I do not know how to fix it... :-(

Valters Jansons (sigv) said : #24

I found that the value can be changed just by clicking 'Unset key' button for that key. Then it gets reset to a true value. Desktop icons become enabled and they are loaded from user's files! The only problem is that the setting is not writable and it is reset on logout/login.
I will look for the file where the '/apps/nautilus/preferences/show_desktop' is set/changed. Maybe someone can help?
I will also rewrite the main post (the one that started the thread).

Valters Jansons (sigv) said : #25

I can not find any file that sets the value to false. I guess I just don't know where and how I should search.
Well, if anything changes, I will post!