Gmail and Twitter webapps are not showing up in Launcher

Asked by Devin

I went to, then navigated to gmail, and it asked if I would like to install the webapp for it. I complied, but it does not show up in the Launcher, not after reboots or reinstallations of the unity-webapps-gmail package. Gmail stays under the Firefox icon in the Launcher when it should have its own icon, e.g., the one in the first part of this Youtube video <>.

Before installing the gmail webapp, I set up my Online Accounts through System Settings. Does this have to do with why my webapps won't work, too? I think I got Launchpad's webapp to successfully lock to the Launcher because it came up as a discrete icon, which I think separated from Firefox's icon after I installed the webapp for it. This makes it more confusing because it seems like if that one works, why not the rest?

Question information

English Edit question
Ubuntu unity-webapps-gmail Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

If you run the app from Dash, does it show ok?

Revision history for this message
mexlinux (mcanedo) said :

Sane probleme here, no it does not show in the dash

Revision history for this message
Tomáš Karger (tomak) said :

Same problem here (only with gmail, twitter works for me). I tried to delete my google settings in online accounts and install the app again with no improvement. But empathy is working fine with the gmail chat since the first install of the app. I don't have evolution installed though - was the app intended to work with it?

Revision history for this message
Devin (8basepairs) said :

It does not show up in the Dash when I type "gmail" or "webapp" either.

@mcanedo, Empathy works fine for me, as well. @tomkarger, I wasn't wondering about Evolution like you were, but I am wondering if the app is somehow intended for Thunderbird?

Revision history for this message
Devin (8basepairs) said :

Hmm, I visited through Firefox after installing the web app and that one is working now, like it did for tomkarger. However, visiting google or gmail through Firefox while the gmail webapp is installed does not make it show up in the Dash or Launcher, still. If I uninstall the webapp and visit gmail again, the dialog asking whether I want to install the webapp for it does pop up, but on for a split second before it is possible to try clicking install again from the website.

Revision history for this message
Tomáš Karger (tomak) said :

I had the "impossibly short popup" problem (like 8basepairs) with youtube but I that went away by itself after a restart.
I wasn't aware that dash could be searched by the word webapp - it shows all the installed webapps except for gmail.

Revision history for this message
Wadelius (wadelius) said :

Same problem for me. If I type webapp in the Dash all appear except for the gmail app. I have tried rebooting and reinstalling unity-webapps-gmail.

Revision history for this message
peterrus (petorrus) said :

This also affects me. All other webapps work fine.

Revision history for this message
makilakixki (zandueta) said :

Same problem here in Ubuntu 13.04. This bug seems to be user-dependent since if I log in with a different user (admin) gmail webapp works perfectly.

Revision history for this message
Kirill (kirill-vanheerden) said :

Same problem on two different ubuntu 13.04 computers here. It works fine for the admin user but fails to show for other users and doesnt show up in dash eiether. Empathy works though, just no mail. Also, other unity-webapps like googlecalendar work fine.

Can you help with this problem?

Provide an answer of your own, or ask Devin for more information if necessary.

To post a message you must log in.