Multiseat setup: black screen with cursor most of the time

Asked by Andy D.

I have a multiseat setup with 4 seats. Every time I boot, it seems random as to if a given seat will produce a login screen or not. If it doesn't, I get a black screen with a cursor I can move with the mouse. I've looked at the logs while I do a:

sudo systemctl stop lightdm
#Look at logs with cd /etc/; tail -fn0 Xorg.*.log lightdm/*.log
sudo systemctl start lighdm

In this specific case, seat0 didn't get a login screen, but seat1 did. The biggest difference I can see in the logs between the two seats is that /var/log/lightdm/seat1-greeter.log gets a lot of stuff and /var/log/lightdm gets very little. Besides that, I don't see any errors in any of the logs that are on seat0 (the one that didn't work) but not on seat1 (the one that worked).

Here is a screenshot showing these two logs side by side with differences highlighted (using meld).

https://paste.pics/96677091ecf69a7a948af79692282f79

My question: How in the world can I debug this if there aren't errors in the logs? I believe the greeter is having a problem starting sometimes, but how can I get more verbose info about what it's doing to help narrow down the problem space?

Thanks for your help.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu unity-greeter Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:

Can you help with this problem?

Provide an answer of your own, or ask Andy D. for more information if necessary.

To post a message you must log in.