Problems compiling/testing unity-greeter

Asked by nixer on 2017-02-15

I am trying to make some modifications to unity-greeter, but I am having trouble compiling/running it.

As I am running Ubuntu 16.04, I got the code from launchpad by running:

    bzr branch lp:unity-greeter/16.04

I then move into the directory and run:

    ./autogen.sh
    make

From this the unity-greeter executable is in the src directory, however, when I try to run it, the following happens:

    ./unity-greeter --test-mode
    [+0.00s] DEBUG: unity-greeter.vala:536: Starting unity-greeter 16.04.3 UID=1000 LANG=en_US.UTF-8
    [+0.00s] DEBUG: unity-greeter.vala:539: Setting cursor
    [+0.00s] DEBUG: unity-greeter.vala:553: Loading command line options
    [+0.00s] DEBUG: unity-greeter.vala:578: Running in test mode
    [+0.00s] DEBUG: unity-greeter.vala:581: Setting GTK+ settings
    [+0.01s] DEBUG: unity-greeter.vala:604: Creating Unity Greeter
    [+0.01s] DEBUG: Connecting to display manager...
    [+0.01s] WARNING: Unable to determine socket to daemon
    [+0.01s] WARNING: Unable to determine socket to daemon
    [+0.01s] DEBUG: unity-greeter.vala:653: Starting main loop

And then the executable just hangs, that is, nothing further happens and no window opens. If I try to run test mode on the executable in /usr/sbin/ I get the test mode for the greeter without any issues. In both cases though, I get a warning "Unable to determined socket to daemon".

I noticed, however, when I ran:

    bzr builddeb -- -us -uc

That I would this in the output:

    libGL error: No matching fbConfigs or visuals found
    libGL error: failed to load driver: swrast

I have done some searching on this issue, and I came across this:

http://askubuntu.com/questions/541343/problems-with-libgl-fbconfigs-swrast-through-each-update

I do have an nvidia card in my laptop, though unfortunately this information wasn't of any help. Running utilities like glxgears didn't provide any of the debugging output I was hoping to get, nor did re-installing the drivers fix the issue.

Despite the libGL errors, if I navigate into the build-area/tests folder and run unity-greeter-test, I can see the greeter come up with the various tests being performed on it.

How can I begin to compile unity-greeter properly so that I can actually get it to display when I try to test it?

UPDATE 1:

When looking at the generated C code, it looks like nothing happens once 'gtk_main()' is called.

UPDATE 2:

I installed the dependencies to build on a freshly setup virtual machine, and went through the process of running ./autogen.sh and then make again. Unfortunately the results are the same.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu unity-greeter Edit question
Assignee:
No assignee Edit question
Solved by:
nixer
Solved:
2017-02-18
Last query:
2017-02-18
Last reply:
nixer (nixer) said : #1

Turns out this was just a version issue. I reverted from 16.04.3 to 16.04.2 and I was able to get things working.