How can I enable the system ready sound in Ubuntu 12.04?

Asked by John Hagerman on 2012-06-05

Running Ubuntu 12.04 alt AMD64.
Acouple of upgrades ago the "system ready" sound (drums) disappeared. I can find all kinds of instructions on how to remove that sound, but none on how to enable it.
In my laptop running Ubuntu 12.04 i386 I can have all the sounds, but I can disable them if necessary. In my desktop, where the system ready sound is useful, I can't find out how to enable it, even though it is in Ubuntu Sounds.
By the way, the "email has arrived" sound in Thunderbird returned today - after at least a year's absence! Did I accidently enable it while looking for a way to start "system ready" or did it arrive with the huge number of updates over the weekend?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu unity-greeter Edit question
Assignee:
No assignee Edit question
Solved by:
John Hagerman
Solved:
2012-12-07
Last query:
2012-12-07
Last reply:
2012-06-08

If you go into the startup items, make a new item and fill it in as the following:

Name: GNOME Login sound
Command: /usr/bin/canberra-gtk-play –id=”desktop-login” –description=”GNOME Login sound”
Comment: Startup Sound

Personally I hate all those worthless beeps and so-on but that is the command ran for the startup sound.

John Hagerman (handj949) said : #3

Nope! I have that "Login" sound.
What I want is the "system ready" sound, which lets you know the system is ready for you to enter your password. In other words, the somewhat useful sound in a home desktop!

Sam_ (and-sam) said : #4

Login sound is the sound after login to desktop.
System ready sound is the sound when display manager (aka login window) is ready.
Display manager may be GDM, LightDM or others.

Ubuntu uses lightdm as standard dm and unity-greeter as greeter.
Install dconf-tools, then alt+f2, run dconf-editor.
Go to
com.canoncial.unity-greeter - enable 'play-ready-sound'. Reboot and test.

John Hagerman (handj949) said : #5

I thought I had replied to this post, but I don't see it here now.
I installed dconf editor and went to:
com.canoncial.unity-greeter - enable 'play-ready-sound', found it already checked, unchecked it, rebooted, went to it again, re-checked it, rebooted, still no 'ready sound'.
Anyone have another idea I can try?

Sam_ (and-sam) said : #6

Sound effects are enabled (sound preferences) and the file system-ready.ogg exists? Just to say compare differences with the laptop or rather which changes have been made on desktop pc.

John Hagerman (handj949) said : #7

Interesting idea - took a lot of time. I found many differences between file systems in the AMD64 desktop and the i386 laptop, some due to different applications installed, some unexplained.
I did find one thing that baffled me. In both /user/share/sounds there are the usual directories, but AMD64 also has a full set of mono sound files there(including system-ready.ogg). There is also a full set of stereo sound files in /user/share/sounds/ubuntu/stereo, but the system-ready file in there is a link and is named system-ready-disabled.ogg.
I suspect that's my problem, but I can't figure out how to replace that link with anything that would remove "-disabled". I can't rename it or send it to trash, or replace it. I have some ideas I'm afraid to try, so .... Help!

Sam_ (and-sam) said : #8

It is not
/user/share/sounds/ubuntu/stereo
it's
/usr/share/sounds/ubuntu/stereo

system-ready.ogg is just a link to dialog-question.ogg
You can rename the link as admin:
cd /usr/share/sounds/ubuntu/stereo
sudo mv system-ready-disabled.ogg system-ready.ogg
sudo reboot

John Hagerman (handj949) said : #9

I don't understand
"It is not
/user/share/sounds/ubuntu/stereo
it's
/usr/share/sounds/ubuntu/stereo"

Aside from a slight difference in font size they seem to be the same.

Otherwise, the "disabled" has disappeared from the link, but still no "system-ready" sound at startup.

??

Sam_ (and-sam) said : #10

> a slight difference

John, there is no such directory named 'user' it's 'usr'.
Enter in a terminal:
man hier

or try this page.
https://help.ubuntu.com/community/LinuxFilesystemTreeOverview

> still no "system-ready" sound

Please consider to report a bug.

John Hagerman (handj949) said : #11

Apologies!
Odd how the human brain can fail to see an obvious error - if I had typed in the question instead of pasting, I would probably have caught it!
I'll consider reporting a bug - or maybe I'll just forget it.

John Hagerman (handj949) said : #12

Time to close this one,
"system-ready" sound re-appeared some time ago after a series of updates.