Can not remote log into Ubuntu 12.10 from Windows

Asked by Kitkat

Hi all,

I was able to use Win 7 Remote Log in to access my Ubuntu PC in the loft.

After upgrading I can not log in remotely from Windows 7. I have tried variations on the Remote Desktop...

This one worked on ubuntu 12.04 - Sesman xvnc - no longer works. It comes up "Failed to load session Ubuntu 2D"

In fact nothing works. Have tried to install VNC Viwer for Windows and my Ubuntu machine does not respond.

I have checked the Ip Address is correct and I have been using the same credentials that I had previously used.

Any ideas please?


Question information

English Edit question
Ubuntu unity-2d Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

Unity2D was removed from Ubuntu in Quantal. I suggest you install xfce4 and use that session

Revision history for this message
Kitkat (davejlkemley) said :

Ok sorted it.

You just need to set up the Desktop Sharing and make a note of my computer name on the Ubuntu 12.10 PC:
1. dash - Type in "Desktop Sharing"
2. Click on Desktop Sharing
3. Tick Settings -
   Allow Users to View
   Allow User to Control your Desktop
   Require Password - set a password (remember this for later)
   Notification - what ever you like
4. Close window
5. To get the computer name click on the top right hand icon - Slect About This Computer. (Make a note of the computer name)

On Windows 7 PC
1. Click on Start - Search Box - Type in "Remote Desktop Connection"
2. Select "Remote Desktop Connection"
3. Put Ubuntu PC name in "Computer"
4. Edit the username and password to that of your standard Ubuntu login
5. Click on "Connect"
6. Change "Module" to "vnc-any"
7."IP" should have the Ubuntu PC name in there (or IP address if you know it)
7. Port should be "5900"
8. Password is the one you put in the Ubuntu Desktop Sharing box above in line 3.
9. Click on ok.

You should now be able to connect. It's not as good as Ubuntu 12.04 when I used to use "sesman-xvnc". There's more lag on the mouse and the screen does not auto resize but it's more than good enough for admin purposes.