Question mark instead of Dash Home icon in Unity 2d

Asked by Murzillo

Ubuntu 12.04
Unity 2d
Intel Celeron CPU 1,7Ghz
Memory 1 Gb
ATI Mobility Radeon RV100

1. Previously - no problem even in this legacy configuration.
2. After the last Unity update (to version 5.16.0) everything works OK in 2d on my notebook except for the question mark instead of the Dash Home icon in the Launcher. Reinstalled all Unity packages - no luck, got back to previous version (5.14) - no luck, changed theme - no luck. Let me stress, that Unity 2d remained fully operational but this graphical bug slightly irritates me. Checked the icon file itself, it is in the right place - /usr/share/unity/5/launcher_bfb.png . Would be obliged if somebody could help me to solve this problem. Thanks.

Question information

English Edit question
Ubuntu unity-2d Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

Try using Ubuntu-tweak or myunity to set a different icon theme.

Revision history for this message
Murzillo (murzillo) said :

Thank you for your answer, actionparsnip. But that had been the first my step before I wrote my question. No result. Every icon changes when switching on any new icon theme except for this very icon in question. I used Ubuntu-Tweak, because MyUnity is next to useless in case of Unity 2D. Only when I tried to apply "gnome" icon theme, instead of a "question mark" there was a "sheet of paper" icon. Any other icon theme in Ubuntu-Tweak - "question mark" in Dash Home place.

Revision history for this message
Murzillo (murzillo) said :

I guess the problem is with some bug in this experimental version of Unity-2d (5.14), after rolling back to Unity-2d stable (5.12) everything is OK now.

Revision history for this message
Niccolò Canestrari (niccolo-canestrari) said :

Hi I just noticed what is the bug. unity-2d-shell during the loading process search for


instead of


to fix it you can

cd /usr/share/unity ; sudo ln -s 5 6

or you can as you did rollback to the stable version.