Cannot run Ubuntu OS since removing Unity-2d

Asked by L-Bit

Ubuntu 12.04 64bit Desktop
After repeated spontaneous error messages relating to Unity-2D, I thought I would remove the problem by removing Unity-2D. Upon restart, cannot access Ubuntu. I can still open Windows 7 and can run Ubuntu from a pen drive.

I have tried all the various options offered at startup with no change in the result. After loading I get an error box stating "failed to load session ubuntu" with keyboard and mouse disabled. In recovery mode 'failsafex' will not proceed as the drivers for keyboard and mouse aren't running. Other options will lead me to a bare desktop with logon box, but the "failed to load" response is the result.

If I try re-installing (without the reformatting) I am offered list of confusing partitions which I have no idea how to manage without the risk of endangering my personal files. (I can't take a screen shot of this but if it is very important I can take a photograph)

I just want to get things back the way they were. I cannot seem to run Terminal from the Pendrive. I am too much a novice to locate ALL my files and back them up.


Question information

English Edit question
Ubuntu unity-2d Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

on the login screen press CTRL+ALT+F1 and log in there and run:

sudo apt-get install unity-2d

Then press CTRL+ALT+F7 and log in to Unity2D session

Revision history for this message
L-Bit (albertfromnz) said :

Thank you. I can breathe again