Can I disable ufw completely

Asked by Ian Brownlie on 2008-05-16

        Every time I boot up my computer since upgrading to ubuntu hardy, I've got no internet, browsers don't work, nor transmission. I have to open a terminal and disable ufw. Can I disable ufw completely? It really is becoming a pain. Other than that I love 'hardy'.
        Ian

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ufw Edit question
Assignee:
No assignee Edit question
Solved by:
Matt Darcy
Solved:
2008-05-16
Last query:
2008-05-16
Last reply:
2008-05-16

Try putting the ufw disable command in the /etc/rc.local file to see if ufw is disabled at boot-up.

Ian Brownlie (ibrownlie) said : #2

  Thanks for your reply Pramod, but I really don't know how to do that.
          Ian

Best Matt Darcy (matt-darcy) said : #3

If you don't want it, you could simpley remove it, which disabled it and removes it from the system.

"sudo apt-get remove ufw"

Ian Brownlie (ibrownlie) said : #4

Thanks Matt Darcy, that solved my question.

Andrew P. (japoth) said : #5

Short of uninstalling it, you can also edit /etc/ufw/ufw.conf with gedit (running as root).

Default contents of ufw.conf:

# /etc/ufw/ufw.conf
#
# set to yes to start on boot
ENABLED=no

If it reads ENABLED=yes in your setup, try changing it to "no" and restart the system. You can check to see if ufw is loaded by typing the following command in a terminal window:

sudo ufw status

Andrew P. (japoth) said : #6

Six months after my last post on 2009-06-01 I discovered that Firestarter is incompatible with ufw, and having both ufw and Firestarter installed blocks access to Windows machines on the LAN. If you've installed Firestarter and the symptom is having to disable ufw every time you boot the system to establish network access, remove it and see if that fixes it.