The package installs an old version (0.8.2-1)

Asked by Handong Choi on 2020-01-17

Hi there,

When I try to install the package in 18.04 LTS by 'sudo apt install uftrace' command, it installs an old version of uftrace which is 0.8.2-1. But as you know the most recent version is 0.9.3-3. I don't know why but I think it needs to be installed with the latest version.

Adding detail:

$ sudo apt install uftrace
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  uftrace
0 upgraded, 1 newly installed, 0 to remove and 42 not upgraded.
Need to get 251 kB of archives.
After this operation, 1,022 kB of additional disk space will be used.
Get:1 http://ap-northeast-2.ec2.archive.ubuntu.com/ubuntu bionic/universe amd64 uftrace amd64 0.8.2-1 [251 kB]
Fetched 251 kB in 0s (917 kB/s)
Selecting previously unselected package uftrace.
(Reading database ... 96426 files and directories currently installed.)
Preparing to unpack .../uftrace_0.8.2-1_amd64.deb ...
Unpacking uftrace (0.8.2-1) ...
Setting up uftrace (0.8.2-1) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
$

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu uftrace Edit question
Assignee:
No assignee Edit question
Solved by:
Bashing-om
Solved:
2020-01-17
Last query:
2020-01-17
Last reply:
2020-01-17
Best Bashing-om (bashing-om) said : #1

Handong Choi ; Hello:

Yes, that is the version that is generally available:
https://packages.ubuntu.com/search?keywords=uftrace&searchon=names&suite=bionic&section=all >>
Package uftrace: bionic (18.04LTS)

"<ubottu> Packages in Ubuntu may not be the latest. Ubuntu aims for stability, so "latest" may not be a good idea.
               Post-release updates are only considered if they are fixes for security vulnerabilities, high impact bug
               fixes, or unintrusive bug fixes with substantial benefit. See also !backports, !sru, and !ppa"

-hope this resolves-

Handong Choi (h3nrychoi) said : #2

Thanks Bashing-om, that solved my question.