Unable to access 53GB Volume

Asked by Rich.b on 2016-09-19

Home built PC running OS 16.04 Ubuntu & Windows Pro 10 - Dual Boot - 8GB ram SSD 120GB HD 500GB.

Since (I think) I inadvertently log in Windows 10 Pro with my Hotmail account I have had this problem, that I could not access the ntfs drives/files from Linux see errors below.

Please advise how I could cure this problem - Thanks for any help -

Kind regards,

Richard

Unable to access 53GB Volume

Error mounting /dev/sda2 at /media/richard/8AA62C62A62C50CD: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000" "/dev/sda2" "/media/richard/8AA62C62A62C50CD"' exited with non-zero exit status 14: Windows is hibernated, refused to mount.
Failed to mount '/dev/sda2': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

Unable to mount “New Volume”

Error mounting /dev/sdb1 at /media/richard/New Volume: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000" "/dev/sdb1" "/media/richard/New Volume"' exited with non-zero exit status 14: The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sdb1': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu udisks2 Edit question
Assignee:
No assignee Edit question
Last query:
2016-09-30
Last reply:
2016-09-30

This question was reopened

Rich.b (aybi30) said : #1

I have since stopped logging in Windows with my Hotmail account but the problem is still there.

It's nothing to do with Hotmail. Just boot to Windows then initiate a shutdown. Once the PC is off, power up and boot to Ubuntu. You will find the NTFS partition is OK.

Manfred Hampl (m-hampl) said : #3

Read the error message:

The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

See also http://discourse.ubuntu.com/t/windows-10-always-shutting-down-in-unsafe-state/2244

Rich.b (aybi30) said : #4

Reset Shut down options in Windows Pro10.

Now I can access the ntfs files OK from Linux.

Thank you Manfred and Andrew.

Rich.b (aybi30) said : #5

Windows Pro 10 has just done update 1607 and my problem has come back.

I sorry but I am not very familiar with Windows.

I know that it is something to do with either fast start up or hibernation but can't remember how to get to the correct settings.

please can you help?

Richard

Manfred Hampl (m-hampl) said : #6

Try this http://www.tenforums.com/tutorials/4189-fast-startup-turn-off-windows-10-a.html#option1
(I hope that this also works in Windows 10-1607.)

Rich.b (aybi30) said : #7

Yes it did, Thank you Manfred

Choose what the power button do, I also switch off fast start up, hibernate, sleep and lock.

I can now access the ntfs files from Linux.

Kind regards,

Richard

Rich.b (aybi30) said : #8

The problem is back, 1 of the 2 ntfs drives has become unavailable. I have repeatedly "Choose what the power button do, I also switch off fast start up, hibernate, sleep and lock." but 1 of the ntfs drives is not available from Linux.

Please advice what to do next.

regards,

Richard

Manfred Hampl (m-hampl) said : #9

What is the exact error message?

If it is
"...The NTFS partition is in an unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting), or mount the volume read-only with the 'ro' mount option..."
Then the solution should be disabling fastboot in Windows.

If it is something else, then running chkdisk from inside Windows might help.

Rich.b (aybi30) said : #10

I have checked again and set shut down with

"Choose what the power button do, I also switch off fast start up, hibernate, sleep and lock"

28/09/16

Error mounting /dev/sda2 at /media/richard/8AA62C62A62C50CD: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000" "/dev/sda2" "/media/richard/8AA62C62A62C50CD"' exited with non-zero exit status 14: Windows is hibernated, refused to mount.
Failed to mount '/dev/sda2': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option

I will check chkdisk soon.

Thank you Manfred

Rich.b (aybi30) said : #11

I have checked chkdisk on Windows pro 10 and no problem found.

I can see and open the hard drive (ntfs) but not the ssd (ntfs) drive or files.

See errors us above this entry.

Kind regards

Richard

Manfred Hampl (m-hampl) said : #12

Error messages is

The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option

This clearly tells that this file system was not fully closed by Windows, but has been kept in a fast-boot mode.

You should try finding out what the name of /dev/sda2 is in Windows terms.

What is the output of
sudo fdisk -l

Rich.b (aybi30) said : #13

Disk /dev/ram14: 64 MiB, 67108864 bytes, 131072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes

Disk /dev/ram15: 64 MiB, 67108864 bytes, 131072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes

Disk /dev/sda: 111.8 GiB, 120034123776 bytes, 234441648 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xef0a0b2d

Device Boot Start End Sectors Size Id Type
/dev/sda1 * 2048 206847 204800 100M 7 HPFS/NTFS/exFAT
/dev/sda2 206848 104366079 104159232 49.7G 7 HPFS/NTFS/exFAT
/dev/sda3 104366080 208523263 104157184 49.7G 83 Linux
/dev/sda4 208525310 234440703 25915394 12.4G 5 Extended
/dev/sda5 208525312 234440703 25915392 12.4G 82 Linux swap / Solaris

Disk /dev/sdb: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0x4d9610dd

Device Boot Start End Sectors Size Id Type
/dev/sdb1 * 2048 157569023 157566976 75.1G 7 HPFS/NTFS/exFAT
/dev/sdb2 157569024 976771071 819202048 390.6G 83 Linux

Rich.b (aybi30) said : #14

I am aware that Windows is in unsafe state.

richard@richard-H81M-S2H:~$ sudo mount /dev/sda2 ro
[sudo] password for richard:
Windows is hibernated, refused to mount.
Failed to mount '/dev/sda2': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.
richard@richard-H81M-S2H:~$

I have retried the correct shut down for Windows as I have done before, but did not make any difference this time or the last time.

I do not understand why this has happened again after the first time when I able to correct it. I assume that Windows has added some updates that has changed this.

Manfred Hampl (m-hampl) said : #15

The command to mount the file system readonly would probably be something like

mount -o uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,ro /dev/sda2 /media/richard/8AA62C62A62C50CD

If you run diskmgmt.msc in Windows, can you identify the drive name that Windows is giving to the partition that Ubuntu calls /dev/sda2 (second one on the ~110 GB disk)?

Rich.b (aybi30) said : #16

  Layout Type File system status Capacity Free space % Free
Disc 0 4 Partitions Simple Basic - Healthy Primary Partitions 49.27GB 49.67GB 100
Disc 0 “ “ “ - Healthy Primary Partitions 12.36 12.36 100
Disc 1 “ “ “ - Healthy Primary Partitions 390.63 360.63 100
Disc 0 C “ “ ntfs Healthy, Boot, Crash Dump,Primary Partition 49.67 17.82 36
Disc 1 New Volume “ “ ntfs Healthy, Page File, Active Primary Partition 75.13 29.79 40
Disc 0 System Reserved “ “ ntfs Healthy, System, Active Primary Partition 100mb 66mb 66

Sorry about the format, hope you can follow it

Kind regards,

Richard

Manfred Hampl (m-hampl) said : #17

As far as I can match the figures, /dev/sda2 is the C drive in Windows.
How do you switch from Windows to Ubuntu?

Rich.b (aybi30) said : #18

I always shut down Window Pro 10 never hibernate.

Then I need Linux I would boot up Ubuntu 16.04, I usually never use restart.

I hope this will help you.

kind regards,

Richard

Manfred Hampl (m-hampl) said : #19

Can you re-check that the fastboot setting is not enabled again in the Windows power settings?

Can you try forcing a complete shutdown in Windows by the following way:
Open a command prompt and execute
shutdown /s /t 0
(maybe you have to use Admin command prompt for this)
Afterwards boot Ubuntu, can you now mount the Windows partition?

Rich.b (aybi30) said : #20

Tried "shutdown /s /t 0" without ""

Can see no change and cannot access 53GB disk 0 drive "C" boot 49.67gb from Linux.

but can access "New Volume" disk 1 75.13gb from Linux

Manfred Hampl (m-hampl) said : #21

This might be a bug in Windows, can you post that in a Windows support forum, too?

Rich.b (aybi30) said : #22

I will try that, Thanks again for your help, I will let you know the out come.

Can you help with this problem?

Provide an answer of your own, or ask Rich.b for more information if necessary.

To post a message you must log in.