How to get Novatel Wireless Ovation MC930D USB 3G Modem to work in Ubuntu 9.04 (Jaunty)

Asked by Tom on 2009-08-13

HI :)

I have a normal LAN that i usually use for internet connection. Is it possible to also use a wireless dongle to connect? I want to try to get this wireless dongle working on my machine so that i have some confidence about getting it working on a completely different machine tomorrow.

Thanks and regards from
Tom :)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu udev Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2009-08-13
Last query:
2009-08-13
Last reply:
2009-08-13

Hi Tom,

According to this list

https://wiki.ubuntu.com/NetworkManager/Hardware/3G

your modem should work, but you first need to manually switch it from storage (USB flash drive) mode to 3G modem mode.

Try the instructions here:

https://bugs.launchpad.net/ubuntu/+bug/281335

Regards,

Mark

Rob Frerejean (hffrerejean) said : #2

http://www.novatelwireless.com/index.php?option=com_content&view=category&layout=blog&id=3&Itemid=10#

On the right side click on data sheets. There you´ll find your 930D. At
the bottom of the document it says it works in Linux too.

Rob

Tom (tom6) said : #3

Hi :)

Thanks Mark & Rob :) So i just need to 'eject' the storage device?

Regards from
Tom )

Hi Tom,

You need to test it, as I have never used your specific 3G modem myself.

But yes, I think you need to eject it using the command

sudo eject /dev/sr0

After ejecting it, try connecting using NetworkManager.

Regards,

Mark

Tom (tom6) said : #5

Hi :)

Thanks :) that eject command worked :) It brought up a wizard "New Mobile Broadband Connection" so i selected contract and now it's asking to unlock the keyring "Enter password for dfault keyring to unlock". I am fairly sure i haven't set up a keyring although i don't know what that is. Is the password one on my machine or is it set-up by O2?

Thanks so far, bit stuck how to proceed.
Regards from
Tom :)

Tom (tom6) said : #6

Hi again

When i type "net" into the command-line and double 'click' the tab key i see only

net netcat net.samba3
netapplet netdaemon netscsid
netapplet-forward netdiscover net-snmp-config
netapplet-startfwd netkit-ftp netstat
netapplet-stopfwd netline network-admin

 - no networkmanager? Is this a side-issue? I could reboot into a dual-boot i have with a fresh install of Ubuntu 9.04 on my new hard-drive. I'm just using the old one in case i break something ;)

Thanks so far and regards from
Tom :)

Try entering

web

as keyring password

when it asks the question: "Enter password for default keyring to unlock"

See

http://www.betavine.net/bvportal/forums/index.html?threadId=ff8080811e01c363011e0ee788784e18&postId=ff8080811e174fe7011e25c961b75ef7

for details.

Tom (tom6) said : #8

HI :)

I tried "web" but the same box just re-appeared. I tried "web" a 2nd time with the same result so i tried my normal user password at which point the dialogue box completely vanished taking the wizard away too. I tried unplugging the usb-device and then plugged it in again, tried the eject command but the wizard still didn't reappear. Can i bring the wizard up from the command-line?

Also although i do have a network connection icon on the top taskbar between my volume control and the time&date i can't right click on it. When i left-click i get a dialogue/info box showing my eth1 connection, it doesn't show eth0 which isn't plugged into anything - when i click on the "Configure" button i get an error message saying "The interface does not exist". I tried reinstalling networkmanager eariler but still get the same result. Is this a side issue?

Thanks so far
Regards from
Tom :)

Tom (tom6) said : #9

HI :)

Arocheste gave me a good link for the settings i will probably need after this stage

* Phone Number: *99***1#
* Initialization String 2: AT+CGDCONT=1,"IP","mobile.o2.co.uk"
* Username: o2web
* Password: password

Also this blog link
http://www.bjw.me.uk/
has some interesting stuf at the bottom but all completely beyond me right now. An interesting way of cycling across town too - generally i stick to the roads rather than cycling along the tops of fences and i've never cycled on a roof either!

Try unplugging the usb wireless dongle, reboot your pc, reconnect the dongle after the Ubuntu desktop is fully loaded, run the eject command. Then try deleting any existing mobile boradband profile in NetworkManager and create a new one. Then try connecting. If that does not work, I don't have any further advice for the moment, sorry.

Tom (tom6) said : #11

Thanks Mark Rijckenberg, that solved my question.

Tom (tom6) said : #12

Mark, you are a total star!!! :)))
Thanks for sticking with me there. It works! I'm using it right now :))
My LAN is unplugged yet i'm still able to post into here :)
Fantastic. Maybe the boat-trip wont be so bad after-all :)
Thanks and regards from
Tom :)