How do I mount USB devices? 11.10

Asked by R Duczmal on 2011-11-06

Along with the other problems I've have with this release it will not mount any USB device, flash drive, external hard drive or camera. When I try I do not have permission. I suppose I need to do command line 'sudo' but whats the command?


Question information

English Edit question
Ubuntu udev Edit question
No assignee Edit question
Last query:
Last reply:
Chris (fabricator4) said : #1

USB devices should automount, but there's been a few cases after an upgrade to 11.10 where some settings are confused and it doesn't work.

To mount the device you need to know it's device name. Type

sudo fdisk -l

And look for the device of the correct format and size. Make a note of it's device name. use the following command to try mounting it:

sudo mount /dev/sdx1 /mnt

This will mount the device on /mnt. You should change sdx to sdc or whatever the correct device name is. This may not show up automatically on the launcher since it is mounted as /mnt and not in the /media directory. You can get to it with file browser however.


R Duczmal (others-7) said : #2

Its a pain but it mounted now how do I unmount? Tried 'sudo unmount .dev/sdx1 /mnt' but the system had a fit.

Chris (fabricator4) said : #3


Close. To unmount a drive mounted on /mnt you can do:

sudo umount /mnt

It's a puzzle why it's not working properly though. Possible solutions might be to re-install the module responsible for finding and mounting USB storage devices. I'll see if I can find out what it's called.

There was also a problem going back a few years that was caused by the floppy driver module being loaded and used incorrectly. Just in the off-chance that this is that problem go into the BIOS for your computer and disable any legacy floppy devices and see if that helps the problem


delance (olivier-delance) said : #4

The module is called udev.
Could you provide end of file /etc/fstab.
On USB disk icon, do you have in contextual menu an option to "remove safely" ?

R Duczmal (others-7) said : #5


'Sudo unmount /mnt' returns the message ;unmount 'command unknown'


# /etc/fstab: static file system information.
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
/dev/sda1 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
#UUID=e36dcb92-45b2-4278-920d-354d05b59aba none swap sw 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
/dev/mapper/cryptswap1 none swap sw 0 0

The icon shows up in dash but is grayed out 'eject' and 'remove safely' are both in the context menu but neither work. Also the icon only appears for flash drives and the camera but not for external hard drives as Chris said would be the case. At least I can down load camera pic and save important files now.


Chris (fabricator4) said : #6

Ah, that's an easy mistake to make. It should be umount, not unmount. I know it doesn't make complete sense, but there's probably some perfectly good reason for it that made sense at the time, way back when...


Chris (fabricator4) said : #7

By the way, did you have any luck disabling floppy controllers and/or legacy floppy support in BIOS? It seems that there may be some kind of conflict that might be causing the problem. Another solutions that seems to suggest itself is to completely remove and re-install the udev module. I'm tying to work out if that's a good idea or not.


delance (olivier-delance) said : #8

delance@delance-desktop:/etc$ sudo udisks --monitor
[sudo] password for delance:
Monitoring activity from the disks daemon. Press Ctrl+C to cancel.
# key insertion manual comment by myself
added: /org/freedesktop/UDisks/devices/sdg
added: /org/freedesktop/UDisks/devices/sdg1
job-changed: /org/freedesktop/UDisks/devices/sdg1
changed: /org/freedesktop/UDisks/devices/sdg1
job-changed: /org/freedesktop/UDisks/devices/sdg1
# key removal manual comment by myself
removed: /org/freedesktop/UDisks/devices/sdg1
removed: /org/freedesktop/UDisks/devices/sdg

What did you get when you insert and remove physically a USB stick ?
( there is also a command sudo udevadm monitor more verbose at a lower level).

R Duczmal (others-7) said : #9


Doh! I should learn to read what it says not what I think it says. I did disable the floppy in BIOS but no joy.


The icon shows up in dash, grayed out, clicking on it does nothing, it used to show up in 'places' menu when there was such a thing but now doesn't appear anywhere. If mounted as Chris suggested it shows up in /mnt but the icon disappears from dash. If removed without mounting then the icon just disappears.


delance (olivier-delance) said : #10

Hello, I'm unstacking old questions. Could you tell me if you succeeded to solve it.

R Duczmal (others-7) said : #11

Hi Delance,

I can mount and unmount using the work around you provided, thank you. Automount is still broken even after the last security etc update so I still consider it a problem that needs a solution but will not pursue that issue. I'm just happy that the security Nazis didn't stick me with one of those convoluted 'pita' [rather pain in the typing finger] passwords The last update sent me back to square one with problems such as grub not loading but sitting in the 'Purple Screen of Oblivion' [same as windows Blue Screen of Death] so I need to re-edit grub again. At this point I have no faith in Ubumtu, seeing no hope of decent working system in their visionary but short sighted attempt to degrade a mostly working PC system into a Cell Phone OS.

Raspberries to the boss.

Don't get me wrong, you guys that help the onerous ocelot stricken and do the nuts and bolts work are still heroes but blind-siding people like this indicates someone higher up needs an enema. I have been advised to just blow Uborktu away and try some other distro. Not WinDoh!s

P.s. that boingy thing dash does is really annoying!! and slow and inefficient. :P

Chris (fabricator4) said : #12

Did you upgrade to 11.10 from a previous version? If so, then considering the range of nasty problems you're seeing then it might be time to re-install from scratch. The more highly configured the system is before the upgrade the more likely you'll see configuration problems after an upgrade. Unfortunately it's the upgrade process that seems to be causing the biggest headaches.

If you re-install most of your problems like automounting should be fixed. (and security updates should not break the system in any way)

If you haven't already done so, consider setting up a separate /home partition and re-installing rather than upgrade, especially if you want to install new releases as they come along.


R Duczmal (others-7) said : #13

It was upgraded from 11.04 and done over the net and yes I had a feeling that was not optimal. Okay I'll bite, I have DL the .iso and will burn a disk to reload from. First , now that USB drives can be mounted/umounted, back up, back up, back up. This will take a while.

Read about the separate /home partition some place but need to review it.

Wish me luck, if I have none then at least I'll have some practice reloading OS's for what ever is next.

P.s. still hate that boingy thing dash does though

Chris (fabricator4) said : #14

Make sure you check the MD5sum of your downloaded ISO:

It only takes minute, but can save you hours of heartache if it later turns out that the download was damaged in some way. For the same reason burn the liveCD at the slowest possible speed, or use make a LiveUSB instead. These days most of my installs are done with a USB pendrive.

These instructions for setting up a separate /home are for an older version, but still quite good if you can translate them to new install without too much trouble:

I normally recommend 15-20 Gb for the / (root) partition which should be ample unless you want to install every piece of software in the repositories. My / normally stays below 10Gb even though I've got a bit installed.

The "boingy thing the dash does" had me a bit puzzled since mine doesn't do anything that I'd call "boingy": it just opens instantly when needed. Then it occurred to me that you might have wobbly windows enabled in compiz. One of the dangers of upgrading from (say) 10.10 to 11.04 is that things that were valid in 10.10 may cause problems for 11.04 - mostly compiz stuff like wobbly windows.

A clean install should hopefully stop your dash from being "boingy", but if it comes back it might be because of some compiz settings that get copied over with your home folder when you restore. This should be fixable.


Can you help with this problem?

Provide an answer of your own, or ask R Duczmal for more information if necessary.

To post a message you must log in.