Ubuntu Customization Kit Issue

Asked by CT_Daemon

(Included in the end is a copy of the build.log file)
This is my situation: I am trying to use the Ubuntu Customization Kit to create a custom LiveCD of Ubuntu 9.04, and I have used both the latest version from Launchpad and from SourceForge. However, when the CLI tries to mount certain images, it gets an error (error=32). Please help me here because I'm currently learning how to program for Linux, but I don't know how to solve this problem on my own. By the way, I am using the official 9.04 .iso image from Ubuntu's website. If possible, I would also like to use this for a customization of BackTrack 4 (which runs on an Ubuntu base). Thank you for your help.

Ubuntu Customization Kit 2.0.8
Starting CD remastering on Sat Oct 3 19:19:38 AST 2009
Customization dir=/home/user/tmp/customization-scripts
(Omitted due to length)
Mounting ISO image...
Unpacking ISO image...
Unmounting ISO image...
Removing remastering root dir...
rm: cannot remove directory `/home/user/tmp/remaster-root/tmp/.X11-unix': Device or resource busy
Mounting SquashFS image...
Unpacking SquashFS image...
Unmounting SquashFS image...
Removing win32 files...
mount: mount point /home/user/tmp/remaster-root/proc does not exist
Failed to mount /home/user/tmp/remaster-root/proc, error=32
mount: mount point /home/user/tmp/remaster-root/sys does not exist
Failed to mount /home/user/tmp/remaster-root/sys, error=32
mount: mount point /home/user/tmp/remaster-root/dev/pts does not exist
Failed to mount /home/user/tmp/remaster-root/dev/pts, error=32
(Note that I placed 'user' in place of my actual user name, for privacy reasons.)

Once again, thank you for your help in this matter.

Question information

English Edit question
Ubuntu uck Edit question
No assignee Edit question
Solved by:
Anton Tolpeev
Last query:
Last reply:
Revision history for this message
Best Anton Tolpeev (anton-tolpeev) said :

Mount errors you can solve with commands

sudo mkdir /home/user/tmp/remaster-root/proc
sudo mkdir /home/user/tmp/remaster-root/sys
sudo mkdir /home/user/tmp/remaster-root/dev/pts

Let me know if it's solve all your problems. :)

Revision history for this message
CT_Daemon (ctdaemon) said :

So far so good. I made the directories (had to put 'sudo mkdir /home/user/tmp/remaster-root/dev' before I put '.../dev/pts')
Currently still building, but it is currently working with the language packages now, so I believe it solved it. Thanks!