Ubuntu One Login Fails

Asked by Charles Curley on 2009-11-20

I tried using Ubuntu One (UO). On Karmic, Applications-> Internet-> Ubuntu One. The hard drive did its thing for a while, and eventually the login page (https://login.launchpad.net/+openid) appeared. It asked me if I wanted to sign in as myself. I clicked on "Sign In". I got the same page over again.

Cookies are permitted for launchpad.net, and there is no cookie entry for login.launchpad.net. I was logged in to launchpad at the time.

The UO application is running, and reports that I am disconnected, presumably from the server. If I left-click on the widget and click on "Connect" it fails silently.

Neither /etc/log/messages nor /etc/log/syslog shows anything.

Something, presumably the UO client, seems to have created a directory, ~/Ubuntu One, and a UO tree under ~/.local.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntuone-client Edit question
Assignee:
No assignee Edit question
Solved by:
Charles Curley
Solved:
2009-11-25
Last query:
2009-11-25
Last reply:
2009-11-24
Soul-Sing (soulzing) said : #1

Try to login without openid.( username and pass) Then close firefox, without login out! try it again, open firefox with openid and your ok now.

Charles Curley (charlescurley) said : #2

I don't have an opeid account.

Jeruvy (jeruvy) said : #3

Then do not sign in via OpenID. Use the normal login.

Charles Curley (charlescurley) said : #4

Well, doh!

I'm trying to use whatever login the UO application hands me. If it incorrectly hands me an OpenID login page, it's broken.

I tried https://wiki.ubuntu.com/UbuntuOne/Tutorials/Subscriptions, and got the same broken login.

What "normal login" did you have in mind?

Jeruvy (jeruvy) said : #5

Well pick one, and lets work with that. I have a launchpad account which Ubuntu One 'rightly' detects and then verifies for me, and I'm able to log in with the same credentials.

Since I cannot mind read if this is your problem or not, I'd rely upon you to not be do 'doh!' and simply explain what is working or not. Leoquant suggested you try this via openid, and you explained you did not have one. So use 'what works'.

Choice however is all yours.

But if you'd like some clear answers, try to be clear about what you are doing so we 'know'. Thanks.

Charles Curley (charlescurley) said : #6

Sorry if that "doh!" came across as nasty. I had tried every way I could to get a normal login, and nothing worked. Hence the last question.

I seem to have solved the problem by logging in from another computer, a fresh installation of Karmic. The problematic one is an upgrade from Jaunty to Karmic. But that isolates the problem to that computer. So I'll mark this as solved.

Thanks for the help.