Unable to unsync a folder in UbuntuOne

Asked by JamesH on 2011-05-26

I accidentally tried to sync a folder that was much bigger than standard 2GB. The 2GB is now full, but because I still have 10000 files still to sync (said it was much too big..), I am unable to tell UbuntuOne, either from desktop or web interface, that I want to unsync the folder.

If I disconnect using the UbuntuOne dialog, then reconnect, it just says it still have a load of files to resysnc and tries to do it. There doesn't seem to be any way to stop it trying to sync these files, and it appears that until they are synced, I cannot unsync the whole folder.

For example, in Nautilus, when selecting the Ubuntu menu there isnt a Stop Syncing folder options. On the web IF, there is also no option to stop syncing.

Any ideas?

James

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntuone-client Edit question
Assignee:
No assignee Edit question
Solved by:
JamesH
Solved:
2011-05-30
Last query:
2011-05-30
Last reply:
2011-05-26
wojox (wojox) said : #1

Open a terminal and run:

u1sdtool --list-folders

Copy the ID of the folder you want to stop synchronizing.
In a terminal session run (replacing ID-COPIED-FROM-STEP-2)

 u1sdtool -q; u1sdtool --start; u1sdtool --delete-folder=ID-COPIED-FROM-STEP-2; u1sdtool -c

JamesH (jnahughes) said : #2

Thanks wojox.

Think that may have solved the problem. I was a bit confused at first, because the delete stage took quite some time and I thought it had hung. Left while put sprogs to bed and when I got back a --waiting command showed the delete had finished.

Thanks.