Ubuntu One client fails to detect Mobile Broadband connection

Asked by Chu on 2011-05-16

Ubuntu Natty Narwhal 11.04, upgraded from Maverick Meerkat 10.10

I use an MTS Mobile Broadband modem for internet use which uses CrossplatformUI as a client for connection rather than Ubuntu's native Network Settings. Though I am connected to the internet, capable of surfing and downloading, Ubuntu One client fails to detect the connection and doesn't let me Sign In or Register, giving me an error, "An internet connection is required to join or sign in to Ubuntu One". Strangely enough, I've never experienced that problem with Dropbox.

I have plenty of documents stored onto Ubuntu One storage via my netbook, and thus am unable to access them to my desktop due to the error. What is the possible fix for this?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntuone-client Edit question
Assignee:
No assignee Edit question
Solved by:
Chu
Solved:
2011-05-21
Last query:
2011-05-21
Last reply:

New to Ubuntu: read the Ubuntu Manual, it's very informative:
http://ubuntu-manual.org/
Click on the "download Button" to download the latest PDF version.
The online help https://help.ubuntu.com/10.10/index.html

Ubuntu guide (For learning more about command lines)
http://www.ubuntupocketguide.com/index_main.html

The new 11.04 Unity interface:
http://www.omgubuntu.co.uk/natty/#what
http://theravingrick.blogspot.com/2011/04/my-effort-at-writing-help-for-unity.html

Relax and fun:
http://planet.ubuntu.com/ and Full Circle Magazine
http://fullcirclemagazine.org/

Chu (tushantin) said : #2

Thanks! Solved the problem, sort of. Just configure Mobile Broadband and copy/paste #777 with the username and password and it works (though it takes about a minute to connect, which is long). But I still don't understand why Ubuntu One doesn't work when connected with MTS Client rather than Network applet...