Command line format for ubuntuone-sso-client-login

Asked by Patrick Dickey

Hello there,

I'm trying to install Ubuntu One on a Fedora 16 computer, by following the instructions given here ( and in his references (to fix his errors). I'm at the step where it says enter /usr/lib/ubuntuone-sso-client/ubuntuone-sso-client-login && .... and it's hung up. I'm assuming that it needs more information (such as my email address/password) but I'm not sure what the format for the command is.

So, my questions are these:

1. What is the format for the command?
2. If it automatically looks in a file for the login information, where is that file located (and is it a plain text file, or generated file)?
3. Is there a command which generates the file (if it's a generated file in #2), and if so, what's the format for that command?

An aside is

Is the Ubuntu One team working on porting this to Fedora or other distributions AT ALL? I mean, I've got an Android phone with it installed, I can install it on my Windows PC/Servers, if I choose, and for all I know, there's an iPhone version (I haven't checked this out). But, I can't install it on Fedora/OpenSuSE/Centros/<insert distribution here>?

Have a great day:)

Question information

English Edit question
Ubuntu ubuntu-sso-client Edit question
No assignee Edit question
Solved by:
Patrick Dickey
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

I suggest you post on a Fedora forum

Revision history for this message
Patrick Dickey (pdickeybeta) said :

In the end, I found my solution. I had to run u1sdtool -c and it would prompt me for the login. However, I ran into another bug (that I'll search for later if they'll accept submissions from people installing it on Fedora). This bug was the Method: CannotFindItem error. I ended up having to delete my keyring from gnome2/keyrings, and then run the u1sdtool -c command. However, if I tried to put a password in for the keyring, I received the "A user pressed the cancel button" message, and had to try again. Not a good thing, IMHO, because it means that at least for the time that you're connecting to your Ubuntu One Account, you're using an unsecured keyring (and from my understanding, this is still an issue on Ubuntu--not just on Fedora).

Thanks for your help though, and have a great week.:)