how to open .wmv files

Asked by sureshkumarjamwal on 2009-12-22

 i am no able to open .wmv files

how can i open it

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ubuntu-restricted-extras Edit question
Assignee:
No assignee Edit question
Last query:
2009-12-22
Last reply:
2010-02-07
Digvijay Patankar (dbpatankar) said : #1

Simply click on the file and totem video player will open. It will ask you to download some extra codecs.
Simply allow it to do so, thats all. It will install the required codecs and then you can play the file.
In any case if its not working then install vlc media player using synaptic package manager.

Digvijay Patankar (dbpatankar) said : #2

Of course, both methods will work only if you have internet connection, otherwise you need to first download it and then install it.

Jan (jancauchi654321) said : #3

Hello there just saw your question. Here is some help.

First of all install Wine (from the Ubuntu Software Center)
Then download Windows Media Player from Microsoft
Configure Wine to run like for example Windows XP (from the applications menu -> Wine -> Configure)
After install normally WMP
Then just double-click Windows Media Player.exe from the Ubuntu desktop when the setup finishes.

Hope this works for you,
Jan

Tiago Faria (gouki) said : #5

Please do not install Wine to play a .wmv file.

As soon as try to open the file with Totem, it should search for the codecs needed. If it doesn't, the solution Oussama gave will also fix your problem.

If you want to do it via Terminal: sudo apt-get install ubuntu-restricted-extras

More information about restricted formats is available at https://help.ubuntu.com/community/RestrictedFormats

Once again, there is no need to install Wine or Windows Media Player. Please ignore that answer.

Tiago Faria (gouki) said : #6

Tiago Faria suggests this article as an answer to your question:
FAQ #3: “Restricted Formats”.

Vikram Dhillon (dhillon-v10) said : #8

As said above, you need restricted formats to play wmv files.

On Sat, Feb 6, 2010 at 3:42 AM, Bounaim Oussama
<email address hidden> wrote:
> Question #94874 on ubuntu-restricted-extras in ubuntu changed:
> https://answers.edge.launchpad.net/ubuntu/+source/ubuntu-restricted-extras/+question/94874
>
> Bounaim Oussama proposed the following answer:
> sudo apt-get install ubuntu-restricted-extras should resolve the problem
>
> or copy this link in your browser(firefox) apt://ubuntu-restricted-
> extras
>
> --
> You received this question notification because you are an answer
> contact for Ubuntu.
>

--
Regards,
Vikram Dhillon

~~~
There are lots of Linux users who don't care how the kernel works, but
only want to use it. That is a tribute to how good Linux is.
-- Linus Torvalds

Play mp3 and dvd under Ubuntu using Medibuntu

First please install https://help.ubuntu.com/community/RestrictedFormats

You need to have extra repositories enabled..

Please first enable the universe and multiverse repository:

Open System → Administration → Software sources → [ Tab Ubuntu software ]

enable "Community-maintained Open Source software ( universe )"
enable "Proprietary drivers for devices ( restricted )"
enable "Software restrictecd by copyright or legal issue ( multiverse )"

Close and confirm the repository reload.

Then open a Terminal from the menu Applications→Accessories→Terminal

Tip: right click with mouse on the terminal title caption and select the item "Always on Top" doing this you will force the terminal window to stay on top of the other windows and you will find very easy to copy single row from this web page into the terminal...
Something more about using the terminal https://help.ubuntu.com/community/UsingTheTerminal

Then type or better copy and paste a row a time then press enter:
(Tip: select the single row to copy then right click into the terminal and to quick paste click with middle button of mouse )

and type or better copy and paste:

sudo aptitude install vlc smplayer mplayer

To get better dvd playback and optional packages here the medibuntu available software list http://packages.medibuntu.org/
you need to add the medibuntu http://www.medibuntu.org/ repository to your /etc/apt/sources.list file:
( here the medibuntu howto https://help.ubuntu.com/community/Medibuntu but see below )

In short please open a Terminal from the menu Applications → Accessories → Terminal and type or copy and paste:

sudo wget http://www.medibuntu.org/sources.list.d/`lsb_release -cs`.list --output-document=/etc/apt/sources.list.d/medibuntu.list; sudo apt-get -q update; sudo apt-get --yes -q --allow-unauthenticated install medibuntu-keyring; sudo apt-get -q update

-- give your user password when requested, you don't see nothing when you type it, then press enter

Now to install, type:

sudo apt-get update
sudo apt-get install ubuntu-restricted-extras libxine1-ffmpeg
sudo aptitude install libdvdread3 libdvdnav4 libdvdcss2 regionset gnome-mplayer
sudo aptitude install non-free-codecs w32codecs
sudo aptitude install gstreamer0.10-pitfdll gstreamer0.10-plugins-good
sudo aptitude install gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse

give your user password when requested, you don't see nothing when you type it, then press enter.

You can also install other Medibuntu repository provided optional software http://packages.medibuntu.org/

Hope this helps

Can you help with this problem?

Provide an answer of your own, or ask sureshkumarjamwal for more information if necessary.

To post a message you must log in.