Unable to play several video formats after upgrading to 9.10 from 9.04

Asked by LEGOManiac on 2009-11-23

There are two 9.10 PCs involved. One was an upgrade from 9.04 and the other is a clean install of 9.10.

On the upgraded machine, all videos played successfully prior to upgrading to 9.10. Post-upgrade, most things don't work.

This applies to Movie Player and VLC.

I have been unable to play DVDs in Movie Player. Movie Player hangs, but does not close. I have to force it to quit.

Flash videos play in my browsers (Opera and Firefox) but when started with either VLC or Movie Player, the application closes without error messages. Nothing is ever displayed, not even briefly.

If I start Movie Player or VLC by themselves, they run. If I use the menu system to locate content (DVD or .FLV) they close. VLC reports that it is unable to decrypt the DVD. Movie Player just closes.

Xine doesn't start at all. It used to prior to upgrading. Xine does not exist on the clean install PC so I haven't tested it there.

Oddly enough (?), avidemux plays the flv files.

I WAS just able to play an AVI file that I had downloaded of the DVD I couldn't play using Movie Player.

I had presumed that since everything worked prior to install, that all my codecs were installed properly and would remain so after an upgrade. Then again, it's not like either application is complaining about a missing codec.

Can any one restore some sanity to my video system?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntu-restricted-extras Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2009-11-24
Last query:
2009-11-24
Last reply:
2009-11-23

sudo apt-get --reinstall install ubuntu-restricted-extras

For DVD playback you will need to add the medibuntu repo and install libdvdcss2

LEGOManiac (bzflaglegomaniac) said : #2

Thanks actionparsnip, that solved my question.

LEGOManiac (bzflaglegomaniac) said : #3

For future reference, to install Medubuntu in 9.10:

sudo wget http://www.medibuntu.org/sources.list.d/$(lsb_release -cs).list --output-document=/etc/apt/sources.list.d/medibuntu.list && sudo apt-get -q update && sudo apt-get --yes -q --allow-unauthenticated install medibuntu-keyring && sudo apt-get -q update