sound noise/not working right -Compaq Presario CQ40 Laptop

Asked by ronnie_libra on 2009-07-20

my laptop compaq presario sounds strange,and my built-in speakers does not work at all...I think i am having problem with sound driver,although kubuntu 9.4 recognize the device, it is not properly working i thing...Any help guys??????Pls...

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ubuntu-restricted-extras Edit question
Assignee:
No assignee Edit question
Last query:
2009-07-20
Last reply:
2009-07-20
Tom (tom6) said : #1

Hopefully it's something simple from early on in one of these two trouble-shooting guides

https://wiki.ubuntu.com/DebuggingSoundProblems

https://help.ubuntu.com/community/SoundTroubleshooting

Good luck and regards from
Tom :)

Hi,

In order to gather essential troubleshooting information about your sound card, please first follow this procedure:

Step 1: Open Terminal from "Applications->Accessories->
Terminal"

Step 2: Run the following 2 commands (copy/paste each command into the Terminal and then hit <enter> after each command)

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh

bash alsa-info.sh

When the alsa-info.sh script asks "Do you want to run this script? [y/n]", press y and then hit <enter> to make sure the script actually runs. Please send us the full terminal output after the script has actually run.

Step 3: Run the following command. The command STARTS with the word cat and ENDS with the word snd. So please copy-paste the ENTIRE command below into a Terminal, press enter, then enter password when sudo asks for password, then press enter again.

cat /proc/asound/cards; sudo aptitude install gnome-alsamixer asoundconf-gtk alsa-utils; asoundconf list; aplay -l; sudo lshw -C sound; ls -lart /dev/snd; cat /dev/sndstat; lspci -nn ; lsmod | grep snd

Step 4: Please post results (copy/paste terminal output) on this thread

Step 5: Please also report on this thread if you cannot hear sound through the speakers, the headphones or cannot hear sound on both.

Step 6: If you are using a dual boot system (with Windows and Ubuntu installed on separate partitions),
then make sure to set the sound volume in Windows to a high level before booting into Ubuntu.
Also make sure to use the special function keys in Windows to make sure the loudspeakers are physically switched ON and working properly in Windows before installing and testing Ubuntu. This step is necessary with certain Toshiba Tecra laptops.

Step 7: Experiment with the audio settings in gnome-alsamixer and asoundconf-gtk until you get sound (hopefully)

Step 8: In System/Administration/Users and Groups , make sure that your user and the root user are members of the following 5 groups:

 pulse
 pulse-access
 pulse-rt
 audio
 video

Step 9: Run the command gnome-volume-control and set the Sound Theme to "No sounds" (Sound Theme is also accessible via System > Preferences > Sound)

Step 10: Try connecting headphones to different audio jacks/ports on the backpanel of the sound card until you hopefully hear sound

======================================================================================================

Please also read the following pages

http://www.ubuntugeek.com/sound-solutions-for-ubuntu-904-jaunty-users.html

http://doc.ubuntu-fr.org/audio_intel_hda (check for correct /etc/modprobe.d/alsa-base.conf options at bottom of this page)

https://help.ubuntu.com/community/SoundTroubleshooting

http://ubuntuforums.org/showthread.php?t=789578&highlight=audacity

for some initial suggestions.

You should add the following string to the /etc/modprobe.d/alsa-base.conf file

options snd-hda-intel model=YOUR_MODEL

Valid model names (that replace YOUR_MODEL) depending on the codec chip, can be found at

http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-jaunty.git;a=blob_plain;f=Documentation/sound/alsa/ALSA-Configuration.txt

If you do not know your codec chip name, you can execute the following Terminal command to find out:

cat /proc/asound/card*/codec* | grep Codec

Each combination of audio codec, audio mixer and audio device name requires a very specific configuration in the alsa-base.conf file, if the audio chipset does not work out-of-the-box.

Make sure to set all channels to high volume levels in gnome-alsamixer.

Make sure all the different speakers (including 'Front', 'Master', and 'PCM") are NOT muted and NOT set to low volume levels in gnome-alsamixer.

If sound still does not work, try upgrading ALSA to the newest version, reboot and retest sound.

ALSA upgrade procedure is here:

http://monespaceperso.org/blog-en/2009/05/09/upgrade-alsa-1020-on-ubuntu-jaunty-904/

Kind regards,

Mark

Can you help with this problem?

Provide an answer of your own, or ask ronnie_libra for more information if necessary.

To post a message you must log in.