Cannot Install Ubuntu Restricted Extras Package

Asked by Martienne on 2009-02-23

I am trying to install the Ubuntu restricted extras package on my new Dell laptop. It starts the installation process, and then halfway through it says that the installation failed. I've tried several times, always with the exact same thing happening. So, how can I install the plugins I need to play my DVD's?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntu-restricted-extras Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2009-03-05
Last query:
2009-03-05
Last reply:
2009-02-26
Andy Ferguson (teknostatik) said : #1

What is the exact message you get when it fails?

Tom (tom6) said : #2

Hopefully this guide should make it easier for you.

https://help.ubuntu.com/community/Medibuntu

In case you're only talking about restricted drivers (although i think it's probably something else) this might help

https://help.ubuntu.com/community/RestrictedDrivers

If you can join in with this project it would greatly help the linux community and hopefully get you some good quality programmes worth viewing
http://www.bbc.co.uk/iplayer/labs

Good luck and regards from
Tom :)

Martienne (martienne-wheeler) said : #3

I am only talking about restricted drivers. I'm doing exactly what this website says to do. Add/Remove Programs -> Other -> Ubuntu restricted extras -> install. It begins the installation process, and when the bar is half-way across it says, "Software installation failed. There has been a problem during the installation of the following pieces of software>" My options are to either retry, close, or add/remove more software.

I just want to play a DVD.

Martienne (martienne-wheeler) said : #4

Tom, your link about restricted drivers says that Intel video cards don't require installed video drivers, because they are pre-installed. Yet, when I try to play a DVD I'm instructed that I don't have the plugins required.

Please first enable the multiverse repository:

Open System → Administration → Software sources → [ Tab Ubuntu software ]
enable "Software restrictecd by copyright or legal issue ( multiverse )"
Close and confirm the repository reload.

Open a Terminal from the menu Applications → Accessories → Terminal and type:
(if the system ask you a password give your user password, you will not see nothing when you type it, then press enter)

sudo dpkg --configure -a

then to update and upgrade and also check pending or missing packages, still using terminal type:

sudo apt-get -f install
sudo apt-get --fix-missing install
sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

sudo apt-get install ubuntu-restricted-extras

Hope this helps

Martienne (martienne-wheeler) said : #6

YES...that worked! Thank you Marcobra!!