do-release-upgrade from 18.04 to 20.04 fails - how to read logs

Asked by Allan W. Macdonald on 2021-03-23

When I run do-release-upgrade, it terminates with the following message on the terminal:

Calculating the changes

Calculating the changes

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

If none of this applies, then please report this bug using the
command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal. If
you want to investigate this yourself the log files in
'/var/log/dist-upgrade' will contain details about the upgrade.
Specifically, look at 'main.log' and 'apt.log'.

Restoring original system state

Aborting
Reading package lists... Done
Building dependency tree
Reading state information... Done
=== Command detached from window (Tue Mar 23 17:23:00 2021) ===
=== Command terminated with exit status 1 (Tue Mar 23 17:23:10 2021) ===

I will post apt.log and main.log

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntu-release-upgrader Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
Last query:
Last reply:

main.log:

2021-03-23 17:22:31,384 INFO Using config files '['./DistUpgrade.cfg.bionic', '/etc/update-manager/release-upgrades.d/system76-third-party-mirrors.cfg']'
2021-03-23 17:22:31,384 INFO uname information: 'Linux AllansLaptop 5.3.0-7648-generic #41~1586790036~18.04~600aeb5~dev-Ubuntu SMP Mon Apr 13 17:49:24 x86_64'
2021-03-23 17:22:31,745 INFO apt version: '1.6.12ubuntu0.2'
2021-03-23 17:22:31,745 INFO python version: '3.6.9 (default, Jan 26 2021, 15:33:00)
[GCC 8.4.0]'
2021-03-23 17:22:31,748 INFO release-upgrader version '20.04.29' started
2021-03-23 17:22:31,752 INFO locale: 'en_CA' 'UTF-8'
2021-03-23 17:22:31,814 DEBUG Using 'DistUpgradeViewText' view
2021-03-23 17:22:31,852 DEBUG enable dpkg --force-overwrite
2021-03-23 17:22:31,875 DEBUG creating statefile: '/var/log/dist-upgrade/apt-clone_system_state.tar.gz'
2021-03-23 17:22:36,068 DEBUG lsb-release: 'bionic'
2021-03-23 17:22:36,068 DEBUG _pythonSymlinkCheck run
2021-03-23 17:22:36,069 DEBUG openCache()
2021-03-23 17:22:36,069 DEBUG quirks: running PreCacheOpen
2021-03-23 17:22:36,069 DEBUG running Quirks.PreCacheOpen
2021-03-23 17:22:36,974 DEBUG Comparing 5.3.0-7642 with
2021-03-23 17:22:36,974 DEBUG Comparing 5.3.0-7648 with 5.3.0-7642
2021-03-23 17:22:37,185 DEBUG /openCache(), new cache size 102445
2021-03-23 17:22:37,186 DEBUG need_server_mode(): can not find a desktop meta package or key deps, running in server mode
2021-03-23 17:22:37,186 DEBUG checkViewDepends()
2021-03-23 17:22:37,187 DEBUG running doUpdate() (showErrors=False)
2021-03-23 17:22:39,462 DEBUG openCache()
2021-03-23 17:22:40,391 DEBUG Comparing 5.3.0-7642 with
2021-03-23 17:22:40,391 DEBUG Comparing 5.3.0-7648 with 5.3.0-7642
2021-03-23 17:22:40,611 DEBUG /openCache(), new cache size 102445
2021-03-23 17:22:40,611 DEBUG doPostInitialUpdate
2021-03-23 17:22:40,611 DEBUG quirks: running focalPostInitialUpdate
2021-03-23 17:22:40,611 DEBUG running Quirks.focalPostInitialUpdate
2021-03-23 17:22:43,136 DEBUG MetaPkgs:
2021-03-23 17:22:46,880 DEBUG no PkgRecord found for 'appmenu-qt5', skipping
2021-03-23 17:22:47,124 DEBUG no PkgRecord found for 'kerneloops-daemon', skipping
2021-03-23 17:22:47,229 DEBUG no PkgRecord found for 'libdouble-conversion1v5', skipping
2021-03-23 17:22:47,451 DEBUG no PkgRecord found for 'libobasis6.2-core', skipping
2021-03-23 17:22:47,451 DEBUG no PkgRecord found for 'libobasis6.4-core', skipping
2021-03-23 17:22:47,475 DEBUG no PkgRecord found for 'libperl5.22', skipping
2021-03-23 17:22:47,518 DEBUG no PkgRecord found for 'libreoffice-style-colibre', skipping
2021-03-23 17:22:47,519 DEBUG no PkgRecord found for 'libreoffice6.2-debian-menus', skipping
2021-03-23 17:22:47,519 DEBUG no PkgRecord found for 'libreoffice6.4-debian-menus', skipping
2021-03-23 17:22:47,519 DEBUG no PkgRecord found for 'libreofficedev6.2-debian-menus', skipping
2021-03-23 17:22:47,677 DEBUG no PkgRecord found for 'linux-image-5.0.0-21-generic', skipping
2021-03-23 17:22:47,679 DEBUG no PkgRecord found for 'linux-image-5.3.0-20-generic', skipping
2021-03-23 17:22:47,680 DEBUG no PkgRecord found for 'linux-image-5.3.0-7625-generic', skipping
2021-03-23 17:22:47,680 DEBUG no PkgRecord found for 'linux-image-5.3.0-7629-generic', skipping
2021-03-23 17:22:47,702 DEBUG no PkgRecord found for 'linux-modules-5.0.0-21-generic', skipping
2021-03-23 17:22:47,704 DEBUG no PkgRecord found for 'linux-modules-5.3.0-20-generic', skipping
2021-03-23 17:22:47,705 DEBUG no PkgRecord found for 'linux-modules-5.3.0-7625-generic', skipping
2021-03-23 17:22:47,705 DEBUG no PkgRecord found for 'linux-modules-5.3.0-7629-generic', skipping
2021-03-23 17:22:47,712 DEBUG no PkgRecord found for 'linux-modules-extra-5.0.0-21-generic', skipping
2021-03-23 17:22:47,713 DEBUG no PkgRecord found for 'linux-modules-extra-5.3.0-20-generic', skipping
2021-03-23 17:22:47,714 DEBUG no PkgRecord found for 'linux-modules-extra-5.3.0-7625-generic', skipping
2021-03-23 17:22:47,714 DEBUG no PkgRecord found for 'linux-modules-extra-5.3.0-7629-generic', skipping
2021-03-23 17:22:47,755 DEBUG no PkgRecord found for 'lodevbasis6.2-core', skipping
2021-03-23 17:22:47,935 DEBUG no PkgRecord found for 'python3-aptdaemon.pkcompat', skipping
2021-03-23 17:22:48,080 DEBUG no PkgRecord found for 'unetbootin', skipping
2021-03-23 17:22:48,081 DEBUG no PkgRecord found for 'unity-webapps-common', skipping
2021-03-23 17:22:48,081 DEBUG no PkgRecord found for 'unity-webapps-service', skipping
2021-03-23 17:22:48,083 DEBUG no PkgRecord found for 'upstart', skipping
2021-03-23 17:22:48,095 DEBUG no PkgRecord found for 'webbrowser-app', skipping
2021-03-23 17:22:48,132 DEBUG Foreign:
2021-03-23 17:22:48,132 DEBUG Obsolete: adobereader-enu:i386 dbeaver-ce firmware-manager firmware-manager-notify firmware-manager-shared gnome-shell-extension-system76-power hidpi-daemon libegl-dev libgl-dev libgles-dev libglx-dev libnm-gtk-common libnma-common libopengl-dev linux-headers-5.3.0-7642 linux-headers-5.3.0-7642-generic linux-headers-5.3.0-7648 linux-headers-5.3.0-7648-generic linux-image-5.3.0-7642-generic linux-image-5.3.0-7648-generic linux-modules-5.3.0-7642-generic linux-modules-5.3.0-7648-generic linux-modules-extra-5.3.0-7642-generic linux-modules-extra-5.3.0-7648-generic linux-system76 system76-acpi-dkms system76-dkms system76-driver system76-firmware-daemon system76-io-dkms system76-oled system76-power system76-wallpapers zoom
2021-03-23 17:22:48,133 DEBUG updateSourcesList()
2021-03-23 17:22:48,143 DEBUG rewriteSourcesList() with mirror_check
2021-03-23 17:22:48,143 DEBUG ['ubuntu-minimal', 'ubuntu-standard']
2021-03-23 17:22:48,143 DEBUG Checking pkg: ubuntu-minimal
2021-03-23 17:22:48,145 DEBUG Checking pkg: ubuntu-standard
2021-03-23 17:22:48,147 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic main restricted'
2021-03-23 17:22:48,147 DEBUG verifySourcesListEntry: deb http://ca.archive.ubuntu.com/ubuntu/ focal main restricted
2021-03-23 17:22:48,147 DEBUG url_downloadable: http://ca.archive.ubuntu.com/ubuntu//dists/focal/Release
2021-03-23 17:22:48,147 DEBUG s='http' n='ca.archive.ubuntu.com' p='/ubuntu//dists/focal/Release' q='' f=''
2021-03-23 17:22:48,237 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal main restricted' updated to new dist
2021-03-23 17:22:48,237 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic-updates main restricted'
2021-03-23 17:22:48,238 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal-updates main restricted' updated to new dist
2021-03-23 17:22:48,238 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic universe'
2021-03-23 17:22:48,238 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal universe' updated to new dist
2021-03-23 17:22:48,238 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic-updates universe'
2021-03-23 17:22:48,238 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal-updates universe' updated to new dist
2021-03-23 17:22:48,238 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic multiverse'
2021-03-23 17:22:48,238 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal multiverse' updated to new dist
2021-03-23 17:22:48,238 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic-updates multiverse'
2021-03-23 17:22:48,238 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal-updates multiverse' updated to new dist
2021-03-23 17:22:48,238 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse'
2021-03-23 17:22:48,238 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse' updated to new dist
2021-03-23 17:22:48,238 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu bionic-security main restricted'
2021-03-23 17:22:48,238 DEBUG verifySourcesListEntry: deb http://security.ubuntu.com/ubuntu focal main restricted
2021-03-23 17:22:48,239 DEBUG url_downloadable: http://security.ubuntu.com/ubuntu/dists/focal/Release
2021-03-23 17:22:48,239 DEBUG s='http' n='security.ubuntu.com' p='/ubuntu/dists/focal/Release' q='' f=''
2021-03-23 17:22:48,443 DEBUG entry 'deb http://security.ubuntu.com/ubuntu focal-security main restricted' updated to new dist
2021-03-23 17:22:48,443 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu bionic-security universe'
2021-03-23 17:22:48,443 DEBUG entry 'deb http://security.ubuntu.com/ubuntu focal-security universe' updated to new dist
2021-03-23 17:22:48,444 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu bionic-security multiverse'
2021-03-23 17:22:48,444 DEBUG entry 'deb http://security.ubuntu.com/ubuntu focal-security multiverse' updated to new dist
2021-03-23 17:22:48,483 DEBUG running doUpdate() (showErrors=True)
2021-03-23 17:22:55,603 DEBUG openCache()
2021-03-23 17:22:56,272 DEBUG Comparing 5.3.0-7642 with
2021-03-23 17:22:56,272 DEBUG Comparing 5.3.0-7648 with 5.3.0-7642
2021-03-23 17:22:56,420 DEBUG /openCache(), new cache size 68359
2021-03-23 17:22:56,421 DEBUG need_server_mode(): can not find a desktop meta package or key deps, running in server mode
2021-03-23 17:22:56,421 DEBUG quirks: running PreDistUpgradeCache
2021-03-23 17:22:56,421 DEBUG running Quirks.PreDistUpgradeCache
2021-03-23 17:22:56,421 INFO checking for python-dbg
2021-03-23 17:22:56,421 INFO checking for python-doc
2021-03-23 17:22:56,421 INFO checking for python-minimal
2021-03-23 17:22:56,421 INFO checking for python-dev
2021-03-23 17:22:56,422 INFO checking for libpython-dev
2021-03-23 17:22:56,422 INFO checking for libpython-stdlib
2021-03-23 17:22:56,422 INFO checking for libpython-dbg
2021-03-23 17:22:57,807 DEBUG Installing 'xserver-xorg-video-all' (Distro KeepInstalledPkgs rule)
2021-03-23 17:22:57,995 ERROR Dist-upgrade failed: 'E:Unable to correct problems, you have held broken packages.'
2021-03-23 17:22:57,996 DEBUG abort called
2021-03-23 17:22:57,997 DEBUG openCache()
2021-03-23 17:23:00,376 DEBUG Comparing 5.3.0-7642 with
2021-03-23 17:23:00,376 DEBUG Comparing 5.3.0-7648 with 5.3.0-7642
2021-03-23 17:23:00,595 DEBUG /openCache(), new cache size 102445

apt.log:

Log time: 2021-03-23 17:22:37.181872
Log time: 2021-03-23 17:22:40.599170
Log time: 2021-03-23 17:22:56.403199
  MarkInstall libunity-settings-daemon1:amd64 < 15.04.1+18.04.20180413-0ubuntu1.2 -> 15.04.1+20.04.20200325-0ubuntu1 @ii umU Ib > FU=0
  Installing libgnome-desktop-3-19 as Depends of libunity-settings-daemon1
    MarkInstall libgnome-desktop-3-19:amd64 < none -> 3.36.8-0ubuntu1 @un uN > FU=0
  MarkInstall fdisk:amd64 < 2.31.1-0.4ubuntu3.7 -> 2.34-0.1ubuntu9.1 @ii umU Ib > FU=0
  Installing libncursesw6 as Depends of fdisk
    MarkInstall libncursesw6:amd64 < none -> 6.2-0ubuntu2 @un uN Ib > FU=0
    Installing libtinfo6 as Depends of libncursesw6
      MarkInstall libtinfo6:amd64 < none -> 6.2-0ubuntu2 @un uN > FU=0
  MarkInstall libfltk1.3:amd64 < 1.3.4-6 -> 1.3.4-10build1 @ii umU Ib > FU=0
  Installing libgcc-s1 as Depends of libfltk1.3
    MarkInstall libgcc-s1:amd64 < none -> 10.2.0-5ubuntu1~20.04 @un uN Ib > FU=0
    Installing gcc-10-base as Depends of libgcc-s1
      MarkInstall gcc-10-base:amd64 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
  MarkInstall firebird3.0-server-core:amd64 < 3.0.2.32703.ds4-11ubuntu2 -> 3.0.5.33220.ds4-1build2 @ii umU Ib > FU=0
  Installing libicu66 as Depends of firebird3.0-server-core
    MarkInstall libicu66:amd64 < none -> 66.1-2ubuntu2 @un uN > FU=0
  MarkInstall perl-base:amd64 < 5.26.1-6ubuntu0.5 -> 5.30.0-9ubuntu0.2 @ii umU Ib > FU=0
  Installing libcrypt1 as PreDepends of perl-base
    MarkInstall libcrypt1:amd64 < none -> 1:4.4.10-10ubuntu4 @un uN > FU=0
  MarkInstall audacity:amd64 < 2.2.1-1 -> 2.3.3-1build1 @ii umU Ib > FU=0
  Installing libavcodec58 as Depends of audacity
    MarkInstall libavcodec58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
    Installing libaom0 as Depends of libavcodec58
      MarkInstall libaom0:amd64 < none -> 1.0.0.errata1-3build1 @un uN > FU=0
    Installing libavutil56 as Depends of libavcodec58
      MarkInstall libavutil56:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
    Installing libcodec2-0.9 as Depends of libavcodec58
      MarkInstall libcodec2-0.9:amd64 < none -> 0.9.2-2 @un uN > FU=0
    Installing libswresample3 as Depends of libavcodec58
      MarkInstall libswresample3:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
    Installing libvpx6 as Depends of libavcodec58
      MarkInstall libvpx6:amd64 < none -> 1.8.2-1build1 @un uN > FU=0
    Installing libx264-155 as Depends of libavcodec58
      MarkInstall libx264-155:amd64 < none -> 2:0.155.2917+git0a84d98-2 @un uN > FU=0
    Installing libx265-179 as Depends of libavcodec58
      MarkInstall libx265-179:amd64 < none -> 3.2.1-1build1 @un uN > FU=0
  Installing libavformat58 as Depends of audacity
    MarkInstall libavformat58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
  Installing libwxgtk3.0-gtk3-0v5 as Depends of audacity
    MarkInstall libwxgtk3.0-gtk3-0v5:amd64 < none -> 3.0.4+dfsg-15build1 @un uN > FU=0
  MarkInstall bluez:amd64 < 5.48-0ubuntu3.4 -> 5.53-0ubuntu3 @ii umU Ib > FU=0
  Installing libreadline8 as Depends of bluez
    MarkInstall libreadline8:amd64 < none -> 8.0-4 @un uN > FU=0
  MarkInstall fluidsynth:amd64 < 1.1.9-1 -> 2.1.1-2 @ii umU Ib > FU=0
  Installing libfluidsynth2 as Depends of fluidsynth
    MarkInstall libfluidsynth2:amd64 < none -> 2.1.1-2 @un uN Ib > FU=0
    Installing libinstpatch-1.0-2 as Depends of libfluidsynth2
      MarkInstall libinstpatch-1.0-2:amd64 < none -> 1.1.2-2build1 @un uN > FU=0
  MarkInstall dvdauthor:amd64 < 0.7.0-2build1 -> 0.7.2-1build1 @ii umU Ib > FU=0
  Installing libdvdread7 as Depends of dvdauthor
    MarkInstall libdvdread7:amd64 < none -> 6.1.0+really6.0.2-1 @un uN > FU=0
  MarkInstall gnome-power-manager:amd64 < 3.26.0-1 -> 3.32.0-2 @ii umU Ib > FU=0
  Installing gnome-settings-daemon-common as Depends of gnome-power-manager
    MarkInstall gnome-settings-daemon-common:amd64 < none -> 3.36.1-0ubuntu1 @un uN Ib > FU=0
     Removing: gnome-settings-daemon-schemas
      MarkDelete gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3pop0~1565899898~18.04~a5b17e2~dev @ii mK > FU=0
  MarkInstall python3-dev:amd64 < 3.6.7-1~18.04 -> 3.8.2-0ubuntu2 @ii umU Ib > FU=0
  Installing python3.8-dev as Depends of python3-dev
    MarkInstall python3.8-dev:amd64 < none -> 3.8.5-1~20.04.2 @un uN Ib > FU=0
    Installing python3.8 as Depends of python3.8-dev
      MarkInstall python3.8:amd64 < none -> 3.8.5-1~20.04.2 @un uN Ib > FU=0
      Installing python3.8-minimal as Depends of python3.8
        MarkInstall python3.8-minimal:amd64 < none -> 3.8.5-1~20.04.2 @un uN Ib > FU=0
        Installing libpython3.8-minimal as Depends of python3.8-minimal
          MarkInstall libpython3.8-minimal:amd64 < none -> 3.8.5-1~20.04.2 @un uN IPb > FU=0
          Installing libpython3.8-stdlib as Recommends of libpython3.8-minimal
            MarkInstall libpython3.8-stdlib:amd64 < none -> 3.8.5-1~20.04.2 @un uN Ib > FU=0
            Installing libffi7 as Depends of libpython3.8-stdlib
              MarkInstall libffi7:amd64 < none -> 3.3-4 @un uN > FU=0
    Installing libpython3.8-dev as Depends of python3.8-dev
      MarkInstall libpython3.8-dev:amd64 < none -> 3.8.5-1~20.04.2 @un uN Ib > FU=0
      Installing libpython3.8 as Depends of libpython3.8-dev
        MarkInstall libpython3.8:amd64 < none -> 3.8.5-1~20.04.2 @un uN > FU=0
  MarkInstall vlc-plugin-video-output:amd64 < 3.0.8-0ubuntu18.04.1 -> 3.0.9.2-1 @ii umU Ib > FU=0
  Installing libplacebo7 as Depends of vlc-plugin-video-output
    MarkInstall libplacebo7:amd64 < none -> 1.7.0-2 @un uN > FU=0
  MarkInstall xserver-xorg:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii umU IPb > FU=0
  new important dependency: mesa-vulkan-drivers:amd64
  Installing mesa-vulkan-drivers as Recommends of xserver-xorg
    MarkInstall mesa-vulkan-drivers:amd64 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
    Installing libllvm11 as Depends of mesa-vulkan-drivers
      MarkInstall libllvm11:amd64 < none -> 1:11.0.0-2~ubuntu20.04.1 @un uN > FU=0
  MarkInstall gnome-calendar:amd64 < 3.28.2-0ubuntu0.18.04.1 -> 3.36.2-0ubuntu1 @ii umU Ib > FU=0
  Installing libecal-2.0-1 as Depends of gnome-calendar
    MarkInstall libecal-2.0-1:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
    Installing libedataserver-1.2-24 as Depends of libecal-2.0-1
      MarkInstall libedataserver-1.2-24:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
      Installing libcamel-1.2-62 as Depends of libedataserver-1.2-24
        MarkInstall libcamel-1.2-62:amd64 < none -> 3.36.4-0ubuntu1 @un uN > FU=0
  Installing libgweather-3-16 as Depends of gnome-calendar
    MarkInstall libgweather-3-16:amd64 < none -> 3.36.1-1~ubuntu20.04.1 @un uN > FU=0
  Installing libhandy-0.0-0 as Depends of gnome-calendar
    MarkInstall libhandy-0.0-0:amd64 < none -> 0.0.13-1 @un uN > FU=0
  MarkInstall libkf5texteditor5:amd64 < 5.44.0-0ubuntu2 -> 5.68.0-0ubuntu1 @ii umU Ib > FU=0
  Installing libkf5texteditor-bin as Depends of libkf5texteditor5
    MarkInstall libkf5texteditor-bin:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
    Installing libkf5authcore5 as Depends of libkf5texteditor-bin
      MarkInstall libkf5authcore5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
  Installing libgit2-28 as Depends of libkf5texteditor5
    MarkInstall libgit2-28:amd64 < none -> 0.28.4+dfsg.1-2 @un uN Ib > FU=0
    Installing libhttp-parser2.9 as Depends of libgit2-28
      MarkInstall libhttp-parser2.9:amd64 < none -> 2.9.2-2 @un uN > FU=0
    Installing libmbedcrypto3 as Depends of libgit2-28
      MarkInstall libmbedcrypto3:amd64 < none -> 2.16.4-1ubuntu2 @un uN > FU=0
    Installing libmbedtls12 as Depends of libgit2-28
      MarkInstall libmbedtls12:amd64 < none -> 2.16.4-1ubuntu2 @un uN Ib > FU=0
      Installing libmbedx509-0 as Depends of libmbedtls12
        MarkInstall libmbedx509-0:amd64 < none -> 2.16.4-1ubuntu2 @un uN > FU=0
  MarkInstall libkf5purpose-bin:amd64 < 5.44.0-0ubuntu1 -> 5.68.0-0ubuntu1 @ii umU Ib > FU=0
  Installing qml-module-org-kde-bluezqt as Depends of libkf5purpose-bin
    MarkInstall qml-module-org-kde-bluezqt:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
    Installing libkf5bluezqt6 as Depends of qml-module-org-kde-bluezqt
      MarkInstall libkf5bluezqt6:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
      Installing libkf5bluezqt-data as Depends of libkf5bluezqt6
        MarkInstall libkf5bluezqt-data:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
  MarkInstall aapt:amd64 < 1:8.1.0+r23-3~18.04 -> 1:8.1.0+r23-3build2 @ii umU Ib > FU=0
  Installing libprotobuf-lite17 as Depends of aapt
    MarkInstall libprotobuf-lite17:amd64 < none -> 3.6.1.3-2ubuntu5 @un uN > FU=0
  MarkInstall libatlas3-base:amd64 < 3.10.3-5 -> 3.10.3-8ubuntu7 @ii umU Ib > FU=0
  Installing libgfortran5 as Depends of libatlas3-base
    MarkInstall libgfortran5:amd64 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
  MarkInstall libisofs6:amd64 < 1.4.8-1 -> 1.5.2-1 @ii umU Ib > FU=0
  Installing libjte2 as Depends of libisofs6
    MarkInstall libjte2:amd64 < none -> 1.22-3build1 @un uN > FU=0
  MarkInstall poppler-utils:amd64 < 0.62.0-2ubuntu2.12 -> 0.86.1-0ubuntu1 @ii umU Ib > FU=0
  Installing libpoppler97 as Depends of poppler-utils
    MarkInstall libpoppler97:amd64 < none -> 0.86.1-0ubuntu1 @un uN > FU=0
  MarkInstall libgusb2:amd64 < 0.2.11-1 -> 0.3.4-0.1 @ii umU IPb > FU=0
  new important dependency: usb.ids:amd64
  Installing usb.ids as Recommends of libgusb2
    MarkInstall usb.ids:amd64 < none -> 2020.03.19-1 @un uN > FU=0
  MarkInstall libaa1:amd64 < 1.4p5-44build2 -> 1.4p5-46 @ii umU Ib > FU=0
  Installing libncurses6 as Depends of libaa1
    MarkInstall libncurses6:amd64 < none -> 6.2-0ubuntu2 @un uN > FU=0
  MarkInstall qtdeclarative5-dev:amd64 < 5.9.5-0ubuntu1.1 -> 5.12.8-0ubuntu1 @ii umU Ib > FU=0
  Installing libqt5quickshapes5 as Depends of qtdeclarative5-dev
    MarkInstall libqt5quickshapes5:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
    MarkKeep gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3pop0~1565899898~18.04~a5b17e2~dev @ii mR > FU=0
  MarkInstall uim-data:amd64 < 1:1.8.6+gh20180114.64e3173-2build2 -> 1:1.8.8-6.1build2 @ii umU Ib > FU=0
  Installing libuim-data as Depends of uim-data
    MarkInstall libuim-data:amd64 < none -> 1:1.8.8-6.1build2 @un uN > FU=0
  MarkInstall libvte-2.91-0:amd64 < 0.52.2-1ubuntu1~18.04.2 -> 0.60.3-0ubuntu1~20.04 @ii umU Ib > FU=0
  Installing libpcre2-8-0 as Depends of libvte-2.91-0
    MarkInstall libpcre2-8-0:amd64 < none -> 10.34-7 @un uN > FU=0
  MarkInstall sonnet-plugins:amd64 < 5.44.0-0ubuntu1 -> 5.68.0-0ubuntu1 @ii umU Ib > FU=0
  Installing libhunspell-1.7-0 as Depends of sonnet-plugins
    MarkInstall libhunspell-1.7-0:amd64 < none -> 1.7.0-2build2 @un uN > FU=0
  MarkInstall clang:amd64 < 1:6.0-41~exp5~ubuntu1 -> 1:10.0-50~exp1 @ii umU Ib > FU=0
  Installing clang-10 as Depends of clang
    MarkInstall clang-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN Ib > FU=0
    Installing libclang-cpp10 as Depends of clang-10
      libclang-cpp10:amd64 Depends on libllvm10:amd64 < 1:10.0.1-1~oibaf~b @ii mK > (= 1:10.0.0-4ubuntu1) can't be satisfied!
    Installing libstdc++-9-dev as Depends of clang-10
      MarkInstall libstdc++-9-dev:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN Ib > FU=0
      Installing gcc-9-base as Depends of libstdc++-9-dev
        MarkInstall gcc-9-base:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN > FU=0
      Installing libgcc-9-dev as Depends of libstdc++-9-dev
        MarkInstall libgcc-9-dev:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN Ib > FU=0
        Installing libasan5 as Depends of libgcc-9-dev
          MarkInstall libasan5:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN > FU=0
        Installing libubsan1 as Depends of libgcc-9-dev
          MarkInstall libubsan1:amd64 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
    Installing libobjc-9-dev as Depends of clang-10
      MarkInstall libobjc-9-dev:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN > FU=0
    Installing libclang-common-10-dev as Depends of clang-10
      libclang-common-10-dev:amd64 Depends on libllvm10:amd64 < 1:10.0.1-1~oibaf~b @ii mK > (= 1:10.0.0-4ubuntu1) can't be satisfied!
    Installing libclang1-10 as Depends of clang-10
      MarkInstall libclang1-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN > FU=0
    Installing llvm-10-dev as Recommends of clang-10
      llvm-10-dev:amd64 Depends on libllvm10:amd64 < 1:10.0.1-1~oibaf~b @ii mK > (= 1:10.0.0-4ubuntu1) can't be satisfied!
    Installing libomp-10-dev as Recommends of clang-10
      MarkInstall libomp-10-dev:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN Ib > FU=0
      Installing libomp5-10 as Depends of libomp-10-dev
        MarkInstall libomp5-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN > FU=0
  MarkInstall kdeconnect:amd64 < 1.3.3-0ubuntu0.18.04.1 -> 1.4-0ubuntu5 @ii umU Ib > FU=0
  Installing plasma-framework as Depends of kdeconnect
    MarkInstall plasma-framework:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
    Installing qml-module-org-kde-kconfig as Depends of plasma-framework
      MarkInstall qml-module-org-kde-kconfig:amd64 < none -> 5.68.0-0ubuntu2 @un uN > FU=0
    Installing qml-module-org-kde-kquickcontrols as Depends of plasma-framework
      MarkInstall qml-module-org-kde-kquickcontrols:amd64 < none -> 5.68.0-0ubuntu2 @un uN > FU=0
    Installing libkf5calendarevents5 as Depends of plasma-framework
      MarkInstall libkf5calendarevents5:amd64 < none -> 5.68.0-0ubuntu2 @un uN > FU=0
    Installing libkf5plasma5 as Depends of plasma-framework
      MarkInstall libkf5plasma5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
    Installing libkf5plasmaquick5 as Depends of plasma-framework
      MarkInstall libkf5plasmaquick5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
    Installing libxcb-composite0 as Depends of plasma-framework
      MarkInstall libxcb-composite0:amd64 < none -> 1.14-2 @un uN > FU=0
    Installing libxcb-damage0 as Depends of plasma-framework
      MarkInstall libxcb-damage0:amd64 < none -> 1.14-2 @un uN > FU=0
  Installing qml-module-org-kde-people as Depends of kdeconnect
    MarkInstall qml-module-org-kde-people:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
    Installing libkf5people5 as Depends of qml-module-org-kde-people
      MarkInstall libkf5people5:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
      Installing libkf5people-data as Depends of libkf5people5
        MarkInstall libkf5people-data:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
      Installing libkf5peoplebackend5 as Depends of libkf5people5
        MarkInstall libkf5peoplebackend5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
    Installing libkf5peoplewidgets5 as Depends of qml-module-org-kde-people
      MarkInstall libkf5peoplewidgets5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
  Installing libkf5pulseaudioqt2 as Depends of kdeconnect
    MarkInstall libkf5pulseaudioqt2:amd64 < none -> 1.2-2build1 @un uN > FU=0
  new important dependency: kpeople-vcard:amd64
  Installing kpeople-vcard as Recommends of kdeconnect
    MarkInstall kpeople-vcard:amd64 < none -> 0.1-0ubuntu1 @un uN Ib > FU=0
    Installing libkf5contacts5 as Depends of kpeople-vcard
      MarkInstall libkf5contacts5:amd64 < none -> 5:5.68.0-0ubuntu1 @un uN Ib > FU=0
      Installing libkf5contacts-data as Depends of libkf5contacts5
        MarkInstall libkf5contacts-data:amd64 < none -> 5:5.68.0-0ubuntu1 @un uN > FU=0
  MarkInstall xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
  MarkInstall linux-headers-generic:amd64 < 5.3.0-7648.41~1586790036~18.04~600aeb5~dev -> 5.4.0.67.70 @ii umU Ib > FU=0
  Installing linux-headers-5.4.0-67-generic as Depends of linux-headers-generic
    MarkInstall linux-headers-5.4.0-67-generic:amd64 < none -> 5.4.0-67.75 @un uN Ib > FU=0
    Installing linux-headers-5.4.0-67 as Depends of linux-headers-5.4.0-67-generic
      MarkInstall linux-headers-5.4.0-67:amd64 < none -> 5.4.0-67.75 @un uN > FU=0
  MarkInstall gedit:amd64 < 3.28.1-1ubuntu1.2 -> 3.36.2-0ubuntu1 @ii umU Ib > FU=0
  Installing gir1.2-gtksource-4 as Depends of gedit
    MarkInstall gir1.2-gtksource-4:amd64 < none -> 4.6.0-1 @un uN Ib > FU=0
    Installing libgtksourceview-4-0 as Depends of gir1.2-gtksource-4
      MarkInstall libgtksourceview-4-0:amd64 < none -> 4.6.0-1 @un uN Ib > FU=0
      Installing libgtksourceview-4-common as Depends of libgtksourceview-4-0
        MarkInstall libgtksourceview-4-common:amd64 < none -> 4.6.0-1 @un uN > FU=0
  Installing libamtk-5-0 as Depends of gedit
    MarkInstall libamtk-5-0:amd64 < none -> 5.0.2-1build1 @un uN Ib > FU=0
    Installing libamtk-5-common as Depends of libamtk-5-0
      MarkInstall libamtk-5-common:amd64 < none -> 5.0.2-1build1 @un uN > FU=0
  Installing libgspell-1-2 as Depends of gedit
    MarkInstall libgspell-1-2:amd64 < none -> 1.8.3-1 @un uN Ib > FU=0
    Installing libenchant-2-2 as Depends of libgspell-1-2
      MarkInstall libenchant-2-2:amd64 < none -> 2.2.8-1ubuntu0.20.04.1 @un uN IPb > FU=0
      Installing enchant-2 as Recommends of libenchant-2-2
        MarkInstall enchant-2:amd64 < none -> 2.2.8-1ubuntu0.20.04.1 @un uN > FU=0
  Installing libtepl-4-0 as Depends of gedit
    MarkInstall libtepl-4-0:amd64 < none -> 4.4.0-1 @un uN Ib > FU=0
    Installing libuchardet0 as Depends of libtepl-4-0
      MarkInstall libuchardet0:amd64 < none -> 0.0.6-3build1 @un uN > FU=0
  MarkInstall iptables:amd64 < 1.6.1-2ubuntu2 -> 1.8.4-3ubuntu2 @ii umU Ib > FU=0
  Installing libip4tc2 as Depends of iptables
    MarkInstall libip4tc2:amd64 < none -> 1.8.4-3ubuntu2 @un uN > FU=0
  Installing libip6tc2 as Depends of iptables
    MarkInstall libip6tc2:amd64 < none -> 1.8.4-3ubuntu2 @un uN > FU=0
  Installing libnftnl11 as Depends of iptables
    MarkInstall libnftnl11:amd64 < none -> 1.1.5-1 @un uN > FU=0
  MarkInstall xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
  MarkInstall at:amd64 < 3.1.20-3.1ubuntu2 -> 3.1.23-1ubuntu1 @ii umU Ib > FU=0
  Installing libfl2 as Depends of at
    MarkInstall libfl2:amd64 < none -> 2.6.4-6.2 @un uN > FU=0
  MarkInstall ffmpeg:amd64 < 7:3.4.8-0ubuntu0.2 -> 7:4.2.4-1ubuntu0.1 @ii umU Ib > FU=0
  Installing libavdevice58 as Depends of ffmpeg
    MarkInstall libavdevice58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
    Installing libavfilter7 as Depends of libavdevice58
      MarkInstall libavfilter7:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
      Installing libmysofa1 as Depends of libavfilter7
        MarkInstall libmysofa1:amd64 < none -> 1.0~dfsg0-1 @un uN > FU=0
      Installing libpostproc55 as Depends of libavfilter7
        MarkInstall libpostproc55:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
      Installing libswscale5 as Depends of libavfilter7
        MarkInstall libswscale5:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
      Installing libvidstab1.1 as Depends of libavfilter7
        MarkInstall libvidstab1.1:amd64 < none -> 1.1.0-2 @un uN > FU=0
    Installing libsndio7.0 as Depends of libavdevice58
      MarkInstall libsndio7.0:amd64 < none -> 1.5.0-3 @un uN > FU=0
  Installing libavresample4 as Depends of ffmpeg
    MarkInstall libavresample4:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
  MarkInstall kde-cli-tools:amd64 < 4:5.12.8-0ubuntu0.1 -> 4:5.18.4.1-0ubuntu1 @ii umU Ib > FU=0
  Installing libkworkspace5-5 as Depends of kde-cli-tools
    MarkInstall libkworkspace5-5:amd64 < none -> 4:5.18.5-0ubuntu0.1 @un uN > FU=0
  MarkInstall libevdocument3-4:amd64 < 3.28.4-0ubuntu1.2 -> 3.36.7-0ubuntu1 @ii umU Ib > FU=0
  Installing libsynctex2 as Depends of libevdocument3-4
    MarkInstall libsynctex2:amd64 < none -> 2019.20190605.51237-3build2 @un uN > FU=0
  MarkInstall seq24:amd64 < 0.9.3-2 -> 0.9.3-2build1 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on jackd:amd64
  MarkInstall libhwloc-plugins:amd64 < 1.11.9-1 -> 2.1.0+dfsg-4 @ii ugU Ib > FU=0
  Installing libxnvctrl0 as Depends of libhwloc-plugins
    MarkInstall libxnvctrl0:amd64 < none -> 460.39-0ubuntu0.20.04.1 @un uN > FU=0
  Installing libhwloc15 as Depends of libhwloc-plugins
    MarkInstall libhwloc15:amd64 < none -> 2.1.0+dfsg-4 @un uN > FU=0
  MarkInstall libpam-modules:amd64 < 1.1.8-3.6ubuntu2.18.04.2 -> 1.3.1-5ubuntu4.1 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on update-motd:amd64
  MarkInstall plymouth-themes:amd64 < 0.9.3-1ubuntu7.18.04.2 -> 0.9.4git20200323-0ubuntu6.2 @ii umU Ib > FU=0
  Installing plymouth-theme-spinner as Depends of plymouth-themes
    MarkInstall plymouth-theme-spinner:amd64 < none -> 0.9.4git20200323-0ubuntu6.2 @un uN Ib > FU=0
    Installing libplymouth5 as Depends of plymouth-theme-spinner
      MarkInstall libplymouth5:amd64 < none -> 0.9.4git20200323-0ubuntu6.2 @un uN > FU=0
  MarkInstall sane-utils:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
  Installing libsane as Depends of sane-utils
    MarkInstall libsane:amd64 < none -> 1.0.29-0ubuntu5.2 @un uN Ib > FU=0
    Installing libsnmp35 as Depends of libsane
      MarkInstall libsnmp35:amd64 < none -> 5.8+dfsg-2ubuntu2.3 @un uN Ib > FU=0
      Installing libmysqlclient21 as Depends of libsnmp35
        MarkInstall libmysqlclient21:amd64 < none -> 8.0.23-0ubuntu0.20.04.1 @un uN Ib > FU=0
        Installing mysql-common as Depends of libmysqlclient21
          MarkInstall mysql-common:amd64 < none -> 5.8+1.0.5ubuntu2 @rc uN > FU=0
      Installing libperl5.30 as Depends of libsnmp35
        MarkInstall libperl5.30:amd64 < none -> 5.30.0-9ubuntu0.2 @un uN Ib > FU=0
        Installing libgdbm6 as Depends of libperl5.30
          MarkInstall libgdbm6:amd64 < none -> 1.18.1-5 @un uN > FU=0
        Installing perl-modules-5.30 as Depends of libperl5.30
          MarkInstall perl-modules-5.30:amd64 < none -> 5.30.0-9ubuntu0.2 @un uN > FU=0
      Installing libsensors5 as Depends of libsnmp35
        MarkInstall libsensors5:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib > FU=0
        Installing libsensors-config as Depends of libsensors5
          MarkInstall libsensors-config:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib > FU=0
           Removing: libsensors4
            MarkDelete libsensors4:amd64 < 1:3.4.0-4 @ii mK > FU=0
  MarkInstall libc6-dev:amd64 < 2.27-3ubuntu1.4 -> 2.31-0ubuntu9.2 @ii umU Ib > FU=0
  Installing libcrypt-dev as Depends of libc6-dev
    MarkInstall libcrypt-dev:amd64 < none -> 1:4.4.10-10ubuntu4 @un uN > FU=0
  MarkInstall libargon2-0:amd64 < 0~20161029-1.1 -> 0~20171227-0.2 @ii umU Ib > FU=0
  Installing libargon2-1 as Depends of libargon2-0
    MarkInstall libargon2-1:amd64 < none -> 0~20171227-0.2 @un uN > FU=0
  MarkInstall libopenal1:i386 < 1:1.18.2-2 -> 1:1.19.1-1 @ii umU Ib > FU=0
  Installing libsndio7.0 as Depends of libopenal1
    MarkInstall libsndio7.0:i386 < none -> 1.5.0-3 @un uN > FU=0
  MarkInstall va-driver-all:amd64 < 2.1.0-3 -> 2.7.0-2 @ii umU Ib > FU=0
  Installing intel-media-va-driver as Depends of va-driver-all
    MarkInstall intel-media-va-driver:amd64 < none -> 20.1.1+dfsg1-1 @un uN Ib > FU=0
    Installing libigdgmm11 as Depends of intel-media-va-driver
      MarkInstall libigdgmm11:amd64 < none -> 20.1.1+ds1-1 @un uN > FU=0
  MarkInstall lib32stdc++6:amd64 < 8.4.0-1ubuntu1~18.04 -> 10.2.0-5ubuntu1~20.04 @ii umU Ib > FU=0
  Installing lib32gcc-s1 as Depends of lib32stdc++6
    MarkInstall lib32gcc-s1:amd64 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
  MarkInstall vino:amd64 < 3.22.0-3ubuntu1.2 -> 3.22.0-5ubuntu2.2 @ii umU Ib > FU=0
  Installing libminiupnpc17 as Depends of vino
    MarkInstall libminiupnpc17:amd64 < none -> 2.1.20190824-0ubuntu2 @un uN > FU=0
  MarkInstall ntfs-3g:amd64 < 1:2017.3.23-2ubuntu0.18.04.2 -> 1:2017.3.23AR.3-3ubuntu1 @ii umU Ib > FU=0
  Installing libntfs-3g883 as Depends of ntfs-3g
    MarkInstall libntfs-3g883:amd64 < none -> 1:2017.3.23AR.3-3ubuntu1 @un uN > FU=0
  MarkInstall libcmis-0.5-5v5:amd64 < 0.5.1+git20160603-3build2 -> 0.5.2-1ubuntu1 @ii umU Ib > FU=0
  Installing libboost-date-time1.71.0 as Depends of libcmis-0.5-5v5
    MarkInstall libboost-date-time1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
  MarkInstall fonts-smc:amd64 < 1:7.0 -> 1:7.1 @ii umU Ib > FU=0
  Installing fonts-smc-gayathri as Depends of fonts-smc
    MarkInstall fonts-smc-gayathri:amd64 < none -> 1.100-1 @un uN > FU=0
  MarkInstall linux-image-generic:amd64 < 5.3.0-7648.41~1586790036~18.04~600aeb5~dev -> 5.4.0.67.70 @ii umU Ib > FU=0
  Installing linux-image-5.4.0-67-generic as Depends of linux-image-generic
    MarkInstall linux-image-5.4.0-67-generic:amd64 < none -> 5.4.0-67.75 @un uN Ib > FU=0
    Installing linux-modules-5.4.0-67-generic as Depends of linux-image-5.4.0-67-generic
      MarkInstall linux-modules-5.4.0-67-generic:amd64 < none -> 5.4.0-67.75 @un uN > FU=0
  Installing linux-modules-extra-5.4.0-67-generic as Depends of linux-image-generic
    MarkInstall linux-modules-extra-5.4.0-67-generic:amd64 < none -> 5.4.0-67.75 @un uN > FU=0
  MarkInstall apt:amd64 < 1.6.12ubuntu0.2 -> 2.0.4 @ii umU Ib > FU=0
  Installing libapt-pkg6.0 as Depends of apt
    MarkInstall libapt-pkg6.0:amd64 < none -> 2.0.4 @un uN > FU=0
  MarkInstall python3-markdown:amd64 < 2.6.9-1 -> 3.1.1-3 @ii umU Ib > FU=0
  Installing python3-packaging as Depends of python3-markdown
    MarkInstall python3-packaging:amd64 < none -> 20.3-1 @un uN > FU=0
  MarkInstall libgjs0g:amd64 < 1.52.5-0ubuntu18.04.1 -> 1.64.3-1~ubuntu20.04.1 @ii umU Ib > FU=0
  Installing libmozjs-68-0 as Depends of libgjs0g
    MarkInstall libmozjs-68-0:amd64 < none -> 68.6.0-1ubuntu1 @un uN > FU=0
  MarkInstall libpango1.0-0:amd64 < 1.40.14-1ubuntu0.1 @ii mK Ib > FU=0
  MarkInstall cpp-7:amd64 < 7.5.0-3ubuntu1~18.04 -> 7.5.0-6ubuntu2 @ii umU Ib > FU=0
  Installing libisl22 as Depends of cpp-7
    MarkInstall libisl22:amd64 < none -> 0.22.1-1 @un uN > FU=0
  MarkInstall libasound2-data:amd64 < 1.1.3-5ubuntu0.5 -> 1.2.2-2.1ubuntu2.3 @ii umU IPb > FU=0
  new important dependency: alsa-ucm-conf:amd64
  Installing alsa-ucm-conf as Recommends of libasound2-data
    MarkInstall alsa-ucm-conf:amd64 < none -> 1.2.2-1ubuntu0.5 @un uN > FU=0
  new important dependency: alsa-topology-conf:amd64
  Installing alsa-topology-conf as Recommends of libasound2-data
    MarkInstall alsa-topology-conf:amd64 < none -> 1.2.2-1 @un uN > FU=0
  MarkInstall clang-6.0:amd64 < 1:6.0-1ubuntu2 -> 1:6.0.1-14 @ii umU NPb IPb > FU=0
  new important dependency: python2:amd64
  Installing python2 as Recommends of clang-6.0
    MarkInstall python2:amd64 < none -> 2.7.17-2ubuntu4 @un uN Ib > FU=0
    Installing python2-minimal as PreDepends of python2
      MarkInstall python2-minimal:amd64 < none -> 2.7.17-2ubuntu4 @un uN Ib > FU=0
      Installing python2.7-minimal as Depends of python2-minimal
        MarkInstall python2.7-minimal:amd64 < none -> 2.7.18-1~20.04.1 @un uN Ib > FU=0
        Installing libpython2.7-minimal as Depends of python2.7-minimal
          MarkInstall libpython2.7-minimal:amd64 < none -> 2.7.18-1~20.04.1 @un uN IPb > FU=0
          Installing libpython2.7-stdlib as Recommends of libpython2.7-minimal
            MarkInstall libpython2.7-stdlib:amd64 < none -> 2.7.18-1~20.04.1 @un uN > FU=0
        Installing python2.7 as Recommends of python2.7-minimal
          MarkInstall python2.7:amd64 < none -> 2.7.18-1~20.04.1 @un uN > FU=0
    Installing libpython2-stdlib as Depends of python2
      MarkInstall libpython2-stdlib:amd64 < none -> 2.7.17-2ubuntu4 @un uN > FU=0
  MarkInstall python3-protobuf:amd64 < 3.0.0-9.1ubuntu1 -> 3.6.1.3-2ubuntu5 @ii umU Ib > FU=0
  Installing libprotobuf17 as Depends of python3-protobuf
    MarkInstall libprotobuf17:amd64 < none -> 3.6.1.3-2ubuntu5 @un uN > FU=0
  MarkInstall cpp:amd64 < 4:7.4.0-1ubuntu2.3 -> 4:9.3.0-1ubuntu2 @ii umU Ib > FU=0
  Installing cpp-9 as Depends of cpp
    MarkInstall cpp-9:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN > FU=0
  MarkInstall libqt5organizer5:amd64 < 5.0~git20140515~29475884-0ubuntu24~7 @ii mK Ib > FU=0
  MarkInstall libgpg-error0:amd64 < 1.27-6 -> 1.37-1 @ii umU IPb > FU=0
  new important dependency: libgpg-error-l10n:amd64
  Installing libgpg-error-l10n as Recommends of libgpg-error0
    MarkInstall libgpg-error-l10n:amd64 < none -> 1.37-1 @un uN > FU=0
  MarkInstall systemsettings:amd64 < 4:5.12.8-0ubuntu0.1 -> 4:5.18.4.1-0ubuntu1 @ii umU Ib > FU=0
  Installing libkf5itemmodels5 as Depends of systemsettings
    MarkInstall libkf5itemmodels5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
  MarkInstall bind9-host:amd64 < 1:9.11.3+dfsg-1ubuntu1.14 -> 1:9.16.1-0ubuntu2.7 @ii umU Ib > FU=0
  Installing bind9-libs as Depends of bind9-host
    MarkInstall bind9-libs:amd64 < none -> 1:9.16.1-0ubuntu2.7 @un uN Ib > FU=0
    Installing libjson-c4 as Depends of bind9-libs
      MarkInstall libjson-c4:amd64 < none -> 0.13.1+dfsg-7ubuntu0.3 @un uN > FU=0
    Installing liblmdb0 as Depends of bind9-libs
      MarkInstall liblmdb0:amd64 < none -> 0.9.24-1 @un uN > FU=0
  MarkInstall libarchive13:amd64 < 3.2.2-3.1ubuntu0.6 -> 3.4.0-2ubuntu1 @ii umU Ib > FU=0
  Installing libnettle7 as Depends of libarchive13
    MarkInstall libnettle7:amd64 < none -> 3.5.1+really3.5.1-2 @un uN > FU=0
  MarkInstall e2fsprogs:amd64 < 1.44.1-1ubuntu1.3 -> 1.45.5-2ubuntu1 @ii umU Ib > FU=0
  Installing logsave as Depends of e2fsprogs
    MarkInstall logsave:amd64 < none -> 1.45.5-2ubuntu1 @un uN > FU=0
  MarkInstall kexi:amd64 < 1:3.1.0-2 -> 1:3.2.0-2build1 @ii umU Ib > FU=0
  Installing libkdb3-4abi1 as Depends of kexi
    MarkInstall libkdb3-4abi1:amd64 < none -> 3.2.0-4build2 @un uN > FU=0
  MarkInstall intel-gpu-tools:amd64 < 1.22-1 -> 1.25-2 @ii umU Ib > FU=0
  Installing libprocps8 as Depends of intel-gpu-tools
    MarkInstall libprocps8:amd64 < none -> 2:3.3.16-1ubuntu2 @un uN > FU=0
  MarkInstall dnsutils:amd64 < 1:9.11.3+dfsg-1ubuntu1.14 -> 1:9.16.1-0ubuntu2.7 @ii umU Ib > FU=0
  Installing bind9-dnsutils as Depends of dnsutils
    MarkInstall bind9-dnsutils:amd64 < none -> 1:9.16.1-0ubuntu2.7 @un uN > FU=0
  MarkInstall g++:amd64 < 4:7.4.0-1ubuntu2.3 -> 4:9.3.0-1ubuntu2 @ii umU Ib > FU=0
  Installing g++-9 as Depends of g++
    MarkInstall g++-9:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN Ib > FU=0
    Installing gcc-9 as Depends of g++-9
      MarkInstall gcc-9:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN > FU=0
  MarkInstall eog:amd64 < 3.28.1-1 -> 3.36.3-0ubuntu1 @ii umU Ib > FU=0
  Installing libexempi8 as Depends of eog
    MarkInstall libexempi8:amd64 < none -> 2.5.1-1build1 @un uN > FU=0
  MarkInstall dnsmasq-base:amd64 < 2.79-1ubuntu0.3 -> 2.80-1.1ubuntu1.3 @ii umU Ib > FU=0
  Installing libhogweed5 as Depends of dnsmasq-base
    MarkInstall libhogweed5:amd64 < none -> 3.5.1+really3.5.1-2 @un uN > FU=0
  MarkInstall python3-pyqt4:amd64 < 4.12.1+dfsg-2 @ii mK Ib > FU=0
  MarkInstall python3-brlapi:amd64 < 5.5-4ubuntu2.0.1 -> 6.0+dfsg-4ubuntu6 @ii umU Ib > FU=0
  Installing libbrlapi0.7 as Depends of python3-brlapi
    MarkInstall libbrlapi0.7:amd64 < none -> 6.0+dfsg-4ubuntu6 @un uN > FU=0
  MarkInstall libcdio-cdda2:amd64 < 10.2+0.94+2-2build1 -> 10.2+2.0.0-1 @ii umU Ib > FU=0
  Installing libcdio18 as Depends of libcdio-cdda2
    MarkInstall libcdio18:amd64 < none -> 2.0.0-2 @un uN > FU=0
  MarkInstall python3-pil:amd64 < 5.1.0-1ubuntu0.5 -> 7.0.0-4ubuntu0.3 @ii umU Ib > FU=0
  Installing libimagequant0 as Depends of python3-pil
    MarkInstall libimagequant0:amd64 < none -> 2.12.2-1.1 @un uN > FU=0
  MarkInstall python3-keyring:amd64 < 10.6.0-1 -> 18.0.1-2ubuntu1 @ii umU Ib > FU=0
  Installing python3-entrypoints as Depends of python3-keyring
    MarkInstall python3-entrypoints:amd64 < none -> 0.3-2ubuntu1 @un uN > FU=0
  MarkInstall nodejs:amd64 < 8.10.0~dfsg-2ubuntu0.4 -> 10.19.0~dfsg-3ubuntu1 @ii umU Ib > FU=0
  Installing libnode64 as Depends of nodejs
    MarkInstall libnode64:amd64 < none -> 10.19.0~dfsg-3ubuntu1 @un uN > FU=0
  MarkInstall libc6:i386 < 2.27-3ubuntu1.4 -> 2.31-0ubuntu9.2 @ii umU Ib > FU=0
  Installing libgcc-s1 as Depends of libc6
    MarkInstall libgcc-s1:i386 < none -> 10.2.0-5ubuntu1~20.04 @un uN Ib > FU=0
    Installing gcc-10-base as Depends of libgcc-s1
      MarkInstall gcc-10-base:i386 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
  Installing libcrypt1 as Depends of libc6
    MarkInstall libcrypt1:i386 < none -> 1:4.4.10-10ubuntu4 @un uN > FU=0
  MarkInstall ubuntu-session:amd64 < 3.28.1-0ubuntu3 -> 3.36.0-2ubuntu1 @ii umU Ib > FU=0
  Installing yaru-theme-gnome-shell as Depends of ubuntu-session
    MarkInstall yaru-theme-gnome-shell:amd64 < none -> 20.04.10.1 @un uN > FU=0
  MarkInstall qemu-system-x86:amd64 < 1:2.11+dfsg-1ubuntu7.36 -> 1:4.2-3ubuntu6.14 @ii umU Ib > FU=0
  Installing libpmem1 as Depends of qemu-system-x86
    MarkInstall libpmem1:amd64 < none -> 1.8-1ubuntu1 @un uN > FU=0
  Installing libslirp0 as Depends of qemu-system-x86
    MarkInstall libslirp0:amd64 < none -> 4.1.0-2ubuntu2.1 @un uN > FU=0
  Installing libvirglrenderer1 as Depends of qemu-system-x86
    MarkInstall libvirglrenderer1:amd64 < none -> 0.8.2-1ubuntu1 @un uN > FU=0
  Installing qemu-system-data as Depends of qemu-system-x86
    MarkInstall qemu-system-data:amd64 < none -> 1:4.2-3ubuntu6.14 @un uN > FU=0
  new important dependency: qemu-system-gui:amd64
  Installing qemu-system-gui as Recommends of qemu-system-x86
    MarkInstall qemu-system-gui:amd64 < none -> 1:4.2-3ubuntu6.14 @un uN > FU=0
  new important dependency: ovmf:amd64
  Installing ovmf as Recommends of qemu-system-x86
    MarkInstall ovmf:amd64 < none -> 0~20191122.bd85bf54-2ubuntu3.1 @un uN > FU=0
  MarkInstall libnet-dns-perl:amd64 < 1.10-2 -> 1.22-1 @ii umU IPb > FU=0
  new important dependency: libdigest-bubblebabble-perl:amd64
  Installing libdigest-bubblebabble-perl as Recommends of libnet-dns-perl
    MarkInstall libdigest-bubblebabble-perl:amd64 < none -> 0.02-2 @un uN > FU=0
  new important dependency: libnet-dns-sec-perl:amd64
  Installing libnet-dns-sec-perl as Recommends of libnet-dns-perl
    MarkInstall libnet-dns-sec-perl:amd64 < none -> 1.15-1 @un uN > FU=0
  MarkInstall jackd1:amd64 < 1:0.125.0-3 -> 1:0.125.0-3build2 @ii ugU NPb IPb > FU=0
  ignore old unsatisfied important dependency on qjackctl:amd64
  MarkInstall fluidr3mono-gm-soundfont:amd64 < 2.315-4 -> 2.315-6 @ii umU Ib > FU=0
   Removing: musescore-common
    MarkDelete musescore-common:amd64 < 2.1.0+dfsg3-3build1 @ii mK > FU=0
  MarkInstall dmeventd:amd64 < 2:1.02.145-4.1ubuntu3.18.04.3 -> 2:1.02.167-1ubuntu1 @ii umU Ib > FU=0
  Installing liblvm2cmd2.03 as Depends of dmeventd
    MarkInstall liblvm2cmd2.03:amd64 < none -> 2.03.07-1ubuntu1 @un uN > FU=0
  MarkInstall qtcreator:amd64 < 4.5.2-3ubuntu2 -> 4.11.0-2build2 @ii umU Ib > FU=0
  Installing libclang1-8 as Depends of qtcreator
    MarkInstall libclang1-8:amd64 < none -> 1:8.0.1-9 @un uN Ib > FU=0
    Installing libllvm8 as Depends of libclang1-8
      MarkInstall libllvm8:amd64 < none -> 1:8.0.1-9 @un uN > FU=0
  Installing libqbscore1.13 as Depends of qtcreator
    MarkInstall libqbscore1.13:amd64 < none -> 1.13.1-2build1 @un uN > FU=0
  Installing libqt5serialport5 as Depends of qtcreator
    MarkInstall libqt5serialport5:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
  new important dependency: clang-tidy:amd64
  Installing clang-tidy as Recommends of qtcreator
    MarkInstall clang-tidy:amd64 < none -> 1:10.0-50~exp1 @un uN Ib > FU=0
    Installing clang-tidy-10 as Depends of clang-tidy
      clang-tidy-10:amd64 Depends on libllvm10:amd64 < 1:10.0.1-1~oibaf~b @ii mK > (= 1:10.0.0-4ubuntu1) can't be satisfied!
  MarkInstall musescore:amd64 < 2.1.0+dfsg3-3build1 @ii mK Ib > FU=0
  Installing musescore-common as Depends of musescore
      MarkKeep musescore-common:amd64 < 2.1.0+dfsg3-3build1 @ii mR > FU=0
  MarkInstall indicator-sound:amd64 < 12.10.2+18.04.20180420.3-0ubuntu1 -> 12.10.2+18.10.20180612-0ubuntu1 @ii umU IPb > FU=0
  new important dependency: accountsservice-ubuntu-schemas:amd64
  Installing accountsservice-ubuntu-schemas as Recommends of indicator-sound
    MarkInstall accountsservice-ubuntu-schemas:amd64 < none -> 0.0.7+17.10.20170922-0ubuntu1 @un uN > FU=0
  MarkInstall python3-louis:amd64 < 3.5.0-1ubuntu0.3 -> 3.12.0-3 @ii umU Ib > FU=0
  Installing liblouis20 as Depends of python3-louis
    MarkInstall liblouis20:amd64 < none -> 3.12.0-3 @un uN > FU=0
  MarkInstall lvm2:amd64 < 2.02.176-4.1ubuntu3.18.04.3 -> 2.03.07-1ubuntu1 @ii umU IPb > FU=0
  new important dependency: thin-provisioning-tools:amd64
  Installing thin-provisioning-tools as Recommends of lvm2
    MarkInstall thin-provisioning-tools:amd64 < none -> 0.8.5-4build1 @un uN > FU=0
  MarkInstall libgwenhywfar-data:amd64 < 4.20.0-1 -> 5.1.3-1build1 @ii umU IPb > FU=0
  new important dependency: libgwenhywfar79:amd64
  Installing libgwenhywfar79 as Recommends of libgwenhywfar-data
    MarkInstall libgwenhywfar79:amd64 < none -> 5.1.3-1build1 @un uN > FU=0
  MarkInstall libglib2.0-tests:amd64 < 2.56.4-0ubuntu0.18.04.8 -> 2.64.6-1~ubuntu20.04.3 @ii umU Ib > FU=0
  Installing python3-dbusmock as Depends of libglib2.0-tests
    MarkInstall python3-dbusmock:amd64 < none -> 0.19-1 @un uN > FU=0
  MarkInstall evolution-data-server:amd64 < 3.28.5-0ubuntu0.18.04.3 -> 3.36.4-0ubuntu1 @ii umU Ib > FU=0
  Installing libebook-1.2-20 as Depends of evolution-data-server
    MarkInstall libebook-1.2-20:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
    Installing libebook-contacts-1.2-3 as Depends of libebook-1.2-20
      MarkInstall libebook-contacts-1.2-3:amd64 < none -> 3.36.4-0ubuntu1 @un uN > FU=0
    Installing libedata-book-1.2-26 as Depends of libebook-1.2-20
      MarkInstall libedata-book-1.2-26:amd64 < none -> 3.36.4-0ubuntu1 @un uN > FU=0
  Installing libedata-cal-2.0-1 as Depends of evolution-data-server
    MarkInstall libedata-cal-2.0-1:amd64 < none -> 3.36.4-0ubuntu1 @un uN > FU=0
  MarkInstall unity:amd64 < 7.5.0+18.04.20190304-0ubuntu1 -> 7.5.0+20.04.20200312-0ubuntu1 @ii umU Ib > FU=0
  Installing unity-settings-daemon-schemas as Depends of unity
    MarkInstall unity-settings-daemon-schemas:amd64 < none -> 15.04.1+20.04.20200325-0ubuntu1 @un uN > FU=0
  new important dependency: nemo:amd64
  Installing nemo as Recommends of unity
    MarkInstall nemo:amd64 < none -> 4.4.2-2 @un uN Ib > FU=0
    Installing cinnamon-desktop-data as Depends of nemo
      MarkInstall cinnamon-desktop-data:amd64 < none -> 4.4.1-3 @un uN > FU=0
    Installing libcinnamon-desktop4 as Depends of nemo
      MarkInstall libcinnamon-desktop4:amd64 < none -> 4.4.1-3 @un uN > FU=0
    Installing libnemo-extension1 as Depends of nemo
      MarkInstall libnemo-extension1:amd64 < none -> 4.4.2-2 @un uN > FU=0
    Installing libxapp1 as Depends of nemo
      MarkInstall libxapp1:amd64 < none -> 1.6.10-2 @un uN Ib > FU=0
      Installing xapps-common as Depends of libxapp1
        MarkInstall xapps-common:amd64 < none -> 1.6.10-2 @un uN IPb > FU=0
        Installing gist as Recommends of xapps-common
          MarkInstall gist:amd64 < none -> 5.0.0-4 @un uN Ib > FU=0
          Installing ruby-json as Depends of gist
            MarkInstall ruby-json:amd64 < none -> 2.3.0+dfsg-1build1 @un uN Ib > FU=0
            Installing libruby2.7 as Depends of ruby-json
              MarkInstall libruby2.7:amd64 < none -> 2.7.0-5ubuntu1.3 @un uN Ib > FU=0
              Installing ruby-xmlrpc as Depends of libruby2.7
                MarkInstall ruby-xmlrpc:amd64 < none -> 0.3.0-2 @un uN > FU=0
        Installing inxi as Recommends of xapps-common
          MarkInstall inxi:amd64 < none -> 3.0.38-1-0ubuntu1 @rc uN IPb > FU=0
          Installing hddtemp as Recommends of inxi
            MarkInstall hddtemp:amd64 < none -> 0.3-beta15-53 @rc uN > FU=0
    Installing nemo-data as Depends of nemo
      MarkInstall nemo-data:amd64 < none -> 4.4.2-2 @un uN > FU=0
    Installing cinnamon-l10n as Recommends of nemo
      MarkInstall cinnamon-l10n:amd64 < none -> 4.4.2-2 @un uN > FU=0
    Installing gvfs-backends as Recommends of nemo
      MarkInstall gvfs-backends:amd64 < none -> 1.44.1-1ubuntu1 @un uN Ib > FU=0
      Installing libnfs13 as Depends of gvfs-backends
        MarkInstall libnfs13:amd64 < none -> 4.0.0-1 @un uN > FU=0
      Installing libsmbclient as Depends of gvfs-backends
        MarkInstall libsmbclient:amd64 < none -> 2:4.11.6+dfsg-0ubuntu1.6 @un uN Ib > FU=0
        Installing samba-libs as Depends of libsmbclient
          MarkInstall samba-libs:amd64 < none -> 2:4.11.6+dfsg-0ubuntu1.6 @un uN Ib > FU=0
          Installing libldb2 as Depends of samba-libs
            MarkInstall libldb2:amd64 < none -> 2:2.0.10-0ubuntu0.20.04.2 @un uN Ib > FU=0
             Removing: libldb1
              MarkDelete libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mK > FU=0
          Installing python3-talloc as Depends of samba-libs
            MarkInstall python3-talloc:amd64 < none -> 2.3.0-3ubuntu1 @un uN > FU=0
    Installing nemo-fileroller as Recommends of nemo
      MarkInstall nemo-fileroller:amd64 < none -> 4.4.0-2 @un uN > FU=0
  MarkInstall alsa-utils:amd64 < 1.1.3-1ubuntu1 -> 1.2.2-1ubuntu2 @ii umU Ib > FU=0
  Installing libatopology2 as Depends of alsa-utils
    MarkInstall libatopology2:amd64 < none -> 1.2.2-2.1ubuntu2.3 @un uN > FU=0
  MarkInstall libmediainfo0v5:amd64 < 17.12-1ubuntu0.1 -> 19.09+dfsg-2build1 @ii umU Ib > FU=0
  Installing libtinyxml2-6a as Depends of libmediainfo0v5
    MarkInstall libtinyxml2-6a:amd64 < none -> 7.0.0+dfsg-1build1 @un uN Ib > FU=0
     Removing: libtinyxml2-6
      MarkDelete libtinyxml2-6:amd64 < 6.0.0+dfsg-1 @ii mK > FU=0
  MarkInstall libvoikko1:amd64 < 4.1.1-1.1 -> 4.3-1build1 @ii umU Ib > FU=0
  Installing libhfstospell10 as Depends of libvoikko1
    MarkInstall libhfstospell10:amd64 < none -> 0.5.0-2build2 @un uN Ib > FU=0
     Removing: libhfstospell9
      MarkDelete libhfstospell9:amd64 < 0.4.5~r343-2.1build2 @ii mK Ib > FU=0
  MarkInstall anthy-common:amd64 < 1:0.3-6ubuntu1 -> 1:0.4-2 @ii umU IPb > FU=0
  new important dependency: kasumi:amd64
  Installing kasumi as Recommends of anthy-common
    MarkInstall kasumi:amd64 < none -> 2.5-9build1 @un uN IPb > FU=0
    Installing anthy as Recommends of kasumi
      MarkInstall anthy:amd64 < none -> 1:0.4-2 @un uN Ib > FU=0
      Installing libanthyinput0 as Depends of anthy
        MarkInstall libanthyinput0:amd64 < none -> 1:0.4-2 @un uN > FU=0
  MarkInstall gdm3:amd64 < 3.28.3-0ubuntu18.04.6 -> 3.36.3-0ubuntu0.20.04.3 @ii umU IPb > FU=0
  new important dependency: libpam-fprintd:amd64
  Installing libpam-fprintd as Recommends of gdm3
    MarkInstall libpam-fprintd:amd64 < none -> 1.90.1-1ubuntu1 @un uN Ib > FU=0
    Installing fprintd as Depends of libpam-fprintd
      MarkInstall fprintd:amd64 < none -> 1.90.1-1ubuntu1 @un uN Ib > FU=0
      Installing libfprint-2-2 as Depends of fprintd
        MarkInstall libfprint-2-2:amd64 < none -> 1:1.90.2+tod1-0ubuntu1~20.04.4 @un uN > FU=0
  MarkInstall libwmf0.2-7:amd64 < 0.2.8.4-12 -> 0.2.8.4-17ubuntu1 @ii umU IPb > FU=0
  new important dependency: fonts-urw-base35:amd64
  Installing fonts-urw-base35 as Recommends of libwmf0.2-7
    MarkInstall fonts-urw-base35:amd64 < none -> 20170801.1-3 @un uN > FU=0
  MarkInstall dkms:amd64 < 2.3-3ubuntu9.7 -> 2.8.1-5ubuntu2 @ii umU Ib > FU=0
  Installing dctrl-tools as Depends of dkms
    MarkInstall dctrl-tools:amd64 < none -> 2.24-3 @rc uN > FU=0
  MarkInstall libkf5bookmarks5:amd64 < 5.44.0-0ubuntu1 -> 5.68.0-0ubuntu1 @ii umU IPb > FU=0
  new important dependency: keditbookmarks:amd64
  Installing keditbookmarks as Recommends of libkf5bookmarks5
    MarkInstall keditbookmarks:amd64 < none -> 19.12.3-0ubuntu1 @un uN Ib > FU=0
    Installing libkf5kiogui5 as Depends of keditbookmarks
      MarkInstall libkf5kiogui5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
  MarkInstall libsvn1:amd64 < 1.9.7-4ubuntu1 -> 1.13.0-3 @ii umU Ib > FU=0
  Installing libutf8proc2 as Depends of libsvn1
    MarkInstall libutf8proc2:amd64 < none -> 2.5.0-1 @un uN > FU=0
  MarkInstall libgexiv2-2:amd64 < 0.10.8-1 -> 0.12.0-2 @ii umU Ib > FU=0
  Installing libexiv2-27 as Depends of libgexiv2-2
    MarkInstall libexiv2-27:amd64 < none -> 0.27.2-8ubuntu2 @un uN > FU=0
  MarkInstall dh-strip-nondeterminism:amd64 < 0.040-1.1~build1 -> 1.7.0-1 @ii umU Ib > FU=0
  Installing libdebhelper-perl as Depends of dh-strip-nondeterminism
    MarkInstall libdebhelper-perl:amd64 < none -> 12.10ubuntu1 @un uN > FU=0
  MarkInstall libfile-stripnondeterminism-perl:amd64 < 0.040-1.1~build1 -> 1.7.0-1 @ii umU Ib > FU=0
  Installing libsub-override-perl as Depends of libfile-stripnondeterminism-perl
    MarkInstall libsub-override-perl:amd64 < none -> 0.09-2 @un uN > FU=0
  MarkInstall libgcc1:amd64 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib > FU=0
   Removing: libgcc1
    MarkDelete libgcc1:i386 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib > FU=0
  MarkInstall libgcc1:i386 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib > FU=0
   Removing: libgcc1
    MarkDelete libgcc1:amd64 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib > FU=0
  MarkInstall gnome-tweaks:amd64 < 3.28.1-1 -> 3.34.0-2ubuntu1 @ii umU Ib > FU=0
  Installing gir1.2-handy-0.0 as Depends of gnome-tweaks
    MarkInstall gir1.2-handy-0.0:amd64 < none -> 0.0.13-1 @un uN > FU=0
  Installing gnome-shell-extension-prefs as Depends of gnome-tweaks
    MarkInstall gnome-shell-extension-prefs:amd64 < none -> 3.36.4-1ubuntu1~20.04.2 @un uN IPb > FU=0
    Installing chrome-gnome-shell as Recommends of gnome-shell-extension-prefs
      MarkInstall chrome-gnome-shell:amd64 < none -> 10.1-5 @un uN > FU=0
  MarkInstall qt5-doc:amd64 < 5.9.5-0ubuntu1 -> 5.12.8-0ubuntu1 @ii umU Ib > FU=0
  Installing qtdatavisualization5-doc as Depends of qt5-doc
    MarkInstall qtdatavisualization5-doc:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
  Installing qtnetworkauth5-doc as Depends of qt5-doc
    MarkInstall qtnetworkauth5-doc:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
  Installing qtscxml5-doc as Depends of qt5-doc
    MarkInstall qtscxml5-doc:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
  Installing qtserialbus5-doc as Depends of qt5-doc
    MarkInstall qtserialbus5-doc:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
  Installing qtvirtualkeyboard5-doc as Depends of qt5-doc
    MarkInstall qtvirtualkeyboard5-doc:amd64 < none -> 5.12.8+dfsg-0ubuntu1 @un uN > FU=0
  MarkInstall libfontconfig1-dev:amd64 < 2.12.6-0ubuntu2 -> 2.13.1-2ubuntu3 @ii umU Ib > FU=0
  Installing uuid-dev as Depends of libfontconfig1-dev
    MarkInstall uuid-dev:amd64 < none -> 2.34-0.1ubuntu9.1 @un uN > FU=0
  MarkInstall deja-dup:amd64 < 37.1-2fakesync1ubuntu0.1 -> 40.7-0ubuntu1 @ii umU NPb Ib > FU=0
  Installing duplicity as Depends of deja-dup
    MarkInstall duplicity:amd64 < none -> 0.8.11.1612-1 @un uN Ib > FU=0
    Installing librsync2 as Depends of duplicity
      MarkInstall librsync2:amd64 < none -> 2.0.2-1ubuntu1 @un uN > FU=0
    Installing python3-fasteners as Depends of duplicity
      MarkInstall python3-fasteners:amd64 < none -> 0.14.1-2 @un uN Ib > FU=0
      Installing python3-monotonic as Depends of python3-fasteners
        MarkInstall python3-monotonic:amd64 < none -> 1.5-0ubuntu2 @un uN > FU=0
    Installing python3-future as Depends of duplicity
      MarkInstall python3-future:amd64 < none -> 0.18.2-2 @un uN > FU=0
    Installing python3-lockfile as Depends of duplicity
      MarkInstall python3-lockfile:amd64 < none -> 1:0.12.2-2ubuntu2 @un uN > FU=0
    Installing python3-paramiko as Recommends of duplicity
      MarkInstall python3-paramiko:amd64 < none -> 2.6.0-2 @un uN Ib > FU=0
      Installing python3-bcrypt as Depends of python3-paramiko
        MarkInstall python3-bcrypt:amd64 < none -> 3.1.7-2ubuntu1 @un uN > FU=0
  MarkInstall python3-dbus.mainloop.qt:amd64 < 4.12.1+dfsg-2 @ii mK Ib > FU=0
  MarkInstall libcairo-perl:amd64 < 1.106-2build2 -> 1.107-1 @ii umU Ib > FU=0
  Installing libextutils-depends-perl as Depends of libcairo-perl
    MarkInstall libextutils-depends-perl:amd64 < none -> 0.8000-1 @un uN > FU=0
  Installing libextutils-pkgconfig-perl as Depends of libcairo-perl
    MarkInstall libextutils-pkgconfig-perl:amd64 < none -> 1.16-1 @un uN > FU=0
  MarkInstall aisleriot:amd64 < 1:3.22.5-1 -> 1:3.22.9-1 @ii umU Ib > FU=0
  Installing guile-2.2-libs as Depends of aisleriot
    MarkInstall guile-2.2-libs:amd64 < none -> 2.2.7+1-4 @un uN > FU=0
  MarkInstall flamerobin:amd64 < 0.9.3~+20160512.c75f8618-2 -> 0.9.3~+20160512.c75f8618-3build1 @ii umU Ib > FU=0
  Installing libboost-thread1.71.0 as Depends of flamerobin
    MarkInstall libboost-thread1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
  MarkInstall binutils-x86-64-linux-gnu:amd64 < 2.30-21ubuntu1~18.04.5 -> 2.34-6ubuntu1.1 @ii umU Ib > FU=0
  Installing libctf-nobfd0 as Depends of binutils-x86-64-linux-gnu
    MarkInstall libctf-nobfd0:amd64 < none -> 2.34-6ubuntu1.1 @un uN > FU=0
  Installing libctf0 as Depends of binutils-x86-64-linux-gnu
    MarkInstall libctf0:amd64 < none -> 2.34-6ubuntu1.1 @un uN > FU=0
  MarkInstall fonts-noto:amd64 < 20171026-2 -> 20200323-1build1~ubuntu20.04.1 @ii ugU Ib > FU=0
  Installing fonts-noto-core as Depends of fonts-noto
    MarkInstall fonts-noto-core:amd64 < none -> 20200323-1build1~ubuntu20.04.1 @un uN > FU=0
  new important dependency: fonts-noto-cjk-extra:amd64
  Installing fonts-noto-cjk-extra as Recommends of fonts-noto
    MarkInstall fonts-noto-cjk-extra:amd64 < none -> 1:20190410+repack1-2 @un uN > FU=0
  new important dependency: fonts-noto-extra:amd64
  Installing fonts-noto-extra as Recommends of fonts-noto
    MarkInstall fonts-noto-extra:amd64 < none -> 20200323-1build1~ubuntu20.04.1 @un uN > FU=0
  new important dependency: fonts-noto-ui-core:amd64
  Installing fonts-noto-ui-core as Recommends of fonts-noto
    MarkInstall fonts-noto-ui-core:amd64 < none -> 20200323-1build1~ubuntu20.04.1 @un uN > FU=0
  new important dependency: fonts-noto-ui-extra:amd64
  Installing fonts-noto-ui-extra as Recommends of fonts-noto
    MarkInstall fonts-noto-ui-extra:amd64 < none -> 20200323-1build1~ubuntu20.04.1 @un uN > FU=0
  MarkInstall libpango1.0-dev:amd64 < 1.40.14-1ubuntu0.1 -> 1.44.7-2ubuntu4 @ii umU Ib > FU=0
  Installing libfribidi-dev as Depends of libpango1.0-dev
    MarkInstall libfribidi-dev:amd64 < none -> 1.0.8-2 @un uN > FU=0
  Installing libthai-dev as Depends of libpango1.0-dev
    MarkInstall libthai-dev:amd64 < none -> 0.1.28-3 @un uN Ib > FU=0
    Installing libdatrie-dev as Depends of libthai-dev
      MarkInstall libdatrie-dev:amd64 < none -> 0.2.12-3 @un uN > FU=0
  Installing pango1.0-tools as Depends of libpango1.0-dev
    MarkInstall pango1.0-tools:amd64 < none -> 1.44.7-2ubuntu4 @un uN > FU=0
  MarkInstall libgps-dev:amd64 < 3.17-5 -> 3.20-8ubuntu0.2 @ii umU Ib > FU=0
  Installing libgps26 as Depends of libgps-dev
    MarkInstall libgps26:amd64 < none -> 3.20-8ubuntu0.2 @un uN > FU=0
  MarkInstall libboost-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost1.71-dev as Depends of libboost-dev
    MarkInstall libboost1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
     Removing: libboost1.65-dev
      MarkDelete libboost1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
  MarkInstall libboost-test1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii gK Ib > FU=0
  Installing libboost1.65-dev as Depends of libboost-test1.65-dev
      MarkKeep libboost1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall dpkg:amd64 < 1.19.0.5ubuntu2.3 -> 1.19.7ubuntu3 @ii umU Ib > FU=0
   Removing: libapt-pkg5.0
    MarkDelete libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mK > FU=0
  MarkInstall cups-filters:amd64 < 1.20.2-0ubuntu3.1 -> 1.27.4-1 @ii umU Ib > FU=0
  Installing libqpdf26 as Depends of cups-filters
    MarkInstall libqpdf26:amd64 < none -> 9.1.1-1build1 @un uN > FU=0
  MarkInstall libsane1:i386 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
  Installing libsane as Depends of libsane1
    MarkInstall libsane:i386 < none -> 1.0.29-0ubuntu5.2 @un uN Ib > FU=0
    Installing libcurl3-gnutls as Depends of libsane
      MarkInstall libcurl3-gnutls:i386 < none -> 7.68.0-1ubuntu2.4 @un uN Ib > FU=0
      Installing libbrotli1 as Depends of libcurl3-gnutls
        MarkInstall libbrotli1:i386 < none -> 1.0.7-6ubuntu0.1 @un uN > FU=0
      Installing libnettle7 as Depends of libcurl3-gnutls
        MarkInstall libnettle7:i386 < none -> 3.5.1+really3.5.1-2 @un uN > FU=0
      Installing libnghttp2-14 as Depends of libcurl3-gnutls
        MarkInstall libnghttp2-14:i386 < none -> 1.40.0-1build1 @un uN > FU=0
      Installing libpsl5 as Depends of libcurl3-gnutls
        MarkInstall libpsl5:i386 < none -> 0.21.0-1ubuntu1 @un uN > FU=0
      Installing librtmp1 as Depends of libcurl3-gnutls
        MarkInstall librtmp1:i386 < none -> 2.4+20151223.gitfa8646d.1-2build1 @un uN Ib > FU=0
        Installing libhogweed5 as Depends of librtmp1
          MarkInstall libhogweed5:i386 < none -> 3.5.1+really3.5.1-2 @un uN > FU=0
      Installing libssh-4 as Depends of libcurl3-gnutls
        MarkInstall libssh-4:i386 < none -> 0.9.3-2ubuntu2.1 @un uN > FU=0
    Installing libsnmp35 as Depends of libsane
      MarkInstall libsnmp35:i386 < none -> 5.8+dfsg-2ubuntu2.3 @un uN Ib > FU=0
      Installing libmysqlclient21 as Depends of libsnmp35
        MarkInstall libmysqlclient21:i386 < none -> 8.0.23-0ubuntu0.20.04.1 @un uN > FU=0
      Installing libpci3 as Depends of libsnmp35
        MarkInstall libpci3:i386 < none -> 1:3.6.4-1 @un uN Ib > FU=0
        Installing pci.ids as Depends of libpci3
          MarkInstall pci.ids:amd64 < none -> 0.0~2020.03.20-1 @un uN > FU=0
      Installing libperl5.30 as Depends of libsnmp35
        MarkInstall libperl5.30:i386 < none -> 5.30.0-9ubuntu0.2 @un uN Ib > FU=0
        Installing libbz2-1.0 as Depends of libperl5.30
          MarkInstall libbz2-1.0:i386 < none -> 1.0.8-2 @un uN > FU=0
        Installing libgdbm-compat4 as Depends of libperl5.30
          MarkInstall libgdbm-compat4:i386 < none -> 1.18.1-5 @un uN Ib > FU=0
          Installing libgdbm6 as Depends of libgdbm-compat4
            MarkInstall libgdbm6:i386 < none -> 1.18.1-5 @un uN > FU=0
      Installing libsensors5 as Depends of libsnmp35
        MarkInstall libsensors5:i386 < none -> 1:3.6.0-2ubuntu1 @un uN > FU=0
  MarkInstall imagemagick-6.q16:amd64 < 8:6.9.7.4+dfsg-16ubuntu6.9 -> 8:6.9.10.23+dfsg-2.1ubuntu11.2 @ii umU Ib > FU=0
  Installing libmagickcore-6.q16-6 as Depends of imagemagick-6.q16
    MarkInstall libmagickcore-6.q16-6:amd64 < none -> 8:6.9.10.23+dfsg-2.1ubuntu11.2 @un uN > FU=0
  Installing libmagickwand-6.q16-6 as Depends of imagemagick-6.q16
    MarkInstall libmagickwand-6.q16-6:amd64 < none -> 8:6.9.10.23+dfsg-2.1ubuntu11.2 @un uN > FU=0
  new important dependency: libmagickcore-6.q16-6-extra:amd64
  Installing libmagickcore-6.q16-6-extra as Recommends of imagemagick-6.q16
    MarkInstall libmagickcore-6.q16-6-extra:amd64 < none -> 8:6.9.10.23+dfsg-2.1ubuntu11.2 @un uN Ib > FU=0
    Installing libopenexr24 as Depends of libmagickcore-6.q16-6-extra
      MarkInstall libopenexr24:amd64 < none -> 2.3.0-6ubuntu0.3 @un uN Ib > FU=0
      Installing libilmbase24 as Depends of libopenexr24
        MarkInstall libilmbase24:amd64 < none -> 2.3.0-6build1 @un uN > FU=0
  MarkInstall libtiff5:i386 < 4.0.9-5ubuntu0.4 -> 4.1.0+git191117-2ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libzstd1 as Depends of libtiff5
    MarkInstall libzstd1:i386 < none -> 1.4.4+dfsg-3ubuntu0.1 @un uN > FU=0
  MarkInstall libqt5gui5:amd64 < 5.9.5+dfsg-0ubuntu2.5 -> 5.12.8+dfsg-0ubuntu1 @ii umU Ib > FU=0
  Installing libxcb-xinput0 as Depends of libqt5gui5
    MarkInstall libxcb-xinput0:amd64 < none -> 1.14-2 @un uN > FU=0
  MarkInstall libsnmp30:amd64 < 5.7.3+dfsg-1.8ubuntu3.6 @ii mK Ib > FU=0
  Installing libsensors4 as Depends of libsnmp30
      MarkKeep libsensors4:amd64 < 1:3.4.0-4 @ii mR > FU=0
  MarkInstall wireshark-common:amd64 < 2.6.10-1~ubuntu18.04.0 -> 3.2.3-1 @ii umU Ib > FU=0
  Installing libwireshark13 as Depends of wireshark-common
    MarkInstall libwireshark13:amd64 < none -> 3.2.3-1 @un uN Ib > FU=0
    Installing libwiretap10 as Depends of libwireshark13
      MarkInstall libwiretap10:amd64 < none -> 3.2.3-1 @un uN Ib > FU=0
      Installing libwsutil11 as Depends of libwiretap10
        MarkInstall libwsutil11:amd64 < none -> 3.2.3-1 @un uN > FU=0
  MarkInstall libfile-mimeinfo-perl:amd64 < 0.28-1 -> 0.29-1 @ii umU IPb > FU=0
  new important dependency: libio-stringy-perl:amd64
  Installing libio-stringy-perl as Recommends of libfile-mimeinfo-perl
    MarkInstall libio-stringy-perl:amd64 < none -> 2.111-3 @un uN > FU=0
  MarkInstall libfabric1:amd64 < 1.5.3-1 -> 1.6.2-3 @ii ugU Ib > FU=0
  Installing libpsm2-2 as Depends of libfabric1
    MarkInstall libpsm2-2:amd64 < none -> 11.2.86-1 @un uN > FU=0
  MarkInstall okular:amd64 < 4:17.12.3-0ubuntu1 -> 4:19.12.3-2ubuntu1 @ii umU Ib > FU=0
  Installing libokular5core9 as Depends of okular
    MarkInstall libokular5core9:amd64 < none -> 4:19.12.3-2ubuntu1 @un uN > FU=0
  new important dependency: okular-extra-backends:amd64
  Installing okular-extra-backends as Recommends of okular
    MarkInstall okular-extra-backends:amd64 < none -> 4:19.12.3-2ubuntu1 @un uN Ib > FU=0
    Installing libchm1 as Depends of okular-extra-backends
      MarkInstall libchm1:amd64 < none -> 2:0.40a-5 @un uN > FU=0
    Installing libepub0 as Depends of okular-extra-backends
      MarkInstall libepub0:amd64 < none -> 0.2.2-4ubuntu2 @un uN Ib > FU=0
      Installing libzip5 as Depends of libepub0
        MarkInstall libzip5:amd64 < none -> 1.5.1-0ubuntu1 @un uN > FU=0
  MarkInstall nautilus:amd64 < 1:3.26.4-0~ubuntu18.04.5 -> 1:3.36.3-0ubuntu1 @ii umU NPb Ib > FU=0
  Installing tracker as Depends of nautilus
    MarkInstall tracker:amd64 < none -> 2.3.6-0ubuntu1 @un uN Ib > FU=0
    Installing libtracker-control-2.0-0 as Depends of tracker
      MarkInstall libtracker-control-2.0-0:amd64 < none -> 2.3.6-0ubuntu1 @un uN > FU=0
    Installing tracker-miner-fs as Recommends of tracker
      MarkInstall tracker-miner-fs:amd64 < none -> 2.3.3-2 @un uN Ib > FU=0
      Installing libtracker-miner-2.0-0 as Depends of tracker-miner-fs
        MarkInstall libtracker-miner-2.0-0:amd64 < none -> 2.3.6-0ubuntu1 @un uN > FU=0
      Installing tracker-extract as Depends of tracker-miner-fs
        MarkInstall tracker-extract:amd64 < none -> 2.3.3-2 @un uN Ib > FU=0
        Installing libcue2 as Depends of tracker-extract
          MarkInstall libcue2:amd64 < none -> 2.2.1-2 @un uN > FU=0
        Installing libgsf-1-114 as Depends of tracker-extract
          MarkInstall libgsf-1-114:amd64 < none -> 1.14.46-1 @un uN Ib > FU=0
          Installing libgsf-1-common as Depends of libgsf-1-114
            MarkInstall libgsf-1-common:amd64 < none -> 1.14.46-1 @un uN > FU=0
  MarkInstall libxenstore3.0:amd64 < 4.9.2-0ubuntu1 -> 4.11.3+24-g14b62ab3e5-1ubuntu2 @ii umU Ib > FU=0
  Installing libxentoolcore1 as Depends of libxenstore3.0
    MarkInstall libxentoolcore1:amd64 < none -> 4.11.3+24-g14b62ab3e5-1ubuntu2 @un uN > FU=0
  MarkInstall libcupsmime1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
  MarkInstall libimobiledevice6:amd64 < 1.2.1~git20171128.5a854327+dfsg-0.1 -> 1.2.1~git20191129.9f79242-1build1 @ii umU Ib > FU=0
  Installing libusbmuxd6 as Depends of libimobiledevice6
    MarkInstall libusbmuxd6:amd64 < none -> 2.0.1-2 @un uN > FU=0
  MarkInstall firebird3.0-examples:amd64 < 3.0.2.32703.ds4-11ubuntu2 -> 3.0.5.33220.ds4-1build2 @ii umU NPb IPb > FU=0
  MarkInstall libavcodec-extra:amd64 < 7:3.4.8-0ubuntu0.2 -> 7:4.2.4-1ubuntu0.1 @ii umU Ib > FU=0
  Installing libavcodec-extra58 as Depends of libavcodec-extra
    MarkInstall libavcodec-extra58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
     Removing: libavcodec58
      MarkDelete libavcodec58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
  MarkInstall ruby:amd64 < 1:2.5.1 -> 1:2.7+1 @ii umU Ib > FU=0
  Installing ruby2.7 as Depends of ruby
    MarkInstall ruby2.7:amd64 < none -> 2.7.0-5ubuntu1.3 @un uN > FU=0
  MarkInstall libmirclient9:amd64 < 0.31.1-0ubuntu1 -> 1.7.1-0ubuntu2 @ii umU Ib > FU=0
  Installing libcapnp-0.7.0 as Depends of libmirclient9
    MarkInstall libcapnp-0.7.0:amd64 < none -> 0.7.0-6 @un uN > FU=0
  MarkInstall libfreetype6-dev:amd64 < 2.8.1-2ubuntu2.1 -> 2.10.1-2ubuntu0.1 @ii umU Ib > FU=0
  Installing libfreetype-dev as Depends of libfreetype6-dev
    MarkInstall libfreetype-dev:amd64 < none -> 2.10.1-2ubuntu0.1 @un uN > FU=0
  MarkInstall libvirt-daemon-system:amd64 < 4.0.0-1ubuntu8.19 -> 6.0.0-0ubuntu8.8 @ii umU Ib > FU=0
  Installing libvirt-daemon-system-systemd as Depends of libvirt-daemon-system
    MarkInstall libvirt-daemon-system-systemd:amd64 < none -> 6.0.0-0ubuntu8.8 @un uN Ib > FU=0
    Installing systemd-container as Depends of libvirt-daemon-system-systemd
      MarkInstall systemd-container:amd64 < none -> 245.4-4ubuntu3.5 @un uN IPb > FU=0
      Installing libnss-mymachines as Recommends of systemd-container
        MarkInstall libnss-mymachines:amd64 < none -> 245.4-4ubuntu3.5 @un uN > FU=0
  MarkInstall xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mK Ib > FU=0
  MarkInstall libcap2-bin:amd64 < 1:2.25-1.2 -> 1:2.32-1 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on libpam-cap:amd64
  MarkInstall tor:amd64 < 0.3.2.10-1 -> 0.4.2.7-1 @ii umU Ib > FU=0
  Installing libevent-2.1-7 as Depends of tor
    MarkInstall libevent-2.1-7:amd64 < none -> 2.1.11-stable-1 @un uN > FU=0
  MarkInstall libical-dev:amd64 < 3.0.1-5 -> 3.0.8-1 @ii umU Ib > FU=0
  Installing gir1.2-ical-3.0 as Depends of libical-dev
    MarkInstall gir1.2-ical-3.0:amd64 < none -> 3.0.8-1 @un uN > FU=0
  MarkInstall acpi-support:amd64 < 0.142 -> 0.143 @ii umU NPb IPb > FU=0
  MarkInstall libqbscore1.10:amd64 < 1.10.1+dfsg-1 @ii mK Ib > FU=0
    MarkKeep libhfstospell9:amd64 < 0.4.5~r343-2.1build2 @ii mR > FU=0
  MarkInstall fonts-gujr:amd64 < 2:1.2 -> 2:1.3 @ii umU Ib > FU=0
  Installing fonts-yrsa-rasa as Depends of fonts-gujr
    MarkInstall fonts-yrsa-rasa:amd64 < none -> 1.002-2 @un uN > FU=0
  MarkInstall printer-driver-gutenprint:amd64 < 5.2.13-2 -> 5.3.3-4 @ii umU Ib > FU=0
  Installing libgutenprint9 as Depends of printer-driver-gutenprint
    MarkInstall libgutenprint9:amd64 < none -> 5.3.3-4 @un uN Ib > FU=0
    Installing libgutenprint-common as Depends of libgutenprint9
      MarkInstall libgutenprint-common:amd64 < none -> 5.3.3-4 @un uN > FU=0
  MarkInstall lintian:amd64 < 2.5.81ubuntu1 -> 2.62.0 @ii umU Ib > FU=0
  Installing libcapture-tiny-perl as Depends of lintian
    MarkInstall libcapture-tiny-perl:amd64 < none -> 0.48-1 @un uN > FU=0
  Installing libclass-xsaccessor-perl as Depends of lintian
    MarkInstall libclass-xsaccessor-perl:amd64 < none -> 1.19-3build3 @un uN > FU=0
  Installing libcpanel-json-xs-perl as Depends of lintian
    MarkInstall libcpanel-json-xs-perl:amd64 < none -> 4.19-1build1 @un uN > FU=0
  Installing libdevel-size-perl as Depends of lintian
    MarkInstall libdevel-size-perl:amd64 < none -> 0.83-1build1 @un uN > FU=0
  Installing libfile-find-rule-perl as Depends of lintian
    MarkInstall libfile-find-rule-perl:amd64 < none -> 0.34-1 @un uN Ib > FU=0
    Installing libnumber-compare-perl as Depends of libfile-find-rule-perl
      MarkInstall libnumber-compare-perl:amd64 < none -> 0.03-1 @un uN > FU=0
    Installing libtext-glob-perl as Depends of libfile-find-rule-perl
      MarkInstall libtext-glob-perl:amd64 < none -> 0.10-1 @un uN > FU=0
  Installing libfont-ttf-perl as Depends of lintian
    MarkInstall libfont-ttf-perl:amd64 < none -> 1.06-1 @un uN > FU=0
  Installing libio-async-perl as Depends of lintian
    MarkInstall libio-async-perl:amd64 < none -> 0.75-1 @un uN Ib > FU=0
    Installing libfuture-perl as Depends of libio-async-perl
      MarkInstall libfuture-perl:amd64 < none -> 0.43-1 @un uN > FU=0
    Installing libstruct-dumb-perl as Depends of libio-async-perl
      MarkInstall libstruct-dumb-perl:amd64 < none -> 0.09-1 @un uN > FU=0
    Installing libasync-mergepoint-perl as Recommends of libio-async-perl
      MarkInstall libasync-mergepoint-perl:amd64 < none -> 0.04-2 @un uN > FU=0
    Installing libsereal-perl as Recommends of libio-async-perl
      MarkInstall libsereal-perl:amd64 < none -> 4.011-1 @un uN Ib > FU=0
      Installing libsereal-decoder-perl as Depends of libsereal-perl
        MarkInstall libsereal-decoder-perl:amd64 < none -> 4.011+ds-1build1 @un uN > FU=0
      Installing libsereal-encoder-perl as Depends of libsereal-perl
        MarkInstall libsereal-encoder-perl:amd64 < none -> 4.011+ds-1build1 @un uN > FU=0
    Installing libtest-fatal-perl as Recommends of libio-async-perl
      MarkInstall libtest-fatal-perl:amd64 < none -> 0.014-1 @un uN > FU=0
    Installing libtest-refcount-perl as Recommends of libio-async-perl
      MarkInstall libtest-refcount-perl:amd64 < none -> 0.10-1 @un uN > FU=0
  Installing libio-async-loop-epoll-perl as Depends of lintian
    MarkInstall libio-async-loop-epoll-perl:amd64 < none -> 0.20-1 @un uN Ib > FU=0
    Installing liblinux-epoll-perl as Depends of libio-async-loop-epoll-perl
      MarkInstall liblinux-epoll-perl:amd64 < none -> 0.017-1 @un uN > FU=0
  Installing libjson-maybexs-perl as Depends of lintian
    MarkInstall libjson-maybexs-perl:amd64 < none -> 1.004000-1 @un uN > FU=0
  Installing liblist-compare-perl as Depends of lintian
    MarkInstall liblist-compare-perl:amd64 < none -> 0.53-1 @un uN > FU=0
  Installing libmoo-perl as Depends of lintian
    MarkInstall libmoo-perl:amd64 < none -> 2.003006-1 @un uN Ib > FU=0
    Installing libclass-method-modifiers-perl as Depends of libmoo-perl
      MarkInstall libclass-method-modifiers-perl:amd64 < none -> 2.13-1 @un uN > FU=0
    Installing libimport-into-perl as Depends of libmoo-perl
      MarkInstall libimport-into-perl:amd64 < none -> 1.002005-1 @un uN Ib > FU=0
      Installing libmodule-runtime-perl as Depends of libimport-into-perl
        MarkInstall libmodule-runtime-perl:amd64 < none -> 0.016-1 @un uN Ib > FU=0
        Installing libparams-classify-perl as Depends of libmodule-runtime-perl
          MarkInstall libparams-classify-perl:amd64 < none -> 0.015-1build2 @un uN Ib > FU=0
          Installing libdevel-callchecker-perl as Depends of libparams-classify-perl
            MarkInstall libdevel-callchecker-perl:amd64 < none -> 0.008-1ubuntu1 @un uN Ib > FU=0
            Installing libb-hooks-op-check-perl as Depends of libdevel-callchecker-perl
              MarkInstall libb-hooks-op-check-perl:amd64 < none -> 0.22-1build2 @un uN > FU=0
            Installing libdynaloader-functions-perl as Depends of libdevel-callchecker-perl
              MarkInstall libdynaloader-functions-perl:amd64 < none -> 0.003-1 @un uN > FU=0
    Installing librole-tiny-perl as Depends of libmoo-perl
      MarkInstall librole-tiny-perl:amd64 < none -> 2.001004-1 @un uN > FU=0
    Installing libstrictures-perl as Depends of libmoo-perl
      MarkInstall libstrictures-perl:amd64 < none -> 2.000006-1 @un uN > FU=0
    Installing libsub-quote-perl as Depends of libmoo-perl
      MarkInstall libsub-quote-perl:amd64 < none -> 2.006006-1 @un uN > FU=0
  Installing libmoox-aliases-perl as Depends of lintian
    MarkInstall libmoox-aliases-perl:amd64 < none -> 0.001006-1 @un uN > FU=0
  Installing libnamespace-clean-perl as Depends of lintian
    MarkInstall libnamespace-clean-perl:amd64 < none -> 0.27-1 @un uN Ib > FU=0
    Installing libb-hooks-endofscope-perl as Depends of libnamespace-clean-perl
      MarkInstall libb-hooks-endofscope-perl:amd64 < none -> 0.24-1 @un uN Ib > FU=0
      Installing libmodule-implementation-perl as Depends of libb-hooks-endofscope-perl
        MarkInstall libmodule-implementation-perl:amd64 < none -> 0.09-1 @un uN > FU=0
      Installing libsub-exporter-progressive-perl as Depends of libb-hooks-endofscope-perl
        MarkInstall libsub-exporter-progressive-perl:amd64 < none -> 0.001013-1 @un uN > FU=0
      Installing libvariable-magic-perl as Depends of libb-hooks-endofscope-perl
        MarkInstall libvariable-magic-perl:amd64 < none -> 0.62-1build2 @un uN > FU=0
    Installing libpackage-stash-perl as Depends of libnamespace-clean-perl
      MarkInstall libpackage-stash-perl:amd64 < none -> 0.38-1 @un uN IPb > FU=0
      Installing libpackage-stash-xs-perl as Recommends of libpackage-stash-perl
        MarkInstall libpackage-stash-xs-perl:amd64 < none -> 0.29-1build1 @un uN > FU=0
    Installing libsub-identify-perl as Depends of libnamespace-clean-perl
      MarkInstall libsub-identify-perl:amd64 < none -> 0.14-1build2 @un uN > FU=0
  Installing libpath-tiny-perl as Depends of lintian
    MarkInstall libpath-tiny-perl:amd64 < none -> 0.108-1 @un uN IPb > FU=0
    Installing libunicode-utf8-perl as Recommends of libpath-tiny-perl
      MarkInstall libunicode-utf8-perl:amd64 < none -> 0.62-1build1 @un uN > FU=0
  Installing libtype-tiny-perl as Depends of lintian
    MarkInstall libtype-tiny-perl:amd64 < none -> 1.008001-2 @un uN IPb > FU=0
    Installing libref-util-perl as Recommends of libtype-tiny-perl
      MarkInstall libref-util-perl:amd64 < none -> 0.204-1 @un uN IPb > FU=0
      Installing libreadonly-perl as Recommends of libref-util-perl
        MarkInstall libreadonly-perl:amd64 < none -> 2.050-2 @un uN > FU=0
      Installing libref-util-xs-perl as Recommends of libref-util-perl
        MarkInstall libref-util-xs-perl:amd64 < none -> 0.117-1build2 @un uN > FU=0
    Installing libtype-tiny-xs-perl as Recommends of libtype-tiny-perl
      MarkInstall libtype-tiny-xs-perl:amd64 < none -> 0.016-1 @un uN > FU=0
  Installing libxml-writer-perl as Depends of lintian
    MarkInstall libxml-writer-perl:amd64 < none -> 0.625-1 @un uN > FU=0
  MarkInstall brltty:amd64 < 5.5-4ubuntu2.0.1 -> 6.0+dfsg-4ubuntu6 @ii umU Ib > FU=0
  Installing libpcre2-32-0 as Depends of brltty
    MarkInstall libpcre2-32-0:amd64 < none -> 10.34-7 @un uN > FU=0
  MarkInstall wine-stable:amd64 < 3.0-1ubuntu1 -> 3.0.1ubuntu1 @ii umU Ib > FU=0
  Installing wine as Depends of wine-stable
    MarkInstall wine:amd64 < none -> 5.0-3ubuntu1 @un uN > FU=0
  MarkInstall libselinux1:i386 < 2.7-2build2 -> 3.0-1build2 @ii umU Ib > FU=0
  Installing libpcre2-8-0 as Depends of libselinux1
    MarkInstall libpcre2-8-0:i386 < none -> 10.34-7 @un uN > FU=0
  MarkInstall libncurses5-dev:amd64 < 6.1-1ubuntu1.18.04 -> 6.2-0ubuntu2 @ii umU Ib > FU=0
  Installing libncurses-dev as Depends of libncurses5-dev
    MarkInstall libncurses-dev:amd64 < none -> 6.2-0ubuntu2 @un uN > FU=0
  MarkInstall vlc:amd64 < 3.0.8-0ubuntu18.04.1 -> 3.0.9.2-1 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on vlc-plugin-samba:amd64
  MarkInstall libglib2.0-dev:amd64 < 2.56.4-0ubuntu0.18.04.8 -> 2.64.6-1~ubuntu20.04.3 @ii umU Ib > FU=0
  Installing libmount-dev as Depends of libglib2.0-dev
    MarkInstall libmount-dev:amd64 < none -> 2.34-0.1ubuntu9.1 @un uN Ib > FU=0
    Installing libblkid-dev as Depends of libmount-dev
      MarkInstall libblkid-dev:amd64 < none -> 2.34-0.1ubuntu9.1 @un uN > FU=0
  Installing libselinux1-dev as Depends of libglib2.0-dev
    MarkInstall libselinux1-dev:amd64 < none -> 3.0-1build2 @un uN Ib > FU=0
    Installing libsepol1-dev as Depends of libselinux1-dev
      MarkInstall libsepol1-dev:amd64 < none -> 3.0-1 @un uN > FU=0
    Installing libpcre2-dev as Depends of libselinux1-dev
      MarkInstall libpcre2-dev:amd64 < none -> 10.34-7 @un uN Ib > FU=0
      Installing libpcre2-16-0 as Depends of libpcre2-dev
        MarkInstall libpcre2-16-0:amd64 < none -> 10.34-7 @un uN > FU=0
      Installing libpcre2-posix2 as Depends of libpcre2-dev
        MarkInstall libpcre2-posix2:amd64 < none -> 10.34-7 @un uN > FU=0
  MarkInstall systemd:amd64 < 237-3ubuntu10.45 -> 245.4-4ubuntu3.5 @ii umU Ib > FU=0
  Installing systemd-timesyncd as Depends of systemd
    MarkInstall systemd-timesyncd:amd64 < none -> 245.4-4ubuntu3.5 @un uN > FU=0
  MarkInstall libwebkit2gtk-4.0-37:amd64 < 2.30.5-0ubuntu0.18.04.1 -> 2.30.5-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing xdg-dbus-proxy as Depends of libwebkit2gtk-4.0-37
    MarkInstall xdg-dbus-proxy:amd64 < none -> 0.1.2-1 @un uN > FU=0
  MarkInstall gnome-online-accounts:amd64 < 3.28.0-0ubuntu2.1 -> 3.36.0-1ubuntu1 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on gnome-control-center:amd64
  MarkInstall libqt5core5a:amd64 < 5.9.5+dfsg-0ubuntu2.5 -> 5.12.8+dfsg-0ubuntu1 @ii umU Ib > FU=0
  Installing libdouble-conversion3 as Depends of libqt5core5a
    MarkInstall libdouble-conversion3:amd64 < none -> 3.1.5-4ubuntu1 @un uN > FU=0
   Removing: libqtcore4
    MarkDelete libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK > FU=0
  MarkInstall shotwell:amd64 < 0.28.4-0ubuntu2 -> 0.30.10-0ubuntu0.1 @ii umU Ib > FU=0
  Installing libraw19 as Depends of shotwell
    MarkInstall libraw19:amd64 < none -> 0.19.5-1ubuntu1 @un uN > FU=0
  MarkInstall libpolkit-backend-1-0:amd64 < 0.105-20ubuntu0.18.04.5 @ii mK Ib > FU=0
  MarkInstall debhelper:amd64 < 11.1.6ubuntu2 -> 12.10ubuntu1 @ii umU Ib > FU=0
  Installing dwz as Depends of debhelper
    MarkInstall dwz:amd64 < none -> 0.13-5 @un uN > FU=0
  MarkInstall xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
  MarkInstall openssh-client:amd64 < 1:7.6p1-4ubuntu0.3 -> 1:8.2p1-4ubuntu0.2 @ii umU Ib > FU=0
  Installing libfido2-1 as Depends of openssh-client
    MarkInstall libfido2-1:amd64 < none -> 1.3.1-1ubuntu2 @un uN Ib > FU=0
    Installing libcbor0.6 as Depends of libfido2-1
      MarkInstall libcbor0.6:amd64 < none -> 0.6.0-0ubuntu1 @un uN > FU=0
  MarkInstall libqt4-sql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
  Installing libqtcore4 as Depends of libqt4-sql
      MarkKeep libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > FU=0
  MarkInstall liblouisutdml-bin:amd64 < 2.7.0-1 -> 2.8.0-3 @ii umU Ib > FU=0
  Installing liblouisutdml9 as Depends of liblouisutdml-bin
    MarkInstall liblouisutdml9:amd64 < none -> 2.8.0-3 @un uN > FU=0
  MarkInstall libphonon4qt5-4:amd64 < 4:4.10.0-2 -> 4:4.11.1-3build1 @ii umU Ib > FU=0
  Installing libphonon4qt5-data as Depends of libphonon4qt5-4
    MarkInstall libphonon4qt5-data:amd64 < none -> 4:4.11.1-3build1 @un uN > FU=0
  MarkInstall qtbase5-dev:amd64 < 5.9.5+dfsg-0ubuntu2.5 -> 5.12.8+dfsg-0ubuntu1 @ii umU Ib > FU=0
  Installing libvulkan-dev as Depends of qtbase5-dev
    MarkInstall libvulkan-dev:amd64 < none -> 1.2.131.2-1 @un uN > FU=0
  MarkInstall libept1.5.0:amd64 < 1.1+nmu3build1 @ii mK Ib > FU=0
  Installing libapt-pkg5.0 as Depends of libept1.5.0
      MarkKeep libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mR > FU=0
  MarkInstall cups-filters-core-drivers:amd64 < 1.20.2-0ubuntu3.1 -> 1.27.4-1 @ii umU Ib > FU=0
  Installing libpoppler-cpp0v5 as Depends of cups-filters-core-drivers
    MarkInstall libpoppler-cpp0v5:amd64 < none -> 0.86.1-0ubuntu1 @un uN > FU=0
  MarkInstall ibus:amd64 < 1.5.17-3ubuntu5.3 -> 1.5.22-2ubuntu2.1 @ii umU Ib > FU=0
  Installing ibus-data as Depends of ibus
    MarkInstall ibus-data:amd64 < none -> 1.5.22-2ubuntu2.1 @un uN > FU=0
  Installing python3-ibus-1.0 as Depends of ibus
    MarkInstall python3-ibus-1.0:amd64 < none -> 1.5.22-2ubuntu2.1 @un uN > FU=0
  MarkInstall xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
  MarkInstall libxml2:i386 < 2.9.4+dfsg1-6.1ubuntu1.3 -> 2.9.10+dfsg-5 @ii umU Ib > FU=0
  Installing libicu66 as Depends of libxml2
    MarkInstall libicu66:i386 < none -> 66.1-2ubuntu2 @un uN > FU=0
  MarkInstall libgimp2.0:amd64 < 2.8.22-1 -> 2.10.18-1 @ii umU Ib > FU=0
  Installing libbabl-0.1-0 as Depends of libgimp2.0
    MarkInstall libbabl-0.1-0:amd64 < none -> 0.1.74-1 @un uN > FU=0
  Installing libgegl-0.4-0 as Depends of libgimp2.0
    MarkInstall libgegl-0.4-0:amd64 < none -> 0.4.22-3 @un uN Ib > FU=0
    Installing libumfpack5 as Depends of libgegl-0.4-0
      MarkInstall libumfpack5:amd64 < none -> 1:5.7.1+dfsg-2 @un uN Ib > FU=0
      Installing libamd2 as Depends of libumfpack5
        MarkInstall libamd2:amd64 < none -> 1:5.7.1+dfsg-2 @un uN > FU=0
      Installing libcholmod3 as Depends of libumfpack5
        MarkInstall libcholmod3:amd64 < none -> 1:5.7.1+dfsg-2 @un uN Ib > FU=0
        Installing libcamd2 as Depends of libcholmod3
          MarkInstall libcamd2:amd64 < none -> 1:5.7.1+dfsg-2 @un uN > FU=0
        Installing libccolamd2 as Depends of libcholmod3
          MarkInstall libccolamd2:amd64 < none -> 1:5.7.1+dfsg-2 @un uN > FU=0
        Installing libmetis5 as Depends of libcholmod3
          MarkInstall libmetis5:amd64 < none -> 5.1.0.dfsg-5 @un uN > FU=0
    Installing libgegl-common as Depends of libgegl-0.4-0
      MarkInstall libgegl-common:amd64 < none -> 0.4.22-3 @un uN > FU=0
  MarkInstall ubuntu-wallpapers:amd64 < 18.04.1-0ubuntu1 -> 20.04.2-0ubuntu1 @ii umU Ib > FU=0
  Installing ubuntu-wallpapers-focal as Depends of ubuntu-wallpapers
    MarkInstall ubuntu-wallpapers-focal:amd64 < none -> 20.04.2-0ubuntu1 @un uN > FU=0
  MarkInstall libcupsppdc1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
  MarkInstall texlive-binaries:amd64 < 2017.20170613.44572-8ubuntu0.1 -> 2019.20190605.51237-3build2 @ii ugU Ib > FU=0
  Installing libtexlua53 as Depends of texlive-binaries
    MarkInstall libtexlua53:amd64 < none -> 2019.20190605.51237-3build2 @un uN > FU=0
  Installing libteckit0 as Depends of texlive-binaries
    MarkInstall libteckit0:amd64 < none -> 2.5.8+ds2-5ubuntu2 @un uN > FU=0
  new important dependency: dvisvgm:amd64
  Installing dvisvgm as Recommends of texlive-binaries
    MarkInstall dvisvgm:amd64 < none -> 2.8.1-1build1 @un uN > FU=0
  MarkInstall fwupd:amd64 < 1.2.10-1ubuntu2~ubuntu18.04.5 -> 1.3.11-1~focal1 @ii umU NPb Ib > FU=0
  Installing libfwupdplugin1 as Depends of fwupd
    MarkInstall libfwupdplugin1:amd64 < none -> 1.3.11-1~focal1 @un uN > FU=0
  Installing libtss2-esys0 as Depends of fwupd
    MarkInstall libtss2-esys0:amd64 < none -> 2.3.2-1 @un uN Ib > FU=0
    Installing tpm-udev as Depends of libtss2-esys0
      MarkInstall tpm-udev:amd64 < none -> 0.4 @un uN > FU=0
  ignore old unsatisfied important dependency on fwupd-signed:amd64
  MarkInstall libmono-system-security4.0-cil:amd64 < 4.6.2.7+dfsg-1ubuntu1 -> 6.8.0.105+dfsg-2 @ii umU IPb > FU=0
  new important dependency: libmono-btls-interface4.0-cil:amd64
  Installing libmono-btls-interface4.0-cil as Recommends of libmono-system-security4.0-cil
    MarkInstall libmono-btls-interface4.0-cil:amd64 < none -> 6.8.0.105+dfsg-2 @un uN > FU=0
  MarkInstall libedata-book-1.2-25:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib > FU=0
  MarkInstall unity-settings-daemon:amd64 < 15.04.1+18.04.20180413-0ubuntu1.2 -> 15.04.1+20.04.20200325-0ubuntu1 @ii umU NPb IPb > FU=0
  MarkInstall libp11-kit0:i386 < 0.23.9-2ubuntu0.1 -> 0.23.20-1ubuntu0.1 @ii umU Ib > FU=0
  Installing libffi7 as Depends of libp11-kit0
    MarkInstall libffi7:i386 < none -> 3.3-4 @un uN > FU=0
  MarkInstall gnome-shell:amd64 < 3.28.4-0ubuntu18.04.3 -> 3.36.4-1ubuntu1~20.04.2 @ii umU NPb Ib > FU=0
  Installing gir1.2-mutter-6 as Depends of gnome-shell
    MarkInstall gir1.2-mutter-6:amd64 < none -> 3.36.7+git20201123-0.20.04.1 @un uN Ib > FU=0
    Installing libmutter-6-0 as Depends of gir1.2-mutter-6
      MarkInstall libmutter-6-0:amd64 < none -> 3.36.7+git20201123-0.20.04.1 @un uN > FU=0
    Installing gir1.2-graphene-1.0 as Depends of gir1.2-mutter-6
      MarkInstall gir1.2-graphene-1.0:amd64 < none -> 1.10.0-1build2 @un uN > FU=0
  ignore old unsatisfied important dependency on gnome-control-center:amd64
  new important dependency: switcheroo-control:amd64
  Installing switcheroo-control as Recommends of gnome-shell
    MarkInstall switcheroo-control:amd64 < none -> 2.1-1 @un uN > FU=0
  MarkInstall libedata-cal-1.2-28:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib > FU=0
  MarkInstall indicator-appmenu:amd64 < 15.02.0+16.10.20160927-0ubuntu3 -> 15.02.0+16.10.20160927-0ubuntu5 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on unity-gtk2-module:amd64
  ignore old unsatisfied important dependency on unity-gtk3-module:amd64
  MarkInstall rosegarden:amd64 < 1:17.12.1-1 -> 1:19.12-1build1 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on jackd:amd64
  ignore old unsatisfied important dependency on lilypond:amd64
  MarkInstall gparted:amd64 < 0.30.0-3ubuntu2 -> 1.0.0-0.1build1 @ii umU Ib > FU=0
  Installing gparted-common as Depends of gparted
    MarkInstall gparted-common:amd64 < none -> 1.0.0-0.1build1 @un uN > FU=0
  MarkInstall qttools5-dev-tools:amd64 < 5.9.5-0ubuntu1 -> 5.12.8-0ubuntu1 @ii umU Ib > FU=0
  Installing qdoc-qt5 as Depends of qttools5-dev-tools
    MarkInstall qdoc-qt5:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
  Installing qhelpgenerator-qt5 as Depends of qttools5-dev-tools
    MarkInstall qhelpgenerator-qt5:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
  Installing qtattributionsscanner-qt5 as Depends of qttools5-dev-tools
    MarkInstall qtattributionsscanner-qt5:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
  MarkInstall vlc-plugin-base:amd64 < 3.0.8-0ubuntu18.04.1 -> 3.0.9.2-1 @ii umU Ib > FU=0
  Installing libixml10 as Depends of vlc-plugin-base
    MarkInstall libixml10:amd64 < none -> 1:1.8.4-2ubuntu2 @un uN > FU=0
  Installing liblivemedia77 as Depends of vlc-plugin-base
    MarkInstall liblivemedia77:amd64 < none -> 2020.01.19-1build1 @un uN > FU=0
  Installing libspatialaudio0 as Depends of vlc-plugin-base
    MarkInstall libspatialaudio0:amd64 < none -> 0.3.0+git20180730+dfsg1-2build1 @un uN > FU=0
  Installing libsrt1 as Depends of vlc-plugin-base
    MarkInstall libsrt1:amd64 < none -> 1.4.0-1build1 @un uN > FU=0
  Installing libupnp13 as Depends of vlc-plugin-base
    MarkInstall libupnp13:amd64 < none -> 1:1.8.4-2ubuntu2 @un uN > FU=0
    MarkKeep libtinyxml2-6:amd64 < 6.0.0+dfsg-1 @ii mR > FU=0
  MarkInstall synaptic:amd64 < 0.84.3ubuntu1 -> 0.84.6ubuntu5 @ii umU Ib > FU=0
  Installing libept1.6.0 as Depends of synaptic
    MarkInstall libept1.6.0:amd64 < none -> 1.1+nmu3ubuntu3 @un uN > FU=0
  MarkInstall openmpi-bin:amd64 < 2.1.1-8 -> 4.0.3-0ubuntu1 @ii ugU Ib > FU=0
  Installing libopenmpi3 as Depends of openmpi-bin
    MarkInstall libopenmpi3:amd64 < none -> 4.0.3-0ubuntu1 @un uN Ib > FU=0
    Installing libevent-pthreads-2.1-7 as Depends of libopenmpi3
      MarkInstall libevent-pthreads-2.1-7:amd64 < none -> 2.1.11-stable-1 @un uN Ib > FU=0
      Installing libevent-core-2.1-7 as Depends of libevent-pthreads-2.1-7
        MarkInstall libevent-core-2.1-7:amd64 < none -> 2.1.11-stable-1 @un uN > FU=0
    Installing libpmix2 as Depends of libopenmpi3
      MarkInstall libpmix2:amd64 < none -> 3.1.5-1 @un uN > FU=0
  MarkInstall libpango-1.0-0:i386 < 1.40.14-1ubuntu0.1 -> 1.44.7-2ubuntu4 @ii umU Ib > FU=0
  Installing libfribidi0 as Depends of libpango-1.0-0
    MarkInstall libfribidi0:i386 < none -> 1.0.8-2 @un uN > FU=0
  MarkInstall libmono-webbrowser4.0-cil:amd64 < 4.6.2.7+dfsg-1ubuntu1 -> 6.8.0.105+dfsg-2 @ii umU NPb IPb > FU=0
  MarkInstall aptitude:amd64 < 0.8.10-6ubuntu1 -> 0.8.12-1ubuntu4 @ii umU Ib > FU=0
  Installing libboost-iostreams1.71.0 as Depends of aptitude
    MarkInstall libboost-iostreams1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
  Installing libcwidget4 as Depends of aptitude
    MarkInstall libcwidget4:amd64 < none -> 0.5.18-5build1 @un uN > FU=0
  MarkInstall isc-dhcp-client:amd64 < 4.3.5-3ubuntu7.1 -> 4.4.1-2.1ubuntu5 @ii umU Ib > FU=0
  Installing libdns-export1109 as Depends of isc-dhcp-client
    MarkInstall libdns-export1109:amd64 < none -> 1:9.11.16+dfsg-3~ubuntu1 @un uN Ib > FU=0
    Installing libisc-export1105 as Depends of libdns-export1109
      MarkInstall libisc-export1105:amd64 < none -> 1:9.11.16+dfsg-3~ubuntu1 @un uN > FU=0
  MarkInstall libcupscgi1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
  MarkInstall cryptsetup:amd64 < 2:2.0.2-1ubuntu1.2 -> 2:2.2.2-3ubuntu2.3 @ii umU IPb > FU=0
  new important dependency: cryptsetup-initramfs:amd64
  Installing cryptsetup-initramfs as Recommends of cryptsetup
    MarkInstall cryptsetup-initramfs:amd64 < none -> 2:2.2.2-3ubuntu2.3 @un uN > FU=0
  new important dependency: cryptsetup-run:amd64
  Installing cryptsetup-run as Recommends of cryptsetup
    MarkInstall cryptsetup-run:amd64 < none -> 2:2.2.2-3ubuntu2.3 @un uN > FU=0
  MarkInstall libibverbs-dev:amd64 < 17.1-1ubuntu0.2 -> 28.0-1ubuntu1 @ii ugU Ib > FU=0
  Installing libnl-3-dev as Depends of libibverbs-dev
    MarkInstall libnl-3-dev:amd64 < none -> 3.4.0-1 @un uN > FU=0
  Installing libnl-route-3-dev as Depends of libibverbs-dev
    MarkInstall libnl-route-3-dev:amd64 < none -> 3.4.0-1 @un uN > FU=0
  MarkInstall linux-system76:amd64 < 5.3.0-7648.41~1586790036~18.04~600aeb5~dev @ii mK Ib > FU=0
  MarkInstall libopenmpi-dev:amd64 < 2.1.1-8 -> 4.0.3-0ubuntu1 @ii ugU Ib > FU=0
  Installing gfortran-8 as Depends of libopenmpi-dev
    MarkInstall gfortran-8:amd64 < none -> 8.4.0-3ubuntu2 @un uN Ib > FU=0
    Installing gcc-8 as Depends of gfortran-8
      MarkInstall gcc-8:amd64 < none -> 8.4.0-3ubuntu2 @un uN Ib > FU=0
      Installing cpp-8 as Depends of gcc-8
        MarkInstall cpp-8:amd64 < none -> 8.4.0-3ubuntu2 @un uN > FU=0
      Installing libgcc-8-dev as Depends of gcc-8
        MarkInstall libgcc-8-dev:amd64 < none -> 8.4.0-3ubuntu2 @un uN > FU=0
    Installing libgfortran-8-dev as Depends of gfortran-8
      MarkInstall libgfortran-8-dev:amd64 < none -> 8.4.0-3ubuntu2 @un uN > FU=0
  Installing libevent-dev as Depends of libopenmpi-dev
    MarkInstall libevent-dev:amd64 < none -> 2.1.11-stable-1 @un uN Ib > FU=0
    Installing libevent-extra-2.1-7 as Depends of libevent-dev
      MarkInstall libevent-extra-2.1-7:amd64 < none -> 2.1.11-stable-1 @un uN > FU=0
    Installing libevent-openssl-2.1-7 as Depends of libevent-dev
      MarkInstall libevent-openssl-2.1-7:amd64 < none -> 2.1.11-stable-1 @un uN > FU=0
  new important dependency: libcoarrays-openmpi-dev:amd64
  Installing libcoarrays-openmpi-dev as Recommends of libopenmpi-dev
    MarkInstall libcoarrays-openmpi-dev:amd64 < none -> 2.8.0-1 @un uN Ib > FU=0
    Installing gfortran as Depends of libcoarrays-openmpi-dev
      MarkInstall gfortran:amd64 < none -> 4:9.3.0-1ubuntu2 @un uN Ib > FU=0
      Installing gfortran-9 as Depends of gfortran
        MarkInstall gfortran-9:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN Ib > FU=0
        Installing libgfortran-9-dev as Depends of gfortran-9
          MarkInstall libgfortran-9-dev:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN > FU=0
    Installing libcaf-openmpi-3 as Depends of libcoarrays-openmpi-dev
      MarkInstall libcaf-openmpi-3:amd64 < none -> 2.8.0-1 @un uN > FU=0
    Installing libcoarrays-dev as Depends of libcoarrays-openmpi-dev
      MarkInstall libcoarrays-dev:amd64 < none -> 2.8.0-1 @un uN > FU=0
  MarkInstall libmircommon7:amd64 < 0.31.1-0ubuntu1 -> 1.7.1-0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-filesystem1.71.0 as Depends of libmircommon7
    MarkInstall libboost-filesystem1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
  MarkInstall initramfs-tools-core:amd64 < 0.130ubuntu3.11 -> 0.136ubuntu6.4 @ii umU Ib > FU=0
  Installing lz4 as Depends of initramfs-tools-core
    MarkInstall lz4:amd64 < none -> 1.9.2-2 @un uN > FU=0
  MarkInstall libwine:amd64 < 3.0-1ubuntu1 -> 5.0-3ubuntu1 @ii umU NPb Ib > FU=0
  Installing libfaudio0 as Depends of libwine
    MarkInstall libfaudio0:amd64 < none -> 20.04-2 @un uN Ib > FU=0
    Installing libstb0 as Depends of libfaudio0
      MarkInstall libstb0:amd64 < none -> 0.0~git20190817.1.052dce1-1 @un uN > FU=0
  Installing libvkd3d1 as Depends of libwine
    MarkInstall libvkd3d1:amd64 < none -> 1.1-4 @un uN > FU=0
  ignore old unsatisfied important dependency on libosmesa6:amd64
  MarkInstall libwine:i386 < 3.0-1ubuntu1 -> 5.0-3ubuntu1 @ii umU NPb Ib > FU=0
  Installing libncurses6 as Depends of libwine
    MarkInstall libncurses6:i386 < none -> 6.2-0ubuntu2 @un uN Ib > FU=0
    Installing libtinfo6 as Depends of libncurses6
      MarkInstall libtinfo6:i386 < none -> 6.2-0ubuntu2 @un uN > FU=0
  Installing libfaudio0 as Depends of libwine
    MarkInstall libfaudio0:i386 < none -> 20.04-2 @un uN Ib > FU=0
    Installing libavcodec58 as Depends of libfaudio0
      MarkInstall libavcodec58:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
      Installing libaom0 as Depends of libavcodec58
        MarkInstall libaom0:i386 < none -> 1.0.0.errata1-3build1 @un uN > FU=0
      Installing libavutil56 as Depends of libavcodec58
        MarkInstall libavutil56:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
        Installing libdrm2 as Depends of libavutil56
          MarkInstall libdrm2:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > FU=0
           Removing: libdrm2
            MarkDelete libdrm2:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib > FU=0
        Installing libva-drm2 as Depends of libavutil56
          MarkInstall libva-drm2:i386 < none -> 2.7.0-2 @un uN Ib > FU=0
          Installing libva2 as Depends of libva-drm2
            MarkInstall libva2:i386 < none -> 2.7.0-2 @un uN IPb > FU=0
            Installing va-driver-all as Recommends of libva2
              MarkInstall va-driver-all:i386 < none -> 2.7.0-2 @un uN Ib > FU=0
              Installing i965-va-driver as Depends of va-driver-all
                MarkInstall i965-va-driver:i386 < none -> 2.4.0-0ubuntu1 @un uN Ib > FU=0
                Installing libdrm-intel1 as Depends of i965-va-driver
                  MarkInstall libdrm-intel1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > FU=0
                  Installing libpciaccess0 as Depends of libdrm-intel1
                    MarkInstall libpciaccess0:i386 < none -> 0.16-0ubuntu1 @un uN > FU=0
                   Removing: libdrm-intel1
                    MarkDelete libdrm-intel1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib > FU=0
              Installing intel-media-va-driver as Depends of va-driver-all
                MarkInstall intel-media-va-driver:i386 < none -> 20.1.1+dfsg1-1 @un uN Ib > FU=0
                Installing libigdgmm11 as Depends of intel-media-va-driver
                  MarkInstall libigdgmm11:i386 < none -> 20.1.1+ds1-1 @un uN > FU=0
              Installing mesa-va-drivers as Depends of va-driver-all
                MarkInstall mesa-va-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
                Installing libdrm-amdgpu1 as Depends of mesa-va-drivers
                  MarkInstall libdrm-amdgpu1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > FU=0
                   Removing: libdrm-amdgpu1
                    MarkDelete libdrm-amdgpu1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib > FU=0
                Installing libdrm-nouveau2 as Depends of mesa-va-drivers
                  MarkInstall libdrm-nouveau2:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > FU=0
                   Removing: libdrm-nouveau2
                    MarkDelete libdrm-nouveau2:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib > FU=0
                Installing libdrm-radeon1 as Depends of mesa-va-drivers
                  MarkInstall libdrm-radeon1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > FU=0
                   Removing: libdrm-radeon1
                    MarkDelete libdrm-radeon1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib > FU=0
                Installing libelf1 as Depends of mesa-va-drivers
                  MarkInstall libelf1:i386 < none -> 0.176-1.1build1 @un uN > FU=0
                Installing libllvm11 as Depends of mesa-va-drivers
                  MarkInstall libllvm11:i386 < none -> 1:11.0.0-2~ubuntu20.04.1 @un uN Ib > FU=0
                  Installing libatomic1 as Depends of libllvm11
                    MarkInstall libatomic1:i386 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
                  Installing libedit2 as Depends of libllvm11
                    MarkInstall libedit2:i386 < none -> 3.1-20191231-1 @un uN > FU=0
                Installing libx11-xcb1 as Depends of mesa-va-drivers
                  MarkInstall libx11-xcb1:i386 < none -> 2:1.6.9-2ubuntu1.1 @un uN > FU=0
                Installing libxcb-dri2-0 as Depends of mesa-va-drivers
                  MarkInstall libxcb-dri2-0:i386 < none -> 1.14-2 @un uN > FU=0
                Installing libxcb-dri3-0 as Depends of mesa-va-drivers
                  MarkInstall libxcb-dri3-0:i386 < none -> 1.14-2 @un uN > FU=0
                Installing libxcb-present0 as Depends of mesa-va-drivers
                  MarkInstall libxcb-present0:i386 < none -> 1.14-2 @un uN > FU=0
                Installing libxcb-sync1 as Depends of mesa-va-drivers
                  MarkInstall libxcb-sync1:i386 < none -> 1.14-2 @un uN > FU=0
                Installing libxcb-xfixes0 as Depends of mesa-va-drivers
                  MarkInstall libxcb-xfixes0:i386 < none -> 1.14-2 @un uN > FU=0
                Installing libxshmfence1 as Depends of mesa-va-drivers
                  MarkInstall libxshmfence1:i386 < none -> 1.3-1 @un uN > FU=0
                 Removing: mesa-va-drivers
                  MarkDelete mesa-va-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mK Ib > FU=0
        Installing libva-x11-2 as Depends of libavutil56
          MarkInstall libva-x11-2:i386 < none -> 2.7.0-2 @un uN > FU=0
        Installing libvdpau1 as Depends of libavutil56
          MarkInstall libvdpau1:i386 < none -> 1.3-1ubuntu2 @un uN IPb > FU=0
          Installing vdpau-driver-all as Recommends of libvdpau1
            MarkInstall vdpau-driver-all:i386 < none -> 1.3-1ubuntu2 @un uN Ib > FU=0
            Installing mesa-vdpau-drivers as Depends of vdpau-driver-all
              MarkInstall mesa-vdpau-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
               Removing: mesa-vdpau-drivers
                MarkDelete mesa-vdpau-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mK Ib > FU=0
      Installing libcodec2-0.9 as Depends of libavcodec58
        MarkInstall libcodec2-0.9:i386 < none -> 0.9.2-2 @un uN > FU=0
      Installing libmp3lame0 as Depends of libavcodec58
        MarkInstall libmp3lame0:i386 < none -> 3.100-3 @un uN > FU=0
      Installing libopenjp2-7 as Depends of libavcodec58
        MarkInstall libopenjp2-7:i386 < none -> 2.3.1-1ubuntu4.20.04.1 @un uN > FU=0
      Installing librsvg2-2 as Depends of libavcodec58
        MarkInstall librsvg2-2:i386 < none -> 2.48.9-1ubuntu0.20.04.1 @un uN Ib > FU=0
        Installing libcairo-gobject2 as Depends of librsvg2-2
          MarkInstall libcairo-gobject2:i386 < none -> 1.16.0-4ubuntu1 @un uN > FU=0
        Installing librsvg2-common as Recommends of librsvg2-2
          MarkInstall librsvg2-common:i386 < none -> 2.48.9-1ubuntu0.20.04.1 @un uN > FU=0
      Installing libshine3 as Depends of libavcodec58
        MarkInstall libshine3:i386 < none -> 3.1.1-2 @un uN > FU=0
      Installing libsnappy1v5 as Depends of libavcodec58
        MarkInstall libsnappy1v5:i386 < none -> 1.1.8-1build1 @un uN > FU=0
      Installing libspeex1 as Depends of libavcodec58
        MarkInstall libspeex1:i386 < none -> 1.2~rc1.2-1.1ubuntu1 @un uN > FU=0
      Installing libswresample3 as Depends of libavcodec58
        MarkInstall libswresample3:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
        Installing libsoxr0 as Depends of libswresample3
          MarkInstall libsoxr0:i386 < none -> 0.1.3-2build1 @un uN Ib > FU=0
          Installing libgomp1 as Depends of libsoxr0
            MarkInstall libgomp1:i386 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
      Installing libtwolame0 as Depends of libavcodec58
        MarkInstall libtwolame0:i386 < none -> 0.4.0-2 @un uN > FU=0
      Installing libvpx6 as Depends of libavcodec58
        MarkInstall libvpx6:i386 < none -> 1.8.2-1build1 @un uN > FU=0
      Installing libwavpack1 as Depends of libavcodec58
        MarkInstall libwavpack1:i386 < none -> 5.2.0-1ubuntu0.1 @un uN > FU=0
      Installing libwebpmux3 as Depends of libavcodec58
        MarkInstall libwebpmux3:i386 < none -> 0.6.1-2 @un uN > FU=0
      Installing libx264-155 as Depends of libavcodec58
        MarkInstall libx264-155:i386 < none -> 2:0.155.2917+git0a84d98-2 @un uN > FU=0
      Installing libx265-179 as Depends of libavcodec58
        MarkInstall libx265-179:i386 < none -> 3.2.1-1build1 @un uN Ib > FU=0
        Installing libnuma1 as Depends of libx265-179
          MarkInstall libnuma1:i386 < none -> 2.0.12-1 @un uN > FU=0
      Installing libxvidcore4 as Depends of libavcodec58
        MarkInstall libxvidcore4:i386 < none -> 2:1.3.7-1 @un uN > FU=0
      Installing libzvbi0 as Depends of libavcodec58
        MarkInstall libzvbi0:i386 < none -> 0.2.35-17 @un uN > FU=0
    Installing libsdl2-2.0-0 as Depends of libfaudio0
      MarkInstall libsdl2-2.0-0:i386 < none -> 2.0.10+dfsg1-3 @un uN Ib > FU=0
      Installing libwayland-client0 as Depends of libsdl2-2.0-0
        MarkInstall libwayland-client0:i386 < none -> 1.18.0-1 @un uN > FU=0
      Installing libwayland-cursor0 as Depends of libsdl2-2.0-0
        MarkInstall libwayland-cursor0:i386 < none -> 1.18.0-1 @un uN > FU=0
      Installing libwayland-egl1 as Depends of libsdl2-2.0-0
        MarkInstall libwayland-egl1:i386 < none -> 1.18.0-1 @un uN > FU=0
      Installing libxkbcommon0 as Depends of libsdl2-2.0-0
        MarkInstall libxkbcommon0:i386 < none -> 0.10.0-1 @un uN > FU=0
      Installing libxss1 as Depends of libsdl2-2.0-0
        MarkInstall libxss1:i386 < none -> 1:1.2.3-1 @un uN > FU=0
    Installing libstb0 as Depends of libfaudio0
      MarkInstall libstb0:i386 < none -> 0.0~git20190817.1.052dce1-1 @un uN > FU=0
  Installing libvkd3d1 as Depends of libwine
    MarkInstall libvkd3d1:i386 < none -> 1.1-4 @un uN Ib > FU=0
    Installing libvulkan1 as Depends of libvkd3d1
      MarkInstall libvulkan1:i386 < none -> 1.2.131.2-1 @un uN IPb > FU=0
      Installing mesa-vulkan-drivers as Recommends of libvulkan1
        MarkInstall mesa-vulkan-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
        Installing libxcb-randr0 as Depends of mesa-vulkan-drivers
          MarkInstall libxcb-randr0:i386 < none -> 1.14-2 @un uN > FU=0
  ignore old unsatisfied important dependency on libgl1:i386
  ignore old unsatisfied important dependency on libglu1-mesa:i386
  ignore old unsatisfied important dependency on libosmesa6:i386
  ignore old unsatisfied important dependency on libgl1-mesa-dri:i386
  ignore old unsatisfied important dependency on libasound2-plugins:i386
  new important dependency: gstreamer1.0-plugins-good:i386
  Installing gstreamer1.0-plugins-good as Recommends of libwine
    MarkInstall gstreamer1.0-plugins-good:i386 < none -> 1.16.2-1ubuntu2 @un uN Ib > FU=0
    Installing libaa1 as Depends of gstreamer1.0-plugins-good
      MarkInstall libaa1:i386 < none -> 1.4p5-46 @un uN Ib > FU=0
      Installing libslang2 as Depends of libaa1
        MarkInstall libslang2:i386 < none -> 2.3.2-4 @un uN > FU=0
    Installing libavc1394-0 as Depends of gstreamer1.0-plugins-good
      MarkInstall libavc1394-0:i386 < none -> 0.5.4-5 @un uN Ib > FU=0
      Installing libraw1394-11 as Depends of libavc1394-0
        MarkInstall libraw1394-11:i386 < none -> 2.1.2-1 @un uN > FU=0
    Installing libcaca0 as Depends of gstreamer1.0-plugins-good
      MarkInstall libcaca0:i386 < none -> 0.99.beta19-2.1ubuntu1 @un uN Ib > FU=0
      Installing libncursesw6 as Depends of libcaca0
        MarkInstall libncursesw6:i386 < none -> 6.2-0ubuntu2 @un uN > FU=0
    Installing libdv4 as Depends of gstreamer1.0-plugins-good
      MarkInstall libdv4:i386 < none -> 1.0.0-12 @un uN > FU=0
    Installing libgstreamer-plugins-good1.0-0 as Depends of gstreamer1.0-plugins-good
      MarkInstall libgstreamer-plugins-good1.0-0:i386 < none -> 1.16.2-1ubuntu2 @un uN > FU=0
    Installing libgudev-1.0-0 as Depends of gstreamer1.0-plugins-good
      MarkInstall libgudev-1.0-0:i386 < none -> 1:233-1 @un uN > FU=0
    Installing libiec61883-0 as Depends of gstreamer1.0-plugins-good
      MarkInstall libiec61883-0:i386 < none -> 1.2.0-3 @un uN > FU=0
    Installing libjack-jackd2-0 as Depends of gstreamer1.0-plugins-good
      MarkInstall libjack-jackd2-0:i386 < none -> 1.9.12~dfsg-2ubuntu2 @un uN Ib > FU=0
      Installing libsamplerate0 as Depends of libjack-jackd2-0
        MarkInstall libsamplerate0:i386 < none -> 0.1.9-2 @un uN > FU=0
       Removing: libjack0
        MarkDelete libjack0:amd64 < 1:0.125.0-3 -> 1:0.125.0-3build2 @ii umU Ib > FU=0
    Installing libshout3 as Depends of gstreamer1.0-plugins-good
      MarkInstall libshout3:i386 < none -> 2.4.3-1 @un uN > FU=0
    Installing libsoup2.4-1 as Depends of gstreamer1.0-plugins-good
      MarkInstall libsoup2.4-1:i386 < none -> 2.70.0-1 @un uN Ib > FU=0
      Installing glib-networking as Depends of libsoup2.4-1
        MarkInstall glib-networking:i386 < none -> 2.64.2-1ubuntu0.1 @un uN Ib > FU=0
        Installing libproxy1v5 as Depends of glib-networking
          MarkInstall libproxy1v5:i386 < none -> 0.4.15-10ubuntu1.2 @un uN > FU=0
    Installing libtag1v5 as Depends of gstreamer1.0-plugins-good
      MarkInstall libtag1v5:i386 < none -> 1.11.1+dfsg.1-0.3ubuntu2 @un uN Ib > FU=0
      Installing libtag1v5-vanilla as Depends of libtag1v5
        MarkInstall libtag1v5-vanilla:i386 < none -> 1.11.1+dfsg.1-0.3ubuntu2 @un uN > FU=0
    Installing gstreamer1.0-x as Recommends of gstreamer1.0-plugins-good
      MarkInstall gstreamer1.0-x:i386 < none -> 1.16.2-4 @un uN Ib > FU=0
      Installing libxv1 as Depends of gstreamer1.0-x
        MarkInstall libxv1:i386 < none -> 2:1.0.11-1 @un uN > FU=0
  MarkInstall wireshark-qt:amd64 < 2.6.10-1~ubuntu18.04.0 -> 3.2.3-1 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on libqt5multimedia5-plugins:amd64
    MarkKeep mesa-va-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mR > FU=0
  MarkInstall python3-bs4:amd64 < 4.6.0-1 -> 4.8.2-1 @ii umU Ib > FU=0
  Installing python3-soupsieve as Depends of python3-bs4
    MarkInstall python3-soupsieve:amd64 < none -> 1.9.5+dfsg-1 @un uN > FU=0
  MarkInstall libglx-mesa0:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mK Ib > FU=0
  Installing libdrm2 as Depends of libglx-mesa0
      MarkKeep libdrm2:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mR > FU=0
  MarkInstall libvirt-daemon:amd64 < 4.0.0-1ubuntu8.19 -> 6.0.0-0ubuntu8.8 @ii umU Ib > FU=0
  Installing libvirt-daemon-driver-qemu as Depends of libvirt-daemon
    MarkInstall libvirt-daemon-driver-qemu:amd64 < none -> 6.0.0-0ubuntu8.8 @un uN > FU=0
    MarkKeep libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mR > FU=0
    MarkKeep libdrm-nouveau2:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mR > FU=0
    MarkKeep libdrm-amdgpu1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mR > FU=0
    MarkKeep libdrm-intel1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mR > FU=0
    MarkKeep libdrm-radeon1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mR > FU=0
    MarkKeep mesa-vdpau-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mR > FU=0
Starting pkgProblemResolver with broken count: 49
Starting 2 pkgProblemResolver with broken count: 49
Investigating (0) dpkg:amd64 < 1.19.0.5ubuntu2.3 -> 1.19.7ubuntu3 @ii umU Ib >
Broken dpkg:amd64 Breaks on libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mK > (< 1.7~b)
  Considering libapt-pkg5.0:amd64 -1 as a solution to dpkg:amd64 5905
  Added libapt-pkg5.0:amd64 to the remove list
  Fixing dpkg:amd64 via remove of libapt-pkg5.0:amd64
  MarkDelete libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mK > FU=0
Investigating (0) libqt5core5a:amd64 < 5.9.5+dfsg-0ubuntu2.5 -> 5.12.8+dfsg-0ubuntu1 @ii umU Ib >
Broken libqt5core5a:amd64 Breaks on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK > (< 4:4.8.7+dfsg-20~)
  Considering libqtcore4:amd64 39 as a solution to libqt5core5a:amd64 1559
  Added libqtcore4:amd64 to the remove list
  Fixing libqt5core5a:amd64 via remove of libqtcore4:amd64
  MarkDelete libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK > FU=0
Investigating (0) libdrm2:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib >
Broken libdrm2:amd64 Breaks on libdrm2:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > (!= 2.4.102+git2010051830.5de99a~oibaf~b)
  Considering libdrm2:i386 14 as a solution to libdrm2:amd64 274
  Added libdrm2:i386 to the remove list
  Conflicts//Breaks against version 2.4.101-2 for libdrm2 but that is not InstVer, ignoring
  Fixing libdrm2:amd64 via keep of libdrm2:i386
  MarkKeep libdrm2:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > FU=0
Investigating (0) libgcc1:amd64 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib >
Broken libgcc1:amd64 Conflicts on libgcc1:i386 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib >
  Considering libgcc1:i386 4 as a solution to libgcc1:amd64 168
  Added libgcc1:i386 to the remove list
  Conflicts//Breaks against version 1:10-20200411-0ubuntu1 for libgcc1 but that is not InstVer, ignoring
  Conflicts//Breaks against version 1:8.4.0-1ubuntu1~18.04 for libgcc1 but that is not InstVer, ignoring
  Fixing libgcc1:amd64 via remove of libgcc1:i386
  MarkDelete libgcc1:i386 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib > FU=0
Investigating (0) gnome-settings-daemon-common:amd64 < none -> 3.36.1-0ubuntu1 @un uN Ib >
Broken gnome-settings-daemon-common:amd64 Breaks on gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3pop0~1565899898~18.04~a5b17e2~dev @ii mK > (< 3.30.1.2-2~)
  Considering gnome-settings-daemon-schemas:amd64 -3 as a solution to gnome-settings-daemon-common:amd64 12
  Added gnome-settings-daemon-schemas:amd64 to the remove list
  Fixing gnome-settings-daemon-common:amd64 via remove of gnome-settings-daemon-schemas:amd64
  MarkDelete gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3pop0~1565899898~18.04~a5b17e2~dev @ii mK > FU=0
Investigating (0) libdrm-amdgpu1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib >
Broken libdrm-amdgpu1:amd64 Breaks on libdrm-amdgpu1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > (!= 2.4.102+git2010051830.5de99a~oibaf~b)
  Considering libdrm-amdgpu1:i386 1 as a solution to libdrm-amdgpu1:amd64 11
  Added libdrm-amdgpu1:i386 to the remove list
  Conflicts//Breaks against version 2.4.101-2 for libdrm-amdgpu1 but that is not InstVer, ignoring
  Fixing libdrm-amdgpu1:amd64 via keep of libdrm-amdgpu1:i386
  MarkKeep libdrm-amdgpu1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > FU=0
Investigating (0) libdrm-intel1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib >
Broken libdrm-intel1:amd64 Breaks on libdrm-intel1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > (!= 2.4.102+git2010051830.5de99a~oibaf~b)
  Considering libdrm-intel1:i386 -1 as a solution to libdrm-intel1:amd64 10
  Added libdrm-intel1:i386 to the remove list
  Conflicts//Breaks against version 2.4.101-2 for libdrm-intel1 but that is not InstVer, ignoring
  Fixing libdrm-intel1:amd64 via keep of libdrm-intel1:i386
  MarkKeep libdrm-intel1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > FU=0
Investigating (0) libdrm-nouveau2:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib >
Broken libdrm-nouveau2:amd64 Breaks on libdrm-nouveau2:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > (!= 2.4.102+git2010051830.5de99a~oibaf~b)
  Considering libdrm-nouveau2:i386 0 as a solution to libdrm-nouveau2:amd64 10
  Added libdrm-nouveau2:i386 to the remove list
  Conflicts//Breaks against version 2.4.101-2 for libdrm-nouveau2 but that is not InstVer, ignoring
  Fixing libdrm-nouveau2:amd64 via keep of libdrm-nouveau2:i386
  MarkKeep libdrm-nouveau2:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > FU=0
Investigating (0) libqtdbus4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqtdbus4:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 39 as a solution to libqtdbus4:amd64 10
  Removing libqtdbus4:amd64 rather than change libqtcore4:amd64
  MarkDelete libqtdbus4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libdrm-radeon1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib >
Broken libdrm-radeon1:amd64 Breaks on libdrm-radeon1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > (!= 2.4.102+git2010051830.5de99a~oibaf~b)
  Considering libdrm-radeon1:i386 0 as a solution to libdrm-radeon1:amd64 9
  Added libdrm-radeon1:i386 to the remove list
  Conflicts//Breaks against version 2.4.101-2 for libdrm-radeon1 but that is not InstVer, ignoring
  Fixing libdrm-radeon1:amd64 via keep of libdrm-radeon1:i386
  MarkKeep libdrm-radeon1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > FU=0
Investigating (0) libqt4-declarative:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-declarative:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 39 as a solution to libqt4-declarative:amd64 8
  Removing libqt4-declarative:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-declarative:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libqtgui4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqtgui4:amd64 Depends on libqt4-declarative:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-declarative:amd64 8 as a solution to libqtgui4:amd64 8
  Removing libqtgui4:amd64 rather than change libqt4-declarative:amd64
  MarkDelete libqtgui4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) qt-at-spi:amd64 < 0.4.0-8 @ii mK Ib >
Broken qt-at-spi:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.8~)
  Considering libqtcore4:amd64 39 as a solution to qt-at-spi:amd64 7
  Removing qt-at-spi:amd64 rather than change libqtcore4:amd64
  MarkDelete qt-at-spi:amd64 < 0.4.0-8 @ii mK Ib > FU=0
Investigating (0) libqt4-xml:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-xml:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 39 as a solution to libqt4-xml:amd64 5
  Removing libqt4-xml:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-xml:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-network:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 39 as a solution to libqt4-network:amd64 3
  Removing libqt4-network:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-dbus:amd64 Depends on libqtdbus4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtdbus4:amd64 10 as a solution to libqt4-dbus:amd64 3
  Removing libqt4-dbus:amd64 rather than change libqtdbus4:amd64
  MarkDelete libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libjack0:amd64 < 1:0.125.0-3 -> 1:0.125.0-3build2 @ii umU Ib >
Broken libjack0:amd64 Conflicts on libjack-0.116:i386 < none @un H >
  Considering libjack-jackd2-0:i386 0 as a solution to libjack0:amd64 3
  Added libjack-jackd2-0:i386 to the remove list
Broken libjack0:amd64 Conflicts on libjack-0.125:i386 < none @un H >
  Considering libjack-jackd2-0:i386 0 as a solution to libjack0:amd64 3
  Added libjack-jackd2-0:i386 to the remove list
  Fixing libjack0:amd64 via keep of libjack-jackd2-0:i386
  MarkKeep libjack-jackd2-0:i386 < none -> 1.9.12~dfsg-2ubuntu2 @un uN Ib > FU=0
  Fixing libjack0:amd64 via keep of libjack-jackd2-0:i386
Investigating (0) libsensors-config:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib >
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii mK >
  Considering libsensors4:amd64 6 as a solution to libsensors-config:amd64 2
  MarkKeep libsensors-config:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib > FU=0
  Holding Back libsensors-config:amd64 rather than change libsensors4:amd64
Investigating (0) libqt4-script:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-script:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 39 as a solution to libqt4-script:amd64 2
  Removing libqt4-script:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-script:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-intel:amd64 2
  Removing xserver-xorg-video-intel:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mK Ib > FU=0
Investigating (0) libva-drm2:i386 < none -> 2.7.0-2 @un uN Ib >
Broken libva-drm2:i386 Depends on libdrm2:i386 < none | 2.4.102-1ubuntu1~20.04.1 @un uH > (>= 2.4.16)
  Considering libdrm2:i386 14 as a solution to libva-drm2:i386 2
  MarkKeep libva-drm2:i386 < none -> 2.7.0-2 @un uN Ib > FU=0
  Holding Back libva-drm2:i386 rather than change libdrm2:i386
Investigating (0) qdbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken qdbus:amd64 Depends on libqt4-xml:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-xml:amd64 5 as a solution to qdbus:amd64 2
  Removing qdbus:amd64 rather than change libqt4-xml:amd64
  MarkDelete qdbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) mesa-vulkan-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib >
Broken mesa-vulkan-drivers:i386 Depends on libdrm-amdgpu1:i386 < none | 2.4.102-1ubuntu1~20.04.1 @un uH > (>= 2.4.99)
  Considering libdrm-amdgpu1:i386 1 as a solution to mesa-vulkan-drivers:i386 2
  MarkKeep mesa-vulkan-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
  Holding Back mesa-vulkan-drivers:i386 rather than change libdrm-amdgpu1:i386
Investigating (0) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-ati:amd64 2
  Removing xserver-xorg-video-ati:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-nouveau:amd64 2
  Removing xserver-xorg-video-nouveau:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
Investigating (0) libavutil56:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib >
Broken libavutil56:i386 Depends on libdrm2:i386 < none | 2.4.102-1ubuntu1~20.04.1 @un uH > (>= 2.3.1)
  Considering libdrm2:i386 14 as a solution to libavutil56:i386 2
  MarkKeep libavutil56:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
  Holding Back libavutil56:i386 rather than change libdrm2:i386
Investigating (0) libva-x11-2:i386 < none -> 2.7.0-2 @un uN Ib >
Broken libva-x11-2:i386 Depends on libdrm2:i386 < none | 2.4.102-1ubuntu1~20.04.1 @un uH > (>= 2.3.1)
  Considering libdrm2:i386 14 as a solution to libva-x11-2:i386 2
  MarkKeep libva-x11-2:i386 < none -> 2.7.0-2 @un uN Ib > FU=0
  Holding Back libva-x11-2:i386 rather than change libdrm2:i386
Investigating (0) libtinyxml2-6a:amd64 < none -> 7.0.0+dfsg-1build1 @un uN Ib >
Broken libtinyxml2-6a:amd64 Conflicts on libtinyxml2-6:amd64 < 6.0.0+dfsg-1 @ii mK >
  Considering libtinyxml2-6:amd64 -3 as a solution to libtinyxml2-6a:amd64 1
  Added libtinyxml2-6:amd64 to the remove list
  Fixing libtinyxml2-6a:amd64 via remove of libtinyxml2-6:amd64
  MarkDelete libtinyxml2-6:amd64 < 6.0.0+dfsg-1 @ii mK > FU=0
Investigating (0) libhfstospell10:amd64 < none -> 0.5.0-2build2 @un uN Ib >
Broken libhfstospell10:amd64 Conflicts on libhfstospell:amd64 < none @un H >
  Considering libhfstospell9:amd64 -2 as a solution to libhfstospell10:amd64 1
  Added libhfstospell9:amd64 to the remove list
  Fixing libhfstospell10:amd64 via remove of libhfstospell9:amd64
  MarkDelete libhfstospell9:amd64 < 0.4.5~r343-2.1build2 @ii mK Ib > FU=0
Investigating (0) fluidr3mono-gm-soundfont:amd64 < 2.315-4 -> 2.315-6 @ii umU Ib >
Broken fluidr3mono-gm-soundfont:amd64 Conflicts on musescore-common:amd64 < 2.1.0+dfsg3-3build1 @ii mK > (< 2.3.2+dfsg1-1~bpo9)
  Considering musescore-common:amd64 -2 as a solution to fluidr3mono-gm-soundfont:amd64 1
  Added musescore-common:amd64 to the remove list
  Fixing fluidr3mono-gm-soundfont:amd64 via remove of musescore-common:amd64
  MarkDelete musescore-common:amd64 < 2.1.0+dfsg3-3build1 @ii mK > FU=0
Investigating (0) xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-amdgpu:amd64 1
  Removing xserver-xorg-video-amdgpu:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
Investigating (0) clang-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN Ib >
Broken clang-10:amd64 Depends on libclang-cpp10:amd64 < none | 1:10.0.0-4ubuntu1 @un uH >
  Considering libclang-cpp10:amd64 1 as a solution to clang-10:amd64 1
  MarkKeep clang-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN Ib > FU=0
  Holding Back clang-10:amd64 rather than change libclang-cpp10:amd64
Investigating (0) gstreamer1.0-plugins-good:i386 < none -> 1.16.2-1ubuntu2 @un uN Ib >
Broken gstreamer1.0-plugins-good:i386 Depends on libjack-jackd2-0:i386 < none | 1.9.12~dfsg-2ubuntu2 @un uH > (>= 1.9.10+20150825)
  Considering libjack-jackd2-0:i386 0 as a solution to gstreamer1.0-plugins-good:i386 1
  MarkKeep gstreamer1.0-plugins-good:i386 < none -> 1.16.2-1ubuntu2 @un uN Ib > FU=0
  Holding Back gstreamer1.0-plugins-good:i386 rather than change libjack-jackd2-0:i386
Broken gstreamer1.0-plugins-good:i386 Depends on libjack-0.125:i386 < none @un H >
  Considering libjack0:i386 -1 as a solution to gstreamer1.0-plugins-good:i386 1
  MarkKeep gstreamer1.0-plugins-good:i386 < none -> 1.16.2-1ubuntu2 @un uN Ib > FU=0
  Holding Back gstreamer1.0-plugins-good:i386 rather than change libjack-0.125:i386
  Or group keep for gstreamer1.0-plugins-good:i386
  MarkKeep gstreamer1.0-plugins-good:i386 < none -> 1.16.2-1ubuntu2 @un uN Ib > FU=0
Investigating (0) libqt4-sql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-sql:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 39 as a solution to libqt4-sql:amd64 1
  Removing libqt4-sql:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-sql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libfaudio0:i386 < none -> 20.04-2 @un uN Ib >
Broken libfaudio0:i386 Depends on libavutil56:i386 < none | 7:4.2.4-1ubuntu0.1 @un uH > (>= 7:4.0)
  Considering libavutil56:i386 2 as a solution to libfaudio0:i386 1
  MarkKeep libfaudio0:i386 < none -> 20.04-2 @un uN Ib > FU=0
  Holding Back libfaudio0:i386 rather than change libavutil56:i386
Investigating (0) libwine:i386 < 3.0-1ubuntu1 -> 5.0-3ubuntu1 @ii umU NPb Ib >
Broken libwine:i386 Depends on libfaudio0:i386 < none | 20.04-2 @un uH > (>= 19.06.07)
  Considering libfaudio0:i386 1 as a solution to libwine:i386 1
  MarkKeep libwine:i386 < 3.0-1ubuntu1 -> 5.0-3ubuntu1 @ii umU NPb Ib > FU=0
  Removing libwine:i386 rather than change libfaudio0:i386
  MarkDelete libwine:i386 < 3.0-1ubuntu1 | 5.0-3ubuntu1 @ii umH NPb Ib > FU=0
Investigating (0) wine32:i386 < 3.0-1ubuntu1 -> 5.0-3ubuntu1 @ii umU Ib >
Broken wine32:i386 Depends on libwine:i386 < 3.0-1ubuntu1 | 5.0-3ubuntu1 @ii umR NPb > (= 5.0-3ubuntu1)
  Considering libwine:i386 1 as a solution to wine32:i386 0
  MarkKeep wine32:i386 < 3.0-1ubuntu1 -> 5.0-3ubuntu1 @ii umU Ib > FU=0
  Removing wine32:i386 rather than change libwine:i386
  MarkDelete wine32:i386 < 3.0-1ubuntu1 | 5.0-3ubuntu1 @ii umH Ib > FU=0
Investigating (0) libboost1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost1.71-dev:amd64 Conflicts on libboost1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK >
  Considering libboost1.65-dev:amd64 29 as a solution to libboost1.71-dev:amd64 0
  MarkKeep libboost1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
  Holding Back libboost1.71-dev:amd64 rather than change libboost1.65-dev:amd64
Investigating (0) libqt4-sql-sqlite:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-sql-sqlite:amd64 Depends on libqt4-sql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-sql:amd64 1 as a solution to libqt4-sql-sqlite:amd64 0
  Removing libqt4-sql-sqlite:amd64 rather than change libqt4-sql:amd64
  MarkDelete libqt4-sql-sqlite:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) appmenu-qt:amd64 < 0.2.7+14.04.20140305-0ubuntu2 @ii mK Ib >
Broken appmenu-qt:amd64 Depends on libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.8)
  Considering libqt4-dbus:amd64 3 as a solution to appmenu-qt:amd64 0
  Removing appmenu-qt:amd64 rather than change libqt4-dbus:amd64
  MarkDelete appmenu-qt:amd64 < 0.2.7+14.04.20140305-0ubuntu2 @ii mK Ib > FU=0
Investigating (0) libsensors5:i386 < none -> 1:3.6.0-2ubuntu1 @un uN Ib >
Broken libsensors5:i386 Depends on libsensors-config:i386 < none @un H >
  Considering libsensors-config:amd64 2 as a solution to libsensors5:i386 0
  MarkKeep libsensors5:i386 < none -> 1:3.6.0-2ubuntu1 @un uN Ib > FU=0
  Holding Back libsensors5:i386 rather than change libsensors-config:i386
Investigating (0) libavcodec-extra58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib >
Broken libavcodec-extra58:amd64 Conflicts on libavcodec58:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib >
  Considering libavcodec58:i386 -1 as a solution to libavcodec-extra58:amd64 0
  Added libavcodec58:i386 to the remove list
  Conflicts//Breaks against version 7:4.2.2-1ubuntu1 for libavcodec58 but that is not InstVer, ignoring
  Fixing libavcodec-extra58:amd64 via keep of libavcodec58:i386
  MarkKeep libavcodec58:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
Investigating (0) libswresample3:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib >
Broken libswresample3:i386 Depends on libavutil56:i386 < none | 7:4.2.4-1ubuntu0.1 @un uH > (= 7:4.2.4-1ubuntu0.1)
  Considering libavutil56:i386 2 as a solution to libswresample3:i386 0
  MarkKeep libswresample3:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
  Holding Back libswresample3:i386 rather than change libavutil56:i386
Investigating (0) libqt4-xmlpatterns:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-xmlpatterns:amd64 Depends on libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-network:amd64 3 as a solution to libqt4-xmlpatterns:amd64 0
  Removing libqt4-xmlpatterns:amd64 rather than change libqt4-network:amd64
  MarkDelete libqt4-xmlpatterns:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libldb2:amd64 < none -> 2:2.0.10-0ubuntu0.20.04.2 @un uN Ib >
Broken libldb2:amd64 Breaks on libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mK > (< 2:2~)
  Considering libldb1:amd64 -3 as a solution to libldb2:amd64 0
  Added libldb1:amd64 to the remove list
  Fixing libldb2:amd64 via remove of libldb1:amd64
  MarkDelete libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mK > FU=0
Investigating (0) libdbusmenu-qt2:amd64 < 0.9.3+16.04.20160218-1ubuntu1 @ii mK Ib >
Broken libdbusmenu-qt2:amd64 Depends on libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.6.2)
  Considering libqt4-dbus:amd64 3 as a solution to libdbusmenu-qt2:amd64 0
  Removing libdbusmenu-qt2:amd64 rather than change libqt4-dbus:amd64
  MarkDelete libdbusmenu-qt2:amd64 < 0.9.3+16.04.20160218-1ubuntu1 @ii mK Ib > FU=0
Investigating (0) libboost-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib >
Broken libboost-dev:amd64 Depends on libboost1.71-dev:amd64 < none | 1.71.0-6ubuntu6 @un uH >
  Considering libboost1.71-dev:amd64 0 as a solution to libboost-dev:amd64 0
  MarkKeep libboost-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Holding Back libboost-dev:amd64 rather than change libboost1.71-dev:amd64
Investigating (0) clang-tidy:amd64 < none -> 1:10.0-50~exp1 @un uN Ib >
Broken clang-tidy:amd64 Depends on clang-tidy-10:amd64 < none | 1:10.0.0-4ubuntu1 @un uH > (>= 10~)
  Considering clang-tidy-10:amd64 0 as a solution to clang-tidy:amd64 0
  MarkKeep clang-tidy:amd64 < none -> 1:10.0-50~exp1 @un uN Ib > FU=0
  Holding Back clang-tidy:amd64 rather than change clang-tidy-10:amd64
Investigating (0) linux-system76:amd64 < 5.3.0-7648.41~1586790036~18.04~600aeb5~dev @ii mK Ib >
Broken linux-system76:amd64 Depends on linux-generic:amd64 < 5.3.0-7648.41~1586790036~18.04~600aeb5~dev -> 5.4.0.67.70 @ii umU > (= 5.3.0-7648.41~1586790036~18.04~600aeb5~dev)
  Considering linux-generic:amd64 1 as a solution to linux-system76:amd64 -1
  Removing linux-system76:amd64 rather than change linux-generic:amd64
  MarkDelete linux-system76:amd64 < 5.3.0-7648.41~1586790036~18.04~600aeb5~dev @ii mK Ib > FU=0
Investigating (0) libqt4-designer:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-designer:amd64 Depends on libqt4-script:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-script:amd64 2 as a solution to libqt4-designer:amd64 -1
  Removing libqt4-designer:amd64 rather than change libqt4-script:amd64
  MarkDelete libqt4-designer:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) i965-va-driver:i386 < none -> 2.4.0-0ubuntu1 @un uN Ib >
Broken i965-va-driver:i386 Depends on libdrm-intel1:i386 < none | 2.4.102-1ubuntu1~20.04.1 @un uH > (>= 2.4.46)
  Considering libdrm-intel1:i386 -1 as a solution to i965-va-driver:i386 -1
  MarkKeep i965-va-driver:i386 < none -> 2.4.0-0ubuntu1 @un uN Ib > FU=0
  Holding Back i965-va-driver:i386 rather than change libdrm-intel1:i386
Investigating (0) libqt4-scripttools:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-scripttools:amd64 Depends on libqt4-script:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-script:amd64 2 as a solution to libqt4-scripttools:amd64 -1
  Removing libqt4-scripttools:amd64 rather than change libqt4-script:amd64
  MarkDelete libqt4-scripttools:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libqt4-svg:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-svg:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 39 as a solution to libqt4-svg:amd64 -1
  Removing libqt4-svg:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-svg:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) mesa-vdpau-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mK Ib >
Broken mesa-vdpau-drivers:amd64 Breaks on mesa-vdpau-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib > (!= 20.3~git2010060730.2b977a~oibaf~b)
  Considering mesa-vdpau-drivers:i386 -1 as a solution to mesa-vdpau-drivers:amd64 -1
  Removing mesa-vdpau-drivers:amd64 rather than change mesa-vdpau-drivers:i386
  MarkDelete mesa-vdpau-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mK Ib > FU=0
Investigating (0) mesa-vdpau-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib >
Broken mesa-vdpau-drivers:i386 Depends on libdrm-amdgpu1:i386 < none | 2.4.102-1ubuntu1~20.04.1 @un uH > (>= 2.4.100)
  Considering libdrm-amdgpu1:i386 1 as a solution to mesa-vdpau-drivers:i386 -1
  MarkKeep mesa-vdpau-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
  Holding Back mesa-vdpau-drivers:i386 rather than change libdrm-amdgpu1:i386
Investigating (0) libqt4-test:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-test:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 39 as a solution to libqt4-test:amd64 -1
  Removing libqt4-test:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-test:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libqtassistantclient4:amd64 < 4.6.3-7build1 @ii mK Ib >
Broken libqtassistantclient4:amd64 Depends on libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.8.1)
  Considering libqt4-network:amd64 3 as a solution to libqtassistantclient4:amd64 -1
  Removing libqtassistantclient4:amd64 rather than change libqt4-network:amd64
  MarkDelete libqtassistantclient4:amd64 < 4.6.3-7build1 @ii mK Ib > FU=0
Investigating (0) libqt4-help:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-help:amd64 Depends on libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-network:amd64 3 as a solution to libqt4-help:amd64 -1
  Removing libqt4-help:amd64 rather than change libqt4-network:amd64
  MarkDelete libqt4-help:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) mesa-va-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib >
Broken mesa-va-drivers:i386 Depends on libdrm-amdgpu1:i386 < none | 2.4.102-1ubuntu1~20.04.1 @un uH > (>= 2.4.100)
  Considering libdrm-amdgpu1:i386 1 as a solution to mesa-va-drivers:i386 -1
  MarkKeep mesa-va-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
  Holding Back mesa-va-drivers:i386 rather than change libdrm-amdgpu1:i386
Investigating (0) libedata-book-1.2-25:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib >
Broken libedata-book-1.2-25:amd64 Depends on libebackend-1.2-10:amd64 < 3.28.5-0ubuntu0.18.04.3 -> 3.36.4-0ubuntu1 @ii umU > (= 3.28.5-0ubuntu0.18.04.3)
  Considering libebackend-1.2-10:amd64 9 as a solution to libedata-book-1.2-25:amd64 -1
  Removing libedata-book-1.2-25:amd64 rather than change libebackend-1.2-10:amd64
  MarkDelete libedata-book-1.2-25:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-radeon:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-radeon:amd64 -1
  Removing xserver-xorg-video-radeon:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (0) libqbscore1.10:amd64 < 1.10.1+dfsg-1 @ii mK Ib >
Broken libqbscore1.10:amd64 Depends on qbs-common:amd64 < 1.10.1+dfsg-1 -> 1.13.1-2build1 @ii umU > (= 1.10.1+dfsg-1)
  Considering qbs-common:amd64 1 as a solution to libqbscore1.10:amd64 -1
  Removing libqbscore1.10:amd64 rather than change qbs-common:amd64
  MarkDelete libqbscore1.10:amd64 < 1.10.1+dfsg-1 @ii mK Ib > FU=0
Investigating (0) libcupsppdc1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib >
Broken libcupsppdc1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
  Considering libcups2:amd64 355 as a solution to libcupsppdc1:amd64 -2
  Removing libcupsppdc1:amd64 rather than change libcups2:amd64
  MarkDelete libcupsppdc1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
Investigating (0) system76-driver:amd64 < 20.04.30~1614370192~18.04~f560ee1~dev @ii mK Ib >
Broken system76-driver:amd64 Depends on linux-system76:amd64 < 5.3.0-7648.41~1586790036~18.04~600aeb5~dev @ii mR >
  Considering linux-system76:amd64 -1 as a solution to system76-driver:amd64 -2
  Removing system76-driver:amd64 rather than change linux-system76:amd64
  MarkDelete system76-driver:amd64 < 20.04.30~1614370192~18.04~f560ee1~dev @ii mK Ib > FU=0
Investigating (0) libpolkit-backend-1-0:amd64 < 0.105-20ubuntu0.18.04.5 @ii mK Ib >
Broken libpolkit-backend-1-0:amd64 Depends on libpolkit-gobject-1-0:amd64 < 0.105-20ubuntu0.18.04.5 -> 0.105-26ubuntu1 @ii umU > (= 0.105-20ubuntu0.18.04.5)
  Considering libpolkit-gobject-1-0:amd64 136 as a solution to libpolkit-backend-1-0:amd64 -2
  Removing libpolkit-backend-1-0:amd64 rather than change libpolkit-gobject-1-0:amd64
  MarkDelete libpolkit-backend-1-0:amd64 < 0.105-20ubuntu0.18.04.5 @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-nouveau-hwe-16.04:amd64 < 3:14.1 @ii mK Ib >
Broken xserver-xorg-video-nouveau-hwe-16.04:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR >
  Considering xserver-xorg-video-nouveau:amd64 2 as a solution to xserver-xorg-video-nouveau-hwe-16.04:amd64 -2
  Removing xserver-xorg-video-nouveau-hwe-16.04:amd64 rather than change xserver-xorg-video-nouveau:amd64
  MarkDelete xserver-xorg-video-nouveau-hwe-16.04:amd64 < 3:14.1 @ii mK Ib > FU=0
Investigating (0) libpango1.0-0:amd64 < 1.40.14-1ubuntu0.1 @ii mK Ib >
Broken libpango1.0-0:amd64 Depends on libpango-1.0-0:amd64 < 1.40.14-1ubuntu0.1 -> 1.44.7-2ubuntu4 @ii umU > (= 1.40.14-1ubuntu0.1)
  Considering libpango-1.0-0:amd64 631 as a solution to libpango1.0-0:amd64 -2
  Removing libpango1.0-0:amd64 rather than change libpango-1.0-0:amd64
  MarkDelete libpango1.0-0:amd64 < 1.40.14-1ubuntu0.1 @ii mK Ib > FU=0
Investigating (0) python3-pyqt4:amd64 < 4.12.1+dfsg-2 @ii mK Ib >
Broken python3-pyqt4:amd64 Depends on python3:amd64 < 3.6.7-1~18.04 -> 3.8.2-0ubuntu2 @ii umU > (< 3.7)
  Considering python3:amd64 497 as a solution to python3-pyqt4:amd64 -2
  Removing python3-pyqt4:amd64 rather than change python3:amd64
  MarkDelete python3-pyqt4:amd64 < 4.12.1+dfsg-2 @ii mK Ib > FU=0
Investigating (0) sni-qt:amd64 < 0.2.7+17.04.20170112-0ubuntu1 @ii mK Ib >
Broken sni-qt:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.7.3-1ubuntu3~)
  Considering libqtcore4:amd64 39 as a solution to sni-qt:amd64 -2
  Removing sni-qt:amd64 rather than change libqtcore4:amd64
  MarkDelete sni-qt:amd64 < 0.2.7+17.04.20170112-0ubuntu1 @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-intel-hwe-16.04:amd64 < 3:14.1 @ii mK Ib >
Broken xserver-xorg-video-intel-hwe-16.04:amd64 Depends on xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mR >
  Considering xserver-xorg-video-intel:amd64 2 as a solution to xserver-xorg-video-intel-hwe-16.04:amd64 -2
  Removing xserver-xorg-video-intel-hwe-16.04:amd64 rather than change xserver-xorg-video-intel:amd64
  MarkDelete xserver-xorg-video-intel-hwe-16.04:amd64 < 3:14.1 @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-ati-hwe-16.04:amd64 < 3:14.1 @ii mK Ib >
Broken xserver-xorg-video-ati-hwe-16.04:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR >
  Considering xserver-xorg-video-ati:amd64 2 as a solution to xserver-xorg-video-ati-hwe-16.04:amd64 -2
  Removing xserver-xorg-video-ati-hwe-16.04:amd64 rather than change xserver-xorg-video-ati:amd64
  MarkDelete xserver-xorg-video-ati-hwe-16.04:amd64 < 3:14.1 @ii mK Ib > FU=0
Investigating (0) libcupscgi1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib >
Broken libcupscgi1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
  Considering libcups2:amd64 355 as a solution to libcupscgi1:amd64 -2
  Removing libcupscgi1:amd64 rather than change libcups2:amd64
  MarkDelete libcupscgi1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
Investigating (0) libedata-cal-1.2-28:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib >
Broken libedata-cal-1.2-28:amd64 Depends on libebackend-1.2-10:amd64 < 3.28.5-0ubuntu0.18.04.3 -> 3.36.4-0ubuntu1 @ii umU > (= 3.28.5-0ubuntu0.18.04.3)
  Considering libebackend-1.2-10:amd64 9 as a solution to libedata-cal-1.2-28:amd64 -2
  Removing libedata-cal-1.2-28:amd64 rather than change libebackend-1.2-10:amd64
  MarkDelete libedata-cal-1.2-28:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib > FU=0
Investigating (0) libapt-inst2.0:amd64 < 1.6.12ubuntu0.2 @ii mK Ib >
Broken libapt-inst2.0:amd64 Depends on libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mR > (>= 1.1~exp9)
  Considering libapt-pkg5.0:amd64 -1 as a solution to libapt-inst2.0:amd64 -2
  Removing libapt-inst2.0:amd64 rather than change libapt-pkg5.0:amd64
  MarkDelete libapt-inst2.0:amd64 < 1.6.12ubuntu0.2 @ii mK Ib > FU=0
Investigating (0) libqt5organizer5:amd64 < 5.0~git20140515~29475884-0ubuntu24~7 @ii mK Ib >
Broken libqt5organizer5:amd64 Depends on qtbase-abi-5-9-5:amd64 < none @un H >
  Considering libqt5core5a:amd64 1559 as a solution to libqt5organizer5:amd64 -2
  Removing libqt5organizer5:amd64 rather than change qtbase-abi-5-9-5:amd64
  MarkDelete libqt5organizer5:amd64 < 5.0~git20140515~29475884-0ubuntu24~7 @ii mK Ib > FU=0
Investigating (0) musescore:amd64 < 2.1.0+dfsg3-3build1 @ii mK Ib >
Broken musescore:amd64 Depends on libqt5core5a:amd64 < 5.9.5+dfsg-0ubuntu2.5 -> 5.12.8+dfsg-0ubuntu1 @ii umU > (< 5.10)
  Considering libqt5core5a:amd64 1559 as a solution to musescore:amd64 -2
  Removing musescore:amd64 rather than change libqt5core5a:amd64
  MarkDelete musescore:amd64 < 2.1.0+dfsg3-3build1 @ii mK Ib > FU=0
Investigating (0) libqbsqtprofilesetup1.10:amd64 < 1.10.1+dfsg-1 @ii mK Ib >
Broken libqbsqtprofilesetup1.10:amd64 Depends on libqbscore1.10:amd64 < 1.10.1+dfsg-1 @ii mR > (>= 1.10.0)
  Considering libqbscore1.10:amd64 -1 as a solution to libqbsqtprofilesetup1.10:amd64 -2
  Removing libqbsqtprofilesetup1.10:amd64 rather than change libqbscore1.10:amd64
  MarkDelete libqbsqtprofilesetup1.10:amd64 < 1.10.1+dfsg-1 @ii mK Ib > FU=0
Investigating (0) libcupsmime1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib >
Broken libcupsmime1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
  Considering libcups2:amd64 355 as a solution to libcupsmime1:amd64 -2
  Removing libcupsmime1:amd64 rather than change libcups2:amd64
  MarkDelete libcupsmime1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
Investigating (0) qt4-linguist-tools:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken qt4-linguist-tools:amd64 Depends on libqt4-xml:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-xml:amd64 5 as a solution to qt4-linguist-tools:amd64 -2
  Removing qt4-linguist-tools:amd64 rather than change libqt4-xml:amd64
  MarkDelete qt4-linguist-tools:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libept1.5.0:amd64 < 1.1+nmu3build1 @ii mK Ib >
Broken libept1.5.0:amd64 Depends on libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mR > (>= 1.1~exp9)
  Considering libapt-pkg5.0:amd64 -1 as a solution to libept1.5.0:amd64 -2
  Removing libept1.5.0:amd64 rather than change libapt-pkg5.0:amd64
  MarkDelete libept1.5.0:amd64 < 1.1+nmu3build1 @ii mK Ib > FU=0
Investigating (0) python3-dbus.mainloop.qt:amd64 < 4.12.1+dfsg-2 @ii mK Ib >
Broken python3-dbus.mainloop.qt:amd64 Depends on python3:amd64 < 3.6.7-1~18.04 -> 3.8.2-0ubuntu2 @ii umU > (< 3.7)
  Considering python3:amd64 497 as a solution to python3-dbus.mainloop.qt:amd64 -2
  Removing python3-dbus.mainloop.qt:amd64 rather than change python3:amd64
  MarkDelete python3-dbus.mainloop.qt:amd64 < 4.12.1+dfsg-2 @ii mK Ib > FU=0
Investigating (0) libebook-1.2-19:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib >
Broken libebook-1.2-19:amd64 Depends on libedata-book-1.2-25:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mR > (= 3.28.5-0ubuntu0.18.04.3)
  Considering libedata-book-1.2-25:amd64 -1 as a solution to libebook-1.2-19:amd64 -2
  Removing libebook-1.2-19:amd64 rather than change libedata-book-1.2-25:amd64
  MarkDelete libebook-1.2-19:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib > FU=0
Investigating (1) xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii umU Ib >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR >
  Considering xserver-xorg-video-amdgpu:amd64 1 as a solution to xserver-xorg-video-all:amd64 6
  Added xserver-xorg-video-amdgpu:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR >
  Considering xserver-xorg-video-ati:amd64 2 as a solution to xserver-xorg-video-all:amd64 6
  Added xserver-xorg-video-ati:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR >
  Considering xserver-xorg-video-nouveau:amd64 2 as a solution to xserver-xorg-video-all:amd64 6
  Added xserver-xorg-video-nouveau:amd64 to the remove list
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-amdgpu:amd64
  MarkKeep xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-ati:amd64
  MarkKeep xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-nouveau:amd64
  MarkKeep xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR > FU=0
Investigating (1) va-driver-all:i386 < none -> 2.7.0-2 @un uN Ib >
Broken va-driver-all:i386 Depends on i965-va-driver:i386 < none | 2.4.0-0ubuntu1 @un uH >
  Considering i965-va-driver:i386 -1 as a solution to va-driver-all:i386 5
  MarkKeep va-driver-all:i386 < none -> 2.7.0-2 @un uN Ib > FU=0
  Holding Back va-driver-all:i386 rather than change i965-va-driver:i386
Broken va-driver-all:i386 Depends on i965-va-driver-shaders:i386 < none | 2.4.0-1build1 @un uH >
  Considering i965-va-driver-shaders:i386 1 as a solution to va-driver-all:i386 5
  MarkKeep va-driver-all:i386 < none -> 2.7.0-2 @un uN Ib > FU=0
  Holding Back va-driver-all:i386 rather than change i965-va-driver-shaders:i386
  Or group keep for va-driver-all:i386
  MarkKeep va-driver-all:i386 < none -> 2.7.0-2 @un uN Ib > FU=0
Broken va-driver-all:i386 Depends on mesa-va-drivers:i386 < none | 20.2.6-0ubuntu0.20.04.1 @un uH >
  Considering mesa-va-drivers:i386 -1 as a solution to va-driver-all:i386 5
  Holding Back va-driver-all:i386 rather than change mesa-va-drivers:i386
Investigating (1) libsensors5:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib >
Broken libsensors5:amd64 Depends on libsensors-config:amd64 < none | 1:3.6.0-2ubuntu1 @un uH >
  Considering libsensors-config:amd64 2 as a solution to libsensors5:amd64 5
  MarkKeep libsensors5:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib > FU=0
  Holding Back libsensors5:amd64 rather than change libsensors-config:amd64
Investigating (1) vdpau-driver-all:amd64 < 1.1.1-3ubuntu1 -> 1.3-1ubuntu2 @ii umU Ib >
Broken vdpau-driver-all:amd64 Depends on mesa-vdpau-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mR >
  Considering mesa-vdpau-drivers:amd64 -1 as a solution to vdpau-driver-all:amd64 4
  Added mesa-vdpau-drivers:amd64 to the remove list
  Fixing vdpau-driver-all:amd64 via keep of mesa-vdpau-drivers:amd64
  MarkKeep mesa-vdpau-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mR > FU=0
Investigating (1) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-ati:amd64 2
  Removing xserver-xorg-video-ati:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (1) xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-nouveau:amd64 2
  Removing xserver-xorg-video-nouveau:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
Investigating (1) libsnmp35:i386 < none -> 5.8+dfsg-2ubuntu2.3 @un uN Ib >
Broken libsnmp35:i386 Depends on libsensors5:i386 < none | 1:3.6.0-2ubuntu1 @un uH > (>= 1:3.5.0)
  Considering libsensors5:i386 0 as a solution to libsnmp35:i386 1
  MarkKeep libsnmp35:i386 < none -> 5.8+dfsg-2ubuntu2.3 @un uN Ib > FU=0
  Holding Back libsnmp35:i386 rather than change libsensors5:i386
Investigating (1) vdpau-driver-all:i386 < none -> 1.3-1ubuntu2 @un uN Ib >
Broken vdpau-driver-all:i386 Depends on mesa-vdpau-drivers:i386 < none | 20.2.6-0ubuntu0.20.04.1 @un uH >
  Considering mesa-vdpau-drivers:i386 -1 as a solution to vdpau-driver-all:i386 1
  MarkKeep vdpau-driver-all:i386 < none -> 1.3-1ubuntu2 @un uN Ib > FU=0
  Holding Back vdpau-driver-all:i386 rather than change mesa-vdpau-drivers:i386
Investigating (1) xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-amdgpu:amd64 1
  Removing xserver-xorg-video-amdgpu:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
Investigating (1) clang:amd64 < 1:6.0-41~exp5~ubuntu1 -> 1:10.0-50~exp1 @ii umU Ib >
Broken clang:amd64 Depends on clang-10:amd64 < none | 1:10.0.0-4ubuntu1 @un uH > (>= 10~)
  Considering clang-10:amd64 1 as a solution to clang:amd64 1
  MarkKeep clang:amd64 < 1:6.0-41~exp5~ubuntu1 -> 1:10.0-50~exp1 @ii umU Ib > FU=0
  Holding Back clang:amd64 rather than change clang-10:amd64
Investigating (1) lm-sensors:amd64 < 1:3.4.0-4 -> 1:3.6.0-2ubuntu1 @ii umU Ib >
Broken lm-sensors:amd64 Depends on libsensors5:amd64 < none | 1:3.6.0-2ubuntu1 @un uH > (>= 1:3.5.0)
  Considering libsensors5:amd64 5 as a solution to lm-sensors:amd64 1
  MarkKeep lm-sensors:amd64 < 1:3.4.0-4 -> 1:3.6.0-2ubuntu1 @ii umU Ib > FU=0
  Holding Back lm-sensors:amd64 rather than change libsensors5:amd64
 Try to Re-Instate (1) libboost-dev:amd64
  MarkKeep libboost-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
Investigating (1) libsensors4-dev:amd64 < 1:3.4.0-4 -> 1:3.6.0-2ubuntu1 @ii umU Ib >
Broken libsensors4-dev:amd64 Depends on libsensors5:amd64 < none | 1:3.6.0-2ubuntu1 @un uH > (= 1:3.6.0-2ubuntu1)
  Considering libsensors5:amd64 5 as a solution to libsensors4-dev:amd64 -1
  MarkKeep libsensors4-dev:amd64 < 1:3.4.0-4 -> 1:3.6.0-2ubuntu1 @ii umU Ib > FU=0
  Holding Back libsensors4-dev:amd64 rather than change libsensors5:amd64
Investigating (2) libsnmp35:amd64 < none -> 5.8+dfsg-2ubuntu2.3 @un uN Ib >
Broken libsnmp35:amd64 Depends on libsensors5:amd64 < none | 1:3.6.0-2ubuntu1 @un uH > (>= 1:3.5.0)
  Considering libsensors5:amd64 5 as a solution to libsnmp35:amd64 12
  MarkKeep libsnmp35:amd64 < none -> 5.8+dfsg-2ubuntu2.3 @un uN Ib > FU=0
  Holding Back libsnmp35:amd64 rather than change libsensors5:amd64
Investigating (2) libhpmud0:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib >
Broken libhpmud0:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un uH > (>= 5.8+dfsg)
  Considering libsnmp35:amd64 12 as a solution to libhpmud0:amd64 6
  MarkKeep libhpmud0:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
  Holding Back libhpmud0:amd64 rather than change libsnmp35:amd64
Investigating (2) xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii umU Ib >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR >
  Considering xserver-xorg-video-amdgpu:amd64 1 as a solution to xserver-xorg-video-all:amd64 6
  Added xserver-xorg-video-amdgpu:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR >
  Considering xserver-xorg-video-ati:amd64 2 as a solution to xserver-xorg-video-all:amd64 6
  Added xserver-xorg-video-ati:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR >
  Considering xserver-xorg-video-nouveau:amd64 2 as a solution to xserver-xorg-video-all:amd64 6
  Added xserver-xorg-video-nouveau:amd64 to the remove list
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-amdgpu:amd64
  MarkKeep xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-ati:amd64
  MarkKeep xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-nouveau:amd64
  MarkKeep xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR > FU=0
Investigating (2) libsane:i386 < none -> 1.0.29-0ubuntu5.2 @un uN Ib >
Broken libsane:i386 Depends on libsnmp35:i386 < none | 5.8+dfsg-2ubuntu2.3 @un uH > (>= 5.8+dfsg)
  Considering libsnmp35:i386 1 as a solution to libsane:i386 2
  MarkKeep libsane:i386 < none -> 1.0.29-0ubuntu5.2 @un uN Ib > FU=0
  Holding Back libsane:i386 rather than change libsnmp35:i386
Investigating (2) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-ati:amd64 6
  Removing xserver-xorg-video-ati:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (2) hplip:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib >
Broken hplip:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH > (= 3.20.3+dfsg0-2)
  Considering libhpmud0:amd64 6 as a solution to hplip:amd64 2
  MarkKeep hplip:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
  Removing hplip:amd64 rather than change libhpmud0:amd64
  MarkDelete hplip:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH Ib > FU=0
Investigating (2) xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-nouveau:amd64 6
  Removing xserver-xorg-video-nouveau:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
Investigating (2) printer-driver-hpcups:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib >
Broken printer-driver-hpcups:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH > (>= 3.20.3+dfsg0)
  Considering libhpmud0:amd64 6 as a solution to printer-driver-hpcups:amd64 2
  MarkKeep printer-driver-hpcups:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
  Holding Back printer-driver-hpcups:amd64 rather than change libhpmud0:amd64
Investigating (2) libsane-hpaio:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib >
Broken libsane-hpaio:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH > (>= 3.20.3+dfsg0)
  Considering libhpmud0:amd64 6 as a solution to libsane-hpaio:amd64 2
  MarkKeep libsane-hpaio:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
  Holding Back libsane-hpaio:amd64 rather than change libhpmud0:amd64
Investigating (2) xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-amdgpu:amd64 6
  Removing xserver-xorg-video-amdgpu:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
 Try to Re-Instate (2) clang:amd64
  MarkKeep clang:amd64 < 1:6.0-41~exp5~ubuntu1 -> 1:10.0-50~exp1 @ii umU Ib > FU=0
 Try to Re-Instate (2) lm-sensors:amd64
  MarkKeep lm-sensors:amd64 < 1:3.4.0-4 -> 1:3.6.0-2ubuntu1 @ii umU Ib > FU=0
Investigating (2) libsane1:i386 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib >
Broken libsane1:i386 Depends on libsane:i386 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.29-0ubuntu5.2)
  Considering libsane:i386 2 as a solution to libsane1:i386 0
  MarkKeep libsane1:i386 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
  Removing libsane1:i386 rather than change libsane:i386
  MarkDelete libsane1:i386 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umH Ib > FU=0
Investigating (2) libsnmp-dev:amd64 < 5.7.3+dfsg-1.8ubuntu3.6 -> 5.8+dfsg-2ubuntu2.3 @ii umU Ib >
Broken libsnmp-dev:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un uH > (= 5.8+dfsg-2ubuntu2.3)
  Considering libsnmp35:amd64 12 as a solution to libsnmp-dev:amd64 0
  MarkKeep libsnmp-dev:amd64 < 5.7.3+dfsg-1.8ubuntu3.6 -> 5.8+dfsg-2ubuntu2.3 @ii umU Ib > FU=0
  Holding Back libsnmp-dev:amd64 rather than change libsnmp35:amd64
 Try to Re-Instate (2) libsensors4-dev:amd64
  MarkKeep libsensors4-dev:amd64 < 1:3.4.0-4 -> 1:3.6.0-2ubuntu1 @ii umU Ib > FU=0
Investigating (3) libsane:amd64 < none -> 1.0.29-0ubuntu5.2 @un uN Ib >
Broken libsane:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un uH > (>= 5.8+dfsg)
  Considering libsnmp35:amd64 12 as a solution to libsane:amd64 16
  MarkKeep libsane:amd64 < none -> 1.0.29-0ubuntu5.2 @un uN Ib > FU=0
  Holding Back libsane:amd64 rather than change libsnmp35:amd64
Investigating (3) sane-utils:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib >
Broken sane-utils:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.27)
  Considering libsane:amd64 16 as a solution to sane-utils:amd64 12
  MarkKeep sane-utils:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
  Holding Back sane-utils:amd64 rather than change libsane:amd64
 Try to Re-Instate (3) libhpmud0:amd64
  MarkKeep libhpmud0:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
Investigating (3) xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii umU Ib >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR >
  Considering xserver-xorg-video-amdgpu:amd64 28 as a solution to xserver-xorg-video-all:amd64 6
  MarkKeep xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii umU Ib > FU=0
  Removing xserver-xorg-video-all:amd64 rather than change xserver-xorg-video-amdgpu:amd64
  MarkDelete xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 | 1:7.7+19ubuntu14 @ii umH Ib > FU=0
Investigating (3) xsane:amd64 < 0.999-5ubuntu2 -> 0.999-8ubuntu2.1 @ii umU Ib >
Broken xsane:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.24)
  Considering libsane:amd64 16 as a solution to xsane:amd64 2
  MarkKeep xsane:amd64 < 0.999-5ubuntu2 -> 0.999-8ubuntu2.1 @ii umU Ib > FU=0
  Removing xsane:amd64 rather than change libsane:amd64
  MarkDelete xsane:amd64 < 0.999-5ubuntu2 | 0.999-8ubuntu2.1 @ii umH Ib > FU=0
 Try to Re-Instate (3) printer-driver-hpcups:amd64
  MarkKeep printer-driver-hpcups:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
 Try to Re-Instate (3) libsane-hpaio:amd64
  MarkKeep libsane-hpaio:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
Investigating (3) libsane1:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib >
Broken libsane1:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.29-0ubuntu5.2)
  Considering libsane:amd64 16 as a solution to libsane1:amd64 0
  MarkKeep libsane1:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
  Removing libsane1:amd64 rather than change libsane:amd64
  MarkDelete libsane1:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umH Ib > FU=0
 Try to Re-Instate (3) libsnmp-dev:amd64
  MarkKeep libsnmp-dev:amd64 < 5.7.3+dfsg-1.8ubuntu3.6 -> 5.8+dfsg-2ubuntu2.3 @ii umU Ib > FU=0
Investigating (3) simple-scan:amd64 < 3.28.0-0ubuntu1 -> 3.36.3-0ubuntu0.20.04.0 @ii umU Ib >
Broken simple-scan:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.24)
  Considering libsane:amd64 16 as a solution to simple-scan:amd64 0
  MarkKeep simple-scan:amd64 < 3.28.0-0ubuntu1 -> 3.36.3-0ubuntu0.20.04.0 @ii umU Ib > FU=0
  Removing simple-scan:amd64 rather than change libsane:amd64
  MarkDelete simple-scan:amd64 < 3.28.0-0ubuntu1 | 3.36.3-0ubuntu0.20.04.0 @ii umH Ib > FU=0
Investigating (3) libsane-dev:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib >
Broken libsane-dev:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (= 1.0.29-0ubuntu5.2)
  Considering libsane:amd64 16 as a solution to libsane-dev:amd64 0
  MarkKeep libsane-dev:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
  Removing libsane-dev:amd64 rather than change libsane:amd64
  MarkDelete libsane-dev:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umH Ib > FU=0
Investigating (3) xserver-xorg-video-all-hwe-16.04:amd64 < 3:14.1 @ii mK Ib >
Broken xserver-xorg-video-all-hwe-16.04:amd64 Depends on xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 | 1:7.7+19ubuntu14 @ii umR >
  Considering xserver-xorg-video-all:amd64 28 as a solution to xserver-xorg-video-all-hwe-16.04:amd64 -2
  Removing xserver-xorg-video-all-hwe-16.04:amd64 rather than change xserver-xorg-video-all:amd64
  MarkDelete xserver-xorg-video-all-hwe-16.04:amd64 < 3:14.1 @ii mK Ib > FU=0
Investigating (4) colord:amd64 < 1.3.3-2build1 -> 1.4.4-2 @ii umU Ib >
Broken colord:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.24)
  Considering libsane:amd64 16 as a solution to colord:amd64 27
  Added libsane:amd64 to the remove list
  Fixing colord:amd64 via keep of libsane:amd64
 Try to Re-Instate (4) sane-utils:amd64
  MarkKeep sane-utils:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
Investigating (4) sane-utils:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umH Ib >
Broken sane-utils:amd64 Depends on libsane1:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umR > (>= 1.0.27)
  Considering libsane1:amd64 16 as a solution to sane-utils:amd64 12
  Removing sane-utils:amd64 rather than change libsane1:amd64
  MarkDelete sane-utils:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umH Ib > FU=0
Investigating (5) colord:amd64 < 1.3.3-2build1 -> 1.4.4-2 @ii umU Ib >
Broken colord:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.24)
  Considering libsane:amd64 27 as a solution to colord:amd64 27
  MarkKeep colord:amd64 < 1.3.3-2build1 -> 1.4.4-2 @ii umU Ib > FU=0
  Removing colord:amd64 rather than change libsane:amd64
  MarkDelete colord:amd64 < 1.3.3-2build1 | 1.4.4-2 @ii umH Ib > FU=0
Done
  MarkInstall xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii ugU Ib > FU=1
  Installing xserver-xorg-video-amdgpu as Depends of xserver-xorg-video-all
      MarkKeep xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii gR > FU=0
  Installing xserver-xorg-video-ati as Depends of xserver-xorg-video-all
      MarkKeep xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii gR > FU=0
  Installing xserver-xorg-video-nouveau as Depends of xserver-xorg-video-all
      MarkKeep xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii gR > FU=0
  previously satisfied important dependency on xserver-xorg-video-intel:amd64
  Installing xserver-xorg-video-intel as Recommends of xserver-xorg-video-all
      MarkKeep xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii gR > FU=0
Starting pkgProblemResolver with broken count: 4
Starting 2 pkgProblemResolver with broken count: 4
Investigating (0) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 27 as a solution to xserver-xorg-video-ati:amd64 0
  Removing xserver-xorg-video-ati:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 27 as a solution to xserver-xorg-video-intel:amd64 0
  Removing xserver-xorg-video-intel:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 27 as a solution to xserver-xorg-video-nouveau:amd64 0
  Removing xserver-xorg-video-nouveau:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 27 as a solution to xserver-xorg-video-amdgpu:amd64 0
  Removing xserver-xorg-video-amdgpu:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
Investigating (1) xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii pumU Ib >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR >
  Considering xserver-xorg-video-amdgpu:amd64 0 as a solution to xserver-xorg-video-all:amd64 10005
  Added xserver-xorg-video-amdgpu:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR >
  Considering xserver-xorg-video-ati:amd64 0 as a solution to xserver-xorg-video-all:amd64 10005
  Added xserver-xorg-video-ati:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR >
  Considering xserver-xorg-video-nouveau:amd64 0 as a solution to xserver-xorg-video-all:amd64 10005
  Added xserver-xorg-video-nouveau:amd64 to the remove list
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-amdgpu:amd64
  MarkKeep xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-ati:amd64
  MarkKeep xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-nouveau:amd64
  MarkKeep xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR > FU=0
Investigating (1) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 27 as a solution to xserver-xorg-video-ati:amd64 0
  Removing xserver-xorg-video-ati:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (1) xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 27 as a solution to xserver-xorg-video-nouveau:amd64 0
  Removing xserver-xorg-video-nouveau:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
Investigating (1) xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 27 as a solution to xserver-xorg-video-amdgpu:amd64 0
  Removing xserver-xorg-video-amdgpu:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
Investigating (2) xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii pumU Ib >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR >
  Considering xserver-xorg-video-amdgpu:amd64 0 as a solution to xserver-xorg-video-all:amd64 10005
  Added xserver-xorg-video-amdgpu:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR >
  Considering xserver-xorg-video-ati:amd64 0 as a solution to xserver-xorg-video-all:amd64 10005
  Added xserver-xorg-video-ati:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR >
  Considering xserver-xorg-video-nouveau:amd64 0 as a solution to xserver-xorg-video-all:amd64 10005
  Added xserver-xorg-video-nouveau:amd64 to the remove list
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-amdgpu:amd64
  MarkKeep xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-ati:amd64
  MarkKeep xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-nouveau:amd64
  MarkKeep xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR > FU=0
Investigating (2) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 27 as a solution to xserver-xorg-video-ati:amd64 10005
  Added xserver-xorg-core:amd64 to the remove list
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii gR >
  Considering xserver-xorg-video-radeon:amd64 1 as a solution to xserver-xorg-video-ati:amd64 10005
  Added xserver-xorg-video-radeon:amd64 to the remove list
  Fixing xserver-xorg-video-ati:amd64 via keep of xserver-xorg-core:amd64
  MarkKeep xserver-xorg-core:amd64 < 2:1.19.6-1ubuntu4.8 -> 2:1.20.9-2ubuntu1.2~20.04.1 @ii umU > FU=0
  Fixing xserver-xorg-video-ati:amd64 via keep of xserver-xorg-video-radeon:amd64
  MarkKeep xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii gR > FU=0
 Try to Re-Instate (3) xserver-xorg-core:amd64
Re-Instated xserver-xorg-core:amd64 (4 vs 4)
Investigating (3) xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii gK Ib >
Broken xserver-xorg-video-radeon:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 10005 as a solution to xserver-xorg-video-radeon:amd64 10005
  Removing xserver-xorg-video-radeon:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii gK Ib > FU=0
Investigating (3) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 10005 as a solution to xserver-xorg-video-ati:amd64 10005
  Removing xserver-xorg-video-ati:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (3) xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 10005 as a solution to xserver-xorg-video-nouveau:amd64 10005
  Removing xserver-xorg-video-nouveau:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
Investigating (3) xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 10005 as a solution to xserver-xorg-video-amdgpu:amd64 10005
  Removing xserver-xorg-video-amdgpu:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
Investigating (4) xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii pumU Ib >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR >
  Considering xserver-xorg-video-amdgpu:amd64 10005 as a solution to xserver-xorg-video-all:amd64 10005
  Considering xserver-xorg-video-amdgpu:amd64 10005 as a solution to xserver-xorg-video-all:amd64 10005
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR >
  Considering xserver-xorg-video-ati:amd64 10005 as a solution to xserver-xorg-video-all:amd64 10005
  Considering xserver-xorg-video-ati:amd64 10005 as a solution to xserver-xorg-video-all:amd64 10005
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR >
  Considering xserver-xorg-video-nouveau:amd64 10005 as a solution to xserver-xorg-video-all:amd64 10005
  Considering xserver-xorg-video-nouveau:amd64 10005 as a solution to xserver-xorg-video-all:amd64 10005
Done
Log time: 2021-03-23 17:23:00.582987

I don't really know how to read these logs.

For example, in main.log, at line 108, t=2021-03-23 17:22:57,995, does the error refer to the previous line? Does this mean that 'xserver-xorg-video-all' has some sort of problem? Am I supposed to remove this package in order to proceed? Isn't this package part of the OS? Would I break my system trying to remove this?

Here is another thing I don't understand, in apt.log, starting at line 1451, there is a line stating, "Starting pkgProblemResolver with broken count: 49" followed by a long sequence of "Broken something-something" (whatever that means) and there are more than 49 of these! What is the package that is broken? How do I fix this? For example, the very first one is "Broken dpkg:amd64"! WHAT?! My dpkg is broken??? What the hell does that mean?!

When I run commands such as:

sudo apt update
sudo apt upgrade
sudo apt dist-upgrade

I don't get anything useful:
$ sudo apt update
Get:1 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]
Hit:2 http://ca.archive.ubuntu.com/ubuntu bionic InRelease
Hit:3 http://ca.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:4 http://ca.archive.ubuntu.com/ubuntu bionic-backports InRelease
Fetched 88.7 kB in 1s (159 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
$ sudo apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
$ sudo apt dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
$

"My Brain Hurts!"

Manfred Hampl (m-hampl) said : #4

You copied everything except the crucial part of the message:

    This was likely caused by:
    Unofficial software packages not provided by Ubuntu
    Please use the tool 'ppa-purge' from the ppa-purge
    package to remove software from a Launchpad PPA and
    try the upgrade again.

This is the case on your system. You have added software from outside Ubuntu, namely the oibaf PPA.

That "the crucial part of the message" you mention does not appear in the terminal output while do-release-upgrade is executing.

Where do you get the information that the oibaf ppa is installed? I don't have such a PPA.

What am I doing wrong?

$ sudo ppa-purge ppa:oibaf/graphics-drivers
Updating packages lists
PPA to be removed: oibaf graphics-drivers
Warning: Could not find package list for PPA: oibaf graphics-drivers
$

So I tried adding the ppa and purging it again:

$ sudo add-apt-repository ppa:oibaf/graphics-drivers
 PLEASE READ: don't email me to report bugs, unless you are sure it's a packaging bug. Not only is email not a good tool for tracking bugs, it also excludes anybody else from tracking or working on the issue. Please read the section "Debugging and reporting problems" below.

Also, please don't ask me to include non-free drivers, I won't do it.

Patches and suggestions are welcomed.

=============

All Ubuntu architectures are supported.

Supported Ubuntu versions:
- 20.04 (focal) <- supported
- 20.10 (groovy) <- supported
- 21.04 (hirsute) <- supported

For forum support see: http://goo.gl/qoUpWK

=== Introduction ===
This PPA provides updated free graphics drivers packages for radeon, intel and nvidia hardware. Updates packages provide:
 * all driver packages are automagically built twice a day, when there are upstream changes
 * Vulkan 1.2+ on recent intel and radeon GPU
 * OpenGL 4.6+ support and new OpenGL extensions: http://mesamatrix.net
 * gallium-nine support. Read the specific section below
 * VDPAU and VAAPI Gallium3D accelerated video drivers (see below)
 * packages built against latest stable LLVM
 * Intel iris driver enabled by default
 * mesa packages built with gcc LTO for smaller binary size (~10-15%) and improved performance

As an added bonus I may include some updated open source games (backported from Debian or newer Ubuntu).

=== Basic usage ===
See "Adding this PPA to your system" later on, or just do:
sudo add-apt-repository ppa:oibaf/graphics-drivers
and update your Ubuntu with the package here.

=== Using gallium-nine ===
Gallium-nine lets you run DirectX 9 games in a faster way, avoiding the inefficient translation of D3D9 calls to OpenGL. For more info see https://wiki.ixit.cz/d3d9
You need:
 * enable this PPA (see previous paragraph)
 * then follow the instructions to install wine from this PPA: https://launchpad.net/~commendsarnex/+archive/ubuntu/winedri3

=== Using alternative drivers - Here be dragons ===
* zink - OpenGL emulated on a Vulkan driver:
  Set MESA_LOADER_DRIVER_OVERRIDE=zink
* Old Intel i965 OpenGL driver (iris is the default):
  Set MESA_LOADER_DRIVER_OVERRIDE=i965
* llvmpipe OpenGL software render:
  Set MESA_LOADER_DRIVER_OVERRIDE=llvmpipe
* Other options here: https://www.mesa3d.org/envvars.html

=== Using accelerated video ===
Supported VDPAU drivers: r300, r600, radeonsi, nouveau
Supported VAAPI drivers: r600, radeonsi

* First you need to install mesa-vdpau-drivers package:
sudo apt-get install mesa-vdpau-drivers

* Then to test the VDPAU driver with mpv use:
$ mpv --hwdec=vdpau yourvideofile

=== Upgrading to a newer Ubuntu ===
It is *strongly* suggested to remove all packages from this PPA before updating to a newer Ubuntu release. See the section "Revert to original drivers" later on.
Then, after the upgrade, you can add again this PPA.

=== Debugging and reporting problems ===
If you have some problem with the drivers try running the application from the command line and see if there are graphics related warnings. Also type dmesg to see if there are other related information here.

If you get crashes install the relevant -dbg pacakges (libgl1-mesa-dri-dbg or libgl1-mesa-dri-experimental-dbg for 3D drivers and xserver-xorg-video-intel-dbg , xserver-xorg-video-nouveau-dbg or xserver-xorg-video-radeon-dbg for X drivers) and reproduce the crash with gdb. Example:
$ gdb glxgears
[...make your application crash and then get a backtrace with:]
(gdb) bt

If X.org crashes look at /var/log/Xorg.0.log (or /var/log/Xorg.0.log.old when a new X session is started after the crash).

With the gathered information try searching at https://bugs.freedesktop.org/query.cgi (also try with google) if someone already reported a similar bug. If not you may want to report a new bug:
for 3D drivers bugs: https://www.mesa3d.org/bugs.html
for X / 2D driver bugs: https://bugs.freedesktop.org/enter_bug.cgi?product=xorg

=== Revert to original drivers ===
To revert to standard Ubuntu drivers type the following in a prompt shell:
$ sudo apt-get install ppa-purge
$ sudo ppa-purge ppa:oibaf/graphics-drivers

=== Donations ===
Some people asked me if I can accept donations to support this work. I don't, but if you have some spare money I would be happy if you could do a donation to a charity of your choice (for the poors, animals, whatever else you may think it might need it). Then feel free to send me a note about it!
 More info: https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers
Press [ENTER] to continue or Ctrl-c to cancel adding it.

Hit:1 http://security.ubuntu.com/ubuntu bionic-security InRelease
Hit:2 http://ca.archive.ubuntu.com/ubuntu bionic InRelease
Hit:3 http://ca.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:4 http://ca.archive.ubuntu.com/ubuntu bionic-backports InRelease
Get:5 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu bionic InRelease [20.8 kB]
Get:6 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu bionic/main Translation-en [804 B]
Fetched 21.6 kB in 1s (24.4 kB/s)
Reading package lists... Done
$ sudo ppa-purge ppa:oibaf/graphics-drivers
Updating packages lists
PPA to be removed: oibaf graphics-drivers
Warning: Could not find package list for PPA: oibaf graphics-drivers
$ ls /etc/apt/sources.list.d/
oibaf-ubuntu-graphics-drivers-bionic.list
$ sudo apt update
Hit:1 http://ca.archive.ubuntu.com/ubuntu bionic InRelease
Hit:2 http://security.ubuntu.com/ubuntu bionic-security InRelease
Hit:3 http://ca.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:4 http://ca.archive.ubuntu.com/ubuntu bionic-backports InRelease
Hit:5 http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu bionic InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
$ sudo apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
$

Here is the do-release-upgrade terminal output (I had to make my terminal window big enough to get all the text). Notice the :

Reading cache

Checking package manager
Reading package lists... Done
Building dependency tree
Reading state information... Done
Hit http://ca.archive.ubuntu.com/ubuntu bionic InRelease
Hit http://ca.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit http://ca.archive.ubuntu.com/ubuntu bionic-backports InRelease
Hit http://security.ubuntu.com/ubuntu bionic-security InRelease
Fetched 0 B in 0s (0 B/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
No candidate ver: appmenu-qt5
No candidate ver: kerneloops-daemon
No candidate ver: libdouble-conversion1v5
No candidate ver: libobasis6.2-core
No candidate ver: libobasis6.4-core
No candidate ver: libperl5.22
No candidate ver: libreoffice-style-colibre
No candidate ver: libreoffice6.2-debian-menus
No candidate ver: libreoffice6.4-debian-menus
No candidate ver: libreofficedev6.2-debian-menus
No candidate ver: linux-image-5.0.0-21-generic
No candidate ver: linux-image-5.3.0-20-generic
No candidate ver: linux-image-5.3.0-7625-generic
No candidate ver: linux-image-5.3.0-7629-generic
No candidate ver: linux-modules-5.0.0-21-generic
No candidate ver: linux-modules-5.3.0-20-generic
No candidate ver: linux-modules-5.3.0-7625-generic
No candidate ver: linux-modules-5.3.0-7629-generic
No candidate ver: linux-modules-extra-5.0.0-21-generic
No candidate ver: linux-modules-extra-5.3.0-20-generic
No candidate ver: linux-modules-extra-5.3.0-7625-generic
No candidate ver: linux-modules-extra-5.3.0-7629-generic
No candidate ver: lodevbasis6.2-core
No candidate ver: python3-aptdaemon.pkcompat
No candidate ver: unetbootin
No candidate ver: unity-webapps-common
No candidate ver: unity-webapps-service
No candidate ver: upstart
No candidate ver: webbrowser-app

Updating repository information
Hit http://security.ubuntu.com/ubuntu focal-security InRelease
Hit http://ca.archive.ubuntu.com/ubuntu focal InRelease
Hit http://ca.archive.ubuntu.com/ubuntu focal-updates InRelease
Hit http://ca.archive.ubuntu.com/ubuntu focal-backports InRelease
Fetched 0 B in 0s (0 B/s)

Checking package manager
Reading package lists... Done
Building dependency tree
Reading state information... Done

Calculating the changes

Calculating the changes

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

If none of this applies, then please report this bug using the
command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal. If
you want to investigate this yourself the log files in
'/var/log/dist-upgrade' will contain details about the upgrade.
Specifically, look at 'main.log' and 'apt.log'.

Restoring original system state

Aborting
Reading package lists... Done
Building dependency tree
Reading state information... Done
=== Command detached from window (Wed Mar 24 08:47:09 2021) ===
=== Command terminated with exit status 1 (Wed Mar 24 08:47:19 2021) ===

Manfred Hampl (m-hampl) said : #6

1. From your output

Investigating (1) xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 27 as a solution to xserver-xorg-video-nouveau:amd64 0
  Removing xserver-xorg-video-nouveau:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0

This tells that you have packages form a foreign source installed that uses ~oibaf in the version number (which indicates that we most probably are talking about PPA:oibaf/graphics-drivers ).

2. Apparently the package versions for bionic have already been removed from https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers (I guess early December 2020).
This now has the effect that ppa-purge does no more work and you have top revert to the Ubuntu-provided versions manually.

What is the output of the commands
grep oibaf /etc/apt/sources.list /etc/apt/sources.list.d/*.list
dpkg -l | grep oibaf

The terminal output I added in my last comment was before I re-added the oibaf ppa in an attempt to fix the problem. I have included it again after-re-adding the oibaf ppa, plus I have pasted in the logs again. Notice that the program still does not include the message you mention but it does mention disabling third party sources. The oibaf ppa gets commented out in the main.log.

Nevertheless, is the problem because there are packages that look like they came from the oibaf ppa but somehow got disconnected from that ppa because they have different names or versions or something like that? I really don't understand what's going on. How do I fix this? Why isn't there a "package list" for the oibaf ppa? I can't even remember why I ever added this oibaf ppa in the first place.

So, here is the output with the oibaf ppa added back in (and after the ppa-purge failed) plus the logs:

Reading cache

Checking package manager
Reading package lists... Done
Building dependency tree
Reading state information... Done
Hit http://ca.archive.ubuntu.com/ubuntu bionic InRelease
Hit http://ca.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit http://ca.archive.ubuntu.com/ubuntu bionic-backports InRelease
Hit http://security.ubuntu.com/ubuntu bionic-security InRelease
Hit http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu bionic InRelease
Fetched 0 B in 0s (0 B/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
No candidate ver: appmenu-qt5
No candidate ver: kerneloops-daemon
No candidate ver: libdouble-conversion1v5
No candidate ver: libobasis6.2-core
No candidate ver: libobasis6.4-core
No candidate ver: libperl5.22
No candidate ver: libreoffice-style-colibre
No candidate ver: libreoffice6.2-debian-menus
No candidate ver: libreoffice6.4-debian-menus
No candidate ver: libreofficedev6.2-debian-menus
No candidate ver: linux-image-5.0.0-21-generic
No candidate ver: linux-image-5.3.0-20-generic
No candidate ver: linux-image-5.3.0-7625-generic
No candidate ver: linux-image-5.3.0-7629-generic
No candidate ver: linux-modules-5.0.0-21-generic
No candidate ver: linux-modules-5.3.0-20-generic
No candidate ver: linux-modules-5.3.0-7625-generic
No candidate ver: linux-modules-5.3.0-7629-generic
No candidate ver: linux-modules-extra-5.0.0-21-generic
No candidate ver: linux-modules-extra-5.3.0-20-generic
No candidate ver: linux-modules-extra-5.3.0-7625-generic
No candidate ver: linux-modules-extra-5.3.0-7629-generic
No candidate ver: lodevbasis6.2-core
No candidate ver: python3-aptdaemon.pkcompat
No candidate ver: unetbootin
No candidate ver: unity-webapps-common
No candidate ver: unity-webapps-service
No candidate ver: upstart
No candidate ver: webbrowser-app

Updating repository information

Third party sources disabled

Some third party entries in your sources.list were disabled. You can
re-enable them after the upgrade with the 'software-properties' tool
or your package manager.

To continue please press [ENTER]

Get:1 http://ca.archive.ubuntu.com/ubuntu focal InRelease [265 kB]
Get:2 http://security.ubuntu.com/ubuntu focal-security InRelease [109 kB]
Get:3 http://ca.archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]
Get:4 http://ca.archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]
Get:5 http://ca.archive.ubuntu.com/ubuntu focal/main i386 Packages [718 kB]
Get:6 http://ca.archive.ubuntu.com/ubuntu focal/main amd64 Packages [970 kB]
Get:7 http://ca.archive.ubuntu.com/ubuntu focal/main Translation-en [506 kB]
Get:8 http://ca.archive.ubuntu.com/ubuntu focal/main Translation-en_CA [4,444 B]
Get:9 http://ca.archive.ubuntu.com/ubuntu focal/main amd64 DEP-11 Metadata [494 kB]
Get:10 http://ca.archive.ubuntu.com/ubuntu focal/main DEP-11 48x48 Icons [98.4 kB]
Get:11 http://ca.archive.ubuntu.com/ubuntu focal/main DEP-11 64x64 Icons [163 kB]
Get:12 http://ca.archive.ubuntu.com/ubuntu focal/main amd64 c-n-f Metadata [29.5 kB]
Get:13 http://ca.archive.ubuntu.com/ubuntu focal/restricted amd64 Packages [22.0 kB]
Get:14 http://ca.archive.ubuntu.com/ubuntu focal/restricted i386 Packages [8,112 B]
Get:15 http://ca.archive.ubuntu.com/ubuntu focal/restricted Translation-en [6,212 B]
Get:16 http://ca.archive.ubuntu.com/ubuntu focal/restricted amd64 c-n-f Metadata [392 B]
Get:17 http://ca.archive.ubuntu.com/ubuntu focal/universe i386 Packages [4,642 kB]
Get:18 http://security.ubuntu.com/ubuntu focal-security/main amd64 Packages [574 kB]
Get:19 http://ca.archive.ubuntu.com/ubuntu focal/universe amd64 Packages [8,628 kB]
Get:20 http://ca.archive.ubuntu.com/ubuntu focal/universe Translation-en_CA [1,132 B]
Get:21 http://ca.archive.ubuntu.com/ubuntu focal/universe Translation-en [5,124 kB]
Get:22 http://security.ubuntu.com/ubuntu focal-security/main i386 Packages [210 kB]
Get:23 http://security.ubuntu.com/ubuntu focal-security/main Translation-en [120 kB]
Get:24 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [24.3 kB]
Get:25 http://security.ubuntu.com/ubuntu focal-security/main DEP-11 48x48 Icons [11.0 kB]
Get:26 http://security.ubuntu.com/ubuntu focal-security/main DEP-11 64x64 Icons [16.5 kB]
Get:27 http://security.ubuntu.com/ubuntu focal-security/main amd64 c-n-f Metadata [7,376 B]
Get:28 http://security.ubuntu.com/ubuntu focal-security/restricted i386 Packages [14.9 kB]
Get:29 http://security.ubuntu.com/ubuntu focal-security/restricted amd64 Packages [148 kB]
Get:30 http://security.ubuntu.com/ubuntu focal-security/restricted Translation-en [21.6 kB]
Get:31 http://security.ubuntu.com/ubuntu focal-security/restricted amd64 c-n-f Metadata [392 B]
Get:32 http://security.ubuntu.com/ubuntu focal-security/universe i386 Packages [436 kB]
Get:33 http://ca.archive.ubuntu.com/ubuntu focal/universe amd64 DEP-11 Metadata [3,603 kB]
Get:34 http://security.ubuntu.com/ubuntu focal-security/universe amd64 Packages [550 kB]
Get:35 http://security.ubuntu.com/ubuntu focal-security/universe Translation-en [81.2 kB]
Get:36 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [58.2 kB]
Get:37 http://security.ubuntu.com/ubuntu focal-security/universe DEP-11 48x48 Icons [26.7 kB]
Get:38 http://security.ubuntu.com/ubuntu focal-security/universe DEP-11 64x64 Icons [46.0 kB]
Get:39 http://security.ubuntu.com/ubuntu focal-security/universe amd64 c-n-f Metadata [10.6 kB]
Get:40 http://security.ubuntu.com/ubuntu focal-security/multiverse i386 Packages [2,520 B]
Get:41 http://security.ubuntu.com/ubuntu focal-security/multiverse amd64 Packages [14.8 kB]
Get:42 http://security.ubuntu.com/ubuntu focal-security/multiverse Translation-en [3,160 B]
Get:43 http://ca.archive.ubuntu.com/ubuntu focal/universe DEP-11 48x48 Icons [3,016 kB]
Get:44 http://security.ubuntu.com/ubuntu focal-security/multiverse amd64 c-n-f Metadata [340 B]
Get:45 http://ca.archive.ubuntu.com/ubuntu focal/universe DEP-11 64x64 Icons [7,794 kB]
Get:46 http://ca.archive.ubuntu.com/ubuntu focal/universe amd64 c-n-f Metadata [265 kB]
Get:47 http://ca.archive.ubuntu.com/ubuntu focal/multiverse i386 Packages [74.7 kB]
Get:48 http://ca.archive.ubuntu.com/ubuntu focal/multiverse amd64 Packages [144 kB]
Get:49 http://ca.archive.ubuntu.com/ubuntu focal/multiverse Translation-en [104 kB]
Get:50 http://ca.archive.ubuntu.com/ubuntu focal/multiverse amd64 DEP-11 Metadata [48.4 kB]
Get:51 http://ca.archive.ubuntu.com/ubuntu focal/multiverse DEP-11 48x48 Icons [23.1 kB]
Get:52 http://ca.archive.ubuntu.com/ubuntu focal/multiverse DEP-11 64x64 Icons [192 kB]
Get:53 http://ca.archive.ubuntu.com/ubuntu focal/multiverse amd64 c-n-f Metadata [9,136 B]
Get:54 http://ca.archive.ubuntu.com/ubuntu focal-updates/main i386 Packages [443 kB]
Get:55 http://ca.archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [889 kB]
Get:56 http://ca.archive.ubuntu.com/ubuntu focal-updates/main Translation-en [207 kB]
Get:57 http://ca.archive.ubuntu.com/ubuntu focal-updates/main amd64 DEP-11 Metadata [264 kB]
Get:58 http://ca.archive.ubuntu.com/ubuntu focal-updates/main DEP-11 48x48 Icons [55.6 kB]
Get:59 http://ca.archive.ubuntu.com/ubuntu focal-updates/main DEP-11 64x64 Icons [87.9 kB]
Get:60 http://ca.archive.ubuntu.com/ubuntu focal-updates/main amd64 c-n-f Metadata [12.9 kB]
Get:61 http://ca.archive.ubuntu.com/ubuntu focal-updates/restricted i386 Packages [16.2 kB]
Get:62 http://ca.archive.ubuntu.com/ubuntu focal-updates/restricted amd64 Packages [171 kB]
Get:63 http://ca.archive.ubuntu.com/ubuntu focal-updates/restricted Translation-en [25.3 kB]
Get:64 http://ca.archive.ubuntu.com/ubuntu focal-updates/restricted amd64 c-n-f Metadata [436 B]
Get:65 http://ca.archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages [755 kB]
Get:66 http://ca.archive.ubuntu.com/ubuntu focal-updates/universe i386 Packages [560 kB]
Get:67 http://ca.archive.ubuntu.com/ubuntu focal-updates/universe Translation-en [159 kB]
Get:68 http://ca.archive.ubuntu.com/ubuntu focal-updates/universe amd64 DEP-11 Metadata [303 kB]
Get:69 http://ca.archive.ubuntu.com/ubuntu focal-updates/universe DEP-11 48x48 Icons [200 kB]
Get:70 http://ca.archive.ubuntu.com/ubuntu focal-updates/universe DEP-11 64x64 Icons [356 kB]
Get:71 http://ca.archive.ubuntu.com/ubuntu focal-updates/universe amd64 c-n-f Metadata [16.4 kB]
Get:72 http://ca.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 Packages [21.6 kB]
Get:73 http://ca.archive.ubuntu.com/ubuntu focal-updates/multiverse i386 Packages [4,356 B]
Get:74 http://ca.archive.ubuntu.com/ubuntu focal-updates/multiverse Translation-en [5,508 B]
Get:75 http://ca.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 DEP-11 Metadata [2,468 B]
Get:76 http://ca.archive.ubuntu.com/ubuntu focal-updates/multiverse DEP-11 48x48 Icons [29 B]
Get:77 http://ca.archive.ubuntu.com/ubuntu focal-updates/multiverse DEP-11 64x64 Icons [2,638 B]
Get:78 http://ca.archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 c-n-f Metadata [596 B]
Get:79 http://ca.archive.ubuntu.com/ubuntu focal-backports/main amd64 c-n-f Metadata [112 B]
Get:80 http://ca.archive.ubuntu.com/ubuntu focal-backports/restricted amd64 c-n-f Metadata [116 B]
Get:81 http://ca.archive.ubuntu.com/ubuntu focal-backports/universe amd64 Packages [4,032 B]
Get:82 http://ca.archive.ubuntu.com/ubuntu focal-backports/universe i386 Packages [2,932 B]
Get:83 http://ca.archive.ubuntu.com/ubuntu focal-backports/universe Translation-en [1,448 B]
Get:84 http://ca.archive.ubuntu.com/ubuntu focal-backports/universe amd64 DEP-11 Metadata [1,768 B]
Get:85 http://ca.archive.ubuntu.com/ubuntu focal-backports/universe DEP-11 48x48 Icons [2,809 B]
Get:86 http://ca.archive.ubuntu.com/ubuntu focal-backports/universe DEP-11 64x64 Icons [3,944 B]
Get:87 http://ca.archive.ubuntu.com/ubuntu focal-backports/universe amd64 c-n-f Metadata [224 B]
Get:88 http://ca.archive.ubuntu.com/ubuntu focal-backports/multiverse amd64 c-n-f Metadata [116 B]
Fetched 44.2 MB in 0s (0 B/s)

Checking package manager
Reading package lists... Done
Building dependency tree
Reading state information... Done

Calculating the changes

Calculating the changes

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

If none of this applies, then please report this bug using the
command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal. If
you want to investigate this yourself the log files in
'/var/log/dist-upgrade' will contain details about the upgrade.
Specifically, look at 'main.log' and 'apt.log'.

Restoring original system state

Aborting
Reading package lists... Done
Building dependency tree
Reading state information... Done
=== Command detached from window (Wed Mar 24 09:06:50 2021) ===
=== Command terminated with exit status 1 (Wed Mar 24 09:07:00 2021) ===

main.log:

2021-03-24 09:06:02,830 INFO Using config files '['./DistUpgrade.cfg.bionic', '/etc/update-manager/release-upgrades.d/system76-third-party-mirrors.cfg']'
2021-03-24 09:06:02,830 INFO uname information: 'Linux AllansLaptop 5.3.0-7648-generic #41~1586790036~18.04~600aeb5~dev-Ubuntu SMP Mon Apr 13 17:49:24 x86_64'
2021-03-24 09:06:03,184 INFO apt version: '1.6.12ubuntu0.2'
2021-03-24 09:06:03,185 INFO python version: '3.6.9 (default, Jan 26 2021, 15:33:00)
[GCC 8.4.0]'
2021-03-24 09:06:03,188 INFO release-upgrader version '20.04.29' started
2021-03-24 09:06:03,191 INFO locale: 'en_CA' 'UTF-8'
2021-03-24 09:06:03,252 DEBUG Using 'DistUpgradeViewText' view
2021-03-24 09:06:03,288 DEBUG enable dpkg --force-overwrite
2021-03-24 09:06:03,312 DEBUG creating statefile: '/var/log/dist-upgrade/apt-clone_system_state.tar.gz'
2021-03-24 09:06:07,742 DEBUG lsb-release: 'bionic'
2021-03-24 09:06:07,743 DEBUG _pythonSymlinkCheck run
2021-03-24 09:06:07,743 DEBUG openCache()
2021-03-24 09:06:07,743 DEBUG quirks: running PreCacheOpen
2021-03-24 09:06:07,743 DEBUG running Quirks.PreCacheOpen
2021-03-24 09:06:08,636 DEBUG Comparing 5.3.0-7642 with
2021-03-24 09:06:08,636 DEBUG Comparing 5.3.0-7648 with 5.3.0-7642
2021-03-24 09:06:08,847 DEBUG /openCache(), new cache size 102601
2021-03-24 09:06:08,847 DEBUG need_server_mode(): can not find a desktop meta package or key deps, running in server mode
2021-03-24 09:06:08,847 DEBUG checkViewDepends()
2021-03-24 09:06:08,849 DEBUG running doUpdate() (showErrors=False)
2021-03-24 09:06:10,029 DEBUG openCache()
2021-03-24 09:06:10,957 DEBUG Comparing 5.3.0-7642 with
2021-03-24 09:06:10,958 DEBUG Comparing 5.3.0-7648 with 5.3.0-7642
2021-03-24 09:06:11,181 DEBUG /openCache(), new cache size 102601
2021-03-24 09:06:11,181 DEBUG doPostInitialUpdate
2021-03-24 09:06:11,181 DEBUG quirks: running focalPostInitialUpdate
2021-03-24 09:06:11,181 DEBUG running Quirks.focalPostInitialUpdate
2021-03-24 09:06:13,778 DEBUG MetaPkgs:
2021-03-24 09:06:17,764 DEBUG no PkgRecord found for 'appmenu-qt5', skipping
2021-03-24 09:06:18,013 DEBUG no PkgRecord found for 'kerneloops-daemon', skipping
2021-03-24 09:06:18,122 DEBUG no PkgRecord found for 'libdouble-conversion1v5', skipping
2021-03-24 09:06:18,345 DEBUG no PkgRecord found for 'libobasis6.2-core', skipping
2021-03-24 09:06:18,346 DEBUG no PkgRecord found for 'libobasis6.4-core', skipping
2021-03-24 09:06:18,371 DEBUG no PkgRecord found for 'libperl5.22', skipping
2021-03-24 09:06:18,404 DEBUG no PkgRecord found for 'libreoffice-style-colibre', skipping
2021-03-24 09:06:18,405 DEBUG no PkgRecord found for 'libreoffice6.2-debian-menus', skipping
2021-03-24 09:06:18,405 DEBUG no PkgRecord found for 'libreoffice6.4-debian-menus', skipping
2021-03-24 09:06:18,405 DEBUG no PkgRecord found for 'libreofficedev6.2-debian-menus', skipping
2021-03-24 09:06:18,564 DEBUG no PkgRecord found for 'linux-image-5.0.0-21-generic', skipping
2021-03-24 09:06:18,566 DEBUG no PkgRecord found for 'linux-image-5.3.0-20-generic', skipping
2021-03-24 09:06:18,568 DEBUG no PkgRecord found for 'linux-image-5.3.0-7625-generic', skipping
2021-03-24 09:06:18,568 DEBUG no PkgRecord found for 'linux-image-5.3.0-7629-generic', skipping
2021-03-24 09:06:18,591 DEBUG no PkgRecord found for 'linux-modules-5.0.0-21-generic', skipping
2021-03-24 09:06:18,593 DEBUG no PkgRecord found for 'linux-modules-5.3.0-20-generic', skipping
2021-03-24 09:06:18,594 DEBUG no PkgRecord found for 'linux-modules-5.3.0-7625-generic', skipping
2021-03-24 09:06:18,594 DEBUG no PkgRecord found for 'linux-modules-5.3.0-7629-generic', skipping
2021-03-24 09:06:18,601 DEBUG no PkgRecord found for 'linux-modules-extra-5.0.0-21-generic', skipping
2021-03-24 09:06:18,603 DEBUG no PkgRecord found for 'linux-modules-extra-5.3.0-20-generic', skipping
2021-03-24 09:06:18,603 DEBUG no PkgRecord found for 'linux-modules-extra-5.3.0-7625-generic', skipping
2021-03-24 09:06:18,603 DEBUG no PkgRecord found for 'linux-modules-extra-5.3.0-7629-generic', skipping
2021-03-24 09:06:18,645 DEBUG no PkgRecord found for 'lodevbasis6.2-core', skipping
2021-03-24 09:06:18,825 DEBUG no PkgRecord found for 'python3-aptdaemon.pkcompat', skipping
2021-03-24 09:06:18,971 DEBUG no PkgRecord found for 'unetbootin', skipping
2021-03-24 09:06:18,972 DEBUG no PkgRecord found for 'unity-webapps-common', skipping
2021-03-24 09:06:18,972 DEBUG no PkgRecord found for 'unity-webapps-service', skipping
2021-03-24 09:06:18,973 DEBUG no PkgRecord found for 'upstart', skipping
2021-03-24 09:06:18,986 DEBUG no PkgRecord found for 'webbrowser-app', skipping
2021-03-24 09:06:19,023 DEBUG Foreign:
2021-03-24 09:06:19,023 DEBUG Obsolete: adobereader-enu:i386 dbeaver-ce firmware-manager firmware-manager-notify firmware-manager-shared gnome-shell-extension-system76-power hidpi-daemon libegl-dev libgl-dev libgles-dev libglx-dev libnm-gtk-common libnma-common libopengl-dev linux-headers-5.3.0-7642 linux-headers-5.3.0-7642-generic linux-headers-5.3.0-7648 linux-headers-5.3.0-7648-generic linux-image-5.3.0-7642-generic linux-image-5.3.0-7648-generic linux-modules-5.3.0-7642-generic linux-modules-5.3.0-7648-generic linux-modules-extra-5.3.0-7642-generic linux-modules-extra-5.3.0-7648-generic linux-system76 system76-acpi-dkms system76-dkms system76-driver system76-firmware-daemon system76-io-dkms system76-oled system76-power system76-wallpapers zoom
2021-03-24 09:06:19,023 DEBUG updateSourcesList()
2021-03-24 09:06:19,034 DEBUG rewriteSourcesList() with mirror_check
2021-03-24 09:06:19,034 DEBUG ['ubuntu-minimal', 'ubuntu-standard']
2021-03-24 09:06:19,034 DEBUG Checking pkg: ubuntu-minimal
2021-03-24 09:06:19,036 DEBUG Checking pkg: ubuntu-standard
2021-03-24 09:06:19,038 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic main restricted'
2021-03-24 09:06:19,038 DEBUG verifySourcesListEntry: deb http://ca.archive.ubuntu.com/ubuntu/ focal main restricted
2021-03-24 09:06:19,038 DEBUG url_downloadable: http://ca.archive.ubuntu.com/ubuntu//dists/focal/Release
2021-03-24 09:06:19,039 DEBUG s='http' n='ca.archive.ubuntu.com' p='/ubuntu//dists/focal/Release' q='' f=''
2021-03-24 09:06:19,135 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal main restricted' updated to new dist
2021-03-24 09:06:19,135 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic-updates main restricted'
2021-03-24 09:06:19,135 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal-updates main restricted' updated to new dist
2021-03-24 09:06:19,135 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic universe'
2021-03-24 09:06:19,135 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal universe' updated to new dist
2021-03-24 09:06:19,135 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic-updates universe'
2021-03-24 09:06:19,135 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal-updates universe' updated to new dist
2021-03-24 09:06:19,135 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic multiverse'
2021-03-24 09:06:19,135 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal multiverse' updated to new dist
2021-03-24 09:06:19,136 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic-updates multiverse'
2021-03-24 09:06:19,136 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal-updates multiverse' updated to new dist
2021-03-24 09:06:19,136 DEBUG examining: 'deb http://ca.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse'
2021-03-24 09:06:19,136 DEBUG entry 'deb http://ca.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse' updated to new dist
2021-03-24 09:06:19,136 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu bionic-security main restricted'
2021-03-24 09:06:19,136 DEBUG verifySourcesListEntry: deb http://security.ubuntu.com/ubuntu focal main restricted
2021-03-24 09:06:19,136 DEBUG url_downloadable: http://security.ubuntu.com/ubuntu/dists/focal/Release
2021-03-24 09:06:19,136 DEBUG s='http' n='security.ubuntu.com' p='/ubuntu/dists/focal/Release' q='' f=''
2021-03-24 09:06:19,336 DEBUG entry 'deb http://security.ubuntu.com/ubuntu focal-security main restricted' updated to new dist
2021-03-24 09:06:19,336 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu bionic-security universe'
2021-03-24 09:06:19,336 DEBUG entry 'deb http://security.ubuntu.com/ubuntu focal-security universe' updated to new dist
2021-03-24 09:06:19,337 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu bionic-security multiverse'
2021-03-24 09:06:19,337 DEBUG entry 'deb http://security.ubuntu.com/ubuntu focal-security multiverse' updated to new dist
2021-03-24 09:06:19,337 DEBUG examining: 'deb http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu bionic main'
2021-03-24 09:06:19,339 DEBUG entry '# deb http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu focal main # disabled on upgrade to focal' was disabled (unknown mirror)
2021-03-24 09:06:32,750 DEBUG running doUpdate() (showErrors=True)
2021-03-24 09:06:45,520 DEBUG openCache()
2021-03-24 09:06:46,243 DEBUG Comparing 5.3.0-7642 with
2021-03-24 09:06:46,243 DEBUG Comparing 5.3.0-7648 with 5.3.0-7642
2021-03-24 09:06:46,400 DEBUG /openCache(), new cache size 68517
2021-03-24 09:06:46,401 DEBUG need_server_mode(): can not find a desktop meta package or key deps, running in server mode
2021-03-24 09:06:46,401 DEBUG quirks: running PreDistUpgradeCache
2021-03-24 09:06:46,401 DEBUG running Quirks.PreDistUpgradeCache
2021-03-24 09:06:46,401 INFO checking for python-dbg
2021-03-24 09:06:46,401 INFO checking for python-doc
2021-03-24 09:06:46,401 INFO checking for python-minimal
2021-03-24 09:06:46,401 INFO checking for python-dev
2021-03-24 09:06:46,401 INFO checking for libpython-dev
2021-03-24 09:06:46,401 INFO checking for libpython-stdlib
2021-03-24 09:06:46,401 INFO checking for libpython-dbg
2021-03-24 09:06:47,822 DEBUG Installing 'xserver-xorg-video-all' (Distro KeepInstalledPkgs rule)
2021-03-24 09:06:48,017 ERROR Dist-upgrade failed: 'E:Unable to correct problems, you have held broken packages.'
2021-03-24 09:06:48,019 DEBUG abort called
2021-03-24 09:06:48,020 DEBUG openCache()
2021-03-24 09:06:50,423 DEBUG Comparing 5.3.0-7642 with
2021-03-24 09:06:50,423 DEBUG Comparing 5.3.0-7648 with 5.3.0-7642
2021-03-24 09:06:50,642 DEBUG /openCache(), new cache size 102601

apt.log:
Log time: 2021-03-24 09:06:08.843605
Log time: 2021-03-24 09:06:11.167835
Log time: 2021-03-24 09:06:46.382410
  MarkInstall libunity-settings-daemon1:amd64 < 15.04.1+18.04.20180413-0ubuntu1.2 -> 15.04.1+20.04.20200325-0ubuntu1 @ii umU Ib > FU=0
  Installing libgnome-desktop-3-19 as Depends of libunity-settings-daemon1
    MarkInstall libgnome-desktop-3-19:amd64 < none -> 3.36.8-0ubuntu1 @un uN > FU=0
  MarkInstall fdisk:amd64 < 2.31.1-0.4ubuntu3.7 -> 2.34-0.1ubuntu9.1 @ii umU Ib > FU=0
  Installing libncursesw6 as Depends of fdisk
    MarkInstall libncursesw6:amd64 < none -> 6.2-0ubuntu2 @un uN Ib > FU=0
    Installing libtinfo6 as Depends of libncursesw6
      MarkInstall libtinfo6:amd64 < none -> 6.2-0ubuntu2 @un uN > FU=0
  MarkInstall libfltk1.3:amd64 < 1.3.4-6 -> 1.3.4-10build1 @ii umU Ib > FU=0
  Installing libgcc-s1 as Depends of libfltk1.3
    MarkInstall libgcc-s1:amd64 < none -> 10.2.0-5ubuntu1~20.04 @un uN Ib > FU=0
    Installing gcc-10-base as Depends of libgcc-s1
      MarkInstall gcc-10-base:amd64 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
  MarkInstall firebird3.0-server-core:amd64 < 3.0.2.32703.ds4-11ubuntu2 -> 3.0.5.33220.ds4-1build2 @ii umU Ib > FU=0
  Installing libicu66 as Depends of firebird3.0-server-core
    MarkInstall libicu66:amd64 < none -> 66.1-2ubuntu2 @un uN > FU=0
  MarkInstall perl-base:amd64 < 5.26.1-6ubuntu0.5 -> 5.30.0-9ubuntu0.2 @ii umU Ib > FU=0
  Installing libcrypt1 as PreDepends of perl-base
    MarkInstall libcrypt1:amd64 < none -> 1:4.4.10-10ubuntu4 @un uN > FU=0
  MarkInstall audacity:amd64 < 2.2.1-1 -> 2.3.3-1build1 @ii umU Ib > FU=0
  Installing libavcodec58 as Depends of audacity
    MarkInstall libavcodec58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
    Installing libaom0 as Depends of libavcodec58
      MarkInstall libaom0:amd64 < none -> 1.0.0.errata1-3build1 @un uN > FU=0
    Installing libavutil56 as Depends of libavcodec58
      MarkInstall libavutil56:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
    Installing libcodec2-0.9 as Depends of libavcodec58
      MarkInstall libcodec2-0.9:amd64 < none -> 0.9.2-2 @un uN > FU=0
    Installing libswresample3 as Depends of libavcodec58
      MarkInstall libswresample3:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
    Installing libvpx6 as Depends of libavcodec58
      MarkInstall libvpx6:amd64 < none -> 1.8.2-1build1 @un uN > FU=0
    Installing libx264-155 as Depends of libavcodec58
      MarkInstall libx264-155:amd64 < none -> 2:0.155.2917+git0a84d98-2 @un uN > FU=0
    Installing libx265-179 as Depends of libavcodec58
      MarkInstall libx265-179:amd64 < none -> 3.2.1-1build1 @un uN > FU=0
  Installing libavformat58 as Depends of audacity
    MarkInstall libavformat58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
  Installing libwxgtk3.0-gtk3-0v5 as Depends of audacity
    MarkInstall libwxgtk3.0-gtk3-0v5:amd64 < none -> 3.0.4+dfsg-15build1 @un uN > FU=0
  MarkInstall bluez:amd64 < 5.48-0ubuntu3.4 -> 5.53-0ubuntu3 @ii umU Ib > FU=0
  Installing libreadline8 as Depends of bluez
    MarkInstall libreadline8:amd64 < none -> 8.0-4 @un uN > FU=0
  MarkInstall fluidsynth:amd64 < 1.1.9-1 -> 2.1.1-2 @ii umU Ib > FU=0
  Installing libfluidsynth2 as Depends of fluidsynth
    MarkInstall libfluidsynth2:amd64 < none -> 2.1.1-2 @un uN Ib > FU=0
    Installing libinstpatch-1.0-2 as Depends of libfluidsynth2
      MarkInstall libinstpatch-1.0-2:amd64 < none -> 1.1.2-2build1 @un uN > FU=0
  MarkInstall dvdauthor:amd64 < 0.7.0-2build1 -> 0.7.2-1build1 @ii umU Ib > FU=0
  Installing libdvdread7 as Depends of dvdauthor
    MarkInstall libdvdread7:amd64 < none -> 6.1.0+really6.0.2-1 @un uN > FU=0
  MarkInstall gnome-power-manager:amd64 < 3.26.0-1 -> 3.32.0-2 @ii umU Ib > FU=0
  Installing gnome-settings-daemon-common as Depends of gnome-power-manager
    MarkInstall gnome-settings-daemon-common:amd64 < none -> 3.36.1-0ubuntu1 @un uN Ib > FU=0
     Removing: gnome-settings-daemon-schemas
      MarkDelete gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3pop0~1565899898~18.04~a5b17e2~dev @ii mK > FU=0
  MarkInstall python3-dev:amd64 < 3.6.7-1~18.04 -> 3.8.2-0ubuntu2 @ii umU Ib > FU=0
  Installing python3.8-dev as Depends of python3-dev
    MarkInstall python3.8-dev:amd64 < none -> 3.8.5-1~20.04.2 @un uN Ib > FU=0
    Installing python3.8 as Depends of python3.8-dev
      MarkInstall python3.8:amd64 < none -> 3.8.5-1~20.04.2 @un uN Ib > FU=0
      Installing python3.8-minimal as Depends of python3.8
        MarkInstall python3.8-minimal:amd64 < none -> 3.8.5-1~20.04.2 @un uN Ib > FU=0
        Installing libpython3.8-minimal as Depends of python3.8-minimal
          MarkInstall libpython3.8-minimal:amd64 < none -> 3.8.5-1~20.04.2 @un uN IPb > FU=0
          Installing libpython3.8-stdlib as Recommends of libpython3.8-minimal
            MarkInstall libpython3.8-stdlib:amd64 < none -> 3.8.5-1~20.04.2 @un uN Ib > FU=0
            Installing libffi7 as Depends of libpython3.8-stdlib
              MarkInstall libffi7:amd64 < none -> 3.3-4 @un uN > FU=0
    Installing libpython3.8-dev as Depends of python3.8-dev
      MarkInstall libpython3.8-dev:amd64 < none -> 3.8.5-1~20.04.2 @un uN Ib > FU=0
      Installing libpython3.8 as Depends of libpython3.8-dev
        MarkInstall libpython3.8:amd64 < none -> 3.8.5-1~20.04.2 @un uN > FU=0
  MarkInstall vlc-plugin-video-output:amd64 < 3.0.8-0ubuntu18.04.1 -> 3.0.9.2-1 @ii umU Ib > FU=0
  Installing libplacebo7 as Depends of vlc-plugin-video-output
    MarkInstall libplacebo7:amd64 < none -> 1.7.0-2 @un uN > FU=0
  MarkInstall xserver-xorg:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii umU IPb > FU=0
  new important dependency: mesa-vulkan-drivers:amd64
  Installing mesa-vulkan-drivers as Recommends of xserver-xorg
    MarkInstall mesa-vulkan-drivers:amd64 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
    Installing libllvm11 as Depends of mesa-vulkan-drivers
      MarkInstall libllvm11:amd64 < none -> 1:11.0.0-2~ubuntu20.04.1 @un uN > FU=0
  MarkInstall gnome-calendar:amd64 < 3.28.2-0ubuntu0.18.04.1 -> 3.36.2-0ubuntu1 @ii umU Ib > FU=0
  Installing libecal-2.0-1 as Depends of gnome-calendar
    MarkInstall libecal-2.0-1:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
    Installing libedataserver-1.2-24 as Depends of libecal-2.0-1
      MarkInstall libedataserver-1.2-24:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
      Installing libcamel-1.2-62 as Depends of libedataserver-1.2-24
        MarkInstall libcamel-1.2-62:amd64 < none -> 3.36.4-0ubuntu1 @un uN > FU=0
  Installing libgweather-3-16 as Depends of gnome-calendar
    MarkInstall libgweather-3-16:amd64 < none -> 3.36.1-1~ubuntu20.04.1 @un uN > FU=0
  Installing libhandy-0.0-0 as Depends of gnome-calendar
    MarkInstall libhandy-0.0-0:amd64 < none -> 0.0.13-1 @un uN > FU=0
  MarkInstall libkf5texteditor5:amd64 < 5.44.0-0ubuntu2 -> 5.68.0-0ubuntu1 @ii umU Ib > FU=0
  Installing libkf5texteditor-bin as Depends of libkf5texteditor5
    MarkInstall libkf5texteditor-bin:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
    Installing libkf5authcore5 as Depends of libkf5texteditor-bin
      MarkInstall libkf5authcore5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
  Installing libgit2-28 as Depends of libkf5texteditor5
    MarkInstall libgit2-28:amd64 < none -> 0.28.4+dfsg.1-2 @un uN Ib > FU=0
    Installing libhttp-parser2.9 as Depends of libgit2-28
      MarkInstall libhttp-parser2.9:amd64 < none -> 2.9.2-2 @un uN > FU=0
    Installing libmbedcrypto3 as Depends of libgit2-28
      MarkInstall libmbedcrypto3:amd64 < none -> 2.16.4-1ubuntu2 @un uN > FU=0
    Installing libmbedtls12 as Depends of libgit2-28
      MarkInstall libmbedtls12:amd64 < none -> 2.16.4-1ubuntu2 @un uN Ib > FU=0
      Installing libmbedx509-0 as Depends of libmbedtls12
        MarkInstall libmbedx509-0:amd64 < none -> 2.16.4-1ubuntu2 @un uN > FU=0
  MarkInstall libkf5purpose-bin:amd64 < 5.44.0-0ubuntu1 -> 5.68.0-0ubuntu1 @ii umU Ib > FU=0
  Installing qml-module-org-kde-bluezqt as Depends of libkf5purpose-bin
    MarkInstall qml-module-org-kde-bluezqt:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
    Installing libkf5bluezqt6 as Depends of qml-module-org-kde-bluezqt
      MarkInstall libkf5bluezqt6:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
      Installing libkf5bluezqt-data as Depends of libkf5bluezqt6
        MarkInstall libkf5bluezqt-data:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
  MarkInstall aapt:amd64 < 1:8.1.0+r23-3~18.04 -> 1:8.1.0+r23-3build2 @ii umU Ib > FU=0
  Installing libprotobuf-lite17 as Depends of aapt
    MarkInstall libprotobuf-lite17:amd64 < none -> 3.6.1.3-2ubuntu5 @un uN > FU=0
  MarkInstall libatlas3-base:amd64 < 3.10.3-5 -> 3.10.3-8ubuntu7 @ii umU Ib > FU=0
  Installing libgfortran5 as Depends of libatlas3-base
    MarkInstall libgfortran5:amd64 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
  MarkInstall libisofs6:amd64 < 1.4.8-1 -> 1.5.2-1 @ii umU Ib > FU=0
  Installing libjte2 as Depends of libisofs6
    MarkInstall libjte2:amd64 < none -> 1.22-3build1 @un uN > FU=0
  MarkInstall poppler-utils:amd64 < 0.62.0-2ubuntu2.12 -> 0.86.1-0ubuntu1 @ii umU Ib > FU=0
  Installing libpoppler97 as Depends of poppler-utils
    MarkInstall libpoppler97:amd64 < none -> 0.86.1-0ubuntu1 @un uN > FU=0
  MarkInstall libgusb2:amd64 < 0.2.11-1 -> 0.3.4-0.1 @ii umU IPb > FU=0
  new important dependency: usb.ids:amd64
  Installing usb.ids as Recommends of libgusb2
    MarkInstall usb.ids:amd64 < none -> 2020.03.19-1 @un uN > FU=0
  MarkInstall libaa1:amd64 < 1.4p5-44build2 -> 1.4p5-46 @ii umU Ib > FU=0
  Installing libncurses6 as Depends of libaa1
    MarkInstall libncurses6:amd64 < none -> 6.2-0ubuntu2 @un uN > FU=0
  MarkInstall qtdeclarative5-dev:amd64 < 5.9.5-0ubuntu1.1 -> 5.12.8-0ubuntu1 @ii umU Ib > FU=0
  Installing libqt5quickshapes5 as Depends of qtdeclarative5-dev
    MarkInstall libqt5quickshapes5:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
    MarkKeep gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3pop0~1565899898~18.04~a5b17e2~dev @ii mR > FU=0
  MarkInstall uim-data:amd64 < 1:1.8.6+gh20180114.64e3173-2build2 -> 1:1.8.8-6.1build2 @ii umU Ib > FU=0
  Installing libuim-data as Depends of uim-data
    MarkInstall libuim-data:amd64 < none -> 1:1.8.8-6.1build2 @un uN > FU=0
  MarkInstall libvte-2.91-0:amd64 < 0.52.2-1ubuntu1~18.04.2 -> 0.60.3-0ubuntu1~20.04 @ii umU Ib > FU=0
  Installing libpcre2-8-0 as Depends of libvte-2.91-0
    MarkInstall libpcre2-8-0:amd64 < none -> 10.34-7 @un uN > FU=0
  MarkInstall sonnet-plugins:amd64 < 5.44.0-0ubuntu1 -> 5.68.0-0ubuntu1 @ii umU Ib > FU=0
  Installing libhunspell-1.7-0 as Depends of sonnet-plugins
    MarkInstall libhunspell-1.7-0:amd64 < none -> 1.7.0-2build2 @un uN > FU=0
  MarkInstall clang:amd64 < 1:6.0-41~exp5~ubuntu1 -> 1:10.0-50~exp1 @ii umU Ib > FU=0
  Installing clang-10 as Depends of clang
    MarkInstall clang-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN Ib > FU=0
    Installing libclang-cpp10 as Depends of clang-10
      libclang-cpp10:amd64 Depends on libllvm10:amd64 < 1:10.0.1-1~oibaf~b @ii mK > (= 1:10.0.0-4ubuntu1) can't be satisfied!
    Installing libstdc++-9-dev as Depends of clang-10
      MarkInstall libstdc++-9-dev:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN Ib > FU=0
      Installing gcc-9-base as Depends of libstdc++-9-dev
        MarkInstall gcc-9-base:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN > FU=0
      Installing libgcc-9-dev as Depends of libstdc++-9-dev
        MarkInstall libgcc-9-dev:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN Ib > FU=0
        Installing libasan5 as Depends of libgcc-9-dev
          MarkInstall libasan5:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN > FU=0
        Installing libubsan1 as Depends of libgcc-9-dev
          MarkInstall libubsan1:amd64 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
    Installing libobjc-9-dev as Depends of clang-10
      MarkInstall libobjc-9-dev:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN > FU=0
    Installing libclang-common-10-dev as Depends of clang-10
      libclang-common-10-dev:amd64 Depends on libllvm10:amd64 < 1:10.0.1-1~oibaf~b @ii mK > (= 1:10.0.0-4ubuntu1) can't be satisfied!
    Installing libclang1-10 as Depends of clang-10
      MarkInstall libclang1-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN > FU=0
    Installing llvm-10-dev as Recommends of clang-10
      llvm-10-dev:amd64 Depends on libllvm10:amd64 < 1:10.0.1-1~oibaf~b @ii mK > (= 1:10.0.0-4ubuntu1) can't be satisfied!
    Installing libomp-10-dev as Recommends of clang-10
      MarkInstall libomp-10-dev:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN Ib > FU=0
      Installing libomp5-10 as Depends of libomp-10-dev
        MarkInstall libomp5-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN > FU=0
  MarkInstall kdeconnect:amd64 < 1.3.3-0ubuntu0.18.04.1 -> 1.4-0ubuntu5 @ii umU Ib > FU=0
  Installing plasma-framework as Depends of kdeconnect
    MarkInstall plasma-framework:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
    Installing qml-module-org-kde-kconfig as Depends of plasma-framework
      MarkInstall qml-module-org-kde-kconfig:amd64 < none -> 5.68.0-0ubuntu2 @un uN > FU=0
    Installing qml-module-org-kde-kquickcontrols as Depends of plasma-framework
      MarkInstall qml-module-org-kde-kquickcontrols:amd64 < none -> 5.68.0-0ubuntu2 @un uN > FU=0
    Installing libkf5calendarevents5 as Depends of plasma-framework
      MarkInstall libkf5calendarevents5:amd64 < none -> 5.68.0-0ubuntu2 @un uN > FU=0
    Installing libkf5plasma5 as Depends of plasma-framework
      MarkInstall libkf5plasma5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
    Installing libkf5plasmaquick5 as Depends of plasma-framework
      MarkInstall libkf5plasmaquick5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
    Installing libxcb-composite0 as Depends of plasma-framework
      MarkInstall libxcb-composite0:amd64 < none -> 1.14-2 @un uN > FU=0
    Installing libxcb-damage0 as Depends of plasma-framework
      MarkInstall libxcb-damage0:amd64 < none -> 1.14-2 @un uN > FU=0
  Installing qml-module-org-kde-people as Depends of kdeconnect
    MarkInstall qml-module-org-kde-people:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
    Installing libkf5people5 as Depends of qml-module-org-kde-people
      MarkInstall libkf5people5:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
      Installing libkf5people-data as Depends of libkf5people5
        MarkInstall libkf5people-data:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
      Installing libkf5peoplebackend5 as Depends of libkf5people5
        MarkInstall libkf5peoplebackend5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
    Installing libkf5peoplewidgets5 as Depends of qml-module-org-kde-people
      MarkInstall libkf5peoplewidgets5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
  Installing libkf5pulseaudioqt2 as Depends of kdeconnect
    MarkInstall libkf5pulseaudioqt2:amd64 < none -> 1.2-2build1 @un uN > FU=0
  new important dependency: kpeople-vcard:amd64
  Installing kpeople-vcard as Recommends of kdeconnect
    MarkInstall kpeople-vcard:amd64 < none -> 0.1-0ubuntu1 @un uN Ib > FU=0
    Installing libkf5contacts5 as Depends of kpeople-vcard
      MarkInstall libkf5contacts5:amd64 < none -> 5:5.68.0-0ubuntu1 @un uN Ib > FU=0
      Installing libkf5contacts-data as Depends of libkf5contacts5
        MarkInstall libkf5contacts-data:amd64 < none -> 5:5.68.0-0ubuntu1 @un uN > FU=0
  MarkInstall xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
  MarkInstall linux-headers-generic:amd64 < 5.3.0-7648.41~1586790036~18.04~600aeb5~dev -> 5.4.0.70.73 @ii umU Ib > FU=0
  Installing linux-headers-5.4.0-70-generic as Depends of linux-headers-generic
    MarkInstall linux-headers-5.4.0-70-generic:amd64 < none -> 5.4.0-70.78 @un uN Ib > FU=0
    Installing linux-headers-5.4.0-70 as Depends of linux-headers-5.4.0-70-generic
      MarkInstall linux-headers-5.4.0-70:amd64 < none -> 5.4.0-70.78 @un uN > FU=0
  MarkInstall gedit:amd64 < 3.28.1-1ubuntu1.2 -> 3.36.2-0ubuntu1 @ii umU Ib > FU=0
  Installing gir1.2-gtksource-4 as Depends of gedit
    MarkInstall gir1.2-gtksource-4:amd64 < none -> 4.6.0-1 @un uN Ib > FU=0
    Installing libgtksourceview-4-0 as Depends of gir1.2-gtksource-4
      MarkInstall libgtksourceview-4-0:amd64 < none -> 4.6.0-1 @un uN Ib > FU=0
      Installing libgtksourceview-4-common as Depends of libgtksourceview-4-0
        MarkInstall libgtksourceview-4-common:amd64 < none -> 4.6.0-1 @un uN > FU=0
  Installing libamtk-5-0 as Depends of gedit
    MarkInstall libamtk-5-0:amd64 < none -> 5.0.2-1build1 @un uN Ib > FU=0
    Installing libamtk-5-common as Depends of libamtk-5-0
      MarkInstall libamtk-5-common:amd64 < none -> 5.0.2-1build1 @un uN > FU=0
  Installing libgspell-1-2 as Depends of gedit
    MarkInstall libgspell-1-2:amd64 < none -> 1.8.3-1 @un uN Ib > FU=0
    Installing libenchant-2-2 as Depends of libgspell-1-2
      MarkInstall libenchant-2-2:amd64 < none -> 2.2.8-1ubuntu0.20.04.1 @un uN IPb > FU=0
      Installing enchant-2 as Recommends of libenchant-2-2
        MarkInstall enchant-2:amd64 < none -> 2.2.8-1ubuntu0.20.04.1 @un uN > FU=0
  Installing libtepl-4-0 as Depends of gedit
    MarkInstall libtepl-4-0:amd64 < none -> 4.4.0-1 @un uN Ib > FU=0
    Installing libuchardet0 as Depends of libtepl-4-0
      MarkInstall libuchardet0:amd64 < none -> 0.0.6-3build1 @un uN > FU=0
  MarkInstall iptables:amd64 < 1.6.1-2ubuntu2 -> 1.8.4-3ubuntu2 @ii umU Ib > FU=0
  Installing libip4tc2 as Depends of iptables
    MarkInstall libip4tc2:amd64 < none -> 1.8.4-3ubuntu2 @un uN > FU=0
  Installing libip6tc2 as Depends of iptables
    MarkInstall libip6tc2:amd64 < none -> 1.8.4-3ubuntu2 @un uN > FU=0
  Installing libnftnl11 as Depends of iptables
    MarkInstall libnftnl11:amd64 < none -> 1.1.5-1 @un uN > FU=0
  MarkInstall xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
  MarkInstall at:amd64 < 3.1.20-3.1ubuntu2 -> 3.1.23-1ubuntu1 @ii umU Ib > FU=0
  Installing libfl2 as Depends of at
    MarkInstall libfl2:amd64 < none -> 2.6.4-6.2 @un uN > FU=0
  MarkInstall ffmpeg:amd64 < 7:3.4.8-0ubuntu0.2 -> 7:4.2.4-1ubuntu0.1 @ii umU Ib > FU=0
  Installing libavdevice58 as Depends of ffmpeg
    MarkInstall libavdevice58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
    Installing libavfilter7 as Depends of libavdevice58
      MarkInstall libavfilter7:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
      Installing libmysofa1 as Depends of libavfilter7
        MarkInstall libmysofa1:amd64 < none -> 1.0~dfsg0-1 @un uN > FU=0
      Installing libpostproc55 as Depends of libavfilter7
        MarkInstall libpostproc55:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
      Installing libswscale5 as Depends of libavfilter7
        MarkInstall libswscale5:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
      Installing libvidstab1.1 as Depends of libavfilter7
        MarkInstall libvidstab1.1:amd64 < none -> 1.1.0-2 @un uN > FU=0
    Installing libsndio7.0 as Depends of libavdevice58
      MarkInstall libsndio7.0:amd64 < none -> 1.5.0-3 @un uN > FU=0
  Installing libavresample4 as Depends of ffmpeg
    MarkInstall libavresample4:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
  MarkInstall kde-cli-tools:amd64 < 4:5.12.8-0ubuntu0.1 -> 4:5.18.4.1-0ubuntu1 @ii umU Ib > FU=0
  Installing libkworkspace5-5 as Depends of kde-cli-tools
    MarkInstall libkworkspace5-5:amd64 < none -> 4:5.18.5-0ubuntu0.1 @un uN > FU=0
  MarkInstall libevdocument3-4:amd64 < 3.28.4-0ubuntu1.2 -> 3.36.7-0ubuntu1 @ii umU Ib > FU=0
  Installing libsynctex2 as Depends of libevdocument3-4
    MarkInstall libsynctex2:amd64 < none -> 2019.20190605.51237-3build2 @un uN > FU=0
  MarkInstall seq24:amd64 < 0.9.3-2 -> 0.9.3-2build1 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on jackd:amd64
  MarkInstall libhwloc-plugins:amd64 < 1.11.9-1 -> 2.1.0+dfsg-4 @ii ugU Ib > FU=0
  Installing libxnvctrl0 as Depends of libhwloc-plugins
    MarkInstall libxnvctrl0:amd64 < none -> 460.39-0ubuntu0.20.04.1 @un uN > FU=0
  Installing libhwloc15 as Depends of libhwloc-plugins
    MarkInstall libhwloc15:amd64 < none -> 2.1.0+dfsg-4 @un uN > FU=0
  MarkInstall libpam-modules:amd64 < 1.1.8-3.6ubuntu2.18.04.2 -> 1.3.1-5ubuntu4.1 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on update-motd:amd64
  MarkInstall plymouth-themes:amd64 < 0.9.3-1ubuntu7.18.04.2 -> 0.9.4git20200323-0ubuntu6.2 @ii umU Ib > FU=0
  Installing plymouth-theme-spinner as Depends of plymouth-themes
    MarkInstall plymouth-theme-spinner:amd64 < none -> 0.9.4git20200323-0ubuntu6.2 @un uN Ib > FU=0
    Installing libplymouth5 as Depends of plymouth-theme-spinner
      MarkInstall libplymouth5:amd64 < none -> 0.9.4git20200323-0ubuntu6.2 @un uN > FU=0
  MarkInstall sane-utils:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
  Installing libsane as Depends of sane-utils
    MarkInstall libsane:amd64 < none -> 1.0.29-0ubuntu5.2 @un uN Ib > FU=0
    Installing libsnmp35 as Depends of libsane
      MarkInstall libsnmp35:amd64 < none -> 5.8+dfsg-2ubuntu2.3 @un uN Ib > FU=0
      Installing libmysqlclient21 as Depends of libsnmp35
        MarkInstall libmysqlclient21:amd64 < none -> 8.0.23-0ubuntu0.20.04.1 @un uN Ib > FU=0
        Installing mysql-common as Depends of libmysqlclient21
          MarkInstall mysql-common:amd64 < none -> 5.8+1.0.5ubuntu2 @rc uN > FU=0
      Installing libperl5.30 as Depends of libsnmp35
        MarkInstall libperl5.30:amd64 < none -> 5.30.0-9ubuntu0.2 @un uN Ib > FU=0
        Installing libgdbm6 as Depends of libperl5.30
          MarkInstall libgdbm6:amd64 < none -> 1.18.1-5 @un uN > FU=0
        Installing perl-modules-5.30 as Depends of libperl5.30
          MarkInstall perl-modules-5.30:amd64 < none -> 5.30.0-9ubuntu0.2 @un uN > FU=0
      Installing libsensors5 as Depends of libsnmp35
        MarkInstall libsensors5:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib > FU=0
        Installing libsensors-config as Depends of libsensors5
          MarkInstall libsensors-config:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib > FU=0
           Removing: libsensors4
            MarkDelete libsensors4:amd64 < 1:3.4.0-4 @ii mK > FU=0
  MarkInstall libc6-dev:amd64 < 2.27-3ubuntu1.4 -> 2.31-0ubuntu9.2 @ii umU Ib > FU=0
  Installing libcrypt-dev as Depends of libc6-dev
    MarkInstall libcrypt-dev:amd64 < none -> 1:4.4.10-10ubuntu4 @un uN > FU=0
  MarkInstall libargon2-0:amd64 < 0~20161029-1.1 -> 0~20171227-0.2 @ii umU Ib > FU=0
  Installing libargon2-1 as Depends of libargon2-0
    MarkInstall libargon2-1:amd64 < none -> 0~20171227-0.2 @un uN > FU=0
  MarkInstall libopenal1:i386 < 1:1.18.2-2 -> 1:1.19.1-1 @ii umU Ib > FU=0
  Installing libsndio7.0 as Depends of libopenal1
    MarkInstall libsndio7.0:i386 < none -> 1.5.0-3 @un uN > FU=0
  MarkInstall va-driver-all:amd64 < 2.1.0-3 -> 2.7.0-2 @ii umU Ib > FU=0
  Installing intel-media-va-driver as Depends of va-driver-all
    MarkInstall intel-media-va-driver:amd64 < none -> 20.1.1+dfsg1-1 @un uN Ib > FU=0
    Installing libigdgmm11 as Depends of intel-media-va-driver
      MarkInstall libigdgmm11:amd64 < none -> 20.1.1+ds1-1 @un uN > FU=0
  MarkInstall lib32stdc++6:amd64 < 8.4.0-1ubuntu1~18.04 -> 10.2.0-5ubuntu1~20.04 @ii umU Ib > FU=0
  Installing lib32gcc-s1 as Depends of lib32stdc++6
    MarkInstall lib32gcc-s1:amd64 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
  MarkInstall vino:amd64 < 3.22.0-3ubuntu1.2 -> 3.22.0-5ubuntu2.2 @ii umU Ib > FU=0
  Installing libminiupnpc17 as Depends of vino
    MarkInstall libminiupnpc17:amd64 < none -> 2.1.20190824-0ubuntu2 @un uN > FU=0
  MarkInstall ntfs-3g:amd64 < 1:2017.3.23-2ubuntu0.18.04.2 -> 1:2017.3.23AR.3-3ubuntu1 @ii umU Ib > FU=0
  Installing libntfs-3g883 as Depends of ntfs-3g
    MarkInstall libntfs-3g883:amd64 < none -> 1:2017.3.23AR.3-3ubuntu1 @un uN > FU=0
  MarkInstall libcmis-0.5-5v5:amd64 < 0.5.1+git20160603-3build2 -> 0.5.2-1ubuntu1 @ii umU Ib > FU=0
  Installing libboost-date-time1.71.0 as Depends of libcmis-0.5-5v5
    MarkInstall libboost-date-time1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
  MarkInstall fonts-smc:amd64 < 1:7.0 -> 1:7.1 @ii umU Ib > FU=0
  Installing fonts-smc-gayathri as Depends of fonts-smc
    MarkInstall fonts-smc-gayathri:amd64 < none -> 1.100-1 @un uN > FU=0
  MarkInstall linux-image-generic:amd64 < 5.3.0-7648.41~1586790036~18.04~600aeb5~dev -> 5.4.0.70.73 @ii umU Ib > FU=0
  Installing linux-image-5.4.0-70-generic as Depends of linux-image-generic
    MarkInstall linux-image-5.4.0-70-generic:amd64 < none -> 5.4.0-70.78 @un uN Ib > FU=0
    Installing linux-modules-5.4.0-70-generic as Depends of linux-image-5.4.0-70-generic
      MarkInstall linux-modules-5.4.0-70-generic:amd64 < none -> 5.4.0-70.78 @un uN > FU=0
  Installing linux-modules-extra-5.4.0-70-generic as Depends of linux-image-generic
    MarkInstall linux-modules-extra-5.4.0-70-generic:amd64 < none -> 5.4.0-70.78 @un uN > FU=0
  MarkInstall apt:amd64 < 1.6.12ubuntu0.2 -> 2.0.4 @ii umU Ib > FU=0
  Installing libapt-pkg6.0 as Depends of apt
    MarkInstall libapt-pkg6.0:amd64 < none -> 2.0.4 @un uN > FU=0
  MarkInstall python3-markdown:amd64 < 2.6.9-1 -> 3.1.1-3 @ii umU Ib > FU=0
  Installing python3-packaging as Depends of python3-markdown
    MarkInstall python3-packaging:amd64 < none -> 20.3-1 @un uN > FU=0
  MarkInstall libgjs0g:amd64 < 1.52.5-0ubuntu18.04.1 -> 1.64.3-1~ubuntu20.04.1 @ii umU Ib > FU=0
  Installing libmozjs-68-0 as Depends of libgjs0g
    MarkInstall libmozjs-68-0:amd64 < none -> 68.6.0-1ubuntu1 @un uN > FU=0
  MarkInstall libpango1.0-0:amd64 < 1.40.14-1ubuntu0.1 @ii mK Ib > FU=0
  MarkInstall cpp-7:amd64 < 7.5.0-3ubuntu1~18.04 -> 7.5.0-6ubuntu2 @ii umU Ib > FU=0
  Installing libisl22 as Depends of cpp-7
    MarkInstall libisl22:amd64 < none -> 0.22.1-1 @un uN > FU=0
  MarkInstall libasound2-data:amd64 < 1.1.3-5ubuntu0.5 -> 1.2.2-2.1ubuntu2.3 @ii umU IPb > FU=0
  new important dependency: alsa-ucm-conf:amd64
  Installing alsa-ucm-conf as Recommends of libasound2-data
    MarkInstall alsa-ucm-conf:amd64 < none -> 1.2.2-1ubuntu0.5 @un uN > FU=0
  new important dependency: alsa-topology-conf:amd64
  Installing alsa-topology-conf as Recommends of libasound2-data
    MarkInstall alsa-topology-conf:amd64 < none -> 1.2.2-1 @un uN > FU=0
  MarkInstall clang-6.0:amd64 < 1:6.0-1ubuntu2 -> 1:6.0.1-14 @ii umU NPb IPb > FU=0
  new important dependency: python2:amd64
  Installing python2 as Recommends of clang-6.0
    MarkInstall python2:amd64 < none -> 2.7.17-2ubuntu4 @un uN Ib > FU=0
    Installing python2-minimal as PreDepends of python2
      MarkInstall python2-minimal:amd64 < none -> 2.7.17-2ubuntu4 @un uN Ib > FU=0
      Installing python2.7-minimal as Depends of python2-minimal
        MarkInstall python2.7-minimal:amd64 < none -> 2.7.18-1~20.04.1 @un uN Ib > FU=0
        Installing libpython2.7-minimal as Depends of python2.7-minimal
          MarkInstall libpython2.7-minimal:amd64 < none -> 2.7.18-1~20.04.1 @un uN IPb > FU=0
          Installing libpython2.7-stdlib as Recommends of libpython2.7-minimal
            MarkInstall libpython2.7-stdlib:amd64 < none -> 2.7.18-1~20.04.1 @un uN > FU=0
        Installing python2.7 as Recommends of python2.7-minimal
          MarkInstall python2.7:amd64 < none -> 2.7.18-1~20.04.1 @un uN > FU=0
    Installing libpython2-stdlib as Depends of python2
      MarkInstall libpython2-stdlib:amd64 < none -> 2.7.17-2ubuntu4 @un uN > FU=0
  MarkInstall python3-protobuf:amd64 < 3.0.0-9.1ubuntu1 -> 3.6.1.3-2ubuntu5 @ii umU Ib > FU=0
  Installing libprotobuf17 as Depends of python3-protobuf
    MarkInstall libprotobuf17:amd64 < none -> 3.6.1.3-2ubuntu5 @un uN > FU=0
  MarkInstall cpp:amd64 < 4:7.4.0-1ubuntu2.3 -> 4:9.3.0-1ubuntu2 @ii umU Ib > FU=0
  Installing cpp-9 as Depends of cpp
    MarkInstall cpp-9:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN > FU=0
  MarkInstall libqt5organizer5:amd64 < 5.0~git20140515~29475884-0ubuntu24~7 @ii mK Ib > FU=0
  MarkInstall libgpg-error0:amd64 < 1.27-6 -> 1.37-1 @ii umU IPb > FU=0
  new important dependency: libgpg-error-l10n:amd64
  Installing libgpg-error-l10n as Recommends of libgpg-error0
    MarkInstall libgpg-error-l10n:amd64 < none -> 1.37-1 @un uN > FU=0
  MarkInstall systemsettings:amd64 < 4:5.12.8-0ubuntu0.1 -> 4:5.18.4.1-0ubuntu1 @ii umU Ib > FU=0
  Installing libkf5itemmodels5 as Depends of systemsettings
    MarkInstall libkf5itemmodels5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
  MarkInstall bind9-host:amd64 < 1:9.11.3+dfsg-1ubuntu1.14 -> 1:9.16.1-0ubuntu2.7 @ii umU Ib > FU=0
  Installing bind9-libs as Depends of bind9-host
    MarkInstall bind9-libs:amd64 < none -> 1:9.16.1-0ubuntu2.7 @un uN Ib > FU=0
    Installing libjson-c4 as Depends of bind9-libs
      MarkInstall libjson-c4:amd64 < none -> 0.13.1+dfsg-7ubuntu0.3 @un uN > FU=0
    Installing liblmdb0 as Depends of bind9-libs
      MarkInstall liblmdb0:amd64 < none -> 0.9.24-1 @un uN > FU=0
  MarkInstall libarchive13:amd64 < 3.2.2-3.1ubuntu0.6 -> 3.4.0-2ubuntu1 @ii umU Ib > FU=0
  Installing libnettle7 as Depends of libarchive13
    MarkInstall libnettle7:amd64 < none -> 3.5.1+really3.5.1-2 @un uN > FU=0
  MarkInstall e2fsprogs:amd64 < 1.44.1-1ubuntu1.3 -> 1.45.5-2ubuntu1 @ii umU Ib > FU=0
  Installing logsave as Depends of e2fsprogs
    MarkInstall logsave:amd64 < none -> 1.45.5-2ubuntu1 @un uN > FU=0
  MarkInstall kexi:amd64 < 1:3.1.0-2 -> 1:3.2.0-2build1 @ii umU Ib > FU=0
  Installing libkdb3-4abi1 as Depends of kexi
    MarkInstall libkdb3-4abi1:amd64 < none -> 3.2.0-4build2 @un uN > FU=0
  MarkInstall intel-gpu-tools:amd64 < 1.22-1 -> 1.25-2 @ii umU Ib > FU=0
  Installing libprocps8 as Depends of intel-gpu-tools
    MarkInstall libprocps8:amd64 < none -> 2:3.3.16-1ubuntu2 @un uN > FU=0
  MarkInstall dnsutils:amd64 < 1:9.11.3+dfsg-1ubuntu1.14 -> 1:9.16.1-0ubuntu2.7 @ii umU Ib > FU=0
  Installing bind9-dnsutils as Depends of dnsutils
    MarkInstall bind9-dnsutils:amd64 < none -> 1:9.16.1-0ubuntu2.7 @un uN > FU=0
  MarkInstall g++:amd64 < 4:7.4.0-1ubuntu2.3 -> 4:9.3.0-1ubuntu2 @ii umU Ib > FU=0
  Installing g++-9 as Depends of g++
    MarkInstall g++-9:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN Ib > FU=0
    Installing gcc-9 as Depends of g++-9
      MarkInstall gcc-9:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN > FU=0
  MarkInstall eog:amd64 < 3.28.1-1 -> 3.36.3-0ubuntu1 @ii umU Ib > FU=0
  Installing libexempi8 as Depends of eog
    MarkInstall libexempi8:amd64 < none -> 2.5.1-1build1 @un uN > FU=0
  MarkInstall dnsmasq-base:amd64 < 2.79-1ubuntu0.3 -> 2.80-1.1ubuntu1.3 @ii umU Ib > FU=0
  Installing libhogweed5 as Depends of dnsmasq-base
    MarkInstall libhogweed5:amd64 < none -> 3.5.1+really3.5.1-2 @un uN > FU=0
  MarkInstall python3-pyqt4:amd64 < 4.12.1+dfsg-2 @ii mK Ib > FU=0
  MarkInstall python3-brlapi:amd64 < 5.5-4ubuntu2.0.1 -> 6.0+dfsg-4ubuntu6 @ii umU Ib > FU=0
  Installing libbrlapi0.7 as Depends of python3-brlapi
    MarkInstall libbrlapi0.7:amd64 < none -> 6.0+dfsg-4ubuntu6 @un uN > FU=0
  MarkInstall libcdio-cdda2:amd64 < 10.2+0.94+2-2build1 -> 10.2+2.0.0-1 @ii umU Ib > FU=0
  Installing libcdio18 as Depends of libcdio-cdda2
    MarkInstall libcdio18:amd64 < none -> 2.0.0-2 @un uN > FU=0
  MarkInstall python3-pil:amd64 < 5.1.0-1ubuntu0.5 -> 7.0.0-4ubuntu0.3 @ii umU Ib > FU=0
  Installing libimagequant0 as Depends of python3-pil
    MarkInstall libimagequant0:amd64 < none -> 2.12.2-1.1 @un uN > FU=0
  MarkInstall python3-keyring:amd64 < 10.6.0-1 -> 18.0.1-2ubuntu1 @ii umU Ib > FU=0
  Installing python3-entrypoints as Depends of python3-keyring
    MarkInstall python3-entrypoints:amd64 < none -> 0.3-2ubuntu1 @un uN > FU=0
  MarkInstall nodejs:amd64 < 8.10.0~dfsg-2ubuntu0.4 -> 10.19.0~dfsg-3ubuntu1 @ii umU Ib > FU=0
  Installing libnode64 as Depends of nodejs
    MarkInstall libnode64:amd64 < none -> 10.19.0~dfsg-3ubuntu1 @un uN > FU=0
  MarkInstall libc6:i386 < 2.27-3ubuntu1.4 -> 2.31-0ubuntu9.2 @ii umU Ib > FU=0
  Installing libgcc-s1 as Depends of libc6
    MarkInstall libgcc-s1:i386 < none -> 10.2.0-5ubuntu1~20.04 @un uN Ib > FU=0
    Installing gcc-10-base as Depends of libgcc-s1
      MarkInstall gcc-10-base:i386 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
  Installing libcrypt1 as Depends of libc6
    MarkInstall libcrypt1:i386 < none -> 1:4.4.10-10ubuntu4 @un uN > FU=0
  MarkInstall ubuntu-session:amd64 < 3.28.1-0ubuntu3 -> 3.36.0-2ubuntu1 @ii umU Ib > FU=0
  Installing yaru-theme-gnome-shell as Depends of ubuntu-session
    MarkInstall yaru-theme-gnome-shell:amd64 < none -> 20.04.10.1 @un uN > FU=0
  MarkInstall qemu-system-x86:amd64 < 1:2.11+dfsg-1ubuntu7.36 -> 1:4.2-3ubuntu6.14 @ii umU Ib > FU=0
  Installing libpmem1 as Depends of qemu-system-x86
    MarkInstall libpmem1:amd64 < none -> 1.8-1ubuntu1 @un uN > FU=0
  Installing libslirp0 as Depends of qemu-system-x86
    MarkInstall libslirp0:amd64 < none -> 4.1.0-2ubuntu2.1 @un uN > FU=0
  Installing libvirglrenderer1 as Depends of qemu-system-x86
    MarkInstall libvirglrenderer1:amd64 < none -> 0.8.2-1ubuntu1 @un uN > FU=0
  Installing qemu-system-data as Depends of qemu-system-x86
    MarkInstall qemu-system-data:amd64 < none -> 1:4.2-3ubuntu6.14 @un uN > FU=0
  new important dependency: qemu-system-gui:amd64
  Installing qemu-system-gui as Recommends of qemu-system-x86
    MarkInstall qemu-system-gui:amd64 < none -> 1:4.2-3ubuntu6.14 @un uN > FU=0
  new important dependency: ovmf:amd64
  Installing ovmf as Recommends of qemu-system-x86
    MarkInstall ovmf:amd64 < none -> 0~20191122.bd85bf54-2ubuntu3.1 @un uN > FU=0
  MarkInstall libnet-dns-perl:amd64 < 1.10-2 -> 1.22-1 @ii umU IPb > FU=0
  new important dependency: libdigest-bubblebabble-perl:amd64
  Installing libdigest-bubblebabble-perl as Recommends of libnet-dns-perl
    MarkInstall libdigest-bubblebabble-perl:amd64 < none -> 0.02-2 @un uN > FU=0
  new important dependency: libnet-dns-sec-perl:amd64
  Installing libnet-dns-sec-perl as Recommends of libnet-dns-perl
    MarkInstall libnet-dns-sec-perl:amd64 < none -> 1.15-1 @un uN > FU=0
  MarkInstall jackd1:amd64 < 1:0.125.0-3 -> 1:0.125.0-3build2 @ii ugU NPb IPb > FU=0
  ignore old unsatisfied important dependency on qjackctl:amd64
  MarkInstall fluidr3mono-gm-soundfont:amd64 < 2.315-4 -> 2.315-6 @ii umU Ib > FU=0
   Removing: musescore-common
    MarkDelete musescore-common:amd64 < 2.1.0+dfsg3-3build1 @ii mK > FU=0
  MarkInstall dmeventd:amd64 < 2:1.02.145-4.1ubuntu3.18.04.3 -> 2:1.02.167-1ubuntu1 @ii umU Ib > FU=0
  Installing liblvm2cmd2.03 as Depends of dmeventd
    MarkInstall liblvm2cmd2.03:amd64 < none -> 2.03.07-1ubuntu1 @un uN > FU=0
  MarkInstall qtcreator:amd64 < 4.5.2-3ubuntu2 -> 4.11.0-2build2 @ii umU Ib > FU=0
  Installing libclang1-8 as Depends of qtcreator
    MarkInstall libclang1-8:amd64 < none -> 1:8.0.1-9 @un uN Ib > FU=0
    Installing libllvm8 as Depends of libclang1-8
      MarkInstall libllvm8:amd64 < none -> 1:8.0.1-9 @un uN > FU=0
  Installing libqbscore1.13 as Depends of qtcreator
    MarkInstall libqbscore1.13:amd64 < none -> 1.13.1-2build1 @un uN > FU=0
  Installing libqt5serialport5 as Depends of qtcreator
    MarkInstall libqt5serialport5:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
  new important dependency: clang-tidy:amd64
  Installing clang-tidy as Recommends of qtcreator
    MarkInstall clang-tidy:amd64 < none -> 1:10.0-50~exp1 @un uN Ib > FU=0
    Installing clang-tidy-10 as Depends of clang-tidy
      clang-tidy-10:amd64 Depends on libllvm10:amd64 < 1:10.0.1-1~oibaf~b @ii mK > (= 1:10.0.0-4ubuntu1) can't be satisfied!
  MarkInstall musescore:amd64 < 2.1.0+dfsg3-3build1 @ii mK Ib > FU=0
  Installing musescore-common as Depends of musescore
      MarkKeep musescore-common:amd64 < 2.1.0+dfsg3-3build1 @ii mR > FU=0
  MarkInstall indicator-sound:amd64 < 12.10.2+18.04.20180420.3-0ubuntu1 -> 12.10.2+18.10.20180612-0ubuntu1 @ii umU IPb > FU=0
  new important dependency: accountsservice-ubuntu-schemas:amd64
  Installing accountsservice-ubuntu-schemas as Recommends of indicator-sound
    MarkInstall accountsservice-ubuntu-schemas:amd64 < none -> 0.0.7+17.10.20170922-0ubuntu1 @un uN > FU=0
  MarkInstall python3-louis:amd64 < 3.5.0-1ubuntu0.3 -> 3.12.0-3 @ii umU Ib > FU=0
  Installing liblouis20 as Depends of python3-louis
    MarkInstall liblouis20:amd64 < none -> 3.12.0-3 @un uN > FU=0
  MarkInstall lvm2:amd64 < 2.02.176-4.1ubuntu3.18.04.3 -> 2.03.07-1ubuntu1 @ii umU IPb > FU=0
  new important dependency: thin-provisioning-tools:amd64
  Installing thin-provisioning-tools as Recommends of lvm2
    MarkInstall thin-provisioning-tools:amd64 < none -> 0.8.5-4build1 @un uN > FU=0
  MarkInstall libgwenhywfar-data:amd64 < 4.20.0-1 -> 5.1.3-1build1 @ii umU IPb > FU=0
  new important dependency: libgwenhywfar79:amd64
  Installing libgwenhywfar79 as Recommends of libgwenhywfar-data
    MarkInstall libgwenhywfar79:amd64 < none -> 5.1.3-1build1 @un uN > FU=0
  MarkInstall libglib2.0-tests:amd64 < 2.56.4-0ubuntu0.18.04.8 -> 2.64.6-1~ubuntu20.04.3 @ii umU Ib > FU=0
  Installing python3-dbusmock as Depends of libglib2.0-tests
    MarkInstall python3-dbusmock:amd64 < none -> 0.19-1 @un uN > FU=0
  MarkInstall evolution-data-server:amd64 < 3.28.5-0ubuntu0.18.04.3 -> 3.36.4-0ubuntu1 @ii umU Ib > FU=0
  Installing libebook-1.2-20 as Depends of evolution-data-server
    MarkInstall libebook-1.2-20:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
    Installing libebook-contacts-1.2-3 as Depends of libebook-1.2-20
      MarkInstall libebook-contacts-1.2-3:amd64 < none -> 3.36.4-0ubuntu1 @un uN > FU=0
    Installing libedata-book-1.2-26 as Depends of libebook-1.2-20
      MarkInstall libedata-book-1.2-26:amd64 < none -> 3.36.4-0ubuntu1 @un uN > FU=0
  Installing libedata-cal-2.0-1 as Depends of evolution-data-server
    MarkInstall libedata-cal-2.0-1:amd64 < none -> 3.36.4-0ubuntu1 @un uN > FU=0
  MarkInstall unity:amd64 < 7.5.0+18.04.20190304-0ubuntu1 -> 7.5.0+20.04.20200312-0ubuntu1 @ii umU Ib > FU=0
  Installing unity-settings-daemon-schemas as Depends of unity
    MarkInstall unity-settings-daemon-schemas:amd64 < none -> 15.04.1+20.04.20200325-0ubuntu1 @un uN > FU=0
  new important dependency: nemo:amd64
  Installing nemo as Recommends of unity
    MarkInstall nemo:amd64 < none -> 4.4.2-2 @un uN Ib > FU=0
    Installing cinnamon-desktop-data as Depends of nemo
      MarkInstall cinnamon-desktop-data:amd64 < none -> 4.4.1-3 @un uN > FU=0
    Installing libcinnamon-desktop4 as Depends of nemo
      MarkInstall libcinnamon-desktop4:amd64 < none -> 4.4.1-3 @un uN > FU=0
    Installing libnemo-extension1 as Depends of nemo
      MarkInstall libnemo-extension1:amd64 < none -> 4.4.2-2 @un uN > FU=0
    Installing libxapp1 as Depends of nemo
      MarkInstall libxapp1:amd64 < none -> 1.6.10-2 @un uN Ib > FU=0
      Installing xapps-common as Depends of libxapp1
        MarkInstall xapps-common:amd64 < none -> 1.6.10-2 @un uN IPb > FU=0
        Installing gist as Recommends of xapps-common
          MarkInstall gist:amd64 < none -> 5.0.0-4 @un uN Ib > FU=0
          Installing ruby-json as Depends of gist
            MarkInstall ruby-json:amd64 < none -> 2.3.0+dfsg-1build1 @un uN Ib > FU=0
            Installing libruby2.7 as Depends of ruby-json
              MarkInstall libruby2.7:amd64 < none -> 2.7.0-5ubuntu1.3 @un uN Ib > FU=0
              Installing ruby-xmlrpc as Depends of libruby2.7
                MarkInstall ruby-xmlrpc:amd64 < none -> 0.3.0-2 @un uN > FU=0
        Installing inxi as Recommends of xapps-common
          MarkInstall inxi:amd64 < none -> 3.0.38-1-0ubuntu1 @rc uN IPb > FU=0
          Installing hddtemp as Recommends of inxi
            MarkInstall hddtemp:amd64 < none -> 0.3-beta15-53 @rc uN > FU=0
    Installing nemo-data as Depends of nemo
      MarkInstall nemo-data:amd64 < none -> 4.4.2-2 @un uN > FU=0
    Installing cinnamon-l10n as Recommends of nemo
      MarkInstall cinnamon-l10n:amd64 < none -> 4.4.2-2 @un uN > FU=0
    Installing gvfs-backends as Recommends of nemo
      MarkInstall gvfs-backends:amd64 < none -> 1.44.1-1ubuntu1 @un uN Ib > FU=0
      Installing libnfs13 as Depends of gvfs-backends
        MarkInstall libnfs13:amd64 < none -> 4.0.0-1 @un uN > FU=0
      Installing libsmbclient as Depends of gvfs-backends
        MarkInstall libsmbclient:amd64 < none -> 2:4.11.6+dfsg-0ubuntu1.6 @un uN Ib > FU=0
        Installing samba-libs as Depends of libsmbclient
          MarkInstall samba-libs:amd64 < none -> 2:4.11.6+dfsg-0ubuntu1.6 @un uN Ib > FU=0
          Installing libldb2 as Depends of samba-libs
            MarkInstall libldb2:amd64 < none -> 2:2.0.10-0ubuntu0.20.04.2 @un uN Ib > FU=0
             Removing: libldb1
              MarkDelete libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mK > FU=0
          Installing python3-talloc as Depends of samba-libs
            MarkInstall python3-talloc:amd64 < none -> 2.3.0-3ubuntu1 @un uN > FU=0
    Installing nemo-fileroller as Recommends of nemo
      MarkInstall nemo-fileroller:amd64 < none -> 4.4.0-2 @un uN > FU=0
  MarkInstall alsa-utils:amd64 < 1.1.3-1ubuntu1 -> 1.2.2-1ubuntu2 @ii umU Ib > FU=0
  Installing libatopology2 as Depends of alsa-utils
    MarkInstall libatopology2:amd64 < none -> 1.2.2-2.1ubuntu2.3 @un uN > FU=0
  MarkInstall libmediainfo0v5:amd64 < 17.12-1ubuntu0.1 -> 19.09+dfsg-2build1 @ii umU Ib > FU=0
  Installing libtinyxml2-6a as Depends of libmediainfo0v5
    MarkInstall libtinyxml2-6a:amd64 < none -> 7.0.0+dfsg-1build1 @un uN Ib > FU=0
     Removing: libtinyxml2-6
      MarkDelete libtinyxml2-6:amd64 < 6.0.0+dfsg-1 @ii mK > FU=0
  MarkInstall libvoikko1:amd64 < 4.1.1-1.1 -> 4.3-1build1 @ii umU Ib > FU=0
  Installing libhfstospell10 as Depends of libvoikko1
    MarkInstall libhfstospell10:amd64 < none -> 0.5.0-2build2 @un uN Ib > FU=0
     Removing: libhfstospell9
      MarkDelete libhfstospell9:amd64 < 0.4.5~r343-2.1build2 @ii mK Ib > FU=0
  MarkInstall anthy-common:amd64 < 1:0.3-6ubuntu1 -> 1:0.4-2 @ii umU IPb > FU=0
  new important dependency: kasumi:amd64
  Installing kasumi as Recommends of anthy-common
    MarkInstall kasumi:amd64 < none -> 2.5-9build1 @un uN IPb > FU=0
    Installing anthy as Recommends of kasumi
      MarkInstall anthy:amd64 < none -> 1:0.4-2 @un uN Ib > FU=0
      Installing libanthyinput0 as Depends of anthy
        MarkInstall libanthyinput0:amd64 < none -> 1:0.4-2 @un uN > FU=0
  MarkInstall gdm3:amd64 < 3.28.3-0ubuntu18.04.6 -> 3.36.3-0ubuntu0.20.04.3 @ii umU IPb > FU=0
  new important dependency: libpam-fprintd:amd64
  Installing libpam-fprintd as Recommends of gdm3
    MarkInstall libpam-fprintd:amd64 < none -> 1.90.1-1ubuntu1 @un uN Ib > FU=0
    Installing fprintd as Depends of libpam-fprintd
      MarkInstall fprintd:amd64 < none -> 1.90.1-1ubuntu1 @un uN Ib > FU=0
      Installing libfprint-2-2 as Depends of fprintd
        MarkInstall libfprint-2-2:amd64 < none -> 1:1.90.2+tod1-0ubuntu1~20.04.4 @un uN > FU=0
  MarkInstall libwmf0.2-7:amd64 < 0.2.8.4-12 -> 0.2.8.4-17ubuntu1 @ii umU IPb > FU=0
  new important dependency: fonts-urw-base35:amd64
  Installing fonts-urw-base35 as Recommends of libwmf0.2-7
    MarkInstall fonts-urw-base35:amd64 < none -> 20170801.1-3 @un uN > FU=0
  MarkInstall dkms:amd64 < 2.3-3ubuntu9.7 -> 2.8.1-5ubuntu2 @ii umU Ib > FU=0
  Installing dctrl-tools as Depends of dkms
    MarkInstall dctrl-tools:amd64 < none -> 2.24-3 @rc uN > FU=0
  MarkInstall libkf5bookmarks5:amd64 < 5.44.0-0ubuntu1 -> 5.68.0-0ubuntu1 @ii umU IPb > FU=0
  new important dependency: keditbookmarks:amd64
  Installing keditbookmarks as Recommends of libkf5bookmarks5
    MarkInstall keditbookmarks:amd64 < none -> 19.12.3-0ubuntu1 @un uN Ib > FU=0
    Installing libkf5kiogui5 as Depends of keditbookmarks
      MarkInstall libkf5kiogui5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
  MarkInstall libsvn1:amd64 < 1.9.7-4ubuntu1 -> 1.13.0-3 @ii umU Ib > FU=0
  Installing libutf8proc2 as Depends of libsvn1
    MarkInstall libutf8proc2:amd64 < none -> 2.5.0-1 @un uN > FU=0
  MarkInstall libgexiv2-2:amd64 < 0.10.8-1 -> 0.12.0-2 @ii umU Ib > FU=0
  Installing libexiv2-27 as Depends of libgexiv2-2
    MarkInstall libexiv2-27:amd64 < none -> 0.27.2-8ubuntu2 @un uN > FU=0
  MarkInstall dh-strip-nondeterminism:amd64 < 0.040-1.1~build1 -> 1.7.0-1 @ii umU Ib > FU=0
  Installing libdebhelper-perl as Depends of dh-strip-nondeterminism
    MarkInstall libdebhelper-perl:amd64 < none -> 12.10ubuntu1 @un uN > FU=0
  MarkInstall libfile-stripnondeterminism-perl:amd64 < 0.040-1.1~build1 -> 1.7.0-1 @ii umU Ib > FU=0
  Installing libsub-override-perl as Depends of libfile-stripnondeterminism-perl
    MarkInstall libsub-override-perl:amd64 < none -> 0.09-2 @un uN > FU=0
  MarkInstall libgcc1:amd64 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib > FU=0
   Removing: libgcc1
    MarkDelete libgcc1:i386 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib > FU=0
  MarkInstall libgcc1:i386 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib > FU=0
   Removing: libgcc1
    MarkDelete libgcc1:amd64 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib > FU=0
  MarkInstall gnome-tweaks:amd64 < 3.28.1-1 -> 3.34.0-2ubuntu1 @ii umU Ib > FU=0
  Installing gir1.2-handy-0.0 as Depends of gnome-tweaks
    MarkInstall gir1.2-handy-0.0:amd64 < none -> 0.0.13-1 @un uN > FU=0
  Installing gnome-shell-extension-prefs as Depends of gnome-tweaks
    MarkInstall gnome-shell-extension-prefs:amd64 < none -> 3.36.4-1ubuntu1~20.04.2 @un uN IPb > FU=0
    Installing chrome-gnome-shell as Recommends of gnome-shell-extension-prefs
      MarkInstall chrome-gnome-shell:amd64 < none -> 10.1-5 @un uN > FU=0
  MarkInstall qt5-doc:amd64 < 5.9.5-0ubuntu1 -> 5.12.8-0ubuntu1 @ii umU Ib > FU=0
  Installing qtdatavisualization5-doc as Depends of qt5-doc
    MarkInstall qtdatavisualization5-doc:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
  Installing qtnetworkauth5-doc as Depends of qt5-doc
    MarkInstall qtnetworkauth5-doc:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
  Installing qtscxml5-doc as Depends of qt5-doc
    MarkInstall qtscxml5-doc:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
  Installing qtserialbus5-doc as Depends of qt5-doc
    MarkInstall qtserialbus5-doc:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
  Installing qtvirtualkeyboard5-doc as Depends of qt5-doc
    MarkInstall qtvirtualkeyboard5-doc:amd64 < none -> 5.12.8+dfsg-0ubuntu1 @un uN > FU=0
  MarkInstall libfontconfig1-dev:amd64 < 2.12.6-0ubuntu2 -> 2.13.1-2ubuntu3 @ii umU Ib > FU=0
  Installing uuid-dev as Depends of libfontconfig1-dev
    MarkInstall uuid-dev:amd64 < none -> 2.34-0.1ubuntu9.1 @un uN > FU=0
  MarkInstall deja-dup:amd64 < 37.1-2fakesync1ubuntu0.1 -> 40.7-0ubuntu1 @ii umU NPb Ib > FU=0
  Installing duplicity as Depends of deja-dup
    MarkInstall duplicity:amd64 < none -> 0.8.11.1612-1 @un uN Ib > FU=0
    Installing librsync2 as Depends of duplicity
      MarkInstall librsync2:amd64 < none -> 2.0.2-1ubuntu1 @un uN > FU=0
    Installing python3-fasteners as Depends of duplicity
      MarkInstall python3-fasteners:amd64 < none -> 0.14.1-2 @un uN Ib > FU=0
      Installing python3-monotonic as Depends of python3-fasteners
        MarkInstall python3-monotonic:amd64 < none -> 1.5-0ubuntu2 @un uN > FU=0
    Installing python3-future as Depends of duplicity
      MarkInstall python3-future:amd64 < none -> 0.18.2-2 @un uN > FU=0
    Installing python3-lockfile as Depends of duplicity
      MarkInstall python3-lockfile:amd64 < none -> 1:0.12.2-2ubuntu2 @un uN > FU=0
    Installing python3-paramiko as Recommends of duplicity
      MarkInstall python3-paramiko:amd64 < none -> 2.6.0-2 @un uN Ib > FU=0
      Installing python3-bcrypt as Depends of python3-paramiko
        MarkInstall python3-bcrypt:amd64 < none -> 3.1.7-2ubuntu1 @un uN > FU=0
  MarkInstall python3-dbus.mainloop.qt:amd64 < 4.12.1+dfsg-2 @ii mK Ib > FU=0
  MarkInstall libcairo-perl:amd64 < 1.106-2build2 -> 1.107-1 @ii umU Ib > FU=0
  Installing libextutils-depends-perl as Depends of libcairo-perl
    MarkInstall libextutils-depends-perl:amd64 < none -> 0.8000-1 @un uN > FU=0
  Installing libextutils-pkgconfig-perl as Depends of libcairo-perl
    MarkInstall libextutils-pkgconfig-perl:amd64 < none -> 1.16-1 @un uN > FU=0
  MarkInstall aisleriot:amd64 < 1:3.22.5-1 -> 1:3.22.9-1 @ii umU Ib > FU=0
  Installing guile-2.2-libs as Depends of aisleriot
    MarkInstall guile-2.2-libs:amd64 < none -> 2.2.7+1-4 @un uN > FU=0
  MarkInstall flamerobin:amd64 < 0.9.3~+20160512.c75f8618-2 -> 0.9.3~+20160512.c75f8618-3build1 @ii umU Ib > FU=0
  Installing libboost-thread1.71.0 as Depends of flamerobin
    MarkInstall libboost-thread1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
  MarkInstall binutils-x86-64-linux-gnu:amd64 < 2.30-21ubuntu1~18.04.5 -> 2.34-6ubuntu1.1 @ii umU Ib > FU=0
  Installing libctf-nobfd0 as Depends of binutils-x86-64-linux-gnu
    MarkInstall libctf-nobfd0:amd64 < none -> 2.34-6ubuntu1.1 @un uN > FU=0
  Installing libctf0 as Depends of binutils-x86-64-linux-gnu
    MarkInstall libctf0:amd64 < none -> 2.34-6ubuntu1.1 @un uN > FU=0
  MarkInstall fonts-noto:amd64 < 20171026-2 -> 20200323-1build1~ubuntu20.04.1 @ii ugU Ib > FU=0
  Installing fonts-noto-core as Depends of fonts-noto
    MarkInstall fonts-noto-core:amd64 < none -> 20200323-1build1~ubuntu20.04.1 @un uN > FU=0
  new important dependency: fonts-noto-cjk-extra:amd64
  Installing fonts-noto-cjk-extra as Recommends of fonts-noto
    MarkInstall fonts-noto-cjk-extra:amd64 < none -> 1:20190410+repack1-2 @un uN > FU=0
  new important dependency: fonts-noto-extra:amd64
  Installing fonts-noto-extra as Recommends of fonts-noto
    MarkInstall fonts-noto-extra:amd64 < none -> 20200323-1build1~ubuntu20.04.1 @un uN > FU=0
  new important dependency: fonts-noto-ui-core:amd64
  Installing fonts-noto-ui-core as Recommends of fonts-noto
    MarkInstall fonts-noto-ui-core:amd64 < none -> 20200323-1build1~ubuntu20.04.1 @un uN > FU=0
  new important dependency: fonts-noto-ui-extra:amd64
  Installing fonts-noto-ui-extra as Recommends of fonts-noto
    MarkInstall fonts-noto-ui-extra:amd64 < none -> 20200323-1build1~ubuntu20.04.1 @un uN > FU=0
  MarkInstall libpango1.0-dev:amd64 < 1.40.14-1ubuntu0.1 -> 1.44.7-2ubuntu4 @ii umU Ib > FU=0
  Installing libfribidi-dev as Depends of libpango1.0-dev
    MarkInstall libfribidi-dev:amd64 < none -> 1.0.8-2 @un uN > FU=0
  Installing libthai-dev as Depends of libpango1.0-dev
    MarkInstall libthai-dev:amd64 < none -> 0.1.28-3 @un uN Ib > FU=0
    Installing libdatrie-dev as Depends of libthai-dev
      MarkInstall libdatrie-dev:amd64 < none -> 0.2.12-3 @un uN > FU=0
  Installing pango1.0-tools as Depends of libpango1.0-dev
    MarkInstall pango1.0-tools:amd64 < none -> 1.44.7-2ubuntu4 @un uN > FU=0
  MarkInstall libgps-dev:amd64 < 3.17-5 -> 3.20-8ubuntu0.2 @ii umU Ib > FU=0
  Installing libgps26 as Depends of libgps-dev
    MarkInstall libgps26:amd64 < none -> 3.20-8ubuntu0.2 @un uN > FU=0
  MarkInstall libboost-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Installing libboost1.71-dev as Depends of libboost-dev
    MarkInstall libboost1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
     Removing: libboost1.65-dev
      MarkDelete libboost1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK > FU=0
  MarkInstall libboost-test1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii gK Ib > FU=0
  Installing libboost1.65-dev as Depends of libboost-test1.65-dev
      MarkKeep libboost1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mR > FU=0
  MarkInstall dpkg:amd64 < 1.19.0.5ubuntu2.3 -> 1.19.7ubuntu3 @ii umU Ib > FU=0
   Removing: libapt-pkg5.0
    MarkDelete libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mK > FU=0
  MarkInstall cups-filters:amd64 < 1.20.2-0ubuntu3.1 -> 1.27.4-1 @ii umU Ib > FU=0
  Installing libqpdf26 as Depends of cups-filters
    MarkInstall libqpdf26:amd64 < none -> 9.1.1-1build1 @un uN > FU=0
  MarkInstall libsane1:i386 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
  Installing libsane as Depends of libsane1
    MarkInstall libsane:i386 < none -> 1.0.29-0ubuntu5.2 @un uN Ib > FU=0
    Installing libcurl3-gnutls as Depends of libsane
      MarkInstall libcurl3-gnutls:i386 < none -> 7.68.0-1ubuntu2.4 @un uN Ib > FU=0
      Installing libbrotli1 as Depends of libcurl3-gnutls
        MarkInstall libbrotli1:i386 < none -> 1.0.7-6ubuntu0.1 @un uN > FU=0
      Installing libnettle7 as Depends of libcurl3-gnutls
        MarkInstall libnettle7:i386 < none -> 3.5.1+really3.5.1-2 @un uN > FU=0
      Installing libnghttp2-14 as Depends of libcurl3-gnutls
        MarkInstall libnghttp2-14:i386 < none -> 1.40.0-1build1 @un uN > FU=0
      Installing libpsl5 as Depends of libcurl3-gnutls
        MarkInstall libpsl5:i386 < none -> 0.21.0-1ubuntu1 @un uN > FU=0
      Installing librtmp1 as Depends of libcurl3-gnutls
        MarkInstall librtmp1:i386 < none -> 2.4+20151223.gitfa8646d.1-2build1 @un uN Ib > FU=0
        Installing libhogweed5 as Depends of librtmp1
          MarkInstall libhogweed5:i386 < none -> 3.5.1+really3.5.1-2 @un uN > FU=0
      Installing libssh-4 as Depends of libcurl3-gnutls
        MarkInstall libssh-4:i386 < none -> 0.9.3-2ubuntu2.1 @un uN > FU=0
    Installing libsnmp35 as Depends of libsane
      MarkInstall libsnmp35:i386 < none -> 5.8+dfsg-2ubuntu2.3 @un uN Ib > FU=0
      Installing libmysqlclient21 as Depends of libsnmp35
        MarkInstall libmysqlclient21:i386 < none -> 8.0.23-0ubuntu0.20.04.1 @un uN > FU=0
      Installing libpci3 as Depends of libsnmp35
        MarkInstall libpci3:i386 < none -> 1:3.6.4-1 @un uN Ib > FU=0
        Installing pci.ids as Depends of libpci3
          MarkInstall pci.ids:amd64 < none -> 0.0~2020.03.20-1 @un uN > FU=0
      Installing libperl5.30 as Depends of libsnmp35
        MarkInstall libperl5.30:i386 < none -> 5.30.0-9ubuntu0.2 @un uN Ib > FU=0
        Installing libbz2-1.0 as Depends of libperl5.30
          MarkInstall libbz2-1.0:i386 < none -> 1.0.8-2 @un uN > FU=0
        Installing libgdbm-compat4 as Depends of libperl5.30
          MarkInstall libgdbm-compat4:i386 < none -> 1.18.1-5 @un uN Ib > FU=0
          Installing libgdbm6 as Depends of libgdbm-compat4
            MarkInstall libgdbm6:i386 < none -> 1.18.1-5 @un uN > FU=0
      Installing libsensors5 as Depends of libsnmp35
        MarkInstall libsensors5:i386 < none -> 1:3.6.0-2ubuntu1 @un uN > FU=0
  MarkInstall imagemagick-6.q16:amd64 < 8:6.9.7.4+dfsg-16ubuntu6.9 -> 8:6.9.10.23+dfsg-2.1ubuntu11.2 @ii umU Ib > FU=0
  Installing libmagickcore-6.q16-6 as Depends of imagemagick-6.q16
    MarkInstall libmagickcore-6.q16-6:amd64 < none -> 8:6.9.10.23+dfsg-2.1ubuntu11.2 @un uN > FU=0
  Installing libmagickwand-6.q16-6 as Depends of imagemagick-6.q16
    MarkInstall libmagickwand-6.q16-6:amd64 < none -> 8:6.9.10.23+dfsg-2.1ubuntu11.2 @un uN > FU=0
  new important dependency: libmagickcore-6.q16-6-extra:amd64
  Installing libmagickcore-6.q16-6-extra as Recommends of imagemagick-6.q16
    MarkInstall libmagickcore-6.q16-6-extra:amd64 < none -> 8:6.9.10.23+dfsg-2.1ubuntu11.2 @un uN Ib > FU=0
    Installing libopenexr24 as Depends of libmagickcore-6.q16-6-extra
      MarkInstall libopenexr24:amd64 < none -> 2.3.0-6ubuntu0.3 @un uN Ib > FU=0
      Installing libilmbase24 as Depends of libopenexr24
        MarkInstall libilmbase24:amd64 < none -> 2.3.0-6build1 @un uN > FU=0
  MarkInstall libtiff5:i386 < 4.0.9-5ubuntu0.4 -> 4.1.0+git191117-2ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libzstd1 as Depends of libtiff5
    MarkInstall libzstd1:i386 < none -> 1.4.4+dfsg-3ubuntu0.1 @un uN > FU=0
  MarkInstall libqt5gui5:amd64 < 5.9.5+dfsg-0ubuntu2.5 -> 5.12.8+dfsg-0ubuntu1 @ii umU Ib > FU=0
  Installing libxcb-xinput0 as Depends of libqt5gui5
    MarkInstall libxcb-xinput0:amd64 < none -> 1.14-2 @un uN > FU=0
  MarkInstall libsnmp30:amd64 < 5.7.3+dfsg-1.8ubuntu3.6 @ii mK Ib > FU=0
  Installing libsensors4 as Depends of libsnmp30
      MarkKeep libsensors4:amd64 < 1:3.4.0-4 @ii mR > FU=0
  MarkInstall wireshark-common:amd64 < 2.6.10-1~ubuntu18.04.0 -> 3.2.3-1 @ii umU Ib > FU=0
  Installing libwireshark13 as Depends of wireshark-common
    MarkInstall libwireshark13:amd64 < none -> 3.2.3-1 @un uN Ib > FU=0
    Installing libwiretap10 as Depends of libwireshark13
      MarkInstall libwiretap10:amd64 < none -> 3.2.3-1 @un uN Ib > FU=0
      Installing libwsutil11 as Depends of libwiretap10
        MarkInstall libwsutil11:amd64 < none -> 3.2.3-1 @un uN > FU=0
  MarkInstall libfile-mimeinfo-perl:amd64 < 0.28-1 -> 0.29-1 @ii umU IPb > FU=0
  new important dependency: libio-stringy-perl:amd64
  Installing libio-stringy-perl as Recommends of libfile-mimeinfo-perl
    MarkInstall libio-stringy-perl:amd64 < none -> 2.111-3 @un uN > FU=0
  MarkInstall libfabric1:amd64 < 1.5.3-1 -> 1.6.2-3 @ii ugU Ib > FU=0
  Installing libpsm2-2 as Depends of libfabric1
    MarkInstall libpsm2-2:amd64 < none -> 11.2.86-1 @un uN > FU=0
  MarkInstall okular:amd64 < 4:17.12.3-0ubuntu1 -> 4:19.12.3-2ubuntu1 @ii umU Ib > FU=0
  Installing libokular5core9 as Depends of okular
    MarkInstall libokular5core9:amd64 < none -> 4:19.12.3-2ubuntu1 @un uN > FU=0
  new important dependency: okular-extra-backends:amd64
  Installing okular-extra-backends as Recommends of okular
    MarkInstall okular-extra-backends:amd64 < none -> 4:19.12.3-2ubuntu1 @un uN Ib > FU=0
    Installing libchm1 as Depends of okular-extra-backends
      MarkInstall libchm1:amd64 < none -> 2:0.40a-5 @un uN > FU=0
    Installing libepub0 as Depends of okular-extra-backends
      MarkInstall libepub0:amd64 < none -> 0.2.2-4ubuntu2 @un uN Ib > FU=0
      Installing libzip5 as Depends of libepub0
        MarkInstall libzip5:amd64 < none -> 1.5.1-0ubuntu1 @un uN > FU=0
  MarkInstall nautilus:amd64 < 1:3.26.4-0~ubuntu18.04.5 -> 1:3.36.3-0ubuntu1 @ii umU NPb Ib > FU=0
  Installing tracker as Depends of nautilus
    MarkInstall tracker:amd64 < none -> 2.3.6-0ubuntu1 @un uN Ib > FU=0
    Installing libtracker-control-2.0-0 as Depends of tracker
      MarkInstall libtracker-control-2.0-0:amd64 < none -> 2.3.6-0ubuntu1 @un uN > FU=0
    Installing tracker-miner-fs as Recommends of tracker
      MarkInstall tracker-miner-fs:amd64 < none -> 2.3.3-2 @un uN Ib > FU=0
      Installing libtracker-miner-2.0-0 as Depends of tracker-miner-fs
        MarkInstall libtracker-miner-2.0-0:amd64 < none -> 2.3.6-0ubuntu1 @un uN > FU=0
      Installing tracker-extract as Depends of tracker-miner-fs
        MarkInstall tracker-extract:amd64 < none -> 2.3.3-2 @un uN Ib > FU=0
        Installing libcue2 as Depends of tracker-extract
          MarkInstall libcue2:amd64 < none -> 2.2.1-2 @un uN > FU=0
        Installing libgsf-1-114 as Depends of tracker-extract
          MarkInstall libgsf-1-114:amd64 < none -> 1.14.46-1 @un uN Ib > FU=0
          Installing libgsf-1-common as Depends of libgsf-1-114
            MarkInstall libgsf-1-common:amd64 < none -> 1.14.46-1 @un uN > FU=0
  MarkInstall libxenstore3.0:amd64 < 4.9.2-0ubuntu1 -> 4.11.3+24-g14b62ab3e5-1ubuntu2 @ii umU Ib > FU=0
  Installing libxentoolcore1 as Depends of libxenstore3.0
    MarkInstall libxentoolcore1:amd64 < none -> 4.11.3+24-g14b62ab3e5-1ubuntu2 @un uN > FU=0
  MarkInstall libcupsmime1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
  MarkInstall libimobiledevice6:amd64 < 1.2.1~git20171128.5a854327+dfsg-0.1 -> 1.2.1~git20191129.9f79242-1build1 @ii umU Ib > FU=0
  Installing libusbmuxd6 as Depends of libimobiledevice6
    MarkInstall libusbmuxd6:amd64 < none -> 2.0.1-2 @un uN > FU=0
  MarkInstall firebird3.0-examples:amd64 < 3.0.2.32703.ds4-11ubuntu2 -> 3.0.5.33220.ds4-1build2 @ii umU NPb IPb > FU=0
  MarkInstall libavcodec-extra:amd64 < 7:3.4.8-0ubuntu0.2 -> 7:4.2.4-1ubuntu0.1 @ii umU Ib > FU=0
  Installing libavcodec-extra58 as Depends of libavcodec-extra
    MarkInstall libavcodec-extra58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
     Removing: libavcodec58
      MarkDelete libavcodec58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
  MarkInstall ruby:amd64 < 1:2.5.1 -> 1:2.7+1 @ii umU Ib > FU=0
  Installing ruby2.7 as Depends of ruby
    MarkInstall ruby2.7:amd64 < none -> 2.7.0-5ubuntu1.3 @un uN > FU=0
  MarkInstall libmirclient9:amd64 < 0.31.1-0ubuntu1 -> 1.7.1-0ubuntu2 @ii umU Ib > FU=0
  Installing libcapnp-0.7.0 as Depends of libmirclient9
    MarkInstall libcapnp-0.7.0:amd64 < none -> 0.7.0-6 @un uN > FU=0
  MarkInstall libfreetype6-dev:amd64 < 2.8.1-2ubuntu2.1 -> 2.10.1-2ubuntu0.1 @ii umU Ib > FU=0
  Installing libfreetype-dev as Depends of libfreetype6-dev
    MarkInstall libfreetype-dev:amd64 < none -> 2.10.1-2ubuntu0.1 @un uN > FU=0
  MarkInstall libvirt-daemon-system:amd64 < 4.0.0-1ubuntu8.19 -> 6.0.0-0ubuntu8.8 @ii umU Ib > FU=0
  Installing libvirt-daemon-system-systemd as Depends of libvirt-daemon-system
    MarkInstall libvirt-daemon-system-systemd:amd64 < none -> 6.0.0-0ubuntu8.8 @un uN Ib > FU=0
    Installing systemd-container as Depends of libvirt-daemon-system-systemd
      MarkInstall systemd-container:amd64 < none -> 245.4-4ubuntu3.5 @un uN IPb > FU=0
      Installing libnss-mymachines as Recommends of systemd-container
        MarkInstall libnss-mymachines:amd64 < none -> 245.4-4ubuntu3.5 @un uN > FU=0
  MarkInstall xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mK Ib > FU=0
  MarkInstall libcap2-bin:amd64 < 1:2.25-1.2 -> 1:2.32-1 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on libpam-cap:amd64
  MarkInstall tor:amd64 < 0.3.2.10-1 -> 0.4.2.7-1 @ii umU Ib > FU=0
  Installing libevent-2.1-7 as Depends of tor
    MarkInstall libevent-2.1-7:amd64 < none -> 2.1.11-stable-1 @un uN > FU=0
  MarkInstall libical-dev:amd64 < 3.0.1-5 -> 3.0.8-1 @ii umU Ib > FU=0
  Installing gir1.2-ical-3.0 as Depends of libical-dev
    MarkInstall gir1.2-ical-3.0:amd64 < none -> 3.0.8-1 @un uN > FU=0
  MarkInstall acpi-support:amd64 < 0.142 -> 0.143 @ii umU NPb IPb > FU=0
  MarkInstall libqbscore1.10:amd64 < 1.10.1+dfsg-1 @ii mK Ib > FU=0
    MarkKeep libhfstospell9:amd64 < 0.4.5~r343-2.1build2 @ii mR > FU=0
  MarkInstall fonts-gujr:amd64 < 2:1.2 -> 2:1.3 @ii umU Ib > FU=0
  Installing fonts-yrsa-rasa as Depends of fonts-gujr
    MarkInstall fonts-yrsa-rasa:amd64 < none -> 1.002-2 @un uN > FU=0
  MarkInstall printer-driver-gutenprint:amd64 < 5.2.13-2 -> 5.3.3-4 @ii umU Ib > FU=0
  Installing libgutenprint9 as Depends of printer-driver-gutenprint
    MarkInstall libgutenprint9:amd64 < none -> 5.3.3-4 @un uN Ib > FU=0
    Installing libgutenprint-common as Depends of libgutenprint9
      MarkInstall libgutenprint-common:amd64 < none -> 5.3.3-4 @un uN > FU=0
  MarkInstall lintian:amd64 < 2.5.81ubuntu1 -> 2.62.0 @ii umU Ib > FU=0
  Installing libcapture-tiny-perl as Depends of lintian
    MarkInstall libcapture-tiny-perl:amd64 < none -> 0.48-1 @un uN > FU=0
  Installing libclass-xsaccessor-perl as Depends of lintian
    MarkInstall libclass-xsaccessor-perl:amd64 < none -> 1.19-3build3 @un uN > FU=0
  Installing libcpanel-json-xs-perl as Depends of lintian
    MarkInstall libcpanel-json-xs-perl:amd64 < none -> 4.19-1build1 @un uN > FU=0
  Installing libdevel-size-perl as Depends of lintian
    MarkInstall libdevel-size-perl:amd64 < none -> 0.83-1build1 @un uN > FU=0
  Installing libfile-find-rule-perl as Depends of lintian
    MarkInstall libfile-find-rule-perl:amd64 < none -> 0.34-1 @un uN Ib > FU=0
    Installing libnumber-compare-perl as Depends of libfile-find-rule-perl
      MarkInstall libnumber-compare-perl:amd64 < none -> 0.03-1 @un uN > FU=0
    Installing libtext-glob-perl as Depends of libfile-find-rule-perl
      MarkInstall libtext-glob-perl:amd64 < none -> 0.10-1 @un uN > FU=0
  Installing libfont-ttf-perl as Depends of lintian
    MarkInstall libfont-ttf-perl:amd64 < none -> 1.06-1 @un uN > FU=0
  Installing libio-async-perl as Depends of lintian
    MarkInstall libio-async-perl:amd64 < none -> 0.75-1 @un uN Ib > FU=0
    Installing libfuture-perl as Depends of libio-async-perl
      MarkInstall libfuture-perl:amd64 < none -> 0.43-1 @un uN > FU=0
    Installing libstruct-dumb-perl as Depends of libio-async-perl
      MarkInstall libstruct-dumb-perl:amd64 < none -> 0.09-1 @un uN > FU=0
    Installing libasync-mergepoint-perl as Recommends of libio-async-perl
      MarkInstall libasync-mergepoint-perl:amd64 < none -> 0.04-2 @un uN > FU=0
    Installing libsereal-perl as Recommends of libio-async-perl
      MarkInstall libsereal-perl:amd64 < none -> 4.011-1 @un uN Ib > FU=0
      Installing libsereal-decoder-perl as Depends of libsereal-perl
        MarkInstall libsereal-decoder-perl:amd64 < none -> 4.011+ds-1build1 @un uN > FU=0
      Installing libsereal-encoder-perl as Depends of libsereal-perl
        MarkInstall libsereal-encoder-perl:amd64 < none -> 4.011+ds-1build1 @un uN > FU=0
    Installing libtest-fatal-perl as Recommends of libio-async-perl
      MarkInstall libtest-fatal-perl:amd64 < none -> 0.014-1 @un uN > FU=0
    Installing libtest-refcount-perl as Recommends of libio-async-perl
      MarkInstall libtest-refcount-perl:amd64 < none -> 0.10-1 @un uN > FU=0
  Installing libio-async-loop-epoll-perl as Depends of lintian
    MarkInstall libio-async-loop-epoll-perl:amd64 < none -> 0.20-1 @un uN Ib > FU=0
    Installing liblinux-epoll-perl as Depends of libio-async-loop-epoll-perl
      MarkInstall liblinux-epoll-perl:amd64 < none -> 0.017-1 @un uN > FU=0
  Installing libjson-maybexs-perl as Depends of lintian
    MarkInstall libjson-maybexs-perl:amd64 < none -> 1.004000-1 @un uN > FU=0
  Installing liblist-compare-perl as Depends of lintian
    MarkInstall liblist-compare-perl:amd64 < none -> 0.53-1 @un uN > FU=0
  Installing libmoo-perl as Depends of lintian
    MarkInstall libmoo-perl:amd64 < none -> 2.003006-1 @un uN Ib > FU=0
    Installing libclass-method-modifiers-perl as Depends of libmoo-perl
      MarkInstall libclass-method-modifiers-perl:amd64 < none -> 2.13-1 @un uN > FU=0
    Installing libimport-into-perl as Depends of libmoo-perl
      MarkInstall libimport-into-perl:amd64 < none -> 1.002005-1 @un uN Ib > FU=0
      Installing libmodule-runtime-perl as Depends of libimport-into-perl
        MarkInstall libmodule-runtime-perl:amd64 < none -> 0.016-1 @un uN Ib > FU=0
        Installing libparams-classify-perl as Depends of libmodule-runtime-perl
          MarkInstall libparams-classify-perl:amd64 < none -> 0.015-1build2 @un uN Ib > FU=0
          Installing libdevel-callchecker-perl as Depends of libparams-classify-perl
            MarkInstall libdevel-callchecker-perl:amd64 < none -> 0.008-1ubuntu1 @un uN Ib > FU=0
            Installing libb-hooks-op-check-perl as Depends of libdevel-callchecker-perl
              MarkInstall libb-hooks-op-check-perl:amd64 < none -> 0.22-1build2 @un uN > FU=0
            Installing libdynaloader-functions-perl as Depends of libdevel-callchecker-perl
              MarkInstall libdynaloader-functions-perl:amd64 < none -> 0.003-1 @un uN > FU=0
    Installing librole-tiny-perl as Depends of libmoo-perl
      MarkInstall librole-tiny-perl:amd64 < none -> 2.001004-1 @un uN > FU=0
    Installing libstrictures-perl as Depends of libmoo-perl
      MarkInstall libstrictures-perl:amd64 < none -> 2.000006-1 @un uN > FU=0
    Installing libsub-quote-perl as Depends of libmoo-perl
      MarkInstall libsub-quote-perl:amd64 < none -> 2.006006-1 @un uN > FU=0
  Installing libmoox-aliases-perl as Depends of lintian
    MarkInstall libmoox-aliases-perl:amd64 < none -> 0.001006-1 @un uN > FU=0
  Installing libnamespace-clean-perl as Depends of lintian
    MarkInstall libnamespace-clean-perl:amd64 < none -> 0.27-1 @un uN Ib > FU=0
    Installing libb-hooks-endofscope-perl as Depends of libnamespace-clean-perl
      MarkInstall libb-hooks-endofscope-perl:amd64 < none -> 0.24-1 @un uN Ib > FU=0
      Installing libmodule-implementation-perl as Depends of libb-hooks-endofscope-perl
        MarkInstall libmodule-implementation-perl:amd64 < none -> 0.09-1 @un uN > FU=0
      Installing libsub-exporter-progressive-perl as Depends of libb-hooks-endofscope-perl
        MarkInstall libsub-exporter-progressive-perl:amd64 < none -> 0.001013-1 @un uN > FU=0
      Installing libvariable-magic-perl as Depends of libb-hooks-endofscope-perl
        MarkInstall libvariable-magic-perl:amd64 < none -> 0.62-1build2 @un uN > FU=0
    Installing libpackage-stash-perl as Depends of libnamespace-clean-perl
      MarkInstall libpackage-stash-perl:amd64 < none -> 0.38-1 @un uN IPb > FU=0
      Installing libpackage-stash-xs-perl as Recommends of libpackage-stash-perl
        MarkInstall libpackage-stash-xs-perl:amd64 < none -> 0.29-1build1 @un uN > FU=0
    Installing libsub-identify-perl as Depends of libnamespace-clean-perl
      MarkInstall libsub-identify-perl:amd64 < none -> 0.14-1build2 @un uN > FU=0
  Installing libpath-tiny-perl as Depends of lintian
    MarkInstall libpath-tiny-perl:amd64 < none -> 0.108-1 @un uN IPb > FU=0
    Installing libunicode-utf8-perl as Recommends of libpath-tiny-perl
      MarkInstall libunicode-utf8-perl:amd64 < none -> 0.62-1build1 @un uN > FU=0
  Installing libtype-tiny-perl as Depends of lintian
    MarkInstall libtype-tiny-perl:amd64 < none -> 1.008001-2 @un uN IPb > FU=0
    Installing libref-util-perl as Recommends of libtype-tiny-perl
      MarkInstall libref-util-perl:amd64 < none -> 0.204-1 @un uN IPb > FU=0
      Installing libreadonly-perl as Recommends of libref-util-perl
        MarkInstall libreadonly-perl:amd64 < none -> 2.050-2 @un uN > FU=0
      Installing libref-util-xs-perl as Recommends of libref-util-perl
        MarkInstall libref-util-xs-perl:amd64 < none -> 0.117-1build2 @un uN > FU=0
    Installing libtype-tiny-xs-perl as Recommends of libtype-tiny-perl
      MarkInstall libtype-tiny-xs-perl:amd64 < none -> 0.016-1 @un uN > FU=0
  Installing libxml-writer-perl as Depends of lintian
    MarkInstall libxml-writer-perl:amd64 < none -> 0.625-1 @un uN > FU=0
  MarkInstall brltty:amd64 < 5.5-4ubuntu2.0.1 -> 6.0+dfsg-4ubuntu6 @ii umU Ib > FU=0
  Installing libpcre2-32-0 as Depends of brltty
    MarkInstall libpcre2-32-0:amd64 < none -> 10.34-7 @un uN > FU=0
  MarkInstall wine-stable:amd64 < 3.0-1ubuntu1 -> 3.0.1ubuntu1 @ii umU Ib > FU=0
  Installing wine as Depends of wine-stable
    MarkInstall wine:amd64 < none -> 5.0-3ubuntu1 @un uN > FU=0
  MarkInstall libselinux1:i386 < 2.7-2build2 -> 3.0-1build2 @ii umU Ib > FU=0
  Installing libpcre2-8-0 as Depends of libselinux1
    MarkInstall libpcre2-8-0:i386 < none -> 10.34-7 @un uN > FU=0
  MarkInstall libncurses5-dev:amd64 < 6.1-1ubuntu1.18.04 -> 6.2-0ubuntu2 @ii umU Ib > FU=0
  Installing libncurses-dev as Depends of libncurses5-dev
    MarkInstall libncurses-dev:amd64 < none -> 6.2-0ubuntu2 @un uN > FU=0
  MarkInstall vlc:amd64 < 3.0.8-0ubuntu18.04.1 -> 3.0.9.2-1 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on vlc-plugin-samba:amd64
  MarkInstall libglib2.0-dev:amd64 < 2.56.4-0ubuntu0.18.04.8 -> 2.64.6-1~ubuntu20.04.3 @ii umU Ib > FU=0
  Installing libmount-dev as Depends of libglib2.0-dev
    MarkInstall libmount-dev:amd64 < none -> 2.34-0.1ubuntu9.1 @un uN Ib > FU=0
    Installing libblkid-dev as Depends of libmount-dev
      MarkInstall libblkid-dev:amd64 < none -> 2.34-0.1ubuntu9.1 @un uN > FU=0
  Installing libselinux1-dev as Depends of libglib2.0-dev
    MarkInstall libselinux1-dev:amd64 < none -> 3.0-1build2 @un uN Ib > FU=0
    Installing libsepol1-dev as Depends of libselinux1-dev
      MarkInstall libsepol1-dev:amd64 < none -> 3.0-1 @un uN > FU=0
    Installing libpcre2-dev as Depends of libselinux1-dev
      MarkInstall libpcre2-dev:amd64 < none -> 10.34-7 @un uN Ib > FU=0
      Installing libpcre2-16-0 as Depends of libpcre2-dev
        MarkInstall libpcre2-16-0:amd64 < none -> 10.34-7 @un uN > FU=0
      Installing libpcre2-posix2 as Depends of libpcre2-dev
        MarkInstall libpcre2-posix2:amd64 < none -> 10.34-7 @un uN > FU=0
  MarkInstall systemd:amd64 < 237-3ubuntu10.45 -> 245.4-4ubuntu3.5 @ii umU Ib > FU=0
  Installing systemd-timesyncd as Depends of systemd
    MarkInstall systemd-timesyncd:amd64 < none -> 245.4-4ubuntu3.5 @un uN > FU=0
  MarkInstall libwebkit2gtk-4.0-37:amd64 < 2.30.5-0ubuntu0.18.04.1 -> 2.30.5-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing xdg-dbus-proxy as Depends of libwebkit2gtk-4.0-37
    MarkInstall xdg-dbus-proxy:amd64 < none -> 0.1.2-1 @un uN > FU=0
  MarkInstall gnome-online-accounts:amd64 < 3.28.0-0ubuntu2.1 -> 3.36.0-1ubuntu1 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on gnome-control-center:amd64
  MarkInstall libqt5core5a:amd64 < 5.9.5+dfsg-0ubuntu2.5 -> 5.12.8+dfsg-0ubuntu1 @ii umU Ib > FU=0
  Installing libdouble-conversion3 as Depends of libqt5core5a
    MarkInstall libdouble-conversion3:amd64 < none -> 3.1.5-4ubuntu1 @un uN > FU=0
   Removing: libqtcore4
    MarkDelete libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK > FU=0
  MarkInstall shotwell:amd64 < 0.28.4-0ubuntu2 -> 0.30.10-0ubuntu0.1 @ii umU Ib > FU=0
  Installing libraw19 as Depends of shotwell
    MarkInstall libraw19:amd64 < none -> 0.19.5-1ubuntu1 @un uN > FU=0
  MarkInstall libpolkit-backend-1-0:amd64 < 0.105-20ubuntu0.18.04.5 @ii mK Ib > FU=0
  MarkInstall debhelper:amd64 < 11.1.6ubuntu2 -> 12.10ubuntu1 @ii umU Ib > FU=0
  Installing dwz as Depends of debhelper
    MarkInstall dwz:amd64 < none -> 0.13-5 @un uN > FU=0
  MarkInstall xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
  MarkInstall openssh-client:amd64 < 1:7.6p1-4ubuntu0.3 -> 1:8.2p1-4ubuntu0.2 @ii umU Ib > FU=0
  Installing libfido2-1 as Depends of openssh-client
    MarkInstall libfido2-1:amd64 < none -> 1.3.1-1ubuntu2 @un uN Ib > FU=0
    Installing libcbor0.6 as Depends of libfido2-1
      MarkInstall libcbor0.6:amd64 < none -> 0.6.0-0ubuntu1 @un uN > FU=0
  MarkInstall libqt4-sql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
  Installing libqtcore4 as Depends of libqt4-sql
      MarkKeep libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > FU=0
  MarkInstall liblouisutdml-bin:amd64 < 2.7.0-1 -> 2.8.0-3 @ii umU Ib > FU=0
  Installing liblouisutdml9 as Depends of liblouisutdml-bin
    MarkInstall liblouisutdml9:amd64 < none -> 2.8.0-3 @un uN > FU=0
  MarkInstall libphonon4qt5-4:amd64 < 4:4.10.0-2 -> 4:4.11.1-3build1 @ii umU Ib > FU=0
  Installing libphonon4qt5-data as Depends of libphonon4qt5-4
    MarkInstall libphonon4qt5-data:amd64 < none -> 4:4.11.1-3build1 @un uN > FU=0
  MarkInstall qtbase5-dev:amd64 < 5.9.5+dfsg-0ubuntu2.5 -> 5.12.8+dfsg-0ubuntu1 @ii umU Ib > FU=0
  Installing libvulkan-dev as Depends of qtbase5-dev
    MarkInstall libvulkan-dev:amd64 < none -> 1.2.131.2-1 @un uN > FU=0
  MarkInstall libept1.5.0:amd64 < 1.1+nmu3build1 @ii mK Ib > FU=0
  Installing libapt-pkg5.0 as Depends of libept1.5.0
      MarkKeep libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mR > FU=0
  MarkInstall cups-filters-core-drivers:amd64 < 1.20.2-0ubuntu3.1 -> 1.27.4-1 @ii umU Ib > FU=0
  Installing libpoppler-cpp0v5 as Depends of cups-filters-core-drivers
    MarkInstall libpoppler-cpp0v5:amd64 < none -> 0.86.1-0ubuntu1 @un uN > FU=0
  MarkInstall ibus:amd64 < 1.5.17-3ubuntu5.3 -> 1.5.22-2ubuntu2.1 @ii umU Ib > FU=0
  Installing ibus-data as Depends of ibus
    MarkInstall ibus-data:amd64 < none -> 1.5.22-2ubuntu2.1 @un uN > FU=0
  Installing python3-ibus-1.0 as Depends of ibus
    MarkInstall python3-ibus-1.0:amd64 < none -> 1.5.22-2ubuntu2.1 @un uN > FU=0
  MarkInstall xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
  MarkInstall libxml2:i386 < 2.9.4+dfsg1-6.1ubuntu1.3 -> 2.9.10+dfsg-5 @ii umU Ib > FU=0
  Installing libicu66 as Depends of libxml2
    MarkInstall libicu66:i386 < none -> 66.1-2ubuntu2 @un uN > FU=0
  MarkInstall libgimp2.0:amd64 < 2.8.22-1 -> 2.10.18-1 @ii umU Ib > FU=0
  Installing libbabl-0.1-0 as Depends of libgimp2.0
    MarkInstall libbabl-0.1-0:amd64 < none -> 0.1.74-1 @un uN > FU=0
  Installing libgegl-0.4-0 as Depends of libgimp2.0
    MarkInstall libgegl-0.4-0:amd64 < none -> 0.4.22-3 @un uN Ib > FU=0
    Installing libumfpack5 as Depends of libgegl-0.4-0
      MarkInstall libumfpack5:amd64 < none -> 1:5.7.1+dfsg-2 @un uN Ib > FU=0
      Installing libamd2 as Depends of libumfpack5
        MarkInstall libamd2:amd64 < none -> 1:5.7.1+dfsg-2 @un uN > FU=0
      Installing libcholmod3 as Depends of libumfpack5
        MarkInstall libcholmod3:amd64 < none -> 1:5.7.1+dfsg-2 @un uN Ib > FU=0
        Installing libcamd2 as Depends of libcholmod3
          MarkInstall libcamd2:amd64 < none -> 1:5.7.1+dfsg-2 @un uN > FU=0
        Installing libccolamd2 as Depends of libcholmod3
          MarkInstall libccolamd2:amd64 < none -> 1:5.7.1+dfsg-2 @un uN > FU=0
        Installing libmetis5 as Depends of libcholmod3
          MarkInstall libmetis5:amd64 < none -> 5.1.0.dfsg-5 @un uN > FU=0
    Installing libgegl-common as Depends of libgegl-0.4-0
      MarkInstall libgegl-common:amd64 < none -> 0.4.22-3 @un uN > FU=0
  MarkInstall ubuntu-wallpapers:amd64 < 18.04.1-0ubuntu1 -> 20.04.2-0ubuntu1 @ii umU Ib > FU=0
  Installing ubuntu-wallpapers-focal as Depends of ubuntu-wallpapers
    MarkInstall ubuntu-wallpapers-focal:amd64 < none -> 20.04.2-0ubuntu1 @un uN > FU=0
  MarkInstall libcupsppdc1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
  MarkInstall texlive-binaries:amd64 < 2017.20170613.44572-8ubuntu0.1 -> 2019.20190605.51237-3build2 @ii ugU Ib > FU=0
  Installing libtexlua53 as Depends of texlive-binaries
    MarkInstall libtexlua53:amd64 < none -> 2019.20190605.51237-3build2 @un uN > FU=0
  Installing libteckit0 as Depends of texlive-binaries
    MarkInstall libteckit0:amd64 < none -> 2.5.8+ds2-5ubuntu2 @un uN > FU=0
  new important dependency: dvisvgm:amd64
  Installing dvisvgm as Recommends of texlive-binaries
    MarkInstall dvisvgm:amd64 < none -> 2.8.1-1build1 @un uN > FU=0
  MarkInstall fwupd:amd64 < 1.2.10-1ubuntu2~ubuntu18.04.5 -> 1.3.11-1~focal1 @ii umU NPb Ib > FU=0
  Installing libfwupdplugin1 as Depends of fwupd
    MarkInstall libfwupdplugin1:amd64 < none -> 1.3.11-1~focal1 @un uN > FU=0
  Installing libtss2-esys0 as Depends of fwupd
    MarkInstall libtss2-esys0:amd64 < none -> 2.3.2-1 @un uN Ib > FU=0
    Installing tpm-udev as Depends of libtss2-esys0
      MarkInstall tpm-udev:amd64 < none -> 0.4 @un uN > FU=0
  ignore old unsatisfied important dependency on fwupd-signed:amd64
  MarkInstall libmono-system-security4.0-cil:amd64 < 4.6.2.7+dfsg-1ubuntu1 -> 6.8.0.105+dfsg-2 @ii umU IPb > FU=0
  new important dependency: libmono-btls-interface4.0-cil:amd64
  Installing libmono-btls-interface4.0-cil as Recommends of libmono-system-security4.0-cil
    MarkInstall libmono-btls-interface4.0-cil:amd64 < none -> 6.8.0.105+dfsg-2 @un uN > FU=0
  MarkInstall libedata-book-1.2-25:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib > FU=0
  MarkInstall unity-settings-daemon:amd64 < 15.04.1+18.04.20180413-0ubuntu1.2 -> 15.04.1+20.04.20200325-0ubuntu1 @ii umU NPb IPb > FU=0
  MarkInstall libp11-kit0:i386 < 0.23.9-2ubuntu0.1 -> 0.23.20-1ubuntu0.1 @ii umU Ib > FU=0
  Installing libffi7 as Depends of libp11-kit0
    MarkInstall libffi7:i386 < none -> 3.3-4 @un uN > FU=0
  MarkInstall gnome-shell:amd64 < 3.28.4-0ubuntu18.04.3 -> 3.36.4-1ubuntu1~20.04.2 @ii umU NPb Ib > FU=0
  Installing gir1.2-mutter-6 as Depends of gnome-shell
    MarkInstall gir1.2-mutter-6:amd64 < none -> 3.36.7+git20201123-0.20.04.1 @un uN Ib > FU=0
    Installing libmutter-6-0 as Depends of gir1.2-mutter-6
      MarkInstall libmutter-6-0:amd64 < none -> 3.36.7+git20201123-0.20.04.1 @un uN > FU=0
    Installing gir1.2-graphene-1.0 as Depends of gir1.2-mutter-6
      MarkInstall gir1.2-graphene-1.0:amd64 < none -> 1.10.0-1build2 @un uN > FU=0
  ignore old unsatisfied important dependency on gnome-control-center:amd64
  new important dependency: switcheroo-control:amd64
  Installing switcheroo-control as Recommends of gnome-shell
    MarkInstall switcheroo-control:amd64 < none -> 2.1-1 @un uN > FU=0
  MarkInstall libedata-cal-1.2-28:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib > FU=0
  MarkInstall indicator-appmenu:amd64 < 15.02.0+16.10.20160927-0ubuntu3 -> 15.02.0+16.10.20160927-0ubuntu5 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on unity-gtk2-module:amd64
  ignore old unsatisfied important dependency on unity-gtk3-module:amd64
  MarkInstall rosegarden:amd64 < 1:17.12.1-1 -> 1:19.12-1build1 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on jackd:amd64
  ignore old unsatisfied important dependency on lilypond:amd64
  MarkInstall gparted:amd64 < 0.30.0-3ubuntu2 -> 1.0.0-0.1build1 @ii umU Ib > FU=0
  Installing gparted-common as Depends of gparted
    MarkInstall gparted-common:amd64 < none -> 1.0.0-0.1build1 @un uN > FU=0
  MarkInstall qttools5-dev-tools:amd64 < 5.9.5-0ubuntu1 -> 5.12.8-0ubuntu1 @ii umU Ib > FU=0
  Installing qdoc-qt5 as Depends of qttools5-dev-tools
    MarkInstall qdoc-qt5:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
  Installing qhelpgenerator-qt5 as Depends of qttools5-dev-tools
    MarkInstall qhelpgenerator-qt5:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
  Installing qtattributionsscanner-qt5 as Depends of qttools5-dev-tools
    MarkInstall qtattributionsscanner-qt5:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
  MarkInstall vlc-plugin-base:amd64 < 3.0.8-0ubuntu18.04.1 -> 3.0.9.2-1 @ii umU Ib > FU=0
  Installing libixml10 as Depends of vlc-plugin-base
    MarkInstall libixml10:amd64 < none -> 1:1.8.4-2ubuntu2 @un uN > FU=0
  Installing liblivemedia77 as Depends of vlc-plugin-base
    MarkInstall liblivemedia77:amd64 < none -> 2020.01.19-1build1 @un uN > FU=0
  Installing libspatialaudio0 as Depends of vlc-plugin-base
    MarkInstall libspatialaudio0:amd64 < none -> 0.3.0+git20180730+dfsg1-2build1 @un uN > FU=0
  Installing libsrt1 as Depends of vlc-plugin-base
    MarkInstall libsrt1:amd64 < none -> 1.4.0-1build1 @un uN > FU=0
  Installing libupnp13 as Depends of vlc-plugin-base
    MarkInstall libupnp13:amd64 < none -> 1:1.8.4-2ubuntu2 @un uN > FU=0
    MarkKeep libtinyxml2-6:amd64 < 6.0.0+dfsg-1 @ii mR > FU=0
  MarkInstall synaptic:amd64 < 0.84.3ubuntu1 -> 0.84.6ubuntu5 @ii umU Ib > FU=0
  Installing libept1.6.0 as Depends of synaptic
    MarkInstall libept1.6.0:amd64 < none -> 1.1+nmu3ubuntu3 @un uN > FU=0
  MarkInstall openmpi-bin:amd64 < 2.1.1-8 -> 4.0.3-0ubuntu1 @ii ugU Ib > FU=0
  Installing libopenmpi3 as Depends of openmpi-bin
    MarkInstall libopenmpi3:amd64 < none -> 4.0.3-0ubuntu1 @un uN Ib > FU=0
    Installing libevent-pthreads-2.1-7 as Depends of libopenmpi3
      MarkInstall libevent-pthreads-2.1-7:amd64 < none -> 2.1.11-stable-1 @un uN Ib > FU=0
      Installing libevent-core-2.1-7 as Depends of libevent-pthreads-2.1-7
        MarkInstall libevent-core-2.1-7:amd64 < none -> 2.1.11-stable-1 @un uN > FU=0
    Installing libpmix2 as Depends of libopenmpi3
      MarkInstall libpmix2:amd64 < none -> 3.1.5-1 @un uN > FU=0
  MarkInstall libpango-1.0-0:i386 < 1.40.14-1ubuntu0.1 -> 1.44.7-2ubuntu4 @ii umU Ib > FU=0
  Installing libfribidi0 as Depends of libpango-1.0-0
    MarkInstall libfribidi0:i386 < none -> 1.0.8-2 @un uN > FU=0
  MarkInstall libmono-webbrowser4.0-cil:amd64 < 4.6.2.7+dfsg-1ubuntu1 -> 6.8.0.105+dfsg-2 @ii umU NPb IPb > FU=0
  MarkInstall aptitude:amd64 < 0.8.10-6ubuntu1 -> 0.8.12-1ubuntu4 @ii umU Ib > FU=0
  Installing libboost-iostreams1.71.0 as Depends of aptitude
    MarkInstall libboost-iostreams1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
  Installing libcwidget4 as Depends of aptitude
    MarkInstall libcwidget4:amd64 < none -> 0.5.18-5build1 @un uN > FU=0
  MarkInstall isc-dhcp-client:amd64 < 4.3.5-3ubuntu7.2 -> 4.4.1-2.1ubuntu5.20.04.1 @ii umU Ib > FU=0
  Installing libdns-export1109 as Depends of isc-dhcp-client
    MarkInstall libdns-export1109:amd64 < none -> 1:9.11.16+dfsg-3~ubuntu1 @un uN Ib > FU=0
    Installing libisc-export1105 as Depends of libdns-export1109
      MarkInstall libisc-export1105:amd64 < none -> 1:9.11.16+dfsg-3~ubuntu1 @un uN > FU=0
  MarkInstall libcupscgi1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
  MarkInstall cryptsetup:amd64 < 2:2.0.2-1ubuntu1.2 -> 2:2.2.2-3ubuntu2.3 @ii umU IPb > FU=0
  new important dependency: cryptsetup-initramfs:amd64
  Installing cryptsetup-initramfs as Recommends of cryptsetup
    MarkInstall cryptsetup-initramfs:amd64 < none -> 2:2.2.2-3ubuntu2.3 @un uN > FU=0
  new important dependency: cryptsetup-run:amd64
  Installing cryptsetup-run as Recommends of cryptsetup
    MarkInstall cryptsetup-run:amd64 < none -> 2:2.2.2-3ubuntu2.3 @un uN > FU=0
  MarkInstall libibverbs-dev:amd64 < 17.1-1ubuntu0.2 -> 28.0-1ubuntu1 @ii ugU Ib > FU=0
  Installing libnl-3-dev as Depends of libibverbs-dev
    MarkInstall libnl-3-dev:amd64 < none -> 3.4.0-1 @un uN > FU=0
  Installing libnl-route-3-dev as Depends of libibverbs-dev
    MarkInstall libnl-route-3-dev:amd64 < none -> 3.4.0-1 @un uN > FU=0
  MarkInstall linux-system76:amd64 < 5.3.0-7648.41~1586790036~18.04~600aeb5~dev @ii mK Ib > FU=0
  MarkInstall libopenmpi-dev:amd64 < 2.1.1-8 -> 4.0.3-0ubuntu1 @ii ugU Ib > FU=0
  Installing gfortran-8 as Depends of libopenmpi-dev
    MarkInstall gfortran-8:amd64 < none -> 8.4.0-3ubuntu2 @un uN Ib > FU=0
    Installing gcc-8 as Depends of gfortran-8
      MarkInstall gcc-8:amd64 < none -> 8.4.0-3ubuntu2 @un uN Ib > FU=0
      Installing cpp-8 as Depends of gcc-8
        MarkInstall cpp-8:amd64 < none -> 8.4.0-3ubuntu2 @un uN > FU=0
      Installing libgcc-8-dev as Depends of gcc-8
        MarkInstall libgcc-8-dev:amd64 < none -> 8.4.0-3ubuntu2 @un uN > FU=0
    Installing libgfortran-8-dev as Depends of gfortran-8
      MarkInstall libgfortran-8-dev:amd64 < none -> 8.4.0-3ubuntu2 @un uN > FU=0
  Installing libevent-dev as Depends of libopenmpi-dev
    MarkInstall libevent-dev:amd64 < none -> 2.1.11-stable-1 @un uN Ib > FU=0
    Installing libevent-extra-2.1-7 as Depends of libevent-dev
      MarkInstall libevent-extra-2.1-7:amd64 < none -> 2.1.11-stable-1 @un uN > FU=0
    Installing libevent-openssl-2.1-7 as Depends of libevent-dev
      MarkInstall libevent-openssl-2.1-7:amd64 < none -> 2.1.11-stable-1 @un uN > FU=0
  new important dependency: libcoarrays-openmpi-dev:amd64
  Installing libcoarrays-openmpi-dev as Recommends of libopenmpi-dev
    MarkInstall libcoarrays-openmpi-dev:amd64 < none -> 2.8.0-1 @un uN Ib > FU=0
    Installing gfortran as Depends of libcoarrays-openmpi-dev
      MarkInstall gfortran:amd64 < none -> 4:9.3.0-1ubuntu2 @un uN Ib > FU=0
      Installing gfortran-9 as Depends of gfortran
        MarkInstall gfortran-9:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN Ib > FU=0
        Installing libgfortran-9-dev as Depends of gfortran-9
          MarkInstall libgfortran-9-dev:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN > FU=0
    Installing libcaf-openmpi-3 as Depends of libcoarrays-openmpi-dev
      MarkInstall libcaf-openmpi-3:amd64 < none -> 2.8.0-1 @un uN > FU=0
    Installing libcoarrays-dev as Depends of libcoarrays-openmpi-dev
      MarkInstall libcoarrays-dev:amd64 < none -> 2.8.0-1 @un uN > FU=0
  MarkInstall libmircommon7:amd64 < 0.31.1-0ubuntu1 -> 1.7.1-0ubuntu2 @ii umU Ib > FU=0
  Installing libboost-filesystem1.71.0 as Depends of libmircommon7
    MarkInstall libboost-filesystem1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
  MarkInstall initramfs-tools-core:amd64 < 0.130ubuntu3.11 -> 0.136ubuntu6.4 @ii umU Ib > FU=0
  Installing lz4 as Depends of initramfs-tools-core
    MarkInstall lz4:amd64 < none -> 1.9.2-2 @un uN > FU=0
  MarkInstall libwine:amd64 < 3.0-1ubuntu1 -> 5.0-3ubuntu1 @ii umU NPb Ib > FU=0
  Installing libfaudio0 as Depends of libwine
    MarkInstall libfaudio0:amd64 < none -> 20.04-2 @un uN Ib > FU=0
    Installing libstb0 as Depends of libfaudio0
      MarkInstall libstb0:amd64 < none -> 0.0~git20190817.1.052dce1-1 @un uN > FU=0
  Installing libvkd3d1 as Depends of libwine
    MarkInstall libvkd3d1:amd64 < none -> 1.1-4 @un uN > FU=0
  ignore old unsatisfied important dependency on libosmesa6:amd64
  MarkInstall libwine:i386 < 3.0-1ubuntu1 -> 5.0-3ubuntu1 @ii umU NPb Ib > FU=0
  Installing libncurses6 as Depends of libwine
    MarkInstall libncurses6:i386 < none -> 6.2-0ubuntu2 @un uN Ib > FU=0
    Installing libtinfo6 as Depends of libncurses6
      MarkInstall libtinfo6:i386 < none -> 6.2-0ubuntu2 @un uN > FU=0
  Installing libfaudio0 as Depends of libwine
    MarkInstall libfaudio0:i386 < none -> 20.04-2 @un uN Ib > FU=0
    Installing libavcodec58 as Depends of libfaudio0
      MarkInstall libavcodec58:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
      Installing libaom0 as Depends of libavcodec58
        MarkInstall libaom0:i386 < none -> 1.0.0.errata1-3build1 @un uN > FU=0
      Installing libavutil56 as Depends of libavcodec58
        MarkInstall libavutil56:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
        Installing libdrm2 as Depends of libavutil56
          MarkInstall libdrm2:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > FU=0
           Removing: libdrm2
            MarkDelete libdrm2:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib > FU=0
        Installing libva-drm2 as Depends of libavutil56
          MarkInstall libva-drm2:i386 < none -> 2.7.0-2 @un uN Ib > FU=0
          Installing libva2 as Depends of libva-drm2
            MarkInstall libva2:i386 < none -> 2.7.0-2 @un uN IPb > FU=0
            Installing va-driver-all as Recommends of libva2
              MarkInstall va-driver-all:i386 < none -> 2.7.0-2 @un uN Ib > FU=0
              Installing i965-va-driver as Depends of va-driver-all
                MarkInstall i965-va-driver:i386 < none -> 2.4.0-0ubuntu1 @un uN Ib > FU=0
                Installing libdrm-intel1 as Depends of i965-va-driver
                  MarkInstall libdrm-intel1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > FU=0
                  Installing libpciaccess0 as Depends of libdrm-intel1
                    MarkInstall libpciaccess0:i386 < none -> 0.16-0ubuntu1 @un uN > FU=0
                   Removing: libdrm-intel1
                    MarkDelete libdrm-intel1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib > FU=0
              Installing intel-media-va-driver as Depends of va-driver-all
                MarkInstall intel-media-va-driver:i386 < none -> 20.1.1+dfsg1-1 @un uN Ib > FU=0
                Installing libigdgmm11 as Depends of intel-media-va-driver
                  MarkInstall libigdgmm11:i386 < none -> 20.1.1+ds1-1 @un uN > FU=0
              Installing mesa-va-drivers as Depends of va-driver-all
                MarkInstall mesa-va-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
                Installing libdrm-amdgpu1 as Depends of mesa-va-drivers
                  MarkInstall libdrm-amdgpu1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > FU=0
                   Removing: libdrm-amdgpu1
                    MarkDelete libdrm-amdgpu1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib > FU=0
                Installing libdrm-nouveau2 as Depends of mesa-va-drivers
                  MarkInstall libdrm-nouveau2:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > FU=0
                   Removing: libdrm-nouveau2
                    MarkDelete libdrm-nouveau2:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib > FU=0
                Installing libdrm-radeon1 as Depends of mesa-va-drivers
                  MarkInstall libdrm-radeon1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > FU=0
                   Removing: libdrm-radeon1
                    MarkDelete libdrm-radeon1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib > FU=0
                Installing libelf1 as Depends of mesa-va-drivers
                  MarkInstall libelf1:i386 < none -> 0.176-1.1build1 @un uN > FU=0
                Installing libllvm11 as Depends of mesa-va-drivers
                  MarkInstall libllvm11:i386 < none -> 1:11.0.0-2~ubuntu20.04.1 @un uN Ib > FU=0
                  Installing libatomic1 as Depends of libllvm11
                    MarkInstall libatomic1:i386 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
                  Installing libedit2 as Depends of libllvm11
                    MarkInstall libedit2:i386 < none -> 3.1-20191231-1 @un uN > FU=0
                Installing libx11-xcb1 as Depends of mesa-va-drivers
                  MarkInstall libx11-xcb1:i386 < none -> 2:1.6.9-2ubuntu1.1 @un uN > FU=0
                Installing libxcb-dri2-0 as Depends of mesa-va-drivers
                  MarkInstall libxcb-dri2-0:i386 < none -> 1.14-2 @un uN > FU=0
                Installing libxcb-dri3-0 as Depends of mesa-va-drivers
                  MarkInstall libxcb-dri3-0:i386 < none -> 1.14-2 @un uN > FU=0
                Installing libxcb-present0 as Depends of mesa-va-drivers
                  MarkInstall libxcb-present0:i386 < none -> 1.14-2 @un uN > FU=0
                Installing libxcb-sync1 as Depends of mesa-va-drivers
                  MarkInstall libxcb-sync1:i386 < none -> 1.14-2 @un uN > FU=0
                Installing libxcb-xfixes0 as Depends of mesa-va-drivers
                  MarkInstall libxcb-xfixes0:i386 < none -> 1.14-2 @un uN > FU=0
                Installing libxshmfence1 as Depends of mesa-va-drivers
                  MarkInstall libxshmfence1:i386 < none -> 1.3-1 @un uN > FU=0
                 Removing: mesa-va-drivers
                  MarkDelete mesa-va-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mK Ib > FU=0
        Installing libva-x11-2 as Depends of libavutil56
          MarkInstall libva-x11-2:i386 < none -> 2.7.0-2 @un uN > FU=0
        Installing libvdpau1 as Depends of libavutil56
          MarkInstall libvdpau1:i386 < none -> 1.3-1ubuntu2 @un uN IPb > FU=0
          Installing vdpau-driver-all as Recommends of libvdpau1
            MarkInstall vdpau-driver-all:i386 < none -> 1.3-1ubuntu2 @un uN Ib > FU=0
            Installing mesa-vdpau-drivers as Depends of vdpau-driver-all
              MarkInstall mesa-vdpau-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
               Removing: mesa-vdpau-drivers
                MarkDelete mesa-vdpau-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mK Ib > FU=0
      Installing libcodec2-0.9 as Depends of libavcodec58
        MarkInstall libcodec2-0.9:i386 < none -> 0.9.2-2 @un uN > FU=0
      Installing libmp3lame0 as Depends of libavcodec58
        MarkInstall libmp3lame0:i386 < none -> 3.100-3 @un uN > FU=0
      Installing libopenjp2-7 as Depends of libavcodec58
        MarkInstall libopenjp2-7:i386 < none -> 2.3.1-1ubuntu4.20.04.1 @un uN > FU=0
      Installing librsvg2-2 as Depends of libavcodec58
        MarkInstall librsvg2-2:i386 < none -> 2.48.9-1ubuntu0.20.04.1 @un uN Ib > FU=0
        Installing libcairo-gobject2 as Depends of librsvg2-2
          MarkInstall libcairo-gobject2:i386 < none -> 1.16.0-4ubuntu1 @un uN > FU=0
        Installing librsvg2-common as Recommends of librsvg2-2
          MarkInstall librsvg2-common:i386 < none -> 2.48.9-1ubuntu0.20.04.1 @un uN > FU=0
      Installing libshine3 as Depends of libavcodec58
        MarkInstall libshine3:i386 < none -> 3.1.1-2 @un uN > FU=0
      Installing libsnappy1v5 as Depends of libavcodec58
        MarkInstall libsnappy1v5:i386 < none -> 1.1.8-1build1 @un uN > FU=0
      Installing libspeex1 as Depends of libavcodec58
        MarkInstall libspeex1:i386 < none -> 1.2~rc1.2-1.1ubuntu1 @un uN > FU=0
      Installing libswresample3 as Depends of libavcodec58
        MarkInstall libswresample3:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
        Installing libsoxr0 as Depends of libswresample3
          MarkInstall libsoxr0:i386 < none -> 0.1.3-2build1 @un uN Ib > FU=0
          Installing libgomp1 as Depends of libsoxr0
            MarkInstall libgomp1:i386 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
      Installing libtwolame0 as Depends of libavcodec58
        MarkInstall libtwolame0:i386 < none -> 0.4.0-2 @un uN > FU=0
      Installing libvpx6 as Depends of libavcodec58
        MarkInstall libvpx6:i386 < none -> 1.8.2-1build1 @un uN > FU=0
      Installing libwavpack1 as Depends of libavcodec58
        MarkInstall libwavpack1:i386 < none -> 5.2.0-1ubuntu0.1 @un uN > FU=0
      Installing libwebpmux3 as Depends of libavcodec58
        MarkInstall libwebpmux3:i386 < none -> 0.6.1-2 @un uN > FU=0
      Installing libx264-155 as Depends of libavcodec58
        MarkInstall libx264-155:i386 < none -> 2:0.155.2917+git0a84d98-2 @un uN > FU=0
      Installing libx265-179 as Depends of libavcodec58
        MarkInstall libx265-179:i386 < none -> 3.2.1-1build1 @un uN Ib > FU=0
        Installing libnuma1 as Depends of libx265-179
          MarkInstall libnuma1:i386 < none -> 2.0.12-1 @un uN > FU=0
      Installing libxvidcore4 as Depends of libavcodec58
        MarkInstall libxvidcore4:i386 < none -> 2:1.3.7-1 @un uN > FU=0
      Installing libzvbi0 as Depends of libavcodec58
        MarkInstall libzvbi0:i386 < none -> 0.2.35-17 @un uN > FU=0
    Installing libsdl2-2.0-0 as Depends of libfaudio0
      MarkInstall libsdl2-2.0-0:i386 < none -> 2.0.10+dfsg1-3 @un uN Ib > FU=0
      Installing libwayland-client0 as Depends of libsdl2-2.0-0
        MarkInstall libwayland-client0:i386 < none -> 1.18.0-1 @un uN > FU=0
      Installing libwayland-cursor0 as Depends of libsdl2-2.0-0
        MarkInstall libwayland-cursor0:i386 < none -> 1.18.0-1 @un uN > FU=0
      Installing libwayland-egl1 as Depends of libsdl2-2.0-0
        MarkInstall libwayland-egl1:i386 < none -> 1.18.0-1 @un uN > FU=0
      Installing libxkbcommon0 as Depends of libsdl2-2.0-0
        MarkInstall libxkbcommon0:i386 < none -> 0.10.0-1 @un uN > FU=0
      Installing libxss1 as Depends of libsdl2-2.0-0
        MarkInstall libxss1:i386 < none -> 1:1.2.3-1 @un uN > FU=0
    Installing libstb0 as Depends of libfaudio0
      MarkInstall libstb0:i386 < none -> 0.0~git20190817.1.052dce1-1 @un uN > FU=0
  Installing libvkd3d1 as Depends of libwine
    MarkInstall libvkd3d1:i386 < none -> 1.1-4 @un uN Ib > FU=0
    Installing libvulkan1 as Depends of libvkd3d1
      MarkInstall libvulkan1:i386 < none -> 1.2.131.2-1 @un uN IPb > FU=0
      Installing mesa-vulkan-drivers as Recommends of libvulkan1
        MarkInstall mesa-vulkan-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
        Installing libxcb-randr0 as Depends of mesa-vulkan-drivers
          MarkInstall libxcb-randr0:i386 < none -> 1.14-2 @un uN > FU=0
  ignore old unsatisfied important dependency on libgl1:i386
  ignore old unsatisfied important dependency on libglu1-mesa:i386
  ignore old unsatisfied important dependency on libosmesa6:i386
  ignore old unsatisfied important dependency on libgl1-mesa-dri:i386
  ignore old unsatisfied important dependency on libasound2-plugins:i386
  new important dependency: gstreamer1.0-plugins-good:i386
  Installing gstreamer1.0-plugins-good as Recommends of libwine
    MarkInstall gstreamer1.0-plugins-good:i386 < none -> 1.16.2-1ubuntu2 @un uN Ib > FU=0
    Installing libaa1 as Depends of gstreamer1.0-plugins-good
      MarkInstall libaa1:i386 < none -> 1.4p5-46 @un uN Ib > FU=0
      Installing libslang2 as Depends of libaa1
        MarkInstall libslang2:i386 < none -> 2.3.2-4 @un uN > FU=0
    Installing libavc1394-0 as Depends of gstreamer1.0-plugins-good
      MarkInstall libavc1394-0:i386 < none -> 0.5.4-5 @un uN Ib > FU=0
      Installing libraw1394-11 as Depends of libavc1394-0
        MarkInstall libraw1394-11:i386 < none -> 2.1.2-1 @un uN > FU=0
    Installing libcaca0 as Depends of gstreamer1.0-plugins-good
      MarkInstall libcaca0:i386 < none -> 0.99.beta19-2.1ubuntu1 @un uN Ib > FU=0
      Installing libncursesw6 as Depends of libcaca0
        MarkInstall libncursesw6:i386 < none -> 6.2-0ubuntu2 @un uN > FU=0
    Installing libdv4 as Depends of gstreamer1.0-plugins-good
      MarkInstall libdv4:i386 < none -> 1.0.0-12 @un uN > FU=0
    Installing libgstreamer-plugins-good1.0-0 as Depends of gstreamer1.0-plugins-good
      MarkInstall libgstreamer-plugins-good1.0-0:i386 < none -> 1.16.2-1ubuntu2 @un uN > FU=0
    Installing libgudev-1.0-0 as Depends of gstreamer1.0-plugins-good
      MarkInstall libgudev-1.0-0:i386 < none -> 1:233-1 @un uN > FU=0
    Installing libiec61883-0 as Depends of gstreamer1.0-plugins-good
      MarkInstall libiec61883-0:i386 < none -> 1.2.0-3 @un uN > FU=0
    Installing libjack-jackd2-0 as Depends of gstreamer1.0-plugins-good
      MarkInstall libjack-jackd2-0:i386 < none -> 1.9.12~dfsg-2ubuntu2 @un uN Ib > FU=0
      Installing libsamplerate0 as Depends of libjack-jackd2-0
        MarkInstall libsamplerate0:i386 < none -> 0.1.9-2 @un uN > FU=0
       Removing: libjack0
        MarkDelete libjack0:amd64 < 1:0.125.0-3 -> 1:0.125.0-3build2 @ii umU Ib > FU=0
    Installing libshout3 as Depends of gstreamer1.0-plugins-good
      MarkInstall libshout3:i386 < none -> 2.4.3-1 @un uN > FU=0
    Installing libsoup2.4-1 as Depends of gstreamer1.0-plugins-good
      MarkInstall libsoup2.4-1:i386 < none -> 2.70.0-1 @un uN Ib > FU=0
      Installing glib-networking as Depends of libsoup2.4-1
        MarkInstall glib-networking:i386 < none -> 2.64.2-1ubuntu0.1 @un uN Ib > FU=0
        Installing libproxy1v5 as Depends of glib-networking
          MarkInstall libproxy1v5:i386 < none -> 0.4.15-10ubuntu1.2 @un uN > FU=0
    Installing libtag1v5 as Depends of gstreamer1.0-plugins-good
      MarkInstall libtag1v5:i386 < none -> 1.11.1+dfsg.1-0.3ubuntu2 @un uN Ib > FU=0
      Installing libtag1v5-vanilla as Depends of libtag1v5
        MarkInstall libtag1v5-vanilla:i386 < none -> 1.11.1+dfsg.1-0.3ubuntu2 @un uN > FU=0
    Installing gstreamer1.0-x as Recommends of gstreamer1.0-plugins-good
      MarkInstall gstreamer1.0-x:i386 < none -> 1.16.2-4 @un uN Ib > FU=0
      Installing libxv1 as Depends of gstreamer1.0-x
        MarkInstall libxv1:i386 < none -> 2:1.0.11-1 @un uN > FU=0
  MarkInstall wireshark-qt:amd64 < 2.6.10-1~ubuntu18.04.0 -> 3.2.3-1 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on libqt5multimedia5-plugins:amd64
    MarkKeep mesa-va-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mR > FU=0
  MarkInstall python3-bs4:amd64 < 4.6.0-1 -> 4.8.2-1 @ii umU Ib > FU=0
  Installing python3-soupsieve as Depends of python3-bs4
    MarkInstall python3-soupsieve:amd64 < none -> 1.9.5+dfsg-1 @un uN > FU=0
  MarkInstall libglx-mesa0:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mK Ib > FU=0
  Installing libdrm2 as Depends of libglx-mesa0
      MarkKeep libdrm2:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mR > FU=0
  MarkInstall libvirt-daemon:amd64 < 4.0.0-1ubuntu8.19 -> 6.0.0-0ubuntu8.8 @ii umU Ib > FU=0
  Installing libvirt-daemon-driver-qemu as Depends of libvirt-daemon
    MarkInstall libvirt-daemon-driver-qemu:amd64 < none -> 6.0.0-0ubuntu8.8 @un uN > FU=0
    MarkKeep libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mR > FU=0
    MarkKeep libdrm-nouveau2:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mR > FU=0
    MarkKeep libdrm-amdgpu1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mR > FU=0
    MarkKeep libdrm-intel1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mR > FU=0
    MarkKeep libdrm-radeon1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mR > FU=0
    MarkKeep mesa-vdpau-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mR > FU=0
Starting pkgProblemResolver with broken count: 49
Starting 2 pkgProblemResolver with broken count: 49
Investigating (0) dpkg:amd64 < 1.19.0.5ubuntu2.3 -> 1.19.7ubuntu3 @ii umU Ib >
Broken dpkg:amd64 Breaks on libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mK > (< 1.7~b)
  Considering libapt-pkg5.0:amd64 -1 as a solution to dpkg:amd64 5905
  Added libapt-pkg5.0:amd64 to the remove list
  Fixing dpkg:amd64 via remove of libapt-pkg5.0:amd64
  MarkDelete libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mK > FU=0
Investigating (0) libqt5core5a:amd64 < 5.9.5+dfsg-0ubuntu2.5 -> 5.12.8+dfsg-0ubuntu1 @ii umU Ib >
Broken libqt5core5a:amd64 Breaks on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK > (< 4:4.8.7+dfsg-20~)
  Considering libqtcore4:amd64 39 as a solution to libqt5core5a:amd64 1559
  Added libqtcore4:amd64 to the remove list
  Fixing libqt5core5a:amd64 via remove of libqtcore4:amd64
  MarkDelete libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK > FU=0
Investigating (0) libdrm2:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib >
Broken libdrm2:amd64 Breaks on libdrm2:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > (!= 2.4.102+git2010051830.5de99a~oibaf~b)
  Considering libdrm2:i386 14 as a solution to libdrm2:amd64 274
  Added libdrm2:i386 to the remove list
  Conflicts//Breaks against version 2.4.101-2 for libdrm2 but that is not InstVer, ignoring
  Fixing libdrm2:amd64 via keep of libdrm2:i386
  MarkKeep libdrm2:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > FU=0
Investigating (0) libgcc1:amd64 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib >
Broken libgcc1:amd64 Conflicts on libgcc1:i386 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib >
  Considering libgcc1:i386 4 as a solution to libgcc1:amd64 168
  Added libgcc1:i386 to the remove list
  Conflicts//Breaks against version 1:10-20200411-0ubuntu1 for libgcc1 but that is not InstVer, ignoring
  Conflicts//Breaks against version 1:8.4.0-1ubuntu1~18.04 for libgcc1 but that is not InstVer, ignoring
  Fixing libgcc1:amd64 via remove of libgcc1:i386
  MarkDelete libgcc1:i386 < 1:8.4.0-1ubuntu1~18.04 -> 1:10.2.0-5ubuntu1~20.04 @ii umU Ib > FU=0
Investigating (0) gnome-settings-daemon-common:amd64 < none -> 3.36.1-0ubuntu1 @un uN Ib >
Broken gnome-settings-daemon-common:amd64 Breaks on gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3pop0~1565899898~18.04~a5b17e2~dev @ii mK > (< 3.30.1.2-2~)
  Considering gnome-settings-daemon-schemas:amd64 -3 as a solution to gnome-settings-daemon-common:amd64 12
  Added gnome-settings-daemon-schemas:amd64 to the remove list
  Fixing gnome-settings-daemon-common:amd64 via remove of gnome-settings-daemon-schemas:amd64
  MarkDelete gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3pop0~1565899898~18.04~a5b17e2~dev @ii mK > FU=0
Investigating (0) libdrm-amdgpu1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib >
Broken libdrm-amdgpu1:amd64 Breaks on libdrm-amdgpu1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > (!= 2.4.102+git2010051830.5de99a~oibaf~b)
  Considering libdrm-amdgpu1:i386 1 as a solution to libdrm-amdgpu1:amd64 11
  Added libdrm-amdgpu1:i386 to the remove list
  Conflicts//Breaks against version 2.4.101-2 for libdrm-amdgpu1 but that is not InstVer, ignoring
  Fixing libdrm-amdgpu1:amd64 via keep of libdrm-amdgpu1:i386
  MarkKeep libdrm-amdgpu1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > FU=0
Investigating (0) libqtdbus4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqtdbus4:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 39 as a solution to libqtdbus4:amd64 10
  Removing libqtdbus4:amd64 rather than change libqtcore4:amd64
  MarkDelete libqtdbus4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libdrm-nouveau2:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib >
Broken libdrm-nouveau2:amd64 Breaks on libdrm-nouveau2:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > (!= 2.4.102+git2010051830.5de99a~oibaf~b)
  Considering libdrm-nouveau2:i386 0 as a solution to libdrm-nouveau2:amd64 10
  Added libdrm-nouveau2:i386 to the remove list
  Conflicts//Breaks against version 2.4.101-2 for libdrm-nouveau2 but that is not InstVer, ignoring
  Fixing libdrm-nouveau2:amd64 via keep of libdrm-nouveau2:i386
  MarkKeep libdrm-nouveau2:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > FU=0
Investigating (0) libdrm-intel1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib >
Broken libdrm-intel1:amd64 Breaks on libdrm-intel1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > (!= 2.4.102+git2010051830.5de99a~oibaf~b)
  Considering libdrm-intel1:i386 -1 as a solution to libdrm-intel1:amd64 10
  Added libdrm-intel1:i386 to the remove list
  Conflicts//Breaks against version 2.4.101-2 for libdrm-intel1 but that is not InstVer, ignoring
  Fixing libdrm-intel1:amd64 via keep of libdrm-intel1:i386
  MarkKeep libdrm-intel1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > FU=0
Investigating (0) libdrm-radeon1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib >
Broken libdrm-radeon1:amd64 Breaks on libdrm-radeon1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > (!= 2.4.102+git2010051830.5de99a~oibaf~b)
  Considering libdrm-radeon1:i386 0 as a solution to libdrm-radeon1:amd64 9
  Added libdrm-radeon1:i386 to the remove list
  Conflicts//Breaks against version 2.4.101-2 for libdrm-radeon1 but that is not InstVer, ignoring
  Fixing libdrm-radeon1:amd64 via keep of libdrm-radeon1:i386
  MarkKeep libdrm-radeon1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > FU=0
Investigating (0) libqtgui4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqtgui4:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 39 as a solution to libqtgui4:amd64 8
  Removing libqtgui4:amd64 rather than change libqtcore4:amd64
  MarkDelete libqtgui4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libqt4-declarative:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-declarative:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 39 as a solution to libqt4-declarative:amd64 8
  Removing libqt4-declarative:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-declarative:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) qt-at-spi:amd64 < 0.4.0-8 @ii mK Ib >
Broken qt-at-spi:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.8~)
  Considering libqtcore4:amd64 39 as a solution to qt-at-spi:amd64 7
  Removing qt-at-spi:amd64 rather than change libqtcore4:amd64
  MarkDelete qt-at-spi:amd64 < 0.4.0-8 @ii mK Ib > FU=0
Investigating (0) libqt4-xml:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-xml:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 39 as a solution to libqt4-xml:amd64 5
  Removing libqt4-xml:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-xml:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-network:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 39 as a solution to libqt4-network:amd64 3
  Removing libqt4-network:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libjack0:amd64 < 1:0.125.0-3 -> 1:0.125.0-3build2 @ii umU Ib >
Broken libjack0:amd64 Conflicts on libjack-0.116:i386 < none @un H >
  Considering libjack-jackd2-0:i386 0 as a solution to libjack0:amd64 3
  Added libjack-jackd2-0:i386 to the remove list
Broken libjack0:amd64 Conflicts on libjack-0.125:i386 < none @un H >
  Considering libjack-jackd2-0:i386 0 as a solution to libjack0:amd64 3
  Added libjack-jackd2-0:i386 to the remove list
  Fixing libjack0:amd64 via keep of libjack-jackd2-0:i386
  MarkKeep libjack-jackd2-0:i386 < none -> 1.9.12~dfsg-2ubuntu2 @un uN Ib > FU=0
  Fixing libjack0:amd64 via keep of libjack-jackd2-0:i386
Investigating (0) libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-dbus:amd64 Depends on libqtdbus4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtdbus4:amd64 10 as a solution to libqt4-dbus:amd64 3
  Removing libqt4-dbus:amd64 rather than change libqtdbus4:amd64
  MarkDelete libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-nouveau:amd64 2
  Removing xserver-xorg-video-nouveau:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
Investigating (0) qdbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken qdbus:amd64 Depends on libqt4-xml:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-xml:amd64 5 as a solution to qdbus:amd64 2
  Removing qdbus:amd64 rather than change libqt4-xml:amd64
  MarkDelete qdbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libva-drm2:i386 < none -> 2.7.0-2 @un uN Ib >
Broken libva-drm2:i386 Depends on libdrm2:i386 < none | 2.4.102-1ubuntu1~20.04.1 @un uH > (>= 2.4.16)
  Considering libdrm2:i386 14 as a solution to libva-drm2:i386 2
  MarkKeep libva-drm2:i386 < none -> 2.7.0-2 @un uN Ib > FU=0
  Holding Back libva-drm2:i386 rather than change libdrm2:i386
Investigating (0) libqt4-script:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-script:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 39 as a solution to libqt4-script:amd64 2
  Removing libqt4-script:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-script:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) mesa-vulkan-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib >
Broken mesa-vulkan-drivers:i386 Depends on libdrm-amdgpu1:i386 < none | 2.4.102-1ubuntu1~20.04.1 @un uH > (>= 2.4.99)
  Considering libdrm-amdgpu1:i386 1 as a solution to mesa-vulkan-drivers:i386 2
  MarkKeep mesa-vulkan-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
  Holding Back mesa-vulkan-drivers:i386 rather than change libdrm-amdgpu1:i386
Investigating (0) libsensors-config:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib >
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii mK >
  Considering libsensors4:amd64 6 as a solution to libsensors-config:amd64 2
  MarkKeep libsensors-config:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib > FU=0
  Holding Back libsensors-config:amd64 rather than change libsensors4:amd64
Investigating (0) libavutil56:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib >
Broken libavutil56:i386 Depends on libdrm2:i386 < none | 2.4.102-1ubuntu1~20.04.1 @un uH > (>= 2.3.1)
  Considering libdrm2:i386 14 as a solution to libavutil56:i386 2
  MarkKeep libavutil56:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
  Holding Back libavutil56:i386 rather than change libdrm2:i386
Investigating (0) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-ati:amd64 2
  Removing xserver-xorg-video-ati:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (0) libva-x11-2:i386 < none -> 2.7.0-2 @un uN Ib >
Broken libva-x11-2:i386 Depends on libdrm2:i386 < none | 2.4.102-1ubuntu1~20.04.1 @un uH > (>= 2.3.1)
  Considering libdrm2:i386 14 as a solution to libva-x11-2:i386 2
  MarkKeep libva-x11-2:i386 < none -> 2.7.0-2 @un uN Ib > FU=0
  Holding Back libva-x11-2:i386 rather than change libdrm2:i386
Investigating (0) xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-intel:amd64 2
  Removing xserver-xorg-video-intel:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mK Ib > FU=0
Investigating (0) libqt4-sql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-sql:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 39 as a solution to libqt4-sql:amd64 1
  Removing libqt4-sql:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-sql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libhfstospell10:amd64 < none -> 0.5.0-2build2 @un uN Ib >
Broken libhfstospell10:amd64 Conflicts on libhfstospell:amd64 < none @un H >
  Considering libhfstospell9:amd64 -2 as a solution to libhfstospell10:amd64 1
  Added libhfstospell9:amd64 to the remove list
  Fixing libhfstospell10:amd64 via remove of libhfstospell9:amd64
  MarkDelete libhfstospell9:amd64 < 0.4.5~r343-2.1build2 @ii mK Ib > FU=0
Investigating (0) libtinyxml2-6a:amd64 < none -> 7.0.0+dfsg-1build1 @un uN Ib >
Broken libtinyxml2-6a:amd64 Conflicts on libtinyxml2-6:amd64 < 6.0.0+dfsg-1 @ii mK >
  Considering libtinyxml2-6:amd64 -3 as a solution to libtinyxml2-6a:amd64 1
  Added libtinyxml2-6:amd64 to the remove list
  Fixing libtinyxml2-6a:amd64 via remove of libtinyxml2-6:amd64
  MarkDelete libtinyxml2-6:amd64 < 6.0.0+dfsg-1 @ii mK > FU=0
Investigating (0) fluidr3mono-gm-soundfont:amd64 < 2.315-4 -> 2.315-6 @ii umU Ib >
Broken fluidr3mono-gm-soundfont:amd64 Conflicts on musescore-common:amd64 < 2.1.0+dfsg3-3build1 @ii mK > (< 2.3.2+dfsg1-1~bpo9)
  Considering musescore-common:amd64 -2 as a solution to fluidr3mono-gm-soundfont:amd64 1
  Added musescore-common:amd64 to the remove list
  Fixing fluidr3mono-gm-soundfont:amd64 via remove of musescore-common:amd64
  MarkDelete musescore-common:amd64 < 2.1.0+dfsg3-3build1 @ii mK > FU=0
Investigating (0) gstreamer1.0-plugins-good:i386 < none -> 1.16.2-1ubuntu2 @un uN Ib >
Broken gstreamer1.0-plugins-good:i386 Depends on libjack-jackd2-0:i386 < none | 1.9.12~dfsg-2ubuntu2 @un uH > (>= 1.9.10+20150825)
  Considering libjack-jackd2-0:i386 0 as a solution to gstreamer1.0-plugins-good:i386 1
  MarkKeep gstreamer1.0-plugins-good:i386 < none -> 1.16.2-1ubuntu2 @un uN Ib > FU=0
  Holding Back gstreamer1.0-plugins-good:i386 rather than change libjack-jackd2-0:i386
Broken gstreamer1.0-plugins-good:i386 Depends on libjack-0.125:i386 < none @un H >
  Considering libjack0:i386 -1 as a solution to gstreamer1.0-plugins-good:i386 1
  MarkKeep gstreamer1.0-plugins-good:i386 < none -> 1.16.2-1ubuntu2 @un uN Ib > FU=0
  Holding Back gstreamer1.0-plugins-good:i386 rather than change libjack-0.125:i386
  Or group keep for gstreamer1.0-plugins-good:i386
  MarkKeep gstreamer1.0-plugins-good:i386 < none -> 1.16.2-1ubuntu2 @un uN Ib > FU=0
Investigating (0) xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-amdgpu:amd64 1
  Removing xserver-xorg-video-amdgpu:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
Investigating (0) clang-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN Ib >
Broken clang-10:amd64 Depends on libclang-cpp10:amd64 < none | 1:10.0.0-4ubuntu1 @un uH >
  Considering libclang-cpp10:amd64 1 as a solution to clang-10:amd64 1
  MarkKeep clang-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN Ib > FU=0
  Holding Back clang-10:amd64 rather than change libclang-cpp10:amd64
Investigating (0) libfaudio0:i386 < none -> 20.04-2 @un uN Ib >
Broken libfaudio0:i386 Depends on libavutil56:i386 < none | 7:4.2.4-1ubuntu0.1 @un uH > (>= 7:4.0)
  Considering libavutil56:i386 2 as a solution to libfaudio0:i386 1
  MarkKeep libfaudio0:i386 < none -> 20.04-2 @un uN Ib > FU=0
  Holding Back libfaudio0:i386 rather than change libavutil56:i386
Investigating (0) libboost1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib >
Broken libboost1.71-dev:amd64 Conflicts on libboost1.65-dev:amd64 < 1.65.1+dfsg-0ubuntu5 @ii mK >
  Considering libboost1.65-dev:amd64 29 as a solution to libboost1.71-dev:amd64 0
  MarkKeep libboost1.71-dev:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
  Holding Back libboost1.71-dev:amd64 rather than change libboost1.65-dev:amd64
Investigating (0) libqt4-sql-sqlite:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-sql-sqlite:amd64 Depends on libqt4-sql:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-sql:amd64 1 as a solution to libqt4-sql-sqlite:amd64 0
  Removing libqt4-sql-sqlite:amd64 rather than change libqt4-sql:amd64
  MarkDelete libqt4-sql-sqlite:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) appmenu-qt:amd64 < 0.2.7+14.04.20140305-0ubuntu2 @ii mK Ib >
Broken appmenu-qt:amd64 Depends on libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.8)
  Considering libqt4-dbus:amd64 3 as a solution to appmenu-qt:amd64 0
  Removing appmenu-qt:amd64 rather than change libqt4-dbus:amd64
  MarkDelete appmenu-qt:amd64 < 0.2.7+14.04.20140305-0ubuntu2 @ii mK Ib > FU=0
Investigating (0) libsensors5:i386 < none -> 1:3.6.0-2ubuntu1 @un uN Ib >
Broken libsensors5:i386 Depends on libsensors-config:i386 < none @un H >
  Considering libsensors-config:amd64 2 as a solution to libsensors5:i386 0
  MarkKeep libsensors5:i386 < none -> 1:3.6.0-2ubuntu1 @un uN Ib > FU=0
  Holding Back libsensors5:i386 rather than change libsensors-config:i386
Investigating (0) libavcodec-extra58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib >
Broken libavcodec-extra58:amd64 Conflicts on libavcodec58:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib >
  Considering libavcodec58:i386 -1 as a solution to libavcodec-extra58:amd64 0
  Added libavcodec58:i386 to the remove list
  Conflicts//Breaks against version 7:4.2.2-1ubuntu1 for libavcodec58 but that is not InstVer, ignoring
  Fixing libavcodec-extra58:amd64 via keep of libavcodec58:i386
  MarkKeep libavcodec58:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
Investigating (0) libswresample3:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib >
Broken libswresample3:i386 Depends on libavutil56:i386 < none | 7:4.2.4-1ubuntu0.1 @un uH > (= 7:4.2.4-1ubuntu0.1)
  Considering libavutil56:i386 2 as a solution to libswresample3:i386 0
  MarkKeep libswresample3:i386 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
  Holding Back libswresample3:i386 rather than change libavutil56:i386
Investigating (0) libqt4-xmlpatterns:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-xmlpatterns:amd64 Depends on libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-network:amd64 3 as a solution to libqt4-xmlpatterns:amd64 0
  Removing libqt4-xmlpatterns:amd64 rather than change libqt4-network:amd64
  MarkDelete libqt4-xmlpatterns:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libldb2:amd64 < none -> 2:2.0.10-0ubuntu0.20.04.2 @un uN Ib >
Broken libldb2:amd64 Breaks on libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mK > (< 2:2~)
  Considering libldb1:amd64 -3 as a solution to libldb2:amd64 0
  Added libldb1:amd64 to the remove list
  Fixing libldb2:amd64 via remove of libldb1:amd64
  MarkDelete libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mK > FU=0
Investigating (0) libdbusmenu-qt2:amd64 < 0.9.3+16.04.20160218-1ubuntu1 @ii mK Ib >
Broken libdbusmenu-qt2:amd64 Depends on libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.6.2)
  Considering libqt4-dbus:amd64 3 as a solution to libdbusmenu-qt2:amd64 0
  Removing libdbusmenu-qt2:amd64 rather than change libqt4-dbus:amd64
  MarkDelete libdbusmenu-qt2:amd64 < 0.9.3+16.04.20160218-1ubuntu1 @ii mK Ib > FU=0
Investigating (0) libboost-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib >
Broken libboost-dev:amd64 Depends on libboost1.71-dev:amd64 < none | 1.71.0-6ubuntu6 @un uH >
  Considering libboost1.71-dev:amd64 0 as a solution to libboost-dev:amd64 0
  MarkKeep libboost-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
  Holding Back libboost-dev:amd64 rather than change libboost1.71-dev:amd64
Investigating (0) clang-tidy:amd64 < none -> 1:10.0-50~exp1 @un uN Ib >
Broken clang-tidy:amd64 Depends on clang-tidy-10:amd64 < none | 1:10.0.0-4ubuntu1 @un uH > (>= 10~)
  Considering clang-tidy-10:amd64 0 as a solution to clang-tidy:amd64 0
  MarkKeep clang-tidy:amd64 < none -> 1:10.0-50~exp1 @un uN Ib > FU=0
  Holding Back clang-tidy:amd64 rather than change clang-tidy-10:amd64
Investigating (0) libqt4-designer:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-designer:amd64 Depends on libqt4-script:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-script:amd64 2 as a solution to libqt4-designer:amd64 -1
  Removing libqt4-designer:amd64 rather than change libqt4-script:amd64
  MarkDelete libqt4-designer:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) i965-va-driver:i386 < none -> 2.4.0-0ubuntu1 @un uN Ib >
Broken i965-va-driver:i386 Depends on libdrm-intel1:i386 < none | 2.4.102-1ubuntu1~20.04.1 @un uH > (>= 2.4.46)
  Considering libdrm-intel1:i386 -1 as a solution to i965-va-driver:i386 -1
  MarkKeep i965-va-driver:i386 < none -> 2.4.0-0ubuntu1 @un uN Ib > FU=0
  Holding Back i965-va-driver:i386 rather than change libdrm-intel1:i386
Investigating (0) linux-system76:amd64 < 5.3.0-7648.41~1586790036~18.04~600aeb5~dev @ii mK Ib >
Broken linux-system76:amd64 Depends on linux-generic:amd64 < 5.3.0-7648.41~1586790036~18.04~600aeb5~dev -> 5.4.0.70.73 @ii umU > (= 5.3.0-7648.41~1586790036~18.04~600aeb5~dev)
  Considering linux-generic:amd64 1 as a solution to linux-system76:amd64 -1
  Removing linux-system76:amd64 rather than change linux-generic:amd64
  MarkDelete linux-system76:amd64 < 5.3.0-7648.41~1586790036~18.04~600aeb5~dev @ii mK Ib > FU=0
Investigating (0) libqt4-scripttools:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-scripttools:amd64 Depends on libqt4-script:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-script:amd64 2 as a solution to libqt4-scripttools:amd64 -1
  Removing libqt4-scripttools:amd64 rather than change libqt4-script:amd64
  MarkDelete libqt4-scripttools:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libqt4-svg:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-svg:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 39 as a solution to libqt4-svg:amd64 -1
  Removing libqt4-svg:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-svg:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) mesa-vdpau-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mK Ib >
Broken mesa-vdpau-drivers:amd64 Breaks on mesa-vdpau-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib > (!= 20.3~git2010060730.2b977a~oibaf~b)
  Considering mesa-vdpau-drivers:i386 -1 as a solution to mesa-vdpau-drivers:amd64 -1
  Removing mesa-vdpau-drivers:amd64 rather than change mesa-vdpau-drivers:i386
  MarkDelete mesa-vdpau-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mK Ib > FU=0
Investigating (0) mesa-vdpau-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib >
Broken mesa-vdpau-drivers:i386 Depends on libdrm-amdgpu1:i386 < none | 2.4.102-1ubuntu1~20.04.1 @un uH > (>= 2.4.100)
  Considering libdrm-amdgpu1:i386 1 as a solution to mesa-vdpau-drivers:i386 -1
  MarkKeep mesa-vdpau-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
  Holding Back mesa-vdpau-drivers:i386 rather than change libdrm-amdgpu1:i386
Investigating (0) libqt4-test:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-test:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqtcore4:amd64 39 as a solution to libqt4-test:amd64 -1
  Removing libqt4-test:amd64 rather than change libqtcore4:amd64
  MarkDelete libqt4-test:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libqtassistantclient4:amd64 < 4.6.3-7build1 @ii mK Ib >
Broken libqtassistantclient4:amd64 Depends on libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.8.1)
  Considering libqt4-network:amd64 3 as a solution to libqtassistantclient4:amd64 -1
  Removing libqtassistantclient4:amd64 rather than change libqt4-network:amd64
  MarkDelete libqtassistantclient4:amd64 < 4.6.3-7build1 @ii mK Ib > FU=0
Investigating (0) mesa-va-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib >
Broken mesa-va-drivers:i386 Depends on libdrm-amdgpu1:i386 < none | 2.4.102-1ubuntu1~20.04.1 @un uH > (>= 2.4.100)
  Considering libdrm-amdgpu1:i386 1 as a solution to mesa-va-drivers:i386 -1
  MarkKeep mesa-va-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
  Holding Back mesa-va-drivers:i386 rather than change libdrm-amdgpu1:i386
Investigating (0) libqt4-help:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken libqt4-help:amd64 Depends on libqt4-network:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-network:amd64 3 as a solution to libqt4-help:amd64 -1
  Removing libqt4-help:amd64 rather than change libqt4-network:amd64
  MarkDelete libqt4-help:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-radeon:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-radeon:amd64 -1
  Removing xserver-xorg-video-radeon:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (0) libedata-book-1.2-25:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib >
Broken libedata-book-1.2-25:amd64 Depends on libebackend-1.2-10:amd64 < 3.28.5-0ubuntu0.18.04.3 -> 3.36.4-0ubuntu1 @ii umU > (= 3.28.5-0ubuntu0.18.04.3)
  Considering libebackend-1.2-10:amd64 9 as a solution to libedata-book-1.2-25:amd64 -1
  Removing libedata-book-1.2-25:amd64 rather than change libebackend-1.2-10:amd64
  MarkDelete libedata-book-1.2-25:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib > FU=0
Investigating (0) libqbscore1.10:amd64 < 1.10.1+dfsg-1 @ii mK Ib >
Broken libqbscore1.10:amd64 Depends on qbs-common:amd64 < 1.10.1+dfsg-1 -> 1.13.1-2build1 @ii umU > (= 1.10.1+dfsg-1)
  Considering qbs-common:amd64 1 as a solution to libqbscore1.10:amd64 -1
  Removing libqbscore1.10:amd64 rather than change qbs-common:amd64
  MarkDelete libqbscore1.10:amd64 < 1.10.1+dfsg-1 @ii mK Ib > FU=0
Investigating (0) libpolkit-backend-1-0:amd64 < 0.105-20ubuntu0.18.04.5 @ii mK Ib >
Broken libpolkit-backend-1-0:amd64 Depends on libpolkit-gobject-1-0:amd64 < 0.105-20ubuntu0.18.04.5 -> 0.105-26ubuntu1 @ii umU > (= 0.105-20ubuntu0.18.04.5)
  Considering libpolkit-gobject-1-0:amd64 136 as a solution to libpolkit-backend-1-0:amd64 -2
  Removing libpolkit-backend-1-0:amd64 rather than change libpolkit-gobject-1-0:amd64
  MarkDelete libpolkit-backend-1-0:amd64 < 0.105-20ubuntu0.18.04.5 @ii mK Ib > FU=0
Investigating (0) libcupsmime1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib >
Broken libcupsmime1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
  Considering libcups2:amd64 355 as a solution to libcupsmime1:amd64 -2
  Removing libcupsmime1:amd64 rather than change libcups2:amd64
  MarkDelete libcupsmime1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
Investigating (0) system76-driver:amd64 < 20.04.30~1614370192~18.04~f560ee1~dev @ii mK Ib >
Broken system76-driver:amd64 Depends on linux-system76:amd64 < 5.3.0-7648.41~1586790036~18.04~600aeb5~dev @ii mR >
  Considering linux-system76:amd64 -1 as a solution to system76-driver:amd64 -2
  Removing system76-driver:amd64 rather than change linux-system76:amd64
  MarkDelete system76-driver:amd64 < 20.04.30~1614370192~18.04~f560ee1~dev @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-nouveau-hwe-16.04:amd64 < 3:14.1 @ii mK Ib >
Broken xserver-xorg-video-nouveau-hwe-16.04:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR >
  Considering xserver-xorg-video-nouveau:amd64 2 as a solution to xserver-xorg-video-nouveau-hwe-16.04:amd64 -2
  Removing xserver-xorg-video-nouveau-hwe-16.04:amd64 rather than change xserver-xorg-video-nouveau:amd64
  MarkDelete xserver-xorg-video-nouveau-hwe-16.04:amd64 < 3:14.1 @ii mK Ib > FU=0
Investigating (0) libpango1.0-0:amd64 < 1.40.14-1ubuntu0.1 @ii mK Ib >
Broken libpango1.0-0:amd64 Depends on libpango-1.0-0:amd64 < 1.40.14-1ubuntu0.1 -> 1.44.7-2ubuntu4 @ii umU > (= 1.40.14-1ubuntu0.1)
  Considering libpango-1.0-0:amd64 631 as a solution to libpango1.0-0:amd64 -2
  Removing libpango1.0-0:amd64 rather than change libpango-1.0-0:amd64
  MarkDelete libpango1.0-0:amd64 < 1.40.14-1ubuntu0.1 @ii mK Ib > FU=0
Investigating (0) libcupsppdc1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib >
Broken libcupsppdc1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
  Considering libcups2:amd64 355 as a solution to libcupsppdc1:amd64 -2
  Removing libcupsppdc1:amd64 rather than change libcups2:amd64
  MarkDelete libcupsppdc1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
Investigating (0) python3-pyqt4:amd64 < 4.12.1+dfsg-2 @ii mK Ib >
Broken python3-pyqt4:amd64 Depends on python3:amd64 < 3.6.7-1~18.04 -> 3.8.2-0ubuntu2 @ii umU > (< 3.7)
  Considering python3:amd64 497 as a solution to python3-pyqt4:amd64 -2
  Removing python3-pyqt4:amd64 rather than change python3:amd64
  MarkDelete python3-pyqt4:amd64 < 4.12.1+dfsg-2 @ii mK Ib > FU=0
Investigating (0) sni-qt:amd64 < 0.2.7+17.04.20170112-0ubuntu1 @ii mK Ib >
Broken sni-qt:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.7.3-1ubuntu3~)
  Considering libqtcore4:amd64 39 as a solution to sni-qt:amd64 -2
  Removing sni-qt:amd64 rather than change libqtcore4:amd64
  MarkDelete sni-qt:amd64 < 0.2.7+17.04.20170112-0ubuntu1 @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-intel-hwe-16.04:amd64 < 3:14.1 @ii mK Ib >
Broken xserver-xorg-video-intel-hwe-16.04:amd64 Depends on xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mR >
  Considering xserver-xorg-video-intel:amd64 2 as a solution to xserver-xorg-video-intel-hwe-16.04:amd64 -2
  Removing xserver-xorg-video-intel-hwe-16.04:amd64 rather than change xserver-xorg-video-intel:amd64
  MarkDelete xserver-xorg-video-intel-hwe-16.04:amd64 < 3:14.1 @ii mK Ib > FU=0
Investigating (0) libedata-cal-1.2-28:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib >
Broken libedata-cal-1.2-28:amd64 Depends on libebackend-1.2-10:amd64 < 3.28.5-0ubuntu0.18.04.3 -> 3.36.4-0ubuntu1 @ii umU > (= 3.28.5-0ubuntu0.18.04.3)
  Considering libebackend-1.2-10:amd64 9 as a solution to libedata-cal-1.2-28:amd64 -2
  Removing libedata-cal-1.2-28:amd64 rather than change libebackend-1.2-10:amd64
  MarkDelete libedata-cal-1.2-28:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-ati-hwe-16.04:amd64 < 3:14.1 @ii mK Ib >
Broken xserver-xorg-video-ati-hwe-16.04:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR >
  Considering xserver-xorg-video-ati:amd64 2 as a solution to xserver-xorg-video-ati-hwe-16.04:amd64 -2
  Removing xserver-xorg-video-ati-hwe-16.04:amd64 rather than change xserver-xorg-video-ati:amd64
  MarkDelete xserver-xorg-video-ati-hwe-16.04:amd64 < 3:14.1 @ii mK Ib > FU=0
Investigating (0) musescore:amd64 < 2.1.0+dfsg3-3build1 @ii mK Ib >
Broken musescore:amd64 Depends on libqt5core5a:amd64 < 5.9.5+dfsg-0ubuntu2.5 -> 5.12.8+dfsg-0ubuntu1 @ii umU > (< 5.10)
  Considering libqt5core5a:amd64 1559 as a solution to musescore:amd64 -2
  Removing musescore:amd64 rather than change libqt5core5a:amd64
  MarkDelete musescore:amd64 < 2.1.0+dfsg3-3build1 @ii mK Ib > FU=0
Investigating (0) libapt-inst2.0:amd64 < 1.6.12ubuntu0.2 @ii mK Ib >
Broken libapt-inst2.0:amd64 Depends on libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mR > (>= 1.1~exp9)
  Considering libapt-pkg5.0:amd64 -1 as a solution to libapt-inst2.0:amd64 -2
  Removing libapt-inst2.0:amd64 rather than change libapt-pkg5.0:amd64
  MarkDelete libapt-inst2.0:amd64 < 1.6.12ubuntu0.2 @ii mK Ib > FU=0
Investigating (0) libqt5organizer5:amd64 < 5.0~git20140515~29475884-0ubuntu24~7 @ii mK Ib >
Broken libqt5organizer5:amd64 Depends on qtbase-abi-5-9-5:amd64 < none @un H >
  Considering libqt5core5a:amd64 1559 as a solution to libqt5organizer5:amd64 -2
  Removing libqt5organizer5:amd64 rather than change qtbase-abi-5-9-5:amd64
  MarkDelete libqt5organizer5:amd64 < 5.0~git20140515~29475884-0ubuntu24~7 @ii mK Ib > FU=0
Investigating (0) libcupscgi1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib >
Broken libcupscgi1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
  Considering libcups2:amd64 355 as a solution to libcupscgi1:amd64 -2
  Removing libcupscgi1:amd64 rather than change libcups2:amd64
  MarkDelete libcupscgi1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
Investigating (0) libqbsqtprofilesetup1.10:amd64 < 1.10.1+dfsg-1 @ii mK Ib >
Broken libqbsqtprofilesetup1.10:amd64 Depends on libqbscore1.10:amd64 < 1.10.1+dfsg-1 @ii mR > (>= 1.10.0)
  Considering libqbscore1.10:amd64 -1 as a solution to libqbsqtprofilesetup1.10:amd64 -2
  Removing libqbsqtprofilesetup1.10:amd64 rather than change libqbscore1.10:amd64
  MarkDelete libqbsqtprofilesetup1.10:amd64 < 1.10.1+dfsg-1 @ii mK Ib > FU=0
Investigating (0) qt4-linguist-tools:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib >
Broken qt4-linguist-tools:amd64 Depends on libqt4-xml:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
  Considering libqt4-xml:amd64 5 as a solution to qt4-linguist-tools:amd64 -2
  Removing qt4-linguist-tools:amd64 rather than change libqt4-xml:amd64
  MarkDelete qt4-linguist-tools:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK Ib > FU=0
Investigating (0) libept1.5.0:amd64 < 1.1+nmu3build1 @ii mK Ib >
Broken libept1.5.0:amd64 Depends on libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mR > (>= 1.1~exp9)
  Considering libapt-pkg5.0:amd64 -1 as a solution to libept1.5.0:amd64 -2
  Removing libept1.5.0:amd64 rather than change libapt-pkg5.0:amd64
  MarkDelete libept1.5.0:amd64 < 1.1+nmu3build1 @ii mK Ib > FU=0
Investigating (0) libebook-1.2-19:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib >
Broken libebook-1.2-19:amd64 Depends on libedata-book-1.2-25:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mR > (= 3.28.5-0ubuntu0.18.04.3)
  Considering libedata-book-1.2-25:amd64 -1 as a solution to libebook-1.2-19:amd64 -2
  Removing libebook-1.2-19:amd64 rather than change libedata-book-1.2-25:amd64
  MarkDelete libebook-1.2-19:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib > FU=0
Investigating (0) python3-dbus.mainloop.qt:amd64 < 4.12.1+dfsg-2 @ii mK Ib >
Broken python3-dbus.mainloop.qt:amd64 Depends on python3:amd64 < 3.6.7-1~18.04 -> 3.8.2-0ubuntu2 @ii umU > (< 3.7)
  Considering python3:amd64 497 as a solution to python3-dbus.mainloop.qt:amd64 -2
  Removing python3-dbus.mainloop.qt:amd64 rather than change python3:amd64
  MarkDelete python3-dbus.mainloop.qt:amd64 < 4.12.1+dfsg-2 @ii mK Ib > FU=0
Investigating (1) xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii umU Ib >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR >
  Considering xserver-xorg-video-amdgpu:amd64 1 as a solution to xserver-xorg-video-all:amd64 6
  Added xserver-xorg-video-amdgpu:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR >
  Considering xserver-xorg-video-ati:amd64 2 as a solution to xserver-xorg-video-all:amd64 6
  Added xserver-xorg-video-ati:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR >
  Considering xserver-xorg-video-nouveau:amd64 2 as a solution to xserver-xorg-video-all:amd64 6
  Added xserver-xorg-video-nouveau:amd64 to the remove list
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-amdgpu:amd64
  MarkKeep xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-ati:amd64
  MarkKeep xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-nouveau:amd64
  MarkKeep xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR > FU=0
Investigating (1) libsensors5:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib >
Broken libsensors5:amd64 Depends on libsensors-config:amd64 < none | 1:3.6.0-2ubuntu1 @un uH >
  Considering libsensors-config:amd64 2 as a solution to libsensors5:amd64 5
  MarkKeep libsensors5:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib > FU=0
  Holding Back libsensors5:amd64 rather than change libsensors-config:amd64
Investigating (1) va-driver-all:i386 < none -> 2.7.0-2 @un uN Ib >
Broken va-driver-all:i386 Depends on i965-va-driver:i386 < none | 2.4.0-0ubuntu1 @un uH >
  Considering i965-va-driver:i386 -1 as a solution to va-driver-all:i386 5
  MarkKeep va-driver-all:i386 < none -> 2.7.0-2 @un uN Ib > FU=0
  Holding Back va-driver-all:i386 rather than change i965-va-driver:i386
Broken va-driver-all:i386 Depends on i965-va-driver-shaders:i386 < none | 2.4.0-1build1 @un uH >
  Considering i965-va-driver-shaders:i386 1 as a solution to va-driver-all:i386 5
  MarkKeep va-driver-all:i386 < none -> 2.7.0-2 @un uN Ib > FU=0
  Holding Back va-driver-all:i386 rather than change i965-va-driver-shaders:i386
  Or group keep for va-driver-all:i386
  MarkKeep va-driver-all:i386 < none -> 2.7.0-2 @un uN Ib > FU=0
Broken va-driver-all:i386 Depends on mesa-va-drivers:i386 < none | 20.2.6-0ubuntu0.20.04.1 @un uH >
  Considering mesa-va-drivers:i386 -1 as a solution to va-driver-all:i386 5
  Holding Back va-driver-all:i386 rather than change mesa-va-drivers:i386
Investigating (1) vdpau-driver-all:amd64 < 1.1.1-3ubuntu1 -> 1.3-1ubuntu2 @ii umU Ib >
Broken vdpau-driver-all:amd64 Depends on mesa-vdpau-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mR >
  Considering mesa-vdpau-drivers:amd64 -1 as a solution to vdpau-driver-all:amd64 4
  Added mesa-vdpau-drivers:amd64 to the remove list
  Fixing vdpau-driver-all:amd64 via keep of mesa-vdpau-drivers:amd64
  MarkKeep mesa-vdpau-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mR > FU=0
Investigating (1) xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-nouveau:amd64 2
  Removing xserver-xorg-video-nouveau:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
Investigating (1) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-ati:amd64 2
  Removing xserver-xorg-video-ati:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (1) lm-sensors:amd64 < 1:3.4.0-4 -> 1:3.6.0-2ubuntu1 @ii umU Ib >
Broken lm-sensors:amd64 Depends on libsensors5:amd64 < none | 1:3.6.0-2ubuntu1 @un uH > (>= 1:3.5.0)
  Considering libsensors5:amd64 5 as a solution to lm-sensors:amd64 1
  MarkKeep lm-sensors:amd64 < 1:3.4.0-4 -> 1:3.6.0-2ubuntu1 @ii umU Ib > FU=0
  Holding Back lm-sensors:amd64 rather than change libsensors5:amd64
Investigating (1) clang:amd64 < 1:6.0-41~exp5~ubuntu1 -> 1:10.0-50~exp1 @ii umU Ib >
Broken clang:amd64 Depends on clang-10:amd64 < none | 1:10.0.0-4ubuntu1 @un uH > (>= 10~)
  Considering clang-10:amd64 1 as a solution to clang:amd64 1
  MarkKeep clang:amd64 < 1:6.0-41~exp5~ubuntu1 -> 1:10.0-50~exp1 @ii umU Ib > FU=0
  Holding Back clang:amd64 rather than change clang-10:amd64
Investigating (1) libsnmp35:i386 < none -> 5.8+dfsg-2ubuntu2.3 @un uN Ib >
Broken libsnmp35:i386 Depends on libsensors5:i386 < none | 1:3.6.0-2ubuntu1 @un uH > (>= 1:3.5.0)
  Considering libsensors5:i386 0 as a solution to libsnmp35:i386 1
  MarkKeep libsnmp35:i386 < none -> 5.8+dfsg-2ubuntu2.3 @un uN Ib > FU=0
  Holding Back libsnmp35:i386 rather than change libsensors5:i386
Investigating (1) xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-amdgpu:amd64 1
  Removing xserver-xorg-video-amdgpu:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
Investigating (1) libwine:i386 < 3.0-1ubuntu1 -> 5.0-3ubuntu1 @ii umU NPb Ib >
Broken libwine:i386 Depends on libfaudio0:i386 < none | 20.04-2 @un uH > (>= 19.06.07)
  Considering libfaudio0:i386 1 as a solution to libwine:i386 1
  MarkKeep libwine:i386 < 3.0-1ubuntu1 -> 5.0-3ubuntu1 @ii umU NPb Ib > FU=0
  Removing libwine:i386 rather than change libfaudio0:i386
  MarkDelete libwine:i386 < 3.0-1ubuntu1 | 5.0-3ubuntu1 @ii umH NPb Ib > FU=0
Investigating (1) vdpau-driver-all:i386 < none -> 1.3-1ubuntu2 @un uN Ib >
Broken vdpau-driver-all:i386 Depends on mesa-vdpau-drivers:i386 < none | 20.2.6-0ubuntu0.20.04.1 @un uH >
  Considering mesa-vdpau-drivers:i386 -1 as a solution to vdpau-driver-all:i386 1
  MarkKeep vdpau-driver-all:i386 < none -> 1.3-1ubuntu2 @un uN Ib > FU=0
  Holding Back vdpau-driver-all:i386 rather than change mesa-vdpau-drivers:i386
Investigating (1) wine32:i386 < 3.0-1ubuntu1 -> 5.0-3ubuntu1 @ii umU Ib >
Broken wine32:i386 Depends on libwine:i386 < 3.0-1ubuntu1 | 5.0-3ubuntu1 @ii umR NPb > (= 5.0-3ubuntu1)
  Considering libwine:i386 1 as a solution to wine32:i386 0
  MarkKeep wine32:i386 < 3.0-1ubuntu1 -> 5.0-3ubuntu1 @ii umU Ib > FU=0
  Removing wine32:i386 rather than change libwine:i386
  MarkDelete wine32:i386 < 3.0-1ubuntu1 | 5.0-3ubuntu1 @ii umH Ib > FU=0
 Try to Re-Instate (1) libboost-dev:amd64
  MarkKeep libboost-dev:amd64 < 1.65.1.0ubuntu1 -> 1.71.0.0ubuntu2 @ii umU Ib > FU=0
Investigating (1) libsensors4-dev:amd64 < 1:3.4.0-4 -> 1:3.6.0-2ubuntu1 @ii umU Ib >
Broken libsensors4-dev:amd64 Depends on libsensors5:amd64 < none | 1:3.6.0-2ubuntu1 @un uH > (= 1:3.6.0-2ubuntu1)
  Considering libsensors5:amd64 5 as a solution to libsensors4-dev:amd64 -1
  MarkKeep libsensors4-dev:amd64 < 1:3.4.0-4 -> 1:3.6.0-2ubuntu1 @ii umU Ib > FU=0
  Holding Back libsensors4-dev:amd64 rather than change libsensors5:amd64
Investigating (2) libsnmp35:amd64 < none -> 5.8+dfsg-2ubuntu2.3 @un uN Ib >
Broken libsnmp35:amd64 Depends on libsensors5:amd64 < none | 1:3.6.0-2ubuntu1 @un uH > (>= 1:3.5.0)
  Considering libsensors5:amd64 5 as a solution to libsnmp35:amd64 12
  MarkKeep libsnmp35:amd64 < none -> 5.8+dfsg-2ubuntu2.3 @un uN Ib > FU=0
  Holding Back libsnmp35:amd64 rather than change libsensors5:amd64
Investigating (2) libhpmud0:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib >
Broken libhpmud0:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un uH > (>= 5.8+dfsg)
  Considering libsnmp35:amd64 12 as a solution to libhpmud0:amd64 6
  MarkKeep libhpmud0:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
  Holding Back libhpmud0:amd64 rather than change libsnmp35:amd64
Investigating (2) xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii umU Ib >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR >
  Considering xserver-xorg-video-amdgpu:amd64 1 as a solution to xserver-xorg-video-all:amd64 6
  Added xserver-xorg-video-amdgpu:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR >
  Considering xserver-xorg-video-ati:amd64 2 as a solution to xserver-xorg-video-all:amd64 6
  Added xserver-xorg-video-ati:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR >
  Considering xserver-xorg-video-nouveau:amd64 2 as a solution to xserver-xorg-video-all:amd64 6
  Added xserver-xorg-video-nouveau:amd64 to the remove list
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-amdgpu:amd64
  MarkKeep xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-ati:amd64
  MarkKeep xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-nouveau:amd64
  MarkKeep xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR > FU=0
Investigating (2) xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-nouveau:amd64 6
  Removing xserver-xorg-video-nouveau:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
Investigating (2) libsane:i386 < none -> 1.0.29-0ubuntu5.2 @un uN Ib >
Broken libsane:i386 Depends on libsnmp35:i386 < none | 5.8+dfsg-2ubuntu2.3 @un uH > (>= 5.8+dfsg)
  Considering libsnmp35:i386 1 as a solution to libsane:i386 2
  MarkKeep libsane:i386 < none -> 1.0.29-0ubuntu5.2 @un uN Ib > FU=0
  Holding Back libsane:i386 rather than change libsnmp35:i386
Investigating (2) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-ati:amd64 6
  Removing xserver-xorg-video-ati:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (2) hplip:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib >
Broken hplip:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH > (= 3.20.3+dfsg0-2)
  Considering libhpmud0:amd64 6 as a solution to hplip:amd64 2
  MarkKeep hplip:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
  Removing hplip:amd64 rather than change libhpmud0:amd64
  MarkDelete hplip:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH Ib > FU=0
Investigating (2) libsane-hpaio:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib >
Broken libsane-hpaio:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH > (>= 3.20.3+dfsg0)
  Considering libhpmud0:amd64 6 as a solution to libsane-hpaio:amd64 2
  MarkKeep libsane-hpaio:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
  Holding Back libsane-hpaio:amd64 rather than change libhpmud0:amd64
Investigating (2) printer-driver-hpcups:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib >
Broken printer-driver-hpcups:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH > (>= 3.20.3+dfsg0)
  Considering libhpmud0:amd64 6 as a solution to printer-driver-hpcups:amd64 2
  MarkKeep printer-driver-hpcups:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
  Holding Back printer-driver-hpcups:amd64 rather than change libhpmud0:amd64
 Try to Re-Instate (2) lm-sensors:amd64
  MarkKeep lm-sensors:amd64 < 1:3.4.0-4 -> 1:3.6.0-2ubuntu1 @ii umU Ib > FU=0
 Try to Re-Instate (2) clang:amd64
  MarkKeep clang:amd64 < 1:6.0-41~exp5~ubuntu1 -> 1:10.0-50~exp1 @ii umU Ib > FU=0
Investigating (2) xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 28 as a solution to xserver-xorg-video-amdgpu:amd64 6
  Removing xserver-xorg-video-amdgpu:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
Investigating (2) libsane1:i386 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib >
Broken libsane1:i386 Depends on libsane:i386 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.29-0ubuntu5.2)
  Considering libsane:i386 2 as a solution to libsane1:i386 0
  MarkKeep libsane1:i386 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
  Removing libsane1:i386 rather than change libsane:i386
  MarkDelete libsane1:i386 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umH Ib > FU=0
Investigating (2) libsnmp-dev:amd64 < 5.7.3+dfsg-1.8ubuntu3.6 -> 5.8+dfsg-2ubuntu2.3 @ii umU Ib >
Broken libsnmp-dev:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un uH > (= 5.8+dfsg-2ubuntu2.3)
  Considering libsnmp35:amd64 12 as a solution to libsnmp-dev:amd64 0
  MarkKeep libsnmp-dev:amd64 < 5.7.3+dfsg-1.8ubuntu3.6 -> 5.8+dfsg-2ubuntu2.3 @ii umU Ib > FU=0
  Holding Back libsnmp-dev:amd64 rather than change libsnmp35:amd64
 Try to Re-Instate (2) libsensors4-dev:amd64
  MarkKeep libsensors4-dev:amd64 < 1:3.4.0-4 -> 1:3.6.0-2ubuntu1 @ii umU Ib > FU=0
Investigating (3) libsane:amd64 < none -> 1.0.29-0ubuntu5.2 @un uN Ib >
Broken libsane:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un uH > (>= 5.8+dfsg)
  Considering libsnmp35:amd64 12 as a solution to libsane:amd64 16
  MarkKeep libsane:amd64 < none -> 1.0.29-0ubuntu5.2 @un uN Ib > FU=0
  Holding Back libsane:amd64 rather than change libsnmp35:amd64
Investigating (3) sane-utils:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib >
Broken sane-utils:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.27)
  Considering libsane:amd64 16 as a solution to sane-utils:amd64 12
  MarkKeep sane-utils:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
  Holding Back sane-utils:amd64 rather than change libsane:amd64
 Try to Re-Instate (3) libhpmud0:amd64
  MarkKeep libhpmud0:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
Investigating (3) xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii umU Ib >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR >
  Considering xserver-xorg-video-amdgpu:amd64 28 as a solution to xserver-xorg-video-all:amd64 6
  MarkKeep xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii umU Ib > FU=0
  Removing xserver-xorg-video-all:amd64 rather than change xserver-xorg-video-amdgpu:amd64
  MarkDelete xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 | 1:7.7+19ubuntu14 @ii umH Ib > FU=0
Investigating (3) xsane:amd64 < 0.999-5ubuntu2 -> 0.999-8ubuntu2.1 @ii umU Ib >
Broken xsane:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.24)
  Considering libsane:amd64 16 as a solution to xsane:amd64 2
  MarkKeep xsane:amd64 < 0.999-5ubuntu2 -> 0.999-8ubuntu2.1 @ii umU Ib > FU=0
  Removing xsane:amd64 rather than change libsane:amd64
  MarkDelete xsane:amd64 < 0.999-5ubuntu2 | 0.999-8ubuntu2.1 @ii umH Ib > FU=0
 Try to Re-Instate (3) libsane-hpaio:amd64
  MarkKeep libsane-hpaio:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
 Try to Re-Instate (3) printer-driver-hpcups:amd64
  MarkKeep printer-driver-hpcups:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
Investigating (3) libsane1:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib >
Broken libsane1:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.29-0ubuntu5.2)
  Considering libsane:amd64 16 as a solution to libsane1:amd64 0
  MarkKeep libsane1:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
  Removing libsane1:amd64 rather than change libsane:amd64
  MarkDelete libsane1:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umH Ib > FU=0
 Try to Re-Instate (3) libsnmp-dev:amd64
  MarkKeep libsnmp-dev:amd64 < 5.7.3+dfsg-1.8ubuntu3.6 -> 5.8+dfsg-2ubuntu2.3 @ii umU Ib > FU=0
Investigating (3) simple-scan:amd64 < 3.28.0-0ubuntu1 -> 3.36.3-0ubuntu0.20.04.0 @ii umU Ib >
Broken simple-scan:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.24)
  Considering libsane:amd64 16 as a solution to simple-scan:amd64 0
  MarkKeep simple-scan:amd64 < 3.28.0-0ubuntu1 -> 3.36.3-0ubuntu0.20.04.0 @ii umU Ib > FU=0
  Removing simple-scan:amd64 rather than change libsane:amd64
  MarkDelete simple-scan:amd64 < 3.28.0-0ubuntu1 | 3.36.3-0ubuntu0.20.04.0 @ii umH Ib > FU=0
Investigating (3) libsane-dev:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib >
Broken libsane-dev:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (= 1.0.29-0ubuntu5.2)
  Considering libsane:amd64 16 as a solution to libsane-dev:amd64 0
  MarkKeep libsane-dev:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
  Removing libsane-dev:amd64 rather than change libsane:amd64
  MarkDelete libsane-dev:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umH Ib > FU=0
Investigating (3) xserver-xorg-video-all-hwe-16.04:amd64 < 3:14.1 @ii mK Ib >
Broken xserver-xorg-video-all-hwe-16.04:amd64 Depends on xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 | 1:7.7+19ubuntu14 @ii umR >
  Considering xserver-xorg-video-all:amd64 28 as a solution to xserver-xorg-video-all-hwe-16.04:amd64 -2
  Removing xserver-xorg-video-all-hwe-16.04:amd64 rather than change xserver-xorg-video-all:amd64
  MarkDelete xserver-xorg-video-all-hwe-16.04:amd64 < 3:14.1 @ii mK Ib > FU=0
Investigating (4) colord:amd64 < 1.3.3-2build1 -> 1.4.4-2 @ii umU Ib >
Broken colord:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.24)
  Considering libsane:amd64 16 as a solution to colord:amd64 27
  Added libsane:amd64 to the remove list
  Fixing colord:amd64 via keep of libsane:amd64
 Try to Re-Instate (4) sane-utils:amd64
  MarkKeep sane-utils:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
Investigating (4) sane-utils:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umH Ib >
Broken sane-utils:amd64 Depends on libsane1:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umR > (>= 1.0.27)
  Considering libsane1:amd64 16 as a solution to sane-utils:amd64 12
  Removing sane-utils:amd64 rather than change libsane1:amd64
  MarkDelete sane-utils:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umH Ib > FU=0
Investigating (5) colord:amd64 < 1.3.3-2build1 -> 1.4.4-2 @ii umU Ib >
Broken colord:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.24)
  Considering libsane:amd64 27 as a solution to colord:amd64 27
  MarkKeep colord:amd64 < 1.3.3-2build1 -> 1.4.4-2 @ii umU Ib > FU=0
  Removing colord:amd64 rather than change libsane:amd64
  MarkDelete colord:amd64 < 1.3.3-2build1 | 1.4.4-2 @ii umH Ib > FU=0
Done
  MarkInstall xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii ugU Ib > FU=1
  Installing xserver-xorg-video-amdgpu as Depends of xserver-xorg-video-all
      MarkKeep xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii gR > FU=0
  Installing xserver-xorg-video-ati as Depends of xserver-xorg-video-all
      MarkKeep xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii gR > FU=0
  Installing xserver-xorg-video-nouveau as Depends of xserver-xorg-video-all
      MarkKeep xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii gR > FU=0
  previously satisfied important dependency on xserver-xorg-video-intel:amd64
  Installing xserver-xorg-video-intel as Recommends of xserver-xorg-video-all
      MarkKeep xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii gR > FU=0
Starting pkgProblemResolver with broken count: 4
Starting 2 pkgProblemResolver with broken count: 4
Investigating (0) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 27 as a solution to xserver-xorg-video-ati:amd64 0
  Removing xserver-xorg-video-ati:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 27 as a solution to xserver-xorg-video-intel:amd64 0
  Removing xserver-xorg-video-intel:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 27 as a solution to xserver-xorg-video-nouveau:amd64 0
  Removing xserver-xorg-video-nouveau:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 27 as a solution to xserver-xorg-video-amdgpu:amd64 0
  Removing xserver-xorg-video-amdgpu:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
Investigating (1) xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii pumU Ib >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR >
  Considering xserver-xorg-video-amdgpu:amd64 0 as a solution to xserver-xorg-video-all:amd64 10005
  Added xserver-xorg-video-amdgpu:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR >
  Considering xserver-xorg-video-ati:amd64 0 as a solution to xserver-xorg-video-all:amd64 10005
  Added xserver-xorg-video-ati:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR >
  Considering xserver-xorg-video-nouveau:amd64 0 as a solution to xserver-xorg-video-all:amd64 10005
  Added xserver-xorg-video-nouveau:amd64 to the remove list
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-amdgpu:amd64
  MarkKeep xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-ati:amd64
  MarkKeep xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-nouveau:amd64
  MarkKeep xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR > FU=0
Investigating (1) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 27 as a solution to xserver-xorg-video-ati:amd64 0
  Removing xserver-xorg-video-ati:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (1) xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 27 as a solution to xserver-xorg-video-nouveau:amd64 0
  Removing xserver-xorg-video-nouveau:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
Investigating (1) xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 27 as a solution to xserver-xorg-video-amdgpu:amd64 0
  Removing xserver-xorg-video-amdgpu:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
Investigating (2) xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii pumU Ib >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR >
  Considering xserver-xorg-video-amdgpu:amd64 0 as a solution to xserver-xorg-video-all:amd64 10005
  Added xserver-xorg-video-amdgpu:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR >
  Considering xserver-xorg-video-ati:amd64 0 as a solution to xserver-xorg-video-all:amd64 10005
  Added xserver-xorg-video-ati:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR >
  Considering xserver-xorg-video-nouveau:amd64 0 as a solution to xserver-xorg-video-all:amd64 10005
  Added xserver-xorg-video-nouveau:amd64 to the remove list
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-amdgpu:amd64
  MarkKeep xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-ati:amd64
  MarkKeep xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-nouveau:amd64
  MarkKeep xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR > FU=0
Investigating (2) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 27 as a solution to xserver-xorg-video-ati:amd64 10005
  Added xserver-xorg-core:amd64 to the remove list
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii gR >
  Considering xserver-xorg-video-radeon:amd64 1 as a solution to xserver-xorg-video-ati:amd64 10005
  Added xserver-xorg-video-radeon:amd64 to the remove list
  Fixing xserver-xorg-video-ati:amd64 via keep of xserver-xorg-core:amd64
  MarkKeep xserver-xorg-core:amd64 < 2:1.19.6-1ubuntu4.8 -> 2:1.20.9-2ubuntu1.2~20.04.1 @ii umU > FU=0
  Fixing xserver-xorg-video-ati:amd64 via keep of xserver-xorg-video-radeon:amd64
  MarkKeep xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii gR > FU=0
 Try to Re-Instate (3) xserver-xorg-core:amd64
Re-Instated xserver-xorg-core:amd64 (4 vs 4)
Investigating (3) xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii gK Ib >
Broken xserver-xorg-video-radeon:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 10005 as a solution to xserver-xorg-video-radeon:amd64 10005
  Removing xserver-xorg-video-radeon:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii gK Ib > FU=0
Investigating (3) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 10005 as a solution to xserver-xorg-video-ati:amd64 10005
  Removing xserver-xorg-video-ati:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (3) xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 10005 as a solution to xserver-xorg-video-nouveau:amd64 10005
  Removing xserver-xorg-video-nouveau:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
Investigating (3) xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 10005 as a solution to xserver-xorg-video-amdgpu:amd64 10005
  Removing xserver-xorg-video-amdgpu:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
Investigating (4) xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii pumU Ib >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR >
  Considering xserver-xorg-video-amdgpu:amd64 10005 as a solution to xserver-xorg-video-all:amd64 10005
  Considering xserver-xorg-video-amdgpu:amd64 10005 as a solution to xserver-xorg-video-all:amd64 10005
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR >
  Considering xserver-xorg-video-ati:amd64 10005 as a solution to xserver-xorg-video-all:amd64 10005
  Considering xserver-xorg-video-ati:amd64 10005 as a solution to xserver-xorg-video-all:amd64 10005
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR >
  Considering xserver-xorg-video-nouveau:amd64 10005 as a solution to xserver-xorg-video-all:amd64 10005
  Considering xserver-xorg-video-nouveau:amd64 10005 as a solution to xserver-xorg-video-all:amd64 10005
Done
Log time: 2021-03-24 09:06:50.630635

Your reply happened while I was composing my last post. Here is the answer to your questions:

$ grep oibaf /etc/apt/sources.list /etc/apt/sources.list.d/*.list
/etc/apt/sources.list.d/oibaf-ubuntu-graphics-drivers-bionic.list:deb http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu bionic main
/etc/apt/sources.list.d/oibaf-ubuntu-graphics-drivers-bionic.list:# deb-src http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu bionic main
$ dpkg -l | grep oibaf
ii libdrm-amdgpu1:amd64 2.4.102+git2010051830.5de99a~oibaf~b amd64 Userspace interface to amdgpu-specific kernel DRM services -- runtime
ii libdrm-common 2.4.102+git2010051830.5de99a~oibaf~b all Userspace interface to kernel DRM services -- common files
ii libdrm-dev:amd64 2.4.102+git2010051830.5de99a~oibaf~b amd64 Userspace interface to kernel DRM services -- development files
ii libdrm-intel1:amd64 2.4.102+git2010051830.5de99a~oibaf~b amd64 Userspace interface to intel-specific kernel DRM services -- runtime
ii libdrm-nouveau2:amd64 2.4.102+git2010051830.5de99a~oibaf~b amd64 Userspace interface to nouveau-specific kernel DRM services -- runtime
ii libdrm-radeon1:amd64 2.4.102+git2010051830.5de99a~oibaf~b amd64 Userspace interface to radeon-specific kernel DRM services -- runtime
ii libdrm2:amd64 2.4.102+git2010051830.5de99a~oibaf~b amd64 Userspace interface to kernel DRM services -- runtime
ii libegl-dev:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- EGL development files
ii libegl-mesa0:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 free implementation of the EGL API -- Mesa vendor library
ii libegl1:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- EGL support
ii libegl1-mesa:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 transitional dummy package
ii libegl1-mesa-dev:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 free implementation of the EGL API -- development files
ii libgbm1:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 generic buffer management API -- runtime
ii libgl-dev:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- GL development files
ii libgl1:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- legacy GL support
ii libgl1-mesa-dev:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 transitional dummy package
ii libgl1-mesa-dri:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 free implementation of the OpenGL API -- DRI modules
ii libgl1-mesa-glx:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 transitional dummy package
ii libglapi-mesa:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 free implementation of the GL API -- shared library
ii libgles-dev:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- GLES development files
ii libgles1:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- GLESv1 support
ii libgles2:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- GLESv2 support
ii libgles2-mesa-dev:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 transitional dummy package
ii libglvnd-dev:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- development files
ii libglvnd0:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library
ii libglx-dev:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- GLX development files
ii libglx-mesa0:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 free implementation of the OpenGL API -- GLX vendor library
ii libglx0:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- GLX support
ii libllvm10:amd64 1:10.0.1-1~oibaf~b amd64 Modular compiler and toolchain technologies, runtime library
ii libopengl-dev:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- OpenGL development files
ii libopengl0:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- OpenGL support
ii libwayland-egl1-mesa:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 transitional dummy package
ii libxatracker2:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 X acceleration library -- runtime
ii mesa-common-dev:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 Developer documentation for Mesa
ii mesa-va-drivers:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 Mesa VA-API video acceleration drivers
ii mesa-vdpau-drivers:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 Mesa VDPAU video acceleration drivers
ii xserver-xorg-video-amdgpu 19.1.0+git2009151930.6bd3dc~oibaf~b amd64 X.Org X server -- AMDGPU display driver
ii xserver-xorg-video-ati 1:19.1.0+git2009161930.8da3e4~oibaf~b amd64 X.Org X server -- AMD/ATI display driver wrapper
ii xserver-xorg-video-intel 2:2.99.917+git2005251930.5ca3ac~oibaf~b amd64 X.Org X server -- Intel i8xx, i9xx display driver
ii xserver-xorg-video-nouveau 1:1.0.16+git2009230730.7212a2~oibaf~b amd64 X.Org X server -- Nouveau display driver
ii xserver-xorg-video-radeon 1:19.1.0+git2009161930.8da3e4~oibaf~b amd64 X.Org X server -- AMD/ATI Radeon display driver

Can I compose some sort of script to remove all of these packages? What happens if I do - will my system be damaged?

@Manfred: I re-read your last post and you said "revert" not "remove". So, are you saying that I have to somehow replace all these packages with something that is "official"? That seems like a rather daunting task, to say the least.

Manfred Hampl (m-hampl) said : #11

1. General advice:
Be prepared for whatever might happen. You should care for a backup of your important files, such that you can restore them in case that the upgrade fails in a manner that the system stops working and has to be rebuilt from scratch.

2. You should consider the effort needed as well as other pros and cons of a clean new installation for Ubuntu 20.04 LTS versus an upgrade.

3. It seems to me that the key is the package xserver-xorg-video-all
What is the output of the command
apt-cache policy xserver-xorg-video-all

If I wanted to just wipe the system and reinstall fresh, I would have done that already ;-) That is what happened when I tried to upgrade from 16.04 to 18.04 but this time I am trying to get to the root of the issue. Besides, what good is a tool called "do-release-upgrade" that doesn't even work for every case?

I also have my OS and working files partitioned apart in case I do have to go with the "nuclear option"!

So, I am trying to figure out the actual root cause of the issue so that

  a. If it is because of something I did, I don't want to do it in the future, and

  b. If there is an underlying problem, it is identified so that it can be addressed in the future.

$ apt-cache policy xserver-xorg-video-all
xserver-xorg-video-all:
  Installed: 1:7.7+19ubuntu7.1
  Candidate: 1:7.7+19ubuntu7.1
  Version table:
 *** 1:7.7+19ubuntu7.1 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1:7.7+19ubuntu7 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

Manfred Hampl (m-hampl) said : #13

Going through the list of packages with conflicts it seems to me that there are even more foreign packages.

What is the output of the commands

uname -a
lsb_release -crid

$ uname -a
Linux <omitted> 5.3.0-7648-generic #41~1586790036~18.04~600aeb5~dev-Ubuntu SMP Mon Apr 13 17:49:24 x86_64 x86_64 x86_64 GNU/Linux
$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 18.04.5 LTS
Release: 18.04
Codename: bionic
$

Manfred Hampl (m-hampl) said : #15

Your system is too much deviating from a standard Ubuntu bionic system.

Your system does not have the package ubuntu-desktop, but linux-system76 and packages like gnome-settings-daemon-schemas version 3.28.1-0ubuntu1.3pop0~156589989

This looks like Pop!_OS

We cannot help with that.

What is the output of:

head /etc/apt/sources.list

Thanks

$ head /etc/apt/sources.list
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://ca.archive.ubuntu.com/ubuntu/ bionic main restricted
# deb-src http://ca.archive.ubuntu.com/ubuntu/ bionic main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://ca.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
# deb-src http://ca.archive.ubuntu.com/ubuntu/ bionic-updates main restricted

$

Manfred Hampl (m-hampl) said : #18

Your log shows
2021-03-23 17:22:31,384 INFO Using config files '['./DistUpgrade.cfg.bionic', '/etc/update-manager/release-upgrades.d/system76-third-party-mirrors.cfg']'

That is another foreign file that interferes with the upgrade.

Ask system76 for advice!

OK, so I need to make sure I purge all the system76 packages. I assume that ppa-purge doesn't work if the ppa isn't installed so first, I attempted to put all the system76 packages in again:
sudo add-apt-repository ppa:system76-dev/stable
sudo apt update
sudo apt upgrade
sudo apt dist-upgrade

This seemed to have worked OK, the System76 stuff is now back in.

Now I tried to remove it using ppa-purge:
$ sudo apt remove system76-driver --purge
$ sudo apt autoremove

sudo ppa-purge ppa:system76-dev/stable

Howerver, during ppa-purge, the system barfed on trying to remove the running kernel:
"You are running a kernel (version 5.3.0-7648-generic) and attempting to remove the same version."
So, I aborted the process and rebooted to an earlier kernel.

After rebooting, I see:
$ uname -r
5.3.0-7642-generic

No problems there. Then, I uncommented the ppa line in the system76 ppa and tried the ppa-purge process again. This time it seemed to have worked: "PPA purged successfully"!

OK. So now I tried do-release-upgrade again. Now the following is happening (from main.log):
2021-04-02 18:12:02,087 DEBUG Marking 'ubuntu-desktop' for upgrade
2021-04-02 18:12:02,783 WARNING Can't mark 'ubuntu-desktop' for upgrade (E:Unable to correct problems, you have held broken packages.)
2021-04-02 18:12:04,802 ERROR Dist-upgrade failed: 'Broken packages after upgrade: ubuntu-desktop'

Looking at apt.log agaion, there are no more references to "system76" anywhere so that suspected cause can now be ruled out.

The first indication of a problem in apt.log seems to be here:

  MarkInstall clang:amd64 < 1:6.0-41~exp5~ubuntu1 -> 1:10.0-50~exp1 @ii umU Ib > FU=0
  Installing clang-10 as Depends of clang
    MarkInstall clang-10:amd64 < none -> 1:10.0.0-4ubuntu1 @un uN Ib > FU=0
    Installing libclang-cpp10 as Depends of clang-10
      libclang-cpp10:amd64 Depends on libllvm10:amd64 < 1:10.0.1-1~oibaf~b @ii mK > (= 1:10.0.0-4ubuntu1) can't be satisfied!

This must be the "oibaf" ppa you mentioned previously. The problem I am having is that ppa-purge doesn't work:

$ sudo ppa-purge ppa:oibaf/graphics-drivers
Updating packages lists
PPA to be removed: oibaf graphics-drivers
Warning: Could not find package list for PPA: oibaf graphics-drivers
$

When I looked online for ppa:oibaf/graphics-drivers, it appears that the packages in this ppa are no longer available for Bionic. I really have no idea what "ppa-purge" does specifically but what if the ppa is no longer available on the server? Is that why ppa-purge didn't work? Is there a way to get the missing package list somewhere else? If I can get hold of this list, where should it be located on my system and how can I get ppa-purge to use this specially-obtained list?

Barring that, is it possible to just force a re-installation of the official packages that was altered when the ppa:/oibaf/graphics-drivers was installed? Is there a way to find out from the logs which packages need to be re-installed?

Now, from what I understand, there are "official" packages and packages that came from a ppa. It seems that do-release-upgrade is unable to figure out what the official packages are required in the next release for a subset of the packages that are installed in my system. Do I have the right idea?

So, in summary, what I am trying to find out are the answers to these questions:

1. How do I read and correctly interpret the entries in apt.log to be able to understand what is actually going on?
2. How do I find out which packages need to be restored to the "official" version?
3. How do I find out the official name of the required package?
4. How do I use apt or dpkg to replace all these packages with the official versions?
5. Is there a way to find out how to install a meta-package or some global package that includes the broken packages and restores them to the official versions? Maybe I can remove this package and re-install it again.
6. Is there a way to get the missing package list so I can automate this by somehow getting ppa-purge (or an equivalent tool) to read this list and restore all the official packages and remove the incorrect ones?

Manfred Hampl (m-hampl) said : #20

Run the command

dpkg -l | grep oibaf

to see a list of packages that were installed from ppa:/oibaf/graphics-drivers (or potentially from another PPA by oibaf)

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-================================================================-===================================================-============-=====================================================================================================================================================================================================================
ii libdrm-amdgpu1:amd64 2.4.102+git2010051830.5de99a~oibaf~b amd64 Userspace interface to amdgpu-specific kernel DRM services -- runtime
ii libdrm-common 2.4.102+git2010051830.5de99a~oibaf~b all Userspace interface to kernel DRM services -- common files
ii libdrm-dev:amd64 2.4.102+git2010051830.5de99a~oibaf~b amd64 Userspace interface to kernel DRM services -- development files
ii libdrm-intel1:amd64 2.4.102+git2010051830.5de99a~oibaf~b amd64 Userspace interface to intel-specific kernel DRM services -- runtime
ii libdrm-nouveau2:amd64 2.4.102+git2010051830.5de99a~oibaf~b amd64 Userspace interface to nouveau-specific kernel DRM services -- runtime
ii libdrm-radeon1:amd64 2.4.102+git2010051830.5de99a~oibaf~b amd64 Userspace interface to radeon-specific kernel DRM services -- runtime
ii libdrm2:amd64 2.4.102+git2010051830.5de99a~oibaf~b amd64 Userspace interface to kernel DRM services -- runtime
ii libegl-dev:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- EGL development files
ii libegl-mesa0:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 free implementation of the EGL API -- Mesa vendor library
ii libegl1:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- EGL support
ii libegl1-mesa:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 transitional dummy package
ii libegl1-mesa-dev:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 free implementation of the EGL API -- development files
ii libgbm1:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 generic buffer management API -- runtime
ii libgl-dev:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- GL development files
ii libgl1:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- legacy GL support
ii libgl1-mesa-dev:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 transitional dummy package
ii libgl1-mesa-dri:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 free implementation of the OpenGL API -- DRI modules
ii libgl1-mesa-glx:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 transitional dummy package
ii libglapi-mesa:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 free implementation of the GL API -- shared library
ii libgles-dev:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- GLES development files
ii libgles1:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- GLESv1 support
ii libgles2:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- GLESv2 support
ii libgles2-mesa-dev:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 transitional dummy package
ii libglvnd-dev:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- development files
ii libglvnd0:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library
ii libglx-dev:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- GLX development files
ii libglx-mesa0:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 free implementation of the OpenGL API -- GLX vendor library
ii libglx0:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- GLX support
ii libllvm10:amd64 1:10.0.1-1~oibaf~b amd64 Modular compiler and toolchain technologies, runtime library
ii libopengl-dev:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- OpenGL development files
ii libopengl0:amd64 1.3.2-1~oibaf~b amd64 Vendor neutral GL dispatch library -- OpenGL support
ii libwayland-egl1-mesa:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 transitional dummy package
ii libxatracker2:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 X acceleration library -- runtime
ii mesa-common-dev:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 Developer documentation for Mesa
ii mesa-va-drivers:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 Mesa VA-API video acceleration drivers
ii mesa-vdpau-drivers:amd64 20.3~git2010060730.2b977a~oibaf~b amd64 Mesa VDPAU video acceleration drivers
ii xserver-xorg-video-ati 1:19.1.0+git2009161930.8da3e4~oibaf~b amd64 X.Org X server -- AMD/ATI display driver wrapper
ii xserver-xorg-video-intel 2:2.99.917+git2005251930.5ca3ac~oibaf~b amd64 X.Org X server -- Intel i8xx, i9xx display driver
ii xserver-xorg-video-nouveau 1:1.0.16+git2009230730.7212a2~oibaf~b amd64 X.Org X server -- Nouveau display driver
ii xserver-xorg-video-radeon 1:19.1.0+git2009161930.8da3e4~oibaf~b amd64 X.Org X server -- AMD/ATI Radeon display driver

So, how can I make use of this output to replace the "oibaf" packages with the correct official packages?

Do I just remove these in one fell swoop? Will that break my system? Can I be selective? How do I figure out how to pick the right packages to remove first? If a package is depended upon by another package, how do I find out what the "parent" package is so I can remove that and replace it with the "official" package?

How can I make sure any packages in this output are not needed at all and can just be removed?

Where do I start?

Manfred Hampl (m-hampl) said : #23

At least some of the packages are required for running our system (they provide the video driver for your display), so you should not uninstall them, but replace them with the "standard" version from the Ubuntu repositories. There is no list that would indicate which package is required and which isn't, because the packages necessary for running your system might differ, e.g. between a server and a desktop system.

Your output in comment #19 above shows a dependency problem with clang. As far as I know, clang ad related packages are optional and can be removed without consequences for running the system.

I suggest running
sudo apt purge clang clang-10 libclang-cpp10
sudo apt --purge autoremove

And then a possible way to proceed with the oibaf packages:

1. Usually all packages with "-dev" at the end of the name are not required for running the system, but only for development of other software. They are candidates for deletion.

What is the output of the command
apt --simulate purge libegl-dev libgl-dev libgles-dev libglvnd-dev libglx-dev libopengl-dev libdrm-dev libegl1-mesa-dev libgl1-mesa-dev libgles2-mesa-dev mesa-common-dev

2. For the other packages:
Let's start with the packages that have "1.3.2-1~oibaf~b" as their version string in the listing. They most probably come from the same source package in the Ubuntu repository and so it would probably best to deal with them at once.
Take one of them (e.g. libgl1) and issue the command
apt-cache policy libgl1
The output shows that the standard package version is 1.0.0-2ubuntu2.3 (at least if you have bionic-updates enabled).

A command to revert to that version is
apt install libegl1=1.0.0-2ubuntu2.3 libgl1=1.0.0-2ubuntu2.3 libgles1=1.0.0-2ubuntu2.3 libgles2=1.0.0-2ubuntu2.3 libglvnd0=1.0.0-2ubuntu2.3 libglx0=1.0.0-2ubuntu2.3 libopengl0=1.0.0-2ubuntu2.3

and so on with all other packages.

@Manfred,

Thanks! I will try your suggestions and get back with the results.

BTW, I was able to get the same list of dev packages you came up with by entering the following command: dpkg -l | grep oibaf | grep dev | awk '{print $2}'

So, for now, here is the output of the command "apt --simulate purge ..." (It looks like no problems were detected):

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

NOTE: This is only a simulation!
      apt needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  libdmx-dev libdmx1 libfontenc-dev libfs-dev libfs6 libgles1 libmirclient-dev
  libmircommon-dev libmircookie-dev libmircookie2 libmircore-dev libopengl0
  libpciaccess-dev libprotobuf-dev libqt5quickparticles5 libsqlite3-dev
  libxaw7-dev libxfont-dev libxkbcommon-dev libxkbfile-dev libxmu-dev
  libxmu-headers libxmuu-dev libxpm-dev libxres-dev libxss-dev libxtst-dev
  libxv-dev libxvmc-dev libxxf86dga-dev libxxf86vm-dev
  mir-client-platform-mesa-dev x11proto-dri2-dev x11proto-fonts-dev
  x11proto-gl-dev x11proto-record-dev x11proto-resource-dev
  x11proto-scrnsaver-dev x11proto-xf86bigfont-dev x11proto-xf86dga-dev
  x11proto-xf86vidmode-dev
Use 'apt autoremove' to remove them.
The following packages will be REMOVED:
  libdrm-dev* libegl-dev* libegl1-mesa-dev* libgl-dev* libgl1-mesa-dev*
  libgles-dev* libgles2-mesa-dev* libglu1-mesa-dev* libglvnd-dev* libglx-dev*
  libopengl-dev* libqt5opengl5-dev* mesa-common-dev* qt5-default* qtbase5-dev*
  qtdeclarative5-dev* qttools5-dev* xorg-dev* xserver-xorg-dev*
0 upgraded, 0 newly installed, 19 to remove and 0 not upgraded.
Purg libqt5opengl5-dev [5.9.5+dfsg-0ubuntu2.5]
Purg qtdeclarative5-dev [5.9.5-0ubuntu1.1]
Purg qtbase5-dev [5.9.5+dfsg-0ubuntu2.5] [qt5-default:amd64 qttools5-dev:amd64 ]
Purg libgles2-mesa-dev [20.3~git2010060730.2b977a~oibaf~b] [qt5-default:amd64 qttools5-dev:amd64 ]
Purg libegl1-mesa-dev [20.3~git2010060730.2b977a~oibaf~b] [qt5-default:amd64 qttools5-dev:amd64 ]
Purg libglu1-mesa-dev [9.0.0-2.1build1] [qt5-default:amd64 qttools5-dev:amd64 ]
Purg libgl1-mesa-dev [20.3~git2010060730.2b977a~oibaf~b] [qt5-default:amd64 qttools5-dev:amd64 ]
Purg mesa-common-dev [20.3~git2010060730.2b977a~oibaf~b] [qt5-default:amd64 xserver-xorg-dev:amd64 qttools5-dev:amd64 ]
Purg libdrm-dev [2.4.102+git2010051830.5de99a~oibaf~b] [qt5-default:amd64 xserver-xorg-dev:amd64 qttools5-dev:amd64 ]
Purg libglvnd-dev [1.3.2-1~oibaf~b] [qt5-default:amd64 xserver-xorg-dev:amd64 qttools5-dev:amd64 ]
Purg libgles-dev [1.3.2-1~oibaf~b] [qt5-default:amd64 xserver-xorg-dev:amd64 qttools5-dev:amd64 ]
Purg libegl-dev [1.3.2-1~oibaf~b] [qt5-default:amd64 xserver-xorg-dev:amd64 qttools5-dev:amd64 ]
Purg libgl-dev [1.3.2-1~oibaf~b] [qt5-default:amd64 xserver-xorg-dev:amd64 qttools5-dev:amd64 ]
Purg libglx-dev [1.3.2-1~oibaf~b] [qt5-default:amd64 xserver-xorg-dev:amd64 qttools5-dev:amd64 ]
Purg libopengl-dev [1.3.2-1~oibaf~b] [qt5-default:amd64 xserver-xorg-dev:amd64 qttools5-dev:amd64 ]
Purg qt5-default [5.9.5+dfsg-0ubuntu2.5] [xserver-xorg-dev:amd64 qttools5-dev:amd64 ]
Purg qttools5-dev [5.9.5-0ubuntu1] [xserver-xorg-dev:amd64 ]
Purg xorg-dev [1:7.7+19ubuntu7.1] [xserver-xorg-dev:amd64 ]
Purg xserver-xorg-dev [2:1.19.6-1ubuntu4.8]
$

Manfred Hampl (m-hampl) said : #25

The output of the simulation to remove the -dev packages looks ok. Doing the real execution will not do any harm, but will make the list of packages that has to be handled shorter.

I suggest that you run

sudo apt purge libegl-dev libgl-dev libgles-dev libglvnd-dev libglx-dev libopengl-dev libdrm-dev libegl1-mesa-dev libgl1-mesa-dev libgles2-mesa-dev mesa-common-dev

sudo apt install libegl1=1.0.0-2ubuntu2.3 libgl1=1.0.0-2ubuntu2.3 libgles1=1.0.0-2ubuntu2.3 libgles2=1.0.0-2ubuntu2.3 libglvnd0=1.0.0-2ubuntu2.3 libglx0=1.0.0-2ubuntu2.3 libopengl0=1.0.0-2ubuntu2.3

sudo apt purge clang clang-10 libclang-cpp10

sudo apt --purge autoremove

and the re-try the release-upgrade.

@Manfred,

I have implemented all of your suggestions up to repeating the do-release-upgrade. No problems were encountered so far but there are still lots of "oibaf" packages although the list is a bit smaller now! Do you think I will need to keep culling more of these "orbaf" packages?

$ dpkg -l | grep "oibaf" | awk '{print $1=$4=""; printf"%s",$0}' | sed 's/:amd64//g';echo

libdrm-amdgpu1 2.4.102+git2010051830.5de99a~oibaf~b Userspace interface to amdgpu-specific kernel DRM services -- runtime
 libdrm-common 2.4.102+git2010051830.5de99a~oibaf~b Userspace interface to kernel DRM services -- common files
 libdrm-intel1 2.4.102+git2010051830.5de99a~oibaf~b Userspace interface to intel-specific kernel DRM services -- runtime
 libdrm-nouveau2 2.4.102+git2010051830.5de99a~oibaf~b Userspace interface to nouveau-specific kernel DRM services -- runtime
 libdrm-radeon1 2.4.102+git2010051830.5de99a~oibaf~b Userspace interface to radeon-specific kernel DRM services -- runtime
 libdrm2 2.4.102+git2010051830.5de99a~oibaf~b Userspace interface to kernel DRM services -- runtime
 libegl-mesa0 20.3~git2010060730.2b977a~oibaf~b free implementation of the EGL API -- Mesa vendor library
 libegl1-mesa 20.3~git2010060730.2b977a~oibaf~b transitional dummy package
 libgbm1 20.3~git2010060730.2b977a~oibaf~b generic buffer management API -- runtime
 libgl1-mesa-dri 20.3~git2010060730.2b977a~oibaf~b free implementation of the OpenGL API -- DRI modules
 libgl1-mesa-glx 20.3~git2010060730.2b977a~oibaf~b transitional dummy package
 libglapi-mesa 20.3~git2010060730.2b977a~oibaf~b free implementation of the GL API -- shared library
 libglx-mesa0 20.3~git2010060730.2b977a~oibaf~b free implementation of the OpenGL API -- GLX vendor library
 libllvm10 1:10.0.1-1~oibaf~b Modular compiler and toolchain technologies, runtime library
 libwayland-egl1-mesa 20.3~git2010060730.2b977a~oibaf~b transitional dummy package
 libxatracker2 20.3~git2010060730.2b977a~oibaf~b X acceleration library -- runtime
 mesa-va-drivers 20.3~git2010060730.2b977a~oibaf~b Mesa VA-API video acceleration drivers
 mesa-vdpau-drivers 20.3~git2010060730.2b977a~oibaf~b Mesa VDPAU video acceleration drivers
 xserver-xorg-video-ati 1:19.1.0+git2009161930.8da3e4~oibaf~b X.Org X server -- AMD/ATI display driver wrapper
 xserver-xorg-video-intel 2:2.99.917+git2005251930.5ca3ac~oibaf~b X.Org X server -- Intel i8xx, i9xx display driver
 xserver-xorg-video-nouveau 1:1.0.16+git2009230730.7212a2~oibaf~b X.Org X server -- Nouveau display driver
 xserver-xorg-video-radeon 1:19.1.0+git2009161930.8da3e4~oibaf~b X.Org X server -- AMD/ATI Radeon display driver
$

I then tried replacing just one of these and ran into this problem:

$ apt-cache policy libdrm2
libdrm2:
  Installed: 2.4.102+git2010051830.5de99a~oibaf~b
  Candidate: 2.4.102+git2010051830.5de99a~oibaf~b
  Version table:
 *** 2.4.102+git2010051830.5de99a~oibaf~b 100
        100 /var/lib/dpkg/status
     2.4.101-2~18.04.1 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
     2.4.99-1ubuntu1~18.04.2 500
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
     2.4.91-2 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
$
$ apt install --simulate libdrm2=2.4.101-2~18.04.1
NOTE: This is only a simulation!
      apt needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 gvfs : Depends: gvfs-daemons (>= 1.36.1-0ubuntu1.3.3)
        Depends: gvfs-daemons (< 1.36.1-0ubuntu1.3.3.1~)
 libwxgtk3.0-0v5 : Depends: libgl1 but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
$

I am not sure what this really means - are the "unmet dependencies" applicable to after the install or before? What does "gvfs : Depends: gvfs-daemons (>= 1.36.1-0ubuntu1.3.3)" actually mean? Why the second line, "Depends: gvfs-daemons (< 1.36.1-0ubuntu1.3.3.1~)"? Am I correct to understand that the current version of gvfs depends on gvfs-daemons (>= 1.36.1-0ubuntu1.3.3) but after the install replacement, gvfs will end up depending on gvfs-daemons (< 1.36.1-0ubuntu1.3.3.1~) and that version is not installed?

Also, why is libgl1 not going to be installed? Isn't it already installed already?
$ dpkg -s libgl1
Package: libgl1
Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 671
Maintainer: Ubuntu Developers <email address hidden>
Architecture: amd64
Multi-Arch: same
Source: libglvnd
Version: 1.0.0-2ubuntu2.3
Replaces: libgl1-mesa-glx (<< 18.0.5-0ubuntu0~18.04), libglvnd0 (<< 0.2.999+git20170201-1)
Depends: libc6 (>= 2.14), libglvnd0 (= 1.0.0-2ubuntu2.3), libglx0 (= 1.0.0-2ubuntu2.3)
Breaks: glx-diversions (<< 0.8), libgl1-mesa-glx (<< 18.0.5-0ubuntu0~18.04), libglvnd0 (<< 0.2.999+git20170201-1)
Description: Vendor neutral GL dispatch library -- legacy GL support
 This is an implementation of the vendor-neutral dispatch layer for
 arbitrating OpenGL API calls between multiple vendors on a per-screen basis.
 .
 This package contains support for old libGL for compatibility reasons.
Original-Maintainer: Debian X Strike Force <email address hidden>
Homepage: https://github.com/NVIDIA/libglvnd
$

Is this going to end up causing me problems when I finally attempt the do-release-upgrade again? (I'm going to go ahead and try it anyway but I though I'd get this out first).

$ grep oibaf apt.log
  MarkInstall xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
      clang-tidy-10:amd64 Depends on libllvm10:amd64 < 1:10.0.1-1~oibaf~b @ii mK > (= 1:10.0.0-4ubuntu1) can't be satisfied!
  MarkInstall xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mK Ib > FU=0
  MarkInstall xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
  MarkInstall xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
            MarkDelete libdrm2:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib > FU=0
                    MarkDelete libdrm-intel1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib > FU=0
                    MarkDelete libdrm-amdgpu1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib > FU=0
                    MarkDelete libdrm-nouveau2:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib > FU=0
                    MarkDelete libdrm-radeon1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib > FU=0
                  MarkDelete mesa-va-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mK Ib > FU=0
                MarkDelete mesa-vdpau-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mK Ib > FU=0
    MarkKeep mesa-va-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mR > FU=0
  MarkInstall libglx-mesa0:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mK Ib > FU=0
      MarkKeep libdrm2:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mR > FU=0
    MarkKeep libdrm-nouveau2:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mR > FU=0
    MarkKeep libdrm-amdgpu1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mR > FU=0
    MarkKeep libdrm-intel1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mR > FU=0
    MarkKeep libdrm-radeon1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mR > FU=0
    MarkKeep mesa-vdpau-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mR > FU=0
Investigating (0) libdrm2:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib >
Broken libdrm2:amd64 Breaks on libdrm2:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > (!= 2.4.102+git2010051830.5de99a~oibaf~b)
Investigating (0) libdrm-intel1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib >
Broken libdrm-intel1:amd64 Breaks on libdrm-intel1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > (!= 2.4.102+git2010051830.5de99a~oibaf~b)
Investigating (0) libdrm-amdgpu1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib >
Broken libdrm-amdgpu1:amd64 Breaks on libdrm-amdgpu1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > (!= 2.4.102+git2010051830.5de99a~oibaf~b)
Investigating (0) libdrm-nouveau2:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib >
Broken libdrm-nouveau2:amd64 Breaks on libdrm-nouveau2:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > (!= 2.4.102+git2010051830.5de99a~oibaf~b)
Investigating (0) libdrm-radeon1:amd64 < 2.4.102+git2010051830.5de99a~oibaf~b @ii mK Ib >
Broken libdrm-radeon1:amd64 Breaks on libdrm-radeon1:i386 < none -> 2.4.102-1ubuntu1~20.04.1 @un uN Ib > (!= 2.4.102+git2010051830.5de99a~oibaf~b)
Investigating (0) mesa-vdpau-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mK Ib >
Broken mesa-vdpau-drivers:amd64 Breaks on mesa-vdpau-drivers:i386 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib > (!= 20.3~git2010060730.2b977a~oibaf~b)
  MarkDelete mesa-vdpau-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mK Ib >
  MarkDelete xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
  MarkDelete xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
  MarkDelete xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib >
  MarkDelete xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
Broken xserver-xorg-video-intel-hwe-16.04:amd64 Depends on xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mR >
Broken xserver-xorg-video-nouveau-hwe-16.04:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR >
Broken xserver-xorg-video-ati-hwe-16.04:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR >
Broken vdpau-driver-all:amd64 Depends on mesa-vdpau-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mR >
  MarkKeep mesa-vdpau-drivers:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mR > FU=0
Investigating (0) libgl1-mesa-dri:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mK Ib >
Investigating (1) libgl1-mesa-dri:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mK Ib >
Investigating (2) libgl1-mesa-dri:amd64 < 20.3~git2010060730.2b977a~oibaf~b @ii mK Ib >
$

I guess I was right! I need to figure out how to clean up the rest of the "oibaf" packages.

Manfred Hampl (m-hampl) said : #28

If you look at librm2 in your output, you see that currently the version is 2.4.102+git2010051830.5de99a~oibaf~b
There are also other packages with this version, namely
libdrm-amdgpu1
libdrm-common
libdrm-intel1
libdrm-nouveau2
libdrm-radeon1

I assume that these packages have a dependency on the other ones in a way that they all have to be the same version. This requires that they are handled together:

sudo apt install librm2=2.4.101-2~18.04.1 libdrm-amdgpu1=2.4.101-2~18.04.1 libdrm-common=2.4.101-2~18.04.1 libdrm-intel1=2.4.101-2~18.04.1 libdrm-nouveau2=2.4.101-2~18.04.1 libdrm-radeon1=2.4.101-2~18.04.1

Probably Similar for the packages with "mesa" in their name.

@Manfred,

I had tried that already. If you look at my comment #26, for the sake of brevity, I had teased out just one of the packages, libdrm2 and tried a simulated re-install of just that package and got the errors I posted to comment #26. However, I already tried the strategy you suggested:

I was able to confirm that all of those libdrm-xxxx packages have the same candidate replacement version:

$ dpkg -l | grep "2.4.102+git2010051830.5de99a~oibaf~b" | awk '{print $2}' | sed 's/:amd64//g' | tr '\n' ' ' | xargs apt-cache policy | grep 'libdrm\|2.4.101-2~18.04.1'
libdrm-amdgpu1:
     2.4.101-2~18.04.1 500
libdrm-common:
     2.4.101-2~18.04.1 500
libdrm-intel1:
     2.4.101-2~18.04.1 500
libdrm-nouveau2:
     2.4.101-2~18.04.1 500
libdrm-radeon1:
     2.4.101-2~18.04.1 500
libdrm2:
     2.4.101-2~18.04.1 500
$

I then constructed the command like so:
dpkg -l | grep "2.4.102+git2010051830.5de99a~oibaf~b" | awk '{print $2}' | sed 's/:amd64//g' | tr '\n' ' ' | xargs printf -- ' %s=2.4.101-2~18.04.1' | xargs echo sudo apt install

I compared the output of the above with yours and it matches, except for one typo (librm2=>libdrm2) and you put libdrm2 first (not sure if the latter difference is important).

I then issued the command with the --simulate option:
apt install --simulate libdrm2=2.4.101-2~18.04.1 libdrm-amdgpu1=2.4.101-2~18.04.1 libdrm-common=2.4.101-2~18.04.1 libdrm-intel1=2.4.101-2~18.04.1 libdrm-nouveau2=2.4.101-2~18.04.1 libdrm-radeon1=2.4.101-2~18.04.1

The result shows that thre still is a problem:

NOTE: This is only a simulation!
      apt needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists...
Building dependency tree...
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 gvfs : Depends: gvfs-daemons (>= 1.36.1-0ubuntu1.3.3)
        Depends: gvfs-daemons (< 1.36.1-0ubuntu1.3.3.1~)
 libwxgtk3.0-0v5 : Depends: libgl1 but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

How do I resolve this?

Manfred Hampl (m-hampl) said : #30

Neither gvfs nor gvfs-daemons are mentioned in the list of oibaf packages, so this might be caused by something different.

What is the full output of
sudo dpkg --audit
apt-cache policy gvfs gvfs-daemons libwxgtk3.0-0v5 libgl1
apt install --simulate libdrm2=2.4.101-2~18.04.1 libdrm-amdgpu1=2.4.101-2~18.04.1 libdrm-common=2.4.101-2~18.04.1 libdrm-intel1=2.4.101-2~18.04.1 libdrm-nouveau2=2.4.101-2~18.04.1 libdrm-radeon1=2.4.101-2~18.04.1

sudo dpkg --audit gives no output

See my last comment for the results of apt install --simulate ...

$ apt-cache policy gvfs gvfs-daemons libwxgtk3.0-0v5 libgl1
gvfs:
  Installed: 1.36.1-0ubuntu1.3.3
  Candidate: 1.36.1-0ubuntu1.3.3
  Version table:
 *** 1.36.1-0ubuntu1.3.3 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
        100 /var/lib/dpkg/status
     1.36.1-0ubuntu1 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
gvfs-daemons:
  Installed: 1.36.1-0ubuntu1.3.3
  Candidate: 1.36.1-0ubuntu1.3.3
  Version table:
 *** 1.36.1-0ubuntu1.3.3 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
        100 /var/lib/dpkg/status
     1.36.1-0ubuntu1 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
libwxgtk3.0-0v5:
  Installed: 3.0.4+dfsg-3
  Candidate: 3.0.4+dfsg-3
  Version table:
 *** 3.0.4+dfsg-3 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libgl1:
  Installed: 1.0.0-2ubuntu2.3
  Candidate: 1.0.0-2ubuntu2.3
  Version table:
 *** 1.0.0-2ubuntu2.3 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1.0.0-2ubuntu2 500
        500 http://ca.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
$

Manfred Hampl (m-hampl) said : #32

Sorry for requesting output that was already there; I realized that just after pressing the "send" button.

In some cases the output of "apt --simulate" is wrong, for reasons not known to me.
I suggest that you just try the apt install command without --simulate (and with sudo).

without --simulate and with sudo:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 gvfs : Depends: gvfs-daemons (>= 1.36.1-0ubuntu1.3.3)
        Depends: gvfs-daemons (< 1.36.1-0ubuntu1.3.3.1~)
 libwxgtk3.0-0v5 : Depends: libgl1 but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Manfred Hampl (m-hampl) said : #34

This is unexpected.

What do you get for

apt install --simulate libdrm2=2.4.101-2~18.04.1 libdrm-amdgpu1=2.4.101-2~18.04.1 libdrm-common=2.4.101-2~18.04.1 libdrm-intel1=2.4.101-2~18.04.1 libdrm-nouveau2=2.4.101-2~18.04.1 libdrm-radeon1=2.4.101-2~18.04.1 gvfs=1.36.1-0ubuntu1.3.3 gvfs-daemons=1.36.1-0ubuntu1.3.3 libwxgtk3.0-0v5=3.0.4+dfsg-3 libgl1=1.0.0-2ubuntu2.3

$ apt install --simulate libdrm2=2.4.101-2~18.04.1 libdrm-amdgpu1=2.4.101-2~18.04.1 libdrm-common=2.4.101-2~18.04.1 libdrm-intel1=2.4.101-2~18.04.1 libdrm-nouveau2=2.4.101-2~18.04.1 libdrm-radeon1=2.4.101-2~18.04.1 gvfs=1.36.1-0ubuntu1.3.3 gvfs-daemons=1.36.1-0ubuntu1.3.3 libwxgtk3.0-0v5=3.0.4+dfsg-3 libgl1=1.0.0-2ubuntu2.3
NOTE: This is only a simulation!
      apt needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
libwxgtk3.0-0v5 is already the newest version (3.0.4+dfsg-3).
libwxgtk3.0-0v5 set to manually installed.
gvfs is already the newest version (1.36.1-0ubuntu1.3.3).
gvfs-daemons is already the newest version (1.36.1-0ubuntu1.3.3).
libgl1 is already the newest version (1.0.0-2ubuntu2.3).
libgl1 set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 libgl1-mesa-dri : Depends: libdrm-amdgpu1 (>= 2.4.102+git2010051830.5de99a~oibaf~b) but 2.4.101-2~18.04.1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
$

Best Manfred Hampl (m-hampl) said : #36

Ok, it seems that we have to care for the *mesa* packages first.

What is the result of

sudo apt install libegl-mesa0=20.0.8-0ubuntu1~18.04.1 libegl1-mesa=20.0.8-0ubuntu1~18.04.1 libgbm1=20.0.8-0ubuntu1~18.04.1 libgl1-mesa-dri=20.0.8-0ubuntu1~18.04.1 libgl1-mesa-glx=20.0.8-0ubuntu1~18.04.1 libglapi-mesa=20.0.8-0ubuntu1~18.04.1 libglx-mesa0=20.0.8-0ubuntu1~18.04.1 libwayland-egl1-mesa=20.0.8-0ubuntu1~18.04.1 libxatracker2=20.0.8-0ubuntu1~18.04.1 mesa-va-drivers=20.0.8-0ubuntu1~18.04.1 mesa-vdpau-drivers=20.0.8-0ubuntu1~18.04.1

I simulated first and didn't see any errors so I went ahead and ran the command:
Reading package lists...
Building dependency tree...
Reading state information...
The following packages will be DOWNGRADED:
  libegl-mesa0 libegl1-mesa libgbm1 libgl1-mesa-dri libgl1-mesa-glx
  libglapi-mesa libglx-mesa0 libwayland-egl1-mesa libxatracker2
  mesa-va-drivers mesa-vdpau-drivers
0 upgraded, 0 newly installed, 11 downgraded, 0 to remove and 0 not upgraded.
Need to get 16.1 MB of archives.
After this operation, 29.1 MB disk space will be freed.
Do you want to continue? [Y/n] Get:1 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libegl-mesa0 amd64 20.0.8-0ubuntu1~18.04.1 [96.3 kB]
Get:2 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libgbm1 amd64 20.0.8-0ubuntu1~18.04.1 [27.6 kB]
Get:3 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libgl1-mesa-dri amd64 20.0.8-0ubuntu1~18.04.1 [9,333 kB]
Get:4 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libglx-mesa0 amd64 20.0.8-0ubuntu1~18.04.1 [139 kB]
Get:5 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libglapi-mesa amd64 20.0.8-0ubuntu1~18.04.1 [26.6 kB]
Get:6 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libegl1-mesa amd64 20.0.8-0ubuntu1~18.04.1 [6,416 B]
Get:7 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libgl1-mesa-glx amd64 20.0.8-0ubuntu1~18.04.1 [5,532 B]
Get:8 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libwayland-egl1-mesa amd64 20.0.8-0ubuntu1~18.04.1 [6,444 B]
Get:9 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libxatracker2 amd64 20.0.8-0ubuntu1~18.04.1 [1,549 kB]
Get:10 http://ca.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 mesa-va-drivers amd64 20.0.8-0ubuntu1~18.04.1 [2,376 kB]
Get:11 http://ca.archive.ubuntu.com/ubuntu bionic-updates/main amd64 mesa-vdpau-drivers amd64 20.0.8-0ubuntu1~18.04.1 [2,496 kB]
Fetched 16.1 MB in 1s (12.9 MB/s)
dpkg: warning: downgrading libegl-mesa0:amd64 from 20.3~git2010060730.2b977a~oibaf~b to 20.0.8-0ubuntu1~18.04.1
(Reading database ...
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 279773 files and directories currently installed.)
Preparing to unpack .../00-libegl-mesa0_20.0.8-0ubuntu1~18.04.1_amd64.deb ...
Unpacking libegl-mesa0:amd64 (20.0.8-0ubuntu1~18.04.1) over (20.3~git2010060730.2b977a~oibaf~b) ...
dpkg: warning: downgrading libgbm1:amd64 from 20.3~git2010060730.2b977a~oibaf~b to 20.0.8-0ubuntu1~18.04.1
Preparing to unpack .../01-libgbm1_20.0.8-0ubuntu1~18.04.1_amd64.deb ...
Unpacking libgbm1:amd64 (20.0.8-0ubuntu1~18.04.1) over (20.3~git2010060730.2b977a~oibaf~b) ...
dpkg: warning: downgrading libgl1-mesa-dri:amd64 from 20.3~git2010060730.2b977a~oibaf~b to 20.0.8-0ubuntu1~18.04.1
Preparing to unpack .../02-libgl1-mesa-dri_20.0.8-0ubuntu1~18.04.1_amd64.deb ...
Unpacking libgl1-mesa-dri:amd64 (20.0.8-0ubuntu1~18.04.1) over (20.3~git2010060730.2b977a~oibaf~b) ...
dpkg: warning: downgrading libglx-mesa0:amd64 from 20.3~git2010060730.2b977a~oibaf~b to 20.0.8-0ubuntu1~18.04.1
Preparing to unpack .../03-libglx-mesa0_20.0.8-0ubuntu1~18.04.1_amd64.deb ...
Unpacking libglx-mesa0:amd64 (20.0.8-0ubuntu1~18.04.1) over (20.3~git2010060730.2b977a~oibaf~b) ...
dpkg: warning: downgrading libglapi-mesa:amd64 from 20.3~git2010060730.2b977a~oibaf~b to 20.0.8-0ubuntu1~18.04.1
Preparing to unpack .../04-libglapi-mesa_20.0.8-0ubuntu1~18.04.1_amd64.deb ...
Unpacking libglapi-mesa:amd64 (20.0.8-0ubuntu1~18.04.1) over (20.3~git2010060730.2b977a~oibaf~b) ...
dpkg: warning: downgrading libegl1-mesa:amd64 from 20.3~git2010060730.2b977a~oibaf~b to 20.0.8-0ubuntu1~18.04.1
Preparing to unpack .../05-libegl1-mesa_20.0.8-0ubuntu1~18.04.1_amd64.deb ...
Unpacking libegl1-mesa:amd64 (20.0.8-0ubuntu1~18.04.1) over (20.3~git2010060730.2b977a~oibaf~b) ...
dpkg: warning: downgrading libgl1-mesa-glx:amd64 from 20.3~git2010060730.2b977a~oibaf~b to 20.0.8-0ubuntu1~18.04.1
Preparing to unpack .../06-libgl1-mesa-glx_20.0.8-0ubuntu1~18.04.1_amd64.deb ...
Unpacking libgl1-mesa-glx:amd64 (20.0.8-0ubuntu1~18.04.1) over (20.3~git2010060730.2b977a~oibaf~b) ...
dpkg: warning: downgrading libwayland-egl1-mesa:amd64 from 20.3~git2010060730.2b977a~oibaf~b to 20.0.8-0ubuntu1~18.04.1
Preparing to unpack .../07-libwayland-egl1-mesa_20.0.8-0ubuntu1~18.04.1_amd64.deb ...
Unpacking libwayland-egl1-mesa:amd64 (20.0.8-0ubuntu1~18.04.1) over (20.3~git2010060730.2b977a~oibaf~b) ...
dpkg: warning: downgrading libxatracker2:amd64 from 20.3~git2010060730.2b977a~oibaf~b to 20.0.8-0ubuntu1~18.04.1
Preparing to unpack .../08-libxatracker2_20.0.8-0ubuntu1~18.04.1_amd64.deb ...
Unpacking libxatracker2:amd64 (20.0.8-0ubuntu1~18.04.1) over (20.3~git2010060730.2b977a~oibaf~b) ...
dpkg: warning: downgrading mesa-va-drivers:amd64 from 20.3~git2010060730.2b977a~oibaf~b to 20.0.8-0ubuntu1~18.04.1
Preparing to unpack .../09-mesa-va-drivers_20.0.8-0ubuntu1~18.04.1_amd64.deb ...
Unpacking mesa-va-drivers:amd64 (20.0.8-0ubuntu1~18.04.1) over (20.3~git2010060730.2b977a~oibaf~b) ...
dpkg: warning: downgrading mesa-vdpau-drivers:amd64 from 20.3~git2010060730.2b977a~oibaf~b to 20.0.8-0ubuntu1~18.04.1
Preparing to unpack .../10-mesa-vdpau-drivers_20.0.8-0ubuntu1~18.04.1_amd64.deb ...
Unpacking mesa-vdpau-drivers:amd64 (20.0.8-0ubuntu1~18.04.1) over (20.3~git2010060730.2b977a~oibaf~b) ...
Setting up mesa-vdpau-drivers:amd64 (20.0.8-0ubuntu1~18.04.1) ...
Setting up libgbm1:amd64 (20.0.8-0ubuntu1~18.04.1) ...
Setting up libglapi-mesa:amd64 (20.0.8-0ubuntu1~18.04.1) ...
Setting up libxatracker2:amd64 (20.0.8-0ubuntu1~18.04.1) ...
Setting up mesa-va-drivers:amd64 (20.0.8-0ubuntu1~18.04.1) ...
Setting up libwayland-egl1-mesa:amd64 (20.0.8-0ubuntu1~18.04.1) ...
Setting up libegl-mesa0:amd64 (20.0.8-0ubuntu1~18.04.1) ...
Setting up libegl1-mesa:amd64 (20.0.8-0ubuntu1~18.04.1) ...
Setting up libgl1-mesa-dri:amd64 (20.0.8-0ubuntu1~18.04.1) ...
Setting up libglx-mesa0:amd64 (20.0.8-0ubuntu1~18.04.1) ...
Setting up libgl1-mesa-glx:amd64 (20.0.8-0ubuntu1~18.04.1) ...
Processing triggers for libc-bin (2.27-3ubuntu1.4) ...

This seemed to work ok so I will now go on to downgrade the libdrm packages and report back.

SUCCESS!

I have replaced all the "oibaf" packages with the official ones and now my system is able to do the upgrade:

...
Do you want to start the upgrade?
...
 Continue [yN] Details [d]

Many thanks to Manfred for your depth of knowledge and amazing patience!

I didn't actually go ahead with the upgrade yet - if new problems occur during that stage, I will ask a different question or raise a bug as required.

Post mortem
===========

Just for closure, here is a summary of all the commands that got my system back to normal:

1. Start with removal of clang:
    sudo apt purge clang clang-10 libclang-cpp10
    sudo apt --purge autoremove
    (This didn't seem to have any effect on the number of "oibaf" packages present!)

2. Get the remaining list of "oibaf" packages
    dpkg -l | grep "oibaf" | sed 's/ \+/ /g' > dpkg-oibaf.txt

3. "dev" packages are safe to remove:

    grep oibaf dpkg-oibaf.txt | grep dev | awk '{print $2}' | sed 's/:amd64//g' | tr '\n' ' ' | xargs echo apt --simulate purge
    produces:
    apt --simulate purge libdrm-dev libegl-dev libegl1-mesa-dev libgl-dev libgl1-mesa-dev libgles-dev libgles2-mesa-dev libglvnd-dev libglx-dev libopengl-dev mesa-common-dev

    grep oibaf dpkg-oibaf.txt | grep dev | awk '{print $2}' | sed 's/:amd64//g' | tr '\n' ' ' | xargs echo sudo apt purge
    produces:
    sudo apt purge libdrm-dev libegl-dev libegl1-mesa-dev libgl-dev libgl1-mesa-dev libgles-dev libgles2-mesa-dev libglvnd-dev libglx-dev libopengl-dev mesa-common-dev

4. So what's left?

    List of remaining packages:
    dpkg -l | grep "oibaf" | sed 's/ \+/ /g' > dpkg-oibaf-nodev.txt

    Looks like quite a few of these have version "1.3.2-1~oibaf~b"
    grep "1.3.2-1~oibaf~b" dpkg-oibaf-nodev.txt | awk '{print $2}' | sed 's/:amd64//g'

    What are the policies:
    grep "1.3.2-1~oibaf~b" dpkg-oibaf-nodev.txt | awk '{print $2}' | sed 's/:amd64//g' | tr '\n' ' ' | xargs echo apt-cache policy
    produces:
    apt-cache policy libegl1 libgl1 libgles1 libgles2 libglvnd0 libglx0 libopengl0

    In this case, all of these had the latest "official" version as "1.0.0-2ubuntu2.3"

    grep "1.3.2-1~oibaf~b" dpkg-oibaf-nodev.txt | awk '{print $2}' | sed 's/:amd64//g' | tr '\n' ' ' | xargs printf -- ' %s=1.0.0-2ubuntu2.3' | xargs echo sudo apt install
    produces:
    sudo apt install libegl1=1.0.0-2ubuntu2.3 libgl1=1.0.0-2ubuntu2.3 libgles1=1.0.0-2ubuntu2.3 libgles2=1.0.0-2ubuntu2.3 libglvnd0=1.0.0-2ubuntu2.3 libglx0=1.0.0-2ubuntu2.3 libopengl0=1.0.0-2ubuntu2.3

5. Remove the "mesa" packages:

    List of remaining packages:
    dpkg -l | grep "oibaf" | sed 's/ \+/ /g' > dpkg-oibaf-nolibgl.txt

    What are the policies?
    grep mesa dpkg-oibaf-nolibgl.txt | awk '{print $2}' | sed 's/:amd64//g' | tr '\n' ' ' | xargs echo apt-cache policy
    produces:
    apt-cache policy libegl-mesa0 libegl1-mesa libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libglx-mesa0 libwayland-egl1-mesa mesa-va-drivers mesa-vdpau-drivers

    In this case, all of these had the latest "official" version as "20.0.8-0ubuntu1~18.04.1"

    grep mesa dpkg-oibaf-nolibgl.txt | awk '{print $2}' | sed 's/:amd64//g' | tr '\n' ' ' | xargs printf -- ' %s=20.0.8-0ubuntu1~18.04.1' | xargs echo sudo apt install
    produces:
    sudo apt install libegl-mesa0=20.0.8-0ubuntu1~18.04.1 libegl1-mesa=20.0.8-0ubuntu1~18.04.1 libgl1-mesa-dri=20.0.8-0ubuntu1~18.04.1 libgl1-mesa-glx=20.0.8-0ubuntu1~18.04.1 libglapi-mesa=20.0.8-0ubuntu1~18.04.1 libglx-mesa0=20.0.8-0ubuntu1~18.04.1 libwayland-egl1-mesa=20.0.8-0ubuntu1~18.04.1 mesa-va-drivers=20.0.8-0ubuntu1~18.04.1 mesa-vdpau-drivers=20.0.8-0ubuntu1~18.04.1

    Manfred's command added these packages:
    libgbm1=20.0.8-0ubuntu1~18.04.1
    libxatracker2=20.0.8-0ubuntu1~18.04.1

    Here's the complete command:
    sudo apt install libegl-mesa0=20.0.8-0ubuntu1~18.04.1 libegl1-mesa=20.0.8-0ubuntu1~18.04.1 libgl1-mesa-dri=20.0.8-0ubuntu1~18.04.1 libgl1-mesa-glx=20.0.8-0ubuntu1~18.04.1 libglapi-mesa=20.0.8-0ubuntu1~18.04.1 libglx-mesa0=20.0.8-0ubuntu1~18.04.1 libwayland-egl1-mesa=20.0.8-0ubuntu1~18.04.1 mesa-va-drivers=20.0.8-0ubuntu1~18.04.1 mesa-vdpau-drivers=20.0.8-0ubuntu1~18.04.1 libgbm1=20.0.8-0ubuntu1~18.04.1 libxatracker2=20.0.8-0ubuntu1~18.04.1

6. Now we can get rid of the libdrm packages

    List of remaining packages:
    dpkg -l | grep "oibaf" | sed 's/ \+/ /g' > dpkg-oibaf-nomesa.txt

    grep libdrm dpkg-oibaf-nomesa.txt | awk '{print $2}' | sed 's/:amd64//g' | tr '\n' ' ' | xargs echo apt-cache policy
    produces:
    apt-cache policy libdrm-amdgpu1 libdrm-common libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2

    grep "libdrm" dpkg-oibaf-nomesa.txt | sed 's/:amd64//g' | awk '{print $2"=2.4.101-2~18.04.1"}' | tr '\n' ' ' | xargs echo sudo apt install
    produces:
    sudo apt install libdrm-amdgpu1=2.4.101-2~18.04.1 libdrm-common=2.4.101-2~18.04.1 libdrm-intel1=2.4.101-2~18.04.1 libdrm-nouveau2=2.4.101-2~18.04.1 libdrm-radeon1=2.4.101-2~18.04.1 libdrm2=2.4.101-2~18.04.1

7. What's left?

    dpkg -l | grep "oibaf" | sed 's/ \+/ /g' > dpkg-oibaf-nolibdrm.txt
    cat dpkg-oibaf-nolibdrm.txt | awk '{print $2 " " $3}' | sed 's/:amd64//g'

    Nice short list:
    libllvm10 1:10.0.1-1~oibaf~b
    xserver-xorg-video-ati 1:19.1.0+git2009161930.8da3e4~oibaf~b
    xserver-xorg-video-intel 2:2.99.917+git2005251930.5ca3ac~oibaf~b
    xserver-xorg-video-nouveau 1:1.0.16+git2009230730.7212a2~oibaf~b
    xserver-xorg-video-radeon 1:19.1.0+git2009161930.8da3e4~oibaf~b

    Try libllvm10 first:
    $ apt-cache policy libllvm10
    $ sudo apt install libllvm10=1:10.0.0-4ubuntu1~18.04.2

8. The remaining xserver-org-video-xxxxx all had different official versions:
    so I installed as follows:
    sudo apt install xserver-xorg-video-ati=1:18.0.1-1 xserver-xorg-video-intel=2:2.99.917+git20171229-1 xserver-xorg-video-nouveau=1:1.0.15-2 xserver-xorg-video-radeon=1:18.0.1-1

    AND IT WORKED!

    dpkg -l | grep "oibaf"
    NOTHING!

Thanks Manfred Hampl, that solved my question.