unable to upgrade from v18.04 to v20.04

Asked by Stephen Shorrock on 2021-02-01

Hello I get the message:

"Could not determine the upgrade

An unresolvable problem occurred while calculating the upgrade.

 If none of this applies, then please report this bug using the command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal. If you want to investigate this yourself the log files in '/var/log/dist-upgrade' will contain details about the upgrade. Specifically, look at 'main.log' and 'apt.log'."

When attempting an upgrade. Below is my apt.log and main.log. Is someone able to point me in the correct direction?

Thanks
S

cat /var/log/dist-upgrade/apt.log
Log time: 2021-02-01 16:04:23.770711
Log time: 2021-02-01 16:04:25.849103
Log time: 2021-02-01 16:04:47.265781
  MarkInstall python-is-python2:amd64 < none -> 2.7.17-4 @un uN Ib > FU=1
   Removing: python
    MarkDelete python:amd64 < 2.7.15-3~oibaf~b @ii mK > FU=0
  MarkDelete python-minimal:amd64 < 2.7.15-3~oibaf~b @ii gK > FU=1
  MarkDelete libpython-stdlib:amd64 < 2.7.15-3~oibaf~b @ii gK > FU=1
  Ignore MarkInstall of python:amd64 < 2.7.15-3~oibaf~b @ii pgR > as its mode (Delete) is protected
    MarkKeep libpython-stdlib:amd64 < 2.7.15-3~oibaf~b @ii gR > FU=0
    MarkKeep python-minimal:amd64 < 2.7.15-3~oibaf~b @ii gR > FU=0
  MarkInstall fdisk:amd64 < 2.31.1-0.4ubuntu3.7 -> 2.34-0.1ubuntu9.1 @ii umU Ib > FU=0
  Installing libncursesw6 as Depends of fdisk
    MarkInstall libncursesw6:amd64 < none -> 6.2-0ubuntu2 @un uN Ib > FU=0
    Installing libtinfo6 as Depends of libncursesw6
      MarkInstall libtinfo6:amd64 < none -> 6.2-0ubuntu2 @un uN > FU=0
  MarkInstall libkpimgapicore5:amd64 < 17.12.3-0ubuntu1 @ii mK Ib > FU=0
  MarkInstall evince:amd64 < 3.28.4-0ubuntu1.2 -> 3.36.7-0ubuntu1 @ii umU Ib > FU=0
  Installing libgnome-desktop-3-19 as Depends of evince
    MarkInstall libgnome-desktop-3-19:amd64 < none -> 3.36.8-0ubuntu1 @un uN > FU=0
  MarkInstall libgcc-7-dev:amd64 < 7.5.0-3ubuntu1~18.04 -> 7.5.0-6ubuntu2 @ii umU Ib > FU=0
  Installing libgcc-s1 as Depends of libgcc-7-dev
    MarkInstall libgcc-s1:amd64 < none -> 10.2.0-5ubuntu1~20.04 @un uN Ib > FU=0
    Installing gcc-10-base as Depends of libgcc-s1
      MarkInstall gcc-10-base:amd64 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
  MarkInstall perl-base:amd64 < 5.26.1-6ubuntu0.5 -> 5.30.0-9ubuntu0.2 @ii umU Ib > FU=0
  Installing libcrypt1 as PreDepends of perl-base
    MarkInstall libcrypt1:amd64 < none -> 1:4.4.10-10ubuntu4 @un uN > FU=0
  MarkInstall gpick:amd64 < 0.2.5+git20161221-1build1 -> 0.2.6~rc1-1 @ii umU Ib > FU=0
  Installing libboost-filesystem1.67.0 as Depends of gpick
    MarkInstall libboost-filesystem1.67.0:amd64 < none -> 1.67.0-17ubuntu8 @un uN Ib > FU=0
    Installing libboost-system1.67.0 as Depends of libboost-filesystem1.67.0
      MarkInstall libboost-system1.67.0:amd64 < none -> 1.67.0-17ubuntu8 @un uN > FU=0
  MarkInstall libreoffice-math:amd64 < 1:6.0.7-0ubuntu0.18.04.10 -> 1:6.4.6-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libuno-cppu3 as Depends of libreoffice-math
    MarkInstall libuno-cppu3:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
    Installing libuno-sal3 as Depends of libuno-cppu3
      MarkInstall libuno-sal3:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
       Removing: uno-libs3
        MarkDelete uno-libs3:amd64 < 6.0.7-0ubuntu0.18.04.10 @ii mK > FU=0
    Installing libuno-salhelpergcc3-3 as Depends of libuno-cppu3
      MarkInstall libuno-salhelpergcc3-3:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN > FU=0
  Installing libuno-cppuhelpergcc3-3 as Depends of libreoffice-math
    MarkInstall libuno-cppuhelpergcc3-3:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
    Installing uno-libs-private as Depends of libuno-cppuhelpergcc3-3
      MarkInstall uno-libs-private:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN > FU=0
  MarkInstall bluez:amd64 < 5.48-0ubuntu3.4 -> 5.53-0ubuntu3 @ii umU Ib > FU=0
  Installing libreadline8 as Depends of bluez
    MarkInstall libreadline8:amd64 < none -> 8.0-4 @un uN > FU=0
  MarkInstall gnome-power-manager:amd64 < 3.26.0-1 -> 3.32.0-2 @ii umU Ib > FU=0
  Installing gnome-settings-daemon-common as Depends of gnome-power-manager
    MarkInstall gnome-settings-daemon-common:amd64 < none -> 3.36.1-0ubuntu1 @un uN Ib > FU=0
     Removing: gnome-settings-daemon-schemas
      MarkDelete gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3 @ii mK > FU=0
  MarkInstall python3-dev:amd64 < 3.6.7-1~18.04 -> 3.8.2-0ubuntu2 @ii umU Ib > FU=0
  Installing python3.8-dev as Depends of python3-dev
    MarkInstall python3.8-dev:amd64 < none -> 3.8.5-1~20.04 @un uN Ib > FU=0
    Installing libpython3.8-dev as Depends of python3.8-dev
      MarkInstall libpython3.8-dev:amd64 < none -> 3.8.5-1~20.04 @un uN Ib > FU=0
      Installing libpython3.8 as Depends of libpython3.8-dev
        MarkInstall libpython3.8:amd64 < none -> 3.8.5-1~20.04 @un uN > FU=0
  MarkInstall vlc-plugin-video-output:amd64 < 3.0.8-0ubuntu18.04.1 -> 3.0.9.2-1 @ii umU Ib > FU=0
  Installing libavcodec58 as Depends of vlc-plugin-video-output
    MarkInstall libavcodec58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
    Installing libaom0 as Depends of libavcodec58
      MarkInstall libaom0:amd64 < none -> 1.0.0.errata1-3build1 @un uN > FU=0
    Installing libavutil56 as Depends of libavcodec58
      MarkInstall libavutil56:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
      Installing ocl-icd-libopencl1 as Depends of libavutil56
        MarkInstall ocl-icd-libopencl1:amd64 < none -> 2.2.11-1ubuntu1 @un uN > FU=0
    Installing libcodec2-0.9 as Depends of libavcodec58
      MarkInstall libcodec2-0.9:amd64 < none -> 0.9.2-2 @un uN > FU=0
    Installing libswresample3 as Depends of libavcodec58
      MarkInstall libswresample3:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
    Installing libvpx6 as Depends of libavcodec58
      MarkInstall libvpx6:amd64 < none -> 1.8.2-1build1 @un uN > FU=0
    Installing libx264-155 as Depends of libavcodec58
      MarkInstall libx264-155:amd64 < none -> 2:0.155.2917+git0a84d98-2 @un uN > FU=0
    Installing libx265-179 as Depends of libavcodec58
      MarkInstall libx265-179:amd64 < none -> 3.2.1-1build1 @un uN > FU=0
  Installing libplacebo7 as Depends of vlc-plugin-video-output
    MarkInstall libplacebo7:amd64 < none -> 1.7.0-2 @un uN > FU=0
  MarkInstall hplip-data:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
  Installing python3-distro as Depends of hplip-data
    MarkInstall python3-distro:amd64 < none -> 1.4.0-1 @un uN > FU=0
  MarkInstall libkf5akonadicore-bin:amd64 < 4:17.12.3-0ubuntu3 -> 4:19.12.3-0ubuntu2 @ii umU Ib > FU=0
  Installing libkf5akonadi-data as Depends of libkf5akonadicore-bin
    MarkInstall libkf5akonadi-data:amd64 < none -> 4:19.12.3-0ubuntu2 @un uN > FU=0
  MarkInstall xserver-xorg:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii umU IPb > FU=0
  new important dependency: mesa-vulkan-drivers:amd64
  Installing mesa-vulkan-drivers as Recommends of xserver-xorg
    MarkInstall mesa-vulkan-drivers:amd64 < none -> 20.2.6-0ubuntu0.20.04.1 @un uN Ib > FU=0
    Installing libllvm11 as Depends of mesa-vulkan-drivers
      MarkInstall libllvm11:amd64 < none -> 1:11.0.0-2~ubuntu20.04.1 @un uN Ib > FU=0
      Installing libffi7 as Depends of libllvm11
        MarkInstall libffi7:amd64 < none -> 3.3-4 @un uN > FU=0
  MarkInstall gnome-calendar:amd64 < 3.28.2-0ubuntu0.18.04.1 -> 3.36.2-0ubuntu1 @ii umU Ib > FU=0
  Installing libecal-2.0-1 as Depends of gnome-calendar
    MarkInstall libecal-2.0-1:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
    Installing libedataserver-1.2-24 as Depends of libecal-2.0-1
      MarkInstall libedataserver-1.2-24:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
      Installing libcamel-1.2-62 as Depends of libedataserver-1.2-24
        MarkInstall libcamel-1.2-62:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
        Installing libicu66 as Depends of libcamel-1.2-62
          MarkInstall libicu66:amd64 < none -> 66.1-2ubuntu2 @un uN > FU=0
  Installing libgweather-3-16 as Depends of gnome-calendar
    MarkInstall libgweather-3-16:amd64 < none -> 3.36.1-1~ubuntu20.04.1 @un uN > FU=0
  Installing libhandy-0.0-0 as Depends of gnome-calendar
    MarkInstall libhandy-0.0-0:amd64 < none -> 0.0.13-1 @un uN > FU=0
  MarkInstall libgupnp-igd-1.0-4:amd64 < 0.2.5-1 -> 0.2.5-5 @ii umU Ib > FU=0
  Installing libgssdp-1.2-0 as Depends of libgupnp-igd-1.0-4
    MarkInstall libgssdp-1.2-0:amd64 < none -> 1.2.3-0ubuntu0.20.04.1 @un uN > FU=0
  Installing libgupnp-1.2-0 as Depends of libgupnp-igd-1.0-4
    MarkInstall libgupnp-1.2-0:amd64 < none -> 1.2.3-0ubuntu0.20.04.1 @un uN > FU=0
  MarkInstall libatlas3-base:amd64 < 3.10.3-5 -> 3.10.3-8ubuntu7 @ii umU Ib > FU=0
  Installing libgfortran5 as Depends of libatlas3-base
    MarkInstall libgfortran5:amd64 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
  MarkInstall tracker-extract:amd64 < 2.0.4-1 -> 2.3.3-2 @ii umU Ib > FU=0
  Installing libcue2 as Depends of tracker-extract
    MarkInstall libcue2:amd64 < none -> 2.2.1-2 @un uN > FU=0
  Installing libexempi8 as Depends of tracker-extract
    MarkInstall libexempi8:amd64 < none -> 2.5.1-1build1 @un uN > FU=0
  MarkInstall poppler-utils:amd64 < 0.62.0-2ubuntu2.12 -> 0.86.1-0ubuntu1 @ii umU Ib > FU=0
  Installing libpoppler97 as Depends of poppler-utils
    MarkInstall libpoppler97:amd64 < none -> 0.86.1-0ubuntu1 @un uN > FU=0
  MarkInstall kdepim-runtime:amd64 < 4:17.12.3-0ubuntu2 -> 4:19.12.3-0ubuntu1 @ii umU Ib > FU=0
  Installing libsasl2-modules-kdexoauth2 as Depends of kdepim-runtime
    MarkInstall libsasl2-modules-kdexoauth2:amd64 < none -> 19.12.3-0ubuntu1 @un uN > FU=0
  Installing libkf5akonadicore5abi2 as Depends of kdepim-runtime
    MarkInstall libkf5akonadicore5abi2:amd64 < none -> 4:19.12.3-0ubuntu2 @un uN Ib > FU=0
    Installing libkf5akonadiprivate5abi2 as Depends of libkf5akonadicore5abi2
      MarkInstall libkf5akonadiprivate5abi2:amd64 < none -> 4:19.12.3-0ubuntu2 @un uN > FU=0
    Installing libkf5akonadiwidgets5abi1 as Recommends of libkf5akonadicore5abi2
      MarkInstall libkf5akonadiwidgets5abi1:amd64 < none -> 4:19.12.3-0ubuntu2 @un uN > FU=0
  Installing libkf5alarmcalendar5abi2 as Depends of kdepim-runtime
    MarkInstall libkf5alarmcalendar5abi2:amd64 < none -> 4:19.12.3-0ubuntu1 @un uN Ib > FU=0
    Installing libkf5calendarcore5abi2 as Depends of libkf5alarmcalendar5abi2
      MarkInstall libkf5calendarcore5abi2:amd64 < none -> 5:5.68.0-0ubuntu1 @un uN > FU=0
  Installing libkpimgapicore5abi1 as Depends of kdepim-runtime
    MarkInstall libkpimgapicore5abi1:amd64 < none -> 19.12.3-0ubuntu1 @un uN > FU=0
  Installing libkpimkdav5abi2 as Depends of kdepim-runtime
    MarkInstall libkpimkdav5abi2:amd64 < none -> 19.12.3-0ubuntu1 @un uN > FU=0
  Installing libqca-qt5-2 as Depends of kdepim-runtime
    MarkInstall libqca-qt5-2:amd64 < none -> 2.2.1-2build1 @un uN IPb > FU=0
    Installing libqca-qt5-2-plugins as Recommends of libqca-qt5-2
      MarkInstall libqca-qt5-2-plugins:amd64 < none -> 2.2.1-2build1 @un uN > FU=0
  Installing libqt5networkauth5 as Depends of kdepim-runtime
    MarkInstall libqt5networkauth5:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
  MarkInstall libgusb2:amd64 < 0.2.11-1 -> 0.3.4-0.1 @ii umU IPb > FU=0
  new important dependency: usb.ids:amd64
  Installing usb.ids as Recommends of libgusb2
    MarkInstall usb.ids:amd64 < none -> 2020.03.19-1 @un uN > FU=0
  MarkInstall akonadi-server:amd64 < 4:17.12.3-0ubuntu3 -> 4:19.12.3-0ubuntu2 @ii umU Ib > FU=0
  Installing libaccounts-qt5-1 as Depends of akonadi-server
    MarkInstall libaccounts-qt5-1:amd64 < none -> 1.15+17.04.20161104.1-0ubuntu3 @un uN Ib > FU=0
    Installing libaccounts-glib0 as Depends of libaccounts-qt5-1
      MarkInstall libaccounts-glib0:amd64 < none -> 1.23+17.04.20161104-0ubuntu3 @un uN > FU=0
  MarkInstall libaa1:amd64 < 1.4p5-44build2 -> 1.4p5-46 @ii umU Ib > FU=0
  Installing libncurses6 as Depends of libaa1
    MarkInstall libncurses6:amd64 < none -> 6.2-0ubuntu2 @un uN > FU=0
    MarkKeep gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3 @ii mR > FU=0
  MarkInstall libvte-2.91-0:amd64 < 0.52.2-1ubuntu1~18.04.2 -> 0.60.3-0ubuntu1~20.04 @ii umU Ib > FU=0
  Installing libpcre2-8-0 as Depends of libvte-2.91-0
    MarkInstall libpcre2-8-0:amd64 < none -> 10.34-7 @un uN > FU=0
  MarkInstall sonnet-plugins:amd64 < 5.44.0-0ubuntu1 -> 5.68.0-0ubuntu1 @ii umU Ib > FU=0
  Installing libhunspell-1.7-0 as Depends of sonnet-plugins
    MarkInstall libhunspell-1.7-0:amd64 < none -> 1.7.0-2build2 @un uN > FU=0
  MarkInstall xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
  MarkInstall gedit:amd64 < 3.28.1-1ubuntu1.2 -> 3.36.2-0ubuntu1 @ii umU Ib > FU=0
  Installing gir1.2-gtksource-4 as Depends of gedit
    MarkInstall gir1.2-gtksource-4:amd64 < none -> 4.6.0-1 @un uN Ib > FU=0
    Installing libgtksourceview-4-0 as Depends of gir1.2-gtksource-4
      MarkInstall libgtksourceview-4-0:amd64 < none -> 4.6.0-1 @un uN Ib > FU=0
      Installing libgtksourceview-4-common as Depends of libgtksourceview-4-0
        MarkInstall libgtksourceview-4-common:amd64 < none -> 4.6.0-1 @un uN > FU=0
  Installing libamtk-5-0 as Depends of gedit
    MarkInstall libamtk-5-0:amd64 < none -> 5.0.2-1build1 @un uN Ib > FU=0
    Installing libamtk-5-common as Depends of libamtk-5-0
      MarkInstall libamtk-5-common:amd64 < none -> 5.0.2-1build1 @un uN > FU=0
  Installing libgspell-1-2 as Depends of gedit
    MarkInstall libgspell-1-2:amd64 < none -> 1.8.3-1 @un uN Ib > FU=0
    Installing libenchant-2-2 as Depends of libgspell-1-2
      MarkInstall libenchant-2-2:amd64 < none -> 2.2.8-1ubuntu0.20.04.1 @un uN IPb > FU=0
      Installing enchant-2 as Recommends of libenchant-2-2
        MarkInstall enchant-2:amd64 < none -> 2.2.8-1ubuntu0.20.04.1 @un uN > FU=0
  Installing libtepl-4-0 as Depends of gedit
    MarkInstall libtepl-4-0:amd64 < none -> 4.4.0-1 @un uN Ib > FU=0
    Installing libuchardet0 as Depends of libtepl-4-0
      MarkInstall libuchardet0:amd64 < none -> 0.0.6-3build1 @un uN > FU=0
  MarkInstall iptables:amd64 < 1.6.1-2ubuntu2 -> 1.8.4-3ubuntu2 @ii umU Ib > FU=0
  Installing libip4tc2 as Depends of iptables
    MarkInstall libip4tc2:amd64 < none -> 1.8.4-3ubuntu2 @un uN > FU=0
  Installing libip6tc2 as Depends of iptables
    MarkInstall libip6tc2:amd64 < none -> 1.8.4-3ubuntu2 @un uN > FU=0
  Installing libnftnl11 as Depends of iptables
    MarkInstall libnftnl11:amd64 < none -> 1.1.5-1 @un uN > FU=0
  MarkInstall xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
  MarkInstall gvfs-backends:amd64 < 1.36.1-0ubuntu1.3.3 -> 1.44.1-1ubuntu1 @ii umU Ib > FU=0
  Installing libcdio18 as Depends of gvfs-backends
    MarkInstall libcdio18:amd64 < none -> 2.0.0-2 @un uN > FU=0
  Installing libnfs13 as Depends of gvfs-backends
    MarkInstall libnfs13:amd64 < none -> 4.0.0-1 @un uN > FU=0
  MarkInstall libkf5pimcommonakonadi5:amd64 < 4:17.12.3-0ubuntu1 -> 4:19.12.3-0ubuntu1 @ii umU Ib > FU=0
  Installing libkf5pimtextedit5abi3 as Depends of libkf5pimcommonakonadi5
    MarkInstall libkf5pimtextedit5abi3:amd64 < none -> 19.12.3-0ubuntu1 @un uN > FU=0
  MarkInstall ffmpeg:amd64 < 7:3.4.8-0ubuntu0.2 -> 7:4.2.4-1ubuntu0.1 @ii umU Ib > FU=0
  Installing libavdevice58 as Depends of ffmpeg
    MarkInstall libavdevice58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
    Installing libavfilter7 as Depends of libavdevice58
      MarkInstall libavfilter7:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
      Installing libavformat58 as Depends of libavfilter7
        MarkInstall libavformat58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
      Installing libmysofa1 as Depends of libavfilter7
        MarkInstall libmysofa1:amd64 < none -> 1.0~dfsg0-1 @un uN > FU=0
      Installing libpostproc55 as Depends of libavfilter7
        MarkInstall libpostproc55:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
      Installing libswscale5 as Depends of libavfilter7
        MarkInstall libswscale5:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
      Installing libvidstab1.1 as Depends of libavfilter7
        MarkInstall libvidstab1.1:amd64 < none -> 1.1.0-2 @un uN > FU=0
    Installing libsndio7.0 as Depends of libavdevice58
      MarkInstall libsndio7.0:amd64 < none -> 1.5.0-3 @un uN > FU=0
  Installing libavresample4 as Depends of ffmpeg
    MarkInstall libavresample4:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
  MarkInstall gnome-control-center:amd64 < 1:3.28.2-0ubuntu0.18.04.6 -> 1:3.36.4-0ubuntu2 @ii umU Ib > FU=0
  Installing libgsound0 as Depends of gnome-control-center
    MarkInstall libgsound0:amd64 < none -> 1.0.2-4 @un uN > FU=0
  new important dependency: rygel:amd64
  Installing rygel as Recommends of gnome-control-center
    MarkInstall rygel:amd64 < none -> 0.38.3-1ubuntu1 @un uN Ib > FU=0
    Installing libgupnp-av-1.0-2 as Depends of rygel
      MarkInstall libgupnp-av-1.0-2:amd64 < none -> 0.12.11-2 @un uN > FU=0
    Installing libgupnp-dlna-2.0-3 as Depends of rygel
      MarkInstall libgupnp-dlna-2.0-3:amd64 < none -> 0.10.5-4 @un uN > FU=0
    Installing librygel-core-2.6-2 as Depends of rygel
      MarkInstall librygel-core-2.6-2:amd64 < none -> 0.38.3-1ubuntu1 @un uN > FU=0
    Installing librygel-db-2.6-2 as Depends of rygel
      MarkInstall librygel-db-2.6-2:amd64 < none -> 0.38.3-1ubuntu1 @un uN > FU=0
    Installing librygel-renderer-2.6-2 as Depends of rygel
      MarkInstall librygel-renderer-2.6-2:amd64 < none -> 0.38.3-1ubuntu1 @un uN > FU=0
    Installing librygel-server-2.6-2 as Depends of rygel
      MarkInstall librygel-server-2.6-2:amd64 < none -> 0.38.3-1ubuntu1 @un uN > FU=0
  MarkInstall libevdocument3-4:amd64 < 3.28.4-0ubuntu1.2 -> 3.36.7-0ubuntu1 @ii umU Ib > FU=0
  Installing libsynctex2 as Depends of libevdocument3-4
    MarkInstall libsynctex2:amd64 < none -> 2019.20190605.51237-3build2 @un uN > FU=0
  MarkInstall libpam-modules:amd64 < 1.1.8-3.6ubuntu2.18.04.2 -> 1.3.1-5ubuntu4.1 @ii umU NPb IPb > FU=0
  ignore old unsatisfied important dependency on update-motd:amd64
  MarkInstall linux-headers-5.4.0-62-generic:amd64 < 5.4.0-62.70~18.04.1 -> 5.4.0-62.70 @ii umU Ib > FU=0
  Installing linux-headers-5.4.0-62 as Depends of linux-headers-5.4.0-62-generic
    MarkInstall linux-headers-5.4.0-62:amd64 < none -> 5.4.0-62.70 @un uN > FU=0
  MarkInstall sane-utils:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
  Installing libsane as Depends of sane-utils
    MarkInstall libsane:amd64 < none -> 1.0.29-0ubuntu5.2 @un uN Ib > FU=0
    Installing libsnmp35 as Depends of libsane
      MarkInstall libsnmp35:amd64 < none -> 5.8+dfsg-2ubuntu2.3 @un uN Ib > FU=0
      Installing libmysqlclient21 as Depends of libsnmp35
        MarkInstall libmysqlclient21:amd64 < none -> 8.0.23-0ubuntu0.20.04.1 @un uN > FU=0
      Installing libperl5.30 as Depends of libsnmp35
        MarkInstall libperl5.30:amd64 < none -> 5.30.0-9ubuntu0.2 @un uN Ib > FU=0
        Installing libgdbm6 as Depends of libperl5.30
          MarkInstall libgdbm6:amd64 < none -> 1.18.1-5 @un uN > FU=0
        Installing perl-modules-5.30 as Depends of libperl5.30
          MarkInstall perl-modules-5.30:amd64 < none -> 5.30.0-9ubuntu0.2 @un uN > FU=0
      Installing libsensors5 as Depends of libsnmp35
        MarkInstall libsensors5:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib > FU=0
        Installing libsensors-config as Depends of libsensors5
          MarkInstall libsensors-config:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib > FU=0
           Removing: libsensors4
            MarkDelete libsensors4:amd64 < 1:3.4.0-4 @ii mK > FU=0
  MarkInstall libc6-dev:amd64 < 2.27-3ubuntu1.4 -> 2.31-0ubuntu9.2 @ii umU Ib > FU=0
  Installing libcrypt-dev as Depends of libc6-dev
    MarkInstall libcrypt-dev:amd64 < none -> 1:4.4.10-10ubuntu4 @un uN > FU=0
  MarkInstall libargon2-0:amd64 < 0~20161029-1.1 -> 0~20171227-0.2 @ii umU Ib > FU=0
  Installing libargon2-1 as Depends of libargon2-0
    MarkInstall libargon2-1:amd64 < none -> 0~20171227-0.2 @un uN > FU=0
  MarkInstall va-driver-all:amd64 < 2.1.0-3 -> 2.7.0-2 @ii umU Ib > FU=0
  Installing intel-media-va-driver as Depends of va-driver-all
    MarkInstall intel-media-va-driver:amd64 < none -> 20.1.1+dfsg1-1 @un uN Ib > FU=0
    Installing libigdgmm11 as Depends of intel-media-va-driver
      MarkInstall libigdgmm11:amd64 < none -> 20.1.1+ds1-1 @un uN > FU=0
  MarkInstall vino:amd64 < 3.22.0-3ubuntu1.2 -> 3.22.0-5ubuntu2.2 @ii umU Ib > FU=0
  Installing libminiupnpc17 as Depends of vino
    MarkInstall libminiupnpc17:amd64 < none -> 2.1.20190824-0ubuntu2 @un uN > FU=0
  MarkInstall ntfs-3g:amd64 < 1:2017.3.23-2ubuntu0.18.04.2 -> 1:2017.3.23AR.3-3ubuntu1 @ii umU Ib > FU=0
  Installing libntfs-3g883 as Depends of ntfs-3g
    MarkInstall libntfs-3g883:amd64 < none -> 1:2017.3.23AR.3-3ubuntu1 @un uN > FU=0
  MarkInstall libgeos-c1v5:amd64 < 3.6.2-1build2 -> 3.8.0-1build1 @ii umU Ib > FU=0
  Installing libgeos-3.8.0 as Depends of libgeos-c1v5
    MarkInstall libgeos-3.8.0:amd64 < none -> 3.8.0-1build1 @un uN > FU=0
  MarkInstall libcmis-0.5-5v5:amd64 < 0.5.1+git20160603-3build2 -> 0.5.2-1ubuntu1 @ii umU Ib > FU=0
  Installing libboost-date-time1.71.0 as Depends of libcmis-0.5-5v5
    MarkInstall libboost-date-time1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
  MarkInstall fonts-smc:amd64 < 1:7.0 -> 1:7.1 @ii umU Ib > FU=0
  Installing fonts-smc-gayathri as Depends of fonts-smc
    MarkInstall fonts-smc-gayathri:amd64 < none -> 1.100-1 @un uN > FU=0
  MarkInstall apt:amd64 < 1.6.12ubuntu0.2 -> 2.0.4 @ii umU Ib > FU=0
  Installing libapt-pkg6.0 as Depends of apt
    MarkInstall libapt-pkg6.0:amd64 < none -> 2.0.4 @un uN > FU=0
  MarkInstall python3-markdown:amd64 < 2.6.9-1 -> 3.1.1-3 @ii umU Ib > FU=0
  Installing python3-packaging as Depends of python3-markdown
    MarkInstall python3-packaging:amd64 < none -> 20.3-1 @un uN > FU=0
  MarkInstall libgjs0g:amd64 < 1.52.5-0ubuntu18.04.1 -> 1.64.3-1~ubuntu20.04.1 @ii umU Ib > FU=0
  Installing libmozjs-68-0 as Depends of libgjs0g
    MarkInstall libmozjs-68-0:amd64 < none -> 68.6.0-1ubuntu1 @un uN > FU=0
  MarkInstall linux-headers-5.4.0-65-generic:amd64 < 5.4.0-65.73~18.04.1 -> 5.4.0-65.73 @ii umU Ib > FU=0
  Installing linux-headers-5.4.0-65 as Depends of linux-headers-5.4.0-65-generic
    MarkInstall linux-headers-5.4.0-65:amd64 < none -> 5.4.0-65.73 @un uN > FU=0
  MarkInstall libreoffice-core:amd64 < 1:6.0.7-0ubuntu0.18.04.10 -> 1:6.4.6-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libboost-locale1.71.0 as Depends of libreoffice-core
    MarkInstall libboost-locale1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN Ib > FU=0
    Installing libboost-thread1.71.0 as Depends of libboost-locale1.71.0
      MarkInstall libboost-thread1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
  Installing liborcus-0.15-0 as Depends of libreoffice-core
    MarkInstall liborcus-0.15-0:amd64 < none -> 0.15.3-3build2 @un uN Ib > FU=0
    Installing libboost-filesystem1.71.0 as Depends of liborcus-0.15-0
      MarkInstall libboost-filesystem1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
    Installing libboost-iostreams1.71.0 as Depends of liborcus-0.15-0
      MarkInstall libboost-iostreams1.71.0:amd64 < none -> 1.71.0-6ubuntu6 @un uN > FU=0
  MarkInstall cpp-7:amd64 < 7.5.0-3ubuntu1~18.04 -> 7.5.0-6ubuntu2 @ii umU Ib > FU=0
  Installing libisl22 as Depends of cpp-7
    MarkInstall libisl22:amd64 < none -> 0.22.1-1 @un uN > FU=0
  MarkInstall yelp:amd64 < 3.26.0-1ubuntu2 -> 3.36.0-1 @ii umU IPb > FU=0
  new important dependency: docbook-xml:amd64
  Installing docbook-xml as Recommends of yelp
    MarkInstall docbook-xml:amd64 < none -> 4.5-9 @un uN Ib > FU=0
    Installing sgml-data as Depends of docbook-xml
      MarkInstall sgml-data:amd64 < none -> 2.0.11 @un uN > FU=0
  MarkInstall libasound2-data:amd64 < 1.1.3-5ubuntu0.5 -> 1.2.2-2.1ubuntu2.3 @ii umU IPb > FU=0
  new important dependency: alsa-ucm-conf:amd64
  Installing alsa-ucm-conf as Recommends of libasound2-data
    MarkInstall alsa-ucm-conf:amd64 < none -> 1.2.2-1ubuntu0.5 @un uN > FU=0
  new important dependency: alsa-topology-conf:amd64
  Installing alsa-topology-conf as Recommends of libasound2-data
    MarkInstall alsa-topology-conf:amd64 < none -> 1.2.2-1 @un uN > FU=0
  MarkInstall knotes:amd64 < 4:17.12.3-0ubuntu1 -> 4:19.12.3-0ubuntu1 @ii umU Ib > FU=0
  Installing libkf5grantleetheme-plugins as Depends of knotes
    MarkInstall libkf5grantleetheme-plugins:amd64 < none -> 19.12.3-0ubuntu1 @un uN > FU=0
  Installing libkf5grantleetheme5 as Depends of knotes
    MarkInstall libkf5grantleetheme5:amd64 < none -> 19.12.3-0ubuntu1 @un uN Ib > FU=0
    Installing libkf5grantleetheme-data as Depends of libkf5grantleetheme5
      MarkInstall libkf5grantleetheme-data:amd64 < none -> 19.12.3-0ubuntu1 @un uN > FU=0
  MarkInstall python3-protobuf:amd64 < 3.0.0-9.1ubuntu1 -> 3.6.1.3-2ubuntu5 @ii umU Ib > FU=0
  Installing libprotobuf17 as Depends of python3-protobuf
    MarkInstall libprotobuf17:amd64 < none -> 3.6.1.3-2ubuntu5 @un uN > FU=0
  MarkInstall cpp:amd64 < 4:7.4.0-1ubuntu2.3 -> 4:9.3.0-1ubuntu2 @ii umU Ib > FU=0
  Installing cpp-9 as Depends of cpp
    MarkInstall cpp-9:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN Ib > FU=0
    Installing gcc-9-base as Depends of cpp-9
      MarkInstall gcc-9-base:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN > FU=0
  MarkInstall libgpg-error0:amd64 < 1.27-6 -> 1.37-1 @ii umU IPb > FU=0
  new important dependency: libgpg-error-l10n:amd64
  Installing libgpg-error-l10n as Recommends of libgpg-error0
    MarkInstall libgpg-error-l10n:amd64 < none -> 1.37-1 @un uN > FU=0
  MarkInstall bind9-host:amd64 < 1:9.11.3+dfsg-1ubuntu1.13 -> 1:9.16.1-0ubuntu2.4 @ii umU Ib > FU=0
  Installing bind9-libs as Depends of bind9-host
    MarkInstall bind9-libs:amd64 < none -> 1:9.16.1-0ubuntu2.4 @un uN Ib > FU=0
    Installing libjson-c4 as Depends of bind9-libs
      MarkInstall libjson-c4:amd64 < none -> 0.13.1+dfsg-7ubuntu0.3 @un uN > FU=0
    Installing liblmdb0 as Depends of bind9-libs
      MarkInstall liblmdb0:amd64 < none -> 0.9.24-1 @un uN > FU=0
    Installing libmaxminddb0 as Depends of bind9-libs
      MarkInstall libmaxminddb0:amd64 < none -> 1.4.2-0ubuntu1.20.04.1 @un uN > FU=0
    Installing libuv1 as Depends of bind9-libs
      MarkInstall libuv1:amd64 < none -> 1.34.2-1ubuntu1.1 @un uN > FU=0
  MarkInstall libarchive13:amd64 < 3.2.2-3.1ubuntu0.6 -> 3.4.0-2ubuntu1 @ii umU Ib > FU=0
  Installing libnettle7 as Depends of libarchive13
    MarkInstall libnettle7:amd64 < none -> 3.5.1+really3.5.1-2 @un uN > FU=0
  MarkInstall e2fsprogs:amd64 < 1.44.1-1ubuntu1.3 -> 1.45.5-2ubuntu1 @ii umU NPb Ib > FU=0
  Installing logsave as Depends of e2fsprogs
    MarkInstall logsave:amd64 < none -> 1.45.5-2ubuntu1 @un uN > FU=0
  ignore old unsatisfied important dependency on e2fsprogs-l10n:amd64
  MarkInstall libspatialite7:amd64 < 4.3.0a-5build1 -> 4.3.0a-6build1 @ii umU Ib > FU=0
  Installing libproj15 as Depends of libspatialite7
    MarkInstall libproj15:amd64 < none -> 6.3.1-1 @un uN > FU=0
  MarkInstall dnsutils:amd64 < 1:9.11.3+dfsg-1ubuntu1.13 -> 1:9.16.1-0ubuntu2.4 @ii umU Ib > FU=0
  Installing bind9-dnsutils as Depends of dnsutils
    MarkInstall bind9-dnsutils:amd64 < none -> 1:9.16.1-0ubuntu2.4 @un uN > FU=0
  MarkInstall g++:amd64 < 4:7.4.0-1ubuntu2.3 -> 4:9.3.0-1ubuntu2 @ii umU Ib > FU=0
  Installing g++-9 as Depends of g++
    MarkInstall g++-9:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN Ib > FU=0
    Installing gcc-9 as Depends of g++-9
      MarkInstall gcc-9:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN Ib > FU=0
      Installing libgcc-9-dev as Depends of gcc-9
        MarkInstall libgcc-9-dev:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN Ib > FU=0
        Installing libasan5 as Depends of libgcc-9-dev
          MarkInstall libasan5:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN > FU=0
        Installing libubsan1 as Depends of libgcc-9-dev
          MarkInstall libubsan1:amd64 < none -> 10.2.0-5ubuntu1~20.04 @un uN > FU=0
    Installing libstdc++-9-dev as Depends of g++-9
      MarkInstall libstdc++-9-dev:amd64 < none -> 9.3.0-17ubuntu1~20.04 @un uN > FU=0
  MarkInstall dnsmasq-base:amd64 < 2.79-1ubuntu0.2 -> 2.80-1.1ubuntu1.2 @ii umU Ib > FU=0
  Installing libhogweed5 as Depends of dnsmasq-base
    MarkInstall libhogweed5:amd64 < none -> 3.5.1+really3.5.1-2 @un uN > FU=0
  MarkInstall python3-brlapi:amd64 < 5.5-4ubuntu2.0.1 -> 6.0+dfsg-4ubuntu6 @ii umU Ib > FU=0
  Installing libbrlapi0.7 as Depends of python3-brlapi
    MarkInstall libbrlapi0.7:amd64 < none -> 6.0+dfsg-4ubuntu6 @un uN > FU=0
  MarkInstall python3-pil:amd64 < 5.1.0-1ubuntu0.4 -> 7.0.0-4ubuntu0.2 @ii umU Ib > FU=0
  Installing libimagequant0 as Depends of python3-pil
    MarkInstall libimagequant0:amd64 < none -> 2.12.2-1.1 @un uN > FU=0
  MarkInstall python3-keyring:amd64 < 10.6.0-1 -> 18.0.1-2ubuntu1 @ii umU Ib > FU=0
  Installing python3-entrypoints as Depends of python3-keyring
    MarkInstall python3-entrypoints:amd64 < none -> 0.3-2ubuntu1 @un uN > FU=0
  MarkInstall docker-ce-rootless-extras:amd64 < 5:20.10.2~3-0~ubuntu-bionic @ii mK NPb IPb > FU=0
  ignore old unsatisfied important dependency on slirp4netns:amd64
  MarkInstall ubuntu-session:amd64 < 3.28.1-0ubuntu3 -> 3.36.0-2ubuntu1 @ii umU Ib > FU=0
  Installing yaru-theme-gnome-shell as Depends of ubuntu-session
    MarkInstall yaru-theme-gnome-shell:amd64 < none -> 20.04.10.1 @un uN > FU=0
  MarkInstall supertuxkart-data:amd64 < 0.9.3-1 -> 1.1+ds-1build1 @ii umU Ib > FU=0
  Installing fonts-noto-core as Depends of supertuxkart-data
    MarkInstall fonts-noto-core:amd64 < none -> 20200323-1build1~ubuntu20.04.1 @un uN > FU=0
  Installing fonts-noto-ui-core as Depends of supertuxkart-data
    MarkInstall fonts-noto-ui-core:amd64 < none -> 20200323-1build1~ubuntu20.04.1 @un uN > FU=0
  MarkInstall libnet-dns-perl:amd64 < 1.10-2 -> 1.22-1 @ii umU IPb > FU=0
  new important dependency: libdigest-bubblebabble-perl:amd64
  Installing libdigest-bubblebabble-perl as Recommends of libnet-dns-perl
    MarkInstall libdigest-bubblebabble-perl:amd64 < none -> 0.02-2 @un uN > FU=0
  new important dependency: libnet-dns-sec-perl:amd64
  Installing libnet-dns-sec-perl as Recommends of libnet-dns-perl
    MarkInstall libnet-dns-sec-perl:amd64 < none -> 1.15-1 @un uN > FU=0
  new important dependency: libperl4-corelibs-perl:amd64
  Installing libperl4-corelibs-perl as Recommends of libnet-dns-perl
    MarkInstall libperl4-corelibs-perl:amd64 < none -> 0.004-2 @un uN > FU=0
  MarkInstall ubuntu-desktop:amd64 < 1.417.5 -> 1.450.2 @ii umU Ib > FU=0
  Installing gnome-shell-extension-desktop-icons as Depends of ubuntu-desktop
    MarkInstall gnome-shell-extension-desktop-icons:amd64 < none -> 20.04.0-3~ubuntu20.04.1 @un uN > FU=0
  Installing ubuntu-desktop-minimal as Depends of ubuntu-desktop
    MarkInstall ubuntu-desktop-minimal:amd64 < none -> 1.450.2 @un uN IPb > FU=0
    Installing apt-config-icons-hidpi as Recommends of ubuntu-desktop-minimal
      MarkInstall apt-config-icons-hidpi:amd64 < none -> 0.12.10-2 @un uN > FU=0
    Installing gamemode as Recommends of ubuntu-desktop-minimal
      MarkInstall gamemode:amd64 < none -> 1.5.1-0ubuntu3.1 @un uN Ib > FU=0
      Installing libgamemode0 as Depends of gamemode
        MarkInstall libgamemode0:amd64 < none -> 1.5.1-0ubuntu3.1 @un uN > FU=0
      Installing libgamemodeauto0 as Depends of gamemode
        MarkInstall libgamemodeauto0:amd64 < none -> 1.5.1-0ubuntu3.1 @un uN > FU=0
    Installing gnome-calculator as Recommends of ubuntu-desktop-minimal
      MarkInstall gnome-calculator:amd64 < none -> 1:3.36.0-1ubuntu1 @un uN > FU=0
    Installing gnome-characters as Recommends of ubuntu-desktop-minimal
      MarkInstall gnome-characters:amd64 < none -> 3.34.0-1 @un uN > FU=0
    Installing gnome-logs as Recommends of ubuntu-desktop-minimal
      MarkInstall gnome-logs:amd64 < none -> 3.34.0-1ubuntu1 @un uN > FU=0
    Installing gnome-system-monitor as Recommends of ubuntu-desktop-minimal
      MarkInstall gnome-system-monitor:amd64 < none -> 3.36.1-0ubuntu0.20.04.1 @un uN > FU=0
    Installing network-manager-openvpn-gnome as Recommends of ubuntu-desktop-minimal
      MarkInstall network-manager-openvpn-gnome:amd64 < none -> 1.8.12-1 @un uN Ib > FU=0
      Installing network-manager-openvpn as Depends of network-manager-openvpn-gnome
        MarkInstall network-manager-openvpn:amd64 < none -> 1.8.12-1 @un uN Ib > FU=0
        Installing openvpn as Depends of network-manager-openvpn
          MarkInstall openvpn:amd64 < none -> 2.4.7-1ubuntu2 @un uN Ib > FU=0
          Installing libpkcs11-helper1 as Depends of openvpn
            MarkInstall libpkcs11-helper1:amd64 < none -> 1.26-1 @un uN > FU=0
    Installing plymouth-theme-spinner as Recommends of ubuntu-desktop-minimal
      MarkInstall plymouth-theme-spinner:amd64 < none -> 0.9.4git20200323-0ubuntu6.2 @un uN Ib > FU=0
      Installing libplymouth5 as Depends of plymouth-theme-spinner
        MarkInstall libplymouth5:amd64 < none -> 0.9.4git20200323-0ubuntu6.2 @un uN > FU=0
    Installing yaru-theme-gtk as Recommends of ubuntu-desktop-minimal
      MarkInstall yaru-theme-gtk:amd64 < none -> 20.04.10.1 @un uN > FU=0
    Installing yaru-theme-icon as Recommends of ubuntu-desktop-minimal
      MarkInstall yaru-theme-icon:amd64 < none -> 20.04.10.1 @un uN > FU=0
    Installing yaru-theme-sound as Recommends of ubuntu-desktop-minimal
      MarkInstall yaru-theme-sound:amd64 < none -> 20.04.10.1 @un uN > FU=0
  MarkInstall python3-louis:amd64 < 3.5.0-1ubuntu0.3 -> 3.12.0-3 @ii umU Ib > FU=0
  Installing liblouis20 as Depends of python3-louis
    MarkInstall liblouis20:amd64 < none -> 3.12.0-3 @un uN > FU=0
  MarkInstall gstreamer1.0-plugins-bad:amd64 < 1.14.5-0ubuntu1~18.04.1 -> 1.16.2-2.1ubuntu1 @ii umU Ib > FU=0
  Installing libdvdread7 as Depends of gstreamer1.0-plugins-bad
    MarkInstall libdvdread7:amd64 < none -> 6.1.0+really6.0.2-1 @un uN > FU=0
  Installing libfluidsynth2 as Depends of gstreamer1.0-plugins-bad
    MarkInstall libfluidsynth2:amd64 < none -> 2.1.1-2 @un uN Ib > FU=0
    Installing libinstpatch-1.0-2 as Depends of libfluidsynth2
      MarkInstall libinstpatch-1.0-2:amd64 < none -> 1.1.2-2build1 @un uN > FU=0
    Installing timgm6mb-soundfont as Depends of libfluidsynth2
      MarkInstall timgm6mb-soundfont:amd64 < none -> 1.3-3 @un uN > FU=0
  Installing libilmbase24 as Depends of gstreamer1.0-plugins-bad
    MarkInstall libilmbase24:amd64 < none -> 2.3.0-6build1 @un uN > FU=0
  Installing libopenexr24 as Depends of gstreamer1.0-plugins-bad
    MarkInstall libopenexr24:amd64 < none -> 2.3.0-6ubuntu0.3 @un uN > FU=0
  Installing libsrt1 as Depends of gstreamer1.0-plugins-bad
    MarkInstall libsrt1:amd64 < none -> 1.4.0-1build1 @un uN > FU=0
  Installing libusrsctp1 as Depends of gstreamer1.0-plugins-bad
    MarkInstall libusrsctp1:amd64 < none -> 0.9.3.0+20190901-1 @un uN > FU=0
  MarkInstall python3-matplotlib:amd64 < 2.1.1-2ubuntu3 -> 3.1.2-1ubuntu4 @ii umU Ib > FU=0
  Installing python3-kiwisolver as Depends of python3-matplotlib
    MarkInstall python3-kiwisolver:amd64 < none -> 1.0.1-3build1 @un uN > FU=0
  MarkInstall python3-lazr.restfulclient:amd64 < 0.13.5-1 -> 0.14.2-2build1 @ii umU Ib > FU=0
  Installing python3-oauthlib as Depends of python3-lazr.restfulclient
    MarkInstall python3-oauthlib:amd64 < none -> 3.1.0-1ubuntu2 @un uN Ib > FU=0
    Installing python3-blinker as Depends of python3-oauthlib
      MarkInstall python3-blinker:amd64 < none -> 1.4+dfsg1-0.3ubuntu1 @un uN > FU=0
    Installing python3-jwt as Depends of python3-oauthlib
      MarkInstall python3-jwt:amd64 < none -> 1.7.1-2ubuntu2 @un uN > FU=0
  MarkInstall evolution-data-server:amd64 < 3.28.5-0ubuntu0.18.04.3 -> 3.36.4-0ubuntu1 @ii umU Ib > FU=0
  Installing libebook-1.2-20 as Depends of evolution-data-server
    MarkInstall libebook-1.2-20:amd64 < none -> 3.36.4-0ubuntu1 @un uN Ib > FU=0
    Installing libebook-contacts-1.2-3 as Depends of libebook-1.2-20
      MarkInstall libebook-contacts-1.2-3:amd64 < none -> 3.36.4-0ubuntu1 @un uN > FU=0
    Installing libedata-book-1.2-26 as Depends of libebook-1.2-20
      MarkInstall libedata-book-1.2-26:amd64 < none -> 3.36.4-0ubuntu1 @un uN > FU=0
  Installing libedata-cal-2.0-1 as Depends of evolution-data-server
    MarkInstall libedata-cal-2.0-1:amd64 < none -> 3.36.4-0ubuntu1 @un uN > FU=0
  MarkInstall procps:amd64 < 2:3.3.12-3ubuntu1.2 -> 2:3.3.16-1ubuntu2 @ii umU Ib > FU=0
  Installing libprocps8 as Depends of procps
    MarkInstall libprocps8:amd64 < none -> 2:3.3.16-1ubuntu2 @un uN > FU=0
  MarkInstall alsa-utils:amd64 < 1.1.3-1ubuntu1 -> 1.2.2-1ubuntu2 @ii umU Ib > FU=0
  Installing libatopology2 as Depends of alsa-utils
    MarkInstall libatopology2:amd64 < none -> 1.2.2-2.1ubuntu2.3 @un uN > FU=0
  MarkInstall orca:amd64 < 3.28.0-3ubuntu1 -> 3.36.2-1ubuntu1~20.04.1 @ii umU IPb > FU=0
  MarkInstall libvoikko1:amd64 < 4.1.1-1.1 -> 4.3-1build1 @ii umU Ib > FU=0
  Installing libhfstospell10 as Depends of libvoikko1
    MarkInstall libhfstospell10:amd64 < none -> 0.5.0-2build2 @un uN Ib > FU=0
     Removing: libhfstospell9
      MarkDelete libhfstospell9:amd64 < 0.4.5~r343-2.1build2 @ii mK Ib > FU=0
  MarkInstall gdm3:amd64 < 3.28.3-0ubuntu18.04.6 -> 3.36.3-0ubuntu0.20.04.2 @ii umU IPb > FU=0
  new important dependency: libpam-fprintd:amd64
  Installing libpam-fprintd as Recommends of gdm3
    MarkInstall libpam-fprintd:amd64 < none -> 1.90.1-1ubuntu1 @un uN Ib > FU=0
    Installing fprintd as Depends of libpam-fprintd
      MarkInstall fprintd:amd64 < none -> 1.90.1-1ubuntu1 @un uN Ib > FU=0
      Installing libfprint-2-2 as Depends of fprintd
        MarkInstall libfprint-2-2:amd64 < none -> 1:1.90.2+tod1-0ubuntu1~20.04.4 @un uN > FU=0
  MarkInstall libwmf0.2-7:amd64 < 0.2.8.4-12 -> 0.2.8.4-17ubuntu1 @ii umU IPb > FU=0
  new important dependency: fonts-urw-base35:amd64
  Installing fonts-urw-base35 as Recommends of libwmf0.2-7
    MarkInstall fonts-urw-base35:amd64 < none -> 20170801.1-3 @un uN > FU=0
  Ignore MarkInstall of python:amd64 < 2.7.15-3~oibaf~b @ii pgR > as its mode (Delete) is protected
  MarkInstall libkf5bookmarks5:amd64 < 5.44.0-0ubuntu1 -> 5.68.0-0ubuntu1 @ii umU IPb > FU=0
  new important dependency: keditbookmarks:amd64
  Installing keditbookmarks as Recommends of libkf5bookmarks5
    MarkInstall keditbookmarks:amd64 < none -> 19.12.3-0ubuntu1 @un uN Ib > FU=0
    Installing libkf5kiogui5 as Depends of keditbookmarks
      MarkInstall libkf5kiogui5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
  MarkInstall kio:amd64 < 5.44.0-0ubuntu1 -> 5.68.0-0ubuntu1 @ii umU Ib > FU=0
  Installing libkf5authcore5 as Depends of kio
    MarkInstall libkf5authcore5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
  MarkInstall libcharon-standard-plugins:amd64 < 5.6.2-1ubuntu2.5 -> 5.8.2-1ubuntu3.1 @ii umU Ib > FU=0
  Installing libcharon-extauth-plugins as Depends of libcharon-standard-plugins
    MarkInstall libcharon-extauth-plugins:amd64 < none -> 5.8.2-1ubuntu3.1 @un uN > FU=0
  MarkInstall fwupdate:amd64 < 12-7~ubuntu18.04.3 -> 12-7 @ii umU Ib > FU=0
   Removing: fwupdate-signed
    MarkDelete fwupdate-signed:amd64 < 12-7~ubuntu18.04.3 @ii mK > FU=0
   Removing: libfwup1
    MarkDelete libfwup1:amd64 < 12-3bionic2 @ii mK > FU=0
  MarkInstall libkf5libkdepimakonadi5:amd64 < 4:17.12.3-0ubuntu1 -> 4:19.12.3-0ubuntu1 @ii umU Ib > FU=0
  Installing libkf5ldap5abi1 as Depends of libkf5libkdepimakonadi5
    MarkInstall libkf5ldap5abi1:amd64 < none -> 19.12.3-0ubuntu1 @un uN > FU=0
  MarkInstall libgexiv2-2:amd64 < 0.10.8-1 -> 0.12.0-2 @ii umU Ib > FU=0
  Installing libexiv2-27 as Depends of libgexiv2-2
    MarkInstall libexiv2-27:amd64 < none -> 0.27.2-8ubuntu2 @un uN > FU=0
  MarkInstall dh-strip-nondeterminism:amd64 < 0.040-1.1~build1 -> 1.7.0-1 @ii umU Ib > FU=0
  Installing libdebhelper-perl as Depends of dh-strip-nondeterminism
    MarkInstall libdebhelper-perl:amd64 < none -> 12.10ubuntu1 @un uN > FU=0
  MarkInstall libfile-stripnondeterminism-perl:amd64 < 0.040-1.1~build1 -> 1.7.0-1 @ii umU Ib > FU=0
  Installing libsub-override-perl as Depends of libfile-stripnondeterminism-perl
    MarkInstall libsub-override-perl:amd64 < none -> 0.09-2 @un uN > FU=0
  MarkInstall libfontconfig1-dev:amd64 < 2.12.6-0ubuntu2 -> 2.13.1-2ubuntu3 @ii umU Ib > FU=0
  Installing uuid-dev as Depends of libfontconfig1-dev
    MarkInstall uuid-dev:amd64 < none -> 2.34-0.1ubuntu9.1 @un uN > FU=0
  MarkInstall deja-dup:amd64 < 37.1-2fakesync1ubuntu0.1 -> 40.7-0ubuntu1 @ii umU Ib > FU=0
  Installing duplicity as Depends of deja-dup
    MarkInstall duplicity:amd64 < none -> 0.8.11.1612-1 @un uN Ib > FU=0
    Installing librsync2 as Depends of duplicity
      MarkInstall librsync2:amd64 < none -> 2.0.2-1ubuntu1 @un uN > FU=0
    Installing python3-fasteners as Depends of duplicity
      MarkInstall python3-fasteners:amd64 < none -> 0.14.1-2 @un uN Ib > FU=0
      Installing python3-monotonic as Depends of python3-fasteners
        MarkInstall python3-monotonic:amd64 < none -> 1.5-0ubuntu2 @un uN > FU=0
    Installing python3-future as Depends of duplicity
      MarkInstall python3-future:amd64 < none -> 0.18.2-2 @un uN > FU=0
    Installing python3-lockfile as Depends of duplicity
      MarkInstall python3-lockfile:amd64 < none -> 1:0.12.2-2ubuntu2 @un uN > FU=0
    Installing python3-paramiko as Recommends of duplicity
      MarkInstall python3-paramiko:amd64 < none -> 2.6.0-2 @un uN Ib > FU=0
      Installing python3-bcrypt as Depends of python3-paramiko
        MarkInstall python3-bcrypt:amd64 < none -> 3.1.7-2ubuntu1 @un uN > FU=0
  MarkInstall libreoffice-style-galaxy:amd64 < 1:6.0.7-0ubuntu0.18.04.10 -> 1:6.4.6-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libreoffice-style-colibre as Depends of libreoffice-style-galaxy
    MarkInstall libreoffice-style-colibre:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN > FU=0
  MarkInstall libcairo-perl:amd64 < 1.106-2build2 -> 1.107-1 @ii umU Ib > FU=0
  Installing libextutils-depends-perl as Depends of libcairo-perl
    MarkInstall libextutils-depends-perl:amd64 < none -> 0.8000-1 @un uN > FU=0
  Installing libextutils-pkgconfig-perl as Depends of libcairo-perl
    MarkInstall libextutils-pkgconfig-perl:amd64 < none -> 1.16-1 @un uN > FU=0
  MarkInstall aisleriot:amd64 < 1:3.22.5-1 -> 1:3.22.9-1 @ii umU Ib > FU=0
  Installing guile-2.2-libs as Depends of aisleriot
    MarkInstall guile-2.2-libs:amd64 < none -> 2.2.7+1-4 @un uN > FU=0
  MarkInstall samba-libs:amd64 < 2:4.7.6+dfsg~ubuntu-0ubuntu2.21 -> 2:4.11.6+dfsg-0ubuntu1.6 @ii umU Ib > FU=0
  Installing libldb2 as Depends of samba-libs
    MarkInstall libldb2:amd64 < none -> 2:2.0.10-0ubuntu0.20.04.2 @un uN Ib > FU=0
     Removing: libldb1
      MarkDelete libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mK > FU=0
  Installing python3-talloc as Depends of samba-libs
    MarkInstall python3-talloc:amd64 < none -> 2.3.0-3ubuntu1 @un uN > FU=0
  MarkInstall binutils-x86-64-linux-gnu:amd64 < 2.30-21ubuntu1~18.04.4 -> 2.34-6ubuntu1 @ii umU Ib > FU=0
  Installing libctf-nobfd0 as Depends of binutils-x86-64-linux-gnu
    MarkInstall libctf-nobfd0:amd64 < none -> 2.34-6ubuntu1 @un uN > FU=0
  Installing libctf0 as Depends of binutils-x86-64-linux-gnu
    MarkInstall libctf0:amd64 < none -> 2.34-6ubuntu1 @un uN > FU=0
  MarkInstall endless-sky:amd64 < 0.9.8-1 -> 0.9.8-1build2 @ii umU Ib > FU=0
  Installing libglew2.1 as Depends of endless-sky
    MarkInstall libglew2.1:amd64 < none -> 2.1.0-4 @un uN > FU=0
  MarkInstall libpango1.0-dev:amd64 < 1.40.14-1ubuntu0.1 -> 1.44.7-2ubuntu4 @ii umU Ib > FU=0
  Installing libfribidi-dev as Depends of libpango1.0-dev
    MarkInstall libfribidi-dev:amd64 < none -> 1.0.8-2 @un uN > FU=0
  Installing libthai-dev as Depends of libpango1.0-dev
    MarkInstall libthai-dev:amd64 < none -> 0.1.28-3 @un uN Ib > FU=0
    Installing libdatrie-dev as Depends of libthai-dev
      MarkInstall libdatrie-dev:amd64 < none -> 0.2.12-3 @un uN > FU=0
  Installing pango1.0-tools as Depends of libpango1.0-dev
    MarkInstall pango1.0-tools:amd64 < none -> 1.44.7-2ubuntu4 @un uN > FU=0
  MarkInstall libpython-stdlib:amd64 < 2.7.15-3~oibaf~b @ii gK Ib > FU=0
  MarkInstall dpkg:amd64 < 1.19.0.5ubuntu2.3 -> 1.19.7ubuntu3 @ii umU Ib > FU=0
   Removing: libapt-pkg5.0
    MarkDelete libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mK > FU=0
  MarkInstall cups-filters:amd64 < 1.20.2-0ubuntu3.1 -> 1.27.4-1 @ii umU Ib > FU=0
  Installing libqpdf26 as Depends of cups-filters
    MarkInstall libqpdf26:amd64 < none -> 9.1.1-1build1 @un uN > FU=0
  MarkInstall libkf5pimcommon5abi3:amd64 < 4:17.12.3-0ubuntu1 -> 4:19.12.3-0ubuntu1 @ii umU Ib > FU=0
  Installing libkf5purpose-bin as Depends of libkf5pimcommon5abi3
    MarkInstall libkf5purpose-bin:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
    Installing libkaccounts1 as Depends of libkf5purpose-bin
      MarkInstall libkaccounts1:amd64 < none -> 4:19.12.3-0ubuntu1 @un uN Ib > FU=0
      Installing libsignon-qt5-1 as Depends of libkaccounts1
        MarkInstall libsignon-qt5-1:amd64 < none -> 8.59+17.10.20170606-0ubuntu2.20.04.1 @un uN > FU=0
      Installing kaccounts-providers as Recommends of libkaccounts1
        MarkInstall kaccounts-providers:amd64 < none -> 4:19.12.3-0ubuntu1 @un uN Ib > FU=0
        Installing plasma-framework as Depends of kaccounts-providers
          MarkInstall plasma-framework:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
          Installing qml-module-org-kde-kconfig as Depends of plasma-framework
            MarkInstall qml-module-org-kde-kconfig:amd64 < none -> 5.68.0-0ubuntu2 @un uN > FU=0
          Installing qml-module-org-kde-kquickcontrols as Depends of plasma-framework
            MarkInstall qml-module-org-kde-kquickcontrols:amd64 < none -> 5.68.0-0ubuntu2 @un uN Ib > FU=0
            Installing qml-module-qtquick-controls as Depends of qml-module-org-kde-kquickcontrols
              MarkInstall qml-module-qtquick-controls:amd64 < none -> 5.12.8-0ubuntu2 @un uN Ib > FU=0
              Installing qml-module-qtquick-layouts as Depends of qml-module-qtquick-controls
                MarkInstall qml-module-qtquick-layouts:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
            Installing qml-module-qtquick-dialogs as Depends of qml-module-org-kde-kquickcontrols
              MarkInstall qml-module-qtquick-dialogs:amd64 < none -> 5.12.8-0ubuntu2 @un uN Ib > FU=0
              Installing qml-module-qtquick-privatewidgets as Depends of qml-module-qtquick-dialogs
                MarkInstall qml-module-qtquick-privatewidgets:amd64 < none -> 5.12.8-0ubuntu2 @un uN > FU=0
          Installing libkf5activities5 as Depends of plasma-framework
            MarkInstall libkf5activities5:amd64 < none -> 5.68.0-0ubuntu2 @un uN IPb > FU=0
            Installing kactivities-bin as Recommends of libkf5activities5
              MarkInstall kactivities-bin:amd64 < none -> 5.68.0-0ubuntu2 @un uN > FU=0
            Installing kactivitymanagerd as Recommends of libkf5activities5
              MarkInstall kactivitymanagerd:amd64 < none -> 5.18.4.1-0ubuntu1 @un uN > FU=0
          Installing libkf5calendarevents5 as Depends of plasma-framework
            MarkInstall libkf5calendarevents5:amd64 < none -> 5.68.0-0ubuntu2 @un uN > FU=0
          Installing libkf5plasmaquick5 as Depends of plasma-framework
            MarkInstall libkf5plasmaquick5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
          Installing libxcb-composite0 as Depends of plasma-framework
            MarkInstall libxcb-composite0:amd64 < none -> 1.14-2 @un uN > FU=0
          Installing libxcb-damage0 as Depends of plasma-framework
            MarkInstall libxcb-damage0:amd64 < none -> 1.14-2 @un uN > FU=0
        Installing signon-plugin-oauth2 as Depends of kaccounts-providers
          MarkInstall signon-plugin-oauth2:amd64 < none -> 0.24+16.10.20160818-0ubuntu2 @un uN Ib > FU=0
          Installing libsignon-plugins-common1 as Depends of signon-plugin-oauth2
            MarkInstall libsignon-plugins-common1:amd64 < none -> 8.59+17.10.20170606-0ubuntu2.20.04.1 @un uN > FU=0
    Installing qml-module-org-kde-bluezqt as Depends of libkf5purpose-bin
      MarkInstall qml-module-org-kde-bluezqt:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
      Installing libkf5bluezqt6 as Depends of qml-module-org-kde-bluezqt
        MarkInstall libkf5bluezqt6:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
        Installing libkf5bluezqt-data as Depends of libkf5bluezqt6
          MarkInstall libkf5bluezqt-data:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
    Installing qml-module-ubuntu-onlineaccounts as Depends of libkf5purpose-bin
      MarkInstall qml-module-ubuntu-onlineaccounts:amd64 < none -> 0.6+17.04.20170405-0ubuntu4 @un uN > FU=0
    Installing libkf5purpose5 as Depends of libkf5purpose-bin
      MarkInstall libkf5purpose5:amd64 < none -> 5.68.0-0ubuntu1 @un uN IPb > FU=0
      Installing qml-module-org-kde-purpose as Recommends of libkf5purpose5
        MarkInstall qml-module-org-kde-purpose:amd64 < none -> 5.68.0-0ubuntu1 @un uN IPb > FU=0
        Installing kdeconnect as Recommends of qml-module-org-kde-purpose
          MarkInstall kdeconnect:amd64 < none -> 1.4-0ubuntu5 @un uN Ib > FU=0
          Installing kde-cli-tools as Depends of kdeconnect
            MarkInstall kde-cli-tools:amd64 < none -> 4:5.18.4.1-0ubuntu1 @un uN Ib > FU=0
            Installing kde-cli-tools-data as Depends of kde-cli-tools
              MarkInstall kde-cli-tools-data:amd64 < none -> 4:5.18.4.1-0ubuntu1 @un uN > FU=0
            Installing libkf5su-bin as Depends of kde-cli-tools
              MarkInstall libkf5su-bin:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
              Installing libkf5su5 as Depends of libkf5su-bin
                MarkInstall libkf5su5:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
                Installing libkf5su-data as Depends of libkf5su5
                  MarkInstall libkf5su-data:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
                Installing libkf5pty5 as Depends of libkf5su5
                  MarkInstall libkf5pty5:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
                  Installing libkf5pty-data as Depends of libkf5pty5
                    MarkInstall libkf5pty-data:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
            Installing libkworkspace5-5 as Depends of kde-cli-tools
              MarkInstall libkworkspace5-5:amd64 < none -> 4:5.18.5-0ubuntu0.1 @un uN > FU=0
          Installing qml-module-org-kde-people as Depends of kdeconnect
            MarkInstall qml-module-org-kde-people:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
            Installing libkf5people5 as Depends of qml-module-org-kde-people
              MarkInstall libkf5people5:amd64 < none -> 5.68.0-0ubuntu1 @un uN Ib > FU=0
              Installing libkf5people-data as Depends of libkf5people5
                MarkInstall libkf5people-data:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
              Installing libkf5peoplebackend5 as Depends of libkf5people5
                MarkInstall libkf5peoplebackend5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
            Installing libkf5peoplewidgets5 as Depends of qml-module-org-kde-people
              MarkInstall libkf5peoplewidgets5:amd64 < none -> 5.68.0-0ubuntu1 @un uN > FU=0
          Installing sshfs as Depends of kdeconnect
            MarkInstall sshfs:amd64 < none -> 3.6.0+repack+really2.10-0ubuntu1 @un uN > FU=0
          Installing libfakekey0 as Depends of kdeconnect
            MarkInstall libfakekey0:amd64 < none -> 0.1-10 @un uN > FU=0
          Installing libkf5pulseaudioqt2 as Depends of kdeconnect
            MarkInstall libkf5pulseaudioqt2:amd64 < none -> 1.2-2build1 @un uN > FU=0
          Installing libqt5multimedia5 as Depends of kdeconnect
            MarkInstall libqt5multimedia5:amd64 < none -> 5.12.8-0ubuntu1 @un uN > FU=0
          Installing kpeople-vcard as Recommends of kdeconnect
            MarkInstall kpeople-vcard:amd64 < none -> 0.1-0ubuntu1 @un uN > FU=0
  MarkInstall imagemagick-6.q16:amd64 < 8:6.9.7.4+dfsg-16ubuntu6.9 -> 8:6.9.10.23+dfsg-2.1ubuntu11.2 @ii umU Ib > FU=0
  Installing libmagickcore-6.q16-6 as Depends of imagemagick-6.q16
    MarkInstall libmagickcore-6.q16-6:amd64 < none -> 8:6.9.10.23+dfsg-2.1ubuntu11.2 @un uN > FU=0
  Installing libmagickwand-6.q16-6 as Depends of imagemagick-6.q16
    MarkInstall libmagickwand-6.q16-6:amd64 < none -> 8:6.9.10.23+dfsg-2.1ubuntu11.2 @un uN > FU=0
  new important dependency: libmagickcore-6.q16-6-extra:amd64
  Installing libmagickcore-6.q16-6-extra as Recommends of imagemagick-6.q16
    MarkInstall libmagickcore-6.q16-6-extra:amd64 < none -> 8:6.9.10.23+dfsg-2.1ubuntu11.2 @un uN > FU=0
  MarkInstall libqt5gui5:amd64 < 5.9.5+dfsg-0ubuntu2.5 -> 5.12.8+dfsg-0ubuntu1 @ii umU Ib > FU=0
  Installing libxcb-xinput0 as Depends of libqt5gui5
    MarkInstall libxcb-xinput0:amd64 < none -> 1.14-2 @un uN > FU=0
  MarkInstall libsnmp30:amd64 < 5.7.3+dfsg-1.8ubuntu3.6 @ii mK Ib > FU=0
  Installing libsensors4 as Depends of libsnmp30
      MarkKeep libsensors4:amd64 < 1:3.4.0-4 @ii mR > FU=0
  MarkInstall libfile-mimeinfo-perl:amd64 < 0.28-1 -> 0.29-1 @ii umU IPb > FU=0
  new important dependency: libio-stringy-perl:amd64
  Installing libio-stringy-perl as Recommends of libfile-mimeinfo-perl
    MarkInstall libio-stringy-perl:amd64 < none -> 2.111-3 @un uN > FU=0
  MarkInstall ubuntu-drivers-common:amd64 < 1:0.5.2.5 -> 1:0.8.6.3~0.20.04.2 @ii umU Ib > FU=0
  Installing python3-click as Depends of ubuntu-drivers-common
    MarkInstall python3-click:amd64 < none -> 7.0-3 @un uN Ib > FU=0
    Installing python3-colorama as Depends of python3-click
      MarkInstall python3-colorama:amd64 < none -> 0.4.3-1build1 @un uN > FU=0
  MarkInstall libkpimkdav5:amd64 < 17.12.3-0ubuntu1 @ii mK Ib > FU=0
  MarkInstall libcupsmime1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
  MarkInstall supertuxkart:amd64 < 0.9.3-1 -> 1.1+ds-1build1 @ii umU Ib > FU=0
  Installing libmcpp0 as Depends of supertuxkart
    MarkInstall libmcpp0:amd64 < none -> 2.7.2-5 @un uN > FU=0
  Installing libraqm0 as Depends of supertuxkart
    MarkInstall libraqm0:amd64 < none -> 0.7.0-4 @un uN > FU=0
  Installing libsquish0 as Depends of supertuxkart
    MarkInstall libsquish0:amd64 < none -> 1.15-1build1 @un uN > FU=0
  MarkInstall libimobiledevice6:amd64 < 1.2.1~git20171128.5a854327+dfsg-0.1 -> 1.2.1~git20191129.9f79242-1build1 @ii umU Ib > FU=0
  Installing libusbmuxd6 as Depends of libimobiledevice6
    MarkInstall libusbmuxd6:amd64 < none -> 2.0.1-2 @un uN > FU=0
  MarkInstall libavcodec-extra:amd64 < 7:3.4.8-0ubuntu0.2 -> 7:4.2.4-1ubuntu0.1 @ii umU Ib > FU=0
  Installing libavcodec-extra58 as Depends of libavcodec-extra
    MarkInstall libavcodec-extra58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN Ib > FU=0
     Removing: libavcodec58
      MarkDelete libavcodec58:amd64 < none -> 7:4.2.4-1ubuntu0.1 @un uN > FU=0
  MarkInstall libkf5mailtransport5abi2:amd64 < 17.12.3-0ubuntu4 -> 19.12.3-0ubuntu1 @ii umU Ib > FU=0
  Installing libkpimsmtp5abi1 as Depends of libkf5mailtransport5abi2
    MarkInstall libkpimsmtp5abi1:amd64 < none -> 19.12.3-0ubuntu2 @un uN Ib > FU=0
     Removing: libkpimsmtp5
      MarkDelete libkpimsmtp5:amd64 < 17.12.2-0ubuntu1 @ii mK > FU=0
  MarkInstall libfreetype6-dev:amd64 < 2.8.1-2ubuntu2.1 -> 2.10.1-2ubuntu0.1 @ii umU Ib > FU=0
  Installing libfreetype-dev as Depends of libfreetype6-dev
    MarkInstall libfreetype-dev:amd64 < none -> 2.10.1-2ubuntu0.1 @un uN > FU=0
  MarkInstall xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mK Ib > FU=0
  MarkInstall acpi-support:amd64 < 0.142 -> 0.143 @ii umU NPb IPb > FU=0
  MarkInstall libkf5ldap5:amd64 < 17.12.3-0ubuntu1 @ii mK Ib > FU=0
    MarkKeep libhfstospell9:amd64 < 0.4.5~r343-2.1build2 @ii mR > FU=0
  MarkInstall fonts-gujr:amd64 < 2:1.2 -> 2:1.3 @ii umU Ib > FU=0
  Installing fonts-yrsa-rasa as Depends of fonts-gujr
    MarkInstall fonts-yrsa-rasa:amd64 < none -> 1.002-2 @un uN > FU=0
  MarkInstall printer-driver-gutenprint:amd64 < 5.2.13-2 -> 5.3.3-4 @ii umU Ib > FU=0
  Installing libgutenprint9 as Depends of printer-driver-gutenprint
    MarkInstall libgutenprint9:amd64 < none -> 5.3.3-4 @un uN Ib > FU=0
    Installing libgutenprint-common as Depends of libgutenprint9
      MarkInstall libgutenprint-common:amd64 < none -> 5.3.3-4 @un uN > FU=0
  MarkInstall lintian:amd64 < 2.5.81ubuntu1 -> 2.62.0 @ii umU Ib > FU=0
  Installing libcapture-tiny-perl as Depends of lintian
    MarkInstall libcapture-tiny-perl:amd64 < none -> 0.48-1 @un uN > FU=0
  Installing libclass-xsaccessor-perl as Depends of lintian
    MarkInstall libclass-xsaccessor-perl:amd64 < none -> 1.19-3build3 @un uN > FU=0
  Installing libcpanel-json-xs-perl as Depends of lintian
    MarkInstall libcpanel-json-xs-perl:amd64 < none -> 4.19-1build1 @un uN > FU=0
  Installing libdevel-size-perl as Depends of lintian
    MarkInstall libdevel-size-perl:amd64 < none -> 0.83-1build1 @un uN > FU=0
  Installing libfile-find-rule-perl as Depends of lintian
    MarkInstall libfile-find-rule-perl:amd64 < none -> 0.34-1 @un uN Ib > FU=0
    Installing libnumber-compare-perl as Depends of libfile-find-rule-perl
      MarkInstall libnumber-compare-perl:amd64 < none -> 0.03-1 @un uN > FU=0
    Installing libtext-glob-perl as Depends of libfile-find-rule-perl
      MarkInstall libtext-glob-perl:amd64 < none -> 0.10-1 @un uN > FU=0
  Installing libfont-ttf-perl as Depends of lintian
    MarkInstall libfont-ttf-perl:amd64 < none -> 1.06-1 @un uN > FU=0
  Installing libio-async-perl as Depends of lintian
    MarkInstall libio-async-perl:amd64 < none -> 0.75-1 @un uN Ib > FU=0
    Installing libfuture-perl as Depends of libio-async-perl
      MarkInstall libfuture-perl:amd64 < none -> 0.43-1 @un uN > FU=0
    Installing libstruct-dumb-perl as Depends of libio-async-perl
      MarkInstall libstruct-dumb-perl:amd64 < none -> 0.09-1 @un uN > FU=0
    Installing libasync-mergepoint-perl as Recommends of libio-async-perl
      MarkInstall libasync-mergepoint-perl:amd64 < none -> 0.04-2 @un uN > FU=0
    Installing libsereal-perl as Recommends of libio-async-perl
      MarkInstall libsereal-perl:amd64 < none -> 4.011-1 @un uN Ib > FU=0
      Installing libsereal-decoder-perl as Depends of libsereal-perl
        MarkInstall libsereal-decoder-perl:amd64 < none -> 4.011+ds-1build1 @un uN > FU=0
      Installing libsereal-encoder-perl as Depends of libsereal-perl
        MarkInstall libsereal-encoder-perl:amd64 < none -> 4.011+ds-1build1 @un uN > FU=0
    Installing libtest-fatal-perl as Recommends of libio-async-perl
      MarkInstall libtest-fatal-perl:amd64 < none -> 0.014-1 @un uN > FU=0
    Installing libtest-refcount-perl as Recommends of libio-async-perl
      MarkInstall libtest-refcount-perl:amd64 < none -> 0.10-1 @un uN > FU=0
  Installing libio-async-loop-epoll-perl as Depends of lintian
    MarkInstall libio-async-loop-epoll-perl:amd64 < none -> 0.20-1 @un uN Ib > FU=0
    Installing liblinux-epoll-perl as Depends of libio-async-loop-epoll-perl
      MarkInstall liblinux-epoll-perl:amd64 < none -> 0.017-1 @un uN > FU=0
  Installing libjson-maybexs-perl as Depends of lintian
    MarkInstall libjson-maybexs-perl:amd64 < none -> 1.004000-1 @un uN > FU=0
  Installing liblist-compare-perl as Depends of lintian
    MarkInstall liblist-compare-perl:amd64 < none -> 0.53-1 @un uN > FU=0
  Installing libmoo-perl as Depends of lintian
    MarkInstall libmoo-perl:amd64 < none -> 2.003006-1 @un uN Ib > FU=0
    Installing libclass-method-modifiers-perl as Depends of libmoo-perl
      MarkInstall libclass-method-modifiers-perl:amd64 < none -> 2.13-1 @un uN > FU=0
    Installing libimport-into-perl as Depends of libmoo-perl
      MarkInstall libimport-into-perl:amd64 < none -> 1.002005-1 @un uN Ib > FU=0
      Installing libmodule-runtime-perl as Depends of libimport-into-perl
        MarkInstall libmodule-runtime-perl:amd64 < none -> 0.016-1 @un uN Ib > FU=0
        Installing libparams-classify-perl as Depends of libmodule-runtime-perl
          MarkInstall libparams-classify-perl:amd64 < none -> 0.015-1build2 @un uN Ib > FU=0
          Installing libdevel-callchecker-perl as Depends of libparams-classify-perl
            MarkInstall libdevel-callchecker-perl:amd64 < none -> 0.008-1ubuntu1 @un uN Ib > FU=0
            Installing libb-hooks-op-check-perl as Depends of libdevel-callchecker-perl
              MarkInstall libb-hooks-op-check-perl:amd64 < none -> 0.22-1build2 @un uN > FU=0
            Installing libdynaloader-functions-perl as Depends of libdevel-callchecker-perl
              MarkInstall libdynaloader-functions-perl:amd64 < none -> 0.003-1 @un uN > FU=0
    Installing librole-tiny-perl as Depends of libmoo-perl
      MarkInstall librole-tiny-perl:amd64 < none -> 2.001004-1 @un uN > FU=0
    Installing libstrictures-perl as Depends of libmoo-perl
      MarkInstall libstrictures-perl:amd64 < none -> 2.000006-1 @un uN > FU=0
    Installing libsub-quote-perl as Depends of libmoo-perl
      MarkInstall libsub-quote-perl:amd64 < none -> 2.006006-1 @un uN > FU=0
  Installing libmoox-aliases-perl as Depends of lintian
    MarkInstall libmoox-aliases-perl:amd64 < none -> 0.001006-1 @un uN > FU=0
  Installing libnamespace-clean-perl as Depends of lintian
    MarkInstall libnamespace-clean-perl:amd64 < none -> 0.27-1 @un uN Ib > FU=0
    Installing libb-hooks-endofscope-perl as Depends of libnamespace-clean-perl
      MarkInstall libb-hooks-endofscope-perl:amd64 < none -> 0.24-1 @un uN Ib > FU=0
      Installing libmodule-implementation-perl as Depends of libb-hooks-endofscope-perl
        MarkInstall libmodule-implementation-perl:amd64 < none -> 0.09-1 @un uN > FU=0
      Installing libsub-exporter-progressive-perl as Depends of libb-hooks-endofscope-perl
        MarkInstall libsub-exporter-progressive-perl:amd64 < none -> 0.001013-1 @un uN > FU=0
      Installing libvariable-magic-perl as Depends of libb-hooks-endofscope-perl
        MarkInstall libvariable-magic-perl:amd64 < none -> 0.62-1build2 @un uN > FU=0
    Installing libpackage-stash-perl as Depends of libnamespace-clean-perl
      MarkInstall libpackage-stash-perl:amd64 < none -> 0.38-1 @un uN IPb > FU=0
      Installing libpackage-stash-xs-perl as Recommends of libpackage-stash-perl
        MarkInstall libpackage-stash-xs-perl:amd64 < none -> 0.29-1build1 @un uN > FU=0
    Installing libsub-identify-perl as Depends of libnamespace-clean-perl
      MarkInstall libsub-identify-perl:amd64 < none -> 0.14-1build2 @un uN > FU=0
  Installing libpath-tiny-perl as Depends of lintian
    MarkInstall libpath-tiny-perl:amd64 < none -> 0.108-1 @un uN IPb > FU=0
    Installing libunicode-utf8-perl as Recommends of libpath-tiny-perl
      MarkInstall libunicode-utf8-perl:amd64 < none -> 0.62-1build1 @un uN > FU=0
  Installing libtype-tiny-perl as Depends of lintian
    MarkInstall libtype-tiny-perl:amd64 < none -> 1.008001-2 @un uN IPb > FU=0
    Installing libref-util-perl as Recommends of libtype-tiny-perl
      MarkInstall libref-util-perl:amd64 < none -> 0.204-1 @un uN IPb > FU=0
      Installing libreadonly-perl as Recommends of libref-util-perl
        MarkInstall libreadonly-perl:amd64 < none -> 2.050-2 @un uN > FU=0
      Installing libref-util-xs-perl as Recommends of libref-util-perl
        MarkInstall libref-util-xs-perl:amd64 < none -> 0.117-1build2 @un uN > FU=0
    Installing libtype-tiny-xs-perl as Recommends of libtype-tiny-perl
      MarkInstall libtype-tiny-xs-perl:amd64 < none -> 0.016-1 @un uN > FU=0
  Installing libxml-writer-perl as Depends of lintian
    MarkInstall libxml-writer-perl:amd64 < none -> 0.625-1 @un uN > FU=0
  MarkInstall ure:amd64 < 6.0.7-0ubuntu0.18.04.10 -> 1:6.4.6-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libuno-purpenvhelpergcc3-3 as Depends of ure
    MarkInstall libuno-purpenvhelpergcc3-3:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN > FU=0
  new important dependency: libjuh-java:amd64
  Installing libjuh-java as Recommends of ure
    MarkInstall libjuh-java:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN > FU=0
  new important dependency: libjurt-java:amd64
  Installing libjurt-java as Recommends of ure
    MarkInstall libjurt-java:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN > FU=0
  new important dependency: libridl-java:amd64
  Installing libridl-java as Recommends of ure
    MarkInstall libridl-java:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN > FU=0
  new important dependency: libunoloader-java:amd64
  Installing libunoloader-java as Recommends of ure
    MarkInstall libunoloader-java:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN > FU=0
  MarkInstall brltty:amd64 < 5.5-4ubuntu2.0.1 -> 6.0+dfsg-4ubuntu6 @ii umU Ib > FU=0
  Installing libpcre2-32-0 as Depends of brltty
    MarkInstall libpcre2-32-0:amd64 < none -> 10.34-7 @un uN > FU=0
  MarkInstall libkf5prison5:amd64 < 5.44.0-0ubuntu1 -> 5.68.0-0ubuntu1 @ii umU Ib > FU=0
  Installing libdmtx0b as Depends of libkf5prison5
    MarkInstall libdmtx0b:amd64 < none -> 0.7.5-3 @un uN Ib > FU=0
     Removing: libdmtx0a
      MarkDelete libdmtx0a:amd64 < 0.7.4-2 @ii mK > FU=0
  Installing libqrencode4 as Depends of libkf5prison5
    MarkInstall libqrencode4:amd64 < none -> 4.0.2-2 @un uN > FU=0
  MarkInstall libglib2.0-dev:amd64 < 2.56.4-0ubuntu0.18.04.6 -> 2.64.6-1~ubuntu20.04.1 @ii umU Ib > FU=0
  Installing libffi-dev as Depends of libglib2.0-dev
    MarkInstall libffi-dev:amd64 < none -> 3.3-4 @un uN > FU=0
  Installing libmount-dev as Depends of libglib2.0-dev
    MarkInstall libmount-dev:amd64 < none -> 2.34-0.1ubuntu9.1 @un uN Ib > FU=0
    Installing libblkid-dev as Depends of libmount-dev
      MarkInstall libblkid-dev:amd64 < none -> 2.34-0.1ubuntu9.1 @un uN > FU=0
  Installing libselinux1-dev as Depends of libglib2.0-dev
    MarkInstall libselinux1-dev:amd64 < none -> 3.0-1build2 @un uN Ib > FU=0
    Installing libsepol1-dev as Depends of libselinux1-dev
      MarkInstall libsepol1-dev:amd64 < none -> 3.0-1 @un uN > FU=0
    Installing libpcre2-dev as Depends of libselinux1-dev
      MarkInstall libpcre2-dev:amd64 < none -> 10.34-7 @un uN Ib > FU=0
      Installing libpcre2-16-0 as Depends of libpcre2-dev
        MarkInstall libpcre2-16-0:amd64 < none -> 10.34-7 @un uN > FU=0
      Installing libpcre2-posix2 as Depends of libpcre2-dev
        MarkInstall libpcre2-posix2:amd64 < none -> 10.34-7 @un uN > FU=0
  MarkInstall systemd:amd64 < 237-3ubuntu10.44 -> 245.4-4ubuntu3.4 @ii umU Ib > FU=0
  Installing systemd-timesyncd as Depends of systemd
    MarkInstall systemd-timesyncd:amd64 < none -> 245.4-4ubuntu3.4 @un uN > FU=0
  MarkInstall libwebkit2gtk-4.0-37:amd64 < 2.30.3-0ubuntu0.18.04.1 -> 2.30.3-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing xdg-dbus-proxy as Depends of libwebkit2gtk-4.0-37
    MarkInstall xdg-dbus-proxy:amd64 < none -> 0.1.2-1 @un uN > FU=0
  MarkInstall libqt5core5a:amd64 < 5.9.5+dfsg-0ubuntu2.5 -> 5.12.8+dfsg-0ubuntu1 @ii umU Ib > FU=0
  Installing libdouble-conversion3 as Depends of libqt5core5a
    MarkInstall libdouble-conversion3:amd64 < none -> 3.1.5-4ubuntu1 @un uN > FU=0
  MarkInstall wpasupplicant:amd64 < 2:2.6-15ubuntu2.6 -> 2:2.9-1ubuntu4.1 @ii umU Ib > FU=0
  Installing libnl-route-3-200 as Depends of wpasupplicant
    MarkInstall libnl-route-3-200:amd64 < none -> 3.4.0-1 @un uN > FU=0
  MarkInstall shotwell:amd64 < 0.28.4-0ubuntu2 -> 0.30.10-0ubuntu0.1 @ii umU Ib > FU=0
  Installing libraw19 as Depends of shotwell
    MarkInstall libraw19:amd64 < none -> 0.19.5-1ubuntu1 @un uN > FU=0
  MarkInstall libpolkit-backend-1-0:amd64 < 0.105-20ubuntu0.18.04.5 @ii mK Ib > FU=0
  MarkInstall debhelper:amd64 < 11.1.6ubuntu2 -> 12.10ubuntu1 @ii umU Ib > FU=0
  Installing dwz as Depends of debhelper
    MarkInstall dwz:amd64 < none -> 0.13-5 @un uN > FU=0
  MarkInstall xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
  MarkInstall openssh-client:amd64 < 1:7.6p1-4ubuntu0.3 -> 1:8.2p1-4ubuntu0.1 @ii umU Ib > FU=0
  Installing libfido2-1 as Depends of openssh-client
    MarkInstall libfido2-1:amd64 < none -> 1.3.1-1ubuntu2 @un uN Ib > FU=0
    Installing libcbor0.6 as Depends of libfido2-1
      MarkInstall libcbor0.6:amd64 < none -> 0.6.0-0ubuntu1 @un uN > FU=0
  MarkInstall liblouisutdml-bin:amd64 < 2.7.0-1 -> 2.8.0-3 @ii umU Ib > FU=0
  Installing liblouisutdml9 as Depends of liblouisutdml-bin
    MarkInstall liblouisutdml9:amd64 < none -> 2.8.0-3 @un uN > FU=0
  MarkInstall libphonon4qt5-4:amd64 < 4:4.10.0-2 -> 4:4.11.1-3build1 @ii umU Ib > FU=0
  Installing libphonon4qt5-data as Depends of libphonon4qt5-4
    MarkInstall libphonon4qt5-data:amd64 < none -> 4:4.11.1-3build1 @un uN > FU=0
  MarkInstall python3-textile:amd64 < 1:3.0.0-1 -> 1:4.0.1-1 @ii umU IPb > FU=0
  new important dependency: python3-regex:amd64
  Installing python3-regex as Recommends of python3-textile
    MarkInstall python3-regex:amd64 < none -> 0.1.20190819-2build1 @un uN > FU=0
  MarkInstall python3-markups:amd64 < 2.0.1-1 -> 3.0.0-1 @ii umU Ib > FU=0
  Installing python3-mdx-math as Depends of python3-markups
    MarkInstall python3-mdx-math:amd64 < none -> 0.6-1 @un uN > FU=0
  MarkInstall cups-filters-core-drivers:amd64 < 1.20.2-0ubuntu3.1 -> 1.27.4-1 @ii umU Ib > FU=0
  Installing libpoppler-cpp0v5 as Depends of cups-filters-core-drivers
    MarkInstall libpoppler-cpp0v5:amd64 < none -> 0.86.1-0ubuntu1 @un uN > FU=0
  MarkInstall ibus:amd64 < 1.5.17-3ubuntu5.3 -> 1.5.22-2ubuntu2.1 @ii umU Ib > FU=0
  Installing ibus-data as Depends of ibus
    MarkInstall ibus-data:amd64 < none -> 1.5.22-2ubuntu2.1 @un uN > FU=0
  Installing python3-ibus-1.0 as Depends of ibus
    MarkInstall python3-ibus-1.0:amd64 < none -> 1.5.22-2ubuntu2.1 @un uN > FU=0
  MarkInstall xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
  MarkInstall ubuntu-wallpapers:amd64 < 18.04.1-0ubuntu1 -> 20.04.2-0ubuntu1 @ii umU Ib > FU=0
  Installing ubuntu-wallpapers-focal as Depends of ubuntu-wallpapers
    MarkInstall ubuntu-wallpapers-focal:amd64 < none -> 20.04.2-0ubuntu1 @un uN > FU=0
  MarkInstall libcupsppdc1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
  MarkInstall fwupd:amd64 < 1.2.10-1ubuntu2~ubuntu18.04.5 -> 1.3.11-1~focal1 @ii umU Ib > FU=0
  Installing libfwupdplugin1 as Depends of fwupd
    MarkInstall libfwupdplugin1:amd64 < none -> 1.3.11-1~focal1 @un uN > FU=0
  Installing libtss2-esys0 as Depends of fwupd
    MarkInstall libtss2-esys0:amd64 < none -> 2.3.2-1 @un uN Ib > FU=0
    Installing tpm-udev as Depends of libtss2-esys0
      MarkInstall tpm-udev:amd64 < none -> 0.4 @un uN > FU=0
  MarkInstall libqt5webenginecore5:amd64 < 5.9.5+dfsg-0ubuntu2 -> 5.12.8+dfsg-0ubuntu1.1 @ii umU Ib > FU=0
  Installing libevent-2.1-7 as Depends of libqt5webenginecore5
    MarkInstall libevent-2.1-7:amd64 < none -> 2.1.11-stable-1 @un uN > FU=0
  Installing libre2-5 as Depends of libqt5webenginecore5
    MarkInstall libre2-5:amd64 < none -> 20200101+dfsg-1build1 @un uN > FU=0
  MarkInstall libedata-book-1.2-25:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib > FU=0
    MarkKeep uno-libs3:amd64 < 6.0.7-0ubuntu0.18.04.10 @ii mR > FU=0
  MarkInstall gnome-shell:amd64 < 3.28.4-0ubuntu18.04.3 -> 3.36.4-1ubuntu1~20.04.2 @ii umU Ib > FU=0
  Installing gir1.2-mutter-6 as Depends of gnome-shell
    MarkInstall gir1.2-mutter-6:amd64 < none -> 3.36.7+git20201123-0.20.04.1 @un uN Ib > FU=0
    Installing libmutter-6-0 as Depends of gir1.2-mutter-6
      MarkInstall libmutter-6-0:amd64 < none -> 3.36.7+git20201123-0.20.04.1 @un uN > FU=0
    Installing gir1.2-graphene-1.0 as Depends of gir1.2-mutter-6
      MarkInstall gir1.2-graphene-1.0:amd64 < none -> 1.10.0-1build2 @un uN > FU=0
  new important dependency: switcheroo-control:amd64
  Installing switcheroo-control as Recommends of gnome-shell
    MarkInstall switcheroo-control:amd64 < none -> 2.1-1 @un uN > FU=0
  MarkInstall libedata-cal-1.2-28:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib > FU=0
  MarkInstall libpci3:amd64 < 1:3.5.2-1ubuntu1.1 -> 1:3.6.4-1 @ii umU Ib > FU=0
  Installing pci.ids as Depends of libpci3
    MarkInstall pci.ids:amd64 < none -> 0.0~2020.03.20-1 @un uN > FU=0
  MarkInstall libreoffice-help-en-us:amd64 < 1:6.0.7-0ubuntu0.18.04.10 -> 1:6.4.6-0ubuntu0.20.04.1 @ii umU Ib > FU=0
  Installing libreoffice-help-common as Depends of libreoffice-help-en-us
    MarkInstall libreoffice-help-common:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN > FU=0
  MarkInstall libkf5pimtextedit5abi2:amd64 < 17.12.3-0ubuntu1 @ii mK Ib > FU=0
  MarkInstall vlc-plugin-base:amd64 < 3.0.8-0ubuntu18.04.1 -> 3.0.9.2-1 @ii umU Ib > FU=0
  Installing libixml10 as Depends of vlc-plugin-base
    MarkInstall libixml10:amd64 < none -> 1:1.8.4-2ubuntu2 @un uN > FU=0
  Installing liblivemedia77 as Depends of vlc-plugin-base
    MarkInstall liblivemedia77:amd64 < none -> 2020.01.19-1build1 @un uN > FU=0
  Installing libprotobuf-lite17 as Depends of vlc-plugin-base
    MarkInstall libprotobuf-lite17:amd64 < none -> 3.6.1.3-2ubuntu5 @un uN > FU=0
  Installing libspatialaudio0 as Depends of vlc-plugin-base
    MarkInstall libspatialaudio0:amd64 < none -> 0.3.0+git20180730+dfsg1-2build1 @un uN > FU=0
  Installing libupnp13 as Depends of vlc-plugin-base
    MarkInstall libupnp13:amd64 < none -> 1:1.8.4-2ubuntu2 @un uN > FU=0
  MarkInstall libreoffice-gnome:amd64 < 1:6.0.7-0ubuntu0.18.04.10 -> 1:6.4.6-0ubuntu0.20.04.1 @ii umU IPb > FU=0
  new important dependency: libreoffice-style-elementary:amd64
  Installing libreoffice-style-elementary as Recommends of libreoffice-gnome
    MarkInstall libreoffice-style-elementary:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN > FU=0
    MarkKeep fwupdate-signed:amd64 < 12-7~ubuntu18.04.3 @ii mR > FU=0
  MarkInstall isc-dhcp-client:amd64 < 4.3.5-3ubuntu7.1 -> 4.4.1-2.1ubuntu5 @ii umU Ib > FU=0
  Installing libdns-export1109 as Depends of isc-dhcp-client
    MarkInstall libdns-export1109:amd64 < none -> 1:9.11.16+dfsg-3~ubuntu1 @un uN Ib > FU=0
    Installing libisc-export1105 as Depends of libdns-export1109
      MarkInstall libisc-export1105:amd64 < none -> 1:9.11.16+dfsg-3~ubuntu1 @un uN > FU=0
  MarkInstall libcupscgi1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
  MarkInstall gdal-data:amd64 < 2.2.3+dfsg-2 -> 3.0.4+dfsg-1build3 @ii umU Ib > FU=0
   Removing: libgdal20
    MarkDelete libgdal20:amd64 < 2.2.3+dfsg-2 @ii mK > FU=0
  MarkInstall python-minimal:amd64 < 2.7.15-3~oibaf~b @ii gK Ib > FU=0
  MarkInstall libkf5alarmcalendar5abi1:amd64 < 4:17.12.3-0ubuntu1 @ii mK Ib > FU=0
  MarkInstall initramfs-tools-core:amd64 < 0.130ubuntu3.11 -> 0.136ubuntu6.3 @ii umU Ib > FU=0
  Installing lz4 as Depends of initramfs-tools-core
    MarkInstall lz4:amd64 < none -> 1.9.2-2 @un uN > FU=0
  MarkInstall mplayer:amd64 < 2:1.3.0-7build2 -> 2:1.3.0-8build5 @ii ugU Ib > FU=0
  Installing libmng2 as Depends of mplayer
    MarkInstall libmng2:amd64 < none -> 2.0.3+dfsg-3 @un uN > FU=0
    MarkKeep libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mR > FU=0
    MarkKeep libfwup1:amd64 < 12-3bionic2 @ii mR > FU=0
    MarkKeep libgdal20:amd64 < 2.2.3+dfsg-2 @ii mR > FU=0
    MarkKeep libkpimsmtp5:amd64 < 17.12.2-0ubuntu1 @ii mR > FU=0
    MarkKeep libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mR > FU=0
  Ignore MarkInstall of python:amd64 < 2.7.15-3~oibaf~b @ii pgR > as its mode (Delete) is protected
    MarkKeep libdmtx0a:amd64 < 0.7.4-2 @ii mR > FU=0
Starting pkgProblemResolver with broken count: 34
Starting 2 pkgProblemResolver with broken count: 34
Investigating (0) dpkg:amd64 < 1.19.0.5ubuntu2.3 -> 1.19.7ubuntu3 @ii umU Ib >
Broken dpkg:amd64 Breaks on libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mK > (< 1.7~b)
  Considering libapt-pkg5.0:amd64 -2 as a solution to dpkg:amd64 5841
  Added libapt-pkg5.0:amd64 to the remove list
  Fixing dpkg:amd64 via remove of libapt-pkg5.0:amd64
  MarkDelete libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mK > FU=0
Investigating (0) libuno-sal3:amd64 < none -> 1:6.4.6-0ubuntu0.20.04.1 @un uN Ib >
Broken libuno-sal3:amd64 Breaks on uno-libs3:amd64 < 6.0.7-0ubuntu0.18.04.10 @ii mK >
  Considering uno-libs3:amd64 -8 as a solution to libuno-sal3:amd64 102
  Added uno-libs3:amd64 to the remove list
  Fixing libuno-sal3:amd64 via remove of uno-libs3:amd64
  MarkDelete uno-libs3:amd64 < 6.0.7-0ubuntu0.18.04.10 @ii mK > FU=0
Investigating (0) gnome-settings-daemon-common:amd64 < none -> 3.36.1-0ubuntu1 @un uN Ib >
Broken gnome-settings-daemon-common:amd64 Breaks on gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3 @ii mK > (< 3.30.1.2-2~)
  Considering gnome-settings-daemon-schemas:amd64 -3 as a solution to gnome-settings-daemon-common:amd64 10
  Added gnome-settings-daemon-schemas:amd64 to the remove list
  Fixing gnome-settings-daemon-common:amd64 via remove of gnome-settings-daemon-schemas:amd64
  MarkDelete gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3 @ii mK > FU=0
Investigating (0) libkpimsmtp5abi1:amd64 < none -> 19.12.3-0ubuntu2 @un uN Ib >
Broken libkpimsmtp5abi1:amd64 Breaks on libkpimsmtp5:amd64 < 17.12.2-0ubuntu1 @ii mK > (< 19.12.3~)
  Considering libkpimsmtp5:amd64 -3 as a solution to libkpimsmtp5abi1:amd64 4
  Added libkpimsmtp5:amd64 to the remove list
  Fixing libkpimsmtp5abi1:amd64 via remove of libkpimsmtp5:amd64
  MarkDelete libkpimsmtp5:amd64 < 17.12.2-0ubuntu1 @ii mK > FU=0
Investigating (0) libhfstospell10:amd64 < none -> 0.5.0-2build2 @un uN Ib >
Broken libhfstospell10:amd64 Conflicts on libhfstospell:amd64 < none @un H >
  Considering libhfstospell9:amd64 -2 as a solution to libhfstospell10:amd64 1
  Added libhfstospell9:amd64 to the remove list
  Fixing libhfstospell10:amd64 via remove of libhfstospell9:amd64
  MarkDelete libhfstospell9:amd64 < 0.4.5~r343-2.1build2 @ii mK Ib > FU=0
Investigating (0) libldb2:amd64 < none -> 2:2.0.10-0ubuntu0.20.04.2 @un uN Ib >
Broken libldb2:amd64 Breaks on libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mK > (< 2:2~)
  Considering libldb1:amd64 -3 as a solution to libldb2:amd64 1
  Added libldb1:amd64 to the remove list
  Fixing libldb2:amd64 via remove of libldb1:amd64
  MarkDelete libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mK > FU=0
Investigating (0) libdmtx0b:amd64 < none -> 0.7.5-3 @un uN Ib >
Broken libdmtx0b:amd64 Conflicts on libdmtx0a:amd64 < 0.7.4-2 @ii mK >
  Considering libdmtx0a:amd64 -3 as a solution to libdmtx0b:amd64 1
  Added libdmtx0a:amd64 to the remove list
  Fixing libdmtx0b:amd64 via remove of libdmtx0a:amd64
  MarkDelete libdmtx0a:amd64 < 0.7.4-2 @ii mK > FU=0
Investigating (0) gdal-data:amd64 < 2.2.3+dfsg-2 -> 3.0.4+dfsg-1build3 @ii umU Ib >
Broken gdal-data:amd64 Breaks on libgdal20:amd64 < 2.2.3+dfsg-2 @ii mK > (< 2.5.0~)
  Considering libgdal20:amd64 -2 as a solution to gdal-data:amd64 1
  Added libgdal20:amd64 to the remove list
  Fixing gdal-data:amd64 via remove of libgdal20:amd64
  MarkDelete libgdal20:amd64 < 2.2.3+dfsg-2 @ii mK > FU=0
Investigating (0) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 21 as a solution to xserver-xorg-video-ati:amd64 0
  Removing xserver-xorg-video-ati:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 21 as a solution to xserver-xorg-video-intel:amd64 0
  Removing xserver-xorg-video-intel:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mK Ib > FU=0
Investigating (0) libsensors-config:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib >
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii mK >
  Considering libsensors4:amd64 5 as a solution to libsensors-config:amd64 0
  MarkKeep libsensors-config:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib > FU=0
  Holding Back libsensors-config:amd64 rather than change libsensors4:amd64
Investigating (0) xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 21 as a solution to xserver-xorg-video-nouveau:amd64 0
  Removing xserver-xorg-video-nouveau:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 21 as a solution to xserver-xorg-video-amdgpu:amd64 0
  Removing xserver-xorg-video-amdgpu:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
Investigating (0) fwupdate:amd64 < 12-7~ubuntu18.04.3 -> 12-7 @ii umU Ib >
Broken fwupdate:amd64 Breaks on fwupdate-signed:amd64 < 12-7~ubuntu18.04.3 @ii mK >
  Considering fwupdate-signed:amd64 -3 as a solution to fwupdate:amd64 0
  Added fwupdate-signed:amd64 to the remove list
Broken fwupdate:amd64 Breaks on libfwup1:amd64 < 12-3bionic2 @ii mK > (< 12-5)
  Considering libfwup1:amd64 -3 as a solution to fwupdate:amd64 0
  Added libfwup1:amd64 to the remove list
  Fixing fwupdate:amd64 via remove of fwupdate-signed:amd64
  MarkDelete fwupdate-signed:amd64 < 12-7~ubuntu18.04.3 @ii mK > FU=0
  Fixing fwupdate:amd64 via remove of libfwup1:amd64
  MarkDelete libfwup1:amd64 < 12-3bionic2 @ii mK > FU=0
Investigating (0) xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-radeon:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 21 as a solution to xserver-xorg-video-radeon:amd64 -1
  Removing xserver-xorg-video-radeon:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (0) libedata-book-1.2-25:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib >
Broken libedata-book-1.2-25:amd64 Depends on libebackend-1.2-10:amd64 < 3.28.5-0ubuntu0.18.04.3 -> 3.36.4-0ubuntu1 @ii umU > (= 3.28.5-0ubuntu0.18.04.3)
  Considering libebackend-1.2-10:amd64 8 as a solution to libedata-book-1.2-25:amd64 -1
  Removing libedata-book-1.2-25:amd64 rather than change libebackend-1.2-10:amd64
  MarkDelete libedata-book-1.2-25:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib > FU=0
Investigating (0) python-minimal:amd64 < 2.7.15-3~oibaf~b @ii gK Ib >
Broken python-minimal:amd64 Depends on python2-minimal:amd64 < 2.7.15-3~oibaf~b -> 2.7.17-2ubuntu4 @ii umU > (= 2.7.15-3~oibaf~b)
  Considering python2-minimal:amd64 13 as a solution to python-minimal:amd64 -2
  Removing python-minimal:amd64 rather than change python2-minimal:amd64
  MarkDelete python-minimal:amd64 < 2.7.15-3~oibaf~b @ii gK Ib > FU=0
Investigating (0) libcupscgi1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib >
Broken libcupscgi1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
  Considering libcups2:amd64 285 as a solution to libcupscgi1:amd64 -2
  Removing libcupscgi1:amd64 rather than change libcups2:amd64
  MarkDelete libcupscgi1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
Investigating (0) libkf5ldap5:amd64 < 17.12.3-0ubuntu1 @ii mK Ib >
Broken libkf5ldap5:amd64 Depends on libkf5ldap-data:amd64 < 17.12.3-0ubuntu1 -> 19.12.3-0ubuntu1 @ii umU > (= 17.12.3-0ubuntu1)
  Considering libkf5ldap-data:amd64 3 as a solution to libkf5ldap5:amd64 -2
  Removing libkf5ldap5:amd64 rather than change libkf5ldap-data:amd64
  MarkDelete libkf5ldap5:amd64 < 17.12.3-0ubuntu1 @ii mK Ib > FU=0
Investigating (0) libkpimkdav5:amd64 < 17.12.3-0ubuntu1 @ii mK Ib >
Broken libkpimkdav5:amd64 Depends on libkpimkdav-data:amd64 < 17.12.3-0ubuntu1 -> 19.12.3-0ubuntu1 @ii umU > (= 17.12.3-0ubuntu1)
  Considering libkpimkdav-data:amd64 1 as a solution to libkpimkdav5:amd64 -2
  Removing libkpimkdav5:amd64 rather than change libkpimkdav-data:amd64
  MarkDelete libkpimkdav5:amd64 < 17.12.3-0ubuntu1 @ii mK Ib > FU=0
Investigating (0) libcupsppdc1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib >
Broken libcupsppdc1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
  Considering libcups2:amd64 285 as a solution to libcupsppdc1:amd64 -2
  Removing libcupsppdc1:amd64 rather than change libcups2:amd64
  MarkDelete libcupsppdc1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
Investigating (0) libedata-cal-1.2-28:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib >
Broken libedata-cal-1.2-28:amd64 Depends on libebackend-1.2-10:amd64 < 3.28.5-0ubuntu0.18.04.3 -> 3.36.4-0ubuntu1 @ii umU > (= 3.28.5-0ubuntu0.18.04.3)
  Considering libebackend-1.2-10:amd64 8 as a solution to libedata-cal-1.2-28:amd64 -2
  Removing libedata-cal-1.2-28:amd64 rather than change libebackend-1.2-10:amd64
  MarkDelete libedata-cal-1.2-28:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib > FU=0
Investigating (0) mysql-workbench:amd64 < 6.3.8+dfsg-1build3 @ii mK Ib >
Broken mysql-workbench:amd64 Depends on gdal-abi-2-2-3:amd64 < none @un H >
  Considering libgdal20:amd64 -2 as a solution to mysql-workbench:amd64 -2
  Removing mysql-workbench:amd64 rather than change gdal-abi-2-2-3:amd64
  MarkDelete mysql-workbench:amd64 < 6.3.8+dfsg-1build3 @ii mK Ib > FU=0
Investigating (0) libkpimgapicore5:amd64 < 17.12.3-0ubuntu1 @ii mK Ib >
Broken libkpimgapicore5:amd64 Depends on libkpimgapi-data:amd64 < 17.12.3-0ubuntu1 -> 19.12.3-0ubuntu1 @ii umU > (= 17.12.3-0ubuntu1)
  Considering libkpimgapi-data:amd64 12 as a solution to libkpimgapicore5:amd64 -2
  Removing libkpimgapicore5:amd64 rather than change libkpimgapi-data:amd64
  MarkDelete libkpimgapicore5:amd64 < 17.12.3-0ubuntu1 @ii mK Ib > FU=0
Investigating (0) libpython-stdlib:amd64 < 2.7.15-3~oibaf~b @ii gK Ib >
Broken libpython-stdlib:amd64 Depends on libpython2-stdlib:amd64 < 2.7.15-3~oibaf~b -> 2.7.17-2ubuntu4 @ii umU > (= 2.7.15-3~oibaf~b)
  Considering libpython2-stdlib:amd64 13 as a solution to libpython-stdlib:amd64 -2
  Removing libpython-stdlib:amd64 rather than change libpython2-stdlib:amd64
  MarkDelete libpython-stdlib:amd64 < 2.7.15-3~oibaf~b @ii gK Ib > FU=0
Investigating (0) libpolkit-backend-1-0:amd64 < 0.105-20ubuntu0.18.04.5 @ii mK Ib >
Broken libpolkit-backend-1-0:amd64 Depends on libpolkit-gobject-1-0:amd64 < 0.105-20ubuntu0.18.04.5 -> 0.105-26ubuntu1 @ii umU > (= 0.105-20ubuntu0.18.04.5)
  Considering libpolkit-gobject-1-0:amd64 128 as a solution to libpolkit-backend-1-0:amd64 -2
  Removing libpolkit-backend-1-0:amd64 rather than change libpolkit-gobject-1-0:amd64
  MarkDelete libpolkit-backend-1-0:amd64 < 0.105-20ubuntu0.18.04.5 @ii mK Ib > FU=0
Investigating (0) libcupsmime1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib >
Broken libcupsmime1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
  Considering libcups2:amd64 285 as a solution to libcupsmime1:amd64 -2
  Removing libcupsmime1:amd64 rather than change libcups2:amd64
  MarkDelete libcupsmime1:amd64 < 2.2.7-1ubuntu2.8 @ii mK Ib > FU=0
Investigating (0) libkf5pimtextedit5abi2:amd64 < 17.12.3-0ubuntu1 @ii mK Ib >
Broken libkf5pimtextedit5abi2:amd64 Depends on libkf5pimtextedit-data:amd64 < 17.12.3-0ubuntu1 -> 19.12.3-0ubuntu1 @ii umU > (= 17.12.3-0ubuntu1)
  Considering libkf5pimtextedit-data:amd64 4 as a solution to libkf5pimtextedit5abi2:amd64 -2
  Removing libkf5pimtextedit5abi2:amd64 rather than change libkf5pimtextedit-data:amd64
  MarkDelete libkf5pimtextedit5abi2:amd64 < 17.12.3-0ubuntu1 @ii mK Ib > FU=0
Investigating (0) libebook-1.2-19:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib >
Broken libebook-1.2-19:amd64 Depends on libedata-book-1.2-25:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mR > (= 3.28.5-0ubuntu0.18.04.3)
  Considering libedata-book-1.2-25:amd64 -1 as a solution to libebook-1.2-19:amd64 -2
  Removing libebook-1.2-19:amd64 rather than change libedata-book-1.2-25:amd64
  MarkDelete libebook-1.2-19:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mK Ib > FU=0
Investigating (0) libapt-inst2.0:amd64 < 1.6.12ubuntu0.2 @ii mK Ib >
Broken libapt-inst2.0:amd64 Depends on libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mR > (>= 1.1~exp9)
  Considering libapt-pkg5.0:amd64 -2 as a solution to libapt-inst2.0:amd64 -2
  Removing libapt-inst2.0:amd64 rather than change libapt-pkg5.0:amd64
  MarkDelete libapt-inst2.0:amd64 < 1.6.12ubuntu0.2 @ii mK Ib > FU=0
Investigating (0) libkf5alarmcalendar5abi1:amd64 < 4:17.12.3-0ubuntu1 @ii mK Ib >
Broken libkf5alarmcalendar5abi1:amd64 Depends on libkf5alarmcalendar-data:amd64 < 4:17.12.3-0ubuntu1 -> 4:19.12.3-0ubuntu1 @ii umU > (= 4:17.12.3-0ubuntu1)
  Considering libkf5alarmcalendar-data:amd64 1 as a solution to libkf5alarmcalendar5abi1:amd64 -2
  Removing libkf5alarmcalendar5abi1:amd64 rather than change libkf5alarmcalendar-data:amd64
  MarkDelete libkf5alarmcalendar5abi1:amd64 < 4:17.12.3-0ubuntu1 @ii mK Ib > FU=0
Investigating (1) xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii umU Ib >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR >
  Considering xserver-xorg-video-amdgpu:amd64 0 as a solution to xserver-xorg-video-all:amd64 4
  Added xserver-xorg-video-amdgpu:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR >
  Considering xserver-xorg-video-ati:amd64 0 as a solution to xserver-xorg-video-all:amd64 4
  Added xserver-xorg-video-ati:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR >
  Considering xserver-xorg-video-nouveau:amd64 0 as a solution to xserver-xorg-video-all:amd64 4
  Added xserver-xorg-video-nouveau:amd64 to the remove list
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-amdgpu:amd64
  MarkKeep xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-ati:amd64
  MarkKeep xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-nouveau:amd64
  MarkKeep xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR > FU=0
Investigating (1) libsensors5:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib >
Broken libsensors5:amd64 Depends on libsensors-config:amd64 < none | 1:3.6.0-2ubuntu1 @un uH >
  Considering libsensors-config:amd64 0 as a solution to libsensors5:amd64 1
  MarkKeep libsensors5:amd64 < none -> 1:3.6.0-2ubuntu1 @un uN Ib > FU=0
  Holding Back libsensors5:amd64 rather than change libsensors-config:amd64
Investigating (1) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 21 as a solution to xserver-xorg-video-ati:amd64 0
  Removing xserver-xorg-video-ati:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (1) xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 21 as a solution to xserver-xorg-video-nouveau:amd64 0
  Removing xserver-xorg-video-nouveau:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
Investigating (1) xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 21 as a solution to xserver-xorg-video-amdgpu:amd64 0
  Removing xserver-xorg-video-amdgpu:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
Investigating (2) libsnmp35:amd64 < none -> 5.8+dfsg-2ubuntu2.3 @un uN Ib >
Broken libsnmp35:amd64 Depends on libsensors5:amd64 < none | 1:3.6.0-2ubuntu1 @un uH > (>= 1:3.5.0)
  Considering libsensors5:amd64 1 as a solution to libsnmp35:amd64 8
  MarkKeep libsnmp35:amd64 < none -> 5.8+dfsg-2ubuntu2.3 @un uN Ib > FU=0
  Holding Back libsnmp35:amd64 rather than change libsensors5:amd64
Investigating (2) libhpmud0:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib >
Broken libhpmud0:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un uH > (>= 5.8+dfsg)
  Considering libsnmp35:amd64 8 as a solution to libhpmud0:amd64 8
  MarkKeep libhpmud0:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
  Holding Back libhpmud0:amd64 rather than change libsnmp35:amd64
Investigating (2) xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii umU Ib >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR >
  Considering xserver-xorg-video-amdgpu:amd64 0 as a solution to xserver-xorg-video-all:amd64 4
  Added xserver-xorg-video-amdgpu:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR >
  Considering xserver-xorg-video-ati:amd64 0 as a solution to xserver-xorg-video-all:amd64 4
  Added xserver-xorg-video-ati:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR >
  Considering xserver-xorg-video-nouveau:amd64 0 as a solution to xserver-xorg-video-all:amd64 4
  Added xserver-xorg-video-nouveau:amd64 to the remove list
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-amdgpu:amd64
  MarkKeep xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-ati:amd64
  MarkKeep xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-nouveau:amd64
  MarkKeep xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR > FU=0
Investigating (2) printer-driver-hpcups:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib >
Broken printer-driver-hpcups:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH > (>= 3.20.3+dfsg0)
  Considering libhpmud0:amd64 8 as a solution to printer-driver-hpcups:amd64 4
  MarkKeep printer-driver-hpcups:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
  Holding Back printer-driver-hpcups:amd64 rather than change libhpmud0:amd64
Investigating (2) hplip:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib >
Broken hplip:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH > (= 3.20.3+dfsg0-2)
  Considering libhpmud0:amd64 8 as a solution to hplip:amd64 4
  MarkKeep hplip:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
  Removing hplip:amd64 rather than change libhpmud0:amd64
  MarkDelete hplip:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH Ib > FU=0
Investigating (2) libsane-hpaio:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib >
Broken libsane-hpaio:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH > (>= 3.20.3+dfsg0)
  Considering libhpmud0:amd64 8 as a solution to libsane-hpaio:amd64 4
  MarkKeep libsane-hpaio:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
  Holding Back libsane-hpaio:amd64 rather than change libhpmud0:amd64
Investigating (2) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 21 as a solution to xserver-xorg-video-ati:amd64 4
  Removing xserver-xorg-video-ati:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (2) xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 21 as a solution to xserver-xorg-video-nouveau:amd64 4
  Removing xserver-xorg-video-nouveau:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
Investigating (2) xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 21 as a solution to xserver-xorg-video-amdgpu:amd64 4
  Removing xserver-xorg-video-amdgpu:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
Investigating (3) libsane:amd64 < none -> 1.0.29-0ubuntu5.2 @un uN Ib >
Broken libsane:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un uH > (>= 5.8+dfsg)
  Considering libsnmp35:amd64 8 as a solution to libsane:amd64 17
  MarkKeep libsane:amd64 < none -> 1.0.29-0ubuntu5.2 @un uN Ib > FU=0
  Holding Back libsane:amd64 rather than change libsnmp35:amd64
Investigating (3) sane-utils:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib >
Broken sane-utils:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.27)
  Considering libsane:amd64 17 as a solution to sane-utils:amd64 11
  MarkKeep sane-utils:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
  Holding Back sane-utils:amd64 rather than change libsane:amd64
 Try to Re-Instate (3) libhpmud0:amd64
  MarkKeep libhpmud0:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
Investigating (3) xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii umU Ib >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR >
  Considering xserver-xorg-video-amdgpu:amd64 21 as a solution to xserver-xorg-video-all:amd64 4
  MarkKeep xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii umU Ib > FU=0
  Removing xserver-xorg-video-all:amd64 rather than change xserver-xorg-video-amdgpu:amd64
  MarkDelete xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 | 1:7.7+19ubuntu14 @ii umH Ib > FU=0
 Try to Re-Instate (3) printer-driver-hpcups:amd64
  MarkKeep printer-driver-hpcups:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
 Try to Re-Instate (3) libsane-hpaio:amd64
  MarkKeep libsane-hpaio:amd64 < 3.17.10+repack0-5 -> 3.20.3+dfsg0-2 @ii umU Ib > FU=0
Investigating (3) simple-scan:amd64 < 3.28.0-0ubuntu1 -> 3.36.3-0ubuntu0.20.04.0 @ii umU Ib >
Broken simple-scan:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.24)
  Considering libsane:amd64 17 as a solution to simple-scan:amd64 1
  MarkKeep simple-scan:amd64 < 3.28.0-0ubuntu1 -> 3.36.3-0ubuntu0.20.04.0 @ii umU Ib > FU=0
  Holding Back simple-scan:amd64 rather than change libsane:amd64
Investigating (3) libsane1:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib >
Broken libsane1:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.29-0ubuntu5.2)
  Considering libsane:amd64 17 as a solution to libsane1:amd64 0
  MarkKeep libsane1:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
  Removing libsane1:amd64 rather than change libsane:amd64
  MarkDelete libsane1:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umH Ib > FU=0
Investigating (4) colord:amd64 < 1.3.3-2build1 -> 1.4.4-2 @ii umU Ib >
Broken colord:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.24)
  Considering libsane:amd64 17 as a solution to colord:amd64 38
  Added libsane:amd64 to the remove list
  Fixing colord:amd64 via keep of libsane:amd64
 Try to Re-Instate (4) sane-utils:amd64
  MarkKeep sane-utils:amd64 < 1.0.27-1~experimental3ubuntu2.4 -> 1.0.29-0ubuntu5.2 @ii umU Ib > FU=0
Investigating (4) sane-utils:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umH Ib >
Broken sane-utils:amd64 Depends on libsane1:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umR > (>= 1.0.27)
  Considering libsane1:amd64 17 as a solution to sane-utils:amd64 11
  Removing sane-utils:amd64 rather than change libsane1:amd64
  MarkDelete sane-utils:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umH Ib > FU=0
 Try to Re-Instate (4) simple-scan:amd64
  MarkKeep simple-scan:amd64 < 3.28.0-0ubuntu1 -> 3.36.3-0ubuntu0.20.04.0 @ii umU Ib > FU=0
Investigating (4) simple-scan:amd64 < 3.28.0-0ubuntu1 | 3.36.3-0ubuntu0.20.04.0 @ii umH Ib >
Broken simple-scan:amd64 Depends on libsane1:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umR > (>= 1.0.24)
  Considering libsane1:amd64 17 as a solution to simple-scan:amd64 1
  Removing simple-scan:amd64 rather than change libsane1:amd64
  MarkDelete simple-scan:amd64 < 3.28.0-0ubuntu1 | 3.36.3-0ubuntu0.20.04.0 @ii umH Ib > FU=0
Investigating (5) colord:amd64 < 1.3.3-2build1 -> 1.4.4-2 @ii umU Ib >
Broken colord:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.24)
  Considering libsane:amd64 38 as a solution to colord:amd64 38
  MarkKeep colord:amd64 < 1.3.3-2build1 -> 1.4.4-2 @ii umU Ib > FU=0
  Removing colord:amd64 rather than change libsane:amd64
  MarkDelete colord:amd64 < 1.3.3-2build1 | 1.4.4-2 @ii umH Ib > FU=0
Investigating (5) gnome-control-center:amd64 < 1:3.28.2-0ubuntu0.18.04.6 -> 1:3.36.4-0ubuntu2 @ii umU Ib >
Broken gnome-control-center:amd64 Depends on colord:amd64 < 1.3.3-2build1 | 1.4.4-2 @ii umR > (>= 0.1.30)
  Considering colord:amd64 38 as a solution to gnome-control-center:amd64 22
  MarkKeep gnome-control-center:amd64 < 1:3.28.2-0ubuntu0.18.04.6 -> 1:3.36.4-0ubuntu2 @ii umU Ib > FU=0
  Removing gnome-control-center:amd64 rather than change colord:amd64
  MarkDelete gnome-control-center:amd64 < 1:3.28.2-0ubuntu0.18.04.6 | 1:3.36.4-0ubuntu2 @ii umH Ib > FU=0
Investigating (5) ubuntu-desktop-minimal:amd64 < none -> 1.450.2 @un uN Ib >
Broken ubuntu-desktop-minimal:amd64 Depends on gnome-control-center:amd64 < 1:3.28.2-0ubuntu0.18.04.6 | 1:3.36.4-0ubuntu2 @ii umR >
  Considering gnome-control-center:amd64 38 as a solution to ubuntu-desktop-minimal:amd64 0
  MarkKeep ubuntu-desktop-minimal:amd64 < none -> 1.450.2 @un uN Ib > FU=0
  Holding Back ubuntu-desktop-minimal:amd64 rather than change gnome-control-center:amd64
Investigating (5) gnome-color-manager:amd64 < 3.28.0-1 -> 3.36.0-1 @ii umU Ib >
Broken gnome-color-manager:amd64 Depends on colord:amd64 < 1.3.3-2build1 | 1.4.4-2 @ii umR > (>= 1.3.1)
  Considering colord:amd64 38 as a solution to gnome-color-manager:amd64 0
  MarkKeep gnome-color-manager:amd64 < 3.28.0-1 -> 3.36.0-1 @ii umU Ib > FU=0
  Removing gnome-color-manager:amd64 rather than change colord:amd64
  MarkDelete gnome-color-manager:amd64 < 3.28.0-1 | 3.36.0-1 @ii umH Ib > FU=0
Investigating (5) ubuntu-desktop:amd64 < 1.417.5 -> 1.450.2 @ii umU Ib >
Broken ubuntu-desktop:amd64 Depends on gnome-control-center:amd64 < 1:3.28.2-0ubuntu0.18.04.6 | 1:3.36.4-0ubuntu2 @ii umR >
  Considering gnome-control-center:amd64 38 as a solution to ubuntu-desktop:amd64 0
  MarkKeep ubuntu-desktop:amd64 < 1.417.5 -> 1.450.2 @ii umU Ib > FU=0
  Removing ubuntu-desktop:amd64 rather than change gnome-control-center:amd64
  Setting alsa-base:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting alsa-utils:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting anacron:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting at-spi2-core:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting bc:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ca-certificates:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting dmz-cursor-theme:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-dejavu-core:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-freefont-ttf:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting foomatic-db-compressed-ppds:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gdm3:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting genisoimage:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ghostscript-x:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-control-center:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-menus:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-session-canberra:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-settings-daemon:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-shell:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-shell-extension-appindicator:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-shell-extension-ubuntu-dock:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gstreamer1.0-alsa:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gstreamer1.0-packagekit:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gstreamer1.0-plugins-base-apps:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gstreamer1.0-pulseaudio:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gvfs-bin:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting inputattach:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting language-selector-gnome:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libatk-adaptor:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libnotify-bin:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libsasl2-modules:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libu2f-udev:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting nautilus:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting openprinting-ppds:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-pnm2ppa:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting pulseaudio:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting rfkill:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting software-properties-gtk:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting spice-vdagent:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ubuntu-artwork:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ubuntu-drivers-common:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ubuntu-release-upgrader-gtk:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ubuntu-session:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ubuntu-settings:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ubuntu-sounds:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting unzip:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting update-manager:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting update-notifier:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting wireless-tools:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting wpasupplicant:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xdg-user-dirs:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xdg-user-dirs-gtk:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xkb-data:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xorg:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting yelp:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting zenity:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting zip:amd64 NOT as auto-installed (direct Depends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting acpi-support:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting aisleriot:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting app-install-data-partner:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting apport-gtk:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting avahi-autoipd:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting avahi-daemon:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting baobab:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting bluez:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting bluez-cups:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting branding-ubuntu:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting brltty:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting cheese:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting cups:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting cups-bsd:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting cups-client:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting cups-filters:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting deja-dup:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting dirmngr:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting eog:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting evince:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting example-content:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting file-roller:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting firefox:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-indic:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-kacst-one:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-khmeros-core:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-lao:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-liberation:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-lklug-sinhala:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-noto-cjk:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-noto-color-emoji:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-sil-abyssinica:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-sil-padauk:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-thai-tlwg:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-tibetan-machine:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fonts-ubuntu:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fwupd:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fwupdate:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting fwupdate-signed:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gedit:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gir1.2-gmenu-3.0:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-accessibility-themes:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-bluetooth:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-calendar:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-disk-utility:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-font-viewer:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-getting-started-docs:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-initial-setup:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-keyring:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-mahjongg:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-mines:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-power-manager:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-screenshot:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-software-plugin-snap:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-sudoku:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-terminal:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gnome-todo:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gpg-agent:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gsettings-ubuntu-schemas:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting gvfs-fuse:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting hplip:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ibus:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ibus-gtk:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ibus-gtk3:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ibus-table:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting im-config:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting kerneloops:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting laptop-detect:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libnss-mdns:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libpam-gnome-keyring:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libproxy1-plugin-gsettings:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libproxy1-plugin-networkmanager:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libreoffice-calc:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libreoffice-gnome:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libreoffice-impress:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libreoffice-math:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libreoffice-ogltrans:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libreoffice-pdfimport:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libreoffice-style-breeze:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libreoffice-writer:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting libwmf0.2-7-gtk:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting memtest86+:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting mousetweaks:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting nautilus-sendto:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting nautilus-share:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting network-manager:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting network-manager-config-connectivity-ubuntu:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting network-manager-pptp-gnome:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting orca:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting packagekit:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting pcmciautils:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting plymouth-theme-ubuntu-logo:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting policykit-desktop-privileges:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ppp:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting pppconfig:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting pppoeconf:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-brlaser:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-c2esp:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-foo2zjs:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-m2300w:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-min12xxw:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-ptouch:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-pxljr:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-sag-gdi:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting printer-driver-splix:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting pulseaudio-module-bluetooth:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting remmina:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting rhythmbox:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting seahorse:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting shotwell:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting simple-scan:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting snapd:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting speech-dispatcher:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting system-config-printer:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting thunderbird:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting thunderbird-gnome-support:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting totem:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting transmission-gtk:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ubuntu-docs:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ubuntu-report:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting ubuntu-software:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting usb-creator-gtk:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting vino:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting whoopsie:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xcursor-themes:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xdg-desktop-portal-gtk:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xdg-utils:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  Setting xul-ext-ubufox:amd64 NOT as auto-installed (direct Recommends of ubuntu-desktop:amd64 which is in APT::Never-MarkAuto-Sections)
  MarkDelete ubuntu-desktop:amd64 < 1.417.5 | 1.450.2 @ii umH Ib > FU=0
Done
  MarkInstall xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii ugU Ib > FU=1
  Installing xserver-xorg-video-amdgpu as Depends of xserver-xorg-video-all
      MarkKeep xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii gR > FU=0
  Installing xserver-xorg-video-ati as Depends of xserver-xorg-video-all
      MarkKeep xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii gR > FU=0
  Installing xserver-xorg-video-nouveau as Depends of xserver-xorg-video-all
      MarkKeep xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii gR > FU=0
  previously satisfied important dependency on xserver-xorg-video-intel:amd64
  Installing xserver-xorg-video-intel as Recommends of xserver-xorg-video-all
      MarkKeep xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii gR > FU=0
Starting pkgProblemResolver with broken count: 4
Starting 2 pkgProblemResolver with broken count: 4
Investigating (0) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 20 as a solution to xserver-xorg-video-ati:amd64 0
  Removing xserver-xorg-video-ati:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 20 as a solution to xserver-xorg-video-intel:amd64 0
  Removing xserver-xorg-video-intel:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-intel:amd64 < 2:2.99.917+git2005251930.5ca3ac~oibaf~b @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 20 as a solution to xserver-xorg-video-nouveau:amd64 0
  Removing xserver-xorg-video-nouveau:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
Investigating (0) xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 20 as a solution to xserver-xorg-video-amdgpu:amd64 0
  Removing xserver-xorg-video-amdgpu:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
Investigating (1) xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii pumU Ib >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR >
  Considering xserver-xorg-video-amdgpu:amd64 0 as a solution to xserver-xorg-video-all:amd64 10004
  Added xserver-xorg-video-amdgpu:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR >
  Considering xserver-xorg-video-ati:amd64 0 as a solution to xserver-xorg-video-all:amd64 10004
  Added xserver-xorg-video-ati:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR >
  Considering xserver-xorg-video-nouveau:amd64 0 as a solution to xserver-xorg-video-all:amd64 10004
  Added xserver-xorg-video-nouveau:amd64 to the remove list
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-amdgpu:amd64
  MarkKeep xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-ati:amd64
  MarkKeep xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-nouveau:amd64
  MarkKeep xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR > FU=0
Investigating (1) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 20 as a solution to xserver-xorg-video-ati:amd64 0
  Removing xserver-xorg-video-ati:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (1) xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 20 as a solution to xserver-xorg-video-nouveau:amd64 0
  Removing xserver-xorg-video-nouveau:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
Investigating (1) xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 20 as a solution to xserver-xorg-video-amdgpu:amd64 0
  Removing xserver-xorg-video-amdgpu:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
Investigating (2) xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii pumU Ib >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR >
  Considering xserver-xorg-video-amdgpu:amd64 0 as a solution to xserver-xorg-video-all:amd64 10004
  Added xserver-xorg-video-amdgpu:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR >
  Considering xserver-xorg-video-ati:amd64 0 as a solution to xserver-xorg-video-all:amd64 10004
  Added xserver-xorg-video-ati:amd64 to the remove list
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR >
  Considering xserver-xorg-video-nouveau:amd64 0 as a solution to xserver-xorg-video-all:amd64 10004
  Added xserver-xorg-video-nouveau:amd64 to the remove list
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-amdgpu:amd64
  MarkKeep xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-ati:amd64
  MarkKeep xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR > FU=0
  Fixing xserver-xorg-video-all:amd64 via keep of xserver-xorg-video-nouveau:amd64
  MarkKeep xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR > FU=0
Investigating (2) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 20 as a solution to xserver-xorg-video-ati:amd64 10004
  Added xserver-xorg-core:amd64 to the remove list
Broken xserver-xorg-video-ati:amd64 Depends on xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii gR >
  Considering xserver-xorg-video-radeon:amd64 1 as a solution to xserver-xorg-video-ati:amd64 10004
  Added xserver-xorg-video-radeon:amd64 to the remove list
  Fixing xserver-xorg-video-ati:amd64 via keep of xserver-xorg-core:amd64
  MarkKeep xserver-xorg-core:amd64 < 2:1.19.6-1ubuntu4.8 -> 2:1.20.9-2ubuntu1.2~20.04.1 @ii umU > FU=0
  Fixing xserver-xorg-video-ati:amd64 via keep of xserver-xorg-video-radeon:amd64
  MarkKeep xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii gR > FU=0
 Try to Re-Instate (3) xserver-xorg-core:amd64
Re-Instated xserver-xorg-core:amd64 (4 vs 4)
Investigating (3) xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii gK Ib >
Broken xserver-xorg-video-radeon:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 10004 as a solution to xserver-xorg-video-radeon:amd64 10004
  Removing xserver-xorg-video-radeon:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-radeon:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii gK Ib > FU=0
Investigating (3) xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-ati:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 10004 as a solution to xserver-xorg-video-ati:amd64 10004
  Removing xserver-xorg-video-ati:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mK Ib > FU=0
Investigating (3) xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-nouveau:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 10004 as a solution to xserver-xorg-video-nouveau:amd64 10004
  Removing xserver-xorg-video-nouveau:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mK Ib > FU=0
Investigating (3) xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib >
Broken xserver-xorg-video-amdgpu:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
  Considering xserver-xorg-core:amd64 10004 as a solution to xserver-xorg-video-amdgpu:amd64 10004
  Removing xserver-xorg-video-amdgpu:amd64 rather than change xorg-video-abi-23:amd64
  MarkDelete xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mK Ib > FU=0
Investigating (4) xserver-xorg-video-all:amd64 < 1:7.7+19ubuntu7.1 -> 1:7.7+19ubuntu14 @ii pumU Ib >
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b @ii mR >
  Considering xserver-xorg-video-amdgpu:amd64 10004 as a solution to xserver-xorg-video-all:amd64 10004
  Considering xserver-xorg-video-amdgpu:amd64 10004 as a solution to xserver-xorg-video-all:amd64 10004
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-ati:amd64 < 1:19.1.0+git2009161930.8da3e4~oibaf~b @ii mR >
  Considering xserver-xorg-video-ati:amd64 10004 as a solution to xserver-xorg-video-all:amd64 10004
  Considering xserver-xorg-video-ati:amd64 10004 as a solution to xserver-xorg-video-all:amd64 10004
Broken xserver-xorg-video-all:amd64 Depends on xserver-xorg-video-nouveau:amd64 < 1:1.0.16+git2009230730.7212a2~oibaf~b @ii mR >
  Considering xserver-xorg-video-nouveau:amd64 10004 as a solution to xserver-xorg-video-all:amd64 10004
  Considering xserver-xorg-video-nouveau:amd64 10004 as a solution to xserver-xorg-video-all:amd64 10004
Done

cat /var/log/dist-upgrade/main.log
2021-02-01 16:04:19,300 INFO Using config files '['./DistUpgrade.cfg.bionic']'
2021-02-01 16:04:19,300 INFO uname information: 'Linux ICSDEV-02 5.4.0-65-generic #73~18.04.1-Ubuntu SMP Tue Jan 19 09:02:24 UTC 2021 x86_64'
2021-02-01 16:04:19,702 INFO apt version: '1.6.12ubuntu0.2'
2021-02-01 16:04:19,702 INFO python version: '3.6.9 (default, Oct 8 2020, 12:12:24)
[GCC 8.4.0]'
2021-02-01 16:04:19,707 INFO release-upgrader version '20.04.29' started
2021-02-01 16:04:19,765 INFO locale: 'en_GB' 'UTF-8'
2021-02-01 16:04:19,895 DEBUG Using 'DistUpgradeViewGtk3' view
2021-02-01 16:04:19,929 DEBUG enable dpkg --force-overwrite
2021-02-01 16:04:19,942 DEBUG creating statefile: '/var/log/dist-upgrade/apt-clone_system_state.tar.gz'
2021-02-01 16:04:22,707 DEBUG lsb-release: 'bionic'
2021-02-01 16:04:22,707 DEBUG _pythonSymlinkCheck run
2021-02-01 16:04:22,708 DEBUG openCache()
2021-02-01 16:04:22,708 DEBUG quirks: running PreCacheOpen
2021-02-01 16:04:22,708 DEBUG running Quirks.PreCacheOpen
2021-02-01 16:04:23,582 DEBUG Comparing 4.15.0-135 with
2021-02-01 16:04:23,586 DEBUG Comparing 5.4.0-62 with 4.15.0-135
2021-02-01 16:04:23,587 DEBUG Comparing 5.4.0-65 with 5.4.0-62
2021-02-01 16:04:23,773 DEBUG /openCache(), new cache size 101748
2021-02-01 16:04:23,773 DEBUG need_server_mode(): run in 'desktop' mode, (because of pkg 'ubuntu-desktop')
2021-02-01 16:04:23,773 DEBUG checkViewDepends()
2021-02-01 16:04:23,776 DEBUG running doUpdate() (showErrors=False)
2021-02-01 16:04:24,775 DEBUG openCache()
2021-02-01 16:04:25,663 DEBUG Comparing 4.15.0-135 with
2021-02-01 16:04:25,667 DEBUG Comparing 5.4.0-62 with 4.15.0-135
2021-02-01 16:04:25,667 DEBUG Comparing 5.4.0-65 with 5.4.0-62
2021-02-01 16:04:25,858 DEBUG /openCache(), new cache size 101748
2021-02-01 16:04:25,858 DEBUG doPostInitialUpdate
2021-02-01 16:04:25,858 DEBUG quirks: running focalPostInitialUpdate
2021-02-01 16:04:25,858 DEBUG running Quirks.focalPostInitialUpdate
2021-02-01 16:04:27,840 DEBUG Snap core18 is installed
2021-02-01 16:04:28,024 DEBUG Snap gnome-3-34-1804 is installed
2021-02-01 16:04:28,025 DEBUG Snap gnome-3-34-1804 is not tracking the release channel
2021-02-01 16:04:28,207 DEBUG Snap gtk-common-themes is installed
2021-02-01 16:04:28,607 DEBUG Snap gnome-3-28-1804 is installed
2021-02-01 16:04:28,608 DEBUG Snap gnome-3-28-1804 is not tracking the release channel
2021-02-01 16:04:28,947 DEBUG Snap gnome-calculator is installed
2021-02-01 16:04:29,204 DEBUG Snap gnome-characters is installed
2021-02-01 16:04:29,399 DEBUG Snap gnome-logs is installed
2021-02-01 16:04:31,277 DEBUG MetaPkgs: ubuntu-desktop
2021-02-01 16:04:33,616 DEBUG Foreign:
2021-02-01 16:04:33,616 DEBUG Obsolete: clipgrab containerd.io docker-ce docker-ce-cli docker-ce-rootless-extras libegl-dev libgl-dev libgles-dev libglx-dev libopengl-dev libpython2-stdlib mysql-apt-config mysql-community-client mysql-community-client-core mysql-community-client-plugins mysql-community-server mysql-community-server-core mysql-workbench-community python2 python2-minimal simplescreenrecorder-lib teams zoom
2021-02-01 16:04:33,617 DEBUG updateSourcesList()
2021-02-01 16:04:33,632 DEBUG rewriteSourcesList() with mirror_check
2021-02-01 16:04:33,632 DEBUG ['ubuntu-minimal', 'ubuntu-standard']
2021-02-01 16:04:33,632 DEBUG Checking pkg: ubuntu-minimal
2021-02-01 16:04:33,634 DEBUG Checking pkg: ubuntu-standard
2021-02-01 16:04:33,635 DEBUG examining: 'deb http://gb.archive.ubuntu.com/ubuntu/ bionic main restricted'
2021-02-01 16:04:33,635 DEBUG verifySourcesListEntry: deb http://gb.archive.ubuntu.com/ubuntu/ focal main restricted
2021-02-01 16:04:33,635 DEBUG url_downloadable: http://gb.archive.ubuntu.com/ubuntu//dists/focal/Release
2021-02-01 16:04:33,635 DEBUG s='http' n='gb.archive.ubuntu.com' p='/ubuntu//dists/focal/Release' q='' f=''
2021-02-01 16:04:33,708 DEBUG entry 'deb http://gb.archive.ubuntu.com/ubuntu/ focal main restricted' updated to new dist
2021-02-01 16:04:33,708 DEBUG examining: 'deb http://gb.archive.ubuntu.com/ubuntu/ bionic-updates main restricted'
2021-02-01 16:04:33,708 DEBUG entry 'deb http://gb.archive.ubuntu.com/ubuntu/ focal-updates main restricted' updated to new dist
2021-02-01 16:04:33,709 DEBUG examining: 'deb http://gb.archive.ubuntu.com/ubuntu/ bionic universe'
2021-02-01 16:04:33,709 DEBUG entry 'deb http://gb.archive.ubuntu.com/ubuntu/ focal universe' updated to new dist
2021-02-01 16:04:33,709 DEBUG examining: 'deb http://gb.archive.ubuntu.com/ubuntu/ bionic-updates universe'
2021-02-01 16:04:33,709 DEBUG entry 'deb http://gb.archive.ubuntu.com/ubuntu/ focal-updates universe' updated to new dist
2021-02-01 16:04:33,709 DEBUG examining: 'deb http://gb.archive.ubuntu.com/ubuntu/ bionic multiverse'
2021-02-01 16:04:33,709 DEBUG entry 'deb http://gb.archive.ubuntu.com/ubuntu/ focal multiverse' updated to new dist
2021-02-01 16:04:33,709 DEBUG examining: 'deb http://gb.archive.ubuntu.com/ubuntu/ bionic-updates multiverse'
2021-02-01 16:04:33,709 DEBUG entry 'deb http://gb.archive.ubuntu.com/ubuntu/ focal-updates multiverse' updated to new dist
2021-02-01 16:04:33,710 DEBUG examining: 'deb http://gb.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse'
2021-02-01 16:04:33,710 DEBUG entry 'deb http://gb.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse' updated to new dist
2021-02-01 16:04:33,710 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu bionic-security main restricted'
2021-02-01 16:04:33,710 DEBUG verifySourcesListEntry: deb http://security.ubuntu.com/ubuntu focal main restricted
2021-02-01 16:04:33,710 DEBUG url_downloadable: http://security.ubuntu.com/ubuntu/dists/focal/Release
2021-02-01 16:04:33,710 DEBUG s='http' n='security.ubuntu.com' p='/ubuntu/dists/focal/Release' q='' f=''
2021-02-01 16:04:33,913 DEBUG entry 'deb http://security.ubuntu.com/ubuntu focal-security main restricted' updated to new dist
2021-02-01 16:04:33,913 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu bionic-security universe'
2021-02-01 16:04:33,914 DEBUG entry 'deb http://security.ubuntu.com/ubuntu focal-security universe' updated to new dist
2021-02-01 16:04:33,914 DEBUG examining: 'deb http://security.ubuntu.com/ubuntu bionic-security multiverse'
2021-02-01 16:04:33,914 DEBUG entry 'deb http://security.ubuntu.com/ubuntu focal-security multiverse' updated to new dist
2021-02-01 16:04:33,921 DEBUG running doUpdate() (showErrors=True)
2021-02-01 16:04:46,425 DEBUG openCache()
2021-02-01 16:04:47,141 DEBUG Comparing 4.15.0-135 with
2021-02-01 16:04:47,142 DEBUG Comparing 5.4.0-62 with 4.15.0-135
2021-02-01 16:04:47,142 DEBUG Comparing 5.4.0-65 with 5.4.0-62
2021-02-01 16:04:47,274 DEBUG /openCache(), new cache size 67704
2021-02-01 16:04:47,274 DEBUG need_server_mode(): run in 'desktop' mode, (because of pkg 'ubuntu-desktop')
2021-02-01 16:04:47,275 DEBUG quirks: running PreDistUpgradeCache
2021-02-01 16:04:47,275 DEBUG running Quirks.PreDistUpgradeCache
2021-02-01 16:04:47,275 INFO checking for python-dbg
2021-02-01 16:04:47,275 INFO checking for python-doc
2021-02-01 16:04:47,275 INFO checking for python-minimal
2021-02-01 16:04:47,275 INFO installing python-is-python2 because python-minimal was installed
2021-02-01 16:04:47,275 DEBUG Installing 'python-is-python2' (python-minimal was installed on the system)
2021-02-01 16:04:47,297 INFO removing python-minimal because python-is-python2 is being installed
2021-02-01 16:04:47,298 DEBUG Removing 'python-minimal' (python-is-python2 is being installed on the system)
2021-02-01 16:04:47,319 INFO failed to remove python-minimal
2021-02-01 16:04:47,320 INFO checking for python-dev
2021-02-01 16:04:47,320 INFO checking for libpython-dev
2021-02-01 16:04:47,321 INFO checking for libpython-stdlib
2021-02-01 16:04:47,321 INFO removing libpython-stdlib because None is being installed
2021-02-01 16:04:47,321 DEBUG Removing 'libpython-stdlib' (None is being installed on the system)
2021-02-01 16:04:47,343 INFO failed to remove libpython-stdlib
2021-02-01 16:04:47,344 INFO checking for libpython-dbg
2021-02-01 16:04:48,647 DEBUG Installing 'xserver-xorg-video-all' (Distro KeepInstalledPkgs rule)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntu-release-upgrader Edit question
Assignee:
No assignee Edit question
Solved by:
Stephen Shorrock
Solved:
Last query:
Last reply:
Manfred Hampl (m-hampl) said : #2

Quote from your output: "xserver-xorg-video-amdgpu:amd64 < 19.1.0+git2009151930.6bd3dc~oibaf~b"

You have drivers from foreign sources (PPAs), and the Ubuntu upgrader does not know how to handle them.
The recommended solution is reverting all packages to the Ubuntu-provided version.

What is the output of:

lsb_release -a

Thanks

Stephen Shorrock (sms67) said : #4

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.5 LTS
Release: 18.04
Codename: bionic

I'm attempting to upgrade to 20.04.

I've been attempting to remove manually added packages, but at some stage the upgrade will just become a fresh install! eg:

sudo ppa-purge ppa:ms-teams
 1934 sudo ppa-purge ppa:teams
 1935 sudo ppa-purge ppa:clipgrab-team/ppa
 1936 sudo ppa-purge ppa:oibaf/graphics-drivers
 1937 sudo ppa-purge ppa:maarten-baert/simplescreenrecorder
 1938 sudo ppa-purge ppa:linux/ubuntu
 1939 sudo ppa-purge ppa:oibaf/graphics-drivers
 1942 sudo ppa-purge ppa:oibaf/graphics-drivers
 1943 sudo ppa-purge ppa:clipgrab-team/ppa
 1952 sudo apt remove teams
 1953 sudo apt remove docker
 1954 sudo apt remove graphics-drivers
 1958 sudo apt remove docker-ce-cli
 1959 sudo apt remove zoom
 1960 sudo apt remove endless-sky
 1961 sudo apt remove containerd.io
 1962 sudo apt remove git
 1971 sudo apt remove apparmor-utils
 1972 sudo apt remove apt-transport-https
 1977 sudo apt remove xserver-xorg-video-all
 1978 sudo apt remove xserver-xorg-video-amdgpu
 1979 sudo apt remove xserver-xorg-video-nouveau
 1980 sudo apt remove xserver-xorg-video-ati

 fgrep -R Broken /var/log/dist-upgrade/apt.log
Broken dpkg:amd64 Breaks on libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mK > (< 1.7~b)
Broken libuno-sal3:amd64 Breaks on uno-libs3:amd64 < 6.0.7-0ubuntu0.18.04.10 @ii mK >
Broken gnome-settings-daemon-common:amd64 Breaks on gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3 @ii mK > (< 3.30.1.2-2~)
Broken libkpimsmtp5abi1:amd64 Breaks on libkpimsmtp5:amd64 < 17.12.2-0ubuntu1 @ii mK > (< 19.12.3~)
Broken libhfstospell10:amd64 Conflicts on libhfstospell:amd64 < none @un H >
Broken libldb2:amd64 Breaks on libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mK > (< 2:2~)
Broken gdal-data:amd64 Breaks on libgdal20:amd64 < 2.2.3+dfsg-2 @ii mK > (< 2.5.0~)
Broken libdmtx0b:amd64 Conflicts on libdmtx0a:amd64 < 0.7.4-2 @ii mK >
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii mK >
Broken fwupdate:amd64 Breaks on fwupdate-signed:amd64 < 12-7~ubuntu18.04.3 @ii mK >
Broken fwupdate:amd64 Breaks on libfwup1:amd64 < 12-3bionic2 @ii mK > (< 12-5)
Broken libedata-book-1.2-25:amd64 Depends on libebackend-1.2-10:amd64 < 3.28.5-0ubuntu0.18.04.3 -> 3.36.4-0ubuntu1 @ii umU > (= 3.28.5-0ubuntu0.18.04.3)
Broken python-minimal:amd64 Depends on python2-minimal:amd64 < 2.7.15-3~oibaf~b -> 2.7.17-2ubuntu4 @ii umU > (= 2.7.15-3~oibaf~b)
Broken libedata-cal-1.2-28:amd64 Depends on libebackend-1.2-10:amd64 < 3.28.5-0ubuntu0.18.04.3 -> 3.36.4-0ubuntu1 @ii umU > (= 3.28.5-0ubuntu0.18.04.3)
Broken libapt-inst2.0:amd64 Depends on libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mR > (>= 1.1~exp9)
Broken libkf5pimtextedit5abi2:amd64 Depends on libkf5pimtextedit-data:amd64 < 17.12.3-0ubuntu1 -> 19.12.3-0ubuntu1 @ii umU > (= 17.12.3-0ubuntu1)
Broken xserver-xorg-video-radeon:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken libcupsmime1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
Broken libpython-stdlib:amd64 Depends on libpython2-stdlib:amd64 < 2.7.15-3~oibaf~b -> 2.7.17-2ubuntu4 @ii umU > (= 2.7.15-3~oibaf~b)
Broken mysql-workbench:amd64 Depends on gdal-abi-2-2-3:amd64 < none @un H >
Broken libkf5ldap5:amd64 Depends on libkf5ldap-data:amd64 < 17.12.3-0ubuntu1 -> 19.12.3-0ubuntu1 @ii umU > (= 17.12.3-0ubuntu1)
Broken libkpimgapicore5:amd64 Depends on libkpimgapi-data:amd64 < 17.12.3-0ubuntu1 -> 19.12.3-0ubuntu1 @ii umU > (= 17.12.3-0ubuntu1)
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken libkpimkdav5:amd64 Depends on libkpimkdav-data:amd64 < 17.12.3-0ubuntu1 -> 19.12.3-0ubuntu1 @ii umU > (= 17.12.3-0ubuntu1)
Broken libebook-1.2-19:amd64 Depends on libedata-book-1.2-25:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mR > (= 3.28.5-0ubuntu0.18.04.3)
Broken libcupsppdc1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
Broken libpolkit-backend-1-0:amd64 Depends on libpolkit-gobject-1-0:amd64 < 0.105-20ubuntu0.18.04.5 -> 0.105-26ubuntu1 @ii umU > (= 0.105-20ubuntu0.18.04.5)
Broken libkf5alarmcalendar5abi1:amd64 Depends on libkf5alarmcalendar-data:amd64 < 4:17.12.3-0ubuntu1 -> 4:19.12.3-0ubuntu1 @ii umU > (= 4:17.12.3-0ubuntu1)
Broken libcupscgi1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
Broken libsensors5:amd64 Depends on libsensors-config:amd64 < none | 1:3.6.0-2ubuntu1 @un uH >
Broken libsnmp35:amd64 Depends on libsensors5:amd64 < none | 1:3.6.0-2ubuntu1 @un uH > (>= 1:3.5.0)
Broken libhpmud0:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un uH > (>= 5.8+dfsg)
Broken hplip:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH > (= 3.20.3+dfsg0-2)
Broken libsane-hpaio:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH > (>= 3.20.3+dfsg0)
Broken printer-driver-hpcups:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH > (>= 3.20.3+dfsg0)
Broken libsane:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un uH > (>= 5.8+dfsg)
Broken sane-utils:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.27)
Broken simple-scan:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.24)
Broken libsane1:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.29-0ubuntu5.2)
Broken colord:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.24)
Broken sane-utils:amd64 Depends on libsane1:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umR > (>= 1.0.27)
Broken simple-scan:amd64 Depends on libsane1:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umR > (>= 1.0.24)
Broken colord:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.24)
Broken gnome-control-center:amd64 Depends on colord:amd64 < 1.3.3-2build1 | 1.4.4-2 @ii umR > (>= 0.1.30)
Broken ubuntu-desktop-minimal:amd64 Depends on gnome-control-center:amd64 < 1:3.28.2-0ubuntu0.18.04.6 | 1:3.36.4-0ubuntu2 @ii umR >
Broken gnome-color-manager:amd64 Depends on colord:amd64 < 1.3.3-2build1 | 1.4.4-2 @ii umR > (>= 1.3.1)
Broken ubuntu-desktop:amd64 Depends on gnome-control-center:amd64 < 1:3.28.2-0ubuntu0.18.04.6 | 1:3.36.4-0ubuntu2 @ii umR >
Broken libgl1-mesa-dri:amd64 Depends on libsensors4:amd64 < 1:3.4.0-4 @ii gR > (>= 1:3.0.0)
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii gK >
Broken libsnmp30:amd64 Depends on libsensors4:amd64 < 1:3.4.0-4 @ii gR > (>= 1:3.0.0)
Broken libgl1-mesa-dri:amd64 Depends on libsensors4:amd64 < 1:3.4.0-4 @ii gR > (>= 1:3.0.0)
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii gK >
Broken libgl1-mesa-dri:amd64 Depends on libsensors4:amd64 < 1:3.4.0-4 @ii gR > (>= 1:3.0.0)
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii gK >
Broken libsensors5:amd64 Depends on libsensors-config:amd64 < none | 1:3.6.0-2ubuntu1 @un umH >
Broken libsnmp35:amd64 Depends on libsensors5:amd64 < none | 1:3.6.0-2ubuntu1 @un umH > (>= 1:3.5.0)
Broken libsane:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un umH > (>= 5.8+dfsg)
Broken sane-utils:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un umH > (>= 1.0.27)
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii gK >
Broken libsensors5:amd64 Depends on libsensors-config:amd64 < none | 1:3.6.0-2ubuntu1 @un umH >
Broken libsnmp35:amd64 Depends on libsensors5:amd64 < none | 1:3.6.0-2ubuntu1 @un umH > (>= 1:3.5.0)
Broken libsane:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un umH > (>= 5.8+dfsg)
Broken sane-utils:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un umH > (>= 1.0.27)
Broken libhpmud0:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un umH > (>= 5.8+dfsg)
Broken printer-driver-hpcups:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umR > (>= 3.20.3+dfsg0)
Broken hplip:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umR > (= 3.20.3+dfsg0-2)
Broken libsane-hpaio:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umR > (>= 3.20.3+dfsg0)
Broken simple-scan:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un umH > (>= 1.0.24)
Broken colord:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un umH > (>= 1.0.24)

 comm -23 <(apt-mark showmanual | sort -u) <(gzip -dc /var/log/installer/initial-status.gz | sed -n 's/^Package: //p' | sort -u)
bijiben
chromium-browser
curl
duplicity
exfat-fuse
exfat-utils
freeglut3-dev
gnome-color-manager
gnupg-agent
gpick
gstreamer1.0-libav
gstreamer1.0-plugins-bad
knotes
krb5-user
libaio1
libcanberra-gtk-module
libcharon-extra-plugins
libgtk-3-dev
libpam-krb5
libwxgtk3.0-gtk3-dev
linux-generic-hwe-18.04
mesa-utils
mysql-server
mysql-workbench
mysql-workbench-community
network-manager-strongswan
pitivi
pkg-config
ppa-purge
python3.7
python3.8
python3-pip
python3-wxgtk4.0
retext
rpm
simplescreenrecorder
strongswan
supertuxkart
unrar

The upgrade error isn't specific enough for me to be able to determine which package is the problem.

Then it's Ubuntu 18.04, not Ubuntu 18 (which doesn't exist)

If you simply move the list files from /etc/apt/sources.list.d to somewhere else like a folder in $HOME it'll be fine. You then need to run:

sudo apt update
sudo apt upgrade
sudo apt dist-upgrade

Then finally

sudo do-release-upgrade

Stephen Shorrock (sms67) said : #7

Thanks

yes it is 18.04 20.04 (sorry I assumed those we the only minor versions for 18 and 20)

After following the above procedure I still get the ambiguous error:

'An unresolvable problem occurred while calculating the upgrade. '

...

Checking package manager
Reading package lists... Done
Building dependency tree
Reading state information... Done

Calculating the changes

Calculating the changes

Could not determine the upgrade

An unresolvable problem occurred while calculating the upgrade.

If none of this applies, then please report this bug using the
command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal. If
you want to investigate this yourself the log files in
'/var/log/dist-upgrade' will contain details about the upgrade.
Specifically, look at 'main.log' and 'apt.log'.

Restoring original system state

??
cat /etc/apt/sources.list | sed '/^#/d'

deb http://gb.archive.ubuntu.com/ubuntu/ bionic main restricted
deb http://gb.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
deb http://gb.archive.ubuntu.com/ubuntu/ bionic universe
deb http://gb.archive.ubuntu.com/ubuntu/ bionic-updates universe
deb http://gb.archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://gb.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
deb http://gb.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu bionic-security main restricted
deb http://security.ubuntu.com/ubuntu bionic-security universe
deb http://security.ubuntu.com/ubuntu bionic-security multiverse

ls -l /etc/apt/
total 56
drwxr-xr-x 2 root root 4096 Feb 1 14:57 apt.conf.d
drwxr-xr-x 2 root root 4096 Sep 3 2019 auth.conf.d
drwxr-xr-x 2 root root 4096 Apr 20 2018 preferences.d
-rw-r--r-- 1 root root 3057 Feb 2 13:22 sources.list
-rw-r--r-- 1 root root 3057 Feb 2 13:21 sources.list.distUpgrade
-rw-r--r-- 1 root root 3057 Feb 1 19:58 sources.list.save
-rw-r--r-- 1 root root 23979 Nov 11 10:58 trusted.gpg
-rw-r--r-- 1 root root 2760 Mar 16 2020 trusted.gpg~
drwxr-xr-x 2 root root 4096 Nov 11 11:03 trusted.gpg.d

Broken dpkg:amd64 Breaks on libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mK > (< 1.7~b)
Broken libuno-sal3:amd64 Breaks on uno-libs3:amd64 < 6.0.7-0ubuntu0.18.04.10 @ii mK >
Broken gnome-settings-daemon-common:amd64 Breaks on gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3 @ii mK > (< 3.30.1.2-2~)
Broken libkpimsmtp5abi1:amd64 Breaks on libkpimsmtp5:amd64 < 17.12.2-0ubuntu1 @ii mK > (< 19.12.3~)
Broken libldb2:amd64 Breaks on libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mK > (< 2:2~)
Broken gdal-data:amd64 Breaks on libgdal20:amd64 < 2.2.3+dfsg-2 @ii mK > (< 2.5.0~)
Broken libdmtx0b:amd64 Conflicts on libdmtx0a:amd64 < 0.7.4-2 @ii mK >
Broken libhfstospell10:amd64 Conflicts on libhfstospell:amd64 < none @un H >
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii mK >
Broken fwupdate:amd64 Breaks on fwupdate-signed:amd64 < 12-7~ubuntu18.04.3 @ii mK >
Broken fwupdate:amd64 Breaks on libfwup1:amd64 < 12-3bionic2 @ii mK > (< 12-5)
Broken libedata-book-1.2-25:amd64 Depends on libebackend-1.2-10:amd64 < 3.28.5-0ubuntu0.18.04.3 -> 3.36.4-0ubuntu1 @ii umU > (= 3.28.5-0ubuntu0.18.04.3)
Broken xserver-xorg-video-radeon:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken python-minimal:amd64 Depends on python2-minimal:amd64 < 2.7.15-3~oibaf~b -> 2.7.17-2ubuntu4 @ii umU > (= 2.7.15-3~oibaf~b)
Broken libkf5ldap5:amd64 Depends on libkf5ldap-data:amd64 < 17.12.3-0ubuntu1 -> 19.12.3-0ubuntu1 @ii umU > (= 17.12.3-0ubuntu1)
Broken libpolkit-backend-1-0:amd64 Depends on libpolkit-gobject-1-0:amd64 < 0.105-20ubuntu0.18.04.5 -> 0.105-26ubuntu1 @ii umU > (= 0.105-20ubuntu0.18.04.5)
Broken libapt-inst2.0:amd64 Depends on libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mR > (>= 1.1~exp9)
Broken libcupscgi1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
Broken libkpimgapicore5:amd64 Depends on libkpimgapi-data:amd64 < 17.12.3-0ubuntu1 -> 19.12.3-0ubuntu1 @ii umU > (= 17.12.3-0ubuntu1)
Broken mysql-workbench:amd64 Depends on gdal-abi-2-2-3:amd64 < none @un H >
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken libedata-cal-1.2-28:amd64 Depends on libebackend-1.2-10:amd64 < 3.28.5-0ubuntu0.18.04.3 -> 3.36.4-0ubuntu1 @ii umU > (= 3.28.5-0ubuntu0.18.04.3)
Broken libkpimkdav5:amd64 Depends on libkpimkdav-data:amd64 < 17.12.3-0ubuntu1 -> 19.12.3-0ubuntu1 @ii umU > (= 17.12.3-0ubuntu1)
Broken libkf5alarmcalendar5abi1:amd64 Depends on libkf5alarmcalendar-data:amd64 < 4:17.12.3-0ubuntu1 -> 4:19.12.3-0ubuntu1 @ii umU > (= 4:17.12.3-0ubuntu1)
Broken libcupsppdc1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
Broken libpython-stdlib:amd64 Depends on libpython2-stdlib:amd64 < 2.7.15-3~oibaf~b -> 2.7.17-2ubuntu4 @ii umU > (= 2.7.15-3~oibaf~b)
Broken libcupsmime1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
Broken libkf5pimtextedit5abi2:amd64 Depends on libkf5pimtextedit-data:amd64 < 17.12.3-0ubuntu1 -> 19.12.3-0ubuntu1 @ii umU > (= 17.12.3-0ubuntu1)
Broken libebook-1.2-19:amd64 Depends on libedata-book-1.2-25:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mR > (= 3.28.5-0ubuntu0.18.04.3)
Broken libsensors5:amd64 Depends on libsensors-config:amd64 < none | 1:3.6.0-2ubuntu1 @un uH >
Broken libsnmp35:amd64 Depends on libsensors5:amd64 < none | 1:3.6.0-2ubuntu1 @un uH > (>= 1:3.5.0)
Broken libhpmud0:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un uH > (>= 5.8+dfsg)
Broken libsane-hpaio:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH > (>= 3.20.3+dfsg0)
Broken hplip:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH > (= 3.20.3+dfsg0-2)
Broken printer-driver-hpcups:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH > (>= 3.20.3+dfsg0)
Broken libsane:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un uH > (>= 5.8+dfsg)
Broken sane-utils:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.27)
Broken simple-scan:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.24)
Broken libsane1:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.29-0ubuntu5.2)
Broken colord:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.24)
Broken sane-utils:amd64 Depends on libsane1:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umR > (>= 1.0.27)
Broken simple-scan:amd64 Depends on libsane1:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umR > (>= 1.0.24)
Broken colord:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.24)
Broken gnome-control-center:amd64 Depends on colord:amd64 < 1.3.3-2build1 | 1.4.4-2 @ii umR > (>= 0.1.30)
Broken ubuntu-desktop-minimal:amd64 Depends on gnome-control-center:amd64 < 1:3.28.2-0ubuntu0.18.04.6 | 1:3.36.4-0ubuntu2 @ii umR >
Broken gnome-color-manager:amd64 Depends on colord:amd64 < 1.3.3-2build1 | 1.4.4-2 @ii umR > (>= 1.3.1)
Broken ubuntu-desktop:amd64 Depends on gnome-control-center:amd64 < 1:3.28.2-0ubuntu0.18.04.6 | 1:3.36.4-0ubuntu2 @ii umR >
Broken libgl1-mesa-dri:amd64 Depends on libsensors4:amd64 < 1:3.4.0-4 @ii gR > (>= 1:3.0.0)
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii gK >
Broken libsnmp30:amd64 Depends on libsensors4:amd64 < 1:3.4.0-4 @ii gR > (>= 1:3.0.0)
Broken libgl1-mesa-dri:amd64 Depends on libsensors4:amd64 < 1:3.4.0-4 @ii gR > (>= 1:3.0.0)
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii gK >
Broken libgl1-mesa-dri:amd64 Depends on libsensors4:amd64 < 1:3.4.0-4 @ii gR > (>= 1:3.0.0)
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii gK >
Broken libsensors5:amd64 Depends on libsensors-config:amd64 < none | 1:3.6.0-2ubuntu1 @un umH >
Broken libsnmp35:amd64 Depends on libsensors5:amd64 < none | 1:3.6.0-2ubuntu1 @un umH > (>= 1:3.5.0)
Broken libsane:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un umH > (>= 5.8+dfsg)
Broken sane-utils:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un umH > (>= 1.0.27)
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii gK >
Broken libsensors5:amd64 Depends on libsensors-config:amd64 < none | 1:3.6.0-2ubuntu1 @un umH >
Broken libsnmp35:amd64 Depends on libsensors5:amd64 < none | 1:3.6.0-2ubuntu1 @un umH > (>= 1:3.5.0)
Broken libsane:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un umH > (>= 5.8+dfsg)
Broken sane-utils:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un umH > (>= 1.0.27)
Broken libhpmud0:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un umH > (>= 5.8+dfsg)
Broken libsane-hpaio:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umR > (>= 3.20.3+dfsg0)
Broken hplip:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umR > (= 3.20.3+dfsg0-2)
Broken printer-driver-hpcups:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umR > (>= 3.20.3+dfsg0)
Broken simple-scan:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un umH > (>= 1.0.24)
Broken colord:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un umH > (>= 1.0.24)

It looks like I need to do quite a bit of manual tidy up; but not sure of the process?

Nothey are not minor versions. Ubuntu has two releases every year. One in April (the xx.04 release as April is the 4th month) and one in October (the xx.10 as October is the 10th month). The fist number in the version number is the year of release. So 20.04 was released in April 2020. Every other xx.04 release is an LTS release. so 18.04 is LTS, 20.04 is LTS and 22.04 will be the next LTS release.

What is the output of:

apt-cache policy dpkg:amd64 libapt-pkg5.0:amd64

Thanks

Stephen Shorrock (sms67) said : #10

thanks for bearing with me!

apt-cache policy dpkg:amd64 libapt-pkg5.0:amd64
dpkg:
  Installed: 1.19.0.5ubuntu2.3
  Candidate: 1.19.0.5ubuntu2.3
  Version table:
 *** 1.19.0.5ubuntu2.3 500
        500 http://gb.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1.19.0.5ubuntu2 500
        500 http://gb.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
libapt-pkg5.0:
  Installed: 1.6.12ubuntu0.2
  Candidate: 1.6.12ubuntu0.2
  Version table:
 *** 1.6.12ubuntu0.2 500
        500 http://gb.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
        100 /var/lib/dpkg/status
     1.6.1 500
        500 http://gb.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

Manfred Hampl (m-hampl) said : #11

I still see packages from the oibaf PPA

Broken python-minimal:amd64 Depends on python2-minimal:amd64 < 2.7.15-3~oibaf~b -> 2.7.17-2ubuntu4 @ii umU > (= 2.7.15-3~oibaf~b)
Broken libpython-stdlib:amd64 Depends on libpython2-stdlib:amd64 < 2.7.15-3~oibaf~b -> 2.7.17-2ubuntu4 @ii umU > (= 2.7.15-3~oibaf~b)

What si the output of
apt-cache policy libpython2-stdlib libpython-stdlib python2-minimal python-minimal

Stephen Shorrock (sms67) said : #12

Thanks:

apt-cache policy libpython2-stdlib libpython-stdlib python2-minimal python-minimal
libpython2-stdlib:
  Installed: 2.7.15-3~oibaf~b
  Candidate: 2.7.15-3~oibaf~b
  Version table:
 *** 2.7.15-3~oibaf~b 100
        100 /var/lib/dpkg/status
libpython-stdlib:
  Installed: 2.7.15-3~oibaf~b
  Candidate: 2.7.15-3~oibaf~b
  Version table:
 *** 2.7.15-3~oibaf~b 100
        100 /var/lib/dpkg/status
     2.7.15~rc1-1 500
        500 http://gb.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
python2-minimal:
  Installed: 2.7.15-3~oibaf~b
  Candidate: 2.7.15-3~oibaf~b
  Version table:
 *** 2.7.15-3~oibaf~b 100
        100 /var/lib/dpkg/status
python-minimal:
  Installed: 2.7.15-3~oibaf~b
  Candidate: 2.7.15-3~oibaf~b
  Version table:
 *** 2.7.15-3~oibaf~b 100
        100 /var/lib/dpkg/status
     2.7.15~rc1-1 500
        500 http://gb.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

How should I go about getting rid of these?

Manfred Hampl (m-hampl) said : #13

What output do you receive for

apt simulate install libpython-stdlib= 2.7.15~rc1-1 python-minimal= 2.7.15~rc1-1 libpython2-stdlib- python2-minimal-

Stephen Shorrock (sms67) said : #14

I didn't seem to have 'simulate' available but used '--dry-run' ?? :

sudo apt --dry-run install libpython-stdlib=2.7.15~rc1-1 python-minimal=2.7.15~rc1-1 libpython2-stdlib- python2-minimal-
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  gdal-data libaec0 libarmadillo8 libarpack2 libctemplate3 libdap25
  libdapclient6v5 libepsilon1 libfreexl1 libfyba0 libgdal20 libgeos-3.6.2
  libgeos-c1v5 libgeotiff2 libgnome-keyring-common libgnome-keyring0
  libgtkmm-2.4-1v5 libhdf4-0-alt libhdf5-100 libkmlbase1 libkmldom1
  libkmlengine1 libmysqlcppconn7v5 libnetcdf13 libodbc1 libogdi3.2 libpq5
  libproj12 libqhull7 librsync1 libspatialite7 libsuperlu5 libsz2
  libtinyxml2.6.2v5 liburiparser1 libvsqlitepp3v5 mysql-workbench-data
  odbcinst odbcinst1debian2 proj-bin proj-data
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  jackd1 jackd1-firewire libjack0 libzita-alsa-pcmi0 libzita-resampler1
Suggested packages:
  jack-tools meterbridge
Recommended packages:
  python
The following packages will be REMOVED
  duplicity jackd2 jackd2-firewire libjack-jackd2-0 libpython2-stdlib
  mysql-utilities mysql-workbench python python-asn1crypto python-cffi-backend
  python-cryptography python-dbus python-enum34 python-fasteners python-gi
  python-idna python-ipaddress python-lockfile python-monotonic
  python-mysql.connector python-paramiko python-pexpect python-ptyprocess
  python-pyasn1 python-pyodbc python-pysqlite2 python-six python2
  python2-minimal
The following NEW packages will be installed
  jackd1 jackd1-firewire libjack0 libzita-alsa-pcmi0 libzita-resampler1
The following packages will be DOWNGRADED:
  libpython-stdlib python-minimal
0 to upgrade, 5 to newly install, 2 to downgrade, 29 to remove and 0 not to upgrade.
Remv duplicity [0.7.17-0ubuntu1.1]
Remv jackd2-firewire [1.9.12~dfsg-2]
Remv jackd2 [1.9.12~dfsg-2] [jackd:amd64 ]
Inst jackd1 (1:0.125.0-3 Ubuntu:18.04/bionic [amd64]) []
Remv libjack-jackd2-0 [1.9.12~dfsg-2] [simplescreenrecorder:amd64 gstreamer1.0-plugins-good:amd64 libfluidsynth1:amd64 libavdevice57:amd64 libasound2-plugins:amd64 qjackctl:amd64 mplayer:amd64 ]
Inst libjack0 (1:0.125.0-3 Ubuntu:18.04/bionic [amd64]) []
Remv python-gi [3.26.1-2ubuntu1] []
Remv mysql-workbench [6.3.8+dfsg-1build3] []
Remv python-paramiko [2.0.0-1ubuntu1.2] []
Remv python-cryptography [2.1.4-1ubuntu1.4] []
Remv python-pyodbc [4.0.17-1] []
Remv python [2.7.15-3~oibaf~b] [python-mysql.connector:amd64 python-six:amd64 mysql-utilities:amd64 python-fasteners:amd64 python-dbus:amd64 python-monotonic:amd64 python-enum34:amd64 python-pexpect:amd64 python-lockfile:amd64 python-cffi-backend:amd64 python-ipaddress:amd64 python-ptyprocess:amd64 python-pyasn1:amd64 python-pysqlite2:amd64 python-idna:amd64 python-asn1crypto:amd64 ]
Remv python2 [2.7.15-3~oibaf~b] [python-mysql.connector:amd64 python-six:amd64 mysql-utilities:amd64 python-fasteners:amd64 python-dbus:amd64 python-monotonic:amd64 python-enum34:amd64 python-pexpect:amd64 python-lockfile:amd64 python-cffi-backend:amd64 python-ipaddress:amd64 python-ptyprocess:amd64 python-pyasn1:amd64 python-pysqlite2:amd64 python-idna:amd64 python-asn1crypto:amd64 ]
Inst libpython-stdlib [2.7.15-3~oibaf~b] (2.7.15~rc1-1 Ubuntu:18.04/bionic [amd64]) [libpython2-stdlib:amd64 on libpython-stdlib:amd64] [python-mysql.connector:amd64 python-six:amd64 libpython2-stdlib:amd64 mysql-utilities:amd64 python-fasteners:amd64 python-dbus:amd64 python-monotonic:amd64 python-enum34:amd64 python-pexpect:amd64 python-lockfile:amd64 python-cffi-backend:amd64 python-ipaddress:amd64 python-ptyprocess:amd64 python-pyasn1:amd64 python-pysqlite2:amd64 python-idna:amd64 python-asn1crypto:amd64 ]
Remv libpython2-stdlib [2.7.15-3~oibaf~b] [python-mysql.connector:amd64 python-six:amd64 mysql-utilities:amd64 python-fasteners:amd64 python-dbus:amd64 python-monotonic:amd64 python-enum34:amd64 python-pexpect:amd64 python-lockfile:amd64 python-cffi-backend:amd64 python-ipaddress:amd64 python-ptyprocess:amd64 python-pyasn1:amd64 python-pysqlite2:amd64 python-idna:amd64 python-asn1crypto:amd64 ]
Remv mysql-utilities [1.6.4-1] [python-mysql.connector:amd64 python-six:amd64 python-fasteners:amd64 python-dbus:amd64 python-monotonic:amd64 python-enum34:amd64 python-pexpect:amd64 python-lockfile:amd64 python-cffi-backend:amd64 python-ipaddress:amd64 python-ptyprocess:amd64 python-pyasn1:amd64 python-pysqlite2:amd64 python-idna:amd64 python-asn1crypto:amd64 ]
Remv python-asn1crypto [0.24.0-1] [python-mysql.connector:amd64 python-six:amd64 python-fasteners:amd64 python-dbus:amd64 python-monotonic:amd64 python-enum34:amd64 python-pexpect:amd64 python-lockfile:amd64 python-cffi-backend:amd64 python-ipaddress:amd64 python-ptyprocess:amd64 python-pyasn1:amd64 python-pysqlite2:amd64 python-idna:amd64 ]
Remv python-cffi-backend [1.11.5-1] [python-mysql.connector:amd64 python-six:amd64 python-fasteners:amd64 python-dbus:amd64 python-monotonic:amd64 python-enum34:amd64 python-pexpect:amd64 python-lockfile:amd64 python-ipaddress:amd64 python-ptyprocess:amd64 python-pyasn1:amd64 python-pysqlite2:amd64 python-idna:amd64 ]
Remv python-dbus [1.2.6-1] [python-mysql.connector:amd64 python-six:amd64 python-fasteners:amd64 python-monotonic:amd64 python-enum34:amd64 python-pexpect:amd64 python-lockfile:amd64 python-ipaddress:amd64 python-ptyprocess:amd64 python-pyasn1:amd64 python-pysqlite2:amd64 python-idna:amd64 ]
Remv python-enum34 [1.1.6-2] [python-mysql.connector:amd64 python-six:amd64 python-fasteners:amd64 python-monotonic:amd64 python-pexpect:amd64 python-lockfile:amd64 python-ipaddress:amd64 python-ptyprocess:amd64 python-pyasn1:amd64 python-pysqlite2:amd64 python-idna:amd64 ]
Remv python-fasteners [0.12.0-3] [python-mysql.connector:amd64 python-six:amd64 python-monotonic:amd64 python-pexpect:amd64 python-lockfile:amd64 python-ipaddress:amd64 python-ptyprocess:amd64 python-pyasn1:amd64 python-pysqlite2:amd64 python-idna:amd64 ]
Remv python-idna [2.6-1] [python-mysql.connector:amd64 python-six:amd64 python-monotonic:amd64 python-pexpect:amd64 python-lockfile:amd64 python-ipaddress:amd64 python-ptyprocess:amd64 python-pyasn1:amd64 python-pysqlite2:amd64 ]
Remv python-ipaddress [1.0.17-1] [python-mysql.connector:amd64 python-six:amd64 python-monotonic:amd64 python-pexpect:amd64 python-lockfile:amd64 python-ptyprocess:amd64 python-pyasn1:amd64 python-pysqlite2:amd64 ]
Remv python-lockfile [1:0.12.2-2] [python-mysql.connector:amd64 python-six:amd64 python-monotonic:amd64 python-pexpect:amd64 python-ptyprocess:amd64 python-pyasn1:amd64 python-pysqlite2:amd64 ]
Remv python-monotonic [1.1-2] [python-mysql.connector:amd64 python-six:amd64 python-pexpect:amd64 python-ptyprocess:amd64 python-pyasn1:amd64 python-pysqlite2:amd64 ]
Remv python-mysql.connector [2.1.6-1] [python-six:amd64 python-pexpect:amd64 python-ptyprocess:amd64 python-pyasn1:amd64 python-pysqlite2:amd64 ]
Remv python-pexpect [4.2.1-1] [python-six:amd64 python-ptyprocess:amd64 python-pyasn1:amd64 python-pysqlite2:amd64 ]
Remv python-ptyprocess [0.5.2-1] [python-six:amd64 python-pyasn1:amd64 python-pysqlite2:amd64 ]
Remv python-pyasn1 [0.4.2-3] [python-six:amd64 python-pysqlite2:amd64 ]
Remv python-pysqlite2 [2.7.0-1] [python-six:amd64 ]
Remv python-six [1.11.0-2] []
Remv python2-minimal [2.7.15-3~oibaf~b] [python-minimal:amd64 ]
Inst python-minimal [2.7.15-3~oibaf~b] (2.7.15~rc1-1 Ubuntu:18.04/bionic [amd64]) []
Inst libzita-alsa-pcmi0 (0.2.0-4ubuntu2 Ubuntu:18.04/bionic [amd64]) []
Inst libzita-resampler1 (1.6.0-2 Ubuntu:18.04/bionic [amd64])
Inst jackd1-firewire (1:0.125.0-3 Ubuntu:18.04/bionic [amd64])
Conf jackd1 (1:0.125.0-3 Ubuntu:18.04/bionic [amd64])
Conf libjack0 (1:0.125.0-3 Ubuntu:18.04/bionic [amd64])
Conf libpython-stdlib (2.7.15~rc1-1 Ubuntu:18.04/bionic [amd64])
Conf python-minimal (2.7.15~rc1-1 Ubuntu:18.04/bionic [amd64])
Conf libzita-alsa-pcmi0 (0.2.0-4ubuntu2 Ubuntu:18.04/bionic [amd64])
Conf libzita-resampler1 (1.6.0-2 Ubuntu:18.04/bionic [amd64])
Conf jackd1-firewire (1:0.125.0-3 Ubuntu:18.04/bionic [amd64])

Manfred Hampl (m-hampl) said : #15

(Sorry for the typos, but you corrected them perfectly)

Not yet what I desired (too much gets removed), try

apt --dry-run install libpython-stdlib=2.7.15~rc1-1 python-minimal=2.7.15~rc1-1 python=2.7.15~rc1-1 libpython2-stdlib- python2-minimal-

and report the results

Stephen Shorrock (sms67) said : #16

Here you go:

sudo apt --dry-run install libpython-stdlib=2.7.15~rc1-1 python-minimal=2.7.15~rc1-1 python=2.7.15~rc1-1 libpython2-stdlib- python2-minimal-
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  python-doc python-tk
The following packages will be REMOVED
  libpython2-stdlib python2 python2-minimal
The following packages will be DOWNGRADED:
  libpython-stdlib python python-minimal
0 to upgrade, 0 to newly install, 3 to downgrade, 3 to remove and 0 not to upgrade.
Inst python-minimal [2.7.15-3~oibaf~b] (2.7.15~rc1-1 Ubuntu:18.04/bionic [amd64]) [python:amd64 on python-minimal:amd64] [python2-minimal:amd64 on python-minimal:amd64] [python:amd64 python2-minimal:amd64 ]
Remv python2-minimal [2.7.15-3~oibaf~b] [python2:amd64 python:amd64 ]
Conf python-minimal (2.7.15~rc1-1 Ubuntu:18.04/bionic [amd64]) [python2:amd64 python:amd64 ]
Inst python [2.7.15-3~oibaf~b] (2.7.15~rc1-1 Ubuntu:18.04/bionic [amd64]) [python2:amd64 on python2-minimal:amd64] [python2:amd64 on python:amd64] [python2:amd64 ]
Remv python2 [2.7.15-3~oibaf~b] []
Remv libpython2-stdlib [2.7.15-3~oibaf~b] [libpython-stdlib:amd64 ]
Inst libpython-stdlib [2.7.15-3~oibaf~b] (2.7.15~rc1-1 Ubuntu:18.04/bionic [amd64])
Conf python (2.7.15~rc1-1 Ubuntu:18.04/bionic [amd64])
Conf libpython-stdlib (2.7.15~rc1-1 Ubuntu:18.04/bionic [amd64])

What are we looking for?

Manfred Hampl (m-hampl) said : #17

Looks good. running that command again without --dry-run should revert the python packages from the oibaf PPA to the standard version.
Maybe this helps for the release upgrade.

Stephen Shorrock (sms67) said : #18

Thanks, but I still have the same ambiguous error after trying again :-(

2097 sudo apt update
 2098 sudo apt upgrade
 2099 sudo apt dist-upgrade
 2100 sudo do-release-upgrade

...
Checking package manager
Reading package lists... Done
Building dependency tree
Reading state information... Done

Calculating the changes

Calculating the changes

Could not determine the upgrade

An unresolvable problem occurred while calculating the upgrade.

If none of this applies, then please report this bug using the
command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal. If
you want to investigate this yourself the log files in
'/var/log/dist-upgrade' will contain details about the upgrade.
Specifically, look at 'main.log' and 'apt.log'.

Restoring original system state

Aborting
Reading package lists... Done
Building dependency tree
Reading state information... Done

Manfred Hampl (m-hampl) said : #19

What is now the output of

tail /var/log/dist-upgrade/apt.log
grep Broken /var/log/dist-upgrade/apt.log

It seems to be necessary to (temporarily) uninstall some of the offending packages.

Stephen Shorrock (sms67) said : #20

when you say temporary uninstall you mean something like:

apt remove <package-name1>, <package-name2> (rather then purge?)

Then after the upgrade:

apt install <package-name1>, <package-name2>

should just create a list of all the manually installed packages ( comm -23 <(apt-mark showmanual | sort -u) <(gzip -dc /var/log/installer/initial-status.gz | sed -n 's/^Package: //p' | sort -u))? and just go for it?

tail /var/log/dist-upgrade/apt.log
  MarkKeep simple-scan:amd64 < 3.28.0-0ubuntu1 -> 3.36.3-0ubuntu0.20.04.0 @ii umU Ib > FU=0
  Removing simple-scan:amd64 rather than change libsane:amd64
  MarkDelete simple-scan:amd64 < 3.28.0-0ubuntu1 | 3.36.3-0ubuntu0.20.04.0 @ii umH Ib > FU=0
Investigating (9) colord:amd64 < 1.3.3-2build1 -> 1.4.4-2 @ii umU Ib >
Broken colord:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un umH > (>= 1.0.24)
  Considering libsane:amd64 15 as a solution to colord:amd64 37
  Added libsane:amd64 to the remove list
  Fixing colord:amd64 via keep of libsane:amd64
Done
Log time: 2021-02-02 19:10:18.461955

sms67@ICSDEV-02:~/code/iib_projects$ grep Broken /var/log/dist-upgrade/apt.log
Broken dpkg:amd64 Breaks on libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mK > (< 1.7~b)
Broken libuno-sal3:amd64 Breaks on uno-libs3:amd64 < 6.0.7-0ubuntu0.18.04.10 @ii mK >
Broken python2-minimal:amd64 Breaks on python-minimal:amd64 < 2.7.15~rc1-1 @ii gK > (< 2.7.15-2)
Broken libpython2-stdlib:amd64 Breaks on libpython-stdlib:amd64 < 2.7.15~rc1-1 @ii gK > (< 2.7.15-2)
Broken gnome-settings-daemon-common:amd64 Breaks on gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3 @ii mK > (< 3.30.1.2-2~)
Broken libkpimsmtp5abi1:amd64 Breaks on libkpimsmtp5:amd64 < 17.12.2-0ubuntu1 @ii mK > (< 19.12.3~)
Broken libhfstospell10:amd64 Conflicts on libhfstospell:amd64 < none @un H >
Broken gdal-data:amd64 Breaks on libgdal20:amd64 < 2.2.3+dfsg-2 @ii mK > (< 2.5.0~)
Broken libldb2:amd64 Breaks on libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mK > (< 2:2~)
Broken libdmtx0b:amd64 Conflicts on libdmtx0a:amd64 < 0.7.4-2 @ii mK >
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii mK >
Broken fwupdate:amd64 Breaks on fwupdate-signed:amd64 < 12-7~ubuntu18.04.3 @ii mK >
Broken fwupdate:amd64 Breaks on libfwup1:amd64 < 12-3bionic2 @ii mK > (< 12-5)
Broken libedata-book-1.2-25:amd64 Depends on libebackend-1.2-10:amd64 < 3.28.5-0ubuntu0.18.04.3 -> 3.36.4-0ubuntu1 @ii umU > (= 3.28.5-0ubuntu0.18.04.3)
Broken libcupsmime1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
Broken xserver-xorg-video-radeon:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken mysql-workbench:amd64 Depends on gdal-abi-2-2-3:amd64 < none @un H >
Broken xserver-xorg-video-intel:amd64 Depends on xorg-video-abi-23:amd64 < none @un H >
Broken libcupsppdc1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
Broken libkpimgapicore5:amd64 Depends on libkpimgapi-data:amd64 < 17.12.3-0ubuntu1 -> 19.12.3-0ubuntu1 @ii umU > (= 17.12.3-0ubuntu1)
Broken libkf5pimtextedit5abi2:amd64 Depends on libkf5pimtextedit-data:amd64 < 17.12.3-0ubuntu1 -> 19.12.3-0ubuntu1 @ii umU > (= 17.12.3-0ubuntu1)
Broken libkpimkdav5:amd64 Depends on libkpimkdav-data:amd64 < 17.12.3-0ubuntu1 -> 19.12.3-0ubuntu1 @ii umU > (= 17.12.3-0ubuntu1)
Broken libedata-cal-1.2-28:amd64 Depends on libebackend-1.2-10:amd64 < 3.28.5-0ubuntu0.18.04.3 -> 3.36.4-0ubuntu1 @ii umU > (= 3.28.5-0ubuntu0.18.04.3)
Broken libcupscgi1:amd64 Depends on libcups2:amd64 < 2.2.7-1ubuntu2.8 -> 2.3.1-9ubuntu1.1 @ii umU > (= 2.2.7-1ubuntu2.8)
Broken libebook-1.2-19:amd64 Depends on libedata-book-1.2-25:amd64 < 3.28.5-0ubuntu0.18.04.3 @ii mR > (= 3.28.5-0ubuntu0.18.04.3)
Broken libkf5alarmcalendar5abi1:amd64 Depends on libkf5alarmcalendar-data:amd64 < 4:17.12.3-0ubuntu1 -> 4:19.12.3-0ubuntu1 @ii umU > (= 4:17.12.3-0ubuntu1)
Broken libapt-inst2.0:amd64 Depends on libapt-pkg5.0:amd64 < 1.6.12ubuntu0.2 @ii mR > (>= 1.1~exp9)
Broken libpolkit-backend-1-0:amd64 Depends on libpolkit-gobject-1-0:amd64 < 0.105-20ubuntu0.18.04.5 -> 0.105-26ubuntu1 @ii umU > (= 0.105-20ubuntu0.18.04.5)
Broken libkf5ldap5:amd64 Depends on libkf5ldap-data:amd64 < 17.12.3-0ubuntu1 -> 19.12.3-0ubuntu1 @ii umU > (= 17.12.3-0ubuntu1)
Broken libsensors5:amd64 Depends on libsensors-config:amd64 < none | 1:3.6.0-2ubuntu1 @un uH >
Broken libsnmp35:amd64 Depends on libsensors5:amd64 < none | 1:3.6.0-2ubuntu1 @un uH > (>= 1:3.5.0)
Broken libsane:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un uH > (>= 5.8+dfsg)
Broken sane-utils:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.27)
Broken libhpmud0:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un uH > (>= 5.8+dfsg)
Broken printer-driver-hpcups:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH > (>= 3.20.3+dfsg0)
Broken libsane-hpaio:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH > (>= 3.20.3+dfsg0)
Broken hplip:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umH > (= 3.20.3+dfsg0-2)
Broken simple-scan:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.24)
Broken libsane1:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.29-0ubuntu5.2)
Broken colord:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.24)
Broken sane-utils:amd64 Depends on libsane1:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umR > (>= 1.0.27)
Broken simple-scan:amd64 Depends on libsane1:amd64 < 1.0.27-1~experimental3ubuntu2.4 | 1.0.29-0ubuntu5.2 @ii umR > (>= 1.0.24)
Broken colord:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un uH > (>= 1.0.24)
Broken gnome-control-center:amd64 Depends on colord:amd64 < 1.3.3-2build1 | 1.4.4-2 @ii umR > (>= 0.1.30)
Broken ubuntu-desktop-minimal:amd64 Depends on gnome-control-center:amd64 < 1:3.28.2-0ubuntu0.18.04.6 | 1:3.36.4-0ubuntu2 @ii umR >
Broken gnome-color-manager:amd64 Depends on colord:amd64 < 1.3.3-2build1 | 1.4.4-2 @ii umR > (>= 1.3.1)
Broken ubuntu-desktop:amd64 Depends on gnome-control-center:amd64 < 1:3.28.2-0ubuntu0.18.04.6 | 1:3.36.4-0ubuntu2 @ii umR >
Broken libgl1-mesa-dri:amd64 Depends on libsensors4:amd64 < 1:3.4.0-4 @ii gR > (>= 1:3.0.0)
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii gK >
Broken libsnmp30:amd64 Depends on libsensors4:amd64 < 1:3.4.0-4 @ii gR > (>= 1:3.0.0)
Broken libgl1-mesa-dri:amd64 Depends on libsensors4:amd64 < 1:3.4.0-4 @ii gR > (>= 1:3.0.0)
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii gK >
Broken libgl1-mesa-dri:amd64 Depends on libsensors4:amd64 < 1:3.4.0-4 @ii gR > (>= 1:3.0.0)
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii gK >
Broken libsensors5:amd64 Depends on libsensors-config:amd64 < none | 1:3.6.0-2ubuntu1 @un umH >
Broken libsnmp35:amd64 Depends on libsensors5:amd64 < none | 1:3.6.0-2ubuntu1 @un umH > (>= 1:3.5.0)
Broken libsane:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un umH > (>= 5.8+dfsg)
Broken sane-utils:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un umH > (>= 1.0.27)
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii gK >
Broken libsensors5:amd64 Depends on libsensors-config:amd64 < none | 1:3.6.0-2ubuntu1 @un umH >
Broken libsnmp35:amd64 Depends on libsensors5:amd64 < none | 1:3.6.0-2ubuntu1 @un umH > (>= 1:3.5.0)
Broken libsane:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un umH > (>= 5.8+dfsg)
Broken sane-utils:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un umH > (>= 1.0.27)
Broken libhpmud0:amd64 Depends on libsnmp35:amd64 < none | 5.8+dfsg-2ubuntu2.3 @un umH > (>= 5.8+dfsg)
Broken hplip:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umR > (= 3.20.3+dfsg0-2)
Broken printer-driver-hpcups:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umR > (>= 3.20.3+dfsg0)
Broken libsane-hpaio:amd64 Depends on libhpmud0:amd64 < 3.17.10+repack0-5 | 3.20.3+dfsg0-2 @ii umR > (>= 3.20.3+dfsg0)
Broken simple-scan:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un umH > (>= 1.0.24)
Broken colord:amd64 Depends on libsane:amd64 < none | 1.0.29-0ubuntu5.2 @un umH > (>= 1.0.24)

Manfred Hampl (m-hampl) said : #21

Saving the list of installed packages is a good idea, but this will not work for all of them. E.g. libsensors4 in bionic is replaced by libsensors5 in focal.

If you want to take the route of removing packages until the release-upgrade works, you should start at the end of the list. In your case I suggest hplip and sane (and their related packages like printer-driver-hpcups and libsane) in the first round.
You have to take care that not too many dependent packages are removed. E.g. it has to be avoided that ubuntu-desktop is removed.

Stephen Shorrock (sms67) said : #22

hhm, okay this sounds like it could take me a fair amount of time an there is a risk I end up with an unusable system.

Would a fresh install of 20.04 via an ISO be simpler? or will the install process lead me to the same place that I'm at at the moment.

?

Bernard Stafford (bernard010) said : #23

Fresh install will be simpler. You have a huge amount of broken packages.

Been thinking that. You've been messing with python which is one of the core systems in the OS. Not something to take lightly

Stephen Shorrock (sms67) said : #25

I've tracked this down to the fact I had previously installed the glut libraries that have vague recollections required a different version of opengl.

So now I've been able to upgrade to 20.04 however the broken package (or the one that allowed me to run the upgrade) was libgl1-mesa-dri:amd64.

I'm now in a terminal on 20.04 however I can't startx (for obvious reasons). Is there a way to reinstall all the xwindow and gnome libraries.

Stephen Shorrock (sms67) said : #26

Looks like I found it, added the ppa back again and reinstalled:

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt update

Thanks for all your help

PPAs are the worst