Update-manager is not opening it says failed to open "usr/bin/update-manager" no such file or directory

Asked by Manish Pathak on 2019-07-25

Update-manager is not working it is giving error.sudo apt-get update is also giving errors that {Sub-process /usr/bin/dpkg returned an error code (1)}.Please Help!!
Thank You.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubuntu-release-upgrader-core 1:18.04.34
ProcVersionSignature: Ubuntu 4.18.0-25.26~18.04.1-generic 4.18.20
Uname: Linux 4.18.0-25-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.7
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: ubuntu:GNOME
Date: Thu Jul 25 12:07:51 2019
InstallationDate: Installed on 2019-07-09 (16 days ago)
InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 (20190210)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_IN:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_IN
 SHELL=/bin/bash
SourcePackage: ubuntu-release-upgrader
Symptom: dist-upgrade
UpgradeStatus: No upgrade log present (probably fresh install)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntu-release-upgrader Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2019-07-25
Last query:
2019-07-25
Last reply:
2019-07-25
Chris Guiver (guiverc) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker.

We understand the difficulties you are facing, but it is better to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. You can also find help with your problem in the support forum of your local Ubuntu community http://loco.ubuntu.com/ or asking at https://askubuntu.com or https://ubuntuforums.org.

For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs.

You've asked for help, bug reports are primarily about fixing the issue (for future users) where I'd be marking it as incomplete as you've provided little detail. Questions instead are about helping you right now (and dealing with future users later if it's decided to be a bug that will impact future users too).

Manish Pathak (srthere) said : #2

when i am running sudo apt-get upgrade
then it says that update-manager and update-notifier is creating problems.

Manfred Hampl (m-hampl) said : #3

For diagnostic purposes please provide the output that you receive for the following commands (to be executed in a terminal window):

uname -a
lsb_release -crid
apt-cache policy update-manager
sudo dpkg --audit
sudo apt update
sudo apt dist-upgrade

Manish Pathak (srthere) said : #4

Below are the outputs for the commands that you have asked for.... @Manfred

1)Linux srthere 4.18.0-25-generic #26~18.04.1-Ubuntu SMP Thu Jun 27 07:28:31 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

2)Distributor ID: Ubuntu
Description: Ubuntu 18.04.2 LTS
Release: 18.04
Codename: bionic

3)update-manager:
  Installed: 1:18.04.11.10
  Candidate: 1:18.04.11.10
  Version table:
 *** 1:18.04.11.10 500
        500 http://in.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        500 http://in.archive.ubuntu.com/ubuntu bionic-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:18.04.11 500
        500 http://in.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        500 http://in.archive.ubuntu.com/ubuntu bionic/main i386 Packages

4)The following packages are in a mess due to serious problems during
installation. They must be reinstalled for them (and any packages
that depend on them) to function properly:
 update-manager GNOME application that manages apt updates

The following packages have been unpacked but not yet configured.
They must be configured using dpkg --configure or the configure
menu option in dselect for them to work:
 update-notifier Daemon which notifies about package updates

5)Hit:1 http://archive.ubuntu.com/ubuntu bionic InRelease
Ign:2 http://ppa.launchpad.net/damien-moore/codeblocks-stable/ubuntu bionic InRelease
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:4 http://ppa.launchpad.net/webupd8team/atom/ubuntu bionic InRelease
Hit:5 http://dl.google.com/linux/chrome/deb stable Release
Err:6 http://ppa.launchpad.net/damien-moore/codeblocks-stable/ubuntu bionic Release
  404 Not Found [IP: 91.189.95.83 80]
Get:8 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]
Hit:9 http://in.archive.ubuntu.com/ubuntu bionic InRelease
Hit:10 http://in.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:11 http://in.archive.ubuntu.com/ubuntu bionic-backports InRelease
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/damien-moore/codeblocks-stable/ubuntu bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

6)Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 0 B/551 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
dpkg: error processing package update-manager (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration
dpkg: dependency problems prevent configuration of update-notifier:
 update-notifier depends on update-manager-gnome | update-manager (>= 1:17.04.3); however:
  Package update-manager-gnome is not installed.
  Package update-manager is not configured yet.

dpkg: error processing package update-notifier (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 update-manager
 update-notifier
E: Sub-process /usr/bin/dpkg returned an error code (1)

Manfred Hampl (m-hampl) said : #5

1st problem:
E: The repository '...damien-moore/codeblocks-stable...' does not have a Release file.

The PPA damien-moore/codeblocks-stable does not provide any software for the Ubuntu release that you are running. To get rid of this error message you have to remove ppa:damien-moore/codeblocks-stable from your list of repositories.

The exact command to be executed can be given based on the output of the command

grep damien-moore /etc/apt/sources.list /etc/apt/sources.list.d/*.list

2nd problem:
The package update-manager is in a very bad inconsistent state

The propsed solution is reinstalling that package with the command

sudo apt install --reinstall update-manager

Manish Pathak (srthere) said : #6

This is the output of the first command .....
/etc/apt/sources.list.d/damien-moore-ubuntu-codeblocks-stable-bionic.list:deb http://ppa.launchpad.net/damien-moore/codeblocks-stable/ubuntu bionic main
/etc/apt/sources.list.d/damien-moore-ubuntu-codeblocks-stable-bionic.list:# deb-src http://ppa.launchpad.net/damien-moore/codeblocks-stable/ubuntu bionic main

Best Manfred Hampl (m-hampl) said : #7

To remove the references to the obsolete PPA issue the command

sudo rm /etc/apt/sources.list.d/damien-moore-ubuntu-codeblocks-stable-bionic.list

Manish Pathak (srthere) said : #10

Thanks Manfred Hampl, that solved my question.

Manfred Hampl (m-hampl) said : #11

If nothing and nobody interferes with the package management system, then a situation "packages are in a mess due to serious problems" should never occur.
What might have happened, is a system crash during installation/upgrade, or an unexpected modification or deletion of files belonging to that package.

A problem of the kind "E: The repository '...' does not have a Release file" will happen after an Ubuntu release upgrade, when you have a PPA enabled which does not provide packages for the new Ubuntu release.

Manish Pathak (srthere) said : #12

Ok!! Great .. Thanks a lot again...