After installing an update , loose my Desktop directory.

Asked by Divyank Deshpande on 2019-05-31

I have just installed an update from Software Updater , after installing i have rebooted my system, but my Desktop directory is not there and also all data in my user directory i am seeing on GUI Screen( Desktop), let me know why this happened and how i can recover my data on Desktop.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubuntu-release-upgrader-core 1:18.04.33
ProcVersionSignature: Ubuntu 4.15.0-50.54-generic 4.15.18
Uname: Linux 4.15.0-50-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.6
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: ubuntu:GNOME
Date: Fri May 31 10:23:00 2019
InstallationDate: Installed on 2018-10-03 (239 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_IN
 SHELL=/bin/bash
SourcePackage: ubuntu-release-upgrader
Symptom: ubuntu-release-upgrader
UpgradeStatus: No upgrade log present (probably fresh install)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ubuntu-release-upgrader Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2019-06-11
Last query:
2019-06-11
Last reply:
2019-06-11
Brian Murray (brian-murray) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We understand the difficulties you are facing, but it is better to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. You can also find help posting your problem in the support forum of your local Ubuntu's community http://loco.ubuntu.com/ or asking at http://askubuntu.com. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs.

If you log on as guest is it OK there?

Divyank Deshpande (divyankd) said : #3

Ubuntu 18.04 does not allow guest login right ?
Do you want me to switch to lightdm then try ?

Yes it does allow guest. Log off then log in as guest

Divyank Deshpande (divyankd) said : #5

I have tried it , i don't see an option for guest log in. I can only see existing user option for log in.

Divyank Deshpande (divyankd) said : #6

I have tried it , i don't see an option for guest log in. I can only see existing user option for log in.

Manfred Hampl (m-hampl) said : #7

If you log in with your normal user and open a terminal window, what output do you receive for the commands

whoami
uname -a
lsb_release -crid
ls -l /home
ls -l /home/`whoami`

Divyank Deshpande (divyankd) said : #8

It prints the output as fololws:
divyank@divyank-B250M-D3H:~/test$ whoami
divyank
divyank@divyank-B250M-D3H:~/test$ uname -a
Linux divyank-B250M-D3H 4.15.0-51-generic #55-Ubuntu SMP Wed May 15 14:27:21 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
divyank@divyank-B250M-D3H:~/test$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 18.04.2 LTS
Release: 18.04
Codename: bionic
divyank@divyank-B250M-D3H:~/test$ ls -l /home
total 4
drwxr-xr-x 23 divyank divyank 4096 Jun 10 18:00 divyank
divyank@divyank-B250M-D3H:~/test$ ls -l /home/`whoami`
total 64
drwxrwxr-x 4 divyank divyank 4096 Jun 10 18:00 data
drwxr-xr-x 3 divyank divyank 4096 Feb 6 13:00 Documents
drwxr-xr-x 2 divyank divyank 4096 Jun 1 13:23 Downloads
-rw-r--r-- 1 divyank divyank 8980 Oct 3 2018 examples.desktop
-rw-r--r-- 1 divyank divyank 11037 Jun 8 16:16 hash_table.c
drwxr-xr-x 2 divyank divyank 4096 Oct 3 2018 Music
drwxr-xr-x 2 divyank divyank 4096 Jun 8 18:15 Pictures
drwxr-xr-x 2 divyank divyank 4096 Oct 3 2018 Public
drwxr-xr-x 7 divyank divyank 4096 Apr 26 09:52 snap
drwxr-xr-x 2 divyank divyank 4096 Oct 3 2018 Templates
drwxr-xr-x 2 divyank divyank 4096 Jun 10 17:58 test
drwxr-xr-x 2 divyank divyank 4096 Oct 3 2018 Videos
divyank@divyank-B250M-D3H:~/test$

Manfred Hampl (m-hampl) said : #9

The home directory is there and there are some subdirectories shown below your home directory.
Are they all empty?

Divyank Deshpande (divyankd) said : #10

Only "Videos" directory is empty.

Manfred Hampl (m-hampl) said : #11

So are your files there (except those in the Videos subdirectory)?

Divyank Deshpande (divyankd) said : #12

Yes those are there, but files and folders which i had in my desktop directory those are not there, Desktop directory is missing.

Best Manfred Hampl (m-hampl) said : #13

Have you looked in the trash folder whether you inadvertently have deleted that directory ?

Command to list the contents of the wastebasket:
gio list trash://

Divyank Deshpande (divyankd) said : #14

Yes i found it there , Thank you for the response, and i am sorry it was my mistake.

Divyank Deshpande (divyankd) said : #15

Thanks Manfred Hampl, that solved my question.